OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : BGP-VPLS Service Mapping Configuration
BGP-VPLS Service Mapping Configuration
Overview
This chapter includes step-by-step configurations for BGP VPLS. It also contains an overview of the concepts of BGP VPLS. Virtual Private LAN Service (VPLS) is a way to provide Ethernet-based multipoint-to-multipoint communication over IP- MPLS networks. It allows geographically-dispersed sites to share an Ethernet broadcast domain by connecting sites through pseudowires
Topology
The diagram depicts the topology for the configuration examples that follow.
BGP-VPLS service mapping
Configuration
PE1: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 21.21.21.21/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
PE1: Interface Configuration
 
(config)#interface xe2
Enter the Interface mode for xe2.
(config-if)# ip address 10.10.23.21/24
Configure IP address on the interface.
(config-if)#enable-rsvp
Enable RSVP on the physical interface
(config-if)# label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
PE1: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#ospf router-id 21.21.21.21
Router-id configurations
(config-router)#network 21.21.21.21/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 10.10.23.0/24 area 0
Advertise network address in OSPF.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
PE1: Global RSVP
 
(config)#router rsvp
Enter the Router OSPF mode.
(config-router)#exit
Exit Router RSVP mode and return to Configure mode.
PE1: RSVP-Trunk Configuration
 
(config)#rsvp-trunk 1
Enter the Trunk configuration mode
(config-trunk)#to 23.23.23.23
Configure the destination of the Trunk
(config-trunk)#exit
Exit.Trunk configuration mode
PE1: BGP Configuration
 
(config)# router bgp 100
Enter the BGP configuration mode.
(config-router)#neighbor 23.23.23.23 remote-as 100
Configure neighbor
(config-router)#neighbor 23.23.23.23 update-source 21.21.21.21
Update loopback address as source
(config-router)#address-family l2vpn vpls
Enter address family mode.
(config-router-af)#neighbor 23.23.23.23 activate
Activate the neighbor.
(config-router-af)#exit
Exit address family mode.
(config-router)#exit
Exit Router BGP mode
PE1: BGP VPLS Configuration
 
(config)#mpls vpls v1 25
Enter VPLS config mode
(config)#service-tpid dot1.ad
Service tp-id configuration.
(config-vpls)#signaling bgp
Define Signaling as BGP
(config-vpls-sig)#ve-id 1
Configure VE-ID
(config-vpls-sig)#exit
Exit Signaling BGP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v2 26
Enter VPLS config mode
(config)#service-tpid dot1.ad
Service tp-id configuration.
(config-vpls)#signaling bgp
Define Signaling as BGP
(config-vpls-sig)#ve-id 1
Configure VE-ID
(config-vpls-sig)#exit
Exit Signaling BGP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v3 27
Enter VPLS config mode
(config-vpls)#signaling bgp
Define Signaling as BGP
(config-vpls-sig)#ve-id 1
Configure VE-ID
(config-vpls-sig)#exit
Exit Signaling BGP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v4 28
Enter VPLS config mode
(config-vpls)#signaling bgp
Define Signaling as BGP
(config-vpls-sig)#ve-id 1
Configure VE-ID
(config-vpls-sig)#exit
Exit Signaling BGP mode
(config-vpls)#exit
Exit VPLS mode
(config)#commit
Commit candidate configuration to running configuration
P1: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 22.22.22.22/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
P1: Interface Configuration
 
(config)#interface xe1
Enter the Interface mode for xe1
(config-if)#ip address 10.10.23.22/24
Configure IP address on the interface.
(config-if)#enable-rsvp
Enable RSVP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe2
Enter the Interface mode for xe2
(config-if)#ip address 10.10.21.22/24
Configure IP address on the interface.
(config-if)#enable-rsvp
Enable RSVP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
P1: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#network 22.22.22.22/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 10.10.23.0/24 area 0
Advertise network address in OSPF.
(config-router)#network 10.10.21.0/24 area 0
Advertise network address in OSPF.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
P1: Global RSVP
 
(config)#router rsvp
Enter the Router OSPF mode.
(config-router)#exit
Exit Router RSVP mode and return to Configure mode.
(config)#commit
Commit candidate configuration to running configuration
PE2: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 23.23.23.23/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
PE2: Interface Configuration
 
(config)#interface xe1
Enter the Interface mode for xe1
(config-if)#ip address 10.10.21.23/24
Configure IP address on the interface.
(config-if)#enable-rsvp
Enable RSVP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
PE2: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#network 23.23.23.23/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 10.10.21.0/24 area 0
Advertise network address in OSPF.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
PE2: Global RSVP
 
(config)#router rsvp
Enter the Router OSPF mode.
(config-router)#exit
Exit Router RSVP mode and return to Configure mode.
PE2: RSVP-Trunk Configuration
 
(config)#rsvp-trunk 1
Enter the Trunk configuration mode
(config-trunk)#to 21.21.21.21
Configure the destination of the Trunk
(config-trunk)#exit
Exit.Trunk configuration mode
PE2: BGP Configuration
 
(config)# router bgp 100
Enter the BGP configuration mode.
(config-router)#neighbor 21.21.21.21 remote-as 100
Configure neighbor
(config-router)#neighbor 21.21.21.21 update-source 23.23.23.23
Update loopback address as source
(config-router)#address-family l2vpn vpls
Enter address family mode.
(config-router-af)#neighbor 21.21.21.21 activate
Activate the neighbor.
(config-router-af)#exit
Exit address family mode.
(config-router)#exit
Exit Router BGP mode
PE2: BGP VPLS Configuration
 
(config)#mpls vpls v1 25
Enter VPLS config mode
(config)#service-tpid dot1.ad
Service tp-id configuration.
(config-vpls)#signaling bgp
Define Signaling as BGP
(config-vpls-sig)#ve-id 2
Configure VE-ID
(config-vpls-sig)#exit
Exit Signaling BGP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v2 26
Enter VPLS config mode
(config)#service-tpid dot1.ad
Service tp-id configuration.
(config-vpls)#signaling bgp
Define Signaling as BGP
(config-vpls-sig)#ve-id 2
Configure VE-ID
(config-vpls-sig)#exit
Exit Signaling BGP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v3 27
Enter VPLS config mode
(config-vpls)#signaling bgp
Define Signaling as BGP
(config-vpls-sig)#ve-id 2
Configure VE-ID
(config-vpls-sig)#exit
Exit Signaling BGP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v4 28
Enter VPLS config mode
(config-vpls)#signaling bgp
Define Signaling as BGP
(config-vpls-sig)#ve-id 2
Configure VE-ID
(config-vpls-sig)#exit
Exit Signaling BGP mode
(config-vpls)#exit
Exit VPLS mode
(config)#commit
Commit candidate configuration to running configuration
BGP VPLS Service Mapping Configuration
PE1: POP
 
(config)#configure terminal
Configure mode
(config)#service-template template1
Template configuration
(config-svc)# match double-tag outer-vlan 2024 inner-vlan 2023
Match criteria under template configuration
(config-svc)# rewrite ingress pop outgoing-tpid dot1.q
Action to be performed for the match.
(config-svc)#exit
Exit template configuration mode
PE1: XLATE
 
(config)#service-template template2
Template configuration
(config-svc)# match double-tag outer-vlan 2030 inner-vlan 2024
Match criteria under template configuration
(config-svc)# rewrite ingress translate 2026 outgoing-tpid dot1.q
Action to be performed for the match
(config-svc)#exit
Exit template configuration mode
PE1: PUSH
 
(config)#service-template template3
Template configuration
(config-svc)# match outer-vlan 500
Match criteria under template configuration
(config-svc)# rewrite ingress push 300
Action to be performed for the default match.
(config-svc)#exit
Exit template configuration mode
PE1: PUSH-service-template with multiple match
This is to validate the multiple match criteria support in a service template. When multiple match statements are configured only rewrite push is supported, rewrite translate and pop are not supported.
 
(config)#service-template template4
Template configuration
(config-svc)# match outer-vlan 700
Allow VLAN 700 traffic on this VC
(config-svc)# match double-tag outer-vlan 1200 inner-vlan 3200
Allow double tag match with s+c tags
(config-svc)# match untagged
Allow untagged traffic
(config-svc)# rewrite ingress push 300
Push Action performed for service template
(config-svc)#exit
Exit configure SVC mode
PE1: Access port Configuration
 
(config)#interface xe1
Enter the Interface mode for xe1.
(config-if)switchport
Configure interface as L2 interface
(config-if)#mpls-vpls v1 service-template template1
Bind the VPLS to the Access Interface.
(config-if-vpls)no ac-admin-status
Making Ac-admin-status Up
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v2 service-template template2
Bind the VPLS to the Access Interface.
(config-if-vpls)no ac-admin-status
Making Ac-admin-status Up
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v3 service-template template3
Bind the VPLS to the Access Interface.
(config-if-vpls)#no ac-admin-statusv
Making Ac-admin-status Up
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v4 service-template template4
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#no ac-admin-status
Making Ac-admin-status Up
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit candidate configuration to running configuration
PE2: POP
 
(config)#configure terminal
Configure mode
(config)#service-template template1
Template configuration
(config-svc)# match double-tag outer-vlan 2024 inner-vlan 2023
Match criteria under template configuration
(config-svc)# rewrite ingress pop outgoing-tpid dot1.ad
Action to be performed for the match.
(config-svc)#exit
Exit template configuration mode
PE2: XLATE
 
(config)#service-template template2
Template configuration
(config-svc)# match double-tag outer-vlan 2030 inner-vlan 2024
Match criteria under template configuration
(config-svc)# rewrite ingress translate 2026 outgoing-tpid dot1.q
Action to be performed for the match
(config-svc)#exit
Exit template configuration mode
PE2: PUSH
 
(config)#service-template template3
Template configuration
(config-svc)# match outer-vlan 500
Match criteria under template configuration
(config-svc)# rewrite ingress push 300
Action to be performed for the default match.
(config-svc)#exit
Exit template configuration mode
PE2: PUSH-service-template with multiple match
This is to validate the multiple match criteria support in a service template. When multiple match statements are configured only rewrite push is supported, rewrite translate and pop are not supported.
 
(config)#service-template template4
Template configuration
(config-svc)# match outer-vlan 700
Allow VLAN 700 traffic on this VC
(config-svc)# match double-tag outer-vlan 1200 inner-vlan 3200
Allow double tag match with s+c tags
(config-svc)# match untagged
Allow untagged traffic
(config-svc)# rewrite ingress push 300
Push Action performed for service template
(config-svc)#exit
Exit configure SVC mode
PE2: Access port Configuration
 
(config)#interface eth2
Enter the Interface mode for ethernet1.
(config-if)switchport
Configure interface as L2 interface
(config-if)#mpls-vpls v1 service-template template1
Bind the VPLS to the Access Interface.
(config-if-vpls)#no ac-admin-status
Making admin status up
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v2 service-template template2
Bind the VPLS to the Access Interface.
(config-if-vpls)#no ac-admin-status
Making admin status up
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v3 service-template template3
Bind the VPLS to the Access Interface.
(config-if-vpls)#no ac-admin-status
Making admin status up
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v4 service-template template4
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#no ac-admin-status
Making Ac-admin-status Up
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit candidate configuration to running configuration
Validation
PE1
PE1#show bgp l2vpn vpls
VPLS-ID VE-ID Discovered-Peers Route-Target
25 1 1 100:25
26 1 1 100:26
27 1 1 100:27
28 1 1 100:28
 
PE1#show bgp l2vpn vpls detail
 
VPLS ID: 25
VE-ID: 1
Discovered Peers: 1
Route-Target: 100:25
Local RD: 100:25
Mesh Peers:
Address:23.23.23.23, RD:100:25, VE-ID:2
VC Details: VC-ID:12
Remote (LB:25216,VBO:1,VBS:64) Local (LB:26240,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:26241, Out Label:25216
PW Status:Established
VC Installed:Yes
 
 
VPLS ID: 26
VE-ID: 1
Discovered Peers: 1
Route-Target: 100:26
Local RD: 100:26
Mesh Peers:
Address:23.23.23.23, RD:100:26, VE-ID:2
VC Details: VC-ID:12
Remote (LB:25280,VBO:1,VBS:64) Local (LB:26304,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:26305, Out Label:25280
PW Status:Established
VC Installed:Yes
 
 
VPLS ID: 27
VE-ID: 1
Discovered Peers: 1
Route-Target: 100:27
Local RD: 100:27
Mesh Peers:
Address:23.23.23.23, RD:100:27, VE-ID:2
VC Details: VC-ID:12
Remote (LB:25344,VBO:1,VBS:64) Local (LB:26368,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:26369, Out Label:25344
PW Status:Established
VC Installed:Yes
 
 
VPLS ID: 28
VE-ID: 1
Discovered Peers: 1
Route-Target: 100:28
Local RD: 100:28
Mesh Peers:
Address:23.23.23.23, RD:100:28, VE-ID:2
VC Details: VC-ID:12
Remote (LB:25408,VBO:1,VBS:64) Local (LB:26432,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:26433, Out Label:25408
PW Status:Established
VC Installed:Yes
 
PE1#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label
Lkps/St PW-INDEX SIG-Protocol Status
25 23.23.23.23 25601 26241 xe2 25216
2/Up 1 BGP Active
26 23.23.23.23 25601 26305 xe2 25280
2/Up 3 BGP Active
27 23.23.23.23 25601 26369 xe2 25344
2/Up 2 BGP Active
28 23.23.23.23 25601 26433 xe2 25408
2/Up 4 BGP Active
 
 
PE2:
 
 
PE1#show bgp l2vpn vpls
VPLS-ID VE-ID Discovered-Peers Route-Target
25 2 1 100:25
26 2 1 100:26
27 2 1 100:27
28 2 1 100:28
 
PE1#show bgp l2vpn vpls detail
 
VPLS ID: 25
VE-ID: 2
Discovered Peers: 1
Route-Target: 100:25
Local RD: 100:25
Mesh Peers:
Address:21.21.21.21, RD:100:25, VE-ID:1
VC Details: VC-ID:21
Remote (LB:26240,VBO:1,VBS:64) Local (LB:25216,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25216, Out Label:26241
PW Status:Established
VC Installed:Yes
All Local LB:
LB:25216,VBO:1,VBS:64
 
 
VPLS ID: 26
VE-ID: 2
Discovered Peers: 1
Route-Target: 100:26
Local RD: 100:26
Mesh Peers:
Address:21.21.21.21, RD:100:26, VE-ID:1
VC Details: VC-ID:21
Remote (LB:26304,VBO:1,VBS:64) Local (LB:25280,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25280, Out Label:26305
PW Status:Established
VC Installed:Yes
All Local LB:
LB:25280,VBO:1,VBS:64
 
 
VPLS ID: 27
VE-ID: 2
Discovered Peers: 1
Route-Target: 100:27
Local RD: 100:27
Mesh Peers:
Address:21.21.21.21, RD:100:27, VE-ID:1
VC Details: VC-ID:21
Remote (LB:26368,VBO:1,VBS:64) Local (LB:25344,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25344, Out Label:26369
PW Status:Established
VC Installed:Yes
All Local LB:
LB:25344,VBO:1,VBS:64
 
 
VPLS ID: 28
VE-ID: 2
Discovered Peers: 1
Route-Target: 100:28
Local RD: 100:28
Mesh Peers:
Address:21.21.21.21, RD:100:28, VE-ID:1
VC Details: VC-ID:21
Remote (LB:26432,VBO:1,VBS:64) Local (LB:25408,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25408, Out Label:26433
PW Status:Established
VC Installed:Yes
All Local LB:
LB:25408,VBO:1,VBS:64
 
 
PE1#show mpls vpls mesh
(m) - Service mapped over multipath transport
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label
Lkps/St PW-INDEX SIG-Protocol Status
25 21.21.21.21 25600 25216 xe1 26241
2/Up 1 BGP Active
26 21.21.21.21 25600 25280 xe1 26305
2/Up 3 BGP Active
27 21.21.21.21 25600 25344 xe1 26369
2/Up 2 BGP Active
28 21.21.21.21 25600 25408 xe1 26433
2/Up 4 BGP Active
 
PE1#show mpls vpls detail
Virtual Private LAN Service Instance: v1, ID: 25
SIG-Protocol: BGP
Route-Distinguisher :100:25
Route-Target :100:25
VE-ID :2
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.ad
Operating mode: Raw
Configured interfaces:
Interface: xe9
Service-template : template1
Match criteria : 2024/2023
Action type : Pop
Outgoing tpid : dot1.q
 
Mesh Peers:
21.21.21.21 (Up)
 
 
Virtual Private LAN Service Instance: v2, ID: 26
SIG-Protocol: BGP
Route-Distinguisher :100:26
Route-Target :100:26
VE-ID :2
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.ad
Operating mode: Raw
Configured interfaces:
Interface: xe9
Service-template : template2
Match criteria : 2030/2024
Action type : Translate
Action value : 2026
Outgoing tpid : dot1.q
 
Mesh Peers:
21.21.21.21 (Up)
 
 
Virtual Private LAN Service Instance: v3, ID: 27
SIG-Protocol: BGP
Route-Distinguisher :100:27
Route-Target :100:27
VE-ID :2
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe9
Service-template : template3
Match criteria : 500
Action type : Push
Action value : 300
 
Mesh Peers:
21.21.21.21 (Up)
 
 
Virtual Private LAN Service Instance: v4, ID: 28
SIG-Protocol: BGP
Route-Distinguisher :100:28
Route-Target :100:28
VE-ID :2
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe9
Service-template : template4
Match criteria : 700,
Untagged ,
1200/3200
Action type : Push
Action value : 300
 
Mesh Peers:
21.21.21.21 (Up)