OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : BGP-VPLS Configuration
BGP-VPLS Configuration
This chapter contains configurations for VPLS with Border Gateway Protocol Signaling.
Overview
Virtual Private LAN Service (VPLS) is a way to provide Ethernet-based multipoint-to-multipoint communication over IP/MPLS networks. It allows geographically-dispersed sites to share an Ethernet broadcast domain by connecting sites through pseudowires. A set of Kompella circuits is grouped by a common VPLS identifier to achieve this service objective.
A Pseudowire (PW) consists of a pair of point-to-point, single-hop unidirectional LSPs in opposite directions, each identified by a PW label, also called a Virtual Connection (VC) label.
The Border Gateway Protocol (BGP) is used to signaling VCs and for auto-discovery of neighbors. A service provider may use either LDP or RSVP-TE or add static provisioning to set up LSP tunnels to transport data through virtual circuits.
The VPLS identifier is exchanged with the labels, so that both PWs can be linked and associated with a particular VPLS instance.
Note: In Inter-AS, OcNOS accepts information from any other AS but the same VPN-ID/VPLS-ID ( *: VPLS-ID). OcNOS does not have explicit RD/RT (import/export) support for BGP VPLS. RD/RT are automatically generated based on the configured BGP AS number and VPN-ID/VPLS-ID as (AS-number: VPN-ID).
Topology
The diagram depicts the topology for the configuration examples that follow.
Sample Topology for VPLS with BGP Signaling
BGP-VPLS Configuration
PE-1
 
#configure terminal
Enter configuration mode.
(config)#interface xe1
Specify the interface (xe1) to be configured.
(config-if)#ip address 10.10.1.1/24
Set the IP address of the interface to 10.10.1.1/24.
(config-if)#label-switching
Enable label switching on interface xe1.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Specify the loopback address.
(config-if)#ip address 1.1.1.1/32 secondary
Set the IP address of the loopback interface to 1.1.1.1/32.
(config-if)#exit
Exit interface mode
(config)#mpls vpls v1 25
Create an instance of VPLS, and switch to the VPLS command mode, by specifying the VPLS name (v1) and VPLS ID (25).
(config-vpls)#vpls-mtu 1400
Configure the MTU for the VPLS. (Default is 1500; range is <576 - 65535>.
(config-vpls)#signaling bgp
Enter the Signaling bgp mode for BGP VPLS.
(config-vpls-sig)#ve-id 1
Configure VE ID, which is mandatory for BGP VPLS, otherwise, Signaling does not take place. VE ID should be unique per VPLS instance.
(config-vpls-sig)#exit
Exit is a mandatory command for signaling BGP configuration to take affect. If exit is not given BGP signaling does not take place.
(config-vpls)#exit
Exit VPLS mode.
(config)#service-template v1
Configure service template
(config-svc)#match all
Configure the match condition
(config-svc)#exit
Exit interface mode
(config)#interface xe3
Specify the interface (xe3) to be configured.
(config-if)#switchport
Switch to Layer-2 mode. (VPLS can be bound only on the Layer-2 port.)
(config-if)#mpls-vpls v1 service-template v1
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#commit
Commit the transaction.
Note: VE IDs range is from 1 to 64. Administrator should configure the VE ID’s accordingly in their Network.
PE1 - LDP
 
#configure terminal
Enter configuration mode
(config)#router ldp
Enter Router LDP mode.
(config-router)#router-id 1.1.1.1
Configure the router ID.
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address for a label space by binding the address to a loopback address.
(config-router)#exit
Exit Router mode.
(config)#interface xe1
Specify the interface (xe1) to be configured.
(config-if)#enable-ldp ipv4
Enable LDP on interface xe1.
(config-if)#commit
Commit the transaction.
PE1 - OSPF
 
#configure terminal
Enter configure mode
(config)#router ospf 1
Configure the OSPF routing process, and specify the process ID.
(config-router)#network 10.10.1.0/24 area 0
 
Define the interfaces on which OSPF runs, and specify the backbone area 0.
(config-router)#network 1.1.1.1/32 area 0
(config-router)#commit
Commit the transaction.
PE1 - BGP
 
#configure terminal
Enter configuration mode.
(config)#router bgp 100
Enter BGP Configure mode.
(config-router)#neighbor 2.2.2.2 remote-as 100
Configure PE2 as an iBGP peer.
(config-router)#neighbor 2.2.2.2 update-source lo
Update the source as loopback for iBGP peering with the remote PE2 router.
(config-router)#neighbor 3.3.3.3 remote-as 100
Configure PE3 as an iBGP peer.
(config-router)#neighbor 3.3.3.3 update-source lo
Update the source as loopback for iBGP peering with the remote PE3 router
(config-router)#address-family l2vpn vpls
Configure address-family L2VPN VPLS.
(config-router-af)#neighbor 2.2.2.2 activate
Activate PE2 in the VPLS address family.
(config-router-af)#neighbor 3.3.3.3 activate
Activate PE3 in the VPLS address family.
(config-router-af)#commit
Commit the transaction.
PE2
 
#configure terminal
Enter configuration mode.
(config)#interface xe3
Specify the interface (xe3 to be configured.
(config-if)#ip address 20.20.1.3/24
Set the IP address of the interface to 20.20.1.3/24.
(config-if)#label-switching
Enable label switching on interface xe3.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Specify the loopback address.
(config-if)#ip address 2.2.2.2/32 secondary
Set the IP address of the loopback interface to 2.2.2.2/32.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls v1 25
Create an instance of VPLS, and switch to the VPLS command mode, by specifying the VPLS name (v1) and VPLS ID (25).
(config-vpls)#vpls-mtu 1400
Configure the MTU for the VPLS. (Default is 1500; range is <576 - 65535>.)
(config-vpls)#signaling bgp
Enter the Signaling BGP mode for BGP VPLS.
(config-vpls-sig)#ve-id 2
Configure ve-id, which is mandatory for BGP VPLS. Without a ve-id Signaling does not take place. VE ID should be unique per VPLS instance.
(config-vpls-sig)#exit
Exit is a mandatory command for signaling BGP configuration to take affect. If exit is done, BGP signaling does not take place.
(config-vpls)#exit
Exit VPLS mode.
(config)#service-template v1
Configure service template
(config-svc)#match all
Configure the match condition
(config-svc)#exit
Exit interface mode
(config)#interface xe1
Specify the interface (xe1) to be configured.
(config-if)#switchport
Switch to Layer-2 mode. (VPLS can only be bound on the Layer-2 port.)
(config-if)#mpls-vpls v1 service-template v1
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#commit
Commit the transaction.
Note: VE ID’s range is from 1 to 64. Administrator should configure the VE ID’s accordingly in their Network.
PE2 - LDP
 
#configure terminal
Enter configuration mode
(config)#router ldp
Enter Router LDP mode.
(config-router)#router-id 2.2.2.2
Configure the router ID.
(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address for a label space by binding the address to a loopback address.
(config-router)#exit
Exit Router mode.
(config)#interface xe3
Specify the interface (xe3) to be configured.
(config-if)#enable-ldp ipv4
Enable LDP on the specified interface (xe3).
(config-if)#commit
Commit the transaction.
PE2 - OSPF
 
#configure terminal
Enter configuration mode.
(config)#router ospf 1
Configure the OSPF routing process, and specify the process ID.
(config-router)#network 20.20.1.0/24 area 0
Define the interfaces on which OSPF runs, and specify the backbone area 0.
(config-router)#network 2.2.2.2/32 area 0
(config-router)#commit
Commit the transaction.
PE2 - BGP
 
#configure terminal
Enter configuration mode.
(config)#router bgp 100
Enter BGP router mode.
(config-router)#neighbor 1.1.1.1 remote-as 100
Configure PE1 as an iBGP peer.
(config-router)#neighbor 1.1.1.1 update-source lo
Update the source as loopback for iBGP peering with the remote PE1 router.
(config-router)#neighbor 3.3.3.3 remote-as 100
Configure PE3 as an iBGP peer.
(config-router)#neighbor 3.3.3.3 update-source lo
Update the source as loopback for iBGP peering with the remote PE3 router.
(config-router)#address-family l2vpn vpls
Configure address-family L2VPN VPLS.
(config-router-af)#neighbor 1.1.1.1 activate
Activate PE1 in the VPLS address family.
(config-router-af)#neighbor 3.3.3.3 activate
Activate PE3 in the VPLS address family.
(config-router-af)#commit
Commit the transaction.
PE3
 
#configure terminal
Enter configuration mode.
(config)#interface xe3
Specify the interface (xe3)to be configured.
(config-if)#ip address 40.40.1.5/24
Set the IP address of the interface to 40.40.1.5/24.
(config-if)#label-switching
Enable label switching on interface xe3.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Specify the loopback address.
(config-if)#ip address 3.3.3.3/32 secondary
Set the IP address of the loopback interface to 3.3.3.3/32.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls v1 25
Create an instance of VPLS, and switch to the VPLS command mode, by indicating the VPLS name (v1) and VPLS ID (25).
(config-vpls)#vpls-mtu 1400
Configure the MTU for the VPLS. Default is 1500; range is <576 - 65535>.
(config-vpls)#signaling bgp
Enter the Signaling BGP mode, for BGP VPLS.
(config-vpls-sig)#ve-id 3
Configure ve-id, which is mandatory for BGP VPLS. Without a ve-id Signaling does not take place. VE ID should be unique per VPLS instance
(config-vpls-sig)#exit
Exit is a mandatory command for signaling BGP configuration to take affect. If exit is not done, BGP signaling does not take place.
(config-vpls)#exit
Exit VPLS mode.
(config)#service-template v1
Configure service template
(config-svc)#match all
Configure the match condition
(config-svc)#exit
Exit interface mode
(config)#interface xe6
Specify the interface (xe6) to be configured.
(config-if)#switchport
Switch to Layer-2 mode. (VPLS can be bound only on the Layer-2 port.)
(config-if)#mpls-vpls v1 service-template v1
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#commit
Commit the transaction.
Note: VE ID’s range is from 1 to 64. Administrator should configure the VE ID’s accordingly in their Network.
PE3 - LDP
 
#configure terminal
Enter configuration mode.
(config)#router ldp
Enter Router LDP mode.
(config-router)#router-id 3.3.3.3
Configure the router ID.
(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address for a label space by binding the address to a loopback address.
(config-router)#exit
Exit Router mode.
(config)#interface xe3
Specify the interface (xe3) to be configured.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#commit
Commit the transaction.
PE3 - OSPF
 
#configure terminal
Enter configuration mode.
(config)#router ospf 1
Configure the OSPF routing process, and specify the process ID.
(config-router)#network 40.40.1.0/24 area 0
 
Define the interfaces on which OSPF runs, and specify the backbone area 0.
(config-router)#network 3.3.3.3/32 area 0
(config-router)#commit
Commit the transaction.
PE3 - BGP
 
#configure terminal
Enter configuration mode.
(config)#router bgp 100
Enter BGP Router mode.
(config-router)#neighbor 1.1.1.1 remote-as 100
Configure PE1 as an iBGP peer.
(config-router)#neighbor 1.1.1.1 update-source lo
Update the source as loopback for iBGP peering with the remote PE1 router.
(config-router)#neighbor 2.2.2.2 remote-as 100
Configure PE2 as an iBGP peer.
(config-router)#neighbor 2.2.2.2 update-source lo
Update the source as loopback for iBGP peering with the remote PE2 router.
(config-router)#address-family l2vpn vpls
Configure address-family L2VPN VPLS.
(config-router-af)#neighbor 1.1.1.1 activate
Activate PE1 in the VPLS address family.
(config-router-af)#neighbor 2.2.2.2 activate
Activate PE2 in the VPLS address family.
(config-router-af)#commit
Commit the transaction.
P
 
#configure terminal
Enter configuration mode.
(config)#interface xe1
Specify the interface (xe1) to be configured.
(config-if)#ip address 10.10.1.2/24
Set the IP address of the interface to 10.10.1.2/24.
(config-if)#label-switching
Enable label switching on interface xe1.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Specify the interface (xe2) to be configured.
(config-if)#ip address 40.40.1.2/24
Set the IP address of the interface to 40.40.1.2/24.
(config-if)#label-switching
Enable label switching on interface xe2.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Specify the interface (xe3) to be configured.
(config-if)#ip address 20.20.1.2/24
Set the IP address of the loopback interface to 20.20.1.2/24.
(config-if)#label-switching
Enable label switching on interface xe3.
(config-if)#commit
Commit the transaction.
P - LDP
 
#configure terminal
Enter configuration mode.
(config)#router ldp
Enter Router LDP mode.
(config-router)#exit
Exit Router mode.
(config)#interface xe1
Specify the interface (xe1) to be configured.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Specify the interface (xe2) to be configured.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Specify the interface (xe3) to be configured.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#commit
Commit the transaction.
P - OSPF
 
#configure terminal
Enter configuration mode.
(config)#router ospf 1
Configure the OSPF routing process, and specify the process ID.
(config-router)#network 10.10.1.0/24 area 0
 
Define the interfaces on which OSPF runs, and specify the backbone area 0.
(config-router)#network 20.20.1.0/24 area 0
(config-router)#network 40.40.1.0/24 area 0
(config-router)#commit
Commit the transaction.
Note: BGP L2VPN VPLS Route Reflector is not supported.
Validation
PE1
#show mpls vpls detail
Virtual Private LAN Service Instance: v1, ID: 25
SIG-Protocol: BGP
Route-Distinguisher :100:25
Route-Target :100:25
VE-ID :1
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, Configured MTU: 1400
Description: none
Redundancy admin role: Primary Redundancy oper role: Primary
Configured interfaces: Interface: xe3 oper-state UP Service-template : v1 Match criteria : Accept all
 
Mesh Peers:
2.2.2.2 (Up)
3.3.3.3 (Up)
 
#show mpls vpls mesh
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status Ecmp-Group
25 2.2.2.2 3 24969 xe1 26125 2/Up 1298 BGP Active N/A
25 3.3.3.3 24677 24961 xe1 25605 2/Up 1297 BGP Active N/A
 
#show bgp l2vpn vpls detail
VPLS ID: 25
VE-ID: 1
Discovered Peers: 2
Route-Target: 1:100
Local RD: 2:100
Mesh Peers:
Address:2.2.2.2, RD:2:100, VE-ID:2
VC Details: VC-ID:610
Remote (LB:26120,VBO:1,VBS:64) Local (LB:24960,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:24969, Out Label:26125
PW Status:Established
VC Installed:Yes
All Local LB:
LB:24960,VBO:1,VBS:64
 
Address:3.3.3.3, RD:2:100, VE-ID:3
VC Details: VC-ID:62
Remote (LB:25600,VBO:1,VBS:64) Local (LB:24960,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:24961, Out Label:25605
PW Status:Established
VC Installed:Yes
 
#show bgp l2vpn vpls 25
VPLS ID: 25
VE-ID: 1
Discovered Peers: 2
Route-Target: 1:100
Local RD: 2:100
Mesh Peers:
Address:2.2.2.2, RD:2:100, VE-ID:2
VC Details: VC-ID:610
Remote (LB:26120,VBO:1,VBS:64) Local (LB:24960,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:24969, Out Label:26125
PW Status:Established
VC Installed:Yes
All Local LB:
LB:24960,VBO:1,VBS:64
 
Address:3.3.3.3, RD:2:100, VE-ID:3
VC Details: VC-ID:62
Remote (LB:25600,VBO:1,VBS:64) Local (LB:24960,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:24961, Out Label:25605
PW Status:Established
VC Installed:Yes
 
PE2
PE2#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
25 1.1.1.1 25601 25600 xe3 25601 2/Up 1 BGP Active
25 3.3.3.3 25602 25602 xe3 25601 2/Up 2 BGP Active
 
 
PE2#show ldp sess
Peer IP Address IF Name My Role State KeepAlive UpTime
10.10.1.2 xe3 Passive OPERATIONAL 30 00:15:54
 
PE2#show mpls vpls detail
Virtual Private LAN Service Instance: v1, ID: 25
SIG-Protocol: BGP
Route-Distinguisher :100:25
Route-Target :100:25
VE-ID :2
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 1400
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe1
Service-template : v1
Match criteria : Accept all
 
Mesh Peers:
1.1.1.1 (Up)
3.3.3.3 (Up)
 
 
PE2#show bgp l2vpn vpls detail
 
VPLS ID: 25
VE-ID: 2
Discovered Peers: 2
Route-Target: 100:25
Local RD: 100:25
Mesh Peers:
BGP Peer:1.1.1.1/32
VC Nbr Address:1.1.1.1, RD:100:25, VE-ID:1
VC Details: VC-ID:21
Remote (LB:25600,VBO:1,VBS:64) Local (LB:25600,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25600, Out Label:25601
PW Status:Established
VC Installed:Yes
 
BGP Peer:3.3.3.3/32
VC Nbr Address:3.3.3.3, RD:100:25, VE-ID:3
VC Details: VC-ID:23
Remote (LB:25600,VBO:1,VBS:64) Local (LB:25600,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25602, Out Label:25601
PW Status:Established
VC Installed:Yes
 
PE2#show bgp l2vpn vpls 25
 
VPLS ID: 25
VE-ID: 2
Discovered Peers: 2
Route-Target: 100:25
Local RD: 100:25
Mesh Peers:
BGP Peer:1.1.1.1/32
VC Nbr Address:1.1.1.1, RD:100:25, VE-ID:1
VC Details: VC-ID:21
Remote (LB:25600,VBO:1,VBS:64) Local (LB:25600,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25600, Out Label:25601
PW Status:Established
VC Installed:Yes
 
BGP Peer:3.3.3.3/32
VC Nbr Address:3.3.3.3, RD:100:25, VE-ID:3
VC Details: VC-ID:23
Remote (LB:25600,VBO:1,VBS:64) Local (LB:25600,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25602, Out Label:25601
PW Status:Established
VC Installed:Yes
P
P#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe2 Active OPERATIONAL 30 00:11:21
2.2.2.2 xe3 Active OPERATIONAL 30 00:19:05
1.1.1.1 xe1 Active OPERATIONAL 30 00:51:45
PE3
PE3#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
10.10.1.2 xe3 Passive OPERATIONAL 30 00:12:27
 
PE3#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
25 1.1.1.1 25604 25600 xe3 25602 2/Up 1 BGP Active
25 2.2.2.2 25605 25601 xe3 25602 2/Up 2 BGP Active
 
PE3#show mpls vpls detail
Virtual Private LAN Service Instance: v1, ID: 25
SIG-Protocol: BGP
Route-Distinguisher :100:25
Route-Target :100:25
VE-ID :3
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 1400
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe6
Service-template : v1
Match criteria : Accept all
 
Mesh Peers:
1.1.1.1 (Up)
2.2.2.2 (Up)
 
 
PE3#show bgp l2vpn vpls detail
 
VPLS ID: 25
VE-ID: 3
Discovered Peers: 2
Route-Target: 100:25
Local RD: 100:25
Mesh Peers:
BGP Peer:1.1.1.1/32
VC Nbr Address:1.1.1.1, RD:100:25, VE-ID:1
VC Details: VC-ID:31
Remote (LB:25600,VBO:1,VBS:64) Local (LB:25600,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25600, Out Label:25602
PW Status:Established
VC Installed:Yes
All Local LB:
LB:25600,VBO:1,VBS:64
 
BGP Peer:2.2.2.2/32
VC Nbr Address:2.2.2.2, RD:100:25, VE-ID:2
VC Details: VC-ID:32
Remote (LB:25600,VBO:1,VBS:64) Local (LB:25600,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25601, Out Label:25602
PW Status:Established
VC Installed:Yes
All Local LB:
LB:25600,VBO:1,VBS:64
 
PE3#show bgp l2vpn vpls 25
 
VPLS ID: 25
VE-ID: 3
Discovered Peers: 2
Route-Target: 100:25
Local RD: 100:25
Mesh Peers:
BGP Peer:1.1.1.1/32
VC Nbr Address:1.1.1.1, RD:100:25, VE-ID:1
VC Details: VC-ID:31
Remote (LB:25600,VBO:1,VBS:64) Local (LB:25600,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25600, Out Label:25602
PW Status:Established
VC Installed:Yes
All Local LB:
LB:25600,VBO:1,VBS:64
 
BGP Peer:2.2.2.2/32
VC Nbr Address:2.2.2.2, RD:100:25, VE-ID:2
VC Details: VC-ID:32
Remote (LB:25600,VBO:1,VBS:64) Local (LB:25600,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:25601, Out Label:25602
PW Status:Established
VC Installed:Yes
All Local LB:
LB:25600,VBO:1,VBS:64