OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : L2VPN FAT SUPPORT
L2VPN FAT SUPPORT
This chapter contains configurations of L2VPN with FAT support.
This is a functional level test plan scoped for the Flow-Aware Transport (FAT) of pseudowire (PW) over an MPLS packet switched network for load-balancing traffic across LDP-based signaled pseudowire for Virtual Private LAN Services (VPLS) and Virtual Private Wire Service (VPWS).
Topology
 
L2VPN configuration topology
Configuration for VPLS with FAT
PE-1
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 1.1.1.1
Configure Router-id
(config-router)#targeted-peer ipv4 6.6.6.6
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit from targeted-peer mode
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface eth2
Enter interface mode
(config-if)#ip address 10.1.1.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the Process ID, (100). The Process ID should be a unique positive integer to identifying the routing process.
(config-router)#ospf router-id 1.1.1.1
Configure ospf Router-id
(config-router)#network 10.1.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 1.1.1.1/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#mpls vpls vpls100 100
Configuring VPLS instance with name and VPLS ID
PE1(config-vpls)#flow-label both
Configure flow label based on requirement (we have three options both, transit and receive) with dynamic and static.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance
(config-vpls-sig)#vpls-peer 6.6.6.6
Configuring VPLS mesh peers
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config-if)#interface eth2.100 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 100
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls vpls100
Associating the VPLS Instance to the attachment circuit interface.
(config-acc-if-vpls)#commit
Commit the configuration
(config-acc-if-vpls)#end
Return to privilege mode
P1
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 2.2.2.2
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface eth1
Enter interface mode
(config-if)#ip address 10.1.1.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po10
Enter interface mode
(config-if)#ip address 10.1.2.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po30
Enter interface mode
(config-if)#ip address 10.1.3.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#interface eth5
Enter the Interface mode for eth5
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 3.3.3.3
Configure ospf Router-id
(config-router)#network 10.1.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.2.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.4.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 2.2.2.2/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P2
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 3.3.3.3
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface po10
Enter interface mode
(config-if)#ip address 10.1.2.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth1
Enter the Interface mode for eth1
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po20
Enter interface mode
(config-if)#ip address 10.1.4.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 3.3.3.3
Configure ospf Router-id
(config-router)#network 10.1.2.0/24 area 0
Define the interface on which OSPF runs and associate the
area ID (0) with the interface.
 
(config-router)#network 10.1.4.0/24 area 0
Define the interface on which OSPF runs and associate the
area ID (0) with the interface.
 
(config-router)#network 3.3.3.3/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P3
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 4.4.4.4/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 4.4.4.4
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface po30
Enter interface mode
(config-if)#ip address 10.1.3.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth1
Enter the Interface mode for eth1
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po40
Enter interface mode
(config-if)#ip address 10.1.5.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer, identifying the routing process
(config-router)#ospf router-id 4.4.4.4
Configure ospf Router-id
(config-router)#network 10.1.3.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.5.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 4.4.4.4/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P4
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 5.5.5.5/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 5.5.5.5
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface eth1
Enter interface mode
(config-if)#ip address 10.1.6.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po20
Enter interface mode
(config-if)#ip address 10.1.4.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po40
Enter interface mode
(config-if)#ip address 10.1.5.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#interface eth5
Enter the Interface mode for eth5
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 5.5.5.5
Configure ospf Router-id
(config-router)#network 10.1.4.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.5.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.6.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 5.5.5.5/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
PE-2
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 6.6.6.6/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 6.6.6.6
Configure Router-id
(config-router)#targeted-peer ipv4 1.1.1.1
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit from targeted-peer mode
(config-router)#transport-address ipv4 6.6.6.6
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface eth2
Enter interface mode
(config-if)#ip address 10.1.6.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the Process ID(100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 6.6.6.6
Configure ospf Router-id
(config-router)#network 10.1.6.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 6.6.6.6/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#mpls vpls vpls100 100
Configuring VPLS instance with name and VPLS ID
PE1(config-vpls)#flow-label both
Configure flow label based on requirement (we have three options both, transit and receive) with dynamic and static.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance
(config-vpls-sig)#vpls-peer 1.1.1.1
Configuring VPLS mesh peers
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config-if)#interface eth2.100 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 100
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls vpls100
Associating the VPLS Instance to the attachment circuit interface.
(config-acc-if-vpls)#commit
Commit the configuration
(config-acc-if-vpls)#end
Return to privilege mode
Validation
PE1
---
PE1#show mpls vpls bgp_vpls100 mesh
(m) - Service mapped over multipath transport
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
100 6.6.6.6 24961 24963 xe4 24963 2/Up 1 LDP Active
PE1#
PE1#show mpls vpls vpls100 detail
Virtual Private LAN Service Instance: vpls100, ID: 100
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Enabled, Direction: Both, Static: No
Group ID: 0, VPLS Type: Ethernet, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe18.100
Subinterface Match Criteria(s) :
dot1q 100
Mesh Peers:
6.6.6.6 (Up)
 
 
#ping mpls vpls 200 peer 6.6.6.6/32
Sending 5 MPLS Echos to VPLS Id : 100, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
!
!
!
!
!
 
Success Rate is 100.00 percent (5/5)
 
PE2
===
PE2#show mpls vpls vpls200 mesh
(m) - Service mapped over multipath transport
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
200 1.1.1.1 24961 24963 xe4 24963 2/Up 1 BGP Active
PE2#
PE1#show mpls vpls vpls100 detail
Virtual Private LAN Service Instance: vpls100, ID: 100
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Enabled, Direction: Both, Static: No
Group ID: 0, VPLS Type: Ethernet, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe18.100
Subinterface Match Criteria(s) :
dot1q 100
Mesh Peers:
1.1.1.1 (Up)
 
 
#ping mpls vpls 200 peer 1.1.1.1/32
Sending 5 MPLS Echos to VPLS Id : 100, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
!
!
!
!
!
 
Success Rate is 100.00 percent (5/5)
 
 
P1
==
P1#clear interface counters
 
P1#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
Po10 1549.80 1265260 1034.60 844649
Po30 0.01 8 0.00 8
xe4 1034.60 844647 1549.80 1265257
xe10 0.00 0 0.00 0
xe11 0.00 0 0.00 0
xe12 943.60 773213 474.05 384785
xe13 0.00 4 0.00 4
xe16 606.20 492047 560.54 459865
xe17 0.00 0 0.00 0
xe19 0.00 4 0.00 4
P1#
 
P4
==
P4#clear interface counters
 
P4#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
Po20 1549.80 1265260 1034.60 844649
Po40 0.01 8 0.00 8
xe4 1034.60 844647 1549.80 1265257
xe10 0.00 0 0.00 0
xe11 0.00 0 0.00 0
xe12 943.60 773213 474.05 384785
xe13 0.00 4 0.00 4
xe16 606.20 492047 560.54 459865
xe17 0.00 0 0.00 0
xe19 0.00 4 0.00 4
P1#
Configuration for BGP VPLS with FAT
PE-1
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 1.1.1.1
Configure Router-id
(config-router)#targeted-peer ipv4 6.6.6.6
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit from targeted-peer mode
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface eth2
Enter interface mode
(config-if)#ip address 10.1.1.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 1.1.1.1
Configure ospf Router-id
(config-router)#network 10.1.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 1.1.1.1/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#mpls vpls bgp_vpls200 200
Configuring VPLS instance with name and VPLS ID
PE1(config-vpls)#flow-label both
Configure flow label based on requirement (we have three options both, transit and receive) with dynamic and static.
(config-vpls)#signaling bgp
Enabling BGP signaling for the VPLS instance
(config-vpls-sig)#ve-id 500
Configure VE ID, which is mandatory for BGP VPLS, otherwise, Signaling does not take place. VE ID should be unique per VPLS instance.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config-if)#interface eth2.200 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 200
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls bgp_vpls200
Associating the VPLS Instance to the attachment circuit interface.
(config-acc-if-vpls)#commit
Commit the configuration
(config-acc-if-vpls)#end
Return to privilege mode
#configure terminal
Enter configuration mode.
(config)#router bgp 100
Enter BGP router mode.
(config-router)#neighbor 6.6.6.6 remote-as 100
Configure PE2 as an iBGP peer.
(config-router)#neighbor 6.6.6.6 updatesource lo
Update the source as loopback for iBGP peering with the remote PE2 router.
(config-router)#address-family l2vpn vpls
Configure address-family l2vpn vpls.
(config-router-af)#neighbor 6.6.6.6 activate
Activate PE2 in the VPLS address family.
(config-router-af)#exit-address-family
Exit address family mode
(config-router)#exit
Exit router mode.
P1
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 2.2.2.2
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface eth1
Enter interface mode
(config-if)#ip address 10.1.1.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po10
Enter interface mode
(config-if)#ip address 10.1.2.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po30
Enter interface mode
(config-if)#ip address 10.1.3.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#interface eth5
Enter the Interface mode for eth5
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 3.3.3.3
Configure ospf Router-id
(config-router)#network 10.1.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.2.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.4.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 2.2.2.2/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P2
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 3.3.3.3
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface po10
Enter interface mode
(config-if)#ip address 10.1.2.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth1
Enter the Interface mode for eth1
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po20
Enter interface mode
(config-if)#ip address 10.1.4.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 3.3.3.3
Configure ospf Router-id
(config-router)#network 10.1.2.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.4.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 3.3.3.3/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P3
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 4.4.4.4/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 4.4.4.4
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface po30
Enter interface mode
(config-if)#ip address 10.1.3.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth1
Enter the Interface mode for eth1
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po40
Enter interface mode
(config-if)#ip address 10.1.5.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 4.4.4.4
Configure ospf Router-id
(config-router)#network 10.1.3.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.5.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 4.4.4.4/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P4
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 5.5.5.5/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 5.5.5.5
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface eth1
Enter interface mode
(config-if)#ip address 10.1.6.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po20
Enter interface mode
(config-if)#ip address 10.1.4.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po40
Enter interface mode
(config-if)#ip address 10.1.5.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#interface eth5
Enter the Interface mode for eth5
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 5.5.5.5
Configure ospf Router-id
(config-router)#network 10.1.4.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.5.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.6.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 5.5.5.5/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
PE-2
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 6.6.6.6/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 6.6.6.6
Configure Router-id
(config-router)#targeted-peer ipv4 1.1.1.1
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit from targeted-peer mode
(config-router)#transport-address ipv4 6.6.6.6
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface eth2
Enter interface mode
(config-if)#ip address 10.1.6.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 6.6.6.6
Configure ospf Router-id
(config-router)#network 10.1.6.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 6.6.6.6/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#mpls vpls bgp_vpls200 200
Configuring VPLS instance with name and VPLS ID
PE1(config-vpls)#flow-label both
Configure flow label based on requirement (we have three options both, transit and receive) with dynamic and static.
(config-vpls)#signaling bgp
Enabling BGP signaling for the VPLS instance
(config-vpls-sig)#ve-id 600
Configure VE ID, which is mandatory for BGP VPLS, otherwise, Signaling does not take place. VE ID should be unique per VPLS instance.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config-if)#interface eth2.200 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 200
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls bgp_vpls200
Associating the VPLS Instance to the attachment circuit interface.
(config-acc-if-vpls)#commit
Commit the configuration
(config-acc-if-vpls)#end
Return to privilege mode
(config)#router bgp 100
Enter BGP router mode.
(config-router)#neighbor 1.1.1.1 remote-as 100
Configure PE1 as an iBGP peer.
(config-router)#neighbor 1.1.1.1 updatesource lo
Update the source as loopback for iBGP peering with the remote PE1 router.
(config-router)#address-family l2vpn vpls
Configure address-family l2vpn vpls.
(config-router-af)#neighbor 1.1.1.1 activate
Activate PE1 in the VPLS address family.
(config-router-af)#exit-address-family
Exit address family mode
(config-router)#exit
Exit router mode.
Validation
PE1
---
PE1#show mpls vpls bgp_vpls200 mesh
(m) - Service mapped over multipath transport
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
200 6.6.6.6 24961 24963 xe4 24963 2/Up 1 BGP Active
PE1#
PE1#show mpls vpls bgp_vpls200 detail
Virtual Private LAN Service Instance: bgp_vpls200, ID: 200
SIG-Protocol: BGP
Route-Distinguisher :100:200
Route-Target :100:200
VE-ID :500
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Enabled, Direction: Receive, Static: No
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: eth1.200
Subinterface Match Criteria(s) :
dot1q 300
Mesh Peers:
6.6.6.6 (Up)
 
#ping mpls bgp_vpls 2 00 peer 6.6.6.6/32
Sending 5 MPLS Echos to VPLS Id : 100, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
!
!
!
!
!
 
Success Rate is 100.00 percent (5/5)
PE2
===
PE2#show mpls vpls bgp_vpls200 mesh
(m) - Service mapped over multipath transport
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
200 1.1.1.1 24961 24963 xe4 24963 2/Up 1 BGP Active
PE2#
PE1#show mpls vpls bgp_vpls200 detail
Virtual Private LAN Service Instance: bgp_vpls200, ID: 200
SIG-Protocol: BGP
Route-Distinguisher :100:200
Route-Target :100:200
VE-ID :500
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Enabled, Direction: Transmit, Static: No
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: eth1.200
Subinterface Match Criteria(s) :
dot1q 200
Mesh Peers:
1.1.1.1 (Up)
 
 
 
#ping mpls bgp_vpls 200 peer 1.1.1.1/32
Sending 5 MPLS Echos to VPLS Id : 100, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
!
!
!
!
!
 
Success Rate is 100.00 percent (5/5)
P1
==
P1#clear interface counters
 
P1#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
Po10 1549.80 1265260 1034.60 844649
Po30 0.01 8 0.00 8
xe4 1034.60 844647 1549.80 1265257
xe10 0.00 0 0.00 0
xe11 0.00 0 0.00 0
xe12 943.60 773213 474.05 384785
xe13 0.00 4 0.00 4
xe16 606.20 492047 560.54 459865
xe17 0.00 0 0.00 0
xe19 0.00 4 0.00 4
P1#
 
P4
==
P4#clear interface counters
 
P4#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
Po20 1549.80 1265260 1034.60 844649
Po40 0.01 8 0.00 8
xe4 1034.60 844647 1549.80 1265257
xe10 0.00 0 0.00 0
xe11 0.00 0 0.00 0
xe12 943.60 773213 474.05 384785
xe13 0.00 4 0.00 4
xe16 606.20 492047 560.54 459865
xe17 0.00 0 0.00 0
xe19 0.00 4 0.00 4
P1#
Configuration for VPWS with FAT
PE-1
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 1.1.1.1
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config-router)#targeted-peer ipv4 6.6.6.6
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit from targeted-peer mode
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface eth2
Enter interface mode
(config-if)#ip address 10.1.1.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 1.1.1.1
Configure ospf Router-id
(config-router)#network 10.1.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 1.1.1.1/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#mpls l2-circuit VPWS4 400 3.3.3.3
Configure the VC for PE-2
PE1(config-vpls)#flow-label both
Configure flow label based on requirement (we have three options both, transit and receive) with dynamic and static.
(config-pseudowire)#commit
Commit the configuration
(config-pseudowire)#exit
Exit from pseudowire configuration mode
(config-if)#interface eth2.300 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 300
Configure encapsulation under a subinterface
(config-if)#access-if-vpws
Access VPWS under sub interface
(config-acc-if-vpws)#mpls-l2-circuit VPWS4 primary
Associating the VPWS Instance to the attachment circuit interface.
(config-acc-if-vpws)#commit
Commit the configuration
(config-acc-if-vpws)#end
Return to privilege mode
P1
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 2.2.2.2
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface eth1
Enter interface mode
(config-if)#ip address 10.1.1.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po10
Enter interface mode
(config-if)#ip address 10.1.2.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po30
Enter interface mode
(config-if)#ip address 10.1.3.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#interface eth5
Enter the Interface mode for eth5
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 3.3.3.3
Configure ospf Router-id
(config-router)#network 10.1.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.2.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.4.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 2.2.2.2/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P2
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 3.3.3.3
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface po10
Enter interface mode
(config-if)#ip address 10.1.2.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth1
Enter the Interface mode for eth1
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 10 mode active
Moving interface to Dynamic LAG 10
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po20
Enter interface mode
(config-if)#ip address 10.1.4.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 3.3.3.3
Configure ospf Router-id
(config-router)#network 10.1.2.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.4.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 3.3.3.3/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P3
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 4.4.4.4/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 4.4.4.4
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface po30
Enter interface mode
(config-if)#ip address 10.1.3.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth1
Enter the Interface mode for eth1
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 30 mode active
Moving interface to Dynamic LAG 30
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po40
Enter interface mode
(config-if)#ip address 10.1.5.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 4.4.4.4
Configure ospf Router-id
(config-router)#network 10.1.3.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.5.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 4.4.4.4/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P4
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 5.5.5.5/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 5.5.5.5
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface eth1
Enter interface mode
(config-if)#ip address 10.1.6.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po20
Enter interface mode
(config-if)#ip address 10.1.4.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth2
Enter the Interface mode for eth2
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#interface eth3
Enter the Interface mode for eth3
(config-if)#channel-group 20 mode active
Moving interface to Dynamic LAG 20
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#interface po40
Enter interface mode
(config-if)#ip address 10.1.5.1/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface eth4
Enter the Interface mode for eth4
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#interface eth5
Enter the Interface mode for eth5
(config-if)#channel-group 40 mode active
Moving interface to Dynamic LAG 40
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 5.5.5.5
Configure ospf Router-id
(config-router)#network 10.1.4.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.5.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.1.6.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 5.5.5.5/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
PE-2
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 6.6.6.6/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 6.6.6.6
Configure Router-id
(config-router)#targeted-peer ipv4 1.1.1.1
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit from targeted-peer mode
(config-router)#transport-address ipv4 6.6.6.6
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface eth2
Enter interface mode
(config-if)#ip address 10.1.6.2/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 6.6.6.6
Configure ospf Router-id
(config-router)#network 10.1.6.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 6.6.6.6/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#mpls l2-circuit VPWS4 400 1.1.1.1
Configure the VC for PE-2
PE1(config-vpls)#flow-label both
Configure flow label based on requirement (we have three options both, transit and receive) with dynamic and static.
(config-pseudowire)#commit
Commit the configuration
(config-pseudowire)#exit
Exit from pseudowire configuration mode
(config-if)#interface eth2.300 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 300
Configure encapsulation under a subinterface
(config-if)#access-if-vpws
Access VPWS under sub interface
(config-acc-if-vpws)#mpls-l2-circuit VPWS4 primary
Associating the VPWS Instance to the attachment circuit interface.
(config-acc-if-vpws)#commit
Commit the configuration
(config-acc-if-vpws)#end
Return to privilege mode
Validation
PE1
---
PE1#show mpls vc-table
(m) - Service mapped over multipath transport
 
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
400 N/A N/A xe18.300 xe4 24967 24961 6.6.6.6 Active
 
PE1#
PE1#show mpls l2-circuit detail
MPLS Layer-2 Virtual Circuit: VPWS4, id: 300 PW-INDEX: 4 service-tpid: dot1.q
Endpoint: 6.6.6.6
Control Word: 0
Flow Label Status: Enabled, Direction: Both, Static: Yes
MPLS Layer-2 Virtual Circuit Group: none
Bound to interface: xe18.200
Subinterface Match Criteria(s) :
dot1q 300
Virtual Circuit Type: Ethernet VLAN
Virtual Circuit is configured as Primary
Virtual Circuit is configured as Active
Virtual Circuit is active
PE2
===
PE2#show mpls vc-table
(m) - Service mapped over multipath transport
 
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
400 N/A N/A xe4.300 xe18 24967 24961 1.1.1.1 Active
 
PE2#
PE2#show mpls l2-circuit detail
MPLS Layer-2 Virtual Circuit: VPWS4, id: 300 PW-INDEX: 4 service-tpid: dot1.q
Endpoint: 1.1.1.1
Control Word: 0
Flow Label Status: Enabled, Direction: Both, Static: Yes
MPLS Layer-2 Virtual Circuit Group: none
Bound to interface: xe4.200
Subinterface Match Criteria(s) :
dot1q 200
Virtual Circuit Type: Ethernet VLAN
Virtual Circuit is configured as Primary
Virtual Circuit is configured as Active
Virtual Circuit is active
P1
==
P1#clear interface counters
 
P1#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
Po10 1549.80 1265260 1034.60 844649
Po30 0.01 8 0.00 8
xe4 1034.60 844647 1549.80 1265257
xe10 0.00 0 0.00 0
xe11 0.00 0 0.00 0
xe12 943.60 773213 474.05 384785
xe13 0.00 4 0.00 4
xe16 606.20 492047 560.54 459865
xe17 0.00 0 0.00 0
xe19 0.00 4 0.00 4
P1#
 
P4
==
P4#clear interface counters
 
P4#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
Po20 1549.80 1265260 1034.60 844649
Po40 0.01 8 0.00 8
xe4 1034.60 844647 1549.80 1265257
xe10 0.00 0 0.00 0
xe11 0.00 0 0.00 0
xe12 943.60 773213 474.05 384785
xe13 0.00 4 0.00 4
xe16 606.20 492047 560.54 459865
xe17 0.00 0 0.00 0
xe19 0.00 4 0.00 4
P1#