OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : L3VPN over EVPN MPLS Configuration
L3VPN over EVPN MPLS Configuration
This chapter includes step-by-step configurations for L3VPN over EVPN MPLS.
Overview
L3vpn EVPN MPLS ensures that we are able to do the Ip-vrf to Ip-vrf routing with MPLS as overlay. We can ensure that with this model we can do the Anycast gateway using EVPN concepts. L3VPN EVPN MPLS is a way of integrating the interface-less model. In this model we will use non-irb interface i.e. L3 interface for the Ip-Vrf routing.
Using Anycast gateway idea is to have the Multi-Homed PE nodes to work in active-standby mode. From remote perspective at one time only one Peer PE will be active. If that PE goes down, then a new tunnel to the peer PE will be established for the traffic. From the access-side Traffic can reach to either of the peer PE and sent across the remote PE nodes. This way we can achieve redundancy using the anycast mac-address.
Topology
Below Topology depicts the topology for the L3VPN over EVPN MPLS configuration examples for both single homing and multi-homing with SR/LDP. MLAG configured between PE1 and PE2 to achieve multi-homing Active-Standby connected to CE1.
Topology diagram for L3VPN over EVPN MPLS
Configuration
PE1
Loopback Interface:
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)# ip address 1.1.1.1/32 secondary
Configure IP address on loopback interface.
(config-if)# prefix-sid index 1
Configuring prefix sid for segment id
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit interface mode
Global EVPN MPLS Command:
 
#configure terminal
Enter configuration mode.
(config)#load-balance enable
Enable Load balance
(config)#hardware-profile filter evpn-mpls-mh enable
Enable hardware profile for evpn mpls multihoming
(config)#evpn mpls enable
Enable EVPN MPLS
(config)#evpn mpls irb
Enable EVPN MPLS IRB
(config)#evpn mpls multihoming enable
Enable EVPN MPLS multihoming
(config)#evpn mpls vtep-ip-global 1.1.1.1
Configuring VTEP global IP to loopback IP
(config)#evpn irb-forwarding anycast-gateway-mac 0011.2233.4466
Confiiguring anycast gateway mac for MH.
Note: Anycast gateway is mandatory for MH nodes.
(config)#commit
Commit candidate configuration to be running configuration Note: Reload is required after Enabling/Disabling EVPN MPLS Feature.
Configure SR:
 
(config)#segment-routing
Configure segment routing
(config-sr)# mpls sr-prefer
Set mpls prefer segment routing over other protocols
(config-sr)#exit
Exit from router sr mode
(config)#commit
Commit the transaction.
Configure LDP:
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)# transport-address ipv4 1.1.1.1
Configuring transport address
(config-router)#exit
Exit from router target peer and LDP mode
(config)#commit
Commit the transaction.
MLAG Configuration:
 
(config)#interface mlag1
Create mlag interface
(config-if)# switchport
Configuring as L2 port
(config-if)# load-interval 30
Configure load interval
(config-if)# exit
Exit from interface mode
(config)#interface po1
Configure dynamic lag
(config-if)# switchport
Configuring as L2 port
(config-if)# mtu 1500
Set mtu value
(config-if)# mlag 1
Attach mlag to po1.
Note: While creating po1 subifp, this needs to be un-configured and configured back
 
(config-if)#interface xe10
Enter interface mode for xe10
(config-if)# channel-group 1 mode active
Attach lag interface po1
(config-if)#exit
Exit interface mode
(config)#mcec domain configuration
Create mcec domain
(config-mcec-domain)# domain-address 1111.2222.3333
Configure mcec domain address
(config-mcec-domain)# domain-system-number 1
Configure system number. Active node should have lower value.
(config-mcec-domain)# intra-domain-link xe4
Configure ideal interface between mlag devices
(config-mcec-domain)# domain-hello-timeout long
Configure domain hello timeout
Interface Configuration Network Side:
 
(config-if)#interface ce0
Configure network interface ce0
(config-if)# ip address 20.1.1.1/24
Configure IP address on the interface.
(config-if)# mtu 1522
Configure mtu
(config-if)# label-switching
Enable label switching on the interface.
(config-if)# mpls ldp-igp sync ospf
Configure mpls igp sync
(config-if)# ip ospf network point-to-point
Configure ospf as p2p
(config-if)# enable-ldp ipv4
Enable LDP on the physical interface
(config)#interface po2
Create channel group po2
(config-if)# ip address 10.1.1.1/24
Configure IP address on the interface.
(config-if)# mtu 2000
Configure mtu
(config-if)# label-switching
Enable label switching on the interface.
(config-if)# mpls ldp-igp sync ospf
Configure mpls igp sync
(config-if)# ip ospf network point-to-point
Configure ospf as p2p
(config-if)# enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#interface xe18
Enter interface mode for xe18
(config-if)# channel-group 2 mode active
Attach lag interface po2
(config-if)#interface xe19
Enter interface mode for xe19
(config-if)# channel-group 2 mode active
Attach lag interface po2
(config)#commit
Commit the transaction.
OSPF Configuration:
 
(config)#router ospf 1
Enter the Router OSPF mode.
(config-router)# network 1.1.1.1/32 area 0.0.0.0
Advertise loopback address in OSPF.
(config-router)# network 10.1.1.0/24 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# network 20.1.1.0/24 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# ospf segment-routing global block 16000 23000
Configure SR global block for ospf
(config-router)# segment-routing mpls
Enable ospf SR
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#commit
Commit the transaction.
BGP Configuration:
 
(config)#router bgp 100
Enter the Router BGP mode, ASN: 100
(config-router)# neighbor 5.5.5.5 remote-as 100
Configuring PE3 as iBGP neighbor using it's loopback IP
(config-router)# neighbor 5.5.5.5 fall-over bfd multihop
Configure BFD
(config-router)# neighbor 5.5.5.5 update-source lo
Source of routing updates as loopback
(config-router)# address-family ipv4 unicast
Enter in to address family ipv4 unicast mode
(config-router-af)# neighbor 5.5.5.5 activate
Activate PE3 neighbor
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family l2vpn evpn
Enter in to address family l2vpn vpn
(config-router-af)# neighbor 5.5.5.5 activate
Activate PE3 neighbor
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv6 unicast
Enter in to address family ipv6 unicast mode
(config-router-af)# neighbor 5.5.5.5 activate
Activate PE3 neighbor
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv4 vrf vrf102
Enter in to address family ipv4 vrf vrf102
(config-router-af)# redistribute connected
Redistribute connected networks in to bgp
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv4 vrf vrf101
Enter in to address family ipv4 vrf vrf102
(config-router-af)# redistribute connected
Redistribute connected networks in to bgp
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv6 vrf vrf101
Enter in to address family ipv6 vrf vrf101
(config-router-af)# redistribute connected
Redistribute connected networks in to bgp
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv6 vrf vrf102
Enter in to address family ipv6 vrf vrf102
(config-router-af)# redistribute connected
Redistribute connected networks in to bgp
(config-router-af)# exit-address-family
Exit address family
IP VRF Configuration:
 
(config-vrf)#ip vrf vrf102
Enter VRF mode
(config-vrf)# rd 10001:102
Configuring Route-Distinguisher value
(config-vrf)# route-target both 1.1.1.1:102
Configure RT value
(config-vrf)# l3vni 102
Configure L3VNID to populate route through evpn
(config-vrf)#ip vrf vrf101
Enter VRF mode
(config-vrf)# rd 10001:1
Configuring Route-Distinguisher value
(config-vrf)# route-target both 1.1.1.1:1
Configure RT value
(config-vrf)# l3vni 101
Configure L3VNID to populate route through evpn
L3 VRF Port Configuration:
 
(config-if)#interface xe3
Enter the Interface mode for xe3. This is for untagged traffic
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# ip address 100.1.1.1/24
Assign ipv4 address
(config-if)# ipv6 address 1000::1/64
Assign ipv6 address
(config-if)#interface xe3.1
Create xe3.1 subifp
(config-if)# encapsulation dot1q 10
Configure encapsulation as single tagged
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# ip address 110.1.1.1/24
Assign ipv4 address
(config-if)# ipv6 address 1100::1/64
Assign ipv6 address
(config-if)#interface xe3.2
Create xe3.2 subifp
(config-if)# encapsulation dot1q 11 inner-dot1q 11
Configure encapsulation as double tagged
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# ip address 120.1.1.1/24
Assign ipv4 address
(config-if)# ipv6 address 1200::1/64
Assign ipv6 address
(config-if)#interface xe3.11
Create xe3.11 subifp
(config-if)# encapsulation dot1q 11
Configure encapsulation as single tagged
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# ip address 111.1.1.1/24
Assign ipv4 address
(config-if)# ipv6 address 1110::1/64
Assign ipv6 address
(config-if)#interface po1.11
Create po1 subinterface. We need to unconfigure mlag under po1 before creating subinterface.
(config-if)# encapsulation dot1q 11
Configure encapsulation type and value
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# evpn irb-if-forwarding anycast-gateway-mac
Configure anycast gateway mac
(config-if)# ip address 150.11.1.1/24
Assign ipv4 address
(config-if)#interface po1.12
Create po1 subinterface.
(config-if)# encapsulation dot1q 12
Configure encapsulation type and value
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# evpn irb-if-forwarding anycast-gateway-mac
Configure anycast gateway mac
(config-if)# ip address 150.12.1.1/24
Assign ipv4 address
(config-if)#interface po1.13
Create po1 subinterface.
(config-if)# encapsulation dot1q 13
Configure encapsulation type and value
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# evpn irb-if-forwarding anycast-gateway-mac
Configure anycast gateway mac
(config-if)# ip address 150.13.1.1/24
Assign ipv4 address
(config-if)#interface po1.14
Create po1 subinterface.
(config-if)# encapsulation dot1q 14
Configure encapsulation type and value
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# evpn irb-if-forwarding anycast-gateway-mac
Configure anycast gateway mac
(config-if)# ip address 150.14.1.1/24
Assign ipv4 address
(config-if)#interface po1.15
Create po1 subinterface.
(config-if)# encapsulation dot1q 15
Configure encapsulation type and value
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# evpn irb-if-forwarding anycast-gateway-mac
Configure anycast gateway mac
(config-if)# ip address 150.15.1.1/24
Assign ipv4 address
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
PE2 Configuration:
 
Loopback Interface:
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)# ip address 2.2.2.2/32 secondary
Configure IP address on loopback interface.
(config-if)# prefix-sid index 2
Configuring prefix sid for segment id
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit interface mode
Global EVPN MPLS Command:
 
#configure terminal
Enter configuration mode.
(config)#load-balance enable
Enable Load balance
(config)#hardware-profile filter evpn-mpls-mh enable
Enable hardware profile for evpn mpls multihoming
(config)#evpn mpls enable
Enable EVPN MPLS
(config)#evpn mpls irb
Enable EVPN MPLS IRB
(config)#evpn mpls multihoming enable
Enable EVPN MPLS multihoming
(config)#evpn mpls vtep-ip-global 2.2.2.2
Configuring VTEP global IP to loopback IP
(config)#evpn irb-forwarding anycast-gateway-mac 0011.2233.4466
Configure Anycast gateway mac for MH. This command is mandatory for MH nodes.
(config)#commit
Commit candidate configuration to be running configuration Note: Reload is required after Enabling/Disabling EVPN MPLS Feature.
Configure SR:
 
(config)#segment-routing
Configure segment routing
(config-sr)# mpls sr-prefer
Set mpls prefer segment routing over other protocols
(config-sr)#exit
Exit from router sr mode
(config)#commit
Commit the transaction.
Configure LDP:
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)# transport-address ipv4 2.2.2.2
Configuring transport address
(config-router)#exit
Exit from router target peer and LDP mode
(config)#commit
Commit the transaction.
MLAG Configuration:
 
(config)#interface mlag1
Create mlag interface
(config-if)# switchport
Configuring as L2 port
(config-if)# load-interval 30
Configure load interval
(config-if)# exit
Exit from interface mode
(config)#interface po1
Configure dynamic lag
(config-if)# switchport
Configuring as L2 port
(config-if)# mtu 1500
Set mtu value
(config-if)# mlag 1
Attach mlag
(config-if)#interface xe9
Enter interface mode
(config-if)# speed 10g
Set speed as 10g
(config-if)# channel-group 1 mode active
Attach the channel group po1
(config-if)# exit
Exit from interface mode
(config)#mcec domain configuration
Create mcec domain
(config-mcec-domain)# domain-address 1111.2222.3333
Configure mcec domain address
(config-mcec-domain)# domain-system-number 2
Configure system number
(config-mcec-domain)# intra-domain-link xe4
Configure ideal interface between mlag devices
(config-mcec-domain)# domain-hello-timeout long
Configure domain hello timeout
(config)#commit
Commit the transaction.
Interface Configuration Network Side:
 
(config-if)#interface xe6
Enter the Interface mode for xe6.
(config-if)# ip address 30.1.1.1/24
Configure ipv4 address
(config-if)# mtu 1522
Configure mtu
(config-if)# label-switching
Enable label switching on the interface.
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf as p2p
(config-if)# enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#interface xe26
Enter the Interface mode for xe26.
(config-if)# ip address 40.1.1.1/24
Configure ipv4 address
(config-if)# mtu 2000
Configure mtu
(config-if)# label-switching
Enable label switching on the interface.
(config-if)# mpls ldp-igp sync ospf
Configure ldp sync with ospf
(config-if)# ip ospf network point-to-point
Configure ospf as p2p
(config-if)# enable-ldp ipv4
Enable LDP on the physical interface
(config-router)#exit
Exit interface mode
(config)#commit
Commit the transaction.
OSPF Configuration:
 
(config)#router ospf 1
Enter the Router OSPF mode.
(config-router)# network 1.1.1.1/32 area 0.0.0.0
Advertise loopback address in OSPF.
(config-router)# network 10.1.1.0/24 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# network 20.1.1.0/24 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# ospf segment-routing global block 16000 23000
Configure SR global block for ospf
(config-router)# segment-routing mpls
Enable ospf SR
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#commit
Commit the transaction.
BGP Configuration:
 
(config)#router bgp 100
Enter the Router BGP mode, ASN: 100
(config-router)# neighbor 5.5.5.5 remote-as 100
Configuring PE3 as iBGP neighbor using it's loopback IP
(config-router)# neighbor 5.5.5.5 fall-over bfd multihop
Configure BFD
(config-router)# neighbor 5.5.5.5 update-source lo
Source of routing updates as loopback
(config-router)# address-family ipv4 unicast
Enter in to address family ipv4 unicast mode
(config-router-af)# neighbor 5.5.5.5 activate
Activate PE3 neighbor
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family l2vpn evpn
Enter in to address family l2vpn vpn
(config-router-af)# neighbor 5.5.5.5 activate
Activate PE3 neighbor
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv6 unicast
Enter in to address family ipv6 unicast mode
(config-router-af)# neighbor 5.5.5.5 activate
Activate PE3 neighbor
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv4 vrf vrf102
Enter in to address family ipv4 vrf vrf102
(config-router-af)# redistribute connected
Redistribute connected networks in to bgp
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv4 vrf vrf101
Enter in to address family ipv4 vrf vrf102
(config-router-af)# redistribute connected
Redistribute connected networks in to bgp
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv6 vrf vrf101
Enter in to address family ipv6 vrf vrf101
(config-router-af)# redistribute connected
Redistribute connected networks in to bgp
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv6 vrf vrf102
Enter in to address family ipv6 vrf vrf102
(config-router-af)# redistribute connected
Redistribute connected networks in to bgp
(config-router-af)# exit-address-family
Exit address family
(config)#commit
Commit the transaction.
IP VRF Configuration:
 
(config-vrf)#ip vrf vrf102
Enter VRF mode
(config-vrf)# rd 10001:102
Configuring Route-Distinguisher value
(config-vrf)# route-target both 1.1.1.1:102
Configure RT
(config-vrf)# l3vni 102
Configure L3VNI to send ipv4 route through evpn
(config-vrf)#ip vrf vrf101
Create ip vrf vrf101
(config-vrf)# rd 10001:1
Configuring Route-Distinguisher value
(config-vrf)# route-target both 1.1.1.1:1
Configure RT
(config-vrf)# l3vni 101
Configure L3VNI to send ipv4 route through evpn
(config)#commit
Commit the transaction.
L3 VRF Port Configuration:
 
(config-if)#interface po1.11
Create po1 subinterface. We need to unconfigure mlag under po1 before creating subinterface.
(config-if)# encapsulation dot1q 11
Configure encapsulation type and value
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# evpn irb-if-forwarding anycast-gateway-mac
Configure anycast gateway mac for multi-homing
(config-if)# ip address 150.11.1.1/24
Assign ipv4 address
(config-if)#interface po1.12
Create po1 subinterface.
(config-if)# encapsulation dot1q 12
Configure encapsulation type and value
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# evpn irb-if-forwarding anycast-gateway-mac
Configure anycast gateway mac for multi-homing
(config-if)# ip address 150.12.1.1/24
Assign ipv4 address
(config-if)#interface po1.13
Create po1 subinterface.
(config-if)# encapsulation dot1q 13
Configure encapsulation type and value
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# evpn irb-if-forwarding anycast-gateway-mac
Configure anycast gateway mac for multi-homing
(config-if)# ip address 150.13.1.1/24
Assign ipv4 address
(config-if)#interface po1.14
Create po1 subinterface.
(config-if)# encapsulation dot1q 14
Configure encapsulation type and value
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# ip address 150.14.1.1/24
Assign ipv4 address
(config-if)# evpn irb-if-forwarding anycast-gateway-mac
Configure anycast gateway mac for multi-homing
(config-if)#interface po1.15
Create po1 subinterface.
(config-if)# encapsulation dot1q 15
Configure encapsulation type and value
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# ip address 150.15.1.1/24
Assign ipv4 address
(config-if)# evpn irb-if-forwarding anycast-gateway-mac
Configure anycast gateway mac for multi-homing
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
P1:
 
(config)#segment-routing
Configure SR.
(config-sr)# mpls sr-prefer
Prefer SR over other protocol.
(config-sr)#exit
Exit sr mode.
(config)#router ldp
Configure router ldp
(config-router)# transport-address ipv4 3.3.3.3
Configure transport address.
(config-router)#exit
Exit
(config)#interface po2
Configure dynamic LAG po2
(config-if)# ip address 10.1.1.2/24
Configure ipv4 address
(config-if)# mtu 2000
Configure MTU
(config-if)# label-switching
Configure label switching
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf p2p
(config-if)# enable-ldp ipv4
Enable ldp
(config-if)#interface ce1
Configure network interface ce1
(config-if)# ip address 60.1.1.1/24
Configure ipv4 address
(config-if)# mtu 1522
Configure MTU
(config-if)# label-switching
Configure label switching
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf p2p
(config-if)# enable-ldp ipv4
Enable ldp
(config-if)#interface lo
Configure loopback interface
(config-if)# ip address 3.3.3.3/32 secondary
Configure secondary ip
(config-if)# prefix-sid absolute 16003
Configure SR segment id
(config-if)#interface xe10
Configure network interface xe10
(config-if)# speed 10g
Set speed 10g
(config-if)# ip address 30.1.1.2/24
Configure ipv4 address
(config-if)# mtu 1522
Configure MTU
(config-if)# label-switching
Configure label switching
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf p2p
(config-if)# enable-ldp ipv4
Enable ldp
(config-if)#interface xe14
Configure network interface xe14
(config-if)# ip address 50.1.1.1/24
Configure ipv4 address
(config-if)# mtu 1522
Configure MTU
(config-if)# label-switching
Configure label switching
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf p2p
(config-if)# enable-ldp ipv4
Enable ldp
(config-if)#interface xe16
Enter interface mode
(config-if)# channel-group 2 mode active
Map dynamic lag po2
(config-if)#interface xe17
Enter interface mode
(config-if)# channel-group 2 mode active
Map dynamic lag po2
(config-if)# exit
Exit
(config)#router ospf 1
Configure router ospf 1
(config-router)# network 3.3.3.3/32 area 0.0.0.0
Add loopback ip to ospf
(config-router)# network 10.1.1.0/24 area 0.0.0.0
Add network address
(config-router)# network 30.1.1.0/24 area 0.0.0.0
Add network address
(config-router)# network 50.1.1.0/24 area 0.0.0.0
Add network address
(config-router)# network 60.1.1.0/24 area 0.0.0.0
Add network address
(config-router)# segment-routing mpls
Enable SR ospf
 
P2:
 
(config)#segment-routing
Configure SR.
(config-sr)# mpls sr-prefer
Prefer SR over other protocol.
(config)#exit
Exit sr mode.
(config-sr)#router ldp
Configure router ldp
(config-router)# transport-address ipv4 4.4.4.4
Configure transport address.
(config-router)#exit
Exit
(config)#interface ce1
Configure network interface ce1
(config-if)# ip address 20.1.1.2/24
Configure ipv4 address
(config-if)# mtu 1522
Configure MTU
(config-if)# label-switching
Configure label switching
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf p2p
(config-if)# enable-ldp ipv4
Enable ldp
(config-if)#interface lo
Configure loopback interface
(config-if)# ip address 4.4.4.4/32 secondary
Configure secondary ip
(config-if)# prefix-sid absolute 16004
Configure SR segment id
(config-if)#interface xe14
Configure network interface xe14
(config-if)# ip address 50.1.1.2/24
Configure ipv4 address
(config-if)# mtu 1522
Configure MTU
(config-if)# label-switching
Configure label switching
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf p2p
(config-if)# enable-ldp ipv4
Enable ldp
(config-if)#interface xe20
Configure network interface xe20
(config-if)# ip address 70.1.1.1/24
Configure ipv4 address
(config-if)# mtu 1522
Configure MTU
(config-if)# label-switching
Configure label switching
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf p2p
(config-if)# enable-ldp ipv4
Enable ldp
(config-if)#interface xe26
Configure network interface xe26
(config-if)# ip address 40.1.1.2/24
Configure ipv4 address
(config-if)# mtu 2000
Configure MTU
(config-if)# label-switching
Configure label switching
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf p2p
(config-if)# enable-ldp ipv4
Enable ldp
(config-if)#router ospf 1
Configure router ospf 1
(config-router)# network 4.4.4.4/32 area 0.0.0.0
Add loopback ip to ospf
(config-router)# network 20.1.1.0/24 area 0.0.0.0
Add network address
(config-router)# network 40.1.1.0/24 area 0.0.0.0
Add network address
(config-router)# network 50.1.1.0/24 area 0.0.0.0
Add network address
(config-router)# network 70.1.1.0/24 area 0.0.0.0
Add network address
(config-router)# segment-routing mpls
Enable SR ospf
PE3
 
Loopback Interface:
 
#configure terminal
Enter configuration mode.
(config-if)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)# ip address 5.5.5.5/32 secondary
Configure IP address on loopback interface.
(config-if)# prefix-sid absolute 16005
Configure SR segment id
(config)#commit
Commit the transaction.
Global EVPN MPLS Command:
 
(config)#evpn mpls enable
Enable EVPN MPLS
(config)#evpn mpls irb
Enable EVPN MPLS IRB
(config)#commit
Commit candidate configuration to be running configuration Note: Reload is required after Enabling/Disabling EVPN MPLS Feature
(config)#evpn mpls vtep-ip-global 5.5.5.5
Configuring VTEP global IP to loopback IP
(config-evpn-mpls)#commit
Commit the transaction.
IP VRF Configuration:
 
(config-vrf)#ip vrf vrf102
Enter VRF mode
(config-vrf)# rd 10001:102
Configuring Route-Distinguisher value
(config-vrf)# route-target both 1.1.1.1:102
Configure RT value
(config-vrf)# l3vni 102
Configure L3VNI to send ipv4 route through evpn
(config-vrf)#ip vrf vrf101
Create ip vrf vrf101
(config-vrf)# rd 10002:1
Configuring Route-Distinguisher value
(config-vrf)# route-target both 1.1.1.1:1
Configure RT value
(config-vrf)# l3vni 101
Configure L3VNI to send ipv4 route through evpn
(config)#commit
Commit the transaction.
Cofigure SR:
 
(config)#segment-routing
Configure SR
(config-sr)# mpls sr-prefer
Prefer SR over other protocols for mpls
(config)#commit
Commit the transaction.
Global LDP:
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)# transport-address ipv4 5.5.5.5
Configure transport address
(config-router)#exit
Exit
(config)#commit
Commit the transaction.
Interface Configuration Network Side:
 
(config-if)#interface ce3
Configure network interface ce3
(config-if)# ip address 60.1.1.2/24
Configure ipv4 address
(config-if)# mtu 1522
Configure MTU
(config-if)# label-switching
Configure label switching
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf p2p
(config-if)# enable-ldp ipv4
Enable ldp
(config-if)#interface xe20
Enter the Interface mode for xe20.
(config-if)# ip address 70.1.1.2/24
Configure ipv4 address
(config-if)# mtu 1522
Configure MTU
(config-if)# label-switching
Configure label switching
(config-if)# mpls ldp-igp sync ospf
Configure ldp ospf sync
(config-if)# ip ospf network point-to-point
Configure ospf p2p
(config-if)# enable-ldp ipv4
Enable ldp
(config)#commit
Commit the transaction.
OSPF Configuration:
(config)#router ospf 1
Enter the Router OSPF mode.
(config-router)# network 5.5.5.5/32 area 0.0.0.0
Advertise loopback address in OSPF.
(config-router)# network 60.1.1.0/24 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# network 70.1.1.0/24 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# segment-routing mpls
Enable SR ospf
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#commit
Commit the transaction.
BGP Configuration:
 
(config-router)#router bgp 100
Enter the Router BGP mode, ASN: 100
(config-router)# neighbor 1.1.1.1 remote-as 100
Configuring PE1 as iBGP neighbor using it's loopback IP
(config-router)# neighbor 1.1.1.1 fall-over bfd multihop
Configure BFD
(config-router)# neighbor 2.2.2.2 remote-as 100
Configuring PE2 as iBGP neighbor using it's loopback IP
(config-router)# neighbor 2.2.2.2 fall-over bfd multihop
Configure BFD
(config-router)# neighbor 1.1.1.1 update-source lo
Source of routing updates as loopback
(config-router)# neighbor 2.2.2.2 update-source lo
Source of routing updates as loopback
(config-router)# address-family ipv4 unicast
Enter ipv4 unicast address family
(config-router-af)# neighbor 1.1.1.1 activate
Activate neighbor PE1
(config-router-af)# neighbor 2.2.2.2 activate
Activate neighbor PE2
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family l2vpn evpn
Enter evpn address family
(config-router-af)# neighbor 1.1.1.1 activate
Activate neighbor PE1
(config-router-af)# neighbor 2.2.2.2 activate
Activate neighbor PE2
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv6 unicast
Enter ipv6 unicast address family
(config-router-af)# neighbor 1.1.1.1 activate
Activate neighbor PE1
(config-router-af)# neighbor 2.2.2.2 activate
Activate neighbor PE2
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv4 vrf vrf102
Enter vrf vrf102 address family
(config-router-af)# redistribute connected
Redisdribute vrf connected routes to bgp
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv6 vrf vrf102
Enter ipv6 vrf vrf102 address family
(config-router-af)# redistribute connected
Redisdribute vrf connected routes to bgp
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv4 vrf vrf101
Enter vrf vrf102 address family
(config-router-af)# redistribute connected
Redisdribute vrf connected routes to bgp
(config-router-af)# exit-address-family
Exit address family
(config-router)# address-family ipv6 vrf vrf101
Enter ipv6 vrf vrf101 address family
(config-router-af)# redistribute connected
Redisdribute vrf connected routes to bgp
(config-router-af)# exit-address-family
Exit address family
(config-router)#exit
Exit bgp mode
(config)#commit
Commit the transaction.
L3 VRF Port Configuration:
 
(config-if)#interface xe13
Enter the Interface mode for xe3. This is for untagged traffic
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# ip address 201.1.1.1/24
Assign ipv4 address
(config-if)# ipv6 address 2001::1/64
Assign ipv6 address
(config-if)#interface xe13.1
Create subinterface xe13.1
(config-if)# encapsulation dot1q 10
Configure encapsulation single tagged
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# ip address 210.1.1.1/24
Assign ipv4 address
(config-if)# ipv6 address 2100::1/64
Assign ipv6 address
(config-if)#interface xe13.2
Create subinterface xe13.2
(config-if)# encapsulation dot1q 11 inner-dot1q 11
Configure encapsulation double tagged
(config-if)# ip vrf forwarding vrf101
Map the vrf vrf101
(config-if)# ip address 220.1.1.1/24
Assign ipv4 address
(config-if)# ipv6 address 2200::1/64
Assign ipv6 address
(config)#commit
Commit the transaction.
Validation
PE1
 
7030-PE1#sh mlag domain summary
------------------------------------
Domain Configuration
------------------------------------
 
Domain System Number : 1
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : xe4
Domain Adjacency : UP
Domain Sync via : Intra-domain-interface
------------------------------------
MLAG Configuration
------------------------------------
 
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : a2 58 27 76 9f 45 ff 6c 2a 62 65 aa b6 22 8f 81
Total Bandwidth : 0
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Active
Switchover-mode : Revertive
 
7030-PE1#
Note:
PE1#sh etherchannel summary
Aggregator po1 100001
Aggregator Type: Layer2
Admin Key: 16385 - Oper Key 16385
Link: xe10 (5011) sync: 1 (Mlag-Active-link)
--------------------------------------
Aggregator po2 100002
Aggregator Type: Layer3
Admin Key: 0002 - Oper Key 0002
Link: xe18 (10025) sync: 1
Link: xe19 (10026) sync: 1
PE1#sh evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
1.1.1.1 5.5.5.5 Installed 02:22:38 02:22:38 102
 
Total number of entries are 1
PE1#sh ip bgp vrf all
BGP table version is 1, local router ID is 120.1.1.1
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
 
BGP Route Table for VRF vrf101
*>i 45.1.1.0/24 5.5.5.5 0 100 0 ?
*>i 52.1.1.0/24 5.5.5.5 0 100 0 ?
*> 100.1.1.0/24 0.0.0.0 0 100 32768 ?
*>i 101.101.101.2/32 5.5.5.5 0 100 0 ?
*> 101.101.101.101/32
0.0.0.0 0 100 32768 ?
*> 110.1.1.0/24 0.0.0.0 0 100 32768 ?
*> 111.1.1.0/24 0.0.0.0 0 100 32768 ?
* 0.0.0.0 1 100 32768 ?
*> 120.1.1.0/24 0.0.0.0 0 100 32768 ?
*>i 201.1.1.0 5.5.5.5 0 100 0 ?
*>i 210.1.1.0 5.5.5.5 0 100 0 ?
*>i 220.1.1.0 5.5.5.5 0 100 0 ?
 
Total number of prefixes 11
 
BGP Route Table for VRF vrf102
*>i 45.1.1.0/24 5.5.5.5 0 100 0 ?
*> 51.1.1.0/24 0.0.0.0 0 100 32768 ?
*>i 52.1.1.0/24 5.5.5.5 0 100 0 ?
*>i 101.101.101.2/32 5.5.5.5 0 100 0 ?
*>i 201.1.1.0 5.5.5.5 0 100 0 ?
*>i 210.1.1.0 5.5.5.5 0 100 0 ?
*>i 220.1.1.0 5.5.5.5 0 100 0 ?
 
Total number of prefixes 7
*>i 5.5.5.5/32 5.5.5.5 0 100 0 i
 
Total number of prefixes 1
PE1#sh bgp l2vpn evpn prefix-route
 
RD[10002:1]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 201.1.1.0 0.0.0.0 17 5.5.5.5 MPLS 0000:0000:0000
0 0 24 210.1.1.0 0.0.0.0 17 5.5.5.5 MPLS 0000:0000:0000
0 0 24 220.1.1.0 0.0.0.0 17 5.5.5.5 MPLS 0000:0000:0000
0 0 64 2001:: :: 17 5.5.5.5 MPLS 0000:0000:0000
0 0 64 2100:: :: 17 5.5.5.5 MPLS 0000:0000:0000
0 0 64 2200:: :: 17 5.5.5.5 MPLS 0000:0000:0000
PE1#sh mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
O> 5.5.5.5/32 7 16005 16005 N/A po2 10.1.1.2 Yes LSP_DEFAULT
O> 3.3.3.3/32 5 16003 3 N/A po2 10.1.1.2 Yes LSP_DEFAULT
B> vrf101 2 17 Nolabel N/A vrf101 N/A Yes LSP_DEFAULT
B> vrf102 1 16 Nolabel N/A vrf102 N/A Yes LSP_DEFAULT
O> 4.4.4.4/32 6 16004 3 N/A ce0 20.1.1.2 Yes LSP_DEFAULT
L> 4.4.4.4/32 10 35202 3 N/A ce0 20.1.1.2 Yes LSP_DEFAULT
L> 3.3.3.3/32 8 35200 3 N/A po2 10.1.1.2 Yes LSP_DEFAULT
L> 60.1.1.0/24 9 35201 3 N/A po2 10.1.1.2 Yes LSP_DEFAULT
O> 20.1.1.2/32 3 35840 3 N/A ce0 20.1.1.2 Yes LSP_DEFAULT
L> 70.1.1.0/24 12 35204 3 N/A ce0 20.1.1.2 Yes LSP_DEFAULT
O> 10.1.1.2/32 4 35841 3 N/A po2 10.1.1.2 Yes LSP_DEFAULT
PE1#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 3.3.3.3/32 1 5 0 Yes LSP_DEFAULT 3 po2 No 10.1.1.2
L 3.3.3.3/32 9 4 - Yes LSP_DEFAULT 3 po2 No 10.1.1.2
O> 4.4.4.4/32 2 6 0 Yes LSP_DEFAULT 3 ce0 No 20.1.1.2
L 4.4.4.4/32 4 3 - Yes LSP_DEFAULT 3 ce0 No 20.1.1.2
O> 5.5.5.5/32 3 8 0 Yes LSP_DEFAULT 16005 po2 No 10.1.1.2
L 5.5.5.5/32 5 13 - Yes LSP_DEFAULT 34567 po2 No 10.1.1.2
14 - Yes LSP_DEFAULT 34566 ce0 No 20.1.1.2
L> 50.1.1.0/24 7 15(e)
4 - Yes LSP_DEFAULT 3 po2 No 10.1.1.2
3 - Yes LSP_DEFAULT 3 ce0 No 20.1.1.2
L> 60.1.1.0/24 10 16
4 - Yes LSP_DEFAULT 3 po2 No 10.1.1.2
L> 70.1.1.0/24 8 10
3 - Yes LSP_DEFAULT 3 ce0 No 20.1.1.2
PE1#
PE2
 
PE2#show mlag domain summary
 
------------------------------------
Domain Configuration
------------------------------------
 
Domain System Number : 2
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : xe4
Domain Adjacency : UP
Domain Sync via : Intra-domain-interface
------------------------------------
MLAG Configuration
------------------------------------
 
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : a2 58 27 76 9f 45 ff 6c 2a 62 65 aa b6 22 8f 81
Total Bandwidth : 0
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Standby
Switchover-mode : Revertive
 
 
PE2#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
2.2.2.2 5.5.5.5 Installed 1d02h23m 1d02h23m 101
 
 
Total number of entries are 1
 
PE2#show evpn mpls tunnel label
EVPN-MPLS Network tunnel labels
(*) in Policy - tunnel-policy inherited from mac-vrf
================+===========+=========+===============+=========+=========+=========+=========+============+=========+============+========
Local Remote MPLS-Multipath Underlay
Destination Status VPN-ID Policy MC-Label UC-Label MC-Label UC-Label Grp-Name NHLFE-ix NW-Intf NW-Label
================+===========+=========+===============+=========+=========+=========+=========+============+=========+============+========
5.5.5.5 Installed 101 -- -- 17 -- -- -- -- -- --
 
Total number of entries are 1
PE2#show bgp l2vpn evpn prefix-route
 
RD[10002:1]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 45.1.1.0 0.0.0.0 17 5.5.5.5 MPLS 0000:0000:0000
0 0 24 52.1.1.0 0.0.0.0 17 5.5.5.5 MPLS 0000:0000:0000
0 0 24 201.1.1.0 0.0.0.0 17 5.5.5.5 MPLS 0000:0000:0000
0 0 24 210.1.1.0 0.0.0.0 17 5.5.5.5 MPLS 0000:0000:0000
0 0 24 220.1.1.0 0.0.0.0 17 5.5.5.5 MPLS 0000:0000:0000
0 0 32 101.101.101.2 0.0.0.0 17 5.5.5.5 MPLS 0000:0000:0000
0 0 64 2001:: :: 17 5.5.5.5 MPLS 0000:0000:0000
0 0 64 2100:: :: 17 5.5.5.5 MPLS 0000:0000:0000
0 0 64 2200:: :: 17 5.5.5.5 MPLS 0000:0000:0000
PE2#show ip bgp vrf all
BGP table version is 1, local router ID is 0.0.0.0
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
 
BGP Route Table for VRF vrf101
*>i 201.1.1.0 5.5.5.5 0 100 0 ?
*>i 210.1.1.0 5.5.5.5 0 100 0 ?
*>i 220.1.1.0 5.5.5.5 0 100 0 ?
 
Total number of prefixes 6
*>i 5.5.5.5/32 5.5.5.5 0 100 0 i
 
Total number of prefixes 1
PE2#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
O> 5.5.5.5/32 8 16005 16005 N/A xe6 30.1.1.2 Yes LSP_DEFAULT
O> 1.1.1.1/32 5 16001 16001 N/A xe6 30.1.1.2 Yes LSP_DEFAULT
B> vrf101 2 17 Nolabel N/A vrf101 N/A Yes LSP_DEFAULT
B> vrf102 1 16 Nolabel N/A vrf102 N/A Yes LSP_DEFAULT
O> 4.4.4.4/32 7 16004 3 N/A xe26 40.1.1.2 Yes LSP_DEFAULT
O> 3.3.3.3/32 6 16003 3 N/A xe6 30.1.1.2 Yes LSP_DEFAULT
L> 10.1.1.0/24 13 35204 3 N/A xe6 30.1.1.2 Yes LSP_DEFAULT
L> 20.1.1.0/24 10 35201 3 N/A xe26 40.1.1.2 Yes LSP_DEFAULT
L> 4.4.4.4/32 9 35200 3 N/A xe26 40.1.1.2 Yes LSP_DEFAULT
L> 3.3.3.3/32 12 35203 3 N/A xe6 30.1.1.2 Yes LSP_DEFAULT
L> 70.1.1.0/24 11 35202 3 N/A xe26 40.1.1.2 Yes LSP_DEFAULT
O> 30.1.1.2/32 3 35840 3 N/A xe6 30.1.1.2 Yes LSP_DEFAULT
L> 60.1.1.0/24 14 35205 3 N/A xe6 30.1.1.2 Yes LSP_DEFAULT
O> 40.1.1.2/32 4 35841 3 N/A xe26 40.1.1.2 Yes LSP_DEFAULT
PE2#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 1.1.1.1/32 1 6 0 Yes LSP_DEFAULT 16001 xe6 No 30.1.1.2
L 1.1.1.1/32 5 16 - Yes LSP_DEFAULT 34573 xe26 No 40.1.1.2
17 - Yes LSP_DEFAULT 34573 xe6 No 30.1.1.2
O> 3.3.3.3/32 2 7 0 Yes LSP_DEFAULT 3 xe6 No 30.1.1.2
L 3.3.3.3/32 6 3 - Yes LSP_DEFAULT 3 xe6 No 30.1.1.2
O> 4.4.4.4/32 3 8 0 Yes LSP_DEFAULT 3 xe26 No 40.1.1.2
L 4.4.4.4/32 11 4 - Yes LSP_DEFAULT 3 xe26 No 40.1.1.2
O> 5.5.5.5/32 4 10 0 Yes LSP_DEFAULT 16005 xe6 No 30.1.1.2
L 5.5.5.5/32 7 19 - Yes LSP_DEFAULT 34575 xe26 No 40.1.1.2
20 - Yes LSP_DEFAULT 34575 xe6 No 30.1.1.2
L> 10.1.1.0/24 8 14
3 - Yes LSP_DEFAULT 3 xe6 No 30.1.1.2
L> 20.1.1.0/24 12 21
4 - Yes LSP_DEFAULT 3 xe26 No 40.1.1.2
L> 50.1.1.0/24 9 22(e)
4 - Yes LSP_DEFAULT 3 xe26 No 40.1.1.2
3 - Yes LSP_DEFAULT 3 xe6 No 30.1.1.2
L> 60.1.1.0/24 10 14
3 - Yes LSP_DEFAULT 3 xe6 No 30.1.1.2
L> 70.1.1.0/24 13 21
4 - Yes LSP_DEFAULT 3 xe26 No 40.1.1.2
PE2#
 
PE3:
 
PE3#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
5.5.5.5 1.1.1.1 Installed 2d05h17m 2d05h17m 102
5.5.5.5 1.1.1.1 Installed 2d05h17m 2d05h17m 101
 
Total number of entries are 2
PE3#show ip bgp vrf all
BGP table version is 1, local router ID is 220.1.1.1
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
 
BGP Route Table for VRF vrf101
*> 45.1.1.0/24 210.1.1.2 0 100 32768 ?
*>i 51.1.1.0/24 1.1.1.1 0 100 0 ?
*> 52.1.1.0/24 0.0.0.0 0 100 32768 ?
*>i 100.1.1.0/24 1.1.1.1 0 100 0 ?
*> 101.101.101.2/32 0.0.0.0 0 100 32768 ?
*>i 101.101.101.101/32
1.1.1.1 0 100 0 ?
*>i 110.1.1.0/24 1.1.1.1 0 100 0 ?
*>i 111.1.1.0/24 1.1.1.1 0 100 0 ?
*>i 120.1.1.0/24 1.1.1.1 0 100 0 ?
*> 201.1.1.0 0.0.0.0 0 100 32768 ?
*> 210.1.1.0 0.0.0.0 0 100 32768 ?
*> 220.1.1.0 0.0.0.0 0 100 32768 ?
 
Total number of prefixes 12
 
...skipping 1 line
BGP Route Table for VRF vrf102
*>i 51.1.1.0/24 1.1.1.1 0 100 0 ?
 
Total number of prefixes 1
*> 5.5.5.5/32 0.0.0.0 0 100 32768 i
 
Total number of prefixes 1
 
PE3#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
O> 4.4.4.4/32 6 16004 3 N/A xe20 70.1.1.1 Yes LSP_DEFAULT
B> vrf101 2 17 Nolabel N/A vrf101 N/A Yes LSP_DEFAULT
B> vrf102 1 16 Nolabel N/A vrf102 N/A Yes LSP_DEFAULT
O> 3.3.3.3/32 5 16003 3 N/A ce3 60.1.1.1 Yes LSP_DEFAULT
O> 1.1.1.1/32 12 16001 16001 N/A ce3 60.1.1.1 Yes LSP_DEFAULT
L> 20.1.1.0/24 10 35203 3 N/A xe20 70.1.1.1 Yes LSP_DEFAULT
L> 4.4.4.4/32 8 35201 3 N/A xe20 70.1.1.1 Yes LSP_DEFAULT
L> 3.3.3.3/32 7 35200 3 N/A ce3 60.1.1.1 Yes LSP_DEFAULT
L> 40.1.1.0/24 9 35202 3 N/A xe20 70.1.1.1 Yes LSP_DEFAULT
O> 70.1.1.1/32 4 35840 3 N/A xe20 70.1.1.1 Yes LSP_DEFAULT
L> 10.1.1.0/24 11 35204 3 N/A ce3 60.1.1.1 Yes LSP_DEFAULT
O> 60.1.1.1/32 3 35841 3 N/A ce3 60.1.1.1 Yes LSP_DEFAULT
PE3#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 1.1.1.1/32 9 13 0 Yes LSP_DEFAULT 16001 ce3 No 60.1.1.1
L 1.1.1.1/32 10 14 - Yes LSP_DEFAULT 34566 ce3 No 60.1.1.1
16 - Yes LSP_DEFAULT 34564 xe20 No 70.1.1.1
O> 3.3.3.3/32 1 6 0 Yes LSP_DEFAULT 3 ce3 No 60.1.1.1
L 3.3.3.3/32 3 3 - Yes LSP_DEFAULT 3 ce3 No 60.1.1.1
O> 4.4.4.4/32 2 7 0 Yes LSP_DEFAULT 3 xe20 No 70.1.1.1
L 4.4.4.4/32 5 4 - Yes LSP_DEFAULT 3 xe20 No 70.1.1.1
L> 10.1.1.0/24 8 8
3 - Yes LSP_DEFAULT 3 ce3 No 60.1.1.1
L> 20.1.1.0/24 7 10
4 - Yes LSP_DEFAULT 3 xe20 No 70.1.1.1
L> 40.1.1.0/24 6 10
4 - Yes LSP_DEFAULT 3 xe20 No 70.1.1.1
L> 50.1.1.0/24 4 11(e)
4 - Yes LSP_DEFAULT 3 xe20 No 70.1.1.1
3 - Yes LSP_DEFAULT 3 ce3 No 60.1.1.1
PE3
 
PE3#show bgp l2vpn evpn prefix-route
 
RD[10001:1]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 100.1.1.0 0.0.0.0 17 1.1.1.1 MPLS 0000:0000:0000
0 0 24 110.1.1.0 0.0.0.0 17 1.1.1.1 MPLS 0000:0000:0000
0 0 24 111.1.1.0 0.0.0.0 17 1.1.1.1 MPLS 0000:0000:0000
0 0 24 120.1.1.0 0.0.0.0 17 1.1.1.1 MPLS 0000:0000:0000
0 0 64 1000:: :: 17 1.1.1.1 MPLS 0000:0000:0000
0 0 64 1100:: :: 17 1.1.1.1 MPLS 0000:0000:0000
0 0 64 1110:: :: 17 1.1.1.1 MPLS 0000:0000:0000
0 0 64 1200:: :: 17 1.1.1.1 MPLS 0000:0000:0000
 
RD[10001:102]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 51.1.1.0 0.0.0.0 16 1.1.1.1 MPLS 0000:0000:0000
PE3#