OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : LDP ECMP Configuration
LDP ECMP Configuration
This chapter contains configurations of LDP ECMP detailed tests that are used to verify the functionality of LDP ECMP (Equal-cost multipath).
Topology
LDP-ECMP configuration topology
Configurations
PE-1
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 111.111.111.111/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 111.111.111.111
Configure Router-id
(config-router)#targeted-peer ipv4 222.222.222.222
Configuring targeted LDP sessions to PE-2
(config-router)#explicit-null
Configure explicit-null.
(config-router)#entropy-label-capability
Enable entropy capability in ldp
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit from targeted-peer mode
(config-router)#transport-address ipv4 111.111.111.111
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface xe13
Enter interface mode
(config-if)#speed 1g
Configure interface speed to 1g
(config-if)#ip address 10.0.1.10/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po1000
Enter the Interface mode for po1000
(config-if)#exit
Exit interface mode
(config)#interface po1000.1000
Enter interface mode for po1000.1000
(config-if)#encapsulation dot1q 1000
Configure encapsulation under a subinterface
(config-if)#ip address 10.0.0.10/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface xe4
Enter interface mode
(config-if)#speed 1g
Configure interface speed to 1g
(config-if)#ip address 16.0.0.10/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface xe4.1001
Enter interface mode
(config-if)#encapsulation dot1q 1001
Configure encapsulation under a subinterface
(config-if)#ip address 16.0.1.10/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface xe12
Enter interface mode
(config-if)#speed 1g
Configure interface speed to 1g
(config-if)#channel-group 1000 mode active
Moving interface to Dynamic LAG
(config-if)#exit
Exit interface mode
(config)#ip vrf l3vpnvrf300
IP VRF config with name l3vpnvrf300
(config-vrf)#rd 300:1
Route-distinguisher value
(config-vrf)#route-target both 300:1
Route target value
(config-vrf)#exit
Exit to config mode
(config)#router ospf 100
Configure the routing process and specify the Process ID, (100). The Process ID should be a unique positive integer to identifying the routing process.
(config-router)#ospf router-id 111.111.111.111
Configure ospf Router-id
(config-router)#network 10.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.0.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 16.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 16.0.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 111.111.111.111/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#router bgp 100
Configure router bgp in AS 100
(config-router)#bgp router-id 111.111.111.111
Configure BGP router ID
(config-router)#neighbor 222.222.222.222 remote-as 100
Configure neighbor in remote-as 100
(config-router)#neighbor 222.222.222.222 update-source lo
Configure neighbor with update-source loopback
(config-router)#address-family vpnv4 unicast
Enter VPNv4 Address family mode
(config-router-af)#neighbor 222.222.222.222 activate
mode Activate VPNv4 neighbor
(config-router-af)#exit-address-family
Exit from Address Family configuration
(config-router)#address-family l2vpn vpls
Enter vpls Address family mode
(config-router-af)#neighbor 222.222.222.222 activate
mode Activate vpls neighbor
(config-router-af)#exit-address-family
Exit from Address Family configuration
(config-router)#address-family vrf l3vpnvrf300
Configure VRF address family
(config-router-af)#redistribute connected
Redistribute connected addresses
(config-router-af)#exit-address-family
Exit from Address Family configuration
(config-router)#exit
Exit from router mode
(config)#mpls vplsldp100 100
Configuring VPLS instance with name and VPLS ID
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance
(config-vpls-sig)# vpls-peer 222.222.222.222
Configuring VPLS mesh peers
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config)#mpls l2-circuit VPWS400 400 222.222.222.222
Configuring VPWS instance with name and VPWS ID
(config)#mpls vpls vplsbgp200 200
Configuring VPLS instance with name and VPLS ID
(config-vpls)#signaling bgp
Enabling LDP signaling for the VPLS instance
(config-vpls-sig)#ve-id 200
Configure VE ID, which is mandatory for BGP VPLS,
otherwise, signaling does not take place. VE ID should be
 
unique per VPLS instance
 
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config-if)#interface xe8.100 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 100
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls vplsldp100
Associating the VPLS Instance to the attachment circuit interface.
(config-acc-if-vpls)#exit
Exit from access mode
(config-if)#interface xe8.400 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 400
Configure encapsulation under a subinterface
(config-if)#access-if-vpws
Access VPWS under sub interface
(config-acc-if-vpws)#mpls-vpws VPWS400
Associating the VPWS Instance to the attachment circuit interface.
(config-acc-if-vpws)#exit
Exit from access mode
(config-if)#interface xe8.200 switchport
Enter sub interface mode
(config-if)#split-horizon group access1
Configure split-horizon group on sub-interface
(config-if)#split-horizon group access1
Configure split-horizon group on sub-interface
(config-if)#encapsulation dot1q 200
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls vplsbgp200
Associating the VPLS Instance to the attachment circuit interface.
(config-acc-if-vpls)#exit
Exit from access mode
(config-if)#interface xe8.300
Enter sub interface mode
(config-if)#encapsulation dot1q 300
Configure encapsulation under a subinterface
(config-if)#ip vrf forwarding l3vpnvrf300
Attaching xe8.300 to as part of l3vpnvrf300
(config-if)#ip address 110.110.110.1/24
Configure the IP address of the interface.
(config-if)#exit
Exit interface mode
(config)#commit
Commit the configuration
(config)#end
Return to privilege mode
 
P1
 
#configure terminal
Enter Configure mode.
(config)#mpls ilm-ecmp
Enable ilm ecmp
(config)#interface lo
Enter interface mode
(config -if)#ip address 11.11.11.11/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 11.11.11.11
Configure Router-id
(config-router)#transport-address ipv4 11.11.11.11
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface ge13
Enter interface mode
(config-if)#ip address 10.0.1.20/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po1000
Enter the Interface mode for po1000
(config-if)#exit
Exit interface mode
(config)#interface po1000.1000
Enter interface mode for po1000.1000
(config-if)#encapsulation dot1q 1000
Configure encapsulation under a subinterface
(config-if)#ip address 10.0.0.20/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po2000
Enter the Interface mode for po2000
(config-if)#exit
Exit interface mode
(config)#interface po2000.100
Enter interface mode for po2000.100
(config-if)#encapsulation dot1q 100
Configure encapsulation under a subinterface
(config-if)#ip address 11.0.0.10/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface ge4
Enter interface mode
(config-if)#ip address 9.0.0.10/24
Configure IP address on interface
(config-if)#ip ospf cost 20
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface ge12
Enter interface mode
(config-if)#channel-group 1000 mode active
Moving interface to Dynamic LAG
(config)#interface xe23
Enter interface mode
(config-if)#channel-group 2000 mode active
Moving interface to Dynamic LAG
(config-if)#speed 1g
Configure speed 1g
(config)#interface xe24
Enter interface mode
(config-if)#channel-group 2000 mode active
Moving interface to Dynamic LAG
(config-if)#speed 1g
Configure speed 1g
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID, (100). The Process ID should be a unique positive integer to identifying the routing process.
(config-router)#ospf router-id 11.11.11.11
Configure ospf Router-id
(config-router)#network 10.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.0.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 11.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 9.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 11.11.11.11/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#exit
Exit from router mode
(config)#commit
Commit the transaction.
P2
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 22.22.22.22/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 22.22.22.22
Configure Router-id
(config-router)#transport-address ipv4 22.22.22.22
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface ge6.300
Enter interface mode
(config-if)#encapsulation dot1q 300
Configure encapsulation under a subinterface
(config-if)#ip address 15.0.0.10/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface ge6.1001
Enter interface mode
(config-if)#encapsulation dot1q 1001
Configure encapsulation under a subinterface
(config-if)#ip address 15.0.1.10/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po2000
Enter the Interface mode for po2000
(config-if)#exit
Exit interface mode
(config)#interface po2000.100
Enter interface mode for po2000.100
(config-if)#encapsulation dot1q 100
Configure encapsulation under a subinterface
(config-if)#ip address 11.0.0.20/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface ge5
Enter interface mode
(config-if)#channel-group 2000 mode active
Moving interface to Dynamic LAG
(config)#interface ge11
Enter interface mode
(config-if)#channel-group 2000 mode active
Moving interface to Dynamic LAG
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID, (100). The Process ID should be a unique positive integer to identifying the routing process.
(config-router)#ospf router-id 22.22.22.22
Configure ospf Router-id
(config-router)#network 15.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 15.0.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 11.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 22.22.22.22/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#exit
Exit from router mode
(config)#commit
Commit the transaction.
P3
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 33.33.33.33/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 33.33.33.33
Configure Router-id
(config-router)#transport-address ipv4 33.33.33.33
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface ge5
Enter interface mode
(config-if)#ip address 16.0.0.20/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface ge5.1001
Enter interface mode
(config-if)#encapsulation dot1q 1001
Configure encapsulation under a subinterface
(config-if)#ip address 16.0.1.20/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface sa4000
Enter the Interface mode for sa4000
(config-if)#exit
Exit interface mode
(config)#interface sa4000.200
Enter interface mode for psa4000.200
(config-if)#encapsulation dot1q 200
Configure encapsulation under a subinterface
(config-if)#ip address 17.0.0.20/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface xe12
Enter interface mode
(config-if)# static-channel-group 4000
Moving interface to Static LAG
(config)#interface xe13
Enter interface mode
(config-if)# static-channel-group 4000
Moving interface to Static LAG
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID, (100). The Process ID should be a unique positive integer to identifying the routing process.
(config-router)#ospf router-id 33.33.33.33
Configure ospf Router-id
(config-router)#network 16.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 16.0.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 17.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 33.33.33.33/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#exit
Exit from router mode
(config)#commit
Commit the transaction.
P4
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 44.44.44.44/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 44.44.44.44
Configure Router-id
(config-router)#transport-address ipv4 44.44.44.44
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface sa3000
Enter the Interface mode for sa3000
(config-if)#exit
Exit interface mode
(config)#interface sa3000
Enter interface mode
(config-if)#ip address 18.0.0.10/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface sa3000.1001
Enter interface mode
(config-if)#encapsulation dot1q 1001
Configure encapsulation under a subinterface
(config-if)#ip address 18.0.1.10/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface sa4000
Enter the Interface mode for sa4000
(config-if)#exit
Exit interface mode
(config)#interface sa4000.200
Enter interface mode for psa4000.200
(config-if)#encapsulation dot1q 200
Configure encapsulation under a subinterface
(config-if)#ip address 17.0.0.10/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface xe6
Enter interface mode
config-if)#speed 1g
Configure speed 1g
(config-if)#static-channel-group 3000
Moving interface to Static LAG
(config)#interface xe8
Enter interface mode
config-if)#speed 1g
Configure speed 1g
(config-if)#static-channel-group 3000
Moving interface to Static LAG
(config)#interface xe12
Enter interface mode
(config-if)# static-channel-group 4000
Moving interface to Static LAG
(config)#interface xe13
Enter interface mode
(config-if)# static-channel-group 4000
Moving interface to Static LAG
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID, (100). The Process ID should be a unique positive integer to identifying the routing process.
(config-router)#ospf router-id 44.44.44.44
Configure ospf Router-id
(config-router)#network 18.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 18.0.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 17.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 44.44.44.44/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#exit
Exit from router mode
(config)#commit
Commit the transaction.
PE2
 
#configure terminal
Enter Configure mode.
(config)#interface lo
Enter interface mode
(config -if)#ip address 222.222.222.222/32 secondary
Configure IP address for the loopback interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 222.222.222.222
Configure Router-id
(config-router)#targeted-peer ipv4 111.111.111.111
Configuring targeted LDP sessions to PE-2
(config-router)#explicit-null
Configure explicit-null.
(config-router)#entropy-label-capability
Enable entropy capability in ldp
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit from targeted-peer mode
(config-router)#transport-address ipv4 222.222.222.222
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface xe14
Enter interface mode
(config-if)#speed 1g
Configure interface speed to 1g
(config)#interface xe14.1001
Enter interface mode
(config-if)#encapsulation dot1q 1001
Configure encapsulation under a subinterface
(config-if)#ip address 15.0.1.20/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface xe14.1002
Enter interface mode
(config-if)#encapsulation dot1q 300
Configure encapsulation under a subinterface
(config-if)#ip address 15.0.0.20/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface sa3000
Enter interface mode
(config-if)#ip address 18.0.0.20/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface sa3000.1001
Enter interface mode
(config-if)#encapsulation dot1q 1001
Configure encapsulation under a subinterface
(config-if)#ip address 18.0.1.20/24
Configure IP address on interface
(config-if)#ip ospf cost 10
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface ge5
Enter interface mode
(config-if)# static-channel-group 3000
Moving interface to static LAG
(config-if)#interface ge7
Enter interface mode
(config-if)# static-channel-group 3000
Moving interface to static LAG
(config-if)#exit
Exit interface mode
(config)#interface ge9
Enter interface mode
(config-if)#ip address 9.0.0.20/24
Configure IP address on interface
(config-if)#ip ospf cost 20
Assign ospf cost to the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#ip vrf l3vpnvrf300
IP VRF config with name l3vpnvrf300
(config-vrf)#rd 300:1
Route-distinguisher value
(config-vrf)#route-target both 300:1
Route target value
(config-vrf)#exit
Exit to config mode
(config)#router ospf 100
Configure the routing process and specify the Process ID, (100). The Process ID should be a unique positive integer to identifying the routing process.
(config-router)#ospf router-id 222.222.222.222
Configure ospf Router-id
(config-router)#network 9.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 15.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 15.0.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 18.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 18.0.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 222.222.222.222/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#router bgp 100
Configure router bgp in AS 100
(config-router)#bgp router-id 222.222.222.222
Configure BGP router ID
(config-router)#neighbor 111.111.111.111 remote-as 100
Configure neighbor in remote-as 100
(config-router)#neighbor 111.111.111.111 update-source lo
Configure neighbor with update-source loopback
(config-router)#address-family vpnv4 unicast
Enter VPNv4 Address family mode
(config-router-af)#neighbor 111.111.111.111 activate
mode Activate VPNv4 neighbor
(config-router-af)#exit-address-family
Exit from Address Family configuration
(config-router)#address-family l2vpn vpls
Enter vpls Address family mode
(config-router-af)#neighbor 111.111.111.111 activate
mode Activate vpls neighbor
(config-router-af)#exit-address-family
Exit from Address Family configuration
(config-router)#address-family vrf l3vpnvrf300
Configure VRF address family
(config-router-af)#redistribute connected
Redistribute connected addresses
(config-router-af)#exit-address-family
Exit from Address Family configuration
(config-router)#exit
Exit from router mode
(config)#mpls vplsldp100 100
Configuring VPLS instance with name and VPLS ID
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance
(config-vpls-sig)# vpls-peer 111.111.111.111
Configuring VPLS mesh peers
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config)#mpls l2-circuit VPWS400 400 111.111.111.111
Configuring VPWS instance with name and VPWS ID
(config)#mpls vpls vplsbgp200 200
Configuring VPLS instance with name and VPLS ID
(config-vpls)#signaling bgp
Enabling LDP signaling for the VPLS instance
(config-vpls-sig)#ve-id 201
Configure VE ID, which is mandatory for BGP VPLS,otherwise, signaling does not take place. VE ID should be unique per VPLS instance
 
 
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config-if)#interface xe12.100 switchport
Enter sub interface mode
(config-if)#split-horizon group access1
Configure split-horizon group on sub-interface
(config-if)#encapsulation dot1q 100
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls vplsldp100
Associating the VPLS Instance to the attachment circuit interface.
(config-acc-if-vpls)#exit
Exit from access mode
(config-if)#interface xe12.400 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 400
Configure encapsulation under a subinterface
(config-if)#access-if-vpws
Access VPWS under sub interface
(config-acc-if-vpws)#mpls-vpws VPWS400
Associating the VPWS Instance to the attachment circuit interface.
(config-acc-if-vpws)#exit
Exit from access mode
(config-if)#interface xe12.200 switchport
Enter sub interface mode
(config-if)#split-horizon group access1
Configure split-horizon group on sub-interface
(config-if)#encapsulation dot1q 200
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls vplsbgp200
Associating the VPLS Instance to the attachment circuit interface.
(config-acc-if-vpls)#exit
Exit from access mode
(config-if)#interface xe12.300
Enter sub interface mode
(config-if)#encapsulation dot1q 300
Configure encapsulation under a subinterface
(config-if)#ip vrf forwarding l3vpnvrf300
Attaching xe12.300 to as part of l3vpnvrf300
(config-if)#ip address 210.210.210.1/24
Configure the IP address of the interface.
(config-if)#exit
Exit interface mode
(config)#commit
Commit the configuration
(config)#end
Return to privilege mode
Validation
PE1
 
---
---
PE1#show ip ospf neighbor
 
Total number of full neighbors: 4
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
11.11.11.11 1 Full/Backup 00:00:30 10.0.0.20 po1000.1000 0
11.11.11.11 1 Full/Backup 00:00:34 10.0.1.20 xe13 0
33.33.33.33 1 Full/Backup 00:00:34 16.0.0.20 xe4 0
33.33.33.33 1 Full/Backup 00:00:34 16.0.1.20 xe4.1001 0
PE1#
 
PE1#show ip ospf interface brief
Interface PID Area Intf ID Cost State Neighbors Status
lo 100 0.0.0.0 1 1 Loopback 0 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
xe4 100 0.0.0.0 10005 10 DR 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
xe13 100 0.0.0.0 10014 10 DR 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
xe4.1001 100 0.0.0.0 327844841 10 DR 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
po1000.1000 100 0.0.0.0 524289000 10 DR 1 Up
 
PE1#
 
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
11.11.11.11 xe13 Active OPERATIONAL 30 00:00:33
33.33.33.33 xe4.1001 Active OPERATIONAL 30 00:00:33
222.222.222.222 xe4.1001 Passive OPERATIONAL 30 00:00:22
PE1#
 
 
PE1#show bgp neighbors
BGP neighbor is 222.222.222.222, remote AS 100, local AS 100, internal link
BGP version 4, local router ID 111.111.111.111, remote router ID 222.222.222.222
BGP state = Established, up for 00:00:27
Last read 00:00:08, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family VPNv4 Unicast: advertised and received
Address family L2VPN VPLS: advertised and received
Address family L2VPN EVPN: advertised and received
Address family IPv6 Unicast: advertised and received
Address family VPNv6 Unicast: advertised and received
Address family IPv6 Labeled Unicast: advertised and received
Received 11 messages, 0 notifications, 0 in queue
Sent 13 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
 
For address family: VPNv4 Unicast
BGP table version 2, neighbor version 2
Index 1, Offset 0, Mask 0x2
AIGP is enabled
Community attribute sent to this neighbor (both)
Large Community attribute sent to this neighbor
1 accepted prefixes
1 announced prefixes
 
For address family: L2VPN VPLS
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
Large Community attribute sent to this neighbor
0 accepted prefixes
1 announced prefixes
 
Connections established 1; dropped 0
Local host: 111.111.111.111, Local port: 179
Foreign host: 222.222.222.222, Foreign port: 35033
Nexthop: 111.111.111.111
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
PE1#
 
 
PE1#show mpls vpls
Name VPLS-ID Type MPeers SPeers SIG-Protocol Learning
vplsldp100 100 Ethernet 1 0 LDP Enabled
vplsbgp200 200 Ethernet 1 0 BGP Enabled
PE1#
 
 
PE1#show mpls vpls mesh
(m) - Service mapped over multipath transport
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
100 222.222.222.222 25611 26253 xe13 26246 2/Up 1 LDP Active
200 222.222.222.222 25611 25608 xe13 25607 2/Up 3 BGP Active
PE1#
 
 
PE1#show mpls vc-table
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
400
 
PE1#show mpls l2-circuit
MPLS Layer-2 Virtual Circuit: VPWS400, id: 400 PW-INDEX: 2 service-tpid: dot1.q
Endpoint: 222.222.222.222
Control Word: 0
Flow Label Status: Disabled, Direction: None, Static: No
MPLS Layer-2 Virtual Circuit Group: none
Bound to interface: xe8.400
Subinterface Match Criteria(s) :
dot1q 400
Virtual Circuit Type: Ethernet VLAN
Virtual Circuit is configured as Primary
Virtual Circuit is configured as Active
Virtual Circuit is active
 
PE1#
 
 
PE1#show mpls vrf-forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, B - BGP FTN
(m) - Service mapped over multipath transport
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf Nexthop
B> 210.210.210.0/24 1 - - LSP_DEFAULT 25664 - 222.222.222.222
B> 210::/64 2 - - LSP_DEFAULT 25664 - 222.222.222.222
PE1#
 
 
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 9.0.0.0/24 1 73(e)
52 - Yes LSP_DEFAULT 3 xe13 No 10.0.1.20
71 - No LSP_DEFAULT 0 xe4 No 222.222.222.222
(via 16.0.0.20 ,label 25612)
53 - Yes LSP_DEFAULT 3 po1000.1000 No 10.0.0.20
71 - No LSP_DEFAULT 0 xe4 No 222.222.222.222
(via 16.0.0.20 ,label 25612)
L> 11.0.0.0/24 2 73(e)
52 - Yes LSP_DEFAULT 3 xe13 No 10.0.1.20
71 - No LSP_DEFAULT 0 xe4 No 222.222.222.222
(via 16.0.0.20 ,label 25612)
53 - Yes LSP_DEFAULT 3 po1000.1000 No 10.0.0.20
71 - No LSP_DEFAULT 0 xe4 No 222.222.222.222
(via 16.0.0.20 ,label 25612)
L> 11.11.11.11/32 3 100(e)
52 - Yes LSP_DEFAULT 3 xe13 No 10.0.1.20
53 - No LSP_DEFAULT 3 po1000.1000 No 10.0.0.20
53 - Yes LSP_DEFAULT 3 po1000.1000 No 10.0.0.20
52 - No LSP_DEFAULT 3 xe13 No 10.0.1.20
L> 15.0.0.0/24 4 77(e)
56 - Yes LSP_DEFAULT 25600 xe13 No 10.0.1.20
71 - No LSP_DEFAULT 0 xe4 No 222.222.222.222
(via 16.0.0.20 ,label 25612)
57 - Yes LSP_DEFAULT 25600 po1000.1000 No 10.0.0.20
71 - No LSP_DEFAULT 0 xe4 No 222.222.222.222
(via 16.0.0.20 ,label 25612)
L> 15.0.1.0/24 5 80(e)
60 - Yes LSP_DEFAULT 25601 xe13 No 10.0.1.20
71 - No LSP_DEFAULT 0 xe4 No 222.222.222.222
(via 16.0.0.20 ,label 25612)
61 - Yes LSP_DEFAULT 25601 po1000.1000 No 10.0.0.20
71 - No LSP_DEFAULT 0 xe4 No 222.222.222.222
(via 16.0.0.20 ,label 25612)
L> 17.0.0.0/24 6 84(e)
16 - Yes LSP_DEFAULT 3 xe4 No 16.0.0.20
82 - No LSP_DEFAULT 26249 po1000.1000 No 222.222.222.222
(via 10.0.0.20 ,label 25611)
17 - Yes LSP_DEFAULT 3 xe4.1001 No 16.0.1.20
82 - No LSP_DEFAULT 26249 po1000.1000 No 222.222.222.222
(via 10.0.0.20 ,label 25611)
L> 18.0.0.0/24 7 88(e)
19 - Yes LSP_DEFAULT 25608 xe4 No 16.0.0.20
86 - No LSP_DEFAULT 0 po1000.1000 No 222.222.222.222
(via 10.0.0.20 ,label 25611)
20 - Yes LSP_DEFAULT 25608 xe4.1001 No 16.0.1.20
86 - No LSP_DEFAULT 0 po1000.1000 No 222.222.222.222
(via 10.0.0.20 ,label 25611)
L> 18.0.1.0/24 8 91(e)
22 - Yes LSP_DEFAULT 25609 xe4 No 16.0.0.20
86 - No LSP_DEFAULT 0 po1000.1000 No 222.222.222.222
(via 10.0.0.20 ,label 25611)
23 - Yes LSP_DEFAULT 25609 xe4.1001 No 16.0.1.20
86 - No LSP_DEFAULT 0 po1000.1000 No 222.222.222.222
(via 10.0.0.20 ,label 25611)
L> 22.22.22.22/32 9 94(e)
64 - Yes LSP_DEFAULT 25607 xe13 No 10.0.1.20
71 - No LSP_DEFAULT 0 xe4 No 222.222.222.222
(via 16.0.0.20 ,label 25612)
65 - Yes LSP_DEFAULT 25607 po1000.1000 No 10.0.0.20
71 - No LSP_DEFAULT 0 xe4 No 222.222.222.222
(via 16.0.0.20 ,label 25612)
L> 33.33.33.33/32 10 102(e)
16 - Yes LSP_DEFAULT 3 xe4 No 16.0.0.20
17 - No LSP_DEFAULT 3 xe4.1001 No 16.0.1.20
17 - Yes LSP_DEFAULT 3 xe4.1001 No 16.0.1.20
16 - No LSP_DEFAULT 3 xe4 No 16.0.0.20
L> 44.44.44.44/32 11 98(e)
28 - Yes LSP_DEFAULT 25611 xe4 No 16.0.0.20
96 - No LSP_DEFAULT 26251 po1000.1000 No 222.222.222.222
(via 10.0.0.20 ,label 25611)
29 - Yes LSP_DEFAULT 25611 xe4.1001 No 16.0.1.20
96 - No LSP_DEFAULT 26251 po1000.1000 No 222.222.222.222
(via 10.0.0.20 ,label 25611)
L> 222.222.222.222/32 12 104(e)
68 - Yes LSP_DEFAULT 25611 xe13 Yes 10.0.1.20
31 - No LSP_DEFAULT 25612 xe4 Yes 16.0.0.20
69 - Yes LSP_DEFAULT 25611 po1000.1000 Yes 10.0.0.20
31 - No LSP_DEFAULT 25612 xe4 Yes 16.0.0.20
31 - Yes LSP_DEFAULT 25612 xe4 Yes 16.0.0.20
69 - No LSP_DEFAULT 25611 po1000.1000 Yes 10.0.0.20
32 - Yes LSP_DEFAULT 25612 xe4.1001 Yes 16.0.1.20
69 - No LSP_DEFAULT 25611 po1000.1000 Yes 10.0.0.20
B> 220::/64 13 49 - - LSP_DEFAULT 25665 - No 222.222.222.222
PE1#
 
 
PE1#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
po1000 350.55 4850 250.40 3466
po1000.1000 350.55 4851 250.39 3465
xe0 0.00 0 0.00 0
xe2 0.00 0 0.00 0
xe4 400.63 5546 500.68 6932
xe4.1001 400.63 5545 250.40 3465
xe8 997.81 13858 997.81 13858
xe8.400 997.80 13858 997.80 13858
xe12 350.56 4850 250.40 3466
xe13 250.28 3467 250.29 3466
PE1#
 
 
P1
---
 
 
P1#show ip ospf interface brief
Interface PID Area Intf ID Cost State Neighbors Status
lo 100 0.0.0.0 1 1 Loopback 0 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
ge8 100 0.0.0.0 10009 20 Backup 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
ge13 100 0.0.0.0 10014 10 Backup 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
po1000.1000 100 0.0.0.0 524289000 10 Backup 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
po2000.100 100 0.0.0.0 557056100 10 Backup 1 Up
 
P1#
 
P1#show ip ospf neighbor
 
Total number of full neighbors: 4
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
222.222.222.222 1 Full/DR 00:00:38 9.0.0.20 ge8 0
111.111.111.111 1 Full/DR 00:00:36 10.0.0.10 po1000.1000 0
111.111.111.111 1 Full/DR 00:00:34 10.0.1.10 ge13 0
22.22.22.22 1 Full/DR 00:00:38 11.0.0.20 po2000.100 0
P1#
 
P1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
22.22.22.22 po2000.100 Passive OPERATIONAL 30 00:01:27
222.222.222.222 ge8 Passive OPERATIONAL 30 00:00:19
111.111.111.111 ge13 Passive OPERATIONAL 30 00:00:32
33.33.33.33 ge13 Passive OPERATIONAL 30 00:00:21
44.44.44.44 po2000.100 Passive OPERATIONAL 30 00:00:14
P1#
 
P1#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
ge8 190.14 2634 250.19 3464
ge10 0.00 0 0.00 0
ge12 250.30 3465 350.42 4848
ge13 250.19 3465 250.19 3465
po1000 250.30 3465 350.42 4849
po1000.1000 250.31 3465 350.42 4848
po2000 410.50 5680 250.30 3464
po2000.100 410.50 5681 250.30 3464
xe23 220.26 3048 120.15 1663
xe24 190.23 2632 130.16 1801
xe26 0.00 0 0.00 0
P1#
 
 
P1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
LDP ilm-ecmp - enabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
L> 111.111.111.111/32 22 25621 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25621 0 N/A po1000.1000 10.0.0.10 No LSP_DEFAULT
25621 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
25621 0 N/A ge13 10.0.1.10 No LSP_DEFAULT
L> 16.0.1.0/24 9 25608 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25608 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 15.0.0.0/24 3 25602 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25602 0 N/A ge8 9.0.0.20 No LSP_DEFAULT
L> 15.0.1.0/24 2 25601 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25601 0 N/A ge8 9.0.0.20 No LSP_DEFAULT
L> 15.0.0.0/24 1 25600 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25600 0 N/A ge8 9.0.0.20 No LSP_DEFAULT
L> 16.0.0.0/24 5 25604 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25604 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 15.0.1.0/24 4 25603 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25603 0 N/A ge8 9.0.0.20 No LSP_DEFAULT
L> 18.0.1.0/24 7 25606 25604 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25606 0 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
25606 3 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
L> 18.0.0.0/24 6 25605 25603 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25605 0 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
25605 3 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
L> 22.22.22.22/32 8 25607 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25607 26267 N/A ge8 9.0.0.20 No LSP_DEFAULT
L> 111.111.111.111/32 17 25616 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25616 0 N/A po1000.1000 10.0.0.10 No LSP_DEFAULT
25616 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
25616 0 N/A ge13 10.0.1.10 No LSP_DEFAULT
L> 16.0.1.0/24 14 25613 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25613 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 18.0.0.0/24 11 25610 25603 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25610 0 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
L> 17.0.0.0/24 10 25609 26245 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25609 26245 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 16.0.0.0/24 13 25612 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25612 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 222.222.222.222/32 12 25611 25607 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25611 0 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
25611 25624 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
L> 17.0.0.0/24 15 25614 26245 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25614 3 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
25614 26245 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
25614 3 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
L> 33.33.33.33/32 16 25615 26249 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25615 25622 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
25615 26249 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
25615 25622 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
L> 22.22.22.22/32 19 25618 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25618 26267 N/A ge8 9.0.0.20 No LSP_DEFAULT
L> 18.0.1.0/24 18 25617 25604 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25617 0 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
L> 33.33.33.33/32 20 25619 26249 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25619 26249 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 44.44.44.44/32 21 25620 25606 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25620 26269 N/A ge8 9.0.0.20 No LSP_DEFAULT
25620 26250 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25620 26269 N/A ge8 9.0.0.20 No LSP_DEFAULT
25620 26250 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
25620 26269 N/A ge8 9.0.0.20 No LSP_DEFAULT
25620 26269 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
25620 26250 N/A po1000.1000 10.0.0.10 No LSP_DEFAULT
L> 33.33.33.33/32 32 25631 26249 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25631 26249 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 16.0.0.0/24 26 25625 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25625 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 15.0.0.0/24 24 25623 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25623 0 N/A ge8 9.0.0.20 No LSP_DEFAULT
L> 222.222.222.222/32 23 25622 25607 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25622 0 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
L> 15.0.1.0/24 25 25624 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25624 0 N/A ge8 9.0.0.20 No LSP_DEFAULT
L> 17.0.0.0/24 28 25627 26245 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25627 26245 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 16.0.1.0/24 27 25626 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25626 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 18.0.1.0/24 30 25629 25604 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25629 0 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
L> 18.0.0.0/24 29 25628 25603 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25628 0 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
L> 22.22.22.22/32 31 25630 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25630 26267 N/A ge8 9.0.0.20 No LSP_DEFAULT
L> 16.0.0.0/24 38 25637 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25637 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 15.0.0.0/24 36 25635 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
L> 111.111.111.111/32 34 25633 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25633 0 N/A po1000.1000 10.0.0.10 No LSP_DEFAULT
25633 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
25633 0 N/A ge13 10.0.1.10 No LSP_DEFAULT
L> 44.44.44.44/32 33 25632 25606 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25632 26269 N/A ge8 9.0.0.20 No LSP_DEFAULT
25632 26250 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25632 26269 N/A ge8 9.0.0.20 No LSP_DEFAULT
25632 26250 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
25632 26269 N/A ge8 9.0.0.20 No LSP_DEFAULT
25632 26269 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
25632 26250 N/A po1000.1000 10.0.0.10 No LSP_DEFAULT
L> 222.222.222.222/32 35 25634 25607 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
25634 0 N/A ge8 9.0.0.20 Yes LSP_DEFAULT
L> 15.0.1.0/24 37 25636 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
L> 22.22.22.22/32 41 25640 3 N/A po2000.100 11.0.0.20 Yes LSP_DEFAULT
L> 16.0.1.0/24 39 25638 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25638 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
L> 17.0.0.0/24 40 25639 26245 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25639 3 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
25639 26245 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
25639 3 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
L> 111.111.111.111/32 43 25642 0 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25642 0 N/A po1000.1000 10.0.0.10 No LSP_DEFAULT
25642 0 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
25642 0 N/A ge13 10.0.1.10 No LSP_DEFAULT
L> 33.33.33.33/32 42 25641 26249 N/A ge13 10.0.1.10 Yes LSP_DEFAULT
25641 25622 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
25641 26249 N/A po1000.1000 10.0.0.10 Yes LSP_DEFAULT
25641 25622 N/A ge8 44.44.44.44 No LSP_DEFAULT
(via 9.0.0.20 ,label 26269)
P1#
P2
---
P2#show ip ospf interface brief
Interface PID Area Intf ID Cost State Neighbors Status
lo 100 0.0.0.0 1 1 Loopback 0 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
ge6.300 100 0.0.0.0 328171820 10 Backup 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
ge6.1001 100 0.0.0.0 328172521 10 Backup 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
po2000.100 100 0.0.0.0 557056100 10 DR 1 Up
 
P2#
 
P2#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
11.11.11.11 1 Full/Backup 00:00:32 11.0.0.10 po2000.100 0
222.222.222.222 1 Full/DR 00:00:36 15.0.0.20 ge6.300 0
222.222.222.222 1 Full/DR 00:00:35 15.0.1.20 ge6.1001 0
P2#
 
 
P2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
222.222.222.222 ge6.1001 Passive OPERATIONAL 30 00:00:21
11.11.11.11 po2000.100 Active OPERATIONAL 30 00:01:27
33.33.33.33 po2000.100 Passive OPERATIONAL 30 00:00:14
P2#
P3
---
P3#show ip ospf interface brief
Interface PID Area Intf ID Cost State Neighbors Status
lo 100 0.0.0.0 1 1 Loopback 0 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
ge5 100 0.0.0.0 10014 10 Backup 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
ge5.1001 100 0.0.0.0 328139753 10 Backup 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
sa4000.200 100 0.0.0.0 1179648200 10 Backup 1 Up
 
P3#
 
P3#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
111.111.111.111 1 Full/DR 00:00:38 16.0.0.10 ge5 0
111.111.111.111 1 Full/DR 00:00:32 16.0.1.10 ge5.1001 0
44.44.44.44 1 Full/DR 00:00:36 17.0.0.10 sa4000.200 0
P3#
 
P3#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
44.44.44.44 sa4000.200 Passive OPERATIONAL 30 00:02:00
111.111.111.111 ge5 Passive OPERATIONAL 30 00:00:32
22.22.22.22 ge5 Active OPERATIONAL 30 00:00:14
11.11.11.11 ge5 Active OPERATIONAL 30 00:00:20
222.222.222.222 sa4000.200 Passive OPERATIONAL 30 00:00:13
P3#
P4
---
P4#show ip ospf interface brief
Interface PID Area Intf ID Cost State Neighbors Status
lo 100 0.0.0.0 1 1 Loopback 0 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
sa3000 100 0.0.0.0 203000 10 Backup 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
sa3000.1001 100 0.0.0.0 1146881001 10 Backup 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
sa4000.200 100 0.0.0.0 1179648200 10 DR 1 Up
 
P4#
 
 
P4#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
33.33.33.33 1 Full/Backup 00:00:34 17.0.0.20 sa4000.200 0
222.222.222.222 1 Full/DR 00:00:36 18.0.0.20 sa3000 0
222.222.222.222 1 Full/DR 00:00:34 18.0.1.20 sa3000.1001 0
P4#
 
 
P4#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
222.222.222.222 sa3000 Passive OPERATIONAL 30 00:00:40
33.33.33.33 sa4000.200 Active OPERATIONAL 30 00:02:00
11.11.11.11 sa4000.200 Active OPERATIONAL 30 00:00:14
P4#
PE2
---
 
PE2#show ip ospf neighbor
 
Total number of full neighbors: 5
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
11.11.11.11 1 Full/Backup 00:00:36 9.0.0.10 ge9 0
22.22.22.22 1 Full/Backup 00:00:31 15.0.0.10 xe14.1002 0
22.22.22.22 1 Full/Backup 00:00:34 15.0.1.10 xe14.1001 0
44.44.44.44 1 Full/Backup 00:00:38 18.0.0.10 sa3000 0
44.44.44.44 1 Full/Backup 00:00:31 18.0.1.10 sa3000.1001 0
PE2#
 
PE2#show ip ospf interface brief
Interface PID Area Intf ID Cost State Neighbors Status
lo 100 0.0.0.0 1 1 Loopback 0 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
ge9 100 0.0.0.0 10018 20 DR 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
sa3000 100 0.0.0.0 203000 10 DR 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
xe14.1001 100 0.0.0.0 328434665 10 DR 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
xe14.1002 100 0.0.0.0 328434666 10 DR 1 Up
 
Interface PID Area Intf ID Cost State Neighbors Status
sa3000.1001 100 0.0.0.0 1146881001 10 DR 1 Up
 
PE2#
 
 
PE2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
44.44.44.44 sa3000 Active OPERATIONAL 30 00:00:41
11.11.11.11 ge9 Active OPERATIONAL 30 00:00:18
22.22.22.22 xe14.1002 Active OPERATIONAL 30 00:00:25
111.111.111.111 xe14.1001 Active OPERATIONAL 30 00:00:22
33.33.33.33 sa3000 Active OPERATIONAL 30 00:00:14
PE2#
 
 
PE2#show bgp neighbors
BGP neighbor is 111.111.111.111, remote AS 100, local AS 100, internal link
BGP version 4, local router ID 222.222.222.222, remote router ID 111.111.111.111
BGP state = Established, up for 00:00:27
Last read 00:00:01, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family VPNv4 Unicast: advertised and received
Address family L2VPN VPLS: advertised and received
Address family L2VPN EVPN: advertised and received
Address family IPv6 Unicast: advertised and received
Address family VPNv6 Unicast: advertised and received
Address family IPv6 Labeled Unicast: advertised and received
Received 12 messages, 0 notifications, 0 in queue
Sent 11 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
 
For address family: VPNv4 Unicast
BGP table version 2, neighbor version 2
Index 1, Offset 0, Mask 0x2
AIGP is enabled
Community attribute sent to this neighbor (both)
Large Community attribute sent to this neighbor
1 accepted prefixes
1 announced prefixes
 
For address family: L2VPN VPLS
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
Large Community attribute sent to this neighbor
0 accepted prefixes
1 announced prefixes
 
Connections established 1; dropped 0
Local host: 222.222.222.222, Local port: 35033
Foreign host: 111.111.111.111, Foreign port: 179
Nexthop: 222.222.222.222
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
PE2#
 
PE2#show mpls vpls
Name VPLS-ID Type MPeers SPeers SIG-Protocol Learning
vplsldp100 100 Ethernet 1 0 LDP Enabled
vplsbgp200 200 Ethernet 1 0 BGP Enabled
PE2#
 
 
PE2#show mpls vpls mesh
(m) - Service mapped over multipath transport
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
100 111.111.111.111 25614 26246 sa3000.1001 26253 2/Up 1 LDP Active
200 111.111.111.111 25614 25607 sa3000.1001 25608 2/Up 3 BGP Active
PE2#
 
PE2#show mpls vc-table
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
400 N/A N/A xe12.400 N/A (e) 26252 N/A (e) 111.111.111.111 Active
PE2#
 
PE2#show mpls l2-circuit
MPLS Layer-2 Virtual Circuit: VPWS400, id: 400 PW-INDEX: 2 service-tpid: dot1.q
Endpoint: 111.111.111.111
Control Word: 0
Flow Label Status: Disabled, Direction: None, Static: No
MPLS Layer-2 Virtual Circuit Group: none
Bound to interface: xe12.400
Subinterface Match Criteria(s) :
dot1q 400
Virtual Circuit Type: Ethernet VLAN
Virtual Circuit is configured as Primary
Virtual Circuit is configured as Active
Virtual Circuit is active
 
PE2#
 
 
 
PE2#show mpls vrf-forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, B - BGP FTN
(m) - Service mapped over multipath transport
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf Nexthop
B> 110.110.110.0/24 2 - - LSP_DEFAULT 25664 - 111.111.111.111
B> 110::/64 1 - - LSP_DEFAULT 25664 - 111.111.111.111
PE2#
 
 
PE2#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 10.0.0.0/24 8 56(e)
54 - Yes LSP_DEFAULT 25617 xe14.1001 No 15.0.1.10
33 - No LSP_DEFAULT 3 ge9 No 9.0.0.10
55 - Yes LSP_DEFAULT 25617 xe14.1002 No 15.0.0.10
33 - No LSP_DEFAULT 3 ge9 No 9.0.0.10
33 - Yes LSP_DEFAULT 3 ge9 No 9.0.0.10
38 - No LSP_DEFAULT 0 ge9 No 111.111.111.111
(via 9.0.0.10 ,label 25642)
L> 10.0.1.0/24 9 59(e)
57 - Yes LSP_DEFAULT 25618 xe14.1001 No 15.0.1.10
33 - No LSP_DEFAULT 3 ge9 No 9.0.0.10
58 - Yes LSP_DEFAULT 25618 xe14.1002 No 15.0.0.10
33 - No LSP_DEFAULT 3 ge9 No 9.0.0.10
33 - Yes LSP_DEFAULT 3 ge9 No 9.0.0.10
38 - No LSP_DEFAULT 0 ge9 No 111.111.111.111
(via 9.0.0.10 ,label 25642)
L> 11.0.0.0/24 11 63(e)
60 - Yes LSP_DEFAULT 3 xe14.1001 No 15.0.1.10
61 - Yes LSP_DEFAULT 3 xe14.1002 No 15.0.0.10
62 - No LSP_DEFAULT 26255 ge9 No 111.111.111.111
(via 9.0.0.10 ,label 25642)
L> 11.11.11.11/32 10 68(e)
66 - Yes LSP_DEFAULT 25619 xe14.1001 No 15.0.1.10
33 - No LSP_DEFAULT 3 ge9 No 9.0.0.10
67 - Yes LSP_DEFAULT 25619 xe14.1002 No 15.0.0.10
33 - No LSP_DEFAULT 3 ge9 No 9.0.0.10
33 - Yes LSP_DEFAULT 3 ge9 No 9.0.0.10
40 - No LSP_DEFAULT 26256 ge9 No 111.111.111.111
(via 9.0.0.10 ,label 25642)
L> 16.0.0.0/24 1 42(e)
1 - Yes LSP_DEFAULT 25604 sa3000.1001 No 18.0.1.10
38 - No LSP_DEFAULT 0 ge9 No 111.111.111.111
(via 9.0.0.10 ,label 25642)
2 - Yes LSP_DEFAULT 25604 sa3000 No 18.0.0.10
38 - No LSP_DEFAULT 0 ge9 No 111.111.111.111
(via 9.0.0.10 ,label 25642)
L> 16.0.1.0/24 2 43(e)
4 - Yes LSP_DEFAULT 25605 sa3000.1001 No 18.0.1.10
38 - No LSP_DEFAULT 0 ge9 No 111.111.111.111
(via 9.0.0.10 ,label 25642)
5 - Yes LSP_DEFAULT 25605 sa3000 No 18.0.0.10
38 - No LSP_DEFAULT 0 ge9 No 111.111.111.111
(via 9.0.0.10 ,label 25642)
L> 17.0.0.0/24 3 53(e)
7 - Yes LSP_DEFAULT 3 sa3000.1001 No 18.0.1.10
52 - No LSP_DEFAULT 3 ge9 No 33.33.33.33
(via 9.0.0.10 ,label 25641)
8 - Yes LSP_DEFAULT 3 sa3000 No 18.0.0.10
52 - No LSP_DEFAULT 3 ge9 No 33.33.33.33
(via 9.0.0.10 ,label 25641)
L> 22.22.22.22/32 12 69(e)
60 - Yes LSP_DEFAULT 3 xe14.1001 No 15.0.1.10
61 - No LSP_DEFAULT 3 xe14.1002 No 15.0.0.10
61 - Yes LSP_DEFAULT 3 xe14.1002 No 15.0.0.10
60 - No LSP_DEFAULT 3 xe14.1001 No 15.0.1.10
L> 33.33.33.33/32 4 45(e)
10 - Yes LSP_DEFAULT 25606 sa3000.1001 No 18.0.1.10
44 - No LSP_DEFAULT 26263 ge9 No 111.111.111.111
(via 9.0.0.10 ,label 25642)
11 - Yes LSP_DEFAULT 25606 sa3000 No 18.0.0.10
44 - No LSP_DEFAULT 26263 ge9 No 111.111.111.111
(via 9.0.0.10 ,label 25642)
L> 44.44.44.44/32 5 31(e)
7 - Yes LSP_DEFAULT 3 sa3000.1001 No 18.0.1.10
8 - No LSP_DEFAULT 3 sa3000 No 18.0.0.10
8 - Yes LSP_DEFAULT 3 sa3000 No 18.0.0.10
7 - No LSP_DEFAULT 3 sa3000.1001 No 18.0.1.10
L> 111.111.111.111/32 6 73(e)
71 - Yes LSP_DEFAULT 25622 xe14.1001 Yes 15.0.1.10
36 - No LSP_DEFAULT 25642 ge9 Yes 9.0.0.10
72 - Yes LSP_DEFAULT 25622 xe14.1002 Yes 15.0.0.10
36 - No LSP_DEFAULT 25642 ge9 Yes 9.0.0.10
36 - Yes LSP_DEFAULT 25642 ge9 Yes 9.0.0.10
17 - No LSP_DEFAULT 25614 sa3000 Yes 18.0.0.10
16 - Yes LSP_DEFAULT 25614 sa3000.1001 Yes 18.0.1.10
36 - No LSP_DEFAULT 25642 ge9 Yes 9.0.0.10
17 - Yes LSP_DEFAULT 25614 sa3000 Yes 18.0.0.10
36 - No LSP_DEFAULT 25642 ge9 Yes 9.0.0.10
B> 120::/64 7 23 - - LSP_DEFAULT 25665 - No 111.111.111.111
PE2#
 
PE2#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
ge4 0.00 0 0.00 0
ge5 240.28 3327 210.29 2913
ge6 0.00 0 0.00 0
ge7 260.29 3603 190.27 2635
ge9 250.29 3466 190.22 2635
ge10 0.00 0 0.00 0
sa3000 500.58 6930 400.56 5548
sa3000.1001 0.00 0 200.33 2774
xe12 997.83 13858 997.83 13858
xe12.400 997.83 13858 997.83 13858
xe14 250.40 3468 410.66 5685
xe14.1001 0.00 1 58.53 811
xe14.1002 250.40 3467 200.33 2772
PE2#