OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : LDP-VPLS Service Mapping Configuration
LDP-VPLS Service Mapping Configuration
Overview
This chapter includes step-by-step configurations for LDP VPLS. It also contains an overview of the concepts of LDP VPLS. Virtual Private LAN Service (VPLS) is a way to provide Ethernet-based multipoint-to-multipoint communication over IP- MPLS networks. It allows geographically-dispersed sites to share an Ethernet broadcast domain by connecting sites through pseudowires.
Topology
The diagram depicts the topology for the configuration examples that follow.
LDP-VPLS service mappring
Configuration
PE1: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 21.21.21.21/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
PE1: Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 21.21.21.21
Set the router ID to IP address 21.21.21.21
(config-router)#transport-address ipv4 21.21.21.21
Configure transport address
(config-router)#targeted-peer ipv4 23.23.23.23
Configure targeted peer
(config-router)#targeted-peer #commit
Commit candidate configuration to the running configuration
(config-router-targeted-peer)#end
Exit from router target peer and LDP mode
PE1: Interface Configuration
 
#configure terminal
Enter configuration mode
(config)#interface xe2
Enter the Interface mode for xe2.
(config-if)# ip address 10.10.23.21/24
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)# label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
PE1: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#ospf router-id 21.21.21.21
Router-id configurations
(config-router)#network 21.21.21.21/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 10.10.23.0/24 area 0
Advertise network address in OSPF.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
PE1: LDP VPLS Configuration
 
(config)#mpls vpls v1 25
Enter VPLS config mode
(config-vpls)#service-tpid dot1.ad
Service tp-id configuration.
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 23.23.23.23
Configure VPLS Peer
(config-vpls-sig)#exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v2 26
Enter VPLS config mode
(config-vpls)#service-tpid dot1.ad
Service tp-id configuration.
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 23.23.23.23
Configure VPLS Peer
(config-vpls-sig)#exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v3 27
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 23.23.23.23
Configure VPLS Peer
(config-vpls-sig)# exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v4 28
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 23.23.23.23
Configure VPLS Peer
(config-vpls-sig)# exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#commit
Commit candidate configuration to the running configuration
P: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 22.22.22.22/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
P: Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 22.22.22.22
Set the router ID to IP address 22.22.22.22
(config-router)#transport-address ipv4 22.22.22.22
Configure transport address
(config-router)#commit
Commit candidate configuration to the running configuration
(config-router-targeted-peer)#end
Exit from router target peer and LDP mode
P: Interface Configuration
 
#configure terminal
Enter configuration mode
(config)#interface xe1
Enter the Interface mode for xe1.
(config-if)# ip address 10.10.23.22/24
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)# label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe2
Enter the Interface mode for xe2.
(config-if)# ip address 10.10.21.22/24
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)# label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
P: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#network 22.22.22.22/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 10.10.23.0/24 area 0
Advertise network address in OSPF.
(config-router)#network 10.10.21.0/24 area 0
Advertise network address in OSPF.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#commit
Commit candidate configuration to the running configuration
PE2: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 23.23.23.23/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
PE2: Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 23.23.23.23
Set the router ID to IP address 23.23.23.23
(config-router)#transport-address ipv4 23.23.23.23
Configure transport address
(config-router)#targeted-peer ipv4 21.21.21.21
Configure targeted peer
(config-router-targeted-peer)#commit
Commit candidate configuration to the running configuration
(config-router-targeted-peer)#end
Exit from router target peer and LDP mode
PE2: Interface Configuration
 
#configure terminal
Enter configuration mode.
(config)#interface xe1
Enter the Interface mode for xe1.
(config-if)# ip address 10.10.21.23/24
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)# label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
PE2: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#network 23.23.23.23/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 10.10.21.0/24 area 0
Advertise network address in OSPF.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
PE2: LDP VPLS Configuration
 
(config)#mpls vpls v1 25
Enter VPLS config mode
(config-vpls)#service-tpid dot1.ad
Service tp-id configuration.
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 21.21.21.21
Configure VPLS Peer
(config-vpls-sig)# exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v2 26
Enter VPLS config mode
(config-vpls)#service-tpid dot1.ad
Service tp-id configuration.
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 21.21.21.21
Configure VPLS Peer
(config-vpls-sig)# exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v3 27
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 21.21.21.21
Configure VPLS Peer
(config-vpls-sig)# exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#mpls vpls v4 28
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 21.21.21.21
Configure VPLS Peer
(config-vpls-sig)# exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#commit
Commit candidate configuration to the running configuration
LDP VPLS Service Mapping Configuration
PE1: POP
 
#configure terminal
Configure mode
(config)#service-template template1
Template configuration
(config-svc)# match double-tag outer-vlan 2024 inner-vlan 2023
Match criteria under template configuration
(config-svc)# rewrite ingress pop outgoing-tpid dot1.q
Action to be performed for the match.
(config-svc)#exit
Exit template configuration mode
PE1: XLATE
 
(config)#service-template template2
Template configuration
(config-svc)# match double-tag outer-vlan 2030 inner-vlan 2024
Match criteria under template configuration
(config-svc)# rewrite ingress translate 2026 outgoing-tpid dot1.q
Action to be performed for the match
(config-svc)#exit
Exit template configuration mode
PE1: PUSH
 
(config)#service-template template3
Template configuration
(config-svc)# match outer-vlan 500
Match criteria under template configuration
(config-svc)# rewrite ingress push 300
Action to be performed for the default match.
(config-svc)#exit
Exit template configuration mode
PE1: PUSH-service-template with multiple match support
This is to validate the multiple match criteria support in a service template. When multiple match statements are configured only rewrite push is supported, rewrite translate and pop are not supported.
 
(config)#service-template template4
Template configuration
(config-svc)# match outer-vlan 700
Allow VLAN 700 traffic on this VC
(config-svc)# match double-tag outer-vlan 1200 inner-vlan 3200
Allow double tag match with s+c tags
(config-svc)# match untagged
Allow untagged traffic
(config-svc)# rewrite ingress push 300
Push Action performed for service template
(config-svc)#exit
Exit configure SVC mode
PE1: Access port Configuration
 
(config)#interface xe1
Enter the Interface mode for xe1.
(config-if)#switchport
Configure interface as a layer 2 port.
(config-if)#mpls-vpls v1 service-template template1
Bind the VPLS to the Access Interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v2 service-template template2
Bind the VPLS to the Access Interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v3 service-template template3
Bind the VPLS to the Access Interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v4 service-template template4
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit candidate configuration to the running configuration
PE2: POP
 
#configure terminal
Configure mode
(config)#service-template template1
Template configuration
(config-svc)# match double-tag outer-vlan 2024 inner-vlan 2023
Match criteria under template configuration
(config-svc)# rewrite ingress pop outgoing-tpid dot1.q
Action to be performed for the match.
(config-svc)#exit
Exit template configuration mode
PE2: XLATE
 
(config)#service-template template2
Template configuration
(config-svc)# match double-tag outer-vlan 2030 inner-vlan 2024
Match criteria under template configuration
(config-svc)# rewrite ingress translate 2026 outgoing-tpid dot1.q
Action to be performed for the match
(config-svc)#exit
Exit template configuration mode
PE2: PUSH
 
(config)#service-template template3
Template configuration
(config-svc)# match outer-vlan 500
Match criteria under template configuration
(config-svc)# rewrite ingress push 300
Action to be performed for the default match.
(config-svc)#exit
Exit template configuration mode
PE2: PUSH-service-template with multiple match
This is to validate the multiple match criteria support in a service template. When multiple match statements are configured only rewrite push is supported, rewrite translate and pop are not supported.
 
(config)#service-template template4
Template configuration
(config-svc)# match outer-vlan 700
Allow VLAN 700 traffic on this VC
(config-svc)# match double-tag outer-vlan 1200 inner-vlan 3200
Allow double tag match with s+c tags
(config-svc)# match untagged
Allow untagged traffic
(config-svc)# rewrite ingress push 300
Push Action performed for service template
(config-svc)#exit
Exit configure SVC mode
PE2: Access port Configuration
 
(config)#interface xe2
Enter the Interface mode for xe2.
(config-if)#switchport
Configure interface as a layer 2 port.
(config-if)#mpls-vpls v1 service-template template1
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v2 service-template template2
Bind the VPLS to the Access Interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v3 service-template template3
Bind the VPLS to the Access Interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls v4 service-template template4
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit candidate configuration to the running configuration
Validation
 
show mpls vpls mesh
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status Ecmp-Group
25 23.23.23.23 24320 24322 xe2 24320 2/Up 1 LDP Active N/A
26 23.23.23.23 24320 24320 xe2 24321 2/Up 2 LDP Active N/A
27 23.23.23.23 24320 24321 xe2 24322 2/Up 3 LDP Active N/A
28 23.23.23.23 24320 24323 xe2 24324 2/Up 3 LDP Active N/A
 
#show ldp vpls
VPLS-ID Peer Address State Type Label-Sent Label-Rcvd
25 23.23.23.23 Up vlan 24322 24320
26 23.23.23.23 Up vlan 24320 24321
27 23.23.23.23 Up vlan 24321 24322
28 23.23.23.23 Up vlan 24323 24324
 
#show ldp vpls detail
VPLS Identifier : 25
Peer IP : 23.23.23.23
VC State : UP
VC Type : vlan
VC Label Sent : 24322
VC Label Received : 24320
 
VPLS Identifier : 26
Peer IP : 23.23.23.23
VC State : UP
VC Type : vlan
VC Label Sent : 24320
VC Label Received : 24321
 
VPLS Identifier : 27
Peer IP : 23.23.23.23
VC State : UP
VC Type : vlan
VC Label Sent : 24321
VC Label Received : 24322
 
VPLS Identifier : 28
Peer IP : 23.23.23.23
VC State : UP
VC Type : vlan
VC Label Sent : 24323
VC Label Received : 24324
 
#show mpls vpls detail
Virtual Private LAN Service Instance: v1, ID: 25
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.ad
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 88a8
Configured interfaces:
Interface: xe1
Service-template : template1
Match criteria : 2024/2023
 
Mesh Peers:
23.23.23.23 (Up)
 
 
Virtual Private LAN Service Instance: v2, ID: 26
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.ad
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 88a8
Configured interfaces:
Interface: xe1
Service-template : template2
Match criteria : 2030/2024
Action type : Translate
Action value : 2026
Outgoing tpid : dot1.q
 
Mesh Peers:
23.23.23.23 (Up)
 
 
Virtual Private LAN Service Instance: v3, ID: 27
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
Configured interfaces:
Interface: xe1
Service-template : template3
Match criteria : Accept all
Action type : Push
Action value : 300
 
Mesh Peers:
23.23.23.23 (Up)
 
Virtual Private LAN Service Instance: v4, ID: 28
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
Configured interfaces:
Interface: xe1
Service-template : template4
Match criteria : 700
1200/3200
Untagged
Action type : Push
Action value : 300
 
 
Mesh Peers:
23.23.23.23 (Up)