OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : Understanding Label Space
Understanding Label Space
This chapter contains configurations for Label Space. It also provides an overview of Label Space concepts.
Overview
The Label space refers to the scope of labels in a given LSR. It determines assignment and distribution of labels to a given peer. During data flow, it decides the key for looking up MPLS table and takes appropriate action based on the entry.
OcNOS supports per-platform label space, where a label must be unique for the entire platform. A label is interpreted the same way at all the interfaces. The FIB entry in the router does not contain incoming interface-related information. Thus the incoming traffic will be matched only with the label.
Topology
LDP Topology
PE1
 
PE1#configure terminal
Enter configure mode
PE1(config)#interface lo
Enter interface mode.
PE1(config-if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback address
PE1(config-if)#exit
Exit interface mode
PE1(config)#interface xe6
Specify the interface (xe6)to be configured
PE1(config-if)#ip address 10.10.10.1/24
Configure IP address for the interface
PE1(config-if)#no shutdown
Administratively bringing up the interface
PE1(config-if)#exit
Exit interface mode
PE1(config)#router ospf 100
Configure the routing process and specify the Process ID (100)
PE1(config-router)#ospf router-id 1.1.1.1
Configure OSPF router ID same as loopback IP address
PE1(config-router)#network 10.10.10.0/24 area 0
PE1(config-router)#network 1.1.1.1/32 area 0
Define the interface on which OSPF runs and associate the area ID(0)with the interface
PE1(config-router)#exit
Exit configure mode
PE1(config)#router ldp
Enter router mode for LDP
PE1(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1
PE1(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
PE1(config-router)# targeted-peer ipv4 3.3.3.3
Configure targeted peer.
PE1(config-router-targeted-peer)#exit
Exit from router target peer and LDP mode
PE1(config-if)#exit
Exit interface mode
PE1(config)#interface xe6
Specify the interface (xe6)to be configured
PE1(config-if)#label-switching
Enabling label switching capability on router
PE1(config-if)#enable-ldp ipv4
Enabling ldp on interface
PE1(config-if)#commit
Commit the transaction.
P
 
P#configure terminal
Enter configure mode.
P(config)#interface lo
Enter interface mode.
P(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback address
P(config-if)#exit
Exit interface mode
P(config)#interface xe6
Specify the interface (xe6)to be configured
P(config-if)#ip address 10.10.10.2/24
Configure IP address for the interface
P(config-if)#no shutdown
Administratively bringing up the interface
P(config)#interface xe1
Specify the interface (xe1)to be configured
P(config-if)#ip address 20.20.20.1/24
Configure IP address for the interface
P(config)#router ospf 100
Configure the routing process and specify the Process ID (100)
P(config-router)#ospf router-id 2.2.2.2
Configure OSPF router ID same as loopback IP address
P(config-router)#network 10.10.10.0/24 area 0
P(config-router)#network 20.20.20.0/24 area 0
P(config-router)#network 2.2.2.2/32 area 0
Define the interface on which OSPF runs and associate the area ID (0)with the interface
P(config-router)#exit
Exit router mode
P(config)#router ldp
Enter router mode for LDP
P(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2
P(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
P(config-router)#exit
Exit router mode for LDP
P(config)#mpls min-label-value 1000 max-label-value 50000 label-space 0
Configure the minimum label value and maximum label value to be used by Platform label space (Label space 0)
P(config)#interface xe6
Specify the interface (xe6)to be configured
P(config-if)#label-switching
Enabling label switching capability on router
P(config-if)#enable-ldp ipv4
Enabling ldp on interface
P(config-if)#exit
Exit interface mode
P(config)#interface xe1
Specify the interface (xe1) to be configured
P(config-if)#label-switching
Enabling label switching capability on router
P(config-if)#enable-ldp ipv4
Enabling ldp on interface
P(config-if)#commit
Commit the transaction.
PE2
 
PE2#configure terminal
Enter configure mode.
PE2(config)#interface lo
Enter interface mode.
PE2(config-if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback address
PE2(config-if)#exit
Exit interface mode
PE2(config)#interface xe1
Specify the interface (xe1)to be configured
PE2(config-if)#ip address 20.20.20.2/24
Configure IP address for the interface
PE2(config-if)#no shutdown
Administratively bringing up the interface
PE2(config-if)#exit
Exit interface mode
PE2(config)#router ospf 100
Configure the routing process and specify the Process ID (100)
PE2(config-router)#ospf router-id 3.3.3.3
Configure OSPF router ID same as loopback IP address
PE2(config-router)#network 20.20.20.0/24 area 0
PE2(config-router)#network 3.3.3.3/32 area 0
Define the interface on which OSPF runs and associate the area ID (0)with the interface
PE2(config-router)#exit
Exit router mode
PE2(config)#router ldp
Enter router mode for LDP
PE2(config-router)#router-id 3.3.3.3
Set the router ID to IP address 3.3.3.3
(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
PE2(config-router)# targeted-peer ipv4 1.1.1.1
Configure targeted peer.
PE1(config-router-targeted-peer)#exit
Exit from router target peer and LDP mode
PE2(config-router)#exit
Exit router mode for LDP
PE2(config)#interface xe1
Specify the interface (xe1) to be configured
PE2(config-if)#label-switching
Enabling label switching capability on router
PE2(config-if)#enable-ldp ipv4
Enabling ldp on interface
PE2(config-if)#commit
Commit the transaction.
Validation
PE1#show ldp
Router ID : 1.1.1.1
LDP Version : 1
Fast-reroute Per-prefix : Disabled
Global Merge Capability : Merge Capable
Label Advertisement Mode : Downstream Unsolicited
Label Retention Mode : Liberal
Label Control Mode : Independent
Instance Loop Detection : Off
Request Retry : Off
Propagate Release : Disabled
Graceful Restart : Disabled
Hello Interval : 5
Targeted Hello Interval : 15
Hold time : 15
Targeted Hold time : 45
Keepalive Interval : 10
Keepalive Timeout : 30
Request retry Timeout : 5
Auto Targeted Hello Receipt : Disabled
Transport Address data :
Labelspace 0 : 1.1.1.1 (in use)
Import BGP routes : No
 
PE1#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:30 10.10.10.2 xe1 0
 
P#show ldp
Router ID : 2.2.2.2
LDP Version : 1
Global Merge Capability : Merge Capable
Label Advertisement Mode : Downstream Unsolicited
Label Retention Mode : Liberal
Label Control Mode : Independent
Instance Loop Detection : Off
Request Retry : Off
Propagate Release : Disabled
Graceful Restart : Disabled
Hello Interval : 5
Targeted Hello Interval : 15
Hold time : 15
Targeted Hold time : 45
Keepalive Interval : 10
Keepalive Timeout : 30
Request retry Timeout : 5
Auto Targeted Hello Receipt: Disabled
Transport Address data :
Labelspace 0 : 2.2.2.2 (in use)
Import BGP routes : No
 
P#show mpls label-space 0
 
Label range (min - max) : 1000 - 50000
 
module-static
Default range : 1000 - 3839
 
module-srgb
Default range (Usable) : 3840 - 8739
Default range (Allotted) : 3840 - 8959
 
module-srlb
Default range (Usable) : 8960 - 9959
Default range (Allotted) : 8960 - 10239
 
module-rsvp
Configured range : N/A
Current dynamic range : N/A
 
module-ldp
Configured range : Not configured
Current dynamic range : 10880 - 11519
 
module-ldp-vc
Configured range : Not configured
Current dynamic range : 11520 - 12159
 
module-bgp
Configured range : N/A
Current dynamic range : N/A
 
P#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.12.49.142 1 Full/DR 00:00:34 10.10.10.1 xe1 0
10.12.49.158 1 Full/Backup 00:00:36 20.20.20.2 xe6 0
 
P#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM, ! - using backup
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
L> 1.1.1.1/32 2 10881 3 N/A eth3 10.10.10.1 Yes LSP_DEFAULT
L> 3.3.3.3/32 1 10880 3 N/A eth2 20.20.20.2 Yes LSP_DEFAULT
 
PE2#show ldp
Router ID : 3.3.3.3
LDP Version : 1
Fast-reroute Per-prefix : Disabled
Global Merge Capability : Merge Capable
Label Advertisement Mode : Downstream Unsolicited
Label Retention Mode : Liberal
Label Control Mode : Independent
Instance Loop Detection : Off
Request Retry : Off
Propagate Release : Disabled
Graceful Restart : Disabled
Hello Interval : 5
Targeted Hello Interval : 15
Hold time : 15
Targeted Hold time : 45
Keepalive Interval : 10
Keepalive Timeout : 30
Request retry Timeout : 5
Auto Targeted Hello Receipt : Disabled
Transport Address data :
Labelspace 0 : 3.3.3.3 (in use)
Import BGP routes : No
 
PE2#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:29 20.20.20.1 xe1 0