OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : MPLS Statistics Configuration
MPLS Statistics Configuration
This chapter provides the configuration required for configuring MPLS LSPs and verifying the statistics of packets captured at the supported interfaces, in terms of both packet count and bytes, when traffic is sent.
Configure LDP-LSP
Topology
MPLS Statistics Topology
RTR1: Loopback Interface configuration
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the interface (lo) to be configured.
(config-if)#ip address 11.11.11.11/32 secondary
Configure IP address on loopback interface
(config-if)#commit
Commit the transaction.
RTR1: Global LDP configuration
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 11.11.11.11
Configure the router-id
(config-router)#transport-address ipv4 11.11.11.11
Configure the loopback address as transport-address
(config-router)#targeted-peer ipv4 44.44.44.44
Configure the loopback address of RTR4 as targeted peer.
(config-router-targeted-peer)#exit
Exit router-targeted-peer mode and enter config-router mode
(config-router-targeted-peer)#commit
Commit the transaction.
RTR1: Enabling LDP and label switching on interface
 
(config)#interface xe2
Enter interface mode for xe2.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 10.10.10.1/24
Configure IP address on the interface.
(config-if)#commit
Commit the transaction.
RTR1: Global OSPF configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#network 11.11.11.11/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 10.10.10.0/24 area 0
Advertise network address (xe2) in OSPF.
(config-router)#commit
Commit the transaction.
RTR2: Loopback Interface configuration
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the interface (lo) to be configured.
(config-if)#ip address 22.22.22.22/32 secondary
Configure IP address on loopback interface
(config-if)#commit
Commit the transaction.
RTR2: Global LDP configuration
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 22.22.22.22
Configure the router-id
(config-router)#transport-address ipv4 22.22.22.22
Configure the loopback address as transport-address
(config-router)#commit
Commit the transaction.
RTR2: Enabling LDP and label switching on interface
 
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 10.10.10.2/24
Configure IP address on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode for xe2.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 20.20.20.1/24
Configure IP address on the interface.
(config-if)#commit
Commit the transaction.
RTR2: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode
(config-router)#network 22.22.22.22/32 area 0.0.0.0
Advertise loopback address in OSPF
(config-router)#network 10.10.10.2/24 area 0.0.0.0
Advertise network address (xe1) in OSPF.
(config-router)#network 20.20.20.1/24 area 0.0.0.0
Advertise network address (xe2) in OSPF.
(config-router)#commit
Commit the transaction.
RTR3: Loopback Interface configuration
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the interface (lo) to be configured.
(config-if)#ip address 33.33.33.33/32 secondary
Configure IP address on loopback interface
(config-if)#commit
Commit the transaction.
RTR3: Global LDP configuration
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 33.33.33.33
Configure the router-id
(config-router)#transport-address ipv4 33.33.33.33
Configure the loopback address as transport-address
(config-router)#commit
Commit the transaction.
RTR3: Enabling LDP and label switching on interface
 
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 20.20.20.2/24
Configure IP address on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode for xe2.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 30.30.30.1/24
Configure IP address on the interface.
(config-if)#commit
Commit the transaction.
RTR3: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode
(config-router)#network 33.33.33.33/32 area 0.0.0.0
Advertise loopback address in OSPF
(config-router)#network 20.20.20.2/24 area 0.0.0.0
Advertise network address (xe1) in OSPF.
(config-router)#network 30.30.30.1/24 area 0.0.0.0
Advertise network address (xe2) in OSPF.
(config-router)#commit
Commit the transaction.
RTR4: Loopback Interface configuration
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the interface (lo) to be configured.
(config-if)#ip address 44.44.44.44/32 secondary
Configure IP address on loopback interface
(config-if)#commit
Commit the transaction.
RTR4: Global LDP configuration
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 44.44.44.44
Configure the router-id
(config-router)#transport-address ipv4 44.44.44.44
Configure the loopback address as transport-address
(config-router)#targeted-peer ipv4 11.11.11.11
Configure the loopback address of RTR1 as targeted peer.
(config-router-targeted-peer)#exit
Exit router-targeted-peer mode and enter config-router mode
(config-router)#commit
Commit the transaction.
RTR4: Enabling LDP and label switching on interface
 
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 30.30.30.2/24
Configure IP address on the interface.
(config-if)#commit
Commit the transaction.
RTR4: Global OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode
(config-router)#network 44.44.44.44/32 area 0.0.0.0
Advertise loopback address in OSPF
(config-router)#network 30.30.30.2/24 area 0.0.0.0
Advertise network address (xe1) in OSPF.
(config-router)#commit
Commit the transaction.
MPLS LDP VPLS Configuration
RTR1: VPLS
 
(config)#mpls vpls vpls1 1
Enter the VPLS configuration mode
(config-vpls)# signaling ldp
Use LDP signaling for VPLS
(config-vpls-sig)#vpls-type ethernet
Configure the VPLS as Ethernet
(config-vpls-sig)#vpls-peer 44.44.44.44
Configure RTR4 as VPLS peer for RTR1.
(config-vpls-sig)#exit-signaling
Exit signaling mode
(config-vpls)# exit-vpls
Exit VPLS config mode and return to Configure mode
(config-vpls)#commit
Commit the transaction.
RTR1: Interface
 
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe1
Enter the Interface mode for xe1
(config-if)#switchport
Enable switchport on the interface
(config-if)#mpls-vpls vpls1 service-template st1
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if)#commit
Commit the transaction.
RTR4: VPLS
 
(config)#mpls vpls vpls1 1
Enter the VPLS configuration mode
(config-vpls)#signaling ldp
Use LDP signaling for VPLS
(config-vpls-sig)#vpls-type ethernet
Configure the VPLS as Ethernet
(config-vpls-sig)#vpls-peer 11.11.11.11
Configure RTR1 as VPLS peer for RTR4.
(config-vpls-sig)#exit-signaling
Exit signaling mode
(config-vpls)#commit
Commit the transaction.
RTR4: Interface
 
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe2
Enter the Interface mode for xe2
(config-if)#switchport
Enable switchport on the interface
(config-if)#mpls-vpls vpls1 service template st1
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#commit
Commit the transaction.
Virtual Circuit Configuration
RTR1: Global VC Configuration
 
(config)#mpls l2-circuit t1 100 44.44.44.44
Enter the VC configuration command in router mode.
(config-pseudowire)#exit
Exit service template mode
(config)#bridge 1 protocol ieee vlan-bridge
Creating a VLAN-bridge in router mode.
(config)#commit
Commit the transaction.
RTR1: Interface Configuration
 
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template configuration
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#switchport
Enable switchport on the interface.
(config-if)#mpls-vpls vpls1 service-template st1
Bind the interface to VPLS.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if)#commit
Commit the transaction.
RTR4: Global VC Configuration
 
(config)#mpls l2-circuit t1 100 11.11.11.11
Enter the VC configuration command in router mode.
(config)#exit
Exit service template mode.
(config)#bridge 1 protocol ieee vlan-bridge
Creating a VLAN-bridge in router mode.
(config)#commit
Commit the transaction.
RTR4: Interface Configuration
 
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe2
Enter interface mode for xe2.
(config-if)#switchport
Enable switchport on the interface.
(config-if)#mpls-vpls vpls1 service-template st1
Bind the interface to VPLS.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config)#commit
Commit the transaction.
VPLS Configuration
RTR1: Global VPLS Configuration
 
(config)#mpls vpls vpls1 1
Enter the VPLS configuration mode.
(config-vpls)#signaling ldp
Use LDP signaling for VPLS.
(config-vpls-sig)#vpls-peer 44.44.44.44
Configure RTR4 as VPLS peer for RTR1.
(config-vpls-sig)#exit-signaling
Exit signaling mode.
(config-vpls)#commit
Commit the transaction.
RTR1: Interface Configuration
 
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#switchport
Enable switchport on the interface.
(config-if)#mpls-vpls vpls1 service-template st1
Bind the interface to VPLS.
(config-if-vpls)#commit
Commit the transaction.
RTR4: Global VC Configuration
 
(config)#mpls vpls vpls1 1
Enter the VPLS configuration mode.
(config-vpls)#signaling ldp
Use LDP signaling for VPLS.
(config-vpls-sig)#vpls-peer 11.11.11.11
Configure RTR4 as VPLS peer for RTR1.
(config-vpls-sig)#exit-signaling
Exit signaling mode.
(config-vpls)#commit
Commit the transaction.
RTR4: Interface Configuration
 
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe2
Enter interface mode for xe2.
(config-if)#switchport
Enable switchport on the interface.
(config-if)#mpls-vpls vpls1 service-template st1
Bind the interface to VPLS.
(config-if-vpls)#exit
Exit VPLS mode and return to interface mode.
(config-if)#commit
Commit the transaction.
Configure RSVP-LSP
RTR1: Global RSVP configuration
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter RSVP configuration mode for the router.
(config-router)#commit
Commit the transaction.
RTR1: Enabling RSVP and label switching on interface
 
(config)#interface xe2
Enter interface mode for xe2.
(config-if)#enable-rsvp
Enable RSVP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#commit
Commit the transaction.
RTR1: Trunk Configuration
 
(config)#rsvp-trunk t1
Configure RSVP trunk t1
(config-trunk)#to 44.44.44.44
Configure RTR4 as the end of trunk
(config-trunk)#commit
Commit the transaction.
RTR2: Global RSVP configuration
 
(config)#router rsvp
Enter RSVP configuration mode for the router.
(config-router)#php
Configure PHP on the end node.
(config-router)#commit
Commit the transaction.
RTR2: Enabling RSVP and label switching on interface
 
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#enable-rsvp
Enable RSVP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode for xe2.
(config-if)#enable-rsvp
Enable RSVP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#commit
Commit the transaction.
RTR3: Global RSVP configuration
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter RSVP configuration mode for the router.
(config-router)#php
Configure PHP on the end node.
(config-router)#commit
Commit the transaction.
RTR3: Enabling RSVP and label switching on interface
 
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#enable-rsvp
Enable RSVP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode for xe3.
(config-if)#enable-rsvp
Enable RSVP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#commit
Commit the transaction.
RTR4: Global RSVP configuration
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter RSVP configuration mode for the router.
(config-router)#commit
Commit the transaction.
RTR4: Enabling RSVP and label switching on interface
 
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#enable-rsvp
Enable RSVP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#commit
Commit the transaction.
RTR4: Trunk Configuration
 
(config)#rsvp-trunk t2
Configure RSVP trunk t2.
(config-trunk)#to 11.11.11.11
Configure RTR1 as the end of trunk.
(config-trunk)#commit
Commit the transaction.
Configure Static-LSP
RTR1: Global Static configuration
 
(config)#mpls ftn-entry 44.44.44.44/32 100 10.10.10.2 xe1
Configure FTN entry for rtr4 loopback.
(config)#mpls ilm-entry 900 pop
Pop the incoming label
(config)#commit
Commit the transaction.
RTR1: Enabling label switching on interface
 
(config)#interface xe2
Enter interface mode for xe2.
(config-if)#label-switching
Enable Label switching on the interface.
(config)#commit
Commit the transaction.
RTR2: Global Static configuration
 
mpls ilm-entry 100 swap 200 xe2 20.20.20.2 44.44.44.44/32
Swap the incoming label
mpls ilm-entry 800 swap 900 xe1 10.10.10.1 11.11.11.11/32
Swap the incoming label
RTR2: Enabling label switching on interface
 
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode for xe2.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#commit
Commit the transaction.
RTR3: Global Static configuration
 
(config)#mpls ilm-entry 200 swap 300 xe2 30.30.30.2 44.44.44.44/32
Swap the incoming label
(config)#mpls ilm-entry 700 swap 800 xe1 20.20.20.1 11.11.11.11/32
Swap the incoming label
(config)#commit
Commit the transaction.
RTR3: Enabling label switching on interface
 
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode for xe3.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#commit
Commit the transaction.
RTR4: Global Static configuration
 
(config)#mpls ftn-entry 11.11.11.11/32 700 30.30.30.1 xe1
Configure FTN entry for RTR1 loopback.
(config)mpls ilm-entry 300 pop
Pop the incoming label.
(config)#commit
Commit the transaction.
RTR4: Enabling label switching on interface
 
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#commit
Commit the transaction.
Validation
Here, 1000 packets are transmitted between the PE nodes and the output of counters at each node is mentioned below.
For Static-LSP
RTR1#show mpls counters static
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
44.44.44.44/32 100 49939 807798
[ILM statistics]
+------------------+-----------+-----------+--------------------+--------------------+--------------------+--------------------+
| FEC | in-label | out-label | Rx packets | Rx bytes | Tx packets | Tx bytes |
+------------------+-----------+-----------+--------------------+--------------------+--------------------+--------------------+
0.0.0.0/0 900 n/a 40546 3486956 n/a n/a
RTR1#
 
 
RTR2#show mpls counters static
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
 
[ILM statistics]
+------------------+-----------+-----------+--------------------+---------------
-----+--------------------+--------------------+
| FEC | in-label | out-label | Rx packets | Rx bytes
| Tx packets | Tx bytes |
+------------------+-----------+-----------+--------------------+---------------
-----+--------------------+--------------------+
44.44.44.44/32 100 200 9393 807798
9393 807798
11.11.11.11/32 800 900 40546 3486956
40546 3486956
RTR2#
 
 
RTR3#show mpls counters static
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
 
[ILM statistics]
+------------------+-----------+-----------+--------------------+--------------------+--------------------+--------------------+
| FEC | in-label | out-label | Rx packets | Rx bytes | Tx packets | Tx bytes |
+------------------+-----------+-----------+--------------------+--------------------+--------------------+--------------------+
44.44.44.44/32 200 300 9393 807798 9393 807798
11.11.11.11/32 700 800 40546 3486956 40546 3486956
RTR3#
 
 
RTR4#show mpls counters static
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
11.11.11.11/32 700 49939 3486956
 
[ILM statistics]
+------------------+-----------+-----------+--------------------+---------------
-----+--------------------+--------------------+
| FEC | in-label | out-label | Rx packets | Rx bytes
| Tx packets | Tx bytes |
+------------------+-----------+-----------+--------------------+---------------
-----+--------------------+--------------------+
0.0.0.0/0 300 n/a 9393 807798
n/a n/a
RTR4#
For RSVP-LSP
RTR1#show mpls counters rsvp
Tunnel-id 5001 Extended Tunnel-ID 44.44.44.44 Egress 11.11.11.11
lsp-name : t1-Primary [Egress]
lsp-ingress : 44.44.44.44 lsp-id : 2201
Rx pkts : 2509072 Rx bytes : 187780192
Tx pkts : 0 Tx bytes : 0
 
Tunnel-id 5001 Extended Tunnel-ID 11.11.11.11 Egress 44.44.44.44
lsp-name : t1-Primary [Ingress]
lsp-ingress : 11.11.11.11 lsp-id : 2201
Rx pkts : 0 Rx bytes : 0
Tx pkts : 5578405 Tx bytes : 451417492
 
 
RTR2#show mpls counters rsvp
Tunnel-id 5001 Extended Tunnel-ID 44.44.44.44 Egress 11.11.11.11
lsp-name : t1-Primary [Transit]
lsp-ingress : 44.44.44.44 lsp-id : 2201
Rx pkts : 2565947 Rx bytes : 192671442
Tx pkts : 2565960 Tx bytes : 192672560
 
Tunnel-id 5001 Extended Tunnel-ID 11.11.11.11 Egress 44.44.44.44
lsp-name : t1-Primary [Transit]
lsp-ingress : 11.11.11.11 lsp-id : 2201
Rx pkts : 5631460 Rx bytes : 456305560
Tx pkts : 5631472 Tx bytes : 456306592
 
 
RTR3#show mpls counters rsvp
Tunnel-id 5001 Extended Tunnel-ID 44.44.44.44 Egress 11.11.11.11
lsp-name : t1-Primary [Transit]
lsp-ingress : 44.44.44.44 lsp-id : 2201
Rx pkts : 2565947 Rx bytes : 282671442
Tx pkts : 2565960 Tx bytes : 282672560
 
Tunnel-id 5001 Extended Tunnel-ID 11.11.11.11 Egress 44.44.44.44
lsp-name : t1-Primary [Transit]
lsp-ingress : 11.11.11.11 lsp-id : 2201
Rx pkts : 8631460 Rx bytes : 457245560
Tx pkts : 8631472 Tx bytes : 45724592
 
 
RTR4#show mpls counters rsvp
Tunnel-id 5001 Extended Tunnel-ID 44.44.44.44 Egress 11.11.11.11
lsp-name : t1-Primary [Ingress]
lsp-ingress : 44.44.44.44 lsp-id : 2201
Rx pkts : 0 Rx bytes : 0
Tx pkts : 10231330 Tx bytes : 374371318
 
Tunnel-id 5001 Extended Tunnel-ID 11.11.11.11 Egress 44.44.44.44
lsp-name : t1-Primary [Egress]
lsp-ingress : 11.11.11.11 lsp-id : 2201
Rx pkts : 5651207 Rx bytes : 458003802
Tx pkts : 0 Tx bytes : 0
 
R3#show mpls counters rsvp
Tunnel-id 5001 Extended Tunnel-ID 44.44.44.44 Egress 11.11.11.11 lsp-name : t1-Primary [Transit]
lsp-ingress : 44.44.44.44 lsp-id : 2201
Rx pkts : 2565947 Rx bytes : 282671442
Tx pkts : 2565960 Tx bytes : 282672560
 
Tunnel-id 5001 Extended Tunnel-ID 11.11.11.11 Egress 44.44.44.44 lsp-name : t1-Primary [Transit]
lsp-ingress : 11.11.11.11 lsp-id : 2201
Rx pkts : 8631460 Rx bytes : 457245560
Tx pkts : 8631472 Tx bytes : 45724592
 
R4#show mpls counters rsvp
Tunnel-id 5001 Extended Tunnel-ID 44.44.44.44 Egress 11.11.11.11 lsp-name : t1-Primary [Ingress]
lsp-ingress : 44.44.44.44 lsp-id : 2201 Rx pkts : 0 Rx bytes : 0
Tx pkts : 10231330 Tx bytes : 374371318
 
Tunnel-id 5001 Extended Tunnel-ID 11.11.11.11 Egress 44.44.44.44 lsp-name : t1-Primary [Egress]
lsp-ingress : 11.11.11.11 lsp-id : 2201
Rx pkts : 5651207 Rx bytes : 458003802
Tx pkts : 0 Tx bytes : 0
 
For LDP-LSP
RTR1#show mpls counters ldp
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-------------+------------------+--------------------+
44.44.44.44/32 52483 1000 1004000
[ILM statistics]
+-----+---------+-----------+------------+---------+-----------+---------+
| FEC |in-label | out-label | Rx packets | Rx bytes| Tx packets| Tx bytes|
+-----+---------+-----------+------------+---------+-----------+---------+
 
RTR2#show mpls counters ldp
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
[ILM statistics]
+-----+----------+-----------+------------+----------+------------+----------+
| FEC | in-label | out-label | Rx packets | Rx bytes | Tx packets | Tx bytes |
+-----+----------+-----------+------------+----------+------------+----------+
44.44.44.44/32 52483 52483 1000 1004000 1000 1004000
 
/RTR2#show mpls counters ldp [FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
[ILM statistics]
+-----+----------+-----------+------------+----------+------------+----------+
| FEC | in-label | out-label | Rx packets | Rx bytes | Tx packets | Tx bytes |
+-----+----------+-----------+------------+----------+------------+----------+ 44.44.44.44/32 52483 52483 1000 1004000 1000 1004000
 
For LDP-VC
RTR1#show mpls l2-circuit t1 statistics
MPLS Layer-2 Virtual Circuit: t1, id 100
Access port statistics:
RX: Input packets : 0
Input bytes : 0
TX: Output packets : 4642811
Output bytes : 297139904
 
Network port statistics:
RX: Input packets : 4642804
Input bytes : 399281144
TX: Output packets : 0
Output bytes : 0
 
 
RTR4#show mpls l2-circuit t1 statistics
MPLS Layer-2 Virtual Circuit: t1, id 100
Access port statistics:
RX: Input packets : 4633957
Input bytes : 296573248
TX: Output packets : 0
Output bytes : 0
 
Network port statistics:
RX: Input packets : 0
Input bytes : 0
TX: Output packets : 4633960
Output bytes : 398520560
For LDP-VPLS
RTR1#show mpls vpls vpls1 statistics
Virtual Private LAN Service Instance: vpls1, ID: 1
 
Access port statistics:
Interface: xe1
RX: Input packets : 1922483
Input bytes : 123038912
TX: Output packets : 3894242
Output bytes : 126192000
 
Network port statistics:
Mesh Peer: 44.44.44.44 (Up)
RX: Input packets : 1971746
Input bytes : 169570156
TX: Output packets : 3894244
Output bytes : 165334398
 
 
 
RTR4#show mpls vpls vpls1 statistics
Virtual Private LAN Service Instance: vpls1, ID: 1
 
Access port statistics:
Interface: xe2
RX: Input packets : 1967571
Input bytes : 125924544
TX: Output packets : 3885889
Output bytes : 122772032
 
Network port statistics:
Mesh Peer: 11.11.11.11 (Up)
RX: Input packets : 1918310
Input bytes : 164974660
TX: Output packets : 3885892
Output bytes : 169211622