OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : MPLS Service Mapping Configuration
MPLS Service Mapping Configuration
This chapter includes step-by-step configurations for tunnel policy configuration for all the MPLS services.
Overview
This feature enables MPLS services L2VPN, L3VPN, EVPN traffic steering with SR-policy as the underlying transport using local-tunnel-policy configuration. This is achieved with the help of color coding and association between service and MPLS transport.
A local-tunnel-policy is created which specifies the color of the transport-tunnel in order to be selected for a VPN service. The created tunnel-policy is now applied for the VPN service so that it will select the preferred tunnel. The destination address of the preferred tunnel identifies a peer PE so the PE will forward traffic destined for that peer PE over the preferred tunnel. If you specify multiple preferred tunnels that have the same destination address in a tunnel policy, only the first configured tunnel takes effect and if the first tunnel is not available, the second tunnel is used, and so forth. No load balancing will be performed on these tunnels.
The tunnels selected by 2 methods, dedicated and best-effort. By default, tunnel policy uses dedicated method. If you configure dedicated method for a tunnel policy, the tunnel policy uses the preferred tunnel to forward traffic destined for the peer PE. If not, the MPLS VPN service will be down. If you configure best-effort method for a tunnel policy, the tunnel policy uses the preferred tunnel to forward traffic destined for the peer PE. If not, the MPLS VPN selects the available MPLS transport in MPLS forwarding table.
Topology
The diagram depicts the topology for the configuration examples that follow.
Service mapping to Tunnel
Configuration
Below are the sample configuration for EVPN (E-LINE, E-LAN), L3VPN, 6VPE, VPWS, and VPLS services with Tunnel Policy along with SR as transport.
PE1: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 10.143.73.1/32 secondary
Configure IP address on loopback interface.
(config-if)#prefix-sid index 1
Configure prefix sid index value
(config-if)#exit
Exit interface mode
PE1: Global EVPN MPLS Command:
#configure terminal
Enter configuration mode.
(config)#evpn mpls enable
Enable EVPN MPLS. Note: Reload is required after Enabling/ Disabling EVPN MPLS Feature.
(config-evpn-mpls)#evpn mpls vtep-ip-global 10.143.73.1
Configuring loopback IP as VTEP global IP
(config-evpn-mpls)#commit
Commit the candidate configuration to the running configuration
(config-evpn-mpls)#end
Ending config mode
#write memory
Save config to startup config
#reload
Reload device after enabling evpn
PE1: LDP Configuration
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 10.143.73.1
Set the router ID to IP address 10.143.73.1.
(config-router)#transport-address ipv4 10.143.73.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
(config-router)# targeted-peer ipv4 10.143.73.3
Configure targeted peer
(config-router-targeted-peer)# exit-targeted-peer-mode
Exit from router target peer and LDP mode
PE1: Interface Configuration Network Side
 
(config)#interface xe16
Enter the Interface mode for xe16
(config-if)# ip address 10.255.128.2/31
Configure IP address on the interface.
(config-if)#mtu 9900
Configure mtu at interface level
(config-if)# label-switching
Enable label switching on the interface.
(config-if)# enable-ldp ipv4
Enable ldp on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe4
Enter the Interface mode for xe4.
(config-if)# ip address 10.255.128.10/31
Configure IP address on the interface.
(config-if)#mtu 9900
Configure mtu at interface level
(config-if)# label-switching
Enable label switching on the interface.
(config-if)# enable-ldp ipv4
Enable ldp on the interface.
(config-if)#exit
Exit interface mode
PE1: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#ospf router-id 10.143.73.1
Router-id configurations
(config-router)# bfd all-interfaces
Enable the OSPF enabled interfaces with bfd
(config-router)# network 10.143.73.1/32 area 0.0.0.0
Advertise loopback address in OSPF.
(config-router)# network 10.255.128.2/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# network 10.255.128.10/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# ospf segment-routing global block 16000 17000
Enable SRGB under ospf process 100
(config-router)#segment-routing mpls
Enable segment routing
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
PE1: BGP Configuration
 
(config)# router bgp 100
Enter the Router BGP mode, ASN: 100.
(config-router)# neighbor 10.143.73.3 remote-as 100
Configuring PE3 as iBGP neighbor using it's loopback ip.
(config-router)# neighbor 10.143.73.3 fall-over bfd multihop
Configure neighbor bfd multihop
(config-router)# neighbor 10.143.73.3 update-source lo
Source of routing updates as loopback
(config-router)# neighbor 10.143.73.3 advertisement-interval 0
Configure advertisement interval
(config-router)# address-family vpnv4 unicast
Enter VPNv4 Address family mode
(config-router-af)# neighbor 10.143.73.3 activate
Enabling VPNv4 Address family for neighbor..
(config-router-af)# exit-address-family
Exit Address-family mode.
(config-router)# address-family l2vpn vpls
Enter l2vpn Address family mode
(config-router-af)# neighbor 10.143.73.3 activate
Enabling l2vpn Address family for neighbor..
(config-router-af)# exit-address-family
Exit Address-family mode.
(config-router)# address-family l2vpn evpn
Enter evpn Address family mode
(config-router-af)# neighbor 10.143.73.3 activate
Enabling evpn Address family for neighbor..
(config-router-af)# exit-address-family
Exit Address-family mode.
(config-router)# address-family vpnv6 unicast
Enter VPNv6 Address family mode
(config-router-af)# neighbor 10.143.73.3 activate
Enabling VPNv6 Address family for neighbor..
(config-router-af)# exit-address-family
Exit Address-family mode.
PE1: SR policy Configuration
 
(config)#segment-routing
Enter the segment routing mode.
(config-sr)# mpls sr-prefer
prefer segment routing MPLS entries for forwarding.
((config-sr)#traffic-engineering
Enter traffic engineering mode.
(config-sr-te)# policy PE1-P1-PE3
Configure SR policy
(config-sr-pol)# color 1 end-point 10.143.73.3
Configure color with destination address.
(config-sr-pol)#candidate-path 1
Enter candidate path mode.
(config-sr-pol-cp)#dynamic-path ospf 100
Configure dynamic path ospf
(config-sr-pol-cp)#constraints
Enter constraint mode
(config-sr-dyn-cp-cons)# 10.143.73.5 loose
Configure P1 as next-hop loose mode.
(config-sr-dyn-cp-cons)#exit-pol-cp
Exit candidate path mode.
(config-sr-pol-cp)#exit-sr-pol
Exit SR policy mode.
(config-sr-te)# policy PE1-P2-PE3
Configure SR policy
(config-sr-pol)# color 2 end-point 10.143.73.3
Configure color with destination address.
(config-sr-pol)#candidate-path 1
Enter candidate path mode.
(config-sr-pol-cp)#dynamic-path ospf 100
Configure dynamic path ospf
(config-sr-pol-cp)#constraints
Enter constraint mode
(config-sr-dyn-cp-cons)# 10.143.73.6 loose
Configure P2 as next-hop loose mode.
(config-sr-dyn-cp-cons)#exit-pol-cp
Exit candidate path mode.
(config-sr-pol-cp)#exit-sr-pol
Exit SR policy mode.
PE1: Tunnel Policy Configuration
 
(config)# tunnel-policy PE1-P1-PE3
Configure tunnel policy
(config-tnl-policy)#color 1
Map the color with the SR policy to be used..
(config-tnl-policy)#exit
Exiting tunnel policy mode
(config)# tunnel-policy PE1-P2-PE3
Configure tunnel policy
(config-tnl-policy)#color 2
Map the color with the SR policy to be used..
(config-tnl-policy)#exit
Exiting tunnel policy mode
PE1: VPWS Configuration
 
(config)# mpls l2-circuit pe1-to-pe3 2002 10.143.73.3
Configure the VC for PE3. In this
example, pe1-to-pe3 is the VC name, 2002 is the VC ID, and 10.143.73.3 is the VC endpoint IP address.
(config-pseudowire)# tunnel-select-policy PE1-P1-PE3
Configure Tunnel-Policy on VC pe1-to-pe3
(config-pseudowire)#exit
Exit pseudowire config mode.
(config)#exit
Exiting from config mode
(config)#service-template pe1-to-pe3
Template configuration.
(config-svc)# match outer-vlan 2002
Match criteria under template configuration
(config)#exit
Exiting from config mode
PE1: VPLS Configuration
 
(config)# mpls vpls vpls-pe1-to-pe3pe4-1 2502
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type ethernet
Type ethernet configuration for VPLS
(config-vpls-sig)# vpls-peer 10.143.73.3 tunnel-select-policy PE1-P2-PE3
Configure VPLS Peer with tunnel-policy
(config-vpls-sig)#exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#service-template vpls-pe1-to-pe3pe4-1
Template configuration.
(config-svc)# match outer-vlan 2502
Match criteria under template configuration
(config-svc)# rewrite ingress translate 2600 outgoing-tpid dot1.q
Action performed for service template.
(config)# mpls vpls vpls-pe1-to-pe3pe4-2 2503
Enter VPLS config mode
(config-vpls)#signaling bgp
Enter the Signaling bgp mode for BGP VPLS.
(config-vpls-sig)# ve-id 3
Configure VE ID, which is mandatory for BGP VPLS, otherwise, signaling does not take place. VE ID should be unique per VPLS instance
(config-vpls-sig)# tunnel-select-policy PE1-P1-PE3
Configure tunnel-policy for a VPLS instance
(config-vpls-sig)#exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#service-template vpls-pe1-to-pe3pe4-2
Template configuration.
(config-svc)# match double-tag outer-vlan 2503 inner-vlan 2504
Match criteria under template configuration
(config-svc)# rewrite ingress push 2505
Action performed for service template.
PE1: MAC VRF and IP VRF Configuration for EVPN and L3VPN services
Note: For EVPN Service, Tunnel Policy can be applied at mac vrf level and VNID level, When Configured at both levels, Preference is given to VNID level.
 
(config)#mac vrf vrf2
Enter VRF mode
(config-vrf)# tunnel-select-policy PE1-P1-PE3
Map tunnel policy to mac vrf
(config-vrf)#rd 10.143.73.1:2
Configuring Route-Distinguisher value 10.143.73.1:2
(config-vrf)#route-target both 2:2
Configuring import and export value as 2:2
(config-vrf)#exit
Exiting VRF Mode.
(config)#mac vrf elan500
Enter VRF mode
(config-vrf)#rd 10.143.73.1:500
Configuring Route-Distinguisher value 10.143.73.1:500
(config-vrf)#route-target both 500:500
Configuring import and export value as 500:500
(config)# ip vrf vrf600
Enter VRF mode
(config-vrf)# tunnel-select-policy PE1-P1-PE3
Configure tunnel-policy to be used for the VRF.
(config-vrf)# rd 10.143.73.1:600
Configuring Route-Distinguisher value 10.143.73.1:600
(config-vrf)#route-target both 600:600
Configuring import and export value as 600:600
(config-vrf)#exit
Exiting VRF Mode.
PE1: EVPN and MAC-VRF mapping for ELAN and ELINE
 
(config)#evpn mpls id 2 xconnect target-mpls-id 252
Configure the EVPN-ELINE identifier with source identifier 2 and target identifier 252.
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf2
Mapping vrf "vrf2" to EVPN-VPWS identifier.
(config-evpn-mpls)#exit
Exiting from evpn-mpls mode
(config)# evpn mpls id 500
Configure evpn mpls id 500
(config-evpn-mpls)#tunnel-select-policy PE1-P2-PE3
Map tunnel-policy to EVI
(config-evpn-mpls)#host-reachability-protocol evpn-bgp elan500
Mapping vrf " elan500" to EVPN-VPLS identifier.
PE1: Access side Configuration
 
(config)#interface xe8
Enter the Interface mode for xe8
(config-if)# switchport
Configure interface as switch port
(config-if)# mpls-l2-circuit pe1-to-pe3 service-template pe1-to-pe3 primary
Bind the interface to the VC with service template
(config-if)# mpls-vpls vpls-pe1-to-pe3pe4-1 service-template vpls-pe1-to-pe3pe4-1
Bind the VPLS instance to the interface
(config-if-vpls)# exit-if-vpls
Exit VPLS attachment-circuit mode
(config-if)# mpls-vpls vpls-pe1-to-pe3pe4-2 service-template vpls-pe1-to-pe3pe4-2
Bind the VPLS instance to the interface
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)# exit-if-vpls
Exit VPLS attachment-circuit mode
(config-if)# exit
Exit from the interface
(config)#interface xe8.2 switchport
Configure Interface xe8.2 as switchport
(config-if)#encapsulation dot1q 2
Setting Encapsulation to dot1q with VLAN ID 2
(config-if)#access-if-evpn
Entering Access mode for EVPN MPLS ID configuration.
(config-access-if)#map vpn-id 2
Map vpn-id 2 to interface xe8.2 (VPWS).
(config-access-if)#exit
Exiting out of access interface mode.
(config)#interface xe8.500 switchport
Configure Interface xe8.500 as switchport
(config-if)#encapsulation dot1q 500
Setting Encapsulation to dot1q with VLAN ID 500
(config-if)#access-if-evpn
Entering Access mode for EVPN MPLS ID configuration.
(config-access-if)#map vpn-id 500
Map vpn-id 500 to interface xe8.500 (VPLS).
(config-access-if)#exit
Exiting out of access interface mode.
(config)#interface xe8.600
Enter Interface mode xe8.600
(config-if)# ip vrf forwarding vrf600
Bind the VRF instance to the interface
(config-if)# ip address 170.1.1.1/24
Configure IP address
(config-if)# ipv6 address 1111::1/64
Configure ipv6 address
(config-if)#encapsulation dot1q 600
Setting Encapsulation to dot1q with VLAN ID 600
(config-if)#exit
Exiting interface Mode.
(config)# router bgp 100
Enter BGP router mode
(config-router)#address-family ipv4 vrf vrf600
Configure VRF address family
(config-router-af)redistribute connected
Redistribute connected router
(config-router-af)#neighbor 170.1.1.2 remote-as 200
Configure neighbor with remote-as
(config-router-af)#neighbor 170.1.1.2 activate
Activate the VPN neighbour
(config-router-af)exit-address-family
Exit VRF address family
(config-router)#address-family ipv6 vrf vrf600
Configure ipv6 VRF address family
(config-router-af)redistribute connected
Redistribute connected router
(config-router-af)#neighbor 1111::2 remote-as 200
Configure neighbor with remote-as
(config-router-af)#neighbor 1111::2 activate
Activate the VPN neighbour
(config-router-af)exit-address-family
Exit VRF address family
(config-router-af)exit
End
(config-router)#commit
Commit the candidate configuration to the running configuration
P1: Loopback Interface
 
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 10.143.73.5/32 secondary
Configure IP address on loopback interface.
(config-if)#prefix-sid index 5
Configure prefix sid index value
(config-if)#exit
Exit interface mode
P1: Interface Configuration Network Side
 
(config)#interface xe15
Enter the Interface mode for xe15
(config-if)# ip address 10.255.128.3/31
Configure IP address on the interface.
(config-if)# mtu 9900
Configure mtu
(config-if)# label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe7
Enter the Interface mode for xe7.
(config-if)# ip address 10.255.128.23/31
Configure IP address on the interface.
(config-if)# label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
P1: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#ospf router-id 10.143.73.5
Router-id configurations
(config-router)# bfd all-interfaces
Enable the OSPF enabled interfaces with bfd
(config-router)# network 10.143.73.5/32 area
 
0.0.0.0
Advertise network address in OSPF.
(config-router)# network 10.255.128.2/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# network 10.255.128.22/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# ospf segment-routing global block 16000 17000
Enable SRGB under ospf process 100
(config-router)#segment-routing mpls
Enable segment routing
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
P2: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 10.143.73.6/32 secondary
Configure IP address on loopback interface.
(config-if)#prefix-sid index 6
Configure prefix sid index value
(config-if)#exit
Exit interface mode
P2: Interface Configuration Network Side
 
(config)#interface xe4
Enter the Interface mode for xe4
(config-if)# ip address 10.255.128.11/31
Configure IP address on the interface.
(config-if)# mtu 9900
Configure mtu
(config-if)# label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe5
Enter the Interface mode for xe5.
(config-if)# ip address 10.255.128.25/31
Configure IP address on the interface.
(config-if)# label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
P2: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#ospf router-id 10.143.73.6
Router-id configurations
(config-router)# bfd all-interfaces
Enable the OSPF enabled interfaces with bfd
(config-router)# network 10.143.73.6/32 area
 
0.0.0.0
Advertise network address in OSPF.
(config-router)# network 10.255.128.10/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# network 10.255.128.24/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# ospf segment-routing global block 16000 17000
Enable SRGB under ospf process 100
(config-router)#segment-routing mpls
Enable segment routing
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
PE3: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)# ip address 10.143.73.3/32 secondary
Configure IP address on loopback interface.
(config-if)#prefix-sid index 3
Configure prefix sid index value
(config-if)#exit
Exit interface mode
PE3: Global EVPN MPLS Command
 
#configure terminal
Enter configuration mode.
(config)#evpn mpls enable
Enable EVPN MPLS. Note: Reload is required after Enabling/ Disabling EVPN MPLS Feature.
(config-evpn-mpls)#evpn mpls vtep-ip-global 10.143.73.3
Configuring vtep global ip to loopback IP.
(config-evpn-mpls)#commit
Commit the candidate configuration to the running configuration
(config-evpn-mpls)#end
End configuration mode
#write memory
Saving configs to startup config
#reload
Reload device after enabling evpn
PE3: LDP Configuration
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 10.143.73.3
Set the router ID to IP address 10.143.73.3.
(config-router)#transport-address ipv4 10.143.73.3
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
(config-router)# targeted-peer ipv4 10.143.73.1
Configure targeted peer
(config-router-targeted-peer)# exit-targeted-peer-mode
Exit from router target peer and LDP mode
PE3: Interface Configuration Network Side
 
(config)#interface xe5
Enter the Interface mode for xe5
(config-if)# ip address 10.255.128.24/31
Configure IP address on the interface.
(config-if)#mtu 9900
Configure mtu at interface level
(config-if)# label-switching
Enable label switching on the interface.
(config-if)# enable-ldp ipv4
Enable ldp on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe7
Enter the Interface mode for xe7.
(config-if)# ip address 10.255.128.22/31
Configure IP address on the interface.
(config-if)# label-switching
Enable label switching on the interface.
(config-if)# enable-ldp ipv4
Enable ldp on the interface.
(config-if)#exit
Exit interface mode
PE3: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#ospf router-id 10.143.73.3
Router-id configurations
(config-router)# bfd all-interfaces
Enable the OSPF enabled interfaces with bfd
(config-router)# network 10.143.73.3/32 area 0.0.0.0
Advertise loopback address in OSPF.
(config-router)# network 10.255.128.22/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# network 10.255.128.24/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)# ospf segment-routing global block 16000 17000
Enable SRGB under ospf process 100
(config-router)#segment-routing mpls
Enable segment routing
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
PE3: BGP Configuration
 
(config)# router bgp 100
Enter the Router BGP mode, ASN: 100.
(config-router)# neighbor 10.143.73.1 remote-as 100
Configuring PE3 as iBGP neighbor using it's loopback ip.
(config-router)# neighbor 10.143.73.1 fall-over bfd multihop
Configure neighbor bfd multihop
(config-router)# neighbor 10.143.73.1 update-source lo
Source of routing updates as loopback
(config-router)# neighbor 10.143.73.1 advertisement-interval 0
Configure advertisement interval
(config-router)# address-family vpnv4 unicast
Enter VPNv4 Address family mode
(config-router-af)# neighbor 10.143.73.1 activate
Enabling VPNv4 Address family for neighbor..
(config-router-af)# exit-address-family
Exit Address-family mode.
(config-router)# address-family l2vpn vpls
Enter l2vpn Address family mode
(config-router-af)# neighbor 10.143.73.1 activate
Enabling l2vpn Address family for neighbor..
(config-router-af)# exit-address-family
Exit Address-family mode.
(config-router)# address-family l2vpn evpn
Enter evpn Address family mode
(config-router-af)# neighbor 10.143.73.1 activate
Enabling evpn Address family for neighbor..
(config-router-af)# exit-address-family
Exit Address-family mode.
(config-router)# address-family vpnv6 unicast
Enter VPNv6 Address family mode
(config-router-af)# neighbor 10.143.73.1 activate
Enabling VPNv6 Address family for neighbor..
(config-router-af)# exit-address-family
Exit Address-family mode.
PE3: VPWS Configuration
 
(config)# mpls l2-circuit pe3-to-pe1 2002 10.143.73.1
Configure the VC for PE-1. In this example, pe3-to-pe1 is the VC name, 2002 is the VC ID, and 10.143.73.1 is the VC endpoint IP address.
(config)#exit
Exiting from config mode
(config)#service-template pe3-to-pe1
Template configuration.
(config-svc)# match outer-vlan 2002
Match criteria under template configuration
(config)#exit
Exiting from config mode
PE3: VPLS Configuration
 
(config)# mpls vpls vpls-pe3-to-pe1pe4-1 2502
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type Ethernet
Type ethernet configuration for VPLS
(config-vpls-sig)# vpls-peer 10.143.73.1
Configure VPLS Peer
(config-vpls-sig)#exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#service-template vpls-pe3-to-pe1pe4-1
Template configuration.
(config-svc)# match outer-vlan 2502
Match criteria under template configuration
(config-svc)# rewrite ingress translate 2600 outgoing-tpid dot1.q
Action performed for service template.
(config)# mpls vpls vpls-pe3-to-pe1pe4-2 2503
Enter VPLS config mode
(config-vpls)#signaling bgp
Enter the Signaling bgp mode for BGP VPLS.
(config-vpls-sig)# ve-id 4
Configure VE ID, which is mandatory for BGP VPLS, otherwise, signaling does not take place. VE ID should be unique per VPLS instance
(config-vpls-sig)#exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#service-template vpls-pe3-to-pe1pe4-2
Template configuration.
(config-svc)# match double-tag outer-vlan 2503 inner-vlan 2504
Match criteria under template configuration
(config-svc)# rewrite ingress push 2505
Action performed for service template.
PE3: MAC and IP VRF Configuration
 
(config)#mac vrf vrf2
Enter VRF mode
(config-vrf)#rd 10.143.73.3:2
Configuring Route-Distinguisher value 10.143.73.3:2
(config-vrf)#route-target both 2:2
Configuring import and export value as 2:2
(config-vrf)#exit
Exiting VRF Mode.
(config)#mac vrf elan500
Enter VRF mode
(config-vrf)#rd 10.143.73.3:500
Configuring Route-Distinguisher value 10.143.73.3:500
(config-vrf)#route-target both 500:500
Configuring import and export value as 500:500
(config)# ip vrf vrf600
Enter VRF mode
(config-vrf)# rd 10.143.73.3:600
Configuring Route-Distinguisher value 10.143.73.3:600
(config-vrf)#route-target both 600:600
Configuring import and export value as 600:600
(config-vrf)#exit
Exiting VRF Mode.
PE3: EVPN and mac vrf mapping Configuration
 
(config)#evpn mpls id 252 xconnect target-mpls-id 2
Configure the EVPN-ELINE identifier with source identifier 252 and target identifier 2.
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf2
Mapping vrf "vrf2" to EVPN-VPWS identifier.
(config-evpn-mpls)#exit
Exiting from evpn-mpls mode
(config)# evpn mpls id 500
Configure evpn mpls id 500
(config-evpn-mpls)#host-reachability-protocol evpn-bgp elan500
Mapping vrf " elan500" to EVPN-VPLS identifier.
PE3: Access side Configuration
 
(config)#interface xe4
Enter the Interface mode for xe8
(config-if)# switchport
Configure interface as switch port
(config-if)# mpls-l2-circuit pe3-to-pe1 service-template pe3-to-pe1 primary
Bind the VPWS instance to the interface
(config-if)# mpls-vpls vpls-pe3-to-pe1pe4-1 service-template vpls-pe3-to-pe1pe4-1
Bind the VPLS instance to the interface
(config-if-vpls)# exit-if-vpls
Exit VPLS attachment-circuit mode
(config-if)# mpls-vpls vpls-pe3-to-pe1pe4-2 service-template vpls-pe3-to-pe1pe4-2
Bind the VPLS instance to the interface
(config-if-vpls)# exit-if-vpls
Exit VPLS attachment-circuit mode
(config-if)# exit
Exit from the interface
(config)#interface xe4.2 switchport
Configure Interface xe4.2 as switchport
(config-if)#encapsulation dot1q 2
Setting Encapsulation to dot1q with VLAN ID 2
(config-if)#access-if-evpn
Entering Access mode for EVPN MPLS ID configuration.
(config-access-if)#map vpn-id 252
Map vpn-id 252 to interface xe4.2 (VPWS).
(config-access-if)#exit
Exiting out of access interface mode.
(config)#interface xe4.500 switchport
Configure Interface xe4.500 as switchport
(config-if)#encapsulation dot1q 500
Setting Encapsulation to dot1q with VLAN ID 500
(config-if)#access-if-evpn
Entering Access mode for EVPN MPLS ID configuration.
(config-access-if)#map vpn-id 500
Map vpn-id 500 to interface xe4.500 (VPLS).
(config-access-if)#exit
Exiting out of access interface mode.
(config)#interface xe4.600
Enter Interface mode xe4.600
(config-if)# ip vrf forwarding vrf600
Bind the VRF instance to the interface
(config-if)# ip address 180.1.1.1/24
Configure IP address
(config-if)# ipv6 address 2222::1/64
Configure ipv6 address
(config-if)#encapsulation dot1q 600
Setting Encapsulation to dot1q with VLAN ID 600
(config-if)#exit
Exiting interface Mode.
(config)# router bgp 100
Enter BGP router mode
(config-router)#address-family ipv4 vrf vrf600
Configure VRF address family
(config-router-af)redistribute connected
Redistribute connected router
(config-router-af)#neighbor 180.1.1.2 remote-as 300
Configure neighbor with remote-as
(config-router-af)#neighbor 180.1.1.2 activate
Activate the VPN neighbour
(config-router-af)exit-address-family
Exit VRF address family
(config-router)#address-family ipv6 vrf vrf600
Configure ipv6 VRF address family
(config-router-af)redistribute connected
Redistribute connected router
(config-router-af)#neighbor 2222::2 remote-as 300
Configure neighbor with remote-as
(config-router-af)#neighbor 2222::2 activate
Activate the VPN neighbour
(config-router-af)exit-address-family
Exit VRF address family
(config-router-af)end
End
(config)#commit
Commit the candidate configuration to the running configuration
Validation
CLI's : Show segment-routing policy, show tunnel-policy, show tunnel-policy service details, show mpls forwarding-table
PE1
PE1#show segment-routing policy
 
Policy-Name Color End-point State Forwarding-Info
PE1-P1-PE3 1 10.143.73.3 UP 3/16003/xe16
PE1-P2-PE3 2 10.143.73.3 UP 3/16003/xe4
VPWS
PE1#show mpls vc-table
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
2002 N/A N/A xe8 xe16 25600 3 10.143.73.3 Active
 
PE1#show mpls l2-circuit
MPLS Layer-2 Virtual Circuit: pe1-to-pe3, id: 2002 PW-INDEX: 2 service-tpid: dot1.q
Tunnel-Policy: PE1-P1-PE3 >>> VPWS is up by using Applied Tunnel Policy
Endpoint: 10.143.73.3
Control Word: 0
MPLS Layer-2 Virtual Circuit Group: none
Bound to interface: xe8
Virtual Circuit Type: Ethernet VLAN
Virtual Circuit is configured as Primary
Virtual Circuit is configured as Active
Virtual Circuit is active
Service-template : pe1-to-pe3
Match criteria : 2002
VPLS
PE1#show mpls vpls mesh
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
2502 10.143.73.3 3 26241 xe4 25601 2/Up 1 LDP Active
2503 10.143.73.3 3 25604 xe16 24962 2/Up 3 BGP Active
 
PE1#show mpls vpls detail
Virtual Private LAN Service Instance: vpls-pe1-to-pe3pe4-1, ID: 2502
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Group ID: 0, VPLS Type: Ethernet, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe8
Service-template : vpls-pe1-to-pe3pe4-1
Match criteria : 2502
Action type : Translate
Action value : 2600
Outgoing tpid : dot1.q
 
Mesh Peers:
10.143.73.3 (Up)
Tunnel-Policy: PE1-P2-PE3 >>> VPLS-LDP is up using applied tunnel policy
 
 
Virtual Private LAN Service Instance: vpls-pe1-to-pe3pe4-2, ID: 2503
SIG-Protocol: BGP
Route-Distinguisher :100:2503
Route-Target :100:2503
VE-ID :3
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe8
Service-template : vpls-pe1-to-pe3pe4-2
Match criteria : 2503/2504
Action type : Push
Action value : 2505
 
Mesh Peers:
10.143.73.3 (Up)
Tunnel-Policy: PE1-P1-PE3 VPLS-BGP is up using applied tunnel policy
 
EVPN E-LAN
PE1#show evpn mpls tunnel label
EVPN-MPLS Network tunnel labels
(*) in Policy - tunnel-policy inherited from mac-vrf
Destination Status evpn-id Policy Network-Intf Tunnel-Label MC-
Local Remote
Label UC-Label MC-Label UC-Label
===================================================================================
10.143.73.3 Installed 500 PE1-P2-PE3 xe4 3 640 17 640 --
Total number of entries are 1
 
Here Tunnel Policy is applied under VNID level.
EVPN E-LINE
PE1#show evpn mpls xconnect tunnel label
EVPN-MPLS Network tunnel labels
(*) in Policy - tunnel-policy inherited from mac-vrf
Local Remote
Destination Status VPWS-ID VPWS-ID Policy Network-Intf Tunnel-
Local Remote
Label MC-Label UC-Label MC-Label UC-Label
==========================================================================================================================
10.143.73.3 Installed 2 252 PE1-P1-PE3(*) xe16 3 -- 16 -- 16
 
Total number of entries are 1
 
Here Tunnel Policy is applied under mac-vrf level.
L3VPN and 6VPE
PE1#show mpls vrf-table
Output for IPv4 VRF table with id: 4
Primary FTN entry with FEC: 180.1.1.0/24, id: 1, row status: Active, Tunnel-Policy: PE1-P1-PE3
Owner: BGP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Transport Tunnel id: 1, Protected LSP id: 0, QoS Resource id: 0, Description: N/A, Color: 1
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 8
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 8, owner: BGP, Stale: NO, BGP out intf: xe16, transport out intf: xe16, out label: 25024
Nexthop addr: 10.143.73.3 cross connect ix: 6, op code: Push and Lookup
 
 
Output for IPv6 VRF table with id: 4
Primary FTN entry with FEC: 2222::/64, id: 13, row status: Active, Tunnel-Policy: PE1-P1-PE3
Owner: BGP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Transport Tunnel id: 1, Protected LSP id: 0, QoS Resource id: 0, Description: N/A, Color: 1
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 8
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 8, owner: BGP, Stale: NO, BGP out intf: xe16, transport out intf: xe16, out label: 25024
Nexthop addr: 10.143.73.3 cross connect ix: 6, op code: Push and Lookup
 
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
P> 10.143.73.3/32 4 10 1 Yes LSP_DEFAULT 3 xe16 No 10.255.128.3
P> 10.143.73.3/32 5 11 2 Yes LSP_DEFAULT 3 xe4 No 10.255.128.11
O 10.143.73.3/32 1 3 0 Yes LSP_DEFAULT 16003 xe16 No 10.255.128.3
O> 10.143.73.5/32 2 5 0 Yes LSP_DEFAULT 3 xe16 No 10.255.128.3
O> 10.143.73.6/32 3 6 0 Yes LSP_DEFAULT 3 xe4 No 10.255.128.11
 
PE1#show mpls forwarding-table detail
FEC prefix: 10.143.73.3/32, FTN-ID: 4
Owner: SR_POLICY, FTN type: Regular, State: Installed
Tunnel-Name: N/A, Tunnel-id: 1, Color: 1
LSP-ID: N/A, LSP-type: Primary
NHLFE-id: 10
Out-Label: 3, Out-Intf: xe16, Nexthop: 10.255.128.3
Exp-bits: 0x0, Incoming DSCP: none, QoS Resource id: 0
ELC: No
 
FEC prefix: 10.143.73.3/32, FTN-ID: 5
Owner: SR_POLICY, FTN type: Regular, State: Installed
Tunnel-Name: N/A, Tunnel-id: 2, Color: 2
LSP-ID: N/A, LSP-type: Primary
NHLFE-id: 11
Out-Label: 3, Out-Intf: xe4, Nexthop: 10.255.128.11
Exp-bits: 0x0, Incoming DSCP: none, QoS Resource id: 0
ELC: No
 
FEC prefix: 10.143.73.3/32, FTN-ID: 1
Owner: OSPF-SR, FTN type: Regular, State: Not Selected
Tunnel-Name: N/A, Tunnel-id: N/A, Color: N/A
LSP-ID: N/A, LSP-type: Primary
NHLFE-id: 3
Out-Label: 16003, Out-Intf: xe16, Nexthop: 10.255.128.3
Exp-bits: 0x0, Incoming DSCP: none, QoS Resource id: 0
ELC: No
 
FEC prefix: 10.143.73.5/32, FTN-ID: 2
Owner: OSPF-SR, FTN type: Regular, State: Installed
Tunnel-Name: N/A, Tunnel-id: N/A, Color: N/A
LSP-ID: N/A, LSP-type: Primary
NHLFE-id: 5
Out-Label: 3, Out-Intf: xe16, Nexthop: 10.255.128.3
Exp-bits: 0x0, Incoming DSCP: none, QoS Resource id: 0
ELC: No
 
FEC prefix: 10.143.73.6/32, FTN-ID: 3
Owner: OSPF-SR, FTN type: Regular, State: Installed
Tunnel-Name: N/A, Tunnel-id: N/A, Color: N/A
LSP-ID: N/A, LSP-type: Primary
NHLFE-id: 6
Out-Label: 3, Out-Intf: xe4, Nexthop: 10.255.128.11
Exp-bits: 0x0, Incoming DSCP: none, QoS Resource id: 0
ELC: No
 
Tunnel policy Output after applying under all services
PE1#show tunnel-policy
tunnel-policy PE1-P1-PE3
color 1
tunnel-mode dedicated
tunnel-type any
Total Services attached:
VRF : 1
VPWS : 1
VPLS : 1
EVPN : 1
 
tunnel-policy PE1-P2-PE3
color 2
tunnel-mode dedicated
tunnel-type any
Total Services attached:
VRF : 0
VPWS : 0
VPLS : 1
EVPN : 1
 
PE1#show tunnel-policy service details
List of services configured with tunnel-policy PE1-P1-PE3:
VPWS
VPWS-Id: 2002, Name: pe1-to-pe3 Status: UP, Mapped Tunnel: SR_POLICY, ftn_ix 4, color 1
L3VPN
VRF id 4
FTN id: 1, Prefix: 180.1.1.0/24, Status: Up, Label: 25024, Mapped Tunnel: SR_POLICY, ftn_ix 4, color 1
FTN id: 13, Prefix: 2222::/64, Status: Up, Label: 25024, Mapped Tunnel: SR_POLICY, ftn_ix 4, color 1
VPLS
VPLS-Id: 2503, Name: vpls-pe1-to-pe3pe4-2, Status: UP, Mapped Tunnel: SR_POLICY, ftn_ix 4, color 1
EVPN
EVPN-Id: 2, Tunnel count: 1
Peer: 10.143.73.3, Mapped Tunnel: SR_POLICY, ftn_ix 4, color 1
List of services configured with tunnel-policy PE1-P2-PE3:
VPLS
VPLS-Id: 2502, Name: vpls-pe1-to-pe3pe4-1, Status: UP, Mapped Tunnel: SR_POLICY, ftn_ix 5, color 2
EVPN
EVPN-Id: 500, Tunnel count: 1
Peer: 10.143.73.3, Mapped Tunnel: SR_POLICY, ftn_ix 5, color 2
 
PE2 Validation:
 
PE2#show mpls vc-table
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
2002 N/A N/A xe22 xe7 26880 16001 10.143.73.1 Active
 
PE2#show mpls l2-circuit
MPLS Layer-2 Virtual Circuit: pe3-to-pe1, id: 2002 PW-INDEX: 2 service-tpid: dot1.q
Endpoint: 10.143.73.1
Control Word: 0
Flow Label Status: Disabled, Direction: None, Static: No
MPLS Layer-2 Virtual Circuit Group: none
Bound to interface: xe4
Virtual Circuit Type: Ethernet VLAN
Virtual Circuit is configured as Primary
Virtual Circuit is configured as Active
Virtual Circuit is active
Service-template : pe3-to-pe1
Match criteria : 2002
 
PE2#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
2502 10.143.73.1 16001 26881 xe7 26881 2/Up 1 LDP Active
2503 10.143.73.1 16001 25602 xe7 25603 2/Up 3 BGP Active
 
PE2#show mpls vpls detail
Virtual Private LAN Service Instance: vpls-pe3-to-pe1pe4-1, ID: 2502
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe4
Service-template : vpls-pe3-to-pe1pe4-1
Match criteria : 2502
Action type : Translate
Action value : 2600
Outgoing tpid : dot1.q
 
Mesh Peers:
10.143.73.1 (Up)
Virtual Private LAN Service Instance: vpls-pe3-to-pe1pe4-2, ID: 2503
 
SIG-Protocol: BGP
Route-Distinguisher :100:2503
Route-Target :100:2503
VE-ID :4
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe4
Service-template : vpls-pe3-to-pe1pe4-2
Match criteria : 2503/2504
Action type : Push
Action value : 2505
 
Mesh Peers:
10.143.73.1 (Up)
 
PE2#show evpn mpls tunnel label
EVPN-MPLS Network tunnel labels
(*) in Policy - tunnel-policy inherited from mac-vrf
(e) - Service mapped over MPLS Multipath/ECMP
================+===========+=========+===============+=========+=========+=========+=========+============+=========+============+========
Local Remote MPLS-Multipath Underlay
Destination Status VPN-ID Policy MC-Label UC-Label MC-Label UC-Label Grp-Name NHLFE-ix NW-Intf NW-Label
================+===========+=========+===============+=========+=========+=========+=========+============+=========+============+========
10.143.73.1 Installed 500 -- 640 17 640 -- -- -- xe7 16001
Total number of entries are 1
 
PE2#show evpn mpls xconnect tunnel label
EVPN-MPLS Network tunnel labels
(*) in Policy - tunnel-policy inherited from mac-vrf
(e) - Service mapped over MPLS Multipath/ECMP
================+===========+=========+=========+===============+=========+=========+============+=========+============+=========
Local Remote Local Remote MPLS-Multipath Underlay
Destination Status VPWS-ID VPWS-ID Policy UC-Label UC-Label Grp-Name NHLFE-ix NW-Intf NW-Label
================+===========+=========+=========+===============+=========+=========+============+=========+============+=========
10.143.73.1 Installed 252 2 -- 16 16 -- -- xe7 16001
Total number of entries are 1
PE2#show mpls vrf-table
Output for IPv4 VRF table with id: 4
Primary FTN entry with FEC: 170.1.1.0/24, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: BGP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
VRF id 4, BGP peer 10.143.73.1 BGP prefix 170.1.1.0
Transport Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A, , Color: 0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 5
 
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: BGP, Stale: NO, BGP out intf: xe7, transport out intf: xe7, out label: 25664
Nexthop addr: 10.143.73.1 cross connect ix: 4, op code: Push and Lookup
 
Output for IPv6 VRF table with id: 4
Primary FTN entry with FEC: 1111::/64, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: BGP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
VRF id 4, BGP peer a8f:4901:: BGP prefix 1111::
Transport Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A, , Color: 0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 5
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: BGP, Stale: NO, BGP out intf: xe7, transport out intf: xe7, out label: 25664
Nexthop addr: 10.143.73.1 cross connect ix: 4, op code: Push and Lookup
 
PE2#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 10.143.73.1/32 1 9 0 Yes LSP_DEFAULT 16001 xe7 No 10.255.128.23
O> 10.143.73.5/32 2 10 0 Yes LSP_DEFAULT 3 xe7 No 10.255.128.23
O> 10.143.73.6/32 3 14 0 Yes LSP_DEFAULT 3 xe5 No 10.255.128.25
PE2#show mpls forwarding-table detail
FEC prefix: 10.143.73.1/32, FTN-ID: 1
Owner: OSPF-SR, FTN type: Regular, State: Installed
Tunnel-Name: N/A, Tunnel-id: N/A, Color: N/A
LSP-ID: N/A, LSP-type: Primary
NHLFE-id: 9
Out-Label: 16001, Out-Intf: xe7, Nexthop: 10.255.128.23
Exp-bits: 0x0, Incoming DSCP: none, QoS Resource id: 0
ELC: No
FEC prefix: 10.143.73.5/32, FTN-ID: 2
Owner: OSPF-SR, FTN type: Regular, State: Installed
Tunnel-Name: N/A, Tunnel-id: N/A, Color: N/A
LSP-ID: N/A, LSP-type: Primary
NHLFE-id: 10
Out-Label: 3, Out-Intf: xe7, Nexthop: 10.255.128.23
Exp-bits: 0x0, Incoming DSCP: none, QoS Resource id: 0
ELC: No
FEC prefix: 10.143.73.6/32, FTN-ID: 3
Owner: OSPF-SR, FTN type: Regular, State: Installed
Tunnel-Name: N/A, Tunnel-id: N/A, Color: N/A
LSP-ID: N/A, LSP-type: Primary
NHLFE-id: 14
Out-Label: 3, Out-Intf: xe5, Nexthop: 10.255.128.25
Exp-bits: 0x0, Incoming DSCP: none, QoS Resource id: 0
 
Note: The following CLI will be used to change from dedicated mode to best effort
tunnel-policy PE1-P1-PE3
color 1
mode best-effort