OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : RSVP Graceful Restart Configuration
RSVP Graceful Restart Configuration
Overview
The RSVP-TE graceful restart enables routers to maintain MPLS forwarding state when a link or node failure occurs. In a link failure, control communication is lost between two nodes, however, the nodes do not lose their control or forwarding state. RSVP Graceful restart (GR) is one of the fault-handling mechanism, that protects the forwarding state of the node during failure and helps to reinstate the previous state when the node has recovered.
Topology
RSVP Graceful Restart
Configuration
PE1-NSM
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 11.11.11.11/32 secondary
Set the IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe7
Enter interface mode.
(config-if)#ip address 10.10.10.2/24
Set the IP address for the interface.
(config-if)#label-switching
Enable label switching on interface xe7.
(config-if)#commit
Commit the transaction.
 
PE1-RSVP-TE
(config)#router rsvp
Enter Configure Router mode.
(config-router)#exit
Exit Router mode.
(config)#interface xe7
Enter interface mode.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#commit
Commit the transaction.
 
 
PE1-OSPF
#configure terminal
Enter configure mode.
(config)#router ospf 100
Configure the Routing process and specify the Process ID
(100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#router-id 11.11.11.11
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 10.10.10.0/24 area 0
Define the network (10.10.10.0/24) on which OSPF runs and associate the area ID (0).
(config-router)#network 11.11.11.11/32 area 0
Set the IP address of the loopback interface to
11.11.11.11/32.
(config-router)#commit
Commit the transaction.
 
P - NSM
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 1.1.1.1/32 secondary
Set the IP address for the interface.
(config-if)#exit
Enable label switching on interface lo.
(config)#interface xe7
Enter interface mode.
(config-if)#ip address 10.10.10.1/24
Set the IP address for the interface.
(config-if)#label-switching
Enable label switching on interface xe7.
(config-if)#exit
Exit interface mode.
(config)#interface xe8
Enter interface mode.
(config-if)#ip address 20.20.20.1/24
Set the IP address for the interface.
(config-if)#label-switching
Enable label switching on interface xe7.
(config-if)#commit
Commit the transaction.
 
 
P - RSVP-TE
(config)#router rsvp
Enter Configure Router mode.
(config-router)#exit
Exit Router mode.
(config)#interface xe7
Enter interface mode.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe8
Enter interface mode.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#commit
Commit the transaction.
P - OSPF
#configure terminal
Enter configure mode.
(config)#router ospf 100
Configure the Routing process and specify the Process ID
(100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#router-id 1.1.1.1
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 10.10.10.0/24 area 0
Define the first network (10.10.10.0/24) on which OSPF runs and associate the area ID (0).
(config-router)#network 20.20.20.0/24 area 0
Define the second network (20.20.20.0/24) on which OSPF runs and associate the area ID (0).
(config-router)#network 1.1.1.1/32 area 0
Set the IP address of the loopback interface to
1.1.1.1/32.
(config-router)#commit
Commit the transaction.
PE3 - NSM
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 33.33.33.33/32 secondary
Set the IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface ge8
Enter interface mode.
(config-if)#ip address 20.20.20.2/24
Set the IP address for the interface.
(config-if)#label-switching
Enable label switching on interface ge8.
(config-if)#commit
Commit the transaction.
 
 
 
 
 
PE3- RSVP-TE
(config)#router rsvp
Enter Configure Router mode.
(config-router)#exit
Exit Router mode.
(config)#interface ge8
Enter interface mode.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#commit
Commit the transaction.
 
PE3 - OSPF
#configure terminal
Enter configure mode.
(config)#router ospf 100
Configure the Routing process and specify the Process ID
(100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#router-id 33.33.33.33
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 20.20.20.0/24 area 0
Define the network (20.20.20.0/24) on which OSPF runs and associate the area ID (0).
(config-router)#network 33.33.33.33/32 area 0
Set the IP address of the loopback interface to
33.33.33.33/32.
(config-router)#commit
Commit the transaction.
PE1 - RSVP-Path
#configure terminal
Enter configure mode.
(config)#rsvp-path PE1_to_PE3_via_P1 mpls
Create an RSVP Path and enter the Path mode.
(config-path)#10.10.10.1 strict
Configure this explicit route path as a strict hop.
(config-path)#20.20.20.2 strict
Configure this explicit route path as a strict hop.
(config-path)#exit
Exit Path mode.
#configure terminal
Enter configure mode.
(config)#rsvp-trunk PE1_to_PE3 ipv4
Create an RSVP trunk and enter the Trunk mode.
(config-trunk)#primary path PE1_to_PE3_via_P1
Configure the trunk to use defined path.
(config-trunk)#from 11.11.11.11
Specify ipv4 source point for the LSP.
(config-trunk)#to 33.33.33.33
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#commit
Commit the transaction.
 
PE3 - RSVP-Path
#configure terminal
Enter configure mode.
(config)#rsvp-path PE3_to_PE1_via_P1 mpls
Create an RSVP Path and enter the Path mode.
(config-path)#20.20.20.1 strict
Configure this explicit route path as a strict hop.
(config-path)#10.10.10.2 strict
Configure this explicit route path as a strict hop.
(config-path)#exit
Exit Path mode.
#configure terminal
Enter configure mode.
(config)#rsvp-trunk PE3_to_PE1 ipv4
Create an RSVP trunk and enter the Trunk mode.
(config-trunk)#primary path PE3_to_PE1_via_P1
Configure the trunk to use defined path.
(config-trunk)#from 33.33.33.33
Specify the ipv4 source point for LSP
(config-trunk)#to 11.11.11.11
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#commit
Commit the transaction.
PE1 RSVP-GR
#configure terminal
Enter configure mode.
(config)#router rsvp
nter the configuration router mode.
(config-router)#neighbor 10.10.10.1
Configure the neighbor ip address.
(config-router)#graceful-restart
Enable the rsvp-gr.
(config-router)#commit
Commit the transaction.
P1 RSVP-GR
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter the configuration router mode.
(config-router)#neighbor 10.10.10.2
Configure the neighbor ip address.
(config-router)#neighbor 20.20.20.2
Configure the neighbor ip address.
(config-router)#graceful-restart
Enable the rsvp-gr.
(config-router)#commit
Commit the transaction.
 
 
 
 
PE3 RSVP-GR
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter the router configuration mode.
(config-router)#neighbor 20.20.20.1
Configure the neighbor ip address.
(config-router)#graceful-restart
Enable the rsvp-gr.
(config-router)#commit
Commit the transaction.
 
Validation
Verify the RSVP graceful restart on PE1.
 
PE1#show rsvp graceful-restart
Graceful Restart: Enabled
Advertised Restart Time: 200000 msec
Advertised Recovery Time: 360000 msec
Sending Recovery Time: No
 
 
PE1#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forc
ed to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Egress RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
11.11.11.11 33.33.33.33 5001 2201 PRI PE1_to_PE3 ipv4s UP 00:54:57 1 1 SE 3 -
Total 5 displayed, Up 5, Down 0.
 
Verify after performing RSVP graceful restart on PE1
 
7038-PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, (t) - tunnel, P - SR Policy FTN, (b) - bypass,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
 
FTN-ECMP LDP: Disabled
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 3 4
3 - Yes LSP_DEFAULT 3 xe7 No 10.10.10.1
R(t)> p 33.33.33.33/32 20 81 5001 Yes LSP_DEFAULT 26881 xe7 Yes p 10.10.10.1