OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : MPLS-TE Shared Risk Link Group
MPLS-TE Shared Risk Link Group
Shared Risk Link Groups (SRLG) is a feature which allows the user to establish a backup secondary LSP (label switched path) path or a FRR (fast-reroute) LSP path which is disjoint from the path of the primary LSP. Links which are members of the same SRLG represent resources which share the same risk. For example, fiber links sharing the same conduit or multiple wavelengths sharing the same fiber.
SRLG groups are used to determine which links belong to the same SRLG. To advertise SRLG, the information is part of the IGP TE parameters in an opaque LSA (link state advertisement). It is advertised in a SRLG sub-TLV (type 16) of the existing Link TLV in OSPF.
The SRLG of a path in a label-switched path (LSP) is the set of SRLGs for all the links in the path. When computing the secondary path for an LSP, it is preferable to find a path such that the secondary and primary paths do not have any links in common in case the SRLGs for the primary and secondary paths are disjoint. This ensures that a single point of failure on a particular link does not bring down both the primary and secondary paths in the LSP.
Backup tunnel path selection with SRLG is done so that a backup tunnel can avoid using links that are in the same SRLG as the interfaces it is protecting. Otherwise, when the protected link fails the backup tunnel fails too.
Configure MPLS-TE Shared Risk Link Group
Topology for SRLG
RTR2
Loopback Interface
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address on loopback interface.
(config-if)#commit
Commit the transaction.
MPLS Interface
 
(config)#interface xe1
Enter the Interface mode
(config-if)#ip address 22.1.1.2/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe5
Enter the Interface mode
(config-if)#ip address 30.1.1.2/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe7
Enter the Interface mode
(config-if)#ip address 11.1.1.2/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#commit
Commit the transaction.
OSPF
 
(config)#router ospf 1
Enter the Router OSPF mode.
(config-router)#router-id 2.2.2.2
Configure OSPF router id
(config-router)#network 2.2.2.2/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 11.1.1.0/24area 0
Advertise network address in OSPF.
(config-router)#network 22.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#network 30.1.1.0/24area 0
Advertise network address in OSPF.
(config-router)#commit
Commit the transaction.
Global RSVP
 
(config)#router rsvp
Enter the Router RSVP mode.
(config-router)#commit
Commit the transaction.
RSVP Interface
 
(config)#interface xe1
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe5
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe7
Enter the Interface mode
(config-if)#enable-rsvp
Enable rsvp on the interface
(config-if)#commit
Commit the transaction.
Global SRLG (Path Type: Forced)
 
(config)#router rsvp
Enter the Router RSVP mode.
(config-router)#srlg-disjoint forced
Configure SRLG path type forced
(config-router)#commit
Commit the transaction.
Note: Disjoint type “preferred” can be configured globally using the command srlg-disjoint preferred.
SRLG Interface
 
(config)#interface xe1
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 11
Configure SRLG value in the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe7
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 11
Configure SRLG value in the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe5
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 30
Configure SRLG value in the interface
(config-if)#commit
Commit the transaction.
MPLS RSVP Path
 
(config)#rsvp-path path1
Configure MPLS-path
(config-path)#11.1.1.3 strict
Configure first hop for the path
(config-path)#12.1.1.4 strict
Configure second hop for the path
(config-path)#exit
Exit mpls-path mode and return to Configure mode.
(config)#rsvp-path sec-path1
Configure MPLS-path
(config-path)#4.4.4.4 loose
Configure loose path
(config-path)#exit
Exit mpls-path mode and return to Configure mode.
(config-path)#rsvp-path sec-path2
Configure MPLS-path.
(config-path)#4.4.4.4 loose
Configure loose path
(config-path)#commit
Commit the transaction.
RSVP-TE Tunnel with Secondary Protection and SRLG Disjoint Type Forced:
 
#configure terminal
Enter configure mode.
(config)#rsvp-trunk lsp1
Configure rsvp trunk
(config-trunk)#primary path path1
Configure primary path
(config-trunk)#secondary-priority 1 path sec-path1
Configure secondary path
(config-trunk)#secondary-priority 1 srlg-disjoint forced
Configure SRLG for secondary path
(config-trunk)#secondary-priority 2 path sec-path2
Configure secondary path
(config-trunk)#secondary-priority 2 srlg-disjoint forced
Configure SRLG for secondary path
(config-trunk)#to 4.4.4.4
Configure rsvp trunk destination address
(config-trunk)#commit
Commit the transaction.
Note: Disjoint type preferred can be configured in rsvp-trunk secondary using the command "secondary-priority 2 srlg-disjoint forced.
RSVP-TE Tunnel with Fast Reroute Protection One-to-One
 
#configure terminal
Enter configure mode.
(config)#rsvp-trunk lsp2
Configure rsvp trunk
(config-trunk)#primary fast-reroute protection one-to-one
Configure fast-reroute protection
(config-trunk)#primary path path1
Configure primary path
(config-trunk)#to 4.4.4.4
Configure rsvp trunk destination address
(config-trunk)#commit
Commit the transaction.
RSVP-TE Tunnel with Fast Reroute Protection Facility Backup
 
#configure terminal
Enter configure mode.
(config)#rsvp-bypass bypass1
Configure rsvp bypass tunnel
(config-bypass)#path path1
Configure path for bypass tunnel
(config-bypass)#to 4.4.4.4
Configure destination address for tunnel
(config-bypass)#exit
Exit rsvp-bypass tunnel mode
(config)#rsvp-trunk lsp3
Configure rsvp trunk
(config-trunk)#primary fast-reroute protection facility
Configure fast-reroute protection facility
(config-trunk)#primary path sec-path1
Configure path
(config-trunk)#to 4.4.4.4
Configure the destination of rsvp trunk
(config-trunk)#commit
Commit the transaction.
RTR3
Loopback Interface
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter the Interface mode for loopback interface.
(config-if)#ip address 3.3.3.3/32 secondary
Configure IP address on loopback interface.
(config-if)#commit
Commit the transaction.
MPLS Interfaces
 
(config)#interface xe5
Enter the Interface mode
(config-if)#ip address 21.1.1.3/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe7
Enter the Interface mode
(config-if)#ip address 11.1.1.3/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce52
Enter the Interface mode
(config-if)#ip address 12.1.1.3/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#commit
Commit the transaction.
OSPF
 
(config)#router ospf 1
Enter the Router OSPF mode.
(config-router)#router-id 3.3.3.3
Configure OSPF router id
(config-router)#network 3.3.3.3/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 11.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#network 12.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#network 21.1.1.0/24 area 0
Advertise network address in OSPF.
(config-if)#commit
Commit the transaction.
Global RSVP
 
(config)#router rsvp
Enter the Router RSVP mode.
(config-router)#commit
Commit the transaction.
RSVP Interface
 
(config)#interface xe5
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe7
Enter the Interface mode
(config-if)#enable-rsvp
Enable rsvp on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce52
Enter the Interface mode
(config-if)#enable-rsvp
Enable rsvp on the interface
(config-if)#commit
Commit the transaction.
Global SRLG (Path Type: Forced)
 
(config)#router rsvp
Enter the Router RSVP mode.
(config-router)#srlg-disjoint forced
Configure SRLG path type forced
(config-router)#commit
Commit the transaction.
When you use the one-to-one or facility backup protection, you must configure the srlg- disjoint type on all routers. When you use the secondary protection type, you only need to configure the srlg-disjoint type at the ingress node.de.
SRLG Interface
 
(config)#interface xe5
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 21
Configure SRLG value in the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe7
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 11
Configure SRLG value in the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce52
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 12
Configure SRLG value in the interface
(config-if)#commit
Commit the transaction.
RTR4
Loopback Interface
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter the Interface mode for loopback interface.
(config-if)#ip address 4.4.4.4/32 secondary
Configure IP address on the loopback address.
(config-if)#commit
Commit the transaction.
MPLS Interface
 
(config)#interface xe9
Enter the Interface mode
(config-if)#ip address 23.1.1.4/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce52
Enter the Interface mode
(config-if)#ip address 12.1.1.4/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce50
Enter the Interface mode
(config-if)#ip address 31.1.1.4/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#commit
Commit the transaction.
OSPF
 
(config)#router ospf 1
Enter Router OSPF mode.
(config-router)#router-id 4.4.4.4
Configure OSPF router id
(config-router)#network 4.4.4.4/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 12.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#network 23.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#network 31.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#commit
Commit the transaction.
Global RSVP
 
(config)#router rsvp
Enter the Router RSVP mode.
(config-router)#commit
Commit the transaction.
RSVP Interface
 
(config)#interface xe9
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce50
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce52
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#commit
Commit the transaction.
Global SRLG (Path Type: Forced)
 
(config)#router rsvp
Enter the Router RSVP mode.
(config-router)#srlg-disjoint forced
Configure SRLG path type forced
(config-router)#commit
Commit the transaction.
SRLG Interface
 
(config)#interface ce50
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 31
Configure SRLG value in the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce52
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 12
Configure SRLG value in the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe9
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 23
Configure SRLG value in the interface
(config-if)#commit
Commit the transaction.
RTR5
Loopback Interface
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter the Interface mode for loopback interface.
(config-if)#ip address 5.5.5.5/32 secondary
Configure IP address on the loopback address.
(config-if)#commit
Commit the transaction.
MPLS Interface
 
(config)#interface xe1
Enter the Interface mode
(config-if)#ip address 22.1.1.5/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe9
Enter the Interface mode
(config-if)#ip address 23.1.1.5/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe5
Enter the Interface mode
(config-if)#ip address 21.1.1.5/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#commit
Commit the transaction.
OSPF
 
(config)#router ospf 1
Enter Router OSPF mode.
(config-router)#router-id 5.5.5.5
Configure OSPF router id
(config-router)#network 5.5.5.5/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 21.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#network 22.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#network 23.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#commit
Commit the transaction.
Global RSVP
 
(config)#router rsvp
Enter the Router RSVP mode.
(config)#commit
Commit the transaction.
RSVP Interface
 
(config)#interface xe1
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe5
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe9
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#commit
Commit the transaction.
Global SRLG (Path Type: Forced)
 
(config)#router rsvp
Enter the Router RSVP mode.
(config-router)#srlg-disjoint forced
Configure SRLG path type forced
(config-router)#commit
Commit the transaction.
SRLG Interface
 
(config)#interface xe1
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 11
Configure SRLG value in the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe5
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 21
Configure SRLG value in the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe9
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 23
Configure SRLG value in the interface
(config-if)#commit
Commit the transaction.
RTR6
Loopback Interface
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter the Interface mode for loopback interface.
(config-if)#ip address 6.6.6.6/32 secondary
Configure IP address on the loopback address.
(config-if)#commit
Commit the transaction.
MPLS Interface
 
(config)#interface xe5
Enter the Interface mode
(config-if)#ip address 30.1.1.6/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce50
Enter the Interface mode
(config-if)#ip address 31.1.1.6/24
Configure ip address on the interface
(config-if)#label-switching
Enable label switching on the interface
(config-if)#commit
Commit the transaction.
OSPF
 
(config)#router ospf 1
Enter Router OSPF mode.
(config-router)#router-id 6.6.6.6
Configure OSPF router id
(config-router)#network 6.6.6.6/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 30.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#network 31.1.1.0/24 area 0
Advertise network address in OSPF.
(config-router)#commit
Commit the transaction.
Global RSVP
 
(config)#router rsvp
Enter the Router RSVP mode.
(config-router)#commit
Commit the transaction.
RSVP Interface
 
(config)#interface xe5
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce50
Enter the Interface mode
(config-if)#enable-rsvp
Enable RSVP on the interface
(config-if)#commit
Commit the transaction.
Global SRLG (Path Type: Forced)
 
(config)#router rsvp
Enter the Router RSVP mode.
(config-router)#srlg-disjoint forced
Configure SRLG path type forced
(config-router)#commit
Commit the transaction.
SRLG Interface
 
(config)#interface xe5
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 30
Configure SRLG value in the interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce50
Enter the Interface mode
(config-if)#mpls traffic-eng srlg 31
Configure SRLG value in the interface
(config-if)#commit
Commit the transaction.
Validation
R1 Configuration (Ingress)
OSPF:
RTR2#show ip ospf neighbor
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
3.3.3.3 1 Full/DR 00:00:29 11.1.1.3 xe7 0
5.5.5.5 1 Full/DR 00:00:37 22.1.1.5 xe1 0
6.6.6.6 1 Full/DR 00:00:35 30.1.1.6 xe5 0
RSVP:
RTR2#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
4.4.4.4 2.2.2.2 PRI lsp1-Primary UP 01:14:21 1 1 SE - 24960 DEFAULT
4.4.4.4 2.2.2.2 SEC lsp1-Secondary-Priority-1 UP 01:14:21 1 1 SE - 24320 DEFAULT
4.4.4.4 2.2.2.2 PRI lsp2-Primary UP 01:03:18 1 1 SE - 24961 DEFAULT
4.4.4.4 30.1.1.2 DTR lsp2-Detour UP 01:03:18 1 1 SE - 24321 DEFAULT
4.4.4.4 2.2.2.2 BPS bypass1-Bypass UP 00:58:02 1 1 SE - 24962 DEFAULT
4.4.4.4 2.2.2.2 PRI lsp3-Primary UP 00:57:26 1 1 SE - 24321 DEFAULT
Total 6 displayed, Up 6, Down 0.
 
RTR2#show rsvp session detail
Ingress (Primary)
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp1-Primary
Ingress FSM state: Operational
Establishment Time: 0s 16ms
SRLG configured in primary path are: 11 12
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 201
LSP Protection: None
Label in: -, Label out: 24960,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 11.1.1.3, xe7
Path refresh: 30 seconds (RR enabled) (due in 25417 seconds)
Resv lifetime: 157 seconds (due in 133 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: path1 (in use)
Configured Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Session Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
11.1.1.3
12.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Secondary-Priority1)
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp1-Secondary-Priority-1
Ingress FSM state: Operational
Establishment Time: 0s 38ms
SRLG configured in backup path are: 30 31
SRLG-disjoint Configured: Forced
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 101
LSP Protection: None
Label in: -, Label out: 24320,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2204, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 30.1.1.6, xe5
Path refresh: 30 seconds (RR enabled) (due in 25416 seconds)
Resv lifetime: 157 seconds (due in 127 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: sec-path1 (in use)
Configured Explicit Route Detail :
4.4.4.4/32 loose
Session Explicit Route Detail :
30.1.1.6/32 strict
31.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
30.1.1.6
31.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Primary)
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp2-Primary
Ingress FSM state: Operational
Establishment Time: 0s 10ms
SRLG configured in primary path are: 11 12
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 201
LSP Protection: one-to-one
Fast-Reroute bandwidth : 0
Protection type desired: Link
Fast-Reroute Hop limit: 255
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: -, Label out: 24961,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5002, LSP Id: 2206, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 11.1.1.3, xe7
Path refresh: 30 seconds (RR enabled) (due in 26088 seconds)
Resv lifetime: 157 seconds (due in 133 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: path1 (in use)
Configured Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Session Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Record route:
LP = 1 -> PLR's Downstream link is protected PU = 1 -> Protection is in use on PLR
NP = 1 -> PLR's Downstream neighbor is protected BP = 1 -> BW protection available at PLR
-------------------------------------------------------------
IP Address Label (LP, PU, NP, BP)
-------------------------------------------------------------
<self>
11.1.1.3 ( 1, 0, 0, 0)
12.1.1.4 ( 0, 0, 0, 0)
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Detour)
4.4.4.4
From: 30.1.1.2, LSPstate: Up, LSPname: lsp2-Detour
Ingress FSM state: Operational
Establishment Time: 0s 9ms
SRLG configured in backup path are: 30 31
SRLG-disjoint Configured: Forced
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 101
LSP Protection: None
Label in: -, Label out: 24321,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5002, LSP Id: 2206, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 30.1.1.6, xe5
Path refresh: 30 seconds (RR enabled) (due in 26073 seconds)
Resv lifetime: 157 seconds (due in 127 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Exclude path detail:
Exclude Link: 11.1.1.3
Configured Path: none
Session Explicit Route Detail :
30.1.1.6/32 strict
31.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
30.1.1.6
31.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Bypass)
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: bypass1-Bypass
Ingress FSM state: Operational
Establishment Time: 0s 10ms
SRLG configured in primary path are: 11 12
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 201
LSP Protection: None
Bypass trunk bandwidth type: Best-effort
Label in: -, Label out: 24962,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5003, LSP Id: 2207, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 11.1.1.3, xe7
Path refresh: 30 seconds (RR enabled) (due in 26388 seconds)
Resv lifetime: 157 seconds (due in 133 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: path1 (in use)
Configured Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Session Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
11.1.1.3
12.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Total LSP protected : 0, Bandwidth in use : 0
Ingress (Primary)
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp3-Primary
Ingress FSM state: Operational
Establishment Time: 0s 17ms
SRLG configured in primary path are: 11 23
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 2
LSP Protection: facility
Fast-Reroute bandwidth : 0
Protection type desired: Link
Fast-Reroute Hop limit: 255
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: -, Label out: 24321,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5004, LSP Id: 2208, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 22.1.1.5, xe1
Path refresh: 30 seconds (RR enabled) (due in 26421 seconds)
Resv lifetime: 157 seconds (due in 141 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Enabled
Admin Groups: none
Configured Path: sec-path1 (in use)
Configured Explicit Route Detail :
4.4.4.4/32 loose
Session Explicit Route Detail :
22.1.1.5/32 strict
23.1.1.4/32 strict
Record route:
LP = 1 -> PLR's Downstream link is protected PU = 1 -> Protection is in use on PLR
NP = 1 -> PLR's Downstream neighbor is protected BP = 1 -> BW protection available at PLR
-------------------------------------------------------------
IP Address Label (LP, PU, NP, BP)
-------------------------------------------------------------
<self>
22.1.1.5 24321 ( 0, 0, 0, 0)
23.1.1.4 0 ( 0, 0, 0, 0)
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
 
CSPF LSP:
RTR2#show cspf lsp
Lsp Id : 0x13890899
OSPF ID : 1
Ingress : 2.2.2.2
Egress : 4.4.4.4
Ext Tunnel ID : 2.2.2.2
LSP Type : 0
Client ID : 1
State : 3
Setup Priority : 7
Hold Priority : 0
Hop Limit : 255
Include Mask : 0x0
Exclude Mask : 0x0
Include All Mask: 0x0
LSP Metric : 201
Path Constraint :
11.1.1.3 strict
12.1.1.4 strict
Computed ERO :
11.1.1.3
12.1.1.4
 
SRLG values of LSP :
11 12
Lsp Id : 0x1389089c
OSPF ID : 1
Ingress : 2.2.2.2
Egress : 4.4.4.4
Ext Tunnel ID : 2.2.2.2
LSP Type : 0
Client ID : 1
State : 3
Setup Priority : 7
Hold Priority : 0
Hop Limit : 255
Include Mask : 0x0
Exclude Mask : 0x0
Include All Mask: 0x0
LSP Metric : 101
Path Constraint :
4.4.4.4 loose
Exclude SRLG Constraint :
11 12
Computed ERO :
30.1.1.6
31.1.1.4
 
SRLG values of LSP :
30 31
Lsp Id : 0x138a089e
OSPF ID : 1
Ingress : 2.2.2.2
Egress : 4.4.4.4
Ext Tunnel ID : 2.2.2.2
LSP Type : 0
Client ID : 1
State : 3
Setup Priority : 7
Hold Priority : 0
Hop Limit : 255
Include Mask : 0x0
Exclude Mask : 0x0
Include All Mask: 0x0
LSP Metric : 201
Path Constraint :
11.1.1.3 strict
12.1.1.4 strict
Computed ERO :
11.1.1.3
12.1.1.4
 
SRLG values of LSP :
11 12
Lsp Id : 0x138a089e
OSPF ID : 1
Ingress : 30.1.1.2
Egress : 4.4.4.4
Ext Tunnel ID : 2.2.2.2
LSP Type : 0
Client ID : 1
State : 3
Setup Priority : 7
Hold Priority : 0
Hop Limit : 255
Include Mask : 0x0
Exclude Mask : 0x0
Include All Mask: 0x0
LSP Metric : 101
Exclude Path Constraint :
11.1.1.3 exclude link
Exclude SRLG Constraint :
11
Computed ERO :
30.1.1.6
31.1.1.4
 
SRLG values of LSP :
30 31
Lsp Id : 0x138b089f
OSPF ID : 1
Ingress : 2.2.2.2
Egress : 4.4.4.4
Ext Tunnel ID : 2.2.2.2
LSP Type : 2
Client ID : 1
State : 3
Setup Priority : 7
Hold Priority : 0
Hop Limit : 255
Include Mask : 0x0
Exclude Mask : 0x0
Include All Mask: 0x0
LSP Metric : 201
Path Constraint :
11.1.1.3 strict
12.1.1.4 strict
Computed ERO :
11.1.1.3
12.1.1.4
 
SRLG values of LSP :
11 12
Lsp Id : 0x138c08a0
OSPF ID : 1
Ingress : 2.2.2.2
Egress : 4.4.4.4
Ext Tunnel ID : 2.2.2.2
LSP Type : 0
Client ID : 1
State : 3
Setup Priority : 7
Hold Priority : 0
Hop Limit : 255
Include Mask : 0x0
Exclude Mask : 0x0
Include All Mask: 0x0
LSP Metric : 2
Path Constraint :
4.4.4.4 loose
Computed ERO :
22.1.1.5
23.1.1.4
 
SRLG values of LSP :
11 23
RTR3 Configuration (Transit)
OSPF:
RTR3#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:32 11.1.1.2 xe7 0
4.4.4.4 1 Full/Backup 00:00:32 12.1.1.4 ce52 0
5.5.5.5 1 Full/Backup 00:00:36 21.1.1.5 xe5 0
 
RSVP:
RTR3#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
4.4.4.4 21.1.1.3 DTR lsp2-Detour UP 01:12:50 1 1 SE - 24320 ELSP_CON
Total 1 displayed, Up 1, Down 0.
 
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
4.4.4.4 2.2.2.2 PRI lsp1-Primary UP 01:23:54 1 1 SE 24960 0 ELSP_CON
4.4.4.4 2.2.2.2 PRI lsp2-Primary UP 01:12:50 1 1 SE 24961 0 ELSP_CON
4.4.4.4 2.2.2.2 PRI bypass1-Bypass UP 01:07:35 1 1 SE 24962 0 ELSP_CON
Total 3 displayed, Up 3, Down 0.
 
 
RTR3#show rsvp session detail
Transit
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp1-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 24960, Label out: 0,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 12.1.1.4, ce52 Upstream: 11.1.1.2, xe7
Path refresh: 30 seconds (RR enabled) (due in 24976 seconds)
Path lifetime: 157 seconds (due in 112 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 32606 seconds)
Resv lifetime: 157 seconds (due in 143 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Session Explicit Route Detail :
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
11.1.1.2
<self>
12.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Transit
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp2-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: one-to-one
Fast-Reroute bandwidth : 0
Protection type desired: Link
Fast-Reroute Hop limit: 255
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: 24961, Label out: 0,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2206, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 12.1.1.4, ce52 Upstream: 11.1.1.2, xe7
Path refresh: 30 seconds (RR enabled) (due in 25624 seconds)
Path lifetime: 157 seconds (due in 112 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 24416 seconds)
Resv lifetime: 157 seconds (due in 143 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Session Explicit Route Detail :
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
11.1.1.2
<self>
12.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Detour)
4.4.4.4
From: 21.1.1.3, LSPstate: Up, LSPname: lsp2-Detour
Ingress FSM state: Operational
Establishment Time: 0s 8ms
SRLG configured in backup path are: 21 23
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 2
LSP Protection: None
Label in: -, Label out: 24320,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5002, LSP Id: 2206, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 21.1.1.5, xe5
Path refresh: 30 seconds (RR enabled) (due in 25636 seconds)
Resv lifetime: 157 seconds (due in 153 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Exclude path detail:
Exclude Link: 11.1.1.2
Exclude Link: 12.1.1.4
Configured Path: none
Session Explicit Route Detail :
21.1.1.5/32 strict
23.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
21.1.1.5
23.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Transit
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: bypass1-Bypass
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 24962, Label out: 0,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5003, LSP Id: 2207, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 12.1.1.4, ce52 Upstream: 11.1.1.2, xe7
Path refresh: 30 seconds (RR enabled) (due in 25940 seconds)
Path lifetime: 157 seconds (due in 112 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 27142 seconds)
Resv lifetime: 157 seconds (due in 143 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Session Explicit Route Detail :
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
11.1.1.2
<self>
12.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
RTR4 Configuration (Egress)
OSPF:
RTR4#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
3.3.3.3 1 Full/DR 00:00:27 12.1.1.3 ce52 0
5.5.5.5 1 Full/Backup 00:00:27 23.1.1.5 xe9 0
6.6.6.6 1 Full/Backup 00:00:34 31.1.1.6 ce50 0
RSVP:
RTR4#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
4.4.4.4 2.2.2.2 PRI lsp1-Primary UP 01:28:26 1 1 SE 0 - ELSP_CON
4.4.4.4 2.2.2.2 PRI lsp1-Secondary-Priority-1 UP 01:28:26 1 1 SE 0 - ELSP_CON
4.4.4.4 2.2.2.2 PRI lsp2-Primary UP 01:17:22 1 1 SE 0 - ELSP_CON
4.4.4.4 30.1.1.2 PRI lsp2-Detour UP 01:17:22 1 1 SE 0 - ELSP_CON
4.4.4.4 21.1.1.3 PRI lsp2-Detour UP 01:17:22 1 1 SE 0 - ELSP_CON
4.4.4.4 2.2.2.2 PRI bypass1-Bypass UP 01:12:07 1 1 SE 0 - ELSP_CON
4.4.4.4 2.2.2.2 PRI lsp3-Primary UP 01:11:31 1 1 SE 0 - ELSP_CON
Total 7 displayed, Up 7, Down 0.
 
RTR4#show rsvp session detail
Egress
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp1-Primary
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 0, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 12.1.1.3, ce52
Path lifetime: 157 seconds (due in 141 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 39085 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
11.1.1.2
12.1.1.3
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Egress
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp1-Secondary-Priority-1
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 0, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2204, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 31.1.1.6, ce50
Path lifetime: 157 seconds (due in 141 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 9957 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
31.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
30.1.1.2
31.1.1.6
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Egress
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp2-Primary
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: one-to-one
Fast-Reroute bandwidth : 0
Protection type desired: Link
Fast-Reroute Hop limit: 255
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: 0, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2206, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 12.1.1.3, ce52
Path lifetime: 157 seconds (due in 141 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 33578 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
11.1.1.2
12.1.1.3
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Egress
4.4.4.4
From: 30.1.1.2, LSPstate: Up, LSPname: lsp2-Detour
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 0, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2206, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 31.1.1.6, ce50
Path lifetime: 157 seconds (due in 141 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 27672 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
31.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
30.1.1.2
31.1.1.6
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Egress
4.4.4.4
From: 21.1.1.3, LSPstate: Up, LSPname: lsp2-Detour
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 0, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2206, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 23.1.1.5, xe9
Path lifetime: 157 seconds (due in 133 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 17352 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
23.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
21.1.1.3
23.1.1.5
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Egress
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: bypass1-Bypass
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 0, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5003, LSP Id: 2207, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 12.1.1.3, ce52
Path lifetime: 157 seconds (due in 141 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 22891 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
11.1.1.2
12.1.1.3
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Egress
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp3-Primary
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: facility
Fast-Reroute bandwidth : 0
Protection type desired: Link
Fast-Reroute Hop limit: 255
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: 0, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5004, LSP Id: 2208, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 23.1.1.5, xe9
Path lifetime: 157 seconds (due in 133 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 33344 seconds)
RRO re-use as ERO: Disabled
Label Recording: Enabled
Admin Groups: Received Explicit Route Detail :
23.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
22.1.1.2 24321
23.1.1.5 0
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
RTR5 Configuration
OSPF:
RTR5#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
3.3.3.3 1 Full/DR 00:00:34 21.1.1.3 xe5 0
2.2.2.2 1 Full/Backup 00:00:30 22.1.1.2 xe1 0
4.4.4.4 1 Full/DR 00:00:39 23.1.1.4 xe9 0
 
RSVP:
RTR5#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
4.4.4.4 21.1.1.3 PRI lsp2-Detour UP 01:23:45 1 1 SE 24320 0 ELSP_CON
4.4.4.4 2.2.2.2 PRI lsp3-Primary UP 01:17:54 1 1 SE 24321 0 ELSP_CON
Total 2 displayed, Up 2, Down 0.
 
RTR5#show rsvp session detail
Transit
4.4.4.4
From: 21.1.1.3, LSPstate: Up, LSPname: lsp2-Detour
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 24320, Label out: 0,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2206, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 23.1.1.4, xe9 Upstream: 21.1.1.3, xe5
Path refresh: 30 seconds (RR enabled) (due in 24907 seconds)
Path lifetime: 157 seconds (due in 126 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 36355 seconds)
Resv lifetime: 157 seconds (due in 144 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
21.1.1.5/32 strict
23.1.1.4/32 strict
Session Explicit Route Detail :
23.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
21.1.1.3
<self>
23.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Transit
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp3-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: facility
Fast-Reroute bandwidth : 0
Protection type desired: Link
Fast-Reroute Hop limit: 255
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: 24321, Label out: 0,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5004, LSP Id: 2208, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 23.1.1.4, xe9 Upstream: 22.1.1.2, xe1
Path refresh: 30 seconds (RR enabled) (due in 25271 seconds)
Path lifetime: 157 seconds (due in 148 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 38338 seconds)
Resv lifetime: 157 seconds (due in 144 seconds)
RRO re-use as ERO: Disabled
Label Recording: Enabled
Admin Groups: Received Explicit Route Detail :
22.1.1.5/32 strict
23.1.1.4/32 strict
Session Explicit Route Detail :
23.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
22.1.1.2 24321
<self>
23.1.1.4 0
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
RTR6 Configuration
OSPF:
RTR6#show ip ospf neighbor
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:32 30.1.1.2 xe5 0
4.4.4.4 1 Full/DR 00:00:38 31.1.1.4 ce50 0
RSVP:
 
RTR6#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
4.4.4.4 2.2.2.2 PRI lsp1-Secondary-Priority-1 UP 01:38:16 1 1 SE 24320 0 ELSP_CON
4.4.4.4 30.1.1.2 PRI lsp2-Detour UP 01:27:12 1 1 SE 24321 0 ELSP_CON
Total 2 displayed, Up 2, Down 0.
 
RTR6#show rsvp session detail
Transit
4.4.4.4
From: 2.2.2.2, LSPstate: Up, LSPname: lsp1-Secondary-Priority-1
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 24320, Label out: 0,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2204, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 31.1.1.4, ce50 Upstream: 30.1.1.2, xe5
Path refresh: 30 seconds (RR enabled) (due in 24080 seconds)
Path lifetime: 157 seconds (due in 149 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 37411 seconds)
Resv lifetime: 157 seconds (due in 150 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
30.1.1.6/32 strict
31.1.1.4/32 strict
Session Explicit Route Detail :
31.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
30.1.1.2
<self>
31.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Transit
4.4.4.4
From: 30.1.1.2, LSPstate: Up, LSPname: lsp2-Detour
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 24321, Label out: 0,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2206, Ext-Tunnel Id: 2.2.2.2
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 31.1.1.4, ce50 Upstream: 30.1.1.2, xe5
Path refresh: 30 seconds (RR enabled) (due in 24724 seconds)
Path lifetime: 157 seconds (due in 149 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 32187 seconds)
Resv lifetime: 157 seconds (due in 150 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
30.1.1.6/32 strict
31.1.1.4/32 strict
Session Explicit Route Detail :
31.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
30.1.1.2
<self>
31.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls