OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : Static VPLS Configuration
Static VPLS Configuration
This chapter includes step-by-step configurations for Static VPLS. It also contains an overview of the concepts of Static VPLS.
Overview
Virtual Private LAN Service (VPLS) is a way to provide Ethernet-based multipoint-to-multipoint communication over IP- MPLS networks. It allows geographically-dispersed sites to share an Ethernet broadcast domain by connecting sites through pseudowires. A set of Martini circuits is grouped by a common VPLS identifier to achieve this service objective.
A pseudowire (PW) consists of a pair of point-to-point, single-hop unidirectional LSPs in opposite directions, each identified by a PW label, also called a Virtual Connection (VC) label.
The Label Distribution Protocol (LDP) is used to signal constituent VCs, and the service provider may use either LDP or RSVP-TE or add static provisioning to set up LSP tunnels to transport data through virtual circuits.
The VPLS identifier is exchanged with the labels, so that both PWs can be linked and be associated with a particular VPLS instance.
Configure Static VPLS
In the following examples, VPLS (v1) is configured on PE-2 with Static VPLS-Peers PE-1 and PE-3 using static LSPs.
Static Virtual Private LAN Service Topology
PE-1
 
#configure terminal
Enter configure mode.
(config)#mpls ftn-entry tunnel-id 11 2.2.2.2/32 102 10.10.1.2 xe1 primary
Configure MPLS FTN entry for the creation of a static LSP to PE-2.
(config)#mpls ftn-entry tunnel-id 22 3.3.3.3/32 103 10.10.1.2 xe1 primary
Configure MPLS FTN entry for the creation of a static LSP to PE-3.
(config)#mpls ilm-entry 201 pop
Configure MPLS ILM entry for the creation of a static LSP to PE-2.
(config)#mpls ilm-entry 301 pop
Configure MPLS ILM entry for the creation of a static LSP to PE-3.
(config)#mpls vpls v1 100
Configure VPLS v1 with ID 100 on PE-1.
(config-vpls)#vpls-peer 2.2.2.2 tunnel-id 11 manual
Configure PE-2 as a manual VPLS peer using the static LSP tunnel ID 11
(config-vpls)#vpls-peer 3.3.3.3 tunnel-id 22 manual
Configure PE-3 as a manual VPLS peer using the static LSP tunnel ID 22.
(config-vpls)#exit
Exit Configure VPLS mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip address 10.10.1.1/24
Configure IP address for the interface.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#exit
Exit interface mode
(config)#interface lo
Enter interface mode
(config-if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#ospf router-id 1.1.1.1
Configure OSPF router id same as loopback IP address
(config-router)#transport-address ipv4 1.1.1.1
Configure transport address as loopback address.
(config-router)#targeted-peer ipv4 3.3.3.3
Configure targeted peer.
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#network 10.10.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#network 1.1.1.1/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe2
Enter interface mode.
(config-if)#switchport
Switch to Layer-2 mode.
(config-if)#mpls-vpls v1 service-template st1
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#exit
Exit interface mode.
(config)#vpls fib-entry 100 peer 2.2.2.2 1000 xe1 2000
Configure VPLS FIB entry for VPLS peer PE-2.
(config)#vpls fib-entry 100 peer 3.3.3.3 3000 xe1 4000
Configure VPLS FIB entry for VPLS peer PE-3.
(config)#commit
Commit the transaction.
P
 
#configure terminal
Enter configure mode
(config)#interface lo
Enter interface mode
(config-if)#ip address 9.9.9.9/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode
(config)#interface xe1
Specify the interface to be configured.
(config-if)#ip address 10.10.1.2/24
Configure IP address for the interface.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe2
Enter interface mode
(config-if)#ip address 20.20.1.2/24
Configure IP address for the interface.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe3
Enter interface mode
(config-if)#ip address 30.30.1.2/24
Configure IP address for the interface.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#ospf router-id 9.9.9.9
Configure OSPF router id same as loopback IP address
(config-router)#transport-address ipv4 9.9.9.9
Configure transport address as loopback address.
(config-router)#network 10.1.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address.
(config-router)#network 20.20.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address.
(config-router)#network 30.30.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address.
(config-router)#network 9.9.9.9/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address.
(config)#commit
Commit the transaction.
PE-2
 
#configure terminal
Enter Configure mode
(config)#mpls ftn-entry tunnel-id 11 1.1.1.1/32 201 20.20.1.2 xe1 primary
Configure MPLS FTN entry for the creation of a static LSP to PE-1, and designate xe1 as primary.
(config)#mpls ftn-entry tunnel-id 33 3.3.3.3/32 301 20.20.1.2 xe1 primary
Configure MPLS FTN entry for the creation of a static LSP to PE-3, and designate xe1 as primary.
(config)#mpls ilm-entry 102 pop
Configure MPLS ILM entry for the creation of a static LSP to PE-1.
(config)#mpls ilm-entry 302 pop
Configure MPLS ILM entry for the creation of a static LSP to PE-3
(config)#mpls vpls v1 100
Configure VPLS v1 with ID 100 on PE-2.
(config-vpls)#vpls-peer 1.1.1.1 tunnel-id 11 manual
Configure PE-1 as a manual VPLS peer using static LSP tunnel ID
(config-vpls)#vpls-peer 3.3.3.3 tunnel-id 33 manual
Configure PE-3 as a manual VPLS peer using static LSP tunnel ID
(config-vpls)#exit
Exit Configure VPLS mode
(config)#interface lo
Enter interface mode
(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter interface mode
(config-if)#ip address 20.20.1.1/24
Configure IP address for the interface
(config-if)#label-switching
Configure label switching
(config-if)#exit
Exit interface mode
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe2
Enter interface mode
(config-if)#switchport
Make port Layer-2
(config-if)#mpls-vpls v1 service-template st1
Bind the VPLS to the Access Interface
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#exit
Exit interface mode
(config)#vpls fib-entry 100 peer 1.1.1.1 2500 xe1 1500
Configure VPLS FIB entry for VPLS peer PE-1.
(config)#vpls fib-entry 100 peer 3.3.3.3 3500 xe1 4500
Configure VPLS FIB entry for VPLS peer PE-3.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#ospf router-id 2.2.2.2
Configure OSPF router id same as loopback IP address
(config-router)#transport-address ipv4 2.2.2.2
Configure transport address as loopback address.
(config-router)#targeted-peer ipv4 1.1.1.1
Configure targeted peer.
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#network 20.20.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#network 2.2.2.2/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode
(config)#commit
Commit the transaction.
PE-3
 
#configure terminal
Enter Configure mode
(config)#mpls ftn-entry tunnel-id 11 1.1.1.1/32 301 30.30.1.2 xe1 primary
Configure MPLS FTN entry for the creation of a static LSP to PE-1.
(config)#mpls ftn-entry tunnel-id 22 2.2.2.2/32 302 30.30.1.2 xe1 primary
Configure MPLS FTN entry for the creation of a static LSP to PE-2.
(config)#mpls ilm-entry 103 pop
Configure MPLS ILM entry for the creation of a static LSP to PE-1.
(config)#mpls ilm-entry 203 pop
Configure MPLS ILM entry for the creation of a static LSP to PE-2.
(config)#mpls vpls v1 100
Configure VPLS v1 with ID 100 on PE-3.
(config-vpls)#vpls-peer 1.1.1.1 tunnel-id 11 manual
Configure PE-1 as a manual VPLS peer using static LSP tunnel ID 11.
(config-vpls)#vpls-peer 2.2.2.2 tunnel-id 22 manual
Configure PE-2 as a manual VPLS peer using static LSP tunnel ID 22.
(config-vpls)#exit
Exit Configure VPLS mode
(config)#interface lo
Enter interface mode
(config-if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter interface mode
(config-if)#ip address 30.30.1.1/24
Configure IP address for the interface
(config-if)#label-switching
Configure label switching
(config-if)#exit
Exit interface mode
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe2
Enter interface mode
(config-if)#switchport
Switch to Layer-2 mode
(config-if)#mpls-vpls v1 service-template st1
Bind the VPLS to the Access Interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#exit
Exit interface mode.
(config)#vpls fib-entry 100 peer 1.1.1.1 4000 xe1 3000
Configure VPLS FIB entry for VPLS peer PE-1.
(config)#vpls fib-entry 100 peer 2.2.2.2 4500 xe1 3500
Configure VPLS FIB entry for VPLS peer PE-2.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#ospf router-id 3.3.3.3
Configure OSPF router id same as loopback IP address
(config-router)#transport-address ipv4 3.3.3.3
Configure transport address as loopback address.
(config-router)#targeted-peer ipv4 1.1.1.1
Configure targeted peer.
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#network 30.30.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#network 3.3.3.3/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config)#commit
Commit the transaction.
Validation
Enter the commands listed in the sections below to confirm the configurations.
Verify VPLS Session on PE-1
#show mpls vpls detail
Virtual Private LAN Service Instance: v1, ID: 100
SIG-Protocol: STATIC
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe48
Service-template : st1
Match criteria : Accept all
 
Mesh Peers:
2.2.2.2 (Up)
Tunnel-Id: 11
3.3.3.3 (Up)
Tunnel-Id: 22
PE1#
 
 
Verify VPLS Peer
#show mpls vpls mesh
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
100 2.2.2.2 102 1000 xe1 2000 2/Up 1 STATIC Active
100 3.3.3.3 103 3000 xe1 4000 2/Up 2 STATIC Active
PE1#
 
Remove Configurations
Follow these steps to remove VPLS peer and VPLS spoke FIB entries from router PE-2.
 
#configure terminal
Enter configure mode
(config)#no vpls fib-entry 100 peer 1.1.1.1
Remove VPLS FIB for VPLS peer PE-1.
(config)#no vpls fib-entry 100 peer 3.3.3.3
Remove VPLS FIB for VPLS peer PE-3.
(config)#exit
Exit Configure mode