OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : Virtual Private LAN Service Configuration
Virtual Private LAN Service Configuration
This chapter contains configurations for Virtual Private LAN Service (VPLS).
VPLS Raw Mode
The examples show the minimum configuration required for enabling a VPLS Mesh peer between PE1, PE2, and PE3 in raw mode.
VPLS Mesh Peers Raw Mode
Configuration
PE1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the Interface (xe1) to be configured.
(config-if)#ip address 10.10.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID (100).
(config-router)#network 10.10.1.0/24 area 0
(config-router)#network 1.1.1.1/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)# router-id 1.1.1.1
Configure the router-id
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run.
(config-router)#targeted-peer ipv4 2.2.2.2
Configuring targeted LDP sessions to PE2
(config-router-targeted-peer)#exit
Exit config-router-targeted-peer mode
(config-router)#targeted-peer ipv4 3.3.3.3
Enter targeted-peer-mode and PE3
(config-router-targeted-peer)#exit
Exit config-router-targeted-peer mode
(config-router)#exit
Exit router configuration mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-peer 2.2.2.2
(config-vpls-sig)#vpls-peer 3.3.3.3
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.
P
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 9.9.9.9/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the interface to be configured.
(config-if)#ip address 10.10.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 20.20.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#ip address 30.30.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 10.10.1.0/24 area 0
(config-router)#network 20.20.1.0/24 area 0
(config-router)#network 30.30.1.0/24 area 0
(config-router)#network 9.9.9.9/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#router-id 9.9.9.9
Confirm the router-id
(config-router)#transport-address ipv4 9.9.9.9
Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run.
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#exit
Exit router mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface configuration mode.
(config)#interface xe2
Specify the interface to be configured.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.
PE2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the Interface (xe1) to be configured.
(config-if)#ip address 20.20.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 20.20.1.0/24 area 0
(config-router)#network 2.2.2.2/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#router-id 2.2.2.2
Confirm the router-id
(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run.
(config-router)#targeted-peer ipv4 1.1.1.1
Configuring targeted LDP sessions to PE2.
(config-router-targeted-peer)#exit
Exit targeted-peer-mode
(config-router)#targeted-peer ipv4 3.3.3.3
Configuring targeted LDP sessions to PE3
(config-router-targeted-peer)#exit
Exit targeted-peer-mode
(config-router)#exit
Exit router configuration mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-peer 1.1.1.1
(config-vpls-sig)#vpls-peer 3.3.3.3
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#service-template st1
Template configuration.
(config-svc)#exit
Exit service template mode.
(config)#interface xe2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.
PE3
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the Interface (xe1) to be configured.
(config-if)#ip address 30.30.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 30.30.1.0/24 area 0
(config-router)#network 3.3.3.3/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#router-id 3.3.3.3
Confirm the router-id
(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run.
(config-router)#targeted-peer ipv4 1.1.1.1
Configuring targeted LDP sessions to PE2
(config-router-targeted-peer)#exit
Exit targeted-peer-mode
(config-router)#targeted-peer ipv4 2.2.2.2
Configuring targeted LDP sessions to PE3
(config-router-targeted-peer)#exit
Exit targeted-peer-mode
(config-router)#exit
Exit router configuration mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-peer 1.1.1.1
(config-vpls-sig)#vpls-peer 2.2.2.2
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#service-template st1
Template configuration.
(config-svc)#exit
Exit service template mode.
(config)#interface xe2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.
Validation
PE1
Verify VPLS Session
PE1#show mpls vpls detail
Virtual Private LAN Service Instance: VPLS1, ID: 100
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Group ID: 0, VPLS Type: Ethernet, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe2
Service-template : st1
Match criteria : Accept all
 
Mesh Peers:
2.2.2.2 (Up)
3.3.3.3 (Up)
PE1#
 
Verify VPLS Mesh Peer
PE1#sh mpls vpls mesh
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
100 2.2.2.2 24325 24321 xe1 24321 2/Up 1 LDP Active
100 3.3.3.3 24322 24320 xe1 24321 2/Up 2 LDP Active
 
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe1 Passive OPERATIONAL 30 00:32:21
3.3.3.3 xe1 Passive OPERATIONAL 30 00:20:50
9.9.9.9 xe1 Passive OPERATIONAL 30 00:34:18
 
PE1#show ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.12.49.145 1 Full/Backup 00:00:35 10.10.1.2 xe1 0
 
P#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
1.1.1.1 xe1 Active OPERATIONAL 30 00:40:04
2.2.2.2 xe2 Active OPERATIONAL 30 00:38:22
3.3.3.3 xe3 Active OPERATIONAL 30 00:25:57
 
P#show ip ospf neighbor
Total number of full neighbors: 3
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.12.49.142 1 Full/DR 00:00:34 10.10.1.1 xe1 0
10.12.49.144 1 Full/Backup 00:00:29 20.20.1.1 xe2 0
10.12.49.146 1 Full/Backup 00:00:36 30.30.1.1 xe3 0
PE2#show mpls vpls detail
Virtual Private LAN Service Instance: VPLS1, ID: 100
SIG-Protocol: LDP Attachment-Circuit :UP
Learning: Enabled Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No Group ID: 0, VPLS Type: Ethernet,
Configured MTU: 1500
Description: none service-tpid: dot1.q Operating mode: Raw Configured interfaces:
Interface: xe2 Service-template : st1
Match criteria : Accept all
Mesh Peers:
1.1.1.1 (Up)
3.3.3.3 (Up)
 
PE2#show mpls vpls mesh
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
100 1.1.1.1 25601 26240 xe1 26240 2/Up 1 LDP Active
100 3.3.3.3 25603 26241 xe1 26241 2/Up 2 LDP Active
 
PE2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
1.1.1.1 xe1 Active OPERATIONAL 30 00:41:59
3.3.3.3 xe1 Passive OPERATIONAL 30 00:30:15
9.9.9.9 xe1 Passive OPERATIONAL 30 00:42:14
 
PE2#show ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.12.49.145 1 Full/DR 00:00:35 20.20.1.2 xe1 0
 
PE3#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
1.1.1.1 xe1 Active OPERATIONAL 30 00:44:25
2.2.2.2 xe1 Active OPERATIONAL 30 00:44:13
9.9.9.9 xe1 Passive OPERATIONAL 30 00:43:47
 
PE3#show ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.12.49.145 1 Full/DR 00:00:33 30.30.1.2 xe1 0
 
PE3#show mpls vpls detail
Virtual Private LAN Service Instance: VPLS1, ID: 100
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe2
Service-template : st1
Match criteria : Accept all
 
Mesh Peers:
1.1.1.1 (Up)
2.2.2.2 (Up)
 
PE3#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
100 1.1.1.1 25602 26240 xe1 26241 2/Up ] LDP Active
100 2.2.2.2 25603 26241 xe1 26241 2/Up 2 LDP Active
 
VPLS Tagged Mode
The examples show the minimum configuration required for enabling a VPLS Mesh peer between PE1, PE2, and PE3 in Tagged Mode. In the below example PE1 and PE2 uses VLAN 10 for binding the VPLS instance to the attachment circuit and PE3 used VLAN 20 where it shows that VLAN swapping is supported.
VPLS Mesh Peers Tagged Mode
Configuration
PE1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the Interface (xe1) to be configured.
(config-if)#ip address 10.10.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 10.10.1.0/24 area 0
(config-router)#network 1.1.1.1/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 2.2.2.2
Configuring targeted LDP sessions to PE2
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router-targeted-peer)#targeted-peer ipv4 3.3.3.3
Configuring targeted LDP sessions to PE3
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router)#exit
Exit router configuration mode
(config)#interface xe1
Enter interface mode
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-type vlan
Configuring VPLS type as VLAN mode.
(config-vpls-sig)#vpls-peer 2.2.2.2
(config-vpls-sig)#vpls-peer 3.3.3.3
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#mpls vpls v4 28
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 2.2.2.2
Configure VPLS Peers
config-vpls-sig)#vpls-peer 3.3.3.3
Configure VPLS Peers
(config-vpls-sig)#exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#service-template st1
Template configuration.
(config-svc)#match outer-vlan 10
Match criteria under template configuration
(config-svc)#exit
Exit service template mode.
(config)#interface xe2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface to match service template st1.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.
Service template with Multiple Match Support
This is to validate the multiple match criteria support in a service template. When multiple match statements are configured only rewrite push is supported, rewrite translate and pop are not supported.
 
(config)#service-template template4
Template configuration
(config-svc)#match outer-vlan 700
Allow VLAN 700 traffic on this VC
(config-svc)#match double-tag outer-vlan 1200 inner-vlan 3200
Allow double tag match with s+c tags
(config-svc)#match untagged
Allow untagged traffic
(config-svc)#rewrite ingress push 300
Push Action performed for service template
(config-svc)#exit
Exit configure SVC mode
(config)#interface xe2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls v4 service-template template4
Associating the VPLS Instance to the attachment circuit interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#commit
Commit the transaction.
P
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 9.9.9.9/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the interface to be configured.
(config-if)#ip address 10.10.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 20.20.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#ip address 30.30.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 10.1.1.0/24 area 0
(config-router)#network 20.20.1.0/24 area 0
(config-router)#network 30.30.1.0/24 area 0
(config-router)#network 9.9.9.9/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#exit
Exit router mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface configuration mode.
(config)#interface xe2
Specify the interface to be configured.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.
PE2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the Interface (xe1) to be configured.
(config-if)#ip address 20.20.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 20.20.1.0/24 area 0
(config-router)#network 2.2.2.2/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 1.1.1.1
Configuring targeted LDP sessions to PE2
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router-targeted-peer)#targeted-peer ipv4 3.3.3.3
Configuring targeted LDP sessions to PE3
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit targeted peer mode.
(config-router)#exit
Exit router configuration mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-type vlan
Configuring VPLS type as VLAN mode.
(config-vpls-sig)#vpls-peer 1.1.1.1
(config-vpls-sig)#vpls-peer 3.3.3.3
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#mpls vpls v4 28
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 1.1.1.1
Configure VPLS Peers
config-vpls-sig)#vpls-peer 3.3.3.3
Configure VPLS Peers
(config-vpls-sig)#exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#service-template st1
Template configuration.
(config-svc)#match outer-vlan 10
Match criteria under template configuration
(config-svc)#exit
Exit service template mode.
(config)#service-template template4
Template configuration
(config-svc)#match outer-vlan 700
Allow VLAN 700 traffic on this VC
(config-svc)#match double-tag outer-vlan 1200 inner-vlan 3200
Allow double tag match with s+c tags
(config-svc)#match untagged
Allow untagged traffic
(config-svc)#rewrite ingress push 300
Push Action performed for service template
(config-svc)#exit
Exit configure SVC mode
(config)#interface xe2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface to match service template st1.
(config-if)mpls-vpls v4 service-template template4
Associating the VPLS Instance to the attachment circuit interface.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.
PE3
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the Interface (xe1) to be configured.
(config-if)#ip address 30.30.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 30.30.1.0/24 area 0
(config-router)#network 3.3.3.3/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 1.1.1.1
Configuring targeted LDP sessions to PE2
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router-targeted-peer)#targeted-peer ipv4 2.2.2.2
Configuring targeted LDP sessions to PE3
config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router)#exit
Exit router configuration mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-type vlan
Configuring VPLS type as VLAN mode.
(config-vpls-sig)#vpls-peer 1.1.1.1
(config-vpls-sig)#vpls-peer 2.2.2.2
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#mpls vpls v4 28
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 1.1.1.1
Configure VPLS Peers
(config-vpls-sig)#vpls-peer 2.2.2.2
Configure VPLS Peers
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#service-template st1
Template configuration.
(config-svc)#match outer-vlan 20
Match criteria under template configuration
(config-svc)#exit
Exit service template mode.
(config)#service-template template4
Template configuration
(config-svc)#match outer-vlan 700
Allow VLAN 700 traffic on this VC
(config-svc)#match double-tag outer-vlan 1200 inner-vlan 3200
Allow double tag match with s+c tags
(config-svc)#match untagged
Allow untagged traffic
(config-svc)#rewrite ingress push 300
Push Action performed for service template
(config-svc)#exit
Exit configure SVC mode
(config)#interface xe2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls v4 service-template st1
Associating the VPLS Instance to the attachment circuit interface to match service template st1.
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.
Validation
PE1
Verify VPLS Session:
PE1#show mpls vpls detail
Virtual Private LAN Service Instance: VPLS1, ID: 100
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
Configured interfaces:
Interface: xe2
Service-template : s1
Match criteria : 10
 
Mesh Peers:
2.2.2.2 (Up)
3.3.3.3 (Up)
 
Virtual Private LAN Service Instance: v4, ID: 28
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
Configured interfaces:
Interface: xe2
Service-template : template4
Match criteria : 700
1200/3200
Untagged
Action type : Push
Action value : 300
 
Mesh Peers:
2.2.2.2 (Up)
3.3.3.3 (Up)
PE1#
Verify VPLS Mesh Peer:
PE1#show mpls vpls mesh
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status Ecmp-Group100
100 2.2.2.2 24320 24322 xe2 24321 2/Up 1 LDP Active N/A
100 3.3.3.3 24325 24321 xe2 24323 2/Up 1 LDP Active N/A
28 2.2.2.2 24327 24324 xe2 24325 2/Up 1 LDP Active N/A
28 3.3.3.3 24345 24325 xe2 24324 2/Up 1 LDP Active N/A
 
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe1 Passive OPERATIONAL 30 00:22:12
3.3.3.3 xe1 Passive OPERATIONAL 30 00:17:27
9.9.9.9 xe1 Passive OPERATIONAL 30 00:24:53
 
PE1#show ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
9.9.9.9 1 Full/Backup 00:00:37 10.10.1.2 xe1 0
 
p#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
1.1.1.1 xe1 Active OPERATIONAL 30 00:03:07
2.2.2.2 xe2 Active OPERATIONAL 30 00:25:52
3.3.3.3 xe3 Active OPERATIONAL 30 00:03:09
 
p#show ip ospf neighbor
Total number of full neighbors: 3
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
1.1.1.1 1 Full/DR 00:00:30 10.10.1.1 xe1 0
2.2.2.2 1 Full/Backup 00:00:38 20.20.1.1 xe2 0
3.3.3.3 1 Full/Backup 00:00:37 30.30.1.1 xe3 0
 
PE2#show mpls vpls detail
Virtual Private LAN Service Instance: v4, ID: 28
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
Configured interfaces:
Interface: xe2
Service-template : template4
Match criteria : 700,
Untagged ,
1200/3200
Action type : Push
Action value : 300
 
Mesh Peers:
1.1.1.1 (Up)
3.3.3.3 (Up)
 
Virtual Private LAN Service Instance: VPLS1, ID: 100
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
Configured interfaces:
Interface: xe2
Service-template : st1
Match criteria : 10
 
Mesh Peers:
1.1.1.1 (Up)
3.3.3.3 (Up)
 
PE2#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
28 1.1.1.1 25601 26241 xe1 26240 2/Up 1 LDP Active
28 3.3.3.3 25603 26242 xe1 27523 2/Up 2 LDP Active
100 1.1.1.1 25601 26240 xe1 26241 2/Up 3 LDP Active
100 3.3.3.3 25603 26243 xe1 27520 2/Up 4 LDP Active
 
PE2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
1.1.1.1 xe1 Active OPERATIONAL 30 00:35:15
3.3.3.3 xe1 Passive OPERATIONAL 30 00:30:51
9.9.9.9 xe1 Passive OPERATIONAL 30 00:00:59
 
PE2#show ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
9.9.9.9 1 Full/DR 00:00:32 20.20.1.2 xe1 0
 
PE3#show mpls vpls detail
Virtual Private LAN Service Instance: v4, ID: 28
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
Configured interfaces:
Interface: xe2
Service-template : template4
Match criteria : 700,
Untagged ,
1200/3200
Action type : Push
Action value : 300
 
Mesh Peers:
1.1.1.1 (Up)
2.2.2.2 (Up)
 
Virtual Private LAN Service Instance: VPLS1, ID: 100
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
 
Svlan Tpid: 8100
Configured interfaces:
Interface: xe2
Service-template : st1
Match criteria : 20
 
Mesh Peers:
1.1.1.1 (Up)
2.2.2.2 (Up)
 
PE3#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
9.9.9.9 xe1 Passive OPERATIONAL 30 00:02:23
1.1.1.1 xe1 Active OPERATIONAL 30 00:31:56
2.2.2.2 xe1 Active OPERATIONAL 30 00:32:17
 
PE3#show ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
9.9.9.9 1 Full/DR 00:00:37 30.30.1.2 xe1 0
Validation for the Number of Configured VPLS Instances
This example below shows number of configured VPLS instances.
PE1#show mpls vpls count
-------------------------------
Total VPLS instances : 2
Active VPLS instances : 2
Inactive VPLS instances : 2
-------------------------------
The example below shows the Count of VPLS from LDP standpoint
PE1#show ldp vpls count
-------------------------------
Total VPLS instances : 2
Active VPLS instances : 2
Inactive VPLS instances : 0
-------------------------------
The example below shows the number of MAC addresses learned by VPLS.
PE1#show mpls vpls mac-address count
Total no of MAC addresses learnt :6
 
VPLS Split Horizon Group
In VPLS Hierarchy, multiple attachment circuits (AC) can be configured per few VPLS instances and AC-AC traffic blocking is not supported.Thus,when the PE router receives a broadcast, multicast, or unknown unicast packet on an AC.It sends the packet out on all other attachment circuits to all other CE devices participating in that VPLS instance.
To avoid this problem of a packet looping in the provider core, the PE devices enforce a "split-horizon" principle for the VPLS instances. That means the traffic will not flood if AC1 and AC2 are in same split horizon group.
The examples show the minimum configuration required for enabling a VPLS Mesh peer between PE-1, PE-2 with split horizon group. In the below example PE-1 and PE-2 uses split horizon groups where traffic can't be forwarded between the ACs if they are part of same access groups.But can send/receive from network ports.
Figure 8-15: VPLS Mesh Peers split horizon
Configuration With Service Template
PE1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 48.48.48.48/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe0
Specify the Interface to be configured.
(config-if)#ip address 40.40.40.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe19
Specify the Interface to be configured
(config-if)#ip address 57.57.57.6/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe20
Specify the Interface to be configured
(config-if)#ip address 52.52.52.5/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface
(config-if)#exit
Exit interface mode.
(config)#router isis ISIS-IGP
Create an IS-IS routing instance
(config)#is-type level-1
Configure instance as level-2-only routing.
(config)#metric-style wide
Configure the new style of metric type as wide.
(config)#mpls traffic-eng router-id 48.48.48.48
Configure MPLS-TE unique router-id TLV.
(config)#mpls traffic-eng level-1
Enable MPLS-TE in is-type Level-1
(config)#capability cspf
Enable CSPF feature for ISIS instance.
(config)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance
(config)#fast-reroute ti-lfa level-1 proto ipv4
Configure LFA-FRR to calculate the available backup path for all L1 IPv4 prefixes learned
(config)#fast-reroute ti-lfa level-2 proto ipv4
Configure LFA-FRR to calculate the available backup path for all L2 IPv4 prefixes learned
(config)#bfd all-interfaces
Enable BFD for all neighbors.
(config)#net 49.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 45.45.45.45
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit
Exit config-router-targeted-peer mode
(config-router)#exit
Exit router configuration mode.
(config)#router bgp 65010
Define the routing process. The number 65010
specifies the AS number
(config-router)#bgp router-id 48.48.48.48
Assign a BGP router ID.
(config-router)#neighbor 45.45.45.45 remote-as 65010
Define the eBGP neighbor
(config-router)#neighbor 45.45.45.45 fall-over bfd multihop
Enabling BFD at BGP level for particular neighbor.
(config-router)#neighbor 45.45.45.45 update-source lo
Update the source for that particular neighbor as loopback interface
(config-router)#address-family ipv4 unicast
Enter into labeled-unicast address family
(config-router)#neighbor 45.45.45.45 activate
Activate the neighbor inside labeled-unicast address family
(config-router)#exit-address-family
Exit from address family IPv4 labeled unicast
(config-router)#address-family vpnv4 unicast
Enter into vpnv4 unicast address family
(config-router)#neighbor 45.45.45.45 activate
Activate the neighbor inside vpnv4 address family
(config-router)#exit-address-family
Exit from address family vpnv4
(config-router)#address-family ipv6 unicast
Enter into labeled-unicast address family
(config-router)#redistribute connected
Redistribute the connected routes.
(config-router)#exit-address-family
Exit from address family IPv6 labeled unicast
(config)#mpls vpls VPLS-PE1-PE2-600 600
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls)#vpls-type vlan
Configure VPLS type as VLAN encapsulation
(config-vpls-sig)#vpls-peer 45.45.45.45
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#mpls vpls VPLS-PE1-PE2-601 601
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls)#vpls-type vlan
Configure VPLS type as VLAN encapsulation
(config-vpls-sig)#vpls-peer 45.45.45.45
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#mpls vpls VPLS-PE1-PE2-602 602
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls)#vpls-type vlan
Configure VPLS type as VLAN encapsulation
(config-vpls-sig)#vpls-peer 45.45.45.45
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#service-template ST-VPLS-PE1-PE2-600
Template configuration
(config-svc)#exit
Exit service template mode
(config)#service-template ST-VPLS-PE1-PE2-601
Template configuration
(config-svc)#exit
Exit service template mode
(config)#service-template ST-VPLS-PE1-PE2-602
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)#mpls-vpls VPLS-PE1-PE2-600 service-template ST-VPLS-PE1-PE2-600
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#split-horizon group access1
Configuring split horizon group.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls VPLS-PE1-PE2-601 service-template ST-VPLS-PE1-PE2-601
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#split-horizon group access1
Configuring split horizon group
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls VPLS-PE1-PE2-602 service-template ST-VPLS-PE1-PE2-602
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#split-horizon group access1
Configuring split horizon group
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config)#interface xe23
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)#mpls-vpls VPLS-PE1-PE2-600 service-template ST-VPLS-PE1-PE2-600
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#split-horizon group access1
Configuring split horizon group
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls VPLS-PE1-PE2-601 service-template ST-VPLS-PE1-PE2-601
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#split-horizon group access1
Configuring split horizon group
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#mpls-vpls VPLS-PE1-PE2-602 service-template ST-VPLS-PE1-PE2-602
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#split-horizon group access1
Configuring split horizon group
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.
P1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 18.18.18.18/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface ge6
Specify the interface to be configured.
(config-if)#ip address 60.60.60.2/24
Configure IP address for the interface.
(config-if)#label-switching
Enabling label switching capability on router
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Specify the Interface to be configured
(config-if)#ip address 60.60.60.2/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Enable LDP IS-IS synchronization
(config-if)#ip router isis ISIS-IGP
Configure the ISIS interface network type as point to point
(config-if)#enable-ldp ipv4
Enable IS-IS routing on an interface
(config-if)#exit
Enable IPv4 LDP configuration on interface
(config)#interface xe3
Exit interface mode.
(config-if)#ip address 80.80.80.1/24
Configure IP address for the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface for area 49
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface.
(config-if)#exit
Exit interface mode.
(config)#router isis ISIS-IGP
Create an IS-IS routing instance
(config)#is-type level-1
Configure instance as level-2-only routing.
(config)#metric-style wide
Configure the new style of metric type as wide.
(config)#mpls traffic-eng router-id 18.18.18.18
Configure MPLS-TE unique router-id TLV.
(config)#mpls traffic-eng level-1
Enable MPLS-TE in is-type Level-1
(config)#capability cspf
Enable CSPF feature for ISIS instance.
(config)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance
(config)#fast-reroute ti-lfa level-1 proto ipv4
Configure LFA-FRR to calculate the available backup path for all L1 IPv4 prefixes learned
(config)#fast-reroute ti-lfa level-2 proto ipv4
Configure LFA-FRR to calculate the available backup path for all L2 IPv4 prefixes learned
(config)#fast-reroute ti-lfa level-2 proto ipv4
Configure LFA-FRR to calculate the available backup path for all L2 IPv4 prefixes learned
(config)#bfd all-interfaces
Enable BFD for all neighbors.
(config)#net 49.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#exit
Exit router mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.
PE2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 45.45.45.45/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the Interface to be configured.
(config-if)#ip address 60.60.60.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe4
Specify the Interface to be configured.
(config-if)#ip address 70.70.70.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe8
Specify the Interface to be configured.
(config-if)#ip address 57.57.57.7/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface
(config-if)#exit
Exit interface mode.
(config)#router isis ISIS-IGP
Create an IS-IS routing instance
(config)#is-type level-1
Configure instance as level-2-only routing.
(config)#metric-style wide
Configure the new style of metric type as wide.
(config)#mpls traffic-eng router-id 48.48.48.48
Configure MPLS-TE unique router-id TLV.
(config)#mpls traffic-eng level-1
Enable MPLS-TE in is-type Level-1
(config)#capability cspf
Enable CSPF feature for ISIS instance.
(config)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance
(config)#fast-reroute ti-lfa level-1 proto ipv4
Configure LFA-FRR to calculate the available backup path for all L1 IPv4 prefixes learned
(config)#fast-reroute ti-lfa level-2 proto ipv4
Configure LFA-FRR to calculate the available backup path for all L2 IPv4 prefixes learned
(config)#bfd all-interfaces
Enable BFD for all neighbors.
(config)#net 49.0000.0000.0003.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 48.48.48.48
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit
Exit config-router-targeted-peer mode
(config-router)#exit
Exit router configuration mode.
(config)#router bgp 65010
Define the routing process. The number 65010
specifies the AS number
(config-router)#bgp router-id 45.45.45.45
Assign a BGP router ID.
(config-router)#neighbor 48.48.48.48 remote-as 65010
Define the eBGP neighbor
(config-router)#neighbor 48.48.48.48 fall-over bfd multihop
Enabling BFD at BGP level for particular neighbor.
(config-router)#neighbor 48.48.48.48 update-source lo
Update the source for that particular neighbor as loopback interface
(config-router)#address-family ipv4 unicast
Enter into labeled-unicast address family
(config-router)#neighbor 48.48.48.48 activate
Activate the neighbor inside labeled-unicast address family
(config-router)#exit-address-family
Exit from address family IPv4 labeled unicast
(config-router)#address-family vpnv4 unicast
Enter into vpnv4 unicast address family
(config-router)#neighbor 48.48.48.48 activate
Activate the neighbor inside vpnv4 address family
(config-router)#exit-address-family
Exit from address family vpnv4
(config-router)#address-family ipv6 unicast
Enter into labeled-unicast address family
(config-router)#redistribute connected
Redistribute the connected routes.
(config-router)#exit-address-family
Exit from address family IPv6 labeled unicast
(config)#mpls vpls VPLS-PE1-PE2-600 600
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls)#vpls-type vlan
Configure VPLS type as VLAN encapsulation
(config-vpls-sig)#vpls-peer 48.48.48.48
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#mpls vpls VPLS-PE1-PE2-601 601
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls)#vpls-type vlan
Configure VPLS type as VLAN encapsulation
(config-vpls-sig)#vpls-peer 48.48.48.48
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#mpls vpls VPLS-PE1-PE2-602 602
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls)#vpls-type vlan
Configure VPLS type as VLAN encapsulation
(config-vpls-sig)#vpls-peer 48.48.48.48
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#interface xe2.600 switchport
Creates a L2 sub-interface as xe2.600.
(config-if)#encapsulation dot1q 600
Configuring the attachment circuit interface as Layer-2.
(config-if)#rewrite push 0x8100 4050
Configure rewrite push.
(config-if)#split-horizon group access1
Configuring split horizon group.
(config-if-vpls)#load-interval 30
Configure load period in multiple of 30 seconds
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-if-vpls)#mpls-vpls VPLS-PE1-PE2-600
Associating the VPLS Instance to the attachment circuit interface.
(config)#interface xe2.601 switchport
Creates a L2 sub-interface as xe2.600.
(config-if)#encapsulation dot1q 601
Configuring the attachment circuit interface as Layer-2.
(config-if)#rewrite push 0x8100 4050
Configure rewrite push.
(config-if)#split-horizon group access1
Configuring split horizon group.
(config-if-vpls)#load-interval 30
Configure load period in multiple of 30 seconds
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-if-vpls)#mpls-vpls VPLS-PE1-PE2-601
Associating the VPLS Instance to the attachment circuit interface.
(config)#interface xe2.602 switchport
Creates a L2 sub-interface as xe2.600.
(config-if)#encapsulation dot1q 602
Configuring the attachment circuit interface as Layer-2.
(config-if)#rewrite push 0x8100 4050
Configure rewrite push.
(config-if)#split-horizon group access1
Configuring split horizon group.
(config-if-vpls)#load-interval 30
Configure load period in multiple of 30 seconds
(config-if)#access-if-vpls
Access VPLS under sub interface
config-if-vpls)#mpls-vpls VPLS-PE1-PE2-602
Associating the VPLS Instance to the attachment circuit interface.
(config)#interface xe23.600 switchport
Creates a L2 sub-interface as xe2.600.
(config-if)#encapsulation dot1q 600
Configuring the attachment circuit interface as Layer-2.
(config-if)#rewrite push 0x8100 4050
Configure rewrite push.
(config-if)#split-horizon group access1
Configuring split horizon group.
(config-if-vpls)#load-interval 30
Configure load period in multiple of 30 seconds
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-if-vpls)#mpls-vpls VPLS-PE1-PE2-600
Associating the VPLS Instance to the attachment circuit interface.
(config)#interface xe23.601 switchport
Creates a L2 sub-interface as xe2.600.
(config-if)#encapsulation dot1q 601
Configuring the attachment circuit interface as Layer-2.
(config-if)#rewrite push 0x8100 4050
Configure rewrite push.
(config-if)#split-horizon group access1
Configuring split horizon group.
(config-if-vpls)#load-interval 30
Configure load period in multiple of 30 seconds
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-if-vpls)#mpls-vpls VPLS-PE1-PE2-601
Associating the VPLS Instance to the attachment circuit interface.
(config)#interface xe23.602 switchport
Creates a L2 sub-interface as xe2.600.
(config-if)#encapsulation dot1q 602
Configuring the attachment circuit interface as Layer-2.
(config-if)#rewrite push 0x8100 4050
Configure rewrite push.
(config-if)#split-horizon group access1
Configuring split horizon group.
(config-if-vpls)#load-interval 30
Configure load period in multiple of 30 seconds
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-if-vpls)#mpls-vpls VPLS-PE1-PE2-602
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#commit
Commit the candidate configuration to the running configuration.
(config-if)#exit
Exit interface mode
#copy running-config startup-config
Save the configuration.
P2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 46.46.46.46/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the interface to be configured.
(config-if)#ip address 80.80.80.2/24
Configure IP address for the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface for area 49
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 70.70.70.2/24
Specify the interface to be configured.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface for area 49
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#ip address 40.40.40.2/24
Specify the interface to be configured.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#mpls ldp-igp sync isis level-1-2
Enable LDP IS-IS synchronization
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface for area 49
(config-if)#enable-ldp ipv4
Enable IPv4 LDP configuration on interface.
(config-if)#exit
Exit interface mode.
(config)#router isis ISIS-IGP
Create an IS-IS routing instance
(config)#is-type level-1
Configure instance as level-2-only routing.
(config)#metric-style wide
Configure the new style of metric type as wide.
(config)#mpls traffic-eng router-id 46.46.46.46
Configure MPLS-TE unique router-id TLV.
(config)#mpls traffic-eng level-1
Enable MPLS-TE in is-type Level-1
(config)#capability cspf
Enable CSPF feature for ISIS instance.
(config)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance
(config)#fast-reroute ti-lfa level-1 proto ipv4
Configure LFA-FRR to calculate the available backup path for all L1 IPv4 prefixes learned
(config)#fast-reroute ti-lfa level-2 proto ipv4
Configure LFA-FRR to calculate the available backup path for all L2 IPv4 prefixes learned
(config)#bfd all-interfaces
Enable BFD for all neighbors.
(config)#net 49.0000.0000.0004.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#exit
Exit router mode.
(config)#commit
Commit the transaction.
#copy running-config startup-config
Save the configuration.