OcNOS-SP : Multicast Guide : Multicast Configuration Guide : VRRP Aware PIM Configuration
VRRP Aware PIM Configuration
VRRP Aware PIM is a redundancy mechanism for the Protocol Independent Multicast to interoperate with the Virtual Router Redundancy Protocol. It helps PIM to track VRRP state changes and to preserve multicast traffic upon failover. In order to ensure that the PIM DR is always able to forward PIM Join/Prune message towards RP, the VRRP master router becomes the PIM DR.
Topology
 
VRRP Aware PIM Topology
In the configs below IGMP host is towards SW1 and source is towards SW2.
SW1
 
SW1#configure terminal
Enter configure mode.
SW1(config)#bridge 1 protocol ieee vlan-bridge
Configure bridge as IEEE VLAN bridge
SW1(config)#vlan 2 bridge 1 state enable
Configure VLANs
SW1(config)#interface eth1
Enter interface mode.
SW1(config-if)#switchport
Configure eth1 as a layer 2 port.
SW1(config-if)#bridge-group 1
Associate bridge to an interface.
SW1(config-if)#switchport mode trunk
Configure port as a trunk.
SW1(config-if)#switchport trunk allowed vlan add 2
Allow VLAN 2 on the eth1 interface.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#interface eth2
Enter interface mode.
SW1(config-if)#switchport
Configure eth2 as a layer 2 port.
SW1(config-if)#bridge-group 1
Associate bridge to an interface.
SW1(config-if)#switchport mode trunk
Configure port as a trunk.
SW1(config-if)#switchport trunk allowed vlan add 2
Allow VLAN 2 on the eth2 interface.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#interface eth3
Enter interface mode.
SW1(config-if)#switchport
Configure eth3 as a layer 2 port.
SW1(config-if)#bridge-group 1
Associate bridge to an interface.
SW1(config-if)#switchport mode trunk
Configure port as a trunk.
SW1(config-if)#switchport trunk allowed vlan add 2
Allow VLAN 2 on the eth1 interface.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#no igmp snooping
Disable IGMP snooping
SW1(config)#commit
Commit the transaction.
R1
 
R1#configure terminal
Enter configure mode.
R1(config)#bridge 1 protocol ieee vlan-bridge
Configure bridge as IEEE VLAN bridge
R1(config)#vlan 2 bridge 1 state enable
Configure VLANs
R1(config)#ip multicast-routing
Configure multicast routing on R1
R1(config)#ip pim rp-address 1.1.1.4
Statically configure RP address for multicast groups.
R1(config)#interface lo
Enter interface mode.
R1(config-if)#ip address 1.1.1.1/32
Configure the IP address of the interface.
R1(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R1(config-if)#exit
Exit interface mode.
R1(config)#interface eth1
Enter interface mode.
R1(config-if)#switchport
Configure eth3 as a Layer 2 port.
R1(config-if)#bridge-group 1
Associate bridge to an interface.
R1(config-if)#switchport mode trunk
Configure port as a trunk.
R1(config-if)#switchport trunk allowed vlan add 2
Allow VLAN 2 on the eth1 interface.
R1(config-if)#exit
Exit interface mode.
R1(config)#interface vlan1.2
Enter interface mode.
R1(config-if)#ip address 100.1.1.1/24
Configure the IP address of the interface.
R1(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R1(config-if)#ip pim redundancy 1 vrrp dr-priority 101
Configure VRRP aware PIM command with dr-priority and VRRP instance
R1(config)#interface eth2
Enter interface mode.
R1(config-if)#ip address 20.1.1.1/24
Configure the IP address of the interface.
R1(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R1(config)#interface eth3
Enter interface mode.
R1(config-if)#ip address 29.1.1.1/24
Configure the IP address of the interface.
R1(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R1(config-if)#exit
Exit interface mode.
R1(config)#interface eth4
Enter interface mode.
R1(config-if)#ip address 5.1.1.1/24
Configure the IP address of the interface.
R1(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R1(config-if)#exit
Exit interface mode.
R1(config)#router ospf 1
Set the routing process ID.
R1(config-router)#network 1.1.1.1/32 area 0.0.0.0
Configure OSPF network in area 0
R1(config-router)#ospf router-id 1.1.1.1
Configure OSPF router-ID
R1(config-router)#network 20.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0
R1(config-router)#network 29.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0
R1(config-router)#network 5.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0
R1(config-router)#exit
Exit router mode.
R1(config)#router vrrp 1 vlan1.2
Create a VRRP instance for interface VLAN1.2
R1(config-router)#virtual-ip 100.1.1.1
Set the virtual IP address for the VRRP session
R1(config-router)#enable
Enable the VRRP session on the router.
R1(config-router)#commit
Commit the transaction.
R2
 
R2#configure terminal
Enter configure mode.
R2(config)#bridge 1 protocol ieee vlan-bridge
Configure bridge as IEEE VLAN bridge
R2(config)#vlan 2 bridge 1 state enable
Configure VLANs
R2(config)#ip multicast-routing
Configure multicast routing on R2
R2(config)#ip pim rp-address 1.1.1.4
Statically configure RP address for multicast groups.
R2(config)#interface lo
Enter interface mode.
R2(config-if)#ip address 1.1.1.2/32
Configure the IP address of the interface.
R2(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R2(config-if)#exit
Exit interface mode.
R2(config)#interface eth1
Enter interface mode.
R2(config-if)#ip address 50.1.1.2/24
Configure the IP address of the interface.
R2(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R2(config)#interface eth2
Enter interface mode.
R2(config-if)#switchport
Configure eth3 as a Layer 2 port.
R2(config-if)#bridge-group 1
Associate bridge to an interface.
R2(config-if)#switchport mode trunk
Configure port as a trunk.
R2(config-if)#switchport trunk allowed vlan add 2
Allow VLAN 2 on the eth1 interface.
R2(config)#interface eth3
Enter interface mode.
R2(config-if)#ip address 29.1.1.2/24
Configure the IP address of the interface.
R2(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R2(config-if)#exit
Exit interface mode.
R2(config)#interface vlan1.2
Enter interface mode.
R2(config-if)#ip address 100.1.1.2/24
Configure the IP address of the interface.
R2(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R2(config-if)#ip pim redundancy 1 vrrp dr-priority 101
Configure VRRP aware PIM command with dr-priority and VRRP instance
R2(config)#router ospf 1
Set the routing process ID .
R2(config-router)#ospf router-id 1.1.1.2
Configure OSPF router-ID
R2(config-router)#network 1.1.1.2/32 area 0.0.0.0
Configure OSPF network in area 0
R2(config-router)#network 29.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0
R2(config-router)#network 50.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0
R2(config-router)#exit
Exit router mode.
R2(config)#router vrrp 1 vlan1.2
Create a VRRP instance for interface VLAN1.2
R2(config-router)#virtual-ip 100.1.1.1
Set the virtual IP address for the VRRP session
R2(config-router)#enable
Enable the VRRP session on the router.
R2(config-router)#commit
Commit the transaction.
R3
 
R3#configure terminal
Enter configure mode.
R3(config)#bridge 1 protocol ieee vlan-bridge
Configure bridge as IEEE VLAN bridge
R3(config)#vlan 2 bridge 1 state enable
Configure VLANs
R3(config)#ip multicast-routing
Configure multicast routing on R3
R3(config)#ip pim rp-address 1.1.1.4
Statically configure RP address for multicast groups.
R3(config)#interface lo
Enter interface mode.
R3(config-if)#ip address 1.1.1.3/32
Configure the IP address of the interface.
R3(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R3(config-if)#exit
Exit interface mode.
R3(config)#interface eth1
Enter interface mode.
R3(config-if)#switchport
Configure eth3 as a Layer 2 port.
R3(config-if)#bridge-group 1
Associate bridge to an interface.
R3(config-if)#switchport mode trunk
Configure port as a trunk.
R3(config-if)#switchport trunk allowed vlan add 2
Allow VLAN 2 on the eth1 interface.
R3(config)#interface eth2
Enter interface mode.
R3(config-if)#ip address 20.1.1.2/24
Configure the IP address of the interface.
R3(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R3(config)#interface eth3
Enter interface mode.
R3(config-if)#ip address 45.1.1.2/24
Configure the IP address of the interface.
R3(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R3(config-if)#exit
Exit interface mode.
R3(config)#interface vlan1.2
Enter interface mode.
R3(config-if)#ip address 200.1.1.2/24
Configure the IP address of the interface.
R3(config-if)#ip pim sparse-mode
Configure PIM as sparse mode.
R3(config-if)#exit
Exit interface mode.
R3(config)#router ospf 1
Set the routing process ID.
R3(config-router)#ospf router-id 1.1.1.3
Configuring OSPF router-ID.
R3(config-router)#network 1.1.1.3/32 area 0.0.0.0
Configure OSPF network in area 0.
R3(config-router)#network 200.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0.
R3(config-router)#network 20.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0.
R3(config-router)#network 45.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0.
R3(config-router)#commit
Commit the transaction.
R4
 
R4#configure terminal
Enter configure mode.
R4(config)#bridge 1 protocol ieee vlan-bridge
Configure bridge as IEEE VLAN bridge
R4(config)#vlan 2 bridge 1 state enable
Configure VLANs
R4(config)#ip multicast-routing
Configure multicast routing on R4
R4(config)#ip pim rp-address 1.1.1.4
statically configure RP address for multicast groups.
R4(config)#interface lo
Enter interface mode.
R4(config-if)#ip address 1.1.1.4/32
Configure the IP address of the interface.
R4(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R4(config-if)#exit
Exit interface mode.
R4(config)#interface eth1
Enter interface mode.
R4(config-if)#ip address 50.1.1.1/24
Configure the IP address of the interface.
R4(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R4(config)#interface eth2
Enter interface mode.
R4(config-if)#switchport
Configure eth3 as a Layer 2 port.
R4(config-if)#bridge-group 1
Associate bridge to an interface.
R4(config-if)#switchport mode trunk
Configure port as a trunk.
R4(config-if)#switchport trunk allowed vlan add 2
Allow VLAN 2 on the eth1 interface.
R4(config)#interface eth3
Enter interface mode.
R4(config-if)#ip address 45.1.1.1/24
Configure the IP address of the interface.
R4(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R4(config-if)#exit
Exit interface mode.
R4(config)#interface eth4
Enter interface mode.
R4(config-if)#ip address 5.1.1.2/24
Configure the IP address of the interface.
R4(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R4(config-if)#exit
Exit interface mode.
R4(config)#interface vlan1.2
Enter interface mode.
R4(config-if)#ip address 200.1.1.1/24
Configure the IP address of the interface.
R4(config-if)#ip pim sparse-mode
Configure PIM as sparse mode
R4(config-if)#exit
Exit interface mode.
R4(config)#router ospf 1
Set the routing process ID .
R4(config-router)#ospf router-id 1.1.1.4
Configuring OSPF router-ID
R4(config-router)#network 1.1.1.4/32 area 0.0.0.0
Configure OSPF network in area 0
R4(config-router)#network 200.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0
R4(config-router)#network 45.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0
R4(config-router)#network 50.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0
R4(config-router)#network 5.1.1.0/24 area 0.0.0.0
Configure OSPF network in area 0
R4(config-router)#commit
Commit the transaction.
SW2
 
SW2#configure terminal
Enter configure mode.
SW2(config)#bridge 1 protocol ieee vlan-bridge
Configure bridge as IEEE VLAN bridge
SW2(config)#vlan 2 bridge 1 state enable
Configure VLANs
SW2(config)#interface eth1
Enter interface mode.
SW2(config-if)#switchport
Configure eth1 as a Layer 2 port.
SW2(config-if)#bridge-group 1
Associate bridge to an interface.
SW2(config-if)#switchport mode trunk
Configure port as a trunk.
SW2(config-if)#switchport trunk allowed vlan add 2
Allow VLAN 2 on the eth1 interface.
SW2(config-if)#exit
Exit interface mode.
SW2(config)#interface eth2
Enter interface mode.
SW2(config-if)#switchport
Configure eth2 as a Layer 2 port.
SW2(config-if)#bridge-group 1
Associate bridge to an interface.
SW2(config-if)#switchport mode trunk
Configure port as a trunk.
SW2(config-if)#switchport trunk allowed vlan add 2
Allow VLAN 2 on the eth2 interface.
SW2(config-if)#exit
Exit interface mode.
SW2(config)#interface eth3
Enter interface mode.
SW2(config-if)#switchport
Configure eth3 as a Layer 2 port.
SW2(config-if)#bridge-group 1
Associate bridge to an interface.
SW2(config-if)#switchport mode trunk
Configure port as a trunk.
SW2(config-if)#switchport trunk allowed vlan add 2
Allow VLAN 2 on the eth1 interface.
SW2(config-if)#commit
Commit the transaction.
Validation
Verify that PIM DR is the same node as VRRP Master.
Validation 1
R1#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
1.1.1.5 1 Full/DR 00:00:31 5.1.1.2 eth4 0
1.1.1.3 1 Full/DR 00:00:36 10.2.3.2 eth3 0
1.1.1.4 1 Full/DR 00:00:35 10.2.4.2 eth2 0
 
R1#show vrrp
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled
 
Address family IPv4
VRRP Id: 1 on interface: vlan1.2
State: AdminUp - Master
Virtual IP address: 100.1.1.1 (Owner)
Virtual MAC address is 0000.5e00.0101
Operational primary IP address: 100.1.1.1
Operational master IP address: 100.1.1.1
Priority is 255
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 2 minutes 3 seconds (12300 centi sec)
Master uptime: 0 hours 2 minutes 3 seconds (12300 centi sec)
Accept mode: TRUE
Preempt mode: TRUE
Multicast membership on IPv4 interface vlan1.2: JOINED
V2-Compatible: FALSE
 
R1#show ip pim neighbor
Neighbor Interface Uptime/Expires Ver DR
Address Priority/Mode
5.1.1.2 eth4 01:55:57/00:01:18 v2 1 / DR
10.2.4.2 eth2 01:45:57/00:01:18 v2 1 / DR
10.2.3.2 eth3 02:13:01/00:01:44 v2 1 / DR
100.1.1.2 vlan1.2 00:01:39/00:01:29 v2 1 /
 
R1#show ip pim mroute
IP Multicast Routing Table
 
(*,*,RP) Entries: 0
G/prefix Entries: 0
(*,G) Entries: 5
(S,G) Entries: 0
(S,G,rpt) Entries: 0
FCR Entries: 1
 
(*, 224.1.1.1)
RP: 1.1.1.4
RPF nbr: 5.1.1.2
RPF idx: eth4
Upstream State: JOINED
Local .....i..........................
Joined ................................
Asserted ................................
FCR:
Source: 200.1.1.5
Outgoing .....o..........................
KAT timer running, 116 seconds remaining
Packet count 1
 
(*, 224.1.1.2)
RP: 1.1.1.4
RPF nbr: 5.1.1.2
RPF idx: eth4
Upstream State: JOINED
Local .....i..........................
Joined ................................
Asserted ................................
FCR:
 
(*, 224.1.1.3)
RP: 1.1.1.4
RPF nbr: 5.1.1.2
RPF idx: eth4
Upstream State: JOINED
Local .....i..........................
Joined ................................
Asserted ................................
FCR:
 
(*, 224.1.1.4)
RP: 1.1.1.4
RPF nbr: 5.1.1.2
RPF idx: eth4
Upstream State: JOINED
Local .....i..........................
Joined ................................
Asserted ................................
FCR:
 
(*, 224.1.1.5)
RP: 1.1.1.4
RPF nbr: 5.1.1.2
RPF idx: eth4
Upstream State: JOINED
Local .....i..........................
Joined ................................
Asserted ................................
FCR:
 
R1#show ip mroute
 
IP Multicast Routing Table
Flags: I - Immediate Stat, T - Timed Stat, F - Forwarder installed
B - BIDIR
Timers: Uptime/Stat Expiry
Interface State: Interface (TTL)
 
(200.1.1.5, 224.1.1.1), uptime 00:01:38, stat expires 00:02:43
Owner PIM, Flags: TF
Incoming interface: eth4
Outgoing interface list:
vlan1.2 (1)
Validation 2
R2#show ip pim neighbor
Neighbor Interface Uptime/Expires Ver DR
Address Priority/Mode
10.2.3.1 eth3 02:13:36/00:01:31 v2 1 /
10.3.5.2 eth1 00:07:45/00:01:30 v2 1 / DR
100.1.1.1 vlan1.2 00:02:14/00:01:36 v2 101 / DR
 
R2#show ip pim neighbor detail
Nbr 10.2.3.1 (eth3)
Expires in 87 seconds, uptime 02:13:40
Holdtime: 105 secs, T-bit: off, Lan delay: 500, Override interval: 2500
DR priority: 1, Gen ID: 234024133,
Interface ID: Router-ID: 1.1.1.2 Local-ID: 10030,
 
Nbr 10.3.5.2 (eth1), DR
Expires in 86 seconds, uptime 00:07:49
Holdtime: 105 secs, T-bit: off, Lan delay: 500, Override interval: 2500
DR priority: 1, Gen ID: 2078598240,
Interface ID: Router-ID: 1.1.1.5 Local-ID: 10050,
 
Nbr 100.1.1.1 (vlan1.2), DR
Expires in 91 seconds, uptime 00:02:18
Holdtime: 105 secs, T-bit: off, Lan delay: 500, Override interval: 2500
DR priority: 101, Gen ID: 379671611,
Interface ID: Router-ID: 1.1.1.2 Local-ID: 10066,
 
R2#show vrrp
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled
 
Address family IPv4
VRRP Id: 1 on interface: vlan1.2
State: AdminUp - Backup
Virtual IP address: 100.1.1.1 (Not-owner)
Virtual MAC address is 0000.5e00.0101
Operational primary IP address: 100.1.1.2
Operational master IP address: 100.1.1.1
Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 1 hours 30 minutes 5 seconds (540500 centi sec)
Skew time: 60 centi sec
Master Down Interval: 360 centi sec
Accept mode: TRUE
Preempt mode: TRUE
Multicast membership on IPv4 interface vlan1.2: JOINED
V2-Compatible: FALSE