OcNOS-SP : Segment Routing Guide : Path Computation Element Communication Protocol Configuration Guide : BGP Link State with OSPF Segment Routing
BGP Link State with OSPF Segment Routing
This chapter contains configuration and validation of BGP-Link state extension for OSPF-SR.
Overview
Segment Routing (SR) allows a headend node to steer a packet flow along any path. Intermediate per-flow states are eliminated due to source routing. The headend node is said to steer a flow into a Segment Routing Policy (SR Policy). The header of a packet steered in an SR Policy is augmented with the ordered list of segments associated with that SR Policy. This feature is supported for the MPLS instantiations.
BGP-LS describes a mechanism by which Link-State (LS) and Traffic Engineering (TE) information from IGPs can be collected from networks and shared with external components using the BGP. This is achieved using a new BGP Network Layer Reachability Information (NLRI) encoding format. These components, while external to the network, require network state information on a real time basis. Specifically, they require link-state database information of each IGP node from the entire network. BGP protocol is used to collect the necessary information and to share with the external components and this is achieved using a NLRI encoding format.
A new NLRI is defined in order to advertise SR Policy to the headend of that policy. New sub-TLVs for the Tunnel Encapsulation Attribute are defined to carry SR related information.
Topology
Here we have taken 7 nodes out of which 6 nodes are OSPF-SR enabled routers and node 7 will act as controller. R3 belong to autonomous-system-100 and R5 belong to autonomous-system-200. R1's xe3 and R3's xe3 belong to Area-1. R2, R4 and R3 belong to Area-0 . R5 and R6 belong to Area-0 . We shall configure OSPF-SR on every node. We shall give distribute-BGP-LS on R3 and R5, after that we will make an E- BGP session between R3 and Controller and R5 and controller. Under link-state link-state address family we will activate the neighbors. Verification will be done on ASBRS which are R3 and R5.
All NLRIs (Node, Link and Prefix) should display proper SR information of nodes belong to other AS.
BGP link state with OSPF segment routing
R1
 
R1#configure terminal
Entering to config mode
R1(config)# hostname R1
Configure hostname
R1(config)#interface lo
Going to interface mode for loopback interface.
R1(config-if)#ip address 1.1.1.1/32 secondary
Configure IPv4 address.
R1(config-if)#prefix-sid absolute 18001
Configure Prefix-sid absolute
R1(config-if)#exit
Exit from interface mode.
R1(config)#interface xe3
Going to interface mode for xe3 interface.
R1(config-if)#ip address 10.1.1.1/24
Configure IPv4 address.
R1(config-if)# label-switching
Configure Label-Switching.
R1(config-if)#exit
Exit from interface mode.
R1(config)# router ospf 100
Entering router ospf.
R1(config-router)# ospf router-id 1.1.1.1
Configure OSPF router-id.
R1(config-router)# network 1.1.1.1/32 area 0.0.0.1
Configure network.
R1(config-router)# network 10.1.1.0/24 area 0.0.0.1
Configure network.
R1(config-router)# segment-routing mpls
Configure segment-routing MPLS.
R1(config-router)#exit
Exit from router-ospf mode.
R2
 
R2#configure terminal
Entering to config mode
R2(config)# hostname R2
Configure hostname
R2(config)#interface lo
Going to interface mode for loopback interface.
R2(config-if)#ip address 2.2.2.2/32 secondary
Configure IPv4 address.
R2(config-if)#prefix-sid absolute 18002
Configure Prefix-sid
R2(config-if)#exit
Exit from interface mode.
R2(config)# interface xe1
Going to interface mode for xe1 interface.
R2(config-if)#ip address 11.1.1.1/24
Configure IPv4 address.
R2(config-if)# label-switching
Configure Label-Switching.
R2(config-if)#exit
Exit from interface mode.
R2(config)#router ospf 100
Entering router ospf.
R2(config-router)# ospf router-id 2.2.2.2
Configure OSPF Router-id.
R2(config-router)# network 2.2.2.2/32 area 0.0.0.0
Configure Network.
R2(config-router)# network 11.1.1.0/24 area 0.0.0.0
Configure Network.
R2(config-router)# segment-routing mpls
Configure segment-routing MPLS.
R2(config-router)#exit
Exit from router-ospf mode.
R3
 
R3#configure terminal
Entering to config mode
R3(config)# hostname R3
Configure hostname
R3(config)#interface lo
Going to interface mode for loopback interface.
R3(config-if)#ip address 3.3.3.3/32 secondary
Configure IPv4 address.
R1(config-if)#prefix-sid absolute 18003
Configure Prefix-sid
R3(config-if)#exit
Exit from interface mode.
R3(config)#interface xe3
Going to interface mode for xe3 interface.
R3(config-if)#ip address 10.1.1.2/24
Configure IPv4 address.
R3(config-if)# label-switching
Configure Label-Switching.
R3(config-if)#exit
Exit from interface mode.
R3(config)#interface xe1
Going to interface mode for xe1 interface.
R3(config-if)#ip address 11.1.1.2/24
Configure IPv4 address.
R3(config-if)# label-switching
Configure Label-Switching.
R3(config-if)#exit
Exit from interface mode.
R3(config)#interface xe8
Going to interface mode for xe8 interface.
R3(config-if)#ip address 12.1.1.2/24
Configure IPv4 address.
R3(config-if)# label-switching
Configure Label-Switching
R3(config-if)#exit
Exit from interface mode.
R3(config)#interface xe4
Going to interface mode for xe4 interface.
R3(config-if)#ip address 13.1.1.1/24
Configure IPv4 address.
R3(config-if)#exit
Exit from interface mode.
R3(config)# router ospf 100
Entering router ospf.
R3(config-router)# ospf router-id 3.3.3.3
Configure OSPF Router-ID.
R3(config-router)# distribute bgp-ls
Configure Distribute BGP-LS.
R3(config-router)# network 3.3.3.3/32 area 0.0.0.0
Configure Network.
R3(config-router)# network 10.1.1.0/24 area 0.0.0.1
Configure Network.
R3(config-router)# network 11.1.1.0/24 area 0.0.0.0
Configure Network.
R3(config-router)# network 12.1.1.0/24 area 0.0.0.0
Configure Network
R3(config-router)# segment-routing mpls
Configure segment-routing MPLS.
R3(config-router)#exit
Exit from router-ospf mode.
R3(config)#router bgp 100
Entering router bgp.
R3(config)# bgp router-id 3.3.3.3
Configure BGP router-id
R3(config-router)# neighbor 13.1.1.2 remote-as 300
Configure E-BGP neighbor with remote-as.
R3(config-router)# address-family link-state link-state
Configure link-state link-state address-family.
R3(config-router-af)# neighbor 13.1.1.2 activate
Activating controller's interface address as neighbor in link-state link-state address family.
R3(config-router-af)#exit
Exit from router bgp-address-family mode
R3(config-router)#exit
Exit from router bgp mode
R4
 
R4#configure terminal
Entering to config mode
R4(config)# hostname R4
Configure hostname
R4(config)#interface lo
Going to interface mode for loopback interface.
R4(config-if)#ip address 4.4.4.4/32 secondary
Configure IPv4 address.
R4(config-if)#prefix-sid absolute 18004
Configure Prefix-sid
R4(config-if)#exit
Exit from interface mode.
R4(config)#interface xe8
Going to interface mode for xe8 interface.
R4(config-if)#ip address 12.1.1.1/24
Configure IPv4 address.
R4(config-if)# label-switching
Configure Label-Switching.
R4(config-if)#exit
Exit from interface mode.
R4(config)#router ospf 100
Entering router ospf.
R4(config-router)# ospf router-id 4.4.4.4
Configure OSPF Router-ID.
R4(config-router)# network 4.4.4.4/32 area 0.0.0.0
Configure network.
R4(config-router)# network 12.1.1.0/24 area 0.0.0.0
Configure network.
R4(config-router)#segment-routing mpls
Enabling Segment-Routing.
R4(config-router)#exit
Exit from router-ospf mode.
R5
 
R5#configure terminal
Entering to config mode
R5(config)# hostname R5
Configure hostname
R5(config)#interface lo
Going to interface mode for loopback interface.
R5(config-if)#ip address 5.5.5.5/32 secondary
Configure IPv4 address.
R4(config-if)#prefix-sid absolute 18005
Configure Prefix-sid
R5(config-if)#exit
Exit from interface mode.
R5(config)#interface xe17
Going to interface mode for xe17 interface.
R5(config-if)#ip address 15.1.1.1/24
Configure IPv4 address.
R5(config-if)# label-switching
Configure Label-Switching.
R5(config-if)#exit
Exit from interface mode.
R5(config)#interface xe8
Going to interface mode for xe8 interface.
R5(config-if)#ip address 14.1.1.1/24
Configure IPv4 address.
R5(config-if)#exit
Exit from interface mode.
R5(config)# router ospf 100
Entering router OSPF.
R5(config-router)# ospf router-id 5.5.5.5
Configure OSPF router-id.
R5(config-router)# distribute bgp-ls
Distributing BGP-LS.
R5(config-router)# network 5.5.5.5/32 area 0.0.0.0
Configure network.
R5(config-router)# network 15.1.1.0/24 area 0.0.0.0
Configure network.
R5(config-router)# segment-routing mpls
Enabling Segment-Routing.
R5(config-router)#exit
Exit from router-ospf mode.
R5(config)#router bgp 200
Entering router bgp.
R5(config)# bgp router-id 5.5.5.5
Configure BGP router-id
R5(config-router)# neighbor 14.1.1.2 remote-as 300
Configure E-BGP neighbor with remote-as.
R5(config-router)#address-family link-state link-state
Entering link-state link-state address family.
R5(config-router-af)# neighbor 14.1.1.2 activate
Activating controller's interface address as neighbor in link-state link-state address family.
R5(config-router-af)#exit
Exit from router bgp-address-family mode.
R5(config-router)#exit
Exit from router bgp mode.
R6
 
R6#configure terminal
Entering to config mode
R6(config)# hostname R6
Configure hostname
R6(config)#interface lo
Going to interface mode for loopback interface.
R6(config-if)#ip address 6.6.6.6/32 secondary
Configure IPv4 address.
R6(config-if)#prefix-sid absolute 18006
Configure Prefix-sid
R6(config-if)#exit
Exit from interface mode.
R6(config)#interface xe17
Going to interface mode for xe17 interface.
R6(config-if)#ip address 15.1.1.2/24
Configure IPv4 address.
R6(config-if)# label-switching
Configure Label-Switching.
R6(config-if)#exit
Exit from interface mode.
R6(config)# router ospf 100
Entering router OSPF.
R6(config-router)# ospf router-id 6.6.6.6
Configure OSPF Router-id.
R6(config-router)# network 6.6.6.6/32 area 0.0.0.0
Configure network.
R6(config-router)# network 15.1.1.0/24 area 0.0.0.0
Configure network.
R6(config-router)#segment-routing mpls
Enabling Segment-Routing.
R6(config-router)#exit
Exit from router-ospf mode.
Controller (R7)
 
Controller#configure terminal
Entering to config mode
Controller(config)# hostname Controller
Configure hostname
Controller(config)#in eth1
Entering to interface eth1.
Controller(config-if)#ip address 13.1.1.2/24
Configure IPv4 address.
Controller(config-if)#in eth2
Entering to interface eth2.
Controller(config-if)#ip address 14.1.1.2/24
Configure IPv4 address.
Controller(config-if)#exit
Exit from interface mode.
Controller(config-if)#router bgp 300
Entering to router bgp mode.
Controller(config-router)# neighbor 13.1.1.1 remote-as 100
Configure neighbor with remote-as.
Controller(config-router)# neighbor 14.1.1.1 remote-as 200
Configure neighbor with remote-as.
Controller(config-router)#address-family link-state link-state
Entering link-state link-state address family.
Controller(config-router-af)# neighbor 13.1.1.1 activate
Activating R3's interface address as neighbor in link-state link-state address family.
Controller(config-router-af)# neighbor 14.1.1.1 activate
Activating R5's interface address as neighbor in link-state link-state address family.
Controller(config-router-af)#exit
Exit from bgp address-family mode
Controller(config-router)#exit
Exit from router bgp mode.
Validation
R3#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface
Instance ID
1.1.1.1 1 Full/DR 00:00:36 10.1.1.1 xe3 0
2.2.2.2 1 Full/DR 00:00:37 11.1.1.1 xe1 0
4.4.4.4 1 Full/Backup 00:00:37 12.1.1.1 xe8 0
 
R3#show ip ospf database opaque-ar
 
OSPF Router with ID (3.3.3.3) (Process ID 100 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 1726
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 2.2.2.2
LS Seq Number: 80000002
Checksum: 0x32eb
Length: 28
 
MPLS TE router ID : 2.2.2.2
 
Number of Links : 0
 
LS age: 1483
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0x36df
Length: 28
 
MPLS TE router ID : 3.3.3.3
 
Number of Links : 0
 
LS age: 366
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 4.4.4.4
LS Seq Number: 80000002
Checksum: 0x3ad3
Length: 28
 
MPLS TE router ID : 4.4.4.4
 
Number of Links : 0
 
LS age: 90
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.22 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 22
Advertising Router: 2.2.2.2
LS Seq Number: 80000002
Checksum: 0xb784
Length: 108
 
Link connected to Broadcast network
Link ID : 11.1.1.1
Interface Address : 11.1.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 253
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.22 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 22
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0xb77f
Length: 108
 
Link connected to Broadcast network
Link ID : 11.1.1.1
Interface Address : 11.1.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 153
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.32 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 32
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0x9792
Length: 108
 
Link connected to Broadcast network
Link ID : 12.1.1.2
Interface Address : 12.1.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 86
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.32 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 32
Advertising Router: 4.4.4.4
LS Seq Number: 80000002
Checksum: 0x5bcb
Length: 108
 
Link connected to Broadcast network
Link ID : 12.1.1.2
Interface Address : 12.1.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1947
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0xd702
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm0: 0
 
 
LS age: 1719
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0xb91c
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm0: 0
 
 
LS age: 1477
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 4.4.4.4
LS Seq Number: 80000001
Checksum: 0x9b36
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm0: 0
 
 
LS age: 1947
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x9d50
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 2.2.2.2
Flags: 0x08 (-|-|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18002
 
LS age: 1719
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0x0a5c
Length: 68
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 3.3.3.3
Flags: 0x08 (-|-|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18003
 
Prefix type : Extended Prefix TLV
Route Type: 3
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 1.1.1.1
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18001
 
LS age: 86
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 4.4.4.4
LS Seq Number: 80000002
Checksum: 0xf7e2
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 4.4.4.4
Flags: 0x08 (-|-|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18004
 
LS age: 1726
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.25 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10009
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x5860
Length: 52
 
Link Type: 2
Link ID: 11.1.1.1
Link Data: 11.1.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 3.3.3.3
SID: 24320
 
 
LS age: 1719
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.25 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10009
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0x08c3
Length: 48
 
Link Type: 2
Link ID: 11.1.1.1
Link Data: 11.1.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24321
 
 
LS age: 1483
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.30 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10014
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0xf6ae
Length: 52
 
Link Type: 2
Link ID: 12.1.1.2
Link Data: 12.1.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 4.4.4.4
SID: 24322
 
 
LS age: 1477
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.30 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10014
Advertising Router: 4.4.4.4
LS Seq Number: 80000001
Checksum: 0xb011
Length: 48
 
Link Type: 2
Link ID: 12.1.1.2
Link Data: 12.1.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24320
 
 
 
Area-Local Opaque-LSA (Area 0.0.0.1)
 
LS age: 1726
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 1.1.1.1
LS Seq Number: 80000002
Checksum: 0x2ef7
Length: 28
 
MPLS TE router ID : 1.1.1.1
 
Number of Links : 0
 
LS age: 433
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0x36df
Length: 28
 
MPLS TE router ID : 3.3.3.3
 
Number of Links : 0
 
LS age: 430
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.12 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 12
Advertising Router: 1.1.1.1
LS Seq Number: 80000002
Checksum: 0x0c40
Length: 108
 
Link connected to Broadcast network
Link ID : 10.1.1.1
Interface Address : 10.1.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 283
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.12 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 12
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0xed55
Length: 108
 
Link connected to Broadcast network
Link ID : 10.1.1.1
Interface Address : 10.1.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 610
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 1.1.1.1
LS Seq Number: 80000002
Checksum: 0xf3e8
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm0: 0
 
 
LS age: 33
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0xb71d
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm0: 0
 
 
LS age: 2140
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 1.1.1.1
LS Seq Number: 80000001
Checksum: 0x6f87
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 1.1.1.1
Flags: 0x08 (-|-|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18001
 
LS age: 1474
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0x6fe0
Length: 92
 
Prefix type : Extended Prefix TLV
Route Type: 3
Prefix Length: 32
AF: 0
Flags: 0xc0 (A|N|-|-|-|-|-|-)
Address Prefix: 3.3.3.3
Flags: 0x08 (-|-|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18003
 
Prefix type : Extended Prefix TLV
Route Type: 3
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 2.2.2.2
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18002
 
Prefix type : Extended Prefix TLV
Route Type: 3
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 4.4.4.4
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18004
 
LS age: 380
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 1.1.1.1
LS Seq Number: 80000002
Checksum: 0x8c36
Length: 52
 
Link Type: 2
Link ID: 10.1.1.1
Link Data: 10.1.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 3.3.3.3
SID: 24320
 
 
LS age: 1719
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0x03d0
Length: 48
 
Link Type: 2
Link ID: 10.1.1.1
Link Data: 10.1.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24320
 
 
R3#
R3#show ip bgp neighbors
BGP neighbor is 13.1.1.2, remote AS 300, local AS 100, external link BGP version 4, local router ID 3.3.3.3, remote router ID 40.1.1.2 BGP state = Established, up for 00:05:16
Last read 00:00:08, hold time is 90, keepalive interval is 30 seconds Neighbor capabilities:
Route refresh: advertised and received (old and new) Address family IPv4 Unicast: advertised and received
Address family Link-State Link-State: advertised and received
Received 22 messages, 0 notifications, 0 in queue
Sent 38 messages, 0 notifications, 0 in queue Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds For address family: IPv4 Unicast
BGP table version 1, neighbor version 1 Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: Link-State Link-State BGP table version 5, neighbor version 5 Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
9 accepted prefixes
31 announced prefixes
 
Connections established 1; dropped 0
Local host: 13.1.1.1, Local port: 45926
Foreign host: 13.1.1.2, Foreign port: 179
Nexthop: 13.1.1.1 Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
R3#show bgp link-state link-state
BGP router identifier 3.3.3.3, local AS number 100 Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID, c confed-ID/ASN, b bgp-identifier, r router-ID, i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1]]/248
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2]]/248
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1]]/248
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]]/216
e [V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]]/216
e [V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1]]/248
e [V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6]]/216
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2. 2d11.1.1.1]][L[i11.1.1.1][n11.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1][R[c100][b3.3.3.3][a0.0.0.0
][r2.2.2.2]][L[i11.1.1.1][n11.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1][R[c100][b3.3.3.3][a0.0.0.0
][r3.3.3.3]][L[i11.1.1.1][n11.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2. 2d11.1.1.1]][L[i11.1.1.2][n11.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3. 3d12.1.1.2]][L[i12.1.1.2][n12.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2][R[c100][b3.3.3.3][a0.0.0.0
][r3.3.3.3]][L[i12.1.1.2][n12.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2][R[c100][b3.3.3.3][a0.0.0.0
][r4.4.4.4]][L[i12.1.1.2][n12.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3. 3d12.1.1.2]][L[i12.1.1.1][n12.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1. 1d10.1.1.1]][L[i10.1.1.1][n10.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1][R[c100][b3.3.3.3][a0.0.0.1
][r1.1.1.1]][L[i10.1.1.1][n10.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1][R[c100][b3.3.3.3][a0.0.0.1
][r3.3.3.3]][L[i10.1.1.1][n10.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1. 1d10.1.1.1]][L[i10.1.1.2][n10.1.1.1]]/376
e [E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5. 5d15.1.1.1]][L[i15.1.1.1][n15.1.1.1]]/376
e [E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1][R[c200][b5.5.5.5][a0.0.0.0
][r5.5.5.5]][L[i15.1.1.1][n15.1.1.1]]/376
e [E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1][R[c200][b5.5.5.5][a0.0.0.0
][r6.6.6.6]][L[i15.1.1.1][n15.1.1.2]]/376
e [E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5. 5d15.1.1.1]][L[i15.1.1.2][n15.1.1.1]]/376
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]][P[0x1][p2.2.2.2/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x1][p3.3.3.3/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x2][p10.1.1.0/24]]/256
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x2][p1.1.1.1/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]][P[0x1][p4.4.4.4/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]][P[0x1][p1.1.1.1/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p11.1.1.0/24]]/256
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p12.1.1.0/24]]/256
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p2.2.2.2/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p3.3.3.3/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p4.4.4.4/32]]/264
e [T][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]][P[0x1][p5.5.5.5/32]]/264
e [T][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6]][P[0x1][p6.6.6.6/32]]/264
NLRIs, Total: 40, Node: 11, Link: 16, Prefix: 13
Note: Count of NLRIs may be different sometimes.
R3#show bgp link-state link-state count
 
Total NLRIs : 40
Node NLRIs : 11
Link NLRIs : 16
Prefix NLRIs : 13
 
R3#show bgp link-state link-state self-originate BGP router identifier 3.3.3.3, local AS number 100 Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID, c confed-ID/ASN, b bgp-identifier, r router-ID, i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1]]/248
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2]]/248
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1]]/248
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]]/216
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2. 2d11.1.1.1]][L[i11.1.1.1][n11.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1][R[c100][b3.3.3.3][a0.0.0.0
][r2.2.2.2]][L[i11.1.1.1][n11.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1][R[c100][b3.3.3.3][a0.0.0.0
][r3.3.3.3]][L[i11.1.1.1][n11.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2. 2d11.1.1.1]][L[i11.1.1.2][n11.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3. 3d12.1.1.2]][L[i12.1.1.2][n12.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2][R[c100][b3.3.3.3][a0.0.0.0
][r3.3.3.3]][L[i12.1.1.2][n12.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2][R[c100][b3.3.3.3][a0.0.0.0
][r4.4.4.4]][L[i12.1.1.2][n12.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3. 3d12.1.1.2]][L[i12.1.1.1][n12.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1. 1d10.1.1.1]][L[i10.1.1.1][n10.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1][R[c100][b3.3.3.3][a0.0.0.1
][r1.1.1.1]][L[i10.1.1.1][n10.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1][R[c100][b3.3.3.3][a0.0.0.1
][r3.3.3.3]][L[i10.1.1.1][n10.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1. 1d10.1.1.1]][L[i10.1.1.2][n10.1.1.1]]/376
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]][P[0x1][p2.2.2.2/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x1][p3.3.3.3/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x2][p10.1.1.0/24]]/256
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x2][p1.1.1.1/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]][P[0x1][p4.4.4.4/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]][P[0x1][p1.1.1.1/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p11.1.1.0/24]]/256
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p12.1.1.0/24]]/256
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p2.2.2.2/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p3.3.3.3/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p4.4.4.4/32]]/264
NLRIs, Total: 31, Node: 8, Link: 12, Prefix: 11
Note: Count of NLRIs may be different sometimes.
 
Node-NLRI
R3#show bgp link-state link-state [V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]]/ 216
BGP routing table entry for [V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]]/216 Local
Received from 13.1.1.2 Link State:
Range Size: 8000 Base SID: 16000 SR Algorithm: 0 Node flag bits: O:0 T:0 B:0 E:0
Local TE Router-ID:5.5.5.5
Link-NLRI
R3#show bgp link-state link-state [E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5. 5d15.1.1.1]][L[i15.1.1.2][n15.1.1.1]]/376
BGP routing table entry for [E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5. 5d15.1.1.1]][L[i15.1.1.2][n15.1.1.1]]/376
Local
Received from 13.1.1.2
Link State:
Local Router ID: 6.6.6.6, Remote Router ID: 5.5.5.5
Max link bw(kbits/sec): 10000000.00 ,Max reservable link bw(kbits/sec): 10000000.00
Max unreserved link bw(kbits/sec):10000000.00 10000000.00 10000000.00 10000000.00 10000000.00 10000000.00 10000000.00 10000000.00
TE metric 1 , IGP metric 1
SR Flags: B:0 V:1 L:1 G:0 P:0
Adjacency SID: 24320
Local TE Router-ID:6.6.6.6
Prefix-NLRI
R3#show bgp link-state link-state [T][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]][P[0x1][p5.5.5.5/32]]/264
BGP routing table entry for [T][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]][P[0x1][p5.5.5.5/32]]/264
Local
Received from 13.1.1.2
Link State:
Prefix flag bits:64[N]
Metric: 1 SID: 18005 SR Flags: NP:0 M:0 E:0 V:1 L:0
Source Router ID:5.5.5.5
Local TE Router-ID:5.5.5.5
R5
R5#show ip ospf neighbor
 
Total number of full neighbors: 1 OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
6.6.6.6 1 Full/Backup 00:00:37 15.1.1.2 xe17 0
 
R5#show ip ospf database opaque-area
 
OSPF Router with ID (5.5.5.5) (Process ID 100 VRF default) Area-Local Opaque-LSA (Area 0.0.0.0)
LS age: 914
Options: 0x22 (-|-|DC|-|-|-|E|-) LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID) Opaque Type: 1
Opaque ID: 1
Advertising Router: 5.5.5.5 LS Seq Number: 80000002 Checksum: 0x3ec7
Length: 28
 
MPLS TE router ID : 5.5.5.5
Number of Links : 0 LS age: 915
Options: 0x22 (-|-|DC|-|-|-|E|-) LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID) Opaque Type: 1
Opaque ID: 1
Advertising Router: 6.6.6.6 LS Seq Number: 80000001 Checksum: 0x44ba
Length: 28
 
MPLS TE router ID : 6.6.6.6
Number of Links : 0 LS age: 914
Options: 0x22 (-|-|DC|-|-|-|E|-) LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.42 (Area-Local Opaque-Type/ID) Opaque Type: 1
Opaque ID: 42
Advertising Router: 5.5.5.5 LS Seq Number: 80000001 Checksum: 0x1f87
Length: 108
 
Link connected to Broadcast network
Link ID : 15.1.1.1
Interface Address : 15.1.1.1 Admin Metric : 1
Maximum bandwidth : 25000000.00 Kbits/s
Maximum reservable bandwidth : 25000000.00 Kbits/s Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 25000000.00 Kbits/s Priority 1 : 25000000.00 Kbits/s
Priority 2 : 25000000.00 Kbits/s Priority 3 : 25000000.00 Kbits/s
Priority 4 : 25000000.00 Kbits/s Priority 5 : 25000000.00 Kbits/s
Priority 6 : 25000000.00 Kbits/s Priority 7 : 25000000.00 Kbits/s Number of Links : 1
LS age: 915
Options: 0x22 (-|-|DC|-|-|-|E|-) LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.42 (Area-Local Opaque-Type/ID) Opaque Type: 1
Opaque ID: 42
Advertising Router: 6.6.6.6 LS Seq Number: 80000001 Checksum: 0x1f82
Length: 108
 
Link connected to Broadcast network Link ID : 15.1.1.1
Interface Address : 15.1.1.2 Admin Metric : 1
Maximum bandwidth : 25000000.00 Kbits/s
Maximum reservable bandwidth : 25000000.00 Kbits/s Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 25000000.00 Kbits/s Priority 1 : 25000000.00 Kbits/s
Priority 2 : 25000000.00 Kbits/s Priority 3 : 25000000.00 Kbits/s
Priority 4 : 25000000.00 Kbits/s Priority 5 : 25000000.00 Kbits/s
Priority 6 : 25000000.00 Kbits/s Priority 7 : 25000000.00 Kbits/s Number of Links : 1
LS age: 1069
Options: 0x22 (-|-|DC|-|-|-|E|-) LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID) Opaque Type: 4
Opaque ID: 0
Advertising Router: 5.5.5.5 LS Seq Number: 80000001 Checksum: 0x7d50
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 912
Options: 0x22 (-|-|DC|-|-|-|E|-) LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID) Opaque Type: 4
Opaque ID: 0
Advertising Router: 6.6.6.6 LS Seq Number: 80000001 Checksum: 0x5f6a
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 1069
Options: 0x22 (-|-|DC|-|-|-|E|-) LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID) Opaque Type: 7
Opaque ID: 0
Advertising Router: 5.5.5.5 LS Seq Number: 80000001 Checksum: 0x28aa
Length: 44
 
Prefix type : Extended Prefix TLV Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-) Address Prefix: 5.5.5.5
Flags: 0x08 (-|-|-|-|V|-|-|-) MT-ID: 0
Algorithm: 0
SID: 18005
 
LS age: 912
Options: 0x22 (-|-|DC|-|-|-|E|-) LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID) Opaque Type: 7
Opaque ID: 0
Advertising Router: 6.6.6.6 LS Seq Number: 80000001 Checksum: 0x5673
Length: 44
 
Prefix type : Extended Prefix TLV Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-) Address Prefix: 6.6.6.6
Flags: 0x08 (-|-|-|-|V|-|-|-) MT-ID: 0
Algorithm: 0
SID: 18006
 
LS age: 914
Options: 0x22 (-|-|DC|-|-|-|E|-) LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.35 (Area-Local Opaque-Type/ID) Opaque Type: 8
Opaque ID: 10019
Advertising Router: 5.5.5.5 LS Seq Number: 80000001 Checksum: 0x5935
Length: 52
 
Link Type: 2
Link ID: 15.1.1.1
Link Data: 15.1.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-) MT-ID: 0
NBR ID: 6.6.6.6
SID: 24320
 
 
LS age: 912
Options: 0x22 (-|-|DC|-|-|-|E|-) LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.35 (Area-Local Opaque-Type/ID) Opaque Type: 8
Opaque ID: 10019
Advertising Router: 6.6.6.6 LS Seq Number: 80000001 Checksum: 0x941a
Length: 48
 
Link Type: 2
Link ID: 15.1.1.1
Link Data: 15.1.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-) MT-ID: 0
SID: 24320
 
R5#show bgp link-state link-state
BGP router identifier 5.5.5.5, local AS number 200 Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID, c confed-ID/ASN, b bgp-identifier, r router-ID, i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]]/216
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1]]/248
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]]/216
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2]]/248
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]]/216
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]]/216
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1]]/248
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]]/216
[V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]]/216
[V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1]]/248
[V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6]]/216
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2. 2d11.1.1.1]][L[i11.1.1.1][n11.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1][R[c100][b3.3.3.3][a0.0.0.0
][r2.2.2.2]][L[i11.1.1.1][n11.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1][R[c100][b3.3.3.3][a0.0.0.0
][r3.3.3.3]][L[i11.1.1.1][n11.1.1.2]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2. 2d11.1.1.1]][L[i11.1.1.2][n11.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3. 3d12.1.1.2]][L[i12.1.1.2][n12.1.1.2]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2][R[c100][b3.3.3.3][a0.0.0.0
][r3.3.3.3]][L[i12.1.1.2][n12.1.1.2]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2][R[c100][b3.3.3.3][a0.0.0.0
][r4.4.4.4]][L[i12.1.1.2][n12.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3. 3d12.1.1.2]][L[i12.1.1.1][n12.1.1.2]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1. 1d10.1.1.1]][L[i10.1.1.1][n10.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1][R[c100][b3.3.3.3][a0.0.0.1
][r1.1.1.1]][L[i10.1.1.1][n10.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1][R[c100][b3.3.3.3][a0.0.0.1
][r3.3.3.3]][L[i10.1.1.1][n10.1.1.2]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1. 1d10.1.1.1]][L[i10.1.1.2][n10.1.1.1]]/376
[E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5. 5d15.1.1.1]][L[i15.1.1.1][n15.1.1.1]]/376
[E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1][R[c200][b5.5.5.5][a0.0.0.0
][r5.5.5.5]][L[i15.1.1.1][n15.1.1.1]]/376
[E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1][R[c200][b5.5.5.5][a0.0.0.0
][r6.6.6.6]][L[i15.1.1.1][n15.1.1.2]]/376
[E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5. 5d15.1.1.1]][L[i15.1.1.2][n15.1.1.1]]/376
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]][P[0x1][p2.2.2.2/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x1][p3.3.3.3/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x2][p10.1.1.0/24]]/256
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x2][p1.1.1.1/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]][P[0x1][p4.4.4.4/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]][P[0x1][p1.1.1.1/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p11.1.1.0/24]]/256
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p12.1.1.0/24]]/256
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p2.2.2.2/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p3.3.3.3/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p4.4.4.4/32]]/264
[T][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]][P[0x1][p5.5.5.5/32]]/264
[T][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6]][P[0x1][p6.6.6.6/32]]/264
NLRIs, Total: 40, Node: 11, Link: 16, Prefix: 13
Note: Count of NLRIs may be different sometimes.
R5#show bgp link-state link-state count
 
Total NLRIs : 40
Node NLRIs : 11
Link NLRIs : 16
Prefix NLRIs : 13
Note: Count of NLRIs may be different sometimes.
R5#show bgp link-state link-state self-originate BGP router identifier 5.5.5.5, local AS number 200 Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID, c confed-ID/ASN, b bgp-identifier, r router-ID, i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID [V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]]/216
[V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1]]/248
[V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6]]/216
[E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5. 5d15.1.1.1]][L[i15.1.1.1][n15.1.1.1]]/376
[E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1][R[c200][b5.5.5.5][a0.0.0.0
][r5.5.5.5]][L[i15.1.1.1][n15.1.1.1]]/376
[E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1][R[c200][b5.5.5.5][a0.0.0.0
][r6.6.6.6]][L[i15.1.1.1][n15.1.1.2]]/376
[E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5. 5d15.1.1.1]][L[i15.1.1.2][n15.1.1.1]]/376
[T][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]][P[0x1][p5.5.5.5/32]]/264
[T][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6]][P[0x1][p6.6.6.6/32]]/264
NLRIs, Total: 9, Node: 3, Link: 4, Prefix: 2
Note: Count of NLRIs may be different sometimes.
[Validation for Particular NLRI
Node-NLRI
R5#show bgp link-state link-state [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]]/ 216
BGP routing table entry for [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]]/216 Local
Received from 14.1.1.2 Link State:
Range Size: 8000 Base SID: 16000 SR Algorithm: 0 Node flag bits: O:0 T:0 B:0 E:0
Local TE Router-ID:2.2.2.2
Link-NLRI
R5#show bgp li li [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2. 2d11.1.1.1]][L[i11.1.1.2][n11.1.1.1]]/376
BGP routing table entry for [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2. 2d11.1.1.1]][L[i11.1.1.2][n11.1.1.1]]/376
Local
Received from 14.1.1.2
Link State:
Local Router ID: 3.3.3.3, Remote Router ID: 2.2.2.2
Max link bw(kbits/sec): 10000000.00 ,Max reservable link bw(kbits/sec): 10000000.00
Max unreserved link bw(kbits/sec):10000000.00 10000000.00 10000000.00 10000000.00 10000000.00 10000000.00 10000000.00 10000000.00
TE metric 1 , IGP metric 1
SR Flags: B:0 V:1 L:1 G:0 P:0
Adjacency SID: 24321
Local TE Router-ID:3.3.3.3
Prefix-NLRI
R5#show bgp link-state link-state [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]][P[0x1][p4.4.4.4/32]]/264
BGP routing table entry for [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]][P[0x1][p4.4.4.4/32]]/264
Local
Received from 13.1.1.2
Link State:
Prefix flag bits:64[N]
Metric: 1 SID: 18005 SR Flags: NP:0 M:0 E:0 V:1 L:0
Source Router ID:5.5.5.5
Local TE Router-ID:5.5.5.5
 
Validation for Controller (R7)
Controller#show bgp neighbors
BGP neighbor is 13.1.1.1, remote AS 100, local AS 300, external link
BGP version 4, local router ID 40.1.1.2, remote router ID 3.3.3.3
BGP state = Established, up for 00:16:41
Last read 00:00:12, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family Link-State Link-State: advertised and received
Received 80 messages, 0 notifications, 0 in queue
Sent 49 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 0, Offset 0, Mask 0x1
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: Link-State Link-State
BGP table version 3, neighbor version 3
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
31 accepted prefixes
9 announced prefixes
 
Connections established 1; dropped 0
Local host: 13.1.1.2, Local port: 179
Foreign host: 13.1.1.1, Foreign port: 45926
Nexthop: 13.1.1.2
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
BGP neighbor is 14.1.1.1, remote AS 200, local AS 300, external link
BGP version 4, local router ID 40.1.1.2, remote router ID 5.5.5.5
BGP state = Established, up for 00:16:33
Last read 00:00:11, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family Link-State Link-State: advertised and received
Received 50 messages, 0 notifications, 0 in queue
Sent 63 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: Link-State Link-State
BGP table version 3, neighbor version 3
Index 0, Offset 0, Mask 0x1
Community attribute sent to this neighbor (both)
9 accepted prefixes
31 announced prefixes
 
Connections established 1; dropped 0
Local host: 14.1.1.2, Local port: 179
Foreign host: 14.1.1.1, Foreign port: 36438
Nexthop: 14.1.1.2
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
Controller#show bgp link-state link-state
BGP router identifier 40.1.1.2, local AS number 300
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]]/216
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1]]/248
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]]/216
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2]]/248
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]]/216
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]]/216
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1]]/248
e [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]]/216
e [V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]]/216
e [V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1]]/248
e [V][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6]]/216
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1]][L[i11.1.1.1][n11.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]][L[i11.1.1.1][n11.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][L[i11.1.1.1][n11.1.1.2]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1]][L[i11.1.1.2][n11.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2]][L[i12.1.1.2][n12.1.1.2]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][L[i12.1.1.2][n12.1.1.2]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2][R[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]][L[i12.1.1.2][n12.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2]][L[i12.1.1.1][n12.1.1.2]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1]][L[i10.1.1.1][n10.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]][L[i10.1.1.1][n10.1.1.1]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1][R[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][L[i10.1.1.1][n10.1.1.2]]/376
e [E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1]][L[i10.1.1.2][n10.1.1.1]]/376
e [E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1]][L[i15.1.1.1][n15.1.1.1]]/376
e [E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]][L[i15.1.1.1][n15.1.1.1]]/376
e [E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1][R[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6]][L[i15.1.1.1][n15.1.1.2]]/376
e [E][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6][R[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5d15.1.1.1]][L[i15.1.1.2][n15.1.1.1]]/376
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]][P[0x1][p2.2.2.2/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x1][p3.3.3.3/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x2][p10.1.1.0/24]]/256
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x2][p1.1.1.1/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]][P[0x1][p4.4.4.4/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]][P[0x1][p1.1.1.1/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p11.1.1.0/24]]/256
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p12.1.1.0/24]]/256
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p2.2.2.2/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p3.3.3.3/32]]/264
e [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p4.4.4.4/32]]/264
e [T][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r5.5.5.5]][P[0x1][p5.5.5.5/32]]/264
e [T][O][I0x64][N[c200][b5.5.5.5][a0.0.0.0][r6.6.6.6]][P[0x1][p6.6.6.6/32]]/264
NLRIs, Total: 40, Node: 11, Link: 16, Prefix: 13
Note: Count of NLRIs may be different sometimes.
Controller#show bgp link-state link-state [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]]/216
BGP routing table entry for [V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]]/216
Local
Received from 13.1.1.1
Link State:
Range Size: 8000 Base SID: 16000 SR Algorithm: 0
Node flag bits: O:0 T:0 B:0 E:0
Local TE Router-ID:1.1.1.1
SRMS Configuration
R5
 
R5(config)#segment-routing
Entering to Segment Routing.
R5(config-sr)#mapping-server
Entering to Mapping Server
R5(config-sr-ms)#prefix-sid-map address-family ipv4
Entering to prefix-to SID mapping.
R5(config-sr-ms-map-af4)#21.21.21.21/32 4545 attached
Configure SID for prefix.
R5(config-sr-ms-map-af4)#31.31.31.31/32 3535 attached
Configure SID for prefix.
R5(config-sr-ms-map-af4)#end
Exit from SRMS.
R5#configure terminal
Entering to Config mode.
R5(config)#router ospf 100
Entering to router OSPF mode.
R5(config-router)#segment-routing prefix-sid-map advertise-local
Configure advertise-local for prefix-sid mapping.
R5(config-router)#exit
Exit from router OSPF mode
R3
R3(config)#segment-routing
Entering to Segment Routing
R3(config-sr)#mapping-server
Entering to Mapping Server
R3(config-sr-ms)#prefix-sid-map address-family ipv4
Entering to prefix-to SID mapping.
R3(config-sr-ms-map-af4)#11.11.11.11/32 1111 range 3
Configure SID for prefix.
R3(config-sr-ms-map-af4)#12.12.12.12/32 6767 range 1
Configure SID for prefix.
R3(config-sr-ms-map-af4)#end
Exit from SRMS.
R3#configure terminal
Entering to Config mode.
R3(config)#router ospf 100
Entering to router OSPF mode.
R3(config-router)#segment-routing prefix-sid-map advertise-local
Configure advertise-local for prefix-sid mapping.
R3(config-router)#exit
Exit from router OSPF mode
Validation on R3
OSPF Database
R3#show ip ospf database opaque-area self-originate
 
OSPF Router with ID (3.3.3.3) (Process ID 100 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 851
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 3.3.3.3
LS Seq Number: 80000003
Checksum: 0x34e0
Length: 28
 
MPLS TE router ID : 3.3.3.3
 
Number of Links : 0
 
LS age: 1421
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.22 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 22
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0xb77f
Length: 108
 
Link connected to Broadcast network
Link ID : 11.1.1.1
Interface Address : 11.1.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1321
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.32 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 32
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0x9792
Length: 108
 
Link connected to Broadcast network
Link ID : 12.1.1.2
Interface Address : 12.1.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 153
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 3.3.3.3
LS Seq Number: 80000003
Checksum: 0x73c4
Length: 52
 
Range Size: 8000
Base-SID: 16000
Algorithm0: 0
Preference: 128
 
 
LS age: 1081
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0x085d
Length: 68
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 3.3.3.3
Flags: 0x08 (-|-|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18003
 
Prefix type : Extended Prefix TLV
Route Type: 3
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 1.1.1.1
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18001
 
LS age: 153
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 1
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0x6cb2
Length: 48
 
Prefix type : Extended Prefix Range TLV
Prefix Length: 32
AF: 0
Range: 3
Flags: 0x00 (-|-|-|-|-|-|-|-)
Address Prefix: 11.11.11.11
Flags: 0x20 (-|-|M|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 1111
 
LS age: 153
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.2 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 2
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0xe30a
Length: 48
 
Prefix type : Extended Prefix Range TLV
Prefix Length: 32
AF: 0
Range: 1
Flags: 0x00 (-|-|-|-|-|-|-|-)
Address Prefix: 12.12.12.12
Flags: 0x20 (-|-|M|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 6767
 
LS age: 471
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.25 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10009
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0x06c4
Length: 48
 
Link Type: 2
Link ID: 11.1.1.1
Link Data: 11.1.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24321
 
 
LS age: 171
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.30 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10014
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0xf4af
Length: 52
 
Link Type: 2
Link ID: 12.1.1.2
Link Data: 12.1.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 4.4.4.4
SID: 24322
 
 
 
Area-Local Opaque-LSA (Area 0.0.0.1)
 
LS age: 1601
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0x36df
Length: 28
 
MPLS TE router ID : 3.3.3.3
 
Number of Links : 0
 
LS age: 1451
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.12 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 12
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0xed55
Length: 108
 
Link connected to Broadcast network
Link ID : 10.1.1.1
Interface Address : 10.1.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 153
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 3.3.3.3
LS Seq Number: 80000003
Checksum: 0x73c4
Length: 52
 
Range Size: 8000
Base-SID: 16000
Algorithm0: 0
Preference: 128
 
 
LS age: 861
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 3.3.3.3
LS Seq Number: 80000003
Checksum: 0x6de1
Length: 92
 
Prefix type : Extended Prefix TLV
Route Type: 3
Prefix Length: 32
AF: 0
Flags: 0xc0 (A|N|-|-|-|-|-|-)
Address Prefix: 3.3.3.3
Flags: 0x08 (-|-|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18003
 
Prefix type : Extended Prefix TLV
Route Type: 3
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 2.2.2.2
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18002
 
Prefix type : Extended Prefix TLV
Route Type: 3
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 4.4.4.4
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 18004
 
LS age: 153
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 1
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0x6cb2
Length: 48
 
Prefix type : Extended Prefix Range TLV
Prefix Length: 32
AF: 0
Range: 3
Flags: 0x00 (-|-|-|-|-|-|-|-)
Address Prefix: 11.11.11.11
Flags: 0x20 (-|-|M|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 1111
 
LS age: 153
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.2 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 2
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0xe30a
Length: 48
 
Prefix type : Extended Prefix Range TLV
Prefix Length: 32
AF: 0
Range: 1
Flags: 0x00 (-|-|-|-|-|-|-|-)
Address Prefix: 12.12.12.12
Flags: 0x20 (-|-|M|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 6767
 
LS age: 641
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 3.3.3.3
LS Seq Number: 80000002
Checksum: 0x01d1
Length: 48
 
Link Type: 2
Link ID: 10.1.1.1
Link Data: 10.1.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24320
Validation for NLRI count
R3#sho bgp link-state link-state count
-------------------------------------------
Total NLRIs : 44
Node NLRIs : 11
Link NLRIs : 16
Prefix NLRIs : 17
Note: Count of NLRIs may be different sometimes.
R3#show bgp link-state link-state self-originate
BGP router identifier 3.3.3.3, local AS number 100
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1]]/248
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2]]/248
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]]/216
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1]]/248
[V][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]]/216
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1]][L[i11.1.1.1][n11.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]][L[i11.1.1.1][n11.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][L[i11.1.1.1][n11.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2d11.1.1.1]][L[i11.1.1.2][n11.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2]][L[i12.1.1.2][n12.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][L[i12.1.1.2][n12.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2][R[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]][L[i12.1.1.2][n12.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4][R[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3d12.1.1.2]][L[i12.1.1.1][n12.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1]][L[i10.1.1.1][n10.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]][L[i10.1.1.1][n10.1.1.1]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1][R[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][L[i10.1.1.1][n10.1.1.2]]/376
[E][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3][R[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1d10.1.1.1]][L[i10.1.1.2][n10.1.1.1]]/376
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r2.2.2.2]][P[0x1][p2.2.2.2/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x1][p3.3.3.3/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x2][p10.1.1.0/24]]/256
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r3.3.3.3]][P[0x2][p1.1.1.1/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.0][r4.4.4.4]][P[0x1][p4.4.4.4/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r1.1.1.1]][P[0x1][p1.1.1.1/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x0][p11.11.11.11/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x0][p12.12.12.12/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p11.1.1.0/24]]/256
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p12.1.1.0/24]]/256
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p2.2.2.2/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p3.3.3.3/32]]/264
[T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x2][p4.4.4.4/32]]/264
NLRIs, Total: 33, Node: 8, Link: 12, Prefix: 13
Note: Count of NLRIs may be different sometimes.
Note: Here the total number of NLRI increases because of prefixes configured in SRMS.
Validation for Particular NLRI
Here we verify the prefix-NLRIs for prefixes configured in SRMS.
R3#show bgp link-state link-state [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x0][p11.11.11.11/32]]/264
BGP routing table entry for [T][O][I0x64][N[c100][b3.3.3.3][a0.0.0.1][r3.3.3.3]][P[0x0][p11.11.11.11/32]]/264
Local
Received from IGP
Link State:
SRMS SID: Start: 1111 Range: 3 Algorithm: 0 SRMS Flags: IA:0
SR SID Flags: NP:0 M:1 E:0 V:0 L:0
Source Router ID:3.3.3.3
Local TE Router-ID:3.3.3.3