OcNOS-SP : Segment Routing Guide : Path Computation Element Communication Protocol Configuration Guide : PCEP RSVP
PCEP RSVP
This chapter describes RSVP configurations requesting path computation from the PCE server.
Topology
 
PCEP-RSVP topology
Configuration
R1
 
R1#configure terminal
Enter configure mode.
R1(config)#interface lo
Enter interface mode.
R1(config-if)#ip address 1.1.1.1/32 secondary
Configure the IP address of the interface.
R1(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)#exit
Exit interface mode.
R1(config)#router rsvp
Configure RSVP globally.
R1(config-router)#exit
Exit router RSVP mode.
(config)# rsvp-trunk to-R3 ipv4
Configure RSVP trunk with IPv4 address family
(config-trunk)# to 3.3.3.3
Tunnel egress IP address
(config-trunk)# path-option dynamic pce
Configure path option as PCE
(config-trunk)# pce entity 1
Assign to the PCE entity 1
R1(config)#interface eth1
Enter interface mode.
R1(config-if)#ip address 11.1.1.1/24
Configure the IP address of the interface.
R1(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)#isis network point-to-point
Network-type as point-to-point
R1(config-if)#label-switching
Enable label switching.
R1(config-if)# enable-rsvp
Enable RSVP on this interface
R1(config)#interface eth2
Enter interface mode.
R1(config-if)#ip address 12.1.1.1/24
Configure the IP address of the interface.
R1(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)#label-switching
Enable label switching.
R1(config-if)#isis network point-to-point
Network-type as point-to-point
R1(config-if)# enable-rsvp
Enable RSVP on this interface
R1(config-if)#exit
Exit interface mode.
R1(config)#interface eth3
Enter interface mode.
R1(config-if)#ip address 20.1.1.1/24
Configure the IP address of the interface towards PCE
R1(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)#label-switching
Enable label switching.
R1(config-if)#isis network point-to-point
Network type as point-to-point
R1(config-if)#exit
Exit interface mode.
R1(config)#router isis 1
Set the routing process ID .
R1(config-router)#is-type level-1
Configure is-type.
R1(config-router)#distribute bgp-ls
Link State distribution to BGP
R1(config-router)#metric-style wide level-1
Configure metric style as wide.
R1(config-router)# net 49.0001.0000.0000.0011.00
Configure Network entity title (NET).
R1(config-router)#mpls traffic-eng router-id 1.1.1.1
Enable MPLS Traffic Engineering under router process.
R1(config-router)#mpls traffic-eng level-1
Enable MPLS Traffic Engineering as level-1.
R1(config-router)# capability cspf
Enable CSPF capability under ISIS 1 process.
R1(config-router)#exit
Exit router mode.
R1(config)# router bgp 100
Configure router BGP in AS 100
R1(config-router)# bgp router-id 1.1.1.1
Router identifier for BGP
R1(config-router)# neighbor 33.33.33.33 remote-as 100
Configure neighbor in remote-as 100
R1(config-router)# neighbor 33.33.33.33 update-source lo
Configure neighbor with update-source loopback
R1(config-router)# address-family link-state link-state
Enter link-state Address family mode
R1(config-router-af)# neighbor 33.33.33.33 activate
Activate PCE neighbor
R1(config-router-af)# exit-address-family
Exit from Address Family configuration mode
R1(config-router)#exit
Exit router mode.
R1(config)# pce configuration 1
Configure Path Computation Client with entity 1
R1(config-pcep)#capability
Enter capabilities submode
R1(config-pcep-cap)# pce instantiation
PCE Initiated LSP Instantiation
R1(config-pcep-cap)# exit-capability
Exit from PCEP Entity Capability mode
R1(config-pcep)# update-source 1.1.1.1
Source of routing updates
R1(config-pcep)# peer-address ipv4 33.33.33.33
Configure peer address
R1(config-pcep)# exit
Exit PCEP mode.
R2
 
R2#configure terminal
Enter configure mode.
R2(config)#interface lo
Enter interface mode.
R2(config-if)#ip address 2.2.2.2/32 secondary
Configure the IP address of the interface.
R2(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R2(config-if)#exit
Exit interface mode.
R2(config)#router rsvp
Configure RSVP globally.
R2(config-router)#exit
Exit router RSVP mode.
R2(config)#interface eth1
Enter interface mode.
R2(config-if)#ip address 11.1.1.2/24
Configure the IP address of the interface.
R2(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R2(config-if)#isis network point-to-point
Network-type as point-to-point
R2(config-if)#label-switching
Enable label switching.
R2(config-if)# enable-rsvp
Enable RSVP on this interface
R2(config)#interface eth2
Enter interface mode.
R2(config-if)#ip address 6.1.1.1/24
Configure the IP address of the interface.
R2(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R2(config-if)#label-switching
Enable label switching.
R2(config-if)#isis network point-to-point
Network-type as point-to-point
R2(config-if)# enable-rsvp
Enable RSVP on this interface
R2(config-if)#exit
Exit interface mode.
R2(config)#router isis 1
Set the routing process ID .
R2(config-router)#is-type level-1
Configure is-type.
R2(config-router)#metric-style wide level-1
Configure metric style as wide.
R2(config-router)# net 49.0001.0000.0000.0022.00
Configure Network entity title (NET).
R2(config-router)#mpls traffic-eng router-id 2.2.2.2
Enable MPLS Traffic Engineering under router process.
R2(config-router)#mpls traffic-eng level-1
Enable MPLS Traffic Engineering as level-1.
R2(config-router)# capability cspf
Enable CSPF capability under ISIS 1 process.
R2(config-router)#exit
Exit router mode.
R3
 
R3#configure terminal
Enter configure mode.
R3(config)#interface lo
Enter interface mode.
R3(config-if)#ip address 3.3.3.3/32 secondary
Configure the IP address of the interface.
R3(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R3(config-if)#exit
Exit interface mode.
R3(config)#router rsvp
Configure RSVP globally.
R3(config-router)#exit
Exit router RSVP mode.
R3(config)#interface eth1
Enter interface mode.
R3(config-if)#ip address 9.1.1.2/24
Configure the IP address of the interface.
R3(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R3(config-if)#isis network point-to-point
Network-type as point-to-point
R3(config-if)#label-switching
Enable label switching.
R3(config-if)# enable-rsvp
Enable RSVP on this interface
R3(config)#interface eth2
Enter interface mode.
R3(config-if)#ip address 6.1.1.2/24
Configure the IP address of the interface.
R3(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R3(config-if)#label-switching
Enable label switching.
R3(config-if)#isis network point-to-point
Network-type as point-to-point
R3(config-if)# enable-rsvp
Enable RSVP on this interface
R3(config-if)#exit
Exit interface mode.
R3(config)#router isis 1
Set the routing process ID .
R3(config-router)#is-type level-1
Configure is-type.
R3(config-router)#distribute bgp-ls
Link State distribution to BGP
R3(config-router)#metric-style wide level-1
Configure metric style as wide.
R3(config-router)# net 49.0001.0000.0000.0033.00
Configure Network entity title (NET).
R3(config-router)#mpls traffic-eng router-id 3.3.3.3
Enable MPLS Traffic Engineering under router process.
R3(config-router)#mpls traffic-eng level-1
Enable MPLS Traffic Engineering as level-1.
R3(config-router)# capability cspf
Enable CSPF capability under ISIS 1 process.
R3(config-router)#exit
Exit router mode.
R3(config)# pce configuration 1
Configure Path Computation Client
R3(config-pcep)#capability
Specify capabilities of entity
R3(config-pcep-cap)# pce instantiation
PCE Initiated LSP Instantiation
R3(config-pcep-cap)# exit-capability
Exit from PCEP Entity Capability mode
R3(config-pcep)# update-source 3.3.3.3
Source of routing updates
R3(config-pcep)# peer-address ipv4 33.33.33.33
Configure peer address
R3(config-pcep)# exit
Exit PCEP mode.
R4
 
R4#configure terminal
Enter configure mode.
R4(config)#interface lo
Enter interface mode.
R4(config-if)#ip address 4.4.4.4/32 secondary
Configure the IP address of the interface.
R4(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R4(config-if)#exit
Exit interface mode.
R4(config)#router rsvp
Configure RSVP globally.
R4(config-router)#exit
Exit router RSVP mode.
R4(config)#interface eth1
Enter interface mode.
R4(config-if)#ip address 9.1.1.1/24
Configure the IP address of the interface.
R4(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R4(config-if)#isis network point-to-point
Network-type as point-to-point
R4(config-if)# enable-rsvp
Enable RSVP on this interface
R4(config-if)#label-switching
Enable label switching.
R4(config)#interface eth2
Enter interface mode.
R4(config-if)#ip address 12.1.1.2/24
Configure the IP address of the interface.
R4(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R4(config-if)#label-switching
Enable label switching.
R4(config-if)#isis network point-to-point
Network-type as point-to-point
R4(config-if)# enable-rsvp
Enable RSVP on this interface
R4(config-if)#exit
Exit interface mode.
R4(config)#router isis 1
Set the routing process ID .
R4(config-router)#is-type level-1
Configure is-type.
R4(config-router)#metric-style wide level-1
Configure metric style as wide.
R4(config-router)# net 49.0001.0000.0000.0044.00
Configure Network entity title (NET).
R4(config-router)#mpls traffic-eng router-id 4.4.4.4
Enable MPLS Traffic Engineering under router process.
R4(config-router)#mpls traffic-eng level-1
Enable MPLS Traffic Engineering as level-1.
R4(config-router)# capability cspf
Enable CSPF capability under ISIS 1 process.
R4(config-router)#exit
Exit router mode.
Validation
R1#sho rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
3.3.3.3 1.1.1.1 PRI to-R3-Primary UP 00:02:44 1 1 SE - 24960 DEFAULT
Total 1 displayed, Up 1, Down 0.
 
R1#sho rsvp session to-R3 primary
Ingress (Primary)
3.3.3.3
From: 1.1.1.1, LSPstate: Up, LSPname: to-R3-Primary
Ingress FSM state: Operational
Establishment Time: 0s 6ms
Setup priority: 7, Hold priority: 0
CSPF usage: Path Computation Element
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: NA
IGP-Shortcut: Disabled, LSP metric: 20
LSP Protection: None
Label in: -, Label out: 24960,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 1.1.1.1
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 12.1.1.2, eth2
Path refresh: 30 seconds (RR enabled) (due in 29830 seconds)
Resv lifetime: 157 seconds (due in 154 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: none
Session Explicit Route Detail :
12.1.1.2/32 strict
9.1.1.2/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
12.1.1.2
9.1.1.2
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls