OcNOS-SP : Segment Routing Guide : Path Computation Element Communication Protocol Configuration Guide : PCEP Segment Routing
PCEP Segment Routing
This chapter describes segment routing configurations requesting path computation from the PCE server.
Topology
 
PCEP-SR topology
Configuration
R1
 
R1#configure terminal
Enter configure mode.
R1(config)#interface lo
Enter interface mode.
R1(config-if)#ip address 1.1.1.1/32 secondary
Configure the IP address of the interface.
R1(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)# prefix-sid absolute 16001 no php
Configure prefix SID absolute value.
R1(config-if)#exit
Exit interface mode.
R1(config)#interface eth1
Enter interface mode.
R1(config-if)#ip address 11.1.1.1/24
Configure the IP address of the interface.
R1(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)#isis network point-to-point
ISIS network type as point-to-point
R1(config-if)#label-switching
Enable label switching.
R1(config)#interface eth2
Enter interface mode.
R1(config-if)#ip address 12.1.1.1/24
Configure the IP address of the interface.
R1(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)#label-switching
Enable label switching.
R1(config-if)#isis network point-to-point
ISIS network type as point-to-point
R1(config-if)#exit
Exit interface mode.
R1(config)#interface eth3
Enter interface mode.
R1(config-if)#ip address 20.1.1.1/24
Configure the IP address of the interface towards PCE
R1(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)#label-switching
Enable label switching.
R1(config-if)#isis network point-to-point
Network type as point-to-point
R1(config-if)#exit
Exit interface mode.
R1(config)#router isis 1
Set the routing process ID .
R1(config-router)#is-type level-1
Configure is-type.
R1(config-router)#distribute bgp-ls
Link State distribution to BGP
R1(config-router)#metric-style wide level-1
Configure metric style as wide.
R1(config-router)# net 49.0001.0000.0000.0011.00
Configure Network entity title (NET).
R1(config-router)#mpls traffic-eng router-id 1.1.1.1
Enable MPLS Traffic Engineering under router process.
R1(config-router)#mpls traffic-eng level-1
Enable MPLS Traffic Engineering as level-1.
R1(config-router)# capability cspf
Enable CSPF capability under ISIS 1 process.
R1(config-router)# isis segment-routing global block 16000 19999
SRGB Starting and End Range
R1(config-router)#segment-routing mpls
Enable segment routing under router process.
R1(config-router)#exit
Exit router mode.
R1(config)#segment-routing
Configuring segment-routing
R1(config-sr)#traffic-engineering
Segment Routing traffic engineering
R1(config-sr-te)#policy policy-to-R3
Policy configuration with name 1
R1(config-sr-pol)#color 1 end-point 3.3.3.3
SR-policy color and end-point
R1(config-sr-pol-cp)#candidate-path 100
SR policy candidate path
R1(config-sr-pol-cp)#preference 100
Candidate Path preference
R1(config-sr-pol-cp)# dynamic-path pcep
Dynamic path as PCEP
R1(config-sr-pol-cp)#exit-pol-cp
Exit from SR policy candidate path configuration mode
R1(config-sr-pol)#pce entity 1
Assign the PCE entity 1 to the SR policy
R1(config-sr-pol)#exit-sr-pol
Exit from SR policy configuration mode
R1(config-sr-te)#exit-te
Exit from traffic engineering configuration mode
R1(config)# router bgp 100
Configure router BGP in AS 100
R1(config-router)# bgp router-id 1.1.1.1
router identifier for BGP
R1(config-router)# neighbor 33.33.33.33 remote-as 100
Configure neighbor in remote-as 100
R1(config-router)# neighbor 33.33.33.33 update-source lo
Configure neighbor with update-source loopback
R1(config-router)# address-family link-state link-state
Enter link-state Address family mode
R1(config-router-af)# neighbor 33.33.33.33 activate
Activate PCE neighbor
R1(config-router-af)# exit-address-family
Exit from Address Family configuration mode
R1(config-router)#exit
Exit router mode.
R1(config)# pce configuration 1
Configure Path Computation Client with entity 1
R1(config-pcep)#capability
Enter capabilities submode
R1(config-pcep-cap)#segment-routing pcep
Segment routing capability for PCE
R1(config-pcep-cap)# pce instantiation
PCE Initiated LSP Instantiation
R1(config-pcep-cap)# exit-capability
Exit from PCEP Entity Capability mode
R1(config-pcep)# update-source 1.1.1.1
Source of routing updates
R1(config-pcep)# peer-address ipv4 33.33.33.33
Configure peer address
R1(config-pcep)# exit
Exit PCEP mode.
R2
 
R2#configure terminal
Enter configure mode.
R2(config)#interface lo
Enter interface mode.
R2(config-if)#ip address 2.2.2.2/32 secondary
Configure the IP address of the interface.
R2(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R2(config-if)# prefix-sid absolute 16002 no php
Configure prefix SID absolute value.
R2(config-if)#exit
Exit interface mode.
R2(config)#interface eth1
Enter interface mode.
R2(config-if)#ip address 11.1.1.2/24
Configure the IP address of the interface.
R2(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R2(config-if)#isis network point-to-point
ISIS network type as point-to-point
R2(config-if)#label-switching
Enable label switching.
R2(config)#interface eth2
Enter interface mode.
R2(config-if)#ip address 6.1.1.1/24
Configure the IP address of the interface.
R2(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R2(config-if)#label-switching
Enable label switching.
R2(config-if)#isis network point-to-point
ISIS network type as point-to-point
R2(config-if)#exit
Exit interface mode.
R2(config)#router isis 1
Set the routing process ID .
R2(config-router)#is-type level-1
Configure is-type.
R2(config-router)#metric-style wide level-1
Configure metric style as wide.
R2(config-router)# net 49.0001.0000.0000.0022.00
Configure Network entity title (NET).
R2(config-router)#mpls traffic-eng router-id 2.2.2.2
Enable MPLS Traffic Engineering under router process.
R2(config-router)#mpls traffic-eng level-1
Enable MPLS Traffic Engineering as level-1.
R2(config-router)# capability cspf
Enable CSPF capability under ISIS 1 process.
R2(config-router)# isis segment-routing global block 16000 19999
SRGB Starting and End Range
R2(config-router)#segment-routing mpls
Enable segment routing under router process.
R2(config-router)#exit
Exit router mode.
R3
 
R3#configure terminal
Enter configure mode.
R3(config)#interface lo
Enter interface mode.
R3(config-if)#ip address 3.3.3.3/32 secondary
Configure the IP address of the interface.
R3(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R3(config-if)# prefix-sid absolute 16003 no php
Configure prefix SID absolute value.
R3(config-if)#exit
Exit interface mode.
R3(config)#interface eth1
Enter interface mode.
R3(config-if)#ip address 9.1.1.2/24
Configure the IP address of the interface.
R3(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R3(config-if)#isis network point-to-point
ISIS network type as point-to-point
R3(config-if)#label-switching
Enable label switching.
R3(config)#interface eth2
Enter interface mode.
R3(config-if)#ip address 6.1.1.2/24
Configure the IP address of the interface.
R3(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R3(config-if)#label-switching
Enable label switching.
R3(config-if)#isis network point-to-point
ISIS network type as point-to-point
R3(config-if)#exit
Exit interface mode.
R3(config)#router isis 1
Set the routing process ID .
R3(config-router)#is-type level-1
Configure is-type.
R3(config-router)#distribute bgp-ls
Link State distribution to BGP
R3(config-router)#metric-style wide level-1
Configure metric style as wide.
R3(config-router)# net 49.0001.0000.0000.0033.00
Configure Network entity title (NET).
R3(config-router)#mpls traffic-eng router-id 3.3.3.3
Enable MPLS Traffic Engineering under router process.
R3(config-router)#mpls traffic-eng level-1
Enable MPLS Traffic Engineering as level-1.
R3(config-router)# capability cspf
Enable CSPF capability under ISIS 1 process.
R3(config-router)# isis segment-routing global block 16000 19999
SRGB Starting and End Range
R3(config-router)#segment-routing mpls
Enable segment routing under router process.
R3(config-router)#exit
Exit router mode.
R3(config)# pce configuration 1
Configure Path Computation Client
R3(config-pcep)#capability
Specify capabilities of entity
R3(config-pcep-cap)#segment-routing pcep
Segment routing for PCE
R3(config-pcep-cap)# pce instantiation
PCE Initiated LSP Instantiation
R3(config-pcep-cap)# exit-capability
Exit from PCEP Entity Capability mode
R3(config-pcep)# update-source 3.3.3.3
Source of routing updates
R3(config-pcep)# peer-address ipv4 33.33.33.33
Configure peer address
R3(config-pcep)# exit
Exit PCEP mode.
R4
 
R4#configure terminal
Enter configure mode.
R4(config)#interface lo
Enter interface mode.
R4(config-if)#ip address 4.4.4.4/32 secondary
Configure the IP address of the interface.
R4(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R4(config-if)# prefix-sid absolute 16004 no php
Configure prefix sid absolute value.
R4(config-if)#exit
Exit interface mode.
R4(config)#interface eth1
Enter interface mode.
R4(config-if)#ip address 9.1.1.1/24
Configure the IP address of the interface.
R4(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R4(config-if)#isis network point-to-point
ISIS network type as point-to-point
R4(config-if)#label-switching
Enable label switching.
R4(config)#interface eth2
Enter interface mode.
R4(config-if)#ip address 12.1.1.2/24
Configure the IP address of the interface.
R4(config-if)#ip router isis 1
Make the interface part of the router ISIS 1 instance.
R4(config-if)#label-switching
Enable label switching.
R4(config-if)#isis network point-to-point
ISIS network type as point-to-point
R4(config-if)#exit
Exit interface mode.
R4(config)#router isis 1
Set the routing process ID .
R4(config-router)#is-type level-1
Configure is-type.
R4(config-router)#metric-style wide level-1
Configure metric style as wide.
R4(config-router)# net 49.0001.0000.0000.0044.00
Configure Network entity title (NET).
R4(config-router)#mpls traffic-eng router-id 4.4.4.4
Enable MPLS Traffic Engineering under router process.
R4(config-router)#mpls traffic-eng level-1
Enable MPLS Traffic Engineering as level-1.
R4(config-router)# capability cspf
Enable CSPF capability under ISIS 1 process.
R4(config-router)# isis segment-routing global block 16000 19999
SRGB Starting and End Range
R4(config-router)#segment-routing mpls
Enable segment routing under router process.
R4(config-router)#exit
Exit router mode.
Validation
R1#show segment-routing policy
 
Policy-Name Color End-point State Forwarding-Info
policy-to-R3 1 3.3.3.3 UP 16003/eth2
 
R1#show segment-routing policy detail
 
Policy-Name: policy-to-R3 Color 1 End-point 3.3.3.3 Tunnel-ID: 1
Admin-Status: UP Oper-Status: UP for 00:07:04
State Transition Count: 1
CSPF Retry Limit: 10 CSPF Retry Interval: 10
PCE Entity ID: 1
Binding SID :
BSID: 25600
Alloc mode: Dynamic
Oper State: Programmed
 
CP ID: 100, Active
Preference: 100 Path Type: Dynamic(pcep) CP Origin: Local
Segment List:
Total no. of segments: 1
Segment0[LABEL]: Label :16003
Out-if: eth2 Out-label-stack: 16003
Attributes:
Configured:
Affinity:
Metric-type: TE
IP Constraints:
 
R1# show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
i> 2.2.2.2/32 2 0 Yes LSP_DEFAULT 16002 eth1 No 11.1.1.2
P> 3.3.3.3/32 5 1 Yes LSP_DEFAULT 16003 eth2 No 12.1.1.2
i 3.3.3.3/32 4 0 Yes LSP_DEFAULT 16003 eth2 No 12.1.1.2
i> 4.4.4.4/32 3 0 Yes LSP_DEFAULT 16004 eth2 No 12.1.1.2
i> 33.33.33.33/32 1 0 Yes LSP_DEFAULT 3 eth3 No 20.1.1.2