OcNOS-SP : Segment Routing Guide : Segment Routing Configuration Guide : SRv6 BGP LS with ISIS Configuration
SRv6 BGP LS with ISIS Configuration
This chapter contains configurations of SRv6 BGP-LS with ISISv6.
BGP-LS
BGP-LS describes a mechanism by which Link-State (LS) and Traffic Engineering (TE) information from IS-IS can be collected from networks and shared with external components using the BGP. It advertises the SRv6 SID's and other SRv6 information from all the SRv6 capable nodes in the IGP domain when sourced from link-state routing protocols.
Topology
BGP-LS with ISISv6 configuration topology
R1
 
R1#configure terminal
Enter configure mode.
R1(config)#interface lo
Enter interface mode.
R1(config-if)#ipv6 address cafe:1:2::11/128
Configure IPv6 address of the loopback interface.
R1(config-if)#ip address 11.11.11.11/32 secondary
Configure ip address on the loopback interface as secondary
R1(config-if)#ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)#exit
Exit interface mode.
R1(config)#interface eth1
Enter interface mode.
R1(config-if)#ipv6 address 2424::1/64
Configure the IPv6 address of the interface.
R1(config-if)#ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config)#interface eth2
Enter interface mode.
R1(config-if)#ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)#ipv6 address 65::2/64
Configure the IPv6 address of the interface.
R1(config-if)#exit
Exit interface mode
R1(config)#interface eth3
Enter interface mode.
R1(config-if)#ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
R1(config-if)#ipv6 address 2002::1/64
Configure the IPv6 address of the interface.
R1(config-if)#exit
Exit interface mode
R1(config)#router isis 1
Set the routing process ID as 1
R1(config-router)#is-type level-2
Configure is-type as level-2
R1(config-router)#metric-style wide level-2
Configure wide metric-style
R1(config-router)# net 49.0001.0000.0000.0001.00
Configure Network entity title (NET).
R1(config-router)#mpls traffic-eng ipv6 router-id cafe:1:2::11
Configure Ipv6 router-id
R1(config-router)#mpls traffic-eng level-2
Configure mpls traffic engineering for level-2
R1(config-router)#distribute bgp-ls
Link State distribution to BGP
R1(config-router)# address-family ipv6
Enter Address-family ipv6
R1(config-router-af)# multi-topology level-2
Enable Multi-Topology
R1(config-router-af)#segment-routing srv6
Enable srv6 under ipv6 address-family
R1(config-router-af-srv6)# srv6-locator R1_locator
Name to srv6 locator
R1(config-router-af-srv6)#exit-srv6
Exit srv6 mode
R1(config-router-af)#exit-address-family
Exit address-family ipv6
R1(config-router)#exit
Exit router mode.
R1(config)# router bgp 1000
Configure router BGP in AS 1000
R1(config-router)# neighbor 65::1 remote-as 1000
Configure neighbor in remote-as 1000
R1(config-router)# neighbor 2002::2 remote-as 1
Configure neighbor with remote-as 1
R1(config-router)# address-family link-state link-state
Enter link-state Address family mode
R1(config-router-af)# neighbor 65::1 activate
Activate IBGP-LS neighbor
R1(config-router-af)# neighbor 2002::2 activate
Activate EBGP-LS neighbor
R1(config-router-af)#exit-address-family
Exit from Address Family configuration mode
R1(config)#segment-routing
Configuring segment-routing
R1(config-sr)#srv6
Segment-Routing over IPv6 Data-Plane
R1(config-srv6)#locators
Configure SRv6 locators
R1(config-srv6-loc)#locator R1_locator
Locator name as R1_locator
R1(config-srv6-loc-conf)# prefix cafe:1:2:a11::/64
Ipv6 prefix for locator
R1(config-srv6-loc-conf)#exit-locator
Exit from locator mode
R1(config-srv6-loc)#exit-locators
Exit from srv6 locators configuration mode
R1(config-srv6)#exit-srv6
Exit from srv6 configuration mode
R1(config-router)#commit
Commit the transaction
 
R2
 
R2#configure terminal
Enter configure mode.
R2(config)#interface lo
Enter interface mode.
R2(config-if)# ip address 12.12.12.12/32 secondary
Configure ip address on the loopback interface as secondary
R2(config)#interface eth1
Enter interface mode.
R2(config-if)# ipv6 address 2424::2/64
Configure the IPv6 address of the interface.
R2(config-if)#ipv6 router isis 1
Make the interface part of the router isis 1 instance.
R2(config-if)#exit
Exit interface mode.
R2(config)#router isis 1
Set the routing process ID as 1
R2(config-router)#is-type level-2
Configure is-type as level-2
R2(config-router)#metric-style wide level-2
Configure wide metric-style
R2(config-router)# net 49.0001.0000.0000.0002.00
Configure Network entity title (NET).
R2(config-router)#mpls traffic-eng level-2
Configure mpls traffic engineering for level-2
R2(config-router)# address-family ipv6
Enter Address-family ipv6
R2(config-router-af)#exit-address-family
Exit address family ipv6
R2(config-router)#commit
Commit the transaction
R2(config-router)#exit
Exit router mode.
 
R3
 
R3#configure terminal
Enter configure mode.
R3(config)#interface lo
Enter interface mode.
R3(config-if)# ip address 13.13.13.13/32 secondary
Configure ip address on the loopback interface as secondary
R3(config)#interface eth2
Enter interface mode.
R3(config-if)# ipv6 address 65::1/64
Configure the IPv6 address of the interface.
R3(config-router)#exit
Exit router mode.
R3(config)# router bgp 1000
Configure router BGP in AS 1000
R3(config-router)# neighbor 65::2 remote-as 1000
Configure neighbor in remote-as 1000
R3(config-router)# address-family link-state link-state
Enter link-state Address family mode
R3(config-router-af)# neighbor 65::2 activate
Activate IBGP-LS neighbor
R3(config-router-af)#exit-address-family
Exit from Address Family configuration mode
Validation
R1
R1#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag 1: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 xe24 9819.2ca4.1c15 Up 27 L2 IS-IS
R1#
R1#show isis database verbose
Tag 1: VRF : default
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00* 0x0000000B 0xEE51 1150 0/0/0
Area Address: 49.0001
Topology: IPv6 (0x2)
NLPID: 0x8E
IPv6 Address: cafe:1:2::11
Router ID: 11.11.11.11
IPV6 Router ID: cafe:1:2::11
Router Cap: 11.11.11.11
SR-Algorithm:
Algorithm: 0
Maximum SID Depth:
SRH maximum segments left : 4
SRH maximum end pop : 4
SRH maximum H.encaps : 4
SRH maximum decapsulation sids : 4
SRV6 flags: 0
Metric: 10 IS (MT-IPv6) 0000.0000.0001.03
Maximum Link Bandwidth: 10g
TE-Default Metric: 10
IPv6 Interface Address: 2424::1
Link Delay : 0 us Anomalous : 0
Link Min/Max Delay : 0/0 us, Anomalous : 0
Link Delay-variation : 0 us
Link Loss : 0.000000%, Anomalous : 0
Link Residual Bandwidth: 0k
Link Available Bandwidth: 0k
Link Utilized Bandwidth: 0k
System-ID: 0000.0000.0002 SRV6 LAN END.X SID: cafe:1:2:a11:6001:: End-behaviour: End.X with PSP (6)
Metric: 10 IPv6 (MT-IPv6) cafe:1:2::11/128
Metric: 10 IPv6 (MT-IPv6) 65::/64
Metric: 10 IPv6 (MT-IPv6) 2424::/64
Metric: 1 IPv6 (MT-IPv6) cafe:1:2:a11::/64
SRV6 Locator: (MT-IPv6)cafe:1:2:a11::/64
Algorithm: 0 flags: 0 metric: 0
END SID: cafe:1:2:a11:2001:: flags:0 End-point behaviour: End with PSP (2)
END SID: cafe:1:2:a11:1001:: flags:0 End-point behaviour: End with USP (3)
END SID: cafe:1:2:a11:801:: flags:0 End-point behaviour: End with USD (28)
0000.0000.0001.03-00* 0x00000001 0x8345 1047 0/0/0
Metric: 0 IS-Extended 0000.0000.0001.00
Metric: 0 IS-Extended 0000.0000.0002.00
0000.0000.0002.00-00 0x0000000E 0x0371 1050 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 2424::2
Metric: 10 IS-Extended 0000.0000.0001.03
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
IPv6 Interface Address: 2424::2
Metric: 10 IPv6 2424::/64
 
R1# show isis database detail
Tag 1: VRF : default
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00* 0x0000000B 0xEE51 1146 0/0/0
Area Address: 49.0001
Topology: IPv6 (0x2)
NLPID: 0x8E
IPv6 Address: cafe:1:2::11
Router ID: 11.11.11.11
IPV6 Router ID: cafe:1:2::11
Router Cap: 11.11.11.11
SR-Algorithm:
Algorithm: 0
Maximum SID Depth:
SRH maximum segments left : 4
SRH maximum end pop : 4
SRH maximum H.encaps : 4
SRH maximum decapsulation sids : 4
SRV6 flags: 0
Metric: 10 IS (MT-IPv6) 0000.0000.0001.03
Metric: 10 IPv6 (MT-IPv6) cafe:1:2::11/128
Metric: 10 IPv6 (MT-IPv6) 65::/64
Metric: 10 IPv6 (MT-IPv6) 2424::/64
Metric: 1 IPv6 (MT-IPv6) cafe:1:2:a11::/64
SRV6 Locator: (MT-IPv6)cafe:1:2:a11::/64
Algorithm: 0 flags: 0 metric: 0
END SID: cafe:1:2:a11:2001:: flags:0 End-point behaviour: End with PSP (2)
END SID: cafe:1:2:a11:1001:: flags:0 End-point behaviour: End with USP (3)
END SID: cafe:1:2:a11:801:: flags:0 End-point behaviour: End with USD (28)
0000.0000.0001.03-00* 0x00000001 0x8345 1043 0/0/0
Metric: 0 IS-Extended 0000.0000.0001.00
Metric: 0 IS-Extended 0000.0000.0002.00
0000.0000.0002.00-00 0x0000000E 0x0371 1046 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 2424::2
Metric: 10 IS-Extended 0000.0000.0001.03
Metric: 10 IPv6 2424::/64
 
R1#
R1#show bgp link-state link-state summary
BGP router identifier 11.11.11.11, local AS number 1000
BGP table version is 11
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
65::1 4 1000 39 100 11 0 0 00:15:12 0
2002::2 4 1 33 87 11 0 0 00:15:12 0
 
Total number of neighbors 2
 
Total number of Established sessions 2
R1# show bgp link-state link-state
BGP router identifier 11.11.11.11, local AS number 1000
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, S SRv6 SID
I Identifier N local node, R remote node, L link P prefix, S SID
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID, s SID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
[V][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]]/208
[V][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.03]]/208
[V][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0002.00]]/208
[E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][R[c1000][b11.11.11.11][s0000.0000.0001.03]]/264
[E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.03]][R[c1000][b11.11.11.11][s0000.0000.0001.00]]/264
[E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.03]][R[c1000][b11.11.11.11][s0000.0000.0002.00]]/264
[E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0002.00]][R[c1000][b11.11.11.11][s0000.0000.0001.03]]/264
[T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][p65::/64]]/280
[T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][p2424::/64]]/280
[T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][pcafe:1:2:a11::/64]]/280
[T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][pcafe:1:2::11/128]]/344
[T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0002.00]][P[t0x0002][p2424::/64]]/280
[S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:801::/128]]/344
[S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:1001::/128]]/344
[S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:2001::/128]]/344
NLRIs, Total: 15, Node: 3, Link: 4, Prefix: 5, SRv6-SID: 3
R1# show bgp link-state link-state [V][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]]/208
BGP routing table entry for [V][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]]/208
Local
Received from IGP
Link State:
ISIS area address:49.0001
Aux Router ID: 11.11.11.11
SR Algorithm: 0
SR Flags: I:0 V:0
SRv6 Capability is enabled - flags 0
Node MSD
SRH maximum segments left - 4
SRH maximum end pop - 4
SRH maximum H.encaps - 4
SRH maximum decapsulation sids - 4
Multi-Topology ID is (0) - Standard Topology
Node flag bits: O:0 T:0 B:0 E:0
R1#
R1#show bgp link-state link-state [E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][R[c1000][b11.11.11.11][s0000.0000.0001.03]]/264
BGP routing table entry for [E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][R[c1000][b11.11.11.11][s0000.0000.0001.03]]/264
Local
Received from IGP
Link State:
Local Router ID: 11.11.11.11, Local Ipv6 Router ID: cafe:1:2::11, Max link bw: 1250000000.00 ,
TE metric 10 , IGP metric 10 Link Delay-variation : 0 us
Link Loss : 0.000000%, Anomalous : 0
Link Residual Bandwidth: 0k
Link Available Bandwidth: 0k
Link Utilized Bandwidth: 0k
SRv6 Lan End.X
SRv6 Lan End.X Endpoint behavior value: 6 - End.X with PSP
SRv6 Lan End.X Endpoint Flags: 0
SRv6 Lan End.X Endpoint Algorithm: 0
SRv6 Lan End.X Endpoint Weight: 0
SRv6 Lan End.X Endpoint neighbor_id: 0000.0000.0002
SRv6 Lan End.X SRv6 SID: cafe:1:2:a11:6001::
R1#
R1#show bgp link-state link-state [T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][pcafe:1:2:a11::/64]]/280
BGP routing table entry for [T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][pcafe:1:2:a11::/64]]/280
Local
Received from IGP
Link State:
Metric: 0 SRv6 Locator Flags :0 SRv6 Locator Algorithm :0 SRv6 Locator Metric :0
R1#show bgp link-state link-state [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:801::/128]]/344
BGP routing table entry for [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:801::/128]]/344
Local
Received from IGP
Link State:
SRv6 Endpoint behavior:
SRv6 Locator Endpoint :28 - End with USD SRv6 flags :0 SRv6 Algorithm :0
 
R1#show bgp link-state link-state [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:1001::/128]]/344
BGP routing table entry for [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:1001::/128]]/344
Local
Received from IGP
Link State:
SRv6 Endpoint behavior:
SRv6 Locator Endpoint :3 - End with USP SRv6 flags :0 SRv6 Algorithm :0
R1#
R1#show bgp link-state link-state [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:2001::/128]]/344
BGP routing table entry for [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:2001::/128]]/344
Local
Received from IGP
Link State:
SRv6 Endpoint behavior:
SRv6 Locator Endpoint :2 - End with PSP SRv6 flags :0 SRv6 Algorithm :0
R1#
R1#show segment-routing srv6 sid
SRv6 Segment ID table:
SID Operation Nexthop Originator
+----------------------+------------+------------------------+----------
cafe:1:2:a11:801:: END[usd] :: nsm
cafe:1:2:a11:1001:: END[usp] :: nsm
cafe:1:2:a11:2001:: END[psp] :: nsm
cafe:1:2:a11:6001:: END.X[psp] fe80::9a19:2cff:fea4:1c15isis
R1#
 
R2
R2#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag 1: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0001 xe17 e8c5.7a09.bc87 Up 6 L2 IS-IS
 
R2#show isis database verbose
Tag 1: VRF : default
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00 0x0000000B 0xEE51 1027 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: cafe:1:2::11
Router ID: 11.11.11.11
IPV6 Router ID: cafe:1:2::11
Router Cap: 11.11.11.11
SR-Algorithm:
Algorithm: 0
Maximum SID Depth:
SRH maximum segments left : 4
SRH maximum end pop : 4
SRH maximum H.encaps : 4
SRH maximum decapsulation sids : 4
Unknown Sub-TLV type 25 length 2
0000.0000.0001.03-00 0x00000001 0x8345 924 0/0/0
Metric: 0 IS-Extended 0000.0000.0001.00
Metric: 0 IS-Extended 0000.0000.0002.00
0000.0000.0002.00-00* 0x0000000E 0x0371 929 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 2424::2
Metric: 10 IS-Extended 0000.0000.0001.03
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
IPv6 Interface Address: 2424::2
Metric: 10 IPv6 2424::/64
 
R2#
 
R3
R3#show bgp link-state link-state summary
BGP router identifier 123.1.1.2, local AS number 1000
BGP table version is 6
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
65::2 4 1000 103 45 6 0 0 00:17:25 15
 
Total number of neighbors 1
 
Total number of Established sessions 1
R3#
R3#show bgp link-state link-state
BGP router identifier 123.1.1.2, local AS number 1000
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, S SRv6 SID
I Identifier N local node, R remote node, L link P prefix, S SID
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID, s SID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
i [V][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]]/208
i [V][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.03]]/208
i [V][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0002.00]]/208
i [E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][R[c1000][b11.11.11.11][s0000.0000.0001.03]]/264
i [E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.03]][R[c1000][b11.11.11.11][s0000.0000.0001.00]]/264
i [E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.03]][R[c1000][b11.11.11.11][s0000.0000.0002.00]]/264
i [E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0002.00]][R[c1000][b11.11.11.11][s0000.0000.0001.03]]/264
i [T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][p65::/64]]/280
i [T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][p2424::/64]]/280
i [T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][pcafe:1:2:a11::/64]]/280
i [T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][pcafe:1:2::11/128]]/344
i [T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0002.00]][P[t0x0002][p2424::/64]]/280
i [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:801::/128]]/344
i [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:1001::/128]]/344
i [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:2001::/128]]/344
NLRIs, Total: 15, Node: 3, Link: 4, Prefix: 5, SRv6-SID: 3
 
R3#show bgp link-state link-state [V][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]]/208
BGP routing table entry for [V][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]]/208
Local
Received from 11.11.11.11
Link State:
ISIS area address:49.0001
Aux Router ID: 11.11.11.11
SR Algorithm: 0
SR Flags: I:0 V:0
SRv6 Capability is enabled - flags 0
Node MSD
SRH maximum segments left - 4
SRH maximum end pop - 4
SRH maximum H.encaps - 4
SRH maximum decapsulation sids - 4
Multi-Topology ID is (0) - Standard Topology
Node flag bits: O:0 T:0 B:0 E:0
R3#
 
R3#show bgp link-state link-state [E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][R[c1000][b11.11.11.11][s0000.0000.0001.03]]/264
BGP routing table entry for [E][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][R[c1000][b11.11.11.11][s0000.0000.0001.03]]/264
Local
Received from 11.11.11.11
Link State:
Local Router ID: 11.11.11.11, Local Ipv6 Router ID: cafe:1:2::11, Max link bw: 1250000000.00 ,
TE metric 10 , IGP metric 10 Link Delay-variation : 0 us
Link Loss : 0.000000%, Anomalous : 0
Link Residual Bandwidth: 0k
Link Available Bandwidth: 0k
Link Utilized Bandwidth: 0k
SRv6 Lan End.X
SRv6 Lan End.X Endpoint behavior value: 6 - End.X with PSP
SRv6 Lan End.X Endpoint Flags: 0
SRv6 Lan End.X Endpoint Algorithm: 0
SRv6 Lan End.X Endpoint Weight: 0
SRv6 Lan End.X Endpoint neighbor_id: 0000.0000.0002
SRv6 Lan End.X SRv6 SID: cafe:1:2:a11:6001::
R3#
R3#show bgp link-state link-state [T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][p65::/64]]/280
BGP routing table entry for [T][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][P[t0x0002][p65::/64]]/280
Local
Received from 11.11.11.11
Link State:
Metric: 10
R3#
R3#show bgp link-state link-state [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:801::/128]]/344
BGP routing table entry for [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:801::/128]]/344
Local
Received from 11.11.11.11
Link State:
SRv6 Endpoint behavior:
SRv6 Locator Endpoint :28 - End with USD SRv6 flags :0 SRv6 Algorithm :0
R3#
R3#show bgp link-state link-state sho
R3#show bgp link-state link-state sho bg
R3#show bgp link-state link-state [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:1001::/128]]/344
BGP routing table entry for [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:1001::/128]]/344
Local
Received from 11.11.11.11
Link State:
SRv6 Endpoint behavior:
SRv6 Locator Endpoint :3 - End with USP SRv6 flags :0 SRv6 Algorithm :0
R3#show bgp link-state link-state [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:2001::/128]]/344
BGP routing table entry for [S][L2][I0x1][N[c1000][b11.11.11.11][s0000.0000.0001.00]][S[t0x0002][scafe:1:2:a11:2001::/128]]/344
Local
Received from 11.11.11.11
Link State:
SRv6 Endpoint behavior:
SRv6 Locator Endpoint :2 - End with PSP SRv6 flags :0 SRv6 Algorithm :0
R3#