OcNOS-SP : Segment Routing Guide : Segment Routing Configuration Guide : Configuring OSPFv6 Segment Routing IPv6
Configuring OSPFv6 Segment Routing IPv6
This chapter contains configurations of SRv6 with OSPFv6.
SRv6
SRv6 represents Segment routing (SR) with IPv6 data plane. The SRv6 network program is encoded in the Segment Routing extension Header (SRH) of a network packet as an ordered list of segments. The most significant bits of a segment are called “locator”. The locator acts as any routed subnet address and ensures that the packet destined for a segment is routed to the destination of that segment. The packet goes from node to node and receives sequential processing according to ordered instructions selected by the source and encoded in the SRH. No intermediate node changes the flow.
Topology
Below example shows the SRv6 with OSPFv6 configurations.
OSPFv6 Configuration Topology
PE1
 
PE1#configure terminal
Enter configure mode.
PE1(config)#tunnel-policy policy0
Configure tunnel policy
PE1(config-tnl-policy)#color 1
Color to be used as 1
PE1(config-tnl-policy)#exit
Exit to config mode
PE1(config)#ip vrf vrf1
IP VRF config with name vrf1
PE1(config-vrf)#tunnel-select-policy policy0
Tunnel-policy to be mapped as policy0
PE1(config-vrf)#rd 1:1
Route-distinguisher value
PE1(config-vrf)#route-target both 1:1
Route target value
PE1(config-vrf)#exit
Exit to config mode
PE1(config)#interface lo
Enter interface mode.
PE1(config-if)#ipv6 address cafe:1:2::11/128
Configure IPv6 address of the loopback interface.
PE1(config-if)# ip address 11.11.11.11/32 secondary
Configure IP address on the loopback interface as secondary
PE1(config-if)# ipv6 address cafe:1:2::11/128
Configure IPv6 address
PE1(config-if)# ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router ospf area 0.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#interface eth1
Enter interface mode.
PE1(config-if)#ipv6 address 1111::2/64
Configure the IPv6 address of the interface.
PE1(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router OSPF area 0.
PE1(config)#interface eth2
Enter interface mode.
PE1(config-if)#ip vrf forwarding vrf1
Attaching eth2 to as part of vrf1
PE1(config-if)#ip address 101.1.1.1/24
Configure the IP address of the interface.
PE1(config-if)#exit
Exit interface mode
PE1(config)#router ipv6 ospf 1
Set the routing process ID as 1
PE1(config-router-af)#segment-routing srv6
Enable SRv6 under IPv6 address-family
PE1(config-router-af-srv6)# srv6-locator Srs123
Name to SRv6 locator
PE1(config-router-af-srv6)#exit-srv6
Exit SRv6 mode
PE1(config-router)#exit
Exit router mode.
PE1(config)# router bgp 1000
Configure router BGP in AS 1000
PE1(config-router)# neighbor cafe:1:2::22 remote-as 1000
Configure neighbor in remote-as 1000
PE1(config-router)#neghbor cafe:1:2::22 update-source lo
Configure neighbor with update-source lo
PE1(config-router)# address-family vpnv4 unicast
Enter VPNv4 Address family mode
PE1(config-router-af)# segment-routing srv6
Enter SR6 mode
PE1(config-router-vpnv4-srv6)# srv6-locator srs123
Configure locator name under srv6 mode
PE1(config-router-vpnv4-srv6)# exit-srv6
Exit SRv6 mode
PE1(config-router-af)#neighbor cafe:1:2::22 activate
Activate VPNv4 neighbor
PE1(config-router-af)# neighbor cafe:1:2::22 capability extended-nexthop-encode
Configure extended nexthop encode capability for vpnv4 neighbor
PE1(config-router-af)#exit-address-family
Exit from Address Family configuration mode
PE1(config-router)#address-family ipv4 vrf vrf1
Enter VRF address family
PE1(config-router-af)#redistribute connected
Redistribute connected routes
PE1(config-router-af)#segment-routing srv6
Enter SRv6 mode
PE1(config-router-vrfv4-srv6)#sid-alloc per-vrf
Allocate sid per VRF
PE1(config-router-vrfv4-srv6)#exit-srv6
Exit SRv6 mode
PE1(config-router-vrfv4-srv6)#exit-address-family
Exit from Address Family configuration mode
PE1(config-router-af)#exit
Exit from router mode
PE1(config)#segment-routing
Configuring segment-routing
PE1(config-sr)#srv6
Segment-Routing over IPv6 Data-Plane
PE1(config-srv6)#locators
Configure SRv6 locators
PE1(config-srv6-loc)#locator srs123
Locator name as Srs123
PE1(config-srv6-loc-conf)# prefix cafe:1:2:a11::/64
IPv6 prefix for locator
PE1(config-srv6-loc-conf)#exit-locator
Exit from locator mode
PE1(config-srv6-loc)#exit-locators
Exit from SRv6 locators configuration mode
PE1(config-srv6)#exit-srv6
Exit from SRv6 configuration mode
PE1(config-sr)#traffic-engineering
Segment Routing traffic engineering
Segment Routing traffic engineering
Configure segment list as 1
PE1(config-sr-sl)#index 1 segment-type-2 cafe:1:2:a22:2001::
Configure segment type 2 with SRv6 SIDs
PE1(config-sr-sl)#exit-sr-sl
Exit segment list mode
PE1(config-sr-te)#policy 1
Policy configuration with name 1
PE1(config-sr-pol)# color 1 end-point cafe:1:2::22
SR-policy color and end-point
PE1(config-sr-pol-cp)#candidate-path 1
SR policy candidate path
PE1(config-sr-pol-cp)#preference 100
Candidate Path preference
PE1(config-sr-pol-cp)# explicit segment-list l
Dynamic candidate path as OSPF
PE1(config-sr-pol)#exit-sr-pol
Exit from SR policy configuration mode
PE1(config-sr-te)#exit-te
Exit from traffic engineering configuration mode
P1
 
P1#configure terminal
Enter configure mode.
P1(config)#interface eth1
Enter interface mode.
P1(config-if)# ipv6 address 1111::1/64
Configure the IPv6 address of the interface.
P1(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router ospf area 0.
P1(config)#interface eth2
Enter interface mode.
P1(config-if)# ipv6 address 5001::1/64
Configure the IP address of the interface.
P1(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router OSPF area 0.
P1(config-if)#exit
Exit interface mode.
P1(config)#router ipv6 ospf 1
Set the routing process ID as 1
P1(config-router)#segment-routing srv6
Enable SRv6 under IPv6 address-family
PE1(config-router-af-srv6)# srv6-locator srs123
Name to SRv6 locator
P1(config-router)#exit
Exit router mode.
P2
 
P2#configure terminal
Enter configure mode.
P2(config)#interface eth1
Enter interface mode.
P2(config-if)# ipv6 address 50::50/64
Configure the IPv6 address of the interface.
P2(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router OSPF area 0.
P2(config)#interface eth2
Enter interface mode.
P2(config-if)# ipv6 address 5001::2/64
Configure the IP address of the interface.
P2(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router OSPF area 0.
P2(config-if)#exit
Exit interface mode.
P2(config)#router ipv6 ospf 1
Set the routing process ID as 1
P2(config-router)#segment-routing srv6
Configure is-type as level-2
P2(config-router-af-srv6)#srv6-locator srs123
Name to SRv6 locator
P2(config-router)#exit
Exit router mode.
P3
 
P3#configure terminal
Enter configure mode.
P3(config)#interface eth1
Enter interface mode.
P3(config-if)# ipv6 address 50::5/64
Configure the IPv6 address of the interface.
P3(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router OSPF area 0.
P3(config)#interface eth2
Enter interface mode.
P3(config-if)# ipv6 address 511::1/64
Configure the IP address of the interface.
P3(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router OSPF area 0.
P3(config-if)#exit
Exit interface mode.
P3(config)#router ipv6 ospf 1
Set the routing process ID as 1
P3(config-router)#segment-routing srv6
Configure is-type as level-2
P3(config-router-af-srv6)#srv6-locator srs123
Name to SRv6 locator
P3(config-router)#exit
Exit router mode.
P4
 
P4#configure terminal
Enter configure mode.
P4(config)#interface eth1
Enter interface mode.
P4(config-if)# ipv6 address 611::1/64
Configure the IPv6 address of the interface.
P4(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router OSPF area 0.
P4(config)#interface eth2
Enter interface mode.
P4(config-if)# ipv6 address 511::2/64
Configure the IP address of the interface.
P4(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router OSPF area 0.
P4(config-if)#exit
Exit interface mode.
P4(config)#router ipv6 ospf 1
Set the routing process ID as 1
P4(config-router)#segment-routing srv6
Configure is-type as level-2
P4(config-router-af-srv6)#srv6-locator srs123
Name to SRv6 locator
P4(config-router)#exit
Exit router mode.
PE2
 
PE2#configure terminal
Enter configure mode.
PE2(config)#tunnel-policy policy0
Configure tunnel policy
PE2(config-tnl-policy)#color 1
Color to be used as 1
PE2(config-tnl-policy)#exit
Exit to config mode
PE2(config)#ip vrf vrf1
IP VRF config with name vrf1
PE2(config-vrf)#tunnel-select-policy policy0
tunnel-policy to be mapped as policy0
PE2(config-vrf)#rd 1:2
Route-distinguisher value
PE2(config-vrf)#route-target both 1:1
Route target value
PE2(config-vrf)#exit
Exit to config mode
PE2(config)#interface lo
Enter interface mode.
PE2(config-if)# ip address 6.6.6.6/32 secondary
Configure ip address on the loopback interface as secondary
PE2(config-if)#ipv6 address cafe:1:2::22/128
Configure IPv6 address of the loopback interface.
PE2(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router OSPF area 0.
PE2(config-if)#exit
Exit interface mode.
PE2(config)#interface eth1
Enter interface mode.
PE2(config-if)#ipv6 address 611::2/64
Configure the IPv6 address of the interface.
PE2(config-if)#ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router ospf area 0.
PE2(config)#interface eth2
Enter interface mode.
PE2(config-if)#ip vrf forwarding vrf1
Attaching eth2 to as part of vrf1
PE2(config-if)#ip address 201.1.1.1/24
Configure the IP address of the interface.
PE2(config-if)#exit
Exit interface mode
PE2(config)#router ipv6 ospf 1
Set the routing process ID as 1
PE2(config-router)#segment-routing srv6
Configure is-type as level-2
PE2(config-router-af-srv6)#srv6-locator srs123
Name to SRv6 locator
PE2(config-router-af-srv6)#exit-srv6
Exit SRv6 mode
PE2(config-router)#exit
Exit router mode.
PE2(config)# router bgp 1000
Configure router BGP in AS 1000
PE2(config-router)# neighbor cafe:1:2::11 remote-as 1000
Configure neighbor in remote-as 1000
PE2(config-router)#neighbor cafe:1:2::11 update-source lo
Configure neighbor with update-source lo
PE2(config-router)# address-family vpnv4 unicast
Enter VPNv4 Address family mode
PE2(config-router-af)# segment-routing srv6
Enter SRv6 mode
PE2(config-router-vpnv4-srv6)# srv6-locator PE2_locator
Configure locator name under SRv6 mode
PE2(config-router-vpnv4-srv6)# exit-srv6
Exit SRv6 mode
PE2(config-router-af)#neighbor cafe:1:2::11 activate
Activate VPNv4 neighbor
PE2(config-router-af)# neighbor cafe:1:2::11 capability extended-nexthop-encode
Configure extended nexthop encode capability for VPNv4 neighbor
PE2(config-router-af)#exit-address-family
Exit from Address Family configuration mode
PE2(config-router)#address-family ipv4 vrf vrf1
Enter VRF address family
PE2(config-router-af)#redistribute connected
Redistribute connected routes
PE2(config-router-af)#segment-routing srv6
Enter SRv6 mode
PE2(config-router-vrfv4-srv6)#sid-alloc per-vrf
Allocate sid per VRF
PE2(config-router-vrfv4-srv6)#exit-srv6
Exit SRv6 mode
PE2(config-router-vrfv4-srv6)#exit-address-family
Exit from Address Family configuration mode
PE2(config-router-af)#exit
Exit from router mode
PE2(config)#segment-routing
Configuring segment-routing
PE2(config-sr)#srv6
Segment-Routing over IPv6 Data-Plane
PE2(config-srv6)#locators
Configure SRv6 locators
PE2(config-srv6-loc)#locator srs123
Locator name as PE2_locator
PE2(config-srv6-loc-conf)# prefix cafe:1:2:a11::/64
IPv6 prefix for locator
PE2(config-srv6-loc-conf)#exit-locator
Exit from locator mode
PE2(config-srv6-loc)#exit-locators
Exit from SRv6 locators configuration mode
PE2(config-srv6)#exit-srv6
Exit from SRv6 configuration mode
PE2(config-sr)#traffic-engineering
Segment Routing traffic engineering
PE2(config-sr-sl)#segment-list 1
Configure segment list as 1
PE2(config-sr-sl)#index 1 segment-type-2 cafe:1:2:a22:2001::
Configure segment type 2 with SRv6 SIDs
PE2(config-sr-sl)#exit-sr-sl
Exit segment list mode
PE2(config-sr-te)#policy 1
Policy configuration with name 1
PE2(config-sr-pol)# color 1 end-point cafe:1:2::11
SR-policy color and end-point
PE2(config-sr-pol-cp)#candidate-path 1
SR policy candidate path
PE2(config-sr-pol-cp)#preference 100
Candidate Path preference
PE2(config-sr-pol-cp)# explicit segment-list l
Configuring explicit segment-list as 1
PE2(config-sr-pol)#exit-sr-pol
Exit from SR policy configuration mode
PE2(config-sr-te)#exit-te
Exit from traffic engineering configuration mode
 
Validation
PE1-7028#show ipv6 ospf neighbor
 
Total number of full neighbors: 1
OSPFv3 Process (1)
Neighbor ID Pri State Dead Time Interface Instance ID
2.2.2.2 1 Full/DR 00:00:31 ce0 0
 
PE1-7028#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, D- DHCP, R - RIP,
O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP,
P - SRV6-POLICY,
v - vrf leaked
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 00:56:23
O 50::/64 [110/3] via fe80::ba6a:97ff:fed6:716e, ce0, 00:02:17
O 102::/64 [110/6] via fe80::ba6a:97ff:fed6:716e, ce0, 00:01:43
O 511::/64 [110/4] via fe80::ba6a:97ff:fed6:716e, ce0, 00:01:43
C 567::/64 via ::, ce0, 00:03:03
O 611::/64 [110/5] via fe80::ba6a:97ff:fed6:716e, ce0, 00:01:43
O 1234::/64 [110/2] via fe80::ba6a:97ff:fed6:716e, ce0, 00:02:17
O 3234::/64 [110/5] via fe80::ba6a:97ff:fed6:716e, ce0, 00:01:43
O 5001::/64 [110/2] via fe80::ba6a:97ff:fed6:716e, ce0, 00:02:17
C cafe:1:2::11/128 via ::, lo, 00:55:51
O cafe:1:2::22/128 [110/5] via fe80::ba6a:97ff:fed6:716e, ce0, 00:01:43
O cafe:1:2:a11::/64 [110/1] via ::, lo, 00:02:23
C cafe:1:2:a11:801::/128, SRV6 END SID
via ::, lo, 00:55:51
C cafe:1:2:a11:1001::/128, SRV6 END SID
via ::, lo, 00:55:51
C cafe:1:2:a11:2001::/128, SRV6 END SID
via ::, lo, 00:55:51
C cafe:1:2:a11:2003::/128, SRV6 END.X SID
via fe80::ba6a:97ff:fed6:716e, ce0, 00:02:23
C cafe:1:2:a11:8001::/128, SRV6 END.DT4 SID
via ::, lo, 00:55:51
O cafe:1:2:a22::/64 [110/6] via fe80::ba6a:97ff:fed6:716e, ce0, 00:01:43
C fe80::/64 via ::, ce0, 00:03:03
 
PE1-7028#show ipv6 ospf database
 
OSPFv3 Router with ID (1.1.1.1) (Process 1)
 
Link-LSA (Interface lo)
 
Link State ID ADV Router Age Seq# CkSum Prefix
0.0.0.1 1.1.1.1 64 0x80000003 0x9f63 2
 
Link-LSA (Interface ce0)
 
Link State ID ADV Router Age Seq# CkSum Prefix
0.0.39.151 1.1.1.1 496 0x80000001 0x0449 1
0.0.39.65 2.2.2.2 497 0x80000001 0xcf29 1
 
Router-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum Link
0.0.0.0 1.1.1.1 416 0x80000009 0x1aa8 1
0.0.0.0 2.2.2.2 452 0x80000008 0x6b13 2
0.0.0.0 3.3.3.3 712 0x80000006 0x2452 2
0.0.0.0 4.4.4.4 709 0x80000004 0xabbf 2
0.0.0.0 5.5.5.5 713 0x80000008 0x5f3d 2
0.0.0.0 6.6.6.6 421 0x8000000d 0x064b 1
 
Network-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum
0.0.39.65 2.2.2.2 457 0x80000001 0xf496
0.0.39.21 3.3.3.3 1799 0x80000002 0xe2c7
0.0.39.66 3.3.3.3 713 0x80000001 0x85f0
0.0.39.22 5.5.5.5 713 0x80000001 0x474b
0.0.39.17 6.6.6.6 5 0x80000003 0xabdd
 
Intra-Area-Prefix-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum Prefix Reference
0.0.0.1 1.1.1.1 415 0x8000000a 0x70e5 2 Router-LSA
0.0.0.1 2.2.2.2 451 0x8000000a 0x6bf9 1 Router-LSA
0.0.0.2 2.2.2.2 451 0x80000001 0x5c82 1 Network-LSA
0.0.0.2 3.3.3.3 1794 0x80000002 0x4bd1 1 Network-LSA
0.0.0.4 3.3.3.3 712 0x80000001 0x39b6 1 Network-LSA
0.0.0.1 5.5.5.5 712 0x80000009 0x0c22 1 Router-LSA
0.0.0.2 5.5.5.5 712 0x80000001 0x2a1e 1 Network-LSA
0.0.0.1 6.6.6.6 420 0x8000000e 0xd7de 3 Router-LSA
0.0.0.2 6.6.6.6 20 0x80000003 0xf7ce 1 Network-LSA
0.0.0.3 6.6.6.6 1798 0x80000002 0x132f 1 Network-LSA
 
Opaque-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum
0.0.0.0 1.1.1.1 456 0x80000004 0x6741
0.0.0.0 6.6.6.6 5 0x80000006 0xccc5
 
Ext-Router-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum
0.0.39.151 1.1.1.1 456 0x80000001 0x9a3a
0.0.39.171 1.1.1.1 456 0x80000003 0xacfa
0.0.39.17 6.6.6.6 3600 0x80000003 0x6e60
0.0.39.37 6.6.6.6 3600 0x80000003 0x0a99
19.138.128.101 6.6.6.6 3600 0x80000003 0x10bd
 
Locator-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum
0.0.39.151 1.1.1.1 456 0x80000001 0x2679
0.0.39.171 1.1.1.1 456 0x80000003 0x5930
0.0.39.17 6.6.6.6 3600 0x80000003 0x4487
0.0.39.37 6.6.6.6 3600 0x80000003 0x7b3c
19.138.128.101 6.6.6.6 3600 0x80000003 0xabd4
 
PE1-7028#show segment-routing srv6 locator srs123 detail
Locator : srs123
Prefix : cafe:1:2:a11::/64
Uptime : 01:01:44
 
PE1-7028#show ipv6 ospf database opaque
 
OSPFv3 Router with ID (1.1.1.1) (Process 1)
 
Opaque-LSA (Area 0.0.0.0)
 
LS age: 569
LS Type: Opaque RI LSA
Link State ID: 0.0.0.0
Advertising Router: 1.1.1.1
LS Seq Number: 0x80000004
Checksum: 0x6741
Length: 48
 
Router Capability TLV:
Flags:0 Reserve bits:0
 
Algorithm TLV :
Algorithm: 0
 
Maximum SID Depth :
SRH maximum segments left (41) : 4
SRH maximum end pop (42) : 4
SRH maximum H.encaps (44) : 4
SRH maximum decapsulation sids (45) : 4
 
 
LS age: 118
LS Type: Opaque RI LSA
Link State ID: 0.0.0.0
Advertising Router: 6.6.6.6
LS Seq Number: 0x80000006
Checksum: 0xCCC5
Length: 48
 
Router Capability TLV:
Flags:0 Reserve bits:0
 
Algorithm TLV :
Algorithm: 0
 
Maximum SID Depth :
SRH maximum segments left (41) : 4
SRH maximum end pop (42) : 4
SRH maximum H.encaps (44) : 4
SRH maximum decapsulation sids (45) : 4
 
PE1-7028#show ipv6 ospf database locator
 
OSPFv3 Router with ID (1.1.1.1) (Process 1)
 
Locator-LSA (Area 0.0.0.0)
 
LS age: 586
LS Type: Locator LSA
Link State ID: 0.0.39.151
Advertising Router: 1.1.1.1
LS Seq Number: 0x80000001
Checksum: 0x2679
Length: 120
 
Locator-LSA (Length:24):
Route type:0 Algorithm:0
Flags:0 Metric:0
Prefix: cafe:1:2:a11::/64
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a11:2001::
End-point behaviour: End with PSP (2)
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a11:1001::
End-point behaviour: End with USP (3)
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a11:801::
End-point behaviour: End with USD (28)
 
 
 
LS age: 586
LS Type: Locator LSA
Link State ID: 0.0.39.171
Advertising Router: 1.1.1.1
LS Seq Number: 0x80000003
Checksum: 0x5930
Length: 120
 
Locator-LSA (Length:24):
Route type:0 Algorithm:0
Flags:0 Metric:0
Prefix: cafe:1:2:a11::/64
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a11:2001::
End-point behaviour: End with PSP (2)
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a11:1001::
End-point behaviour: End with USP (3)
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a11:801::
End-point behaviour: End with USD (28)
 
 
 
LS age: 135
LS Type: Locator LSA
Link State ID: 0.0.39.17
Advertising Router: 6.6.6.6
LS Seq Number: 0x80000004
Checksum: 0x4288
Length: 120
 
Locator-LSA (Length:24):
Route type:0 Algorithm:0
Flags:0 Metric:0
Prefix: cafe:1:2:a22::/64
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:2001::
End-point behaviour: End with PSP (2)
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:1001::
End-point behaviour: End with USP (3)
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:801::
End-point behaviour: End with USD (28)
 
 
 
LS age: 135
LS Type: Locator LSA
Link State ID: 0.0.39.37
Advertising Router: 6.6.6.6
LS Seq Number: 0x80000004
Checksum: 0x793D
Length: 120
 
Locator-LSA (Length:24):
Route type:0 Algorithm:0
Flags:0 Metric:0
Prefix: cafe:1:2:a22::/64
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:2001::
End-point behaviour: End with PSP (2)
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:1001::
End-point behaviour: End with USP (3)
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:801::
End-point behaviour: End with USD (28)
 
 
 
LS age: 135
LS Type: Locator LSA
Link State ID: 19.138.128.101
Advertising Router: 6.6.6.6
LS Seq Number: 0x80000004
Checksum: 0xA9D5
Length: 120
 
Locator-LSA (Length:24):
Route type:0 Algorithm:0
Flags:0 Metric:0
Prefix: cafe:1:2:a22::/64
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:2001::
End-point behaviour: End with PSP (2)
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:1001::
End-point behaviour: End with USP (3)
 
SRv6 END TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:801::
End-point behaviour: End with USD (28)
 
PE1-7028#sho ip bgp vpnv4 all summary
BGP router identifier 11.11.11.11, local AS number 1000
BGP table version is 2
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
cafe:1:2::22 4 1000 150 150 2 0 0 01:02:47 1
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE1-7028#show ip bgp vpnv4 all
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:1 (Default for VRF vrf1)
*> 101.1.1.0/24 0.0.0.0 0 100 32768 ?
*>i201.1.1.0 cafe:1:2::22 0 100 0 ?
Announced routes count = 1
Accepted routes count = 1
Route Distinguisher: 1:1
*>i201.1.1.0 cafe:1:2::22 0 100 0 ?
Announced routes count = 0
Accepted routes count = 1
 
PE1-7028#show ip bgp vpnv4 all tags
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop In Label/Out Label
Route Distinguisher: 1:1 (Default for VRF vrf1)
*> 101.1.1.0/24 0.0.0.0 Local sid cafe:1:2:a11:8001::
*>i 201.1.1.0 cafe:1:2::22 vpn sid cafe:1:2:a22:8001::
Announced routes count = 1
Accepted routes count = 1
Route Distinguisher: 1:1
*>i 201.1.1.0 cafe:1:2::22
Announced routes count = 0
Accepted routes count = 1
PE1-7028#
PE1-7028#show segment-routing srv6 sid
SRv6 Segment ID table:
SID Operation Nexthop Originator
+----------------------+------------+------------------------+----------
cafe:1:2:a11:801:: END[usd] :: nsm
cafe:1:2:a11:1001:: END[usp] :: nsm
cafe:1:2:a11:2001:: END[psp] :: nsm
cafe:1:2:a11:2003:: END.X[psp] fe80::ba6a:97ff:fed6:716eospf
cafe:1:2:a11:8001:: END.DT4 vrf vrf1 bgp:1000
 
PE1-7028#show segment-routing srv6 services
Codes: > - installed; T:Uses service-mapped tunnel
Service Flags vrf FEC SID Nexthop SRv6-Policy-Name
vpnv4 >*T vrf1 201.1.1.0/24 cafe:1:2:a22:8001:: cafe:1:2::22 p1
 
PE1-7028#show hsl srv6 l3vpn
TABLE: SRV6 L3VPN
+-------+---------------------+---------------------+--------+----------------------------+--------------------------+----------+------------------------+
| VRF | DESTINATION | POLICY/LSP/ | OUT | VPN NEXTHOP | NEXTHOP | Number of| SEGMENTS |
| ID | FEC | TYPE/NHLFE ID | IFNAME | | | Segments | |
+-------+---------------------+---------------------+--------+----------------------------+--------------------------+----------+------------------------+
2 201.1.1.0/24 1 /3 /PRI /3 ce0 cafe:1:2::22 fe80::ba6a:97ff:fed6:716e 1 cafe:1:2:a22:8001::