OcNOS-SP : Segment Routing Guide : Segment Routing Configuration Guide : OSPF-SR-User Defined Adjacency SID
OSPF-SR-User Defined Adjacency SID
This chapter contains configurations of OSPF-SR-user defined local adjacency.
Segment routing (SR) networks often use SR Traffic Engineering (SR-TE) to influence the path-specific traffic that takes over the network. SR-TE tunnels can be provisioned manually on the tunnel headend, or are calculated and provisioned by a central controller.
For traffic engineering, operators of a network need to be able to force traffic over specific nodes and links.
To force traffic over a certain node in the SR network, operators can use the Prefix-SID that is advertised by the node.
To force traffic through a certain link, operators can use the adjacency SID of the link. Without the support for user-configured adjacency SIDs, adjacency SIDs are dynamically allocated.
As dynamic value is not persistent over reload or process restart, also not known upfront, a controller cannot use it unless it has access to the information flooded by IGP.
Topology
L2VPN with SRLB-SID-ADJ configuration topology
Configuration
PE-1
 
#configure terminal
Enter Configure mode.
(config)#segment-routing
Enter the segment routing mode.
(config-sr)#global block 10001 20000
Enable SRGB under segment routing
(config-sr)#local block 100000 109999
Enable SRLB under segment routing
(config)#interface lo
Enter interface mode
(config -if)#ip address 43.43.43.43/32 secondary
Configure IP address for the loopback interface
(config -if)#prefix-sid index 4300
Configure prefix-sid absolute value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 43.43.43.43
Configure Router-id
(config-router)#targeted-peer ipv4 14.14.14.14
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit from targeted-peer mode
(config-router)#transport-address ipv4 43.43.43.43
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface ce3
Enter interface mode
(config-if)#ip address 16.0.0.10/24
Configure IP address on interface
(config-if)#adjacency-sid absolute 100500
Configure adjacency-sid absolute value
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po100
Enter interface mode
(config-if)#ip address 15.0.0.20/24
Configure IP address on interface
(config-if)#adjacency-sid index 501
Configure adjacency-sid index value
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface xe20
Enter interface mode
(config-if)#channel-group 100 mode active
Moving interface to Dynamic LAG
(config-if)#exit
Exit interface mode
(config-if)#interface xe21
Enter interface mode
(config-if)#channel-group 100 mode active
Moving interface to Dynamic LAG
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the Process ID, (100). The Process ID should be a unique positive integer to identifying the routing process.
(config-router)#ospf router-id 43.43.43.43
Configure ospf Router-id
(config-router)#network 15.0.0.20/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 16.0.0.10/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 43.43.43.43/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#segment-routing mpls
Enable segment routing
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#tunnel-policy PE1-P1-PE2
Configure tunnel policy
(config-tnl-policy)# color 1
Map the color with the SR policy to be used..
(config)#tunnel-policy PE1-P3-PE2
Configure tunnel policy
(config-tnl-policy)# color 2
Map the color with the SR policy to be used..
(config)#segment-routing
Enter the segment routing mode.
(config-sr)# traffic-engineering
Segment Routing traffic engineering
(config-sr-te) policy PE1-P1-PE2
Policy configuration with name
(config-sr-pol) color 1 end-point 14.14.14.14
SR-policy color and end-point
(config-sr-pol-cp) candidate-path 1
SR policy candidate path
(config-sr-pol-cp)# dynamic-path ospf 1
Dynamic candidate path as OSPF
(config-sr-pol-cp)# constraints
Specify constraints
(config-sr-dyn-cp-cons)# 30.30.30.30 loose
Loopback IP of P1 as loose constraint
(config-sr-dyn-cp-cons)# 44.44.44.44 loose
Loopback IP of P2 as loose constraint
(config-sr-pol-cp)# exit-pol-cp
Exit from SR policy candidate path configuration mode
(config-sr-pol)#exit-sr-pol
Exit from SR policy configuration mode
(config-sr-te) policy PE1-P3-PE2
Policy configuration with name
(config-sr-pol) color 2 end-point 14.14.14.14
SR-policy color and end-point
(config-sr-pol-cp) candidate-path 1
SR policy candidate path
(config-sr-pol-cp)# dynamic-path ospf 1
Dynamic candidate path as OSPF
(config-sr-pol-cp)# constraints
Specify constraints
(config-sr-dyn-cp-cons)# 42.42.42.42 loose
Loopback IP of P1 as loose constraint
(config-sr-dyn-cp-cons)# 29.29.29.29 loose
Loopback IP of P2 as loose constraint
(config-sr-pol-cp)# exit-pol-cp
Exit from SR policy candidate path configuration mode
(config-sr-pol)#exit-sr-pol
Exit from SR policy configuration mode
(config-sr-te)#exit-te
Exit from traffic engineering configuration mode
(config)#commit
Commit candidate configuration to be running configuration
(config)#mac vrf vrf500
Enter VRF mode
(config-vrf)#rd 43.43.43.43:500
Configuring Route-Distinguisher value
(config-vrf)#route-target both 500:500
Configuring import and export value
(config)#mac vrf vpls600
Enter VRF mode
(config-vrf)#rd 43.43.43.43:600
Configuring Route-Distinguisher value
(config-vrf)#route-target both 600:600
Configuring import and export value
(config)#mac vrf vrfetree700
Enter VRF mode
(config-vrf)#rd 101:1
Configuring Route-Distinguisher value
(config-vrf)#route-target export 101:1
Configuring export value
(config-vrf)#route-target import 102:1
Configuring import value
(config-vrf)#evpn mpls vtep-ip-global 43.43.43.43
Configuring VTEP global IP to loopback IP
(config)#evpn mpls id 2 xconnect target-mpls-id 252
Configure the EVPN-ELINE identifier with source identifier
and target identifier
 
(config)#host-reachability-protocol evpn-bgp vrf500
Mapping vrf to EVPN-ELINE identifier
(config)#evpn mpls id 600
Configure the EVPN-ELAN identifier with identifier
(config)#host-reachability-protocol evpn-bgp vpls600
Mapping vrf to EVPN-ELAN identifier
(config)#evpn mpls id 700
Configure the EVPN-ETREE identifier with identifier
(config)#host-reachability-protocol evpn-bgp vrfetree700
Mapping vrf to EVPN-TREE identifier
(config)#router bgp 100
Configure router bgp in AS 100
(config-router)#bgp router-id 43.43.43.43
Configure BGP router ID
(config-router)#neighbor 14.14.14.14 remote-as 100
Configure neighbor in remote-as 100
(config-router)#neighbor 14.14.14.14 update-source lo
Configure neighbor with update-source loopback
(config-router)#address-family vpnv4 unicast
Enter VPNv4 Address family mode
(config-router-af)#neighbor 14.14.14.14 activate
mode Activate VPNv4 neighbor
(config-router-af)#exit-address-family
Exit from Address Family configuration
(config-router)#address-family l2vpn evpn
Enter evpn Address family mode
(config-router-af)#neighbor 14.14.14.14 activate
mode Activate evpn neighbor
(config-router-af)#exit-address-family
Exit from Address Family configuration
(config-router)#exit
Exit from router mode
(config)#mpls vpls100 100
Configuring VPLS instance with name and VPLS ID
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance
(config-vpls-sig)#vpls-type ethernet
Type ethernet configuration for VPLS
(config-vpls-sig)# vpls-peer 14.14.14.14 tunnel-select-policy PE1-P3-PE2
Configuring VPLS mesh peers with policy
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config)#mpls l2-circuit VPWS200 200 14.14.14.14
Configuring VPWS instance with name and VPWS ID
(config-pseudowire)# tunnel-select-policy PE1-P5-PE2
Configuring VPWS peers with policy
(config)#mpls vpls BGP-VPLS-PE1-PE2-300 300
Configuring VPLS instance with name and VPLS ID
(config-vpls)#signaling bgp
Enabling LDP signaling for the VPLS instance
(config-vpls-sig)#ve-id 500
Configure VE ID, which is mandatory for BGP VPLS,
otherwise, signaling does not take place. VE ID should be
 
unique per VPLS instance
 
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config-if)#interface xe17.100 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 100
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls vpls100
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#interface xe17.200 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 200
Configure encapsulation under a subinterface
(config-if)#access-if-vpws
Access VPWS under sub interface
(config-acc-if-vpls)#mpls-vpws VPWS100
Associating the VPWS Instance to the attachment circuit interface.
(config-if)#interface xe17.300 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 300
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls BGP-VPLS-PE1-PE2-300
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#interface xe17.500 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 500
Configure encapsulation under a subinterface
(config-if)#access-if-evpn
Access evpn under sub interface
(config-acc-if-vpls)#map vpn-id 2
Associating the evpn Instance to the attachment circuit interface.
(config-if)#interface xe17.600 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 600
Configure encapsulation under a subinterface
(config-if)#access-if-evpn
Access evpn under sub interface
(config-acc-if-vpls)#map vpn-id 600
Associating the evpn Instance to the attachment circuit interface.
(config-if)#interface xe17.700 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 700
Configure encapsulation under a subinterface
(config-if)#access-if-evpn
Access evpn under sub interface
(config-acc-if-vpls)#map vpn-id 700
Associating the evpn Instance to the attachment circuit interface.
(config-acc-if-vpls)#commit
Commit the configuration
(config-acc-if-vpls)#end
Return to privilege mode
P1
 
#configure terminal
Enter Configure mode.
(config)#segment-routing
Enter the segment routing mode.
(config-sr)#global block 10001 20000
Enable SRGB under segment routing
(config-sr)#local block 30000 36000
Enable SRLB under segment routing
(config)#interface lo
Enter interface mode
(config -if)#ip address 5.5.5.5/32 secondary
Configure IP address for the loopback interface
(config -if)#prefix-sid index 3000
Configure prefix-sid absolute value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 5.5.5.5
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface ce4
Enter interface mode
(config-if)#ip address 16.0.0.20/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)# ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#adjacency-sid index 1000
Configure adjacency-sid index value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po400
Enter interface mode
(config-if)#ip address 17.0.0.10/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)# ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)# adjacency-sid absolute 30700
Configure adjacency-sid absolute value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface ce22
Enter the Interface mode
(config-if)#channel-group 400 mode active
Moving interface to Dynamic LAG
(config-if)#interface ce23
Enter the Interface mode
(config-if)#channel-group 400 mode active
Moving interface to Dynamic LAG
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 5.5.5.5
Configure ospf Router-id
(config-router)#network 17.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 16.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 5.5.5.5/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#segment-routing mpls
Enable segment routing
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P2
 
#configure terminal
Enter Configure mode.
(config)#segment-routing
Enter the segment routing mode.
(config-sr)#global block 10001 20000
Enable SRGB under segment routing
(config-sr)#local block 41000 50000
Enable SRLB under segment routing
(config)#interface lo
Enter interface mode
(config -if)#ip address 44.44.44.44/32 secondary
Configure IP address for the loopback interface
(config -if)#prefix-sid index 4400
Configure prefix-sid index value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 44.44.44.44
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface sa300
Enter interface mode
(config-if)#ip address 12.0.0.10/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)# ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#adjacency-sid index 45000
Configure adjacency-sid index value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface po400
Enter interface mode
(config-if)#ip address 17.0.0.20/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)# ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#adjacency-sid index 2000
Configure adjacency-sid index value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface ce50
Enter the Interface mode
(config-if)#channel-group 400 mode active
Moving interface to Dynamic LAG
(config-if)#interface ce51
Enter the Interface mode
(config-if)#channel-group 400 mode active
Moving interface to Dynamic LAG
(config-if)#interface xe21
Enter the Interface mode
(config-if)#static-channel-group 300
Moving interface to static LAG
(config-if)#interface xe22
Enter the Interface mode
(config-if)#static-channel-group 300
Moving interface to static LAG
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 5.5.5.5
Configure ospf Router-id
(config-router)#network 17.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 16.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 5.5.5.5/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#segment-routing mpls
Enable segment routing
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P3
 
#configure terminal
Enter Configure mode.
(config)#segment-routing
Enter the segment routing mode.
(config-sr)# global block 10001 17000
Enable SRGB under segment routing
(config-sr)# local block 41000 50000
Enable SRLB under segment routing
(config)#interface lo
Enter interface mode
(config -if)#ip address 42.42.42.42 /32 secondary
Configure IP address for the loopback interface
(config -if)#prefix-sid index 4200
Configure prefix-sid index value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 42.42.42.42
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface po100
Enter interface mode
(config-if)#ip address 15.0.0.10/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)# ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#adjacency-sid index 4159
Configure adjacency-sid index value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface xe9
Enter interface mode
(config-if)#ip address 14.0.0.10/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)# ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)# adjacency-sid absolute 41599
Configure adjacency-sid absolute value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface xe20
Enter the Interface mode for eth2
(config-if)#channel-group 100 mode active
Moving interface to Dynamic LAG 10
(config-if)#interface xe21
Enter the Interface mode for eth3
(config-if)#channel-group 100 mode active
Moving interface to Dynamic LAG 10
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 42.42.42.42
Configure ospf Router-id
(config-router)#network 14.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 15.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 42.42.42.42 /32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#segment-routing mpls
Enable segment routing
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
P4
 
#configure terminal
Enter Configure mode.
(config)#segment-routing
Enter the segment routing mode.
(config-sr)#global block 10001 20000
Enable SRGB under segment routing
(config-sr)#local block 41000 50000
Enable SRLB under segment routing
(config)#interface lo
Enter interface mode
(config -if)#ip address 29.29.29.29/32 secondary
Configure IP address for the loopback interface
(config -if)#prefix-sid index 2900
Configure prefix-sid index value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 29.29.29.29
Configure Router-id
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#interface xe2.2000
Enter interface mode
(config-if)#ip address 13.0.0.20/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)# ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#adjacency-sid index 4900
Configure adjacency-sid index value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface xe9
Enter interface mode
(config-if)#ip address 14.0.0.20/24
Configure IP address on interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)# ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)# adjacency-sid index 5000
Configure adjacency-sid index value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 5.5.5.5
Configure ospf Router-id
(config-router)#network 13.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 14.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 29.29.29.29/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#segment-routing mpls
Enable segment routing
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
PE2
 
#configure terminal
Enter Configure mode.
(config)#segment-routing
Enter the segment routing mode.
(config-sr)#global block 10001 20000
Enable SRGB under segment routing
(config-sr)#local block 65000 74000
Enable SRLB under segment routing
(config)#interface lo
Enter interface mode
(config -if)#ip address 14.14.14.14/32 secondary
Configure IP address for the loopback interface
(config -if)#prefix-sid index 1400
Configure prefix-sid index value
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router mode for LDP
(config-router)#router-id 14.14.14.14
Configure Router-id
(config-router)#targeted-peer ipv4 43.43.43.43
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit from targeted-peer mode
(config-router)#transport-address ipv4 14.14.14.14
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
(config-router)#commit
Commit the configuration
(config-router)#exit
Exit from router mode
(config)#interface sa300
Enter interface mode
(config-if)#ip address 12.0.0.10/24
Configure IP address on interface
(config-if)#adjacency-sid index 5000
Configure adjacency-sid index value
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config)#interface x2.2000
Enter interface mode
(config-if)#ip address 13.0.0.10/24
Configure IP address on interface
(config-if)#adjacency-sid index 5001
Configure adjacency-sid index value
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#enable-ldp ipv4
Enabling LDP on the interface
(config-if)#commit
Commit the configuration
(config-if)#exit
Exit interface mode
(config-if)#interface xe3
Enter interface mode
(config-if)# static-channel-group 300
Moving interface to static LAG
(config-if)#exit
Exit interface mode
(config-if)#interface xe4
Enter interface mode
(config-if)#channel-group 100 mode active
Moving interface to static LAG
(config-if)#exit
Exit interface mode
(config)#router ospf 100
Configure the routing process and specify the Process ID, (100). The Process ID should be a unique positive integer to identifying the routing process.
(config-router)#ospf router-id 14.14.14.14
Configure ospf Router-id
(config-router)#network 12.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 13.0.0.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 14.14.14.14/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#segment-routing mpls
Enable segment routing
(config-router)#commit
Commit the transaction.
(config-router)#exit
Exit from router mode
(config)#tunnel-policy PE1-P1-PE2
Configure tunnel policy
(config-tnl-policy)# color 1
Map the color with the SR policy to be used..
(config)#tunnel-policy PE1-P3-PE2
Configure tunnel policy
(config-tnl-policy)# color 2
Map the color with the SR policy to be used..
(config)#segment-routing
Enter the segment routing mode.
(config-sr)# traffic-engineering
Segment Routing traffic engineering
(config-sr-te) policy PE1-P1-PE2
Policy configuration with name
(config-sr-pol) color 1 end-point 43.43.43.43
SR-policy color and end-point
(config-sr-pol-cp) candidate-path 1
SR policy candidate path
(config-sr-pol-cp)# dynamic-path ospf 1
Dynamic candidate path as OSPF
(config-sr-pol-cp)# constraints
Specify constraints
(config-sr-dyn-cp-cons)# 44.44.44.44 loose
Loopback IP of P2 as loose constraint
(config-sr-dyn-cp-cons)# 30.30.30.30 loose
Loopback IP of P1 as loose constraint
(config-sr-pol-cp)# exit-pol-cp
Exit from SR policy candidate path configuration mode
(config-sr-pol)#exit-sr-pol
Exit from SR policy configuration mode
(config-sr-te) policy PE1-P3-PE2
Policy configuration with name
(config-sr-pol) color 2 end-point 43.43.43.43
SR-policy color and end-point
(config-sr-pol-cp) candidate-path 1
SR policy candidate path
(config-sr-pol-cp)# dynamic-path ospf 1
Dynamic candidate path as OSPF
(config-sr-pol-cp)# constraints
Specify constraints
(config-sr-dyn-cp-cons)# 29.29.29.29 loose
Loopback IP of P2 as loose constraint
(config-sr-dyn-cp-cons)# 42.42.42.42 loose
Loopback IP of P1 as loose constraint
(config-sr-pol-cp)# exit-pol-cp
Exit from SR policy candidate path configuration mode
(config-sr-pol)#exit-sr-pol
Exit from SR policy configuration mode
(config-sr-te)#exit-te
Exit from traffic engineering configuration mode
(config)#commit
Commit candidate configuration to be running configuration
(config)#mac vrf vrf500
Enter VRF mode
(config-vrf)#rd 14.14.14.14:500
Configuring Route-Distinguisher value
(config-vrf)#route-target both 500:500
Configuring import and export value
(config)#mac vrf vpls600
Enter VRF mode
(config-vrf)#rd 14.14.14.14:600
Configuring Route-Distinguisher value
(config-vrf)#route-target both 600:600
Configuring import and export value
(config)#mac vrf vrfetree700
Enter VRF mode
(config-vrf)#rd 101:1
Configuring Route-Distinguisher value
(config-vrf)#route-target export 101:1
Configuring export value
(config-vrf)#route-target import 102:1
Configuring import value
(config-vrf)#evpn mpls vtep-ip-global 14.14.14.14
Configuring VTEP global IP to loopback IP
(config)#evpn mpls id 252 xconnect target-mpls-id 2
Configure the EVPN-ELINE identifier with source identifier
and target identifier
 
(config)#host-reachability-protocol evpn-bgp vrf500
Mapping vrf to EVPN-ELINE identifier
(config)#evpn mpls id 600
Configure the EVPN-ELAN identifier with identifier
(config)#host-reachability-protocol evpn-bgp vpls600
Mapping vrf to EVPN-ELAN identifier
(config)#evpn mpls id 700
Configure the EVPN-ETREE identifier with identifier
(config)#host-reachability-protocol evpn-bgp vrfetree700
Mapping vrf to EVPN-TREE identifier
(config)#router bgp 100
Configure router bgp in AS 100
(config-router)#bgp router-id 14.14.14.14
Configure BGP router ID
(config-router)#neighbor 43.43.43.43 remote-as 100
Configure neighbor in remote-as 100
(config-router)#neighbor 43.43.43.43 update-source lo
Configure neighbor with update-source loopback
(config-router)#address-family vpnv4 unicast
Enter VPNv4 Address family mode
(config-router-af)#neighbor 43.43.43.43 activate
mode Activate VPNv4 neighbor
(config-router-af)#exit-address-family
Exit from Address Family configuration
(config-router)#address-family l2vpn evpn
Enter evpn Address family mode
(config-router-af)#neighbor 43.43.43.43 activate
mode Activate evpn neighbor
(config-router-af)#exit-address-family
Exit from Address Family configuration
(config-router)#exit
Exit from router mode
(config)#mpls vpls100 100
Configuring VPLS instance with name and VPLS ID
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance
(config-vpls-sig)#vpls-type ethernet
Type ethernet configuration for VPLS
(config-vpls-sig)# vpls-peer 43.43.43.43 tunnel-select-policy PE1-P3-PE2
Configuring VPLS mesh peers with policy
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config)#mpls l2-circuit VPWS200 200 43.43.43.43
Configuring VPWS instance with name and VPWS ID
(config-pseudowire)# tunnel-select-policy PE1-P5-PE2
Configuring VPWS peers with policy
(config)#mpls vpls BGP-VPLS-PE1-PE2-300 300
Configuring VPLS instance with name and VPLS ID
(config-vpls)#signaling bgp
Enabling LDP signaling for the VPLS instance
(config-vpls-sig)#ve-id 500
Configure VE ID, which is mandatory for BGP VPLS,
otherwise, signaling does not take place. VE ID should be
 
unique per VPLS instance
 
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode
(config-vpls)#exit-vpls
Exit from VPLS mode
(config-if)#interface xe17.100 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 100
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls vpls100
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#interface xe17.200 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 200
Configure encapsulation under a subinterface
(config-if)#access-if-vpws
Access VPWS under sub interface
(config-acc-if-vpls)#mpls-vpws VPWS100
Associating the VPWS Instance to the attachment circuit interface.
(config-if)#interface xe17.300 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 300
Configure encapsulation under a subinterface
(config-if)#access-if-vpls
Access VPLS under sub interface
(config-acc-if-vpls)#mpls-vpls BGP-VPLS-PE1-PE2-300
Associating the VPLS Instance to the attachment circuit interface.
(config-if)#interface xe17.500 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 500
Configure encapsulation under a subinterface
(config-if)#access-if-evpn
Access evpn under sub interface
(config-acc-if-vpls)#map vpn-id 252
Associating the evpn Instance to the attachment circuit interface.
(config-if)#interface xe17.600 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 600
Configure encapsulation under a subinterface
(config-if)#access-if-evpn
Access evpn under sub interface
(config-acc-if-vpls)#map vpn-id 600
Associating the evpn Instance to the attachment circuit interface.
(config-if)#interface xe17.700 switchport
Enter sub interface mode
(config-if)#encapsulation dot1q 700
Configure encapsulation under a subinterface
(config-if)#access-if-evpn
Access evpn under sub interface
(config-acc-if-vpls)#map vpn-id 700
Associating the evpn Instance to the attachment circuit interface.
(config-acc-if-vpls)#commit
Commit the configuration
(config-acc-if-vpls)#end
Return to privilege mode
Validation
 
PE1
 
SRLB-PE1-7043#show ip ospf neighbor detail
Neighbor 42.42.42.42, interface address 15.0.0.10
In the area 0.0.0.0 via interface po100
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:34
Neighbor is detected for 00:20:31
Neighbor is FULL for 00:20:31
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 27521
Static adj sid: 100501
Bidirectional Forwarding Detection is enabled
 
Neighbor 5.5.5.5, interface address 16.0.0.20
In the area 0.0.0.0 via interface ce3
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:33
Neighbor is detected for 00:28:15
Neighbor is FULL for 00:28:15
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 27520
Static adj sid: 100500
Bidirectional Forwarding Detection is enabled
 
SRLB-PE1-7043#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
O> 5.5.5.5/32 10 19000 3 N/A ce3 16.0.0.20 Yes LSP_DEFAULT
B> evpn:600 2 640 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:600 3 17 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:2 1 16 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:900 7 19 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:700 5 18 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:1000 8 20 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:900 6 642 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:700 4 641 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
O> 14.14.14.14/32 13 17400 17400 N/A po100 15.0.0.10 Yes LSP_DEFAULT
O> 29.29.29.29/32 14 18900 18900 N/A po100 15.0.0.10 Yes LSP_DEFAULT
P> 5.5.5.5/32 11 26883 3 N/A ce3 16.0.0.20 Yes LSP_DEFAULT
B> vrf400 16 25664 Nolabel N/A vrf400 N/A Yes LSP_DEFAULT
O> 44.44.44.44/32 12 20400 14401 N/A ce3 16.0.0.20 Yes LSP_DEFAULT
O> 42.42.42.42/32 19 20200 3 N/A po100 15.0.0.10 Yes LSP_DEFAULT
P> 14.14.14.14/32 15 26882 14401 N/A ce3 16.0.0.20 Yes LSP_DEFAULT
P> 14.14.14.14/32 21 26881 18900 N/A po100 15.0.0.10 Yes LSP_DEFAULT
O> 16.0.0.20/32 18 100500 3 N/A ce3 16.0.0.20 Yes LSP_DEFAULT
O> 16.0.0.20/32 9 27520 3 N/A ce3 16.0.0.20 Yes LSP_DEFAULT
O> 15.0.0.10/32 20 27521 3 N/A po100 15.0.0.10 Yes LSP_DEFAULT
V> l2ckt:200 17 26240 Nolabel ce3 xe17.200 N/A Yes LSP_DEFAULT
O> 15.0.0.10/32 27 100501 3 N/A po100 15.0.0.10 Yes LSP_DEFAULT
SRLB-PE1-7043#show mpls label-space 0
 
Label range (min - max) : 16 - 1048575
 
module-static
Default range : 16 - 15999
 
module-srgb
Default range : 16000 - 23999
 
module-srlb
Default range : 24000 - 24999
Configured range : 100000 - 109999
 
module-rsvp
Configured range : N/A
Current dynamic range : N/A
 
 
module-ldp
Configured range : Not configured
Current dynamic range : 26240 - 26879
 
module-bgp
Configured range : Not configured
Current dynamic range : 25600 - 26239
 
module-isis-srlb
Configured range : N/A
Current dynamic range : 26880 - 27519
 
module-ospf-srlb
Configured range : N/A
Current dynamic range : 27520 - 28159
 
SRLB-PE1-7043#
P1
 
SRLB-P1-7030#show ip ospf neighbor detail
Neighbor 43.43.43.43, interface address 16.0.0.10
In the area 0.0.0.0 via interface ce4
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:30
Neighbor is detected for 00:29:51
Neighbor is FULL for 00:29:51
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 26240
Static adj sid: 31000
Bidirectional Forwarding Detection is enabled
 
Neighbor 44.44.44.44, interface address 17.0.0.20
In the area 0.0.0.0 via interface po400
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:37
Neighbor is detected for 00:28:35
Neighbor is FULL for 00:28:26
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 26241
Static adj sid: 30700
Bidirectional Forwarding Detection is enabled
 
SRLB-P1-7030#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
O> 16.0.0.10/32 1 26240 3 N/A ce4 16.0.0.10 Yes LSP_DEFAULT
O> 43.43.43.43/32 3 14301 3 N/A ce4 16.0.0.10 Yes LSP_DEFAULT
O> 29.29.29.29/32 9 12901 18900 N/A ce4 16.0.0.10 Yes LSP_DEFAULT
O> 14.14.14.14/32 8 11401 11401 N/A po400 17.0.0.20 Yes LSP_DEFAULT
O> 42.42.42.42/32 10 14201 20200 N/A ce4 16.0.0.10 Yes LSP_DEFAULT
O> 44.44.44.44/32 7 14401 3 N/A po400 17.0.0.20 Yes LSP_DEFAULT
P> 43.43.43.43/32 4 25600 3 N/A ce4 16.0.0.10 Yes LSP_DEFAULT
O> 17.0.0.20/32 6 30700 3 N/A po400 17.0.0.20 Yes LSP_DEFAULT
O> 17.0.0.20/32 5 26241 3 N/A po400 17.0.0.20 Yes LSP_DEFAULT
O> 16.0.0.10/32 2 31000 3 N/A ce4 16.0.0.10 Yes LSP_DEFAULT
SRLB-P1-7030#show mpls label-space 0
 
Label range (min - max) : 16 - 1048575
 
module-static
Default range : 16 - 15999
 
module-srgb
Default range : 16000 - 23999
Configured range : 10001 - 20000
 
module-srlb
Default range : 24000 - 24999
Configured range : 30000 - 36000
 
module-rsvp
Configured range : N/A
Current dynamic range : N/A
 
 
module-ldp
Configured range : N/A
Current dynamic range : N/A
 
 
module-bgp
Configured range : N/A
Current dynamic range : N/A
 
 
module-isis-srlb
Configured range : N/A
Current dynamic range : 25600 - 26239
 
module-ospf-srlb
Configured range : N/A
Current dynamic range : 26240 - 26879
 
SRLB-P1-7030#
P2
---
SRLB-P2-7044#show ip ospf neighbor detail
Neighbor 14.14.14.14, interface address 12.0.0.20
In the area 0.0.0.0 via interface sa300
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:38
Neighbor is detected for 00:28:44
Neighbor is FULL for 00:28:35
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 26240
Static adj sid: 45000
Bidirectional Forwarding Detection is enabled
 
Neighbor 5.5.5.5, interface address 17.0.0.10
In the area 0.0.0.0 via interface po400
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:31
Neighbor is detected for 00:28:41
Neighbor is FULL for 00:28:32
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 26241
Static adj sid: 43000
Bidirectional Forwarding Detection is enabled
 
SRLB-P2-7044#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
O> 5.5.5.5/32 8 13001 3 N/A po400 17.0.0.10 Yes LSP_DEFAULT
B> evpn:2000 3 641 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:900 2 640 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:900 1 16 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
O> 29.29.29.29/32 7 12901 12901 N/A sa300 12.0.0.20 Yes LSP_DEFAULT
O> 14.14.14.14/32 6 11401 3 N/A sa300 12.0.0.20 Yes LSP_DEFAULT
O> 12.0.0.20/32 4 26240 3 N/A sa300 12.0.0.20 Yes LSP_DEFAULT
O> 43.43.43.43/32 9 14301 14301 N/A po400 17.0.0.10 Yes LSP_DEFAULT
O> 42.42.42.42/32 11 14201 14201 N/A sa300 12.0.0.20 Yes LSP_DEFAULT
O> 17.0.0.10/32 12 43000 3 N/A po400 17.0.0.10 Yes LSP_DEFAULT
O> 17.0.0.10/32 5 26241 3 N/A po400 17.0.0.10 Yes LSP_DEFAULT
O> 12.0.0.20/32 10 45000 3 N/A sa300 12.0.0.20 Yes LSP_DEFAULT
SRLB-P2-7044#show mpls label-space 0
 
Label range (min - max) : 16 - 1048575
 
module-static
Default range : 16 - 15999
 
module-srgb
Default range : 16000 - 23999
Configured range : 10001 - 20000
 
module-srlb
Default range : 24000 - 24999
Configured range : 41000 - 50000
 
module-rsvp
Configured range : N/A
Current dynamic range : N/A
 
 
module-ldp
Configured range : N/A
Current dynamic range : N/A
 
 
module-bgp
Configured range : Not configured
Current dynamic range : 25600 - 26239
 
module-ospf-srlb
Configured range : N/A
Current dynamic range : 26240 - 26879
 
SRLB-P2-7044#!
P3
 
SRLB-P3-7042#show ip ospf neighbor detail
Neighbor 29.29.29.29, interface address 14.0.0.20
In the area 0.0.0.0 via interface xe9
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:39
Neighbor is detected for 00:22:20
Neighbor is FULL for 00:22:20
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 25601
Static adj sid: 41599
Bidirectional Forwarding Detection is enabled
 
Neighbor 43.43.43.43, interface address 15.0.0.20
In the area 0.0.0.0 via interface po100
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:37
Neighbor is detected for 00:22:27
Neighbor is FULL for 00:22:17
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 25600
Static adj sid: 45159
Bidirectional Forwarding Detection is enabled
 
SRLB-P3-7042#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
O> 5.5.5.5/32 2 19000 19000 N/A po100 15.0.0.20 Yes LSP_DEFAULT
O> 29.29.29.29/32 4 18900 3 N/A xe9 14.0.0.20 Yes LSP_DEFAULT
O> 14.14.14.14/32 3 17400 11401 N/A xe9 14.0.0.20 Yes LSP_DEFAULT
O> 14.0.0.20/32 1 25601 3 N/A xe9 14.0.0.20 Yes LSP_DEFAULT
O> 44.44.44.44/32 6 20400 14401 N/A xe9 14.0.0.20 Yes LSP_DEFAULT
O> 43.43.43.43/32 5 20300 3 N/A po100 15.0.0.20 Yes LSP_DEFAULT
O> 15.0.0.20/32 7 25600 3 N/A po100 15.0.0.20 Yes LSP_DEFAULT
O> 14.0.0.20/32 8 41599 3 N/A xe9 14.0.0.20 Yes LSP_DEFAULT
O> 15.0.0.20/32 9 45159 3 N/A po100 15.0.0.20 Yes LSP_DEFAULT
SRLB-P3-7042#show mpls label-space 0
 
Label range (min - max) : 16 - 1048575
 
module-static
Default range : 16 - 15999
 
module-srgb
Default range : 16000 - 23999
Configured range : 10001 - 20000
 
module-srlb
Default range : 24000 - 24999
Configured range : 41000 - 50000
 
module-rsvp
Configured range : N/A
Current dynamic range : N/A
 
 
module-ldp
Configured range : N/A
Current dynamic range : N/A
 
 
module-bgp
Configured range : N/A
Current dynamic range : N/A
 
 
module-ospf-srlb
Configured range : N/A
Current dynamic range : 25600 - 26239
 
SRLB-P3-7042#!
P4
 
SRLB-P4-7029#show ip ospf neighbor detail
Neighbor 14.14.14.14, interface address 13.0.0.10
In the area 0.0.0.0 via interface xe2.2000
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:35
Neighbor is detected for 00:33:03
Neighbor is FULL for 00:32:55
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 26240
Static adj sid: 45900
Bidirectional Forwarding Detection is enabled
 
Neighbor 42.42.42.42, interface address 14.0.0.10
In the area 0.0.0.0 via interface xe9
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:34
Neighbor is detected for 00:22:33
Neighbor is FULL for 00:22:23
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 26241
Static adj sid: 46000
Bidirectional Forwarding Detection is enabled
 
SRLB-P4-7029#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
O> 44.44.44.44/32 7 14401 14401 N/A xe2.2000 13.0.0.10 Yes LSP_DEFAULT
O> 14.14.14.14/32 5 11401 3 N/A xe2.2000 13.0.0.10 Yes LSP_DEFAULT
B> evpn:900 2 640 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:900 1 16 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:2000 3 641 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
O> 42.42.42.42/32 12 14201 3 N/A xe9 14.0.0.10 Yes LSP_DEFAULT
O> 5.5.5.5/32 8 13001 13001 N/A xe2.2000 13.0.0.10 Yes LSP_DEFAULT
O> 43.43.43.43/32 9 14301 20300 N/A xe9 14.0.0.10 Yes LSP_DEFAULT
O> 13.0.0.10/32 6 45900 3 N/A xe2.2000 13.0.0.10 Yes LSP_DEFAULT
O> 13.0.0.10/32 4 26240 3 N/A xe2.2000 13.0.0.10 Yes LSP_DEFAULT
O> 14.0.0.10/32 10 26241 3 N/A xe9 14.0.0.10 Yes LSP_DEFAULT
O> 14.0.0.10/32 11 46000 3 N/A xe9 14.0.0.10 Yes LSP_DEFAULT
SRLB-P4-7029#show mpls label-space 0
 
Label range (min - max) : 16 - 1048575
 
module-static
Default range : 16 - 15999
 
module-srgb
Default range : 16000 - 23999
Configured range : 10001 - 20000
 
module-srlb
Default range : 24000 - 24999
Configured range : 41000 - 50000
 
module-rsvp
Configured range : N/A
Current dynamic range : N/A
 
 
module-ldp
Configured range : N/A
Current dynamic range : N/A
 
 
module-bgp
Configured range : Not configured
Current dynamic range : 25600 - 26239
 
module-ospf-srlb
Configured range : N/A
Current dynamic range : 26240 - 26879
 
SRLB-P4-7029#!
PE2
 
SRLB-PE2-7014#show ip ospf neighbor detail
Neighbor 44.44.44.44, interface address 12.0.0.10
In the area 0.0.0.0 via interface sa300
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:39
Neighbor is detected for 00:28:45
Neighbor is FULL for 00:28:45
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 27521
Static adj sid: 70000
Bidirectional Forwarding Detection is enabled
 
Neighbor 29.29.29.29, interface address 13.0.0.20
In the area 0.0.0.0 via interface xe2.2000
Neighbor priority is 1, State is Full, 5 state changes
DR is 0.0.0.0, BDR is 0.0.0.0
Options is 0x42 (-|O|-|-|-|-|E|-)
Dead timer due in 00:00:37
Neighbor is detected for 00:32:58
Neighbor is FULL for 00:32:58
Database Summary List 0
Link State Request List 0
Link State Retransmission List 0
Crypt Sequence Number is 0
Thread Inactivity Timer on
Thread Database Description Retransmission off
Thread Link State Request Retransmission off
Thread Link State Update Retransmission off
System assigned adj sid: 27520
Static adj sid: 70001
Bidirectional Forwarding Detection is enabled
 
SRLB-PE2-7014#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
O> 29.29.29.29/32 7 12901 3 N/A xe2.2000 13.0.0.20 Yes LSP_DEFAULT
B> evpn:600 2 640 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:600 3 17 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:252 1 16 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:700 5 18 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B> evpn:700 4 641 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
O> 13.0.0.20/32 6 27520 3 N/A xe2.2000 13.0.0.20 Yes LSP_DEFAULT
O> 44.44.44.44/32 9 14401 3 N/A sa300 12.0.0.10 Yes LSP_DEFAULT
O> 42.42.42.42/32 17 14201 14201 N/A xe2.2000 13.0.0.20 Yes LSP_DEFAULT
O> 5.5.5.5/32 10 13001 13001 N/A sa300 12.0.0.10 Yes LSP_DEFAULT
O> 43.43.43.43/32 11 14301 14301 N/A sa300 12.0.0.10 Yes LSP_DEFAULT
P> 43.43.43.43/32 18 26881 14201 N/A xe2.2000 13.0.0.20 Yes LSP_DEFAULT
B> vrf400 12 25664 Nolabel N/A vrf400 N/A Yes LSP_DEFAULT
P> 43.43.43.43/32 13 26882 13001 N/A sa300 12.0.0.10 Yes LSP_DEFAULT
O> 12.0.0.10/32 15 70000 3 N/A sa300 12.0.0.10 Yes LSP_DEFAULT
O> 12.0.0.10/32 8 27521 3 N/A sa300 12.0.0.10 Yes LSP_DEFAULT
V> l2ckt:200 14 26240 Nolabel sa300 xe17.200 N/A Yes LSP_DEFAULT
O> 13.0.0.20/32 16 70001 3 N/A xe2.2000 13.0.0.20 Yes LSP_DEFAULT
SRLB-PE2-7014#show mpls label-space 0
 
Label range (min - max) : 16 - 1048575
 
module-static
Default range : 16 - 15999
 
module-srgb
Default range : 16000 - 23999
Configured range : 10001 - 20000
 
module-srlb
Default range : 24000 - 24999
Configured range : 65000 - 74000
 
module-rsvp
Configured range : N/A
Current dynamic range : N/A
 
 
module-ldp
Configured range : Not configured
Current dynamic range : 26240 - 26879
 
module-bgp
Configured range : Not configured
Current dynamic range : 25600 - 26239
 
module-isis-srlb
Configured range : N/A
Current dynamic range : 26880 - 27519
 
module-ospf-srlb
Configured range : N/A
Current dynamic range : 27520 - 28159