OcNOS-SP : Layer 3 Guide : Virtual Router Redundancy Protocol Configuration Guide : VRRP IPv6 Configuration
VRRP IPv6 Configuration
This chapter contains a Virtual Router Redundancy Protocol IPv6 (VRRPv6) configuration example.
VRRPv6 eliminates the risk of a single point of failure inherent in a static default routing environment. It specifies an election protocol that dynamically assigns responsibility for a virtual router to one of the VRRPv6 routers on a LAN. In this sample, OSPFv3 is enabled on Router 1 (R1), the master router, and the backup router. In R1, the connected routes are redistributed.
Note: IPv6 VRRP can be configured using link local address along with additional global ipv6 address as Virtual IP.
Topology
Topology
Configuration
Owner/Master Router
 
#configure terminal
Enter the Configure mode.
(config)#interface eth0
Enter the Interface mode for eth0.
(config-if)#ipv6 address
fe80::3037:3aff:fe3a:3a32/64
Configure the IPv6 address for interface eth0 to be in network 0.
(config-if)#exit
Exit the Interface mode.
(config)#interface eth1
Enter the Interface mode for eth1.
(config-if)#ipv6 address
fe80::3037:a0ff:fea4:3539/64
Configure the IPv6 address for interface eth1 to be in network 1.
(config-if)#exit
Exit the Interface mode.
(config)#router ipv6 vrrp 1 eth0
Create a VRRPv6 instance for interface eth0.
(config-router)#virtual-ipv6
fe80::3037:3aff:fe3a:3a32 owner
Configure R1 as the owner.
(config-router)#advertisement-interval 100
Configure the default value for the advertisement interval.
The configurable range is <5-4095> (value must be a multiple of 5).
(config-router)#preempt-mode true
Set true as the default value for the field.
(config-router)#enable
Enable the VRRPv6 session on the router.
(config-router)#exit
Exit Router mode.
Backup Router
 
#configure terminal
Enter the Configure mode.
(config)#interface eth0
Enter the Interface mode for eth0.
(config-if)#ipv6 address
fe80::3037:3aff:fe3a:3b45/64
Configure the IPv6 address for interface eth0 to be in network 0.
(config-if)#exit
Exit the Interface mode.
(config)#interface eth1
Enter the Interface mode for eth1.
(config-if)#ipv6 address
fe80::3037:a0ff:fea4:3a40/64
Configure the IPv6 address for interface eth1 to be in network 1.
(config-if)#exit
Exit the Interface mode.
(config)#router ipv6 vrrp 1 eth0
Create a VRRPv6 instance for interface eth0.
(config-router)#virtual-ipv6 fe80::3037:3aff:fe3a:3a32
Configure Router 2 (R2) as the backup.
(config-router)#advertisement-interval 100
Configure the default value for the advertisement interval.
The configurable range is <5-4095> (value must be a multiple of 5).
(config-router)#priority 100
Set the default value for the backup router.
(config-router)#preempt-mode true
Set true as the default value for the field.
(config-router)#enable
Enable the VRRPv6 session on the router.
(config-router)#exit
Exit Router mode.
Host A
 
#configure terminal
Enter the Configure mode.
(config)#interface eth0
Enter the Interface mode for eth0.
(config-if)#ipv6 address
fe80::3037:3aff:fe3a:3a11/64
Configure the IPv6 address for interface eth0 to be in network 0.
(config-if)#exit
Exit the Interface mode.
(config)#ipv6 route 5ffe:14:14:14::/64
fe80::3037:3aff:fe3a:3a32
Configure a static route to reach interface eth2 of R1 through the virtual IPv6 address.
Router 1
 
#configure terminal
Enter the Configure mode.
(config)#interface eth1
Enter the Interface mode for eth1.
(config-if)#ipv6 address fe80::3037:a0ff:fea4:1111/64
Configure the IPv6 address for interface eth1 to be in network 1.
(config-if)#exit
Exit the Interface mode.
(config)#interface eth2
Enter the Interface mode for eth2.
(config-if)#ipv6 address
fe80::3437:30ff:fe35:a6ac/64
Configure the IPv6 address of interface eth2.
Validation
Master Router
R1#sh vrrp
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled
 
Address family IPv6
VRRP Id: 1 on interface: eth0
State: AdminUp - Master
Virtual IP address: fe80::3037:3aff:fe3a:3a32 (Owner)
Priority is 255
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Skew time: 0 centi sec
Accept mode: FALSE
Preempt mode: TRUE
Multicast membership on IPv6 interface eth0: JOINED
Backup Router
R1#sh vrrp
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled
 
Address family IPv6
VRRP Id: 1 on interface: eth0
State: AdminUp - Backup
Virtual IP address: fe80::3037:3aff:fe3a:3a32 (Not-Owner)
Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Skew time: 0 centi sec
Accept mode: FALSE
Preempt mode: TRUE
Multicast membership on IPv6 interface eth0: JOINED
Ping Output at Host A
[[root@HstA root]#ping ipv6 fe80::3437:30ff:fe35:a6ac
PING fe80::3437:30ff:fe35:a6ac(fe80::3437:30ff:fe35:a6ac) 56 data bytes
64 bytes from fe80::3437:30ff:fe35:a6ac: icmp_seq=1 ttl=63 time=0.398 ms
64 bytes from fe80::3437:30ff:fe35:a6ac: icmp_seq=2 ttl=63 time=0.230 ms
64 bytes from fe80::3437:30ff:fe35:a6ac: icmp_seq=3 ttl=63 time=0.234 ms
64 bytes from fe80::3437:30ff:fe35:a6ac: icmp_seq=4 ttl=63 time=0.230 ms
Disabling the Master
 
#configure terminal
Enter the Configure mode.
(config)#interface eth0
Enter the Interface mode for eth0.
(config-router)#shutdown
Shut down the interface
Validation
R1#sh vrrp
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled
 
Address family IPv6
VRRP Id: 1 on interface: eth0
State: AdminUp - Init (interface is not running)
Virtual IP address: fe80::3037:3aff:fe3a:3a32 (Owner)
Priority is 255
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Skew time: 0 centi sec
Accept mode: FALSE
Preempt mode: TRUE
Multicast membership on IPv6 interface eth0: LEFT
Backup Router
R1#sh vrrp
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled
 
Address family IPv6
VRRP Id: 1 on interface: eth0
State: AdminUp - Backup
Virtual IP address: fe80::3037:3aff:fe3a:3a32 (Not-Owner)
Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Skew time: 0 centi sec
Accept mode: FALSE
Preempt mode: TRUE
Multicast membership on IPv6 interface eth0: LEFT
Ping Output at Host A
[root@HstA root]#ping ipv6 fe80::3437:30ff:fe35:a6ac
PING fe80::3437:30ff:fe35:a6ac(fe80::3437:30ff:fe35:a6ac) 56 data bytes
64 bytes from fe80::3437:30ff:fe35:a6ac: icmp_seq=1 ttl=63 time=0.423 ms
64 bytes from fe80::3437:30ff:fe35:a6ac: icmp_seq=2 ttl=63 time=0.291 ms
 
GLOBAL IPV6 SUPPORT FOR VRRP
Master Router
 
#configure terminal
Enter the Configure mode.
(config)#interface eth0
Enter the Interface mode for eth0.
(config-if)#ipv6 address 2001::1/64
Configure global IPv6 address for interface eth0 to be in network 0.
(config-if)#commit
Commit the configurations.
(config-if)#exit
Exit the Interface mode.
(config)#interface eth1
Enter the Interface mode for eth1.
(config-if)#ipv6 address 3000::1/64
Configure global IPv6 address for interface eth1 to be in network 1.
(config-if)#commit
Commit the configurations.
(config-if)#exit
Exit the Interface mode.
(config)#router ipv6 vrrp 1 eth0
Create a VRRPv6 instance for interface eth0.
(config-router)#virtual-ipv6 fe80::1
Configure link local address as primary virtual-ip.
(config-router)#virtual-ipv6 2001::3
Configure global ipv6 address as additional virtual-ip.
(config-router)#priority 250
Set priority for master node as 250.
(config-router)#enable
Enable the VRRPv6 session on the router.
(config-router)#commit
Commit the configurations.
(config-router)#exit
Exit Router mode.
(config)#ipv6 route 4000::/64 3000::2
Configure static route to reach eth2 of router1.
(config-router)#commit
Commit the configurations.
(config-router)#exit
Exit Router mode.
 
 
Backup Router
 
#configure terminal
Enter the Configure mode.
(config)#interface eth0
Enter the Interface mode for eth0.
(config-if)#ipv6 address 2001::2/64
Configure global IPv6 address for interface eth0 to be in network 0.
(config-if)#commit
Commit the configurations.
(config-if)#exit
Exit the Interface mode.
(config)#interface eth1
Enter the Interface mode for eth1.
(config-if)#ipv6 address 3001::1/64
Configure global IPv6 address for interface eth1 to be in network 1.
(config-if)#commit
Commit the configurations.
(config-if)#exit
Exit the Interface mode.
(config)#router ipv6 vrrp 1 eth0
Create a VRRPv6 instance for interface eth0.
(config-router)#virtual-ipv6 fe80::1
Configure link local address as primary virtual-ip.
(config-router)#virtual-ipv6 2001::3
Configure global ipv6 address as additional virtual-ip.
(config-router)#priority 100
Set the default value for the backup router.
(config-router)#enable
Enable the VRRPv6 session on the router.
(config-router)#commit
Commit the configurations.
(config-router)#exit
Exit Router mode.
(config)#ipv6 route 4000::/64 3001::2
Configure static route to reach eth2 of router1.
(config-router)#exit
Exit Router mode.
Host A
 
#configure terminal
Enter the Configure mode.
(config)#bridge 1 protocol rstp vlan-bridge
Create a RSTP VLAN aware bridge with bridge-id.
(config)#vlan 100 bridge 1
Create VLAN 100 and map it to bridge 1
(config)#interface eth0
Enter the Interface mode for eth0.
(config-if)#switchport
Configure switch port.
(config-if)#bridge-group 1 spanning-tree disable
Configure bridge group to l2 interface with spanning-tree Disable
(config-if)#switchport mode trunk
Configure switch port mode as trunk
(config-if)#switchport trunk allowed vlan add 100
Allow vlan 100 on the interface
(config-if)#commit
Commit the configurations.
(config-if)#exit
Exit the Interface mode
(config)#interface eth1
Enter the Interface mode for eth1.
(config-if)#switchport
Configure switch port.
(config-if)#bridge-group 1 spanning-tree disable
Configure bridge group to l2 interface with spanning-tree Disable
(config-if)#switchport mode trunk
Configure switch port mode as trunk
(config-if)#switchport trunk allowed vlan add 100
Allow vlan 100 on the interface
(config-if)#commit
Commit the configurations.
(config-if)#exit
Exit the Interface mode.
Router 1
 
#configure terminal
Enter the Configure mode.
(config)#interface eth0
Enter the Interface mode for eth0.
(config-if)#ipv6 address 3000::2/64
Configure global IPv6 address for interface eth1 to be in network 1.
(config-if)#commit
Commit the configurations.
(config-if)#exit
Exit the Interface mode.
(config)#interface eth1
Enter the Interface mode for eth1.
(config-if)#ipv6 address 3001::2/64
Configure global IPv6 address for interface eth1 to be in network 1.
(config-if)#commit
Commit the configurations.
(config-if)#exit
Exit the Interface mode.
(config)#interface eth2
Enter the Interface mode for eth2.
(config-if)#ipv6 address 4000::1/64
Configure global ipv6 address for interface eth2.
(config-if)#commit
Commit the configurations.
(config-if)#exit
Exit the Interface mode.
(config)#ipv6 route 2001::/64 3001::1
Configure static route to reach eth2 of master.
(config)#ipv6 route 2001::/64 3001::1
Configure static route to reach eth2 of backup.
(config-if)#commit
Commit the configurations.
(config-if)# exit
Exit the Interface mode.
 
 
Validation
Master Router
OcNOS#sh vrrp
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled
 
Address family IPv6
VRRP Id: 1 on interface: eth0
State: AdminUp - Master
Virtual IP address: fe80::1 (Not-owner)
Virtual IP address: 2001::3
Virtual MAC address is 0000.5e00.0201
Operational primary IP address: fe80::923c:b3ff:fe82:8d88
Operational master IP address: fe80::923c:b3ff:fe82:8d88
Priority is 250
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 1 minutes 0 seconds (6000 centi sec)
Master uptime: 0 hours 0 minutes 57 seconds (5700 centi sec)
Accept mode: TRUE
Preempt mode: TRUE
Multicast membership on IPv6 interface eth0: JOINED
V2-Compatible: FALSE
Backup Router
OcNOS#sh vrrp
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled
 
Address family IPv6
VRRP Id: 1 on interface: eth0
State: AdminUp - Backup
Virtual IP address: fe80::1 (Not-owner)
Virtual IP address: 2001::3
Virtual MAC address is 0000.5e00.0201
Operational primary IP address: fe80::1644:8fff:fe8e:32e7
Operational master IP address: fe80::923c:b3ff:fe82:8d88
Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 18 minutes 57 seconds (113700 centi sec)
Skew time: 60 centi sec
Master Down Interval: 360 centi sec
Accept mode: TRUE
Preempt mode: TRUE
Multicast membership on IPv6 interface eth0: JOINED
V2-Compatible: FALSE
Ping From master to backup
[[root@HstA root]#ping ipv6 2001::2
PING 2001::2(2001::2) 56 data bytes
64 bytes from fe80::3437:30ff:fe35:a6ac: icmp_seq=1 ttl=63 time=0.398 ms
64 bytes from fe80::3437:30ff:fe35:a6ac: icmp_seq=2 ttl=63 time=0.230 ms
64 bytes from fe80::3437:30ff:fe35:a6ac: icmp_seq=3 ttl=63 time=0.234 ms
64 bytes from fe80::3437:30ff:fe35:a6ac: icmp_seq=4 ttl=63 time=0.230 ms