OcNOS-SP : Virtual Extensible LAN Guide : Virtual Extensible LAN Configuration Guide : VxLAN Trunk Access Port Configuration
VxLAN Trunk Access Port Configuration
In VxLAN, most of the use cases demand to carry the complete traffic received on the access interface to another VTEP access-port. Hence this support of accepting all tagged and untagged traffic received on the mapped physical port.
Topology
VxLAN Trunk Access Port Configuration topology
Base Configuration - L2 VxLAN
VTEP1
 
Hardware profile and generic configuration:
 
#configure terminal
Enter Configure mode.
(config)#hardware-profile filter vxlan enable
Enable hardware-profile filter for VxLAN.
(config)#hardware-profile filter egress-ipv4 enable
Enable hardware-profile filter for egress IPv4.
(config)#hardware-profile statistics ac-lif enable
Enable ac-lif for vxlan access-if port counters
(config)#qos enable
Enable qos
(config)#commit
Committing the configurations
Interface and loopback configuration:
 
(config)#interface xe7
Enter Interface mode for xe7
(config-if)#switchport
Make it L2 interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe8
Enter Interface mode for xe8
(config-if)#ip add 10.10.10.1/24
Configuring the ip address in the network side
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 1.1.1.1/32 secondary
Configure loopback ip address as 1.1.1.1 for VTEP1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Committing the interface configurations
OSPF configuration:
 
(config)#router ospf 1
Enter into router OSPF mode
(config-router)#ospf router-id 1.1.1.1
Configure router-id as 1.1.1.1 (lo ip address)
(config-router)#network 1.1.1.1/32 area 0.0.0.0
Add 1.1.1.1 (lo ip address) network into area 0
(config-router)#network 10.10.10.0/24 area 0.0.0.0
Add 10.10.10.0(Spine) network into area 0
(config-router)#bfd all-interfaces
Enabling bfd on all ospf interface for fast convergence
(config-router)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Committing the ospf configurations
BGP configuration:
 
(config)#router bgp 1
Enter into Router BGP mode
(config-router)#bgp router-id 1.1.1.1
Configure router-id as 1.1.1.1 (lo ip address)
(config-router)#neighbor 2.2.2.2 remote-as 1
Specify a VTEP2 loopback ip address and remote-as defined
(config-router)#neighbor 2.2.2.2 update-source lo
Configure update as loopback for VTEP2
(config-router)#neighbor 2.2.2.2 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP2
(config-router)#address-family l2vpn evpn
Enter into l2vpn EVPN address family mode
(config-router-af)#neighbor 2.2.2.2 activate
Activate 2.2.2.2(VTEP2) into l2vpn evpn address family mode
(config-router-af)#exit-address-family
Exit from l2vpn address family mode
(config-router)#exit
Exit from Router BGP mode and enter into config mode
(config)#commit
Committing the bgp configurations
L2 MAC VRF Configuration:
 
(config)#mac vrf L2VRF1
Create mac routing/forwarding instance with L2VRF1 name and enter into vrf mode
(config-vrf)#rd 1.1.1.1:1
Assign RD value
(config-vrf)#route-target both 1:1
Assign route-target value for same for import and export. Should be same on all node for L2VRF1
(config-vrf)#exit
Exit from vrf mode
(config)#commit
Committing the vrf configurations
L2 VxLAN configuration:
 
(config)#nvo vxlan enable
Enable VxLAN
(config)#nvo vxlan vtep-ip-global 1.1.1.1
Configure Source vtep-ip-global configuration - Use loopback ip address
(config)#nvo vxlan id 100 ingress-replication
Configure VxLAN Network identifier without inner-vid- disabled configured for vxlan trunk access port and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp L2VRF1
Assign vrf for evpn-bgp to carry EVPN route
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#commit
Committing the vxlan configurations
VTEP2
Hardware profile and generic configuration:
 
#configure terminal
Enter Configure mode.
(config)#hardware-profile filter vxlan enable
Enable hardware-profile filter for VxLAN.
(config)#hardware-profile filter egress-ipv4 enable
Enable hardware-profile filter for egress IPv4.
(config)#hardware-profile statistics ac-lif enable
Enable ac-lif for vxlan access-if port counters
(config)#qos enable
Enable qos
(config)#commit
Committing the configurations
Interface and loopback configuration:
 
(config)#interface xe23
Enter Interface mode for xe23
(config-if)#switchport
Make it L2 interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe14
Enter Interface mode for xe14
(config-if)#ip add 20.20.20.1/24
Configuring the ip address in the network side
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 2.2.2.2/32 secondary
Configure loopback ip address as 2.2.2.2 for VTEP2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Committing the interface configurations
OSPF configuration:
 
(config)#router ospf 1
Enter into router OSPF mode
(config-router)#ospf router-id 2.2.2.2
Configure router-id as 2.2.2.2 (lo ip address)
(config-router)#network 2.2.2.2/32 area 0.0.0.0
Add 2.2.2.2 (lo ip address) network into area 0
(config-router)#network 20.20.20.0/24 area 0.0.0.0
Add 20.20.20.0(Spine) network into area 0
(config-router)#bfd all-interfaces
Enabling bfd on all ospf interface for fast convergence
(config-router)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Committing the ospf configurations
BGP configuration:
 
(config)#router bgp 1
Enter into Router BGP mode
(config-router)#bgp router-id 2.2.2.2
Configure router-id as 2.2.2.2 (lo ip address)
(config-router)#neighbor 1.1.1.1 remote-as 1
Specify a VTEP1 loopback ip address and remote-as defined
(config-router)#neighbor 1.1.1.1 update-source lo
Configure update as loopback for VTEP2
(config-router)#neighbor 1.1.1.1 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP1
(config-router)#address-family l2vpn evpn
Enter into l2vpn EVPN address family mode
(config-router-af)#neighbor 1.1.1.1 activate
Activate 1.1.1.1(VTEP1) into l2vpn evpn address family mode
(config-router-af)#exit-address-family
Exit from l2vpn address family mode
(config-router)#exit
Exit from Router BGP mode and enter into config mode
(config)#commit
Committing the bgp configurations
L2 MAC VRF Configuration:
 
(config)#mac vrf L2VRF1
Create mac routing/forwarding instance with L2VRF1 name and enter into vrf mode
(config-vrf)#rd 2.2.2.2:1
Assign RD value
(config-vrf)#route-target both 1:1
Assign route-target value for same for import and export. Should be same on all node for L2VRF1
(config-vrf)#exit
Exit from vrf mode
(config)#commit
Committing the vrf configurations
L2 VxLAN configuration:
 
(config)#nvo vxlan enable
Enable VxLAN
(config)#nvo vxlan vtep-ip-global 2.2.2.2
Configure Source vtep-ip-global configuration - Use loopback ip address
(config)#nvo vxlan id 100 ingress-replication
Configure VxLAN Network identifier without inner-vid- disabled configured for vxlan trunk access port and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp L2VRF1
Assign vrf for evpn-bgp to carry EVPN route
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#commit
Committing the vxlan configurations
SPINE
Spine node where all VTEPs are connected.
Generic configuration:
 
#configure terminal
Enter Configure mode.
(config)#qos enable
Enabling qos
(config)#commit
Committing the configuration
Interface configuration:
 
(config)#interface xe8
Enter Interface mode for xe8
(config-if)#ip address 10.10.10.2/24
Configure ip address as 10.10.10.2 on network side of VTEP1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config) interface xe14
Enter into ce5/1 interface mode
(config-if)#ip address 20.20.20.2/24
Configure ip address as 20.20.20.2 on network side of VTEP2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config) commit
Committing the configuration
OSPF configuration:
 
(config)#router ospf 1
Enter into router OSPF mode
(config-router)#ospf router-id 3.3.3.3
Configure router-id as 3.3.3.3
(config-router)#network 10.10.10.0/24 area 0.0.0.0
Add 10.10.10.0 (VTEP1) network into area 0
(config-router)#network 20.20.20.0/24 area 0.0.0.0
Add 20.20.20.0 (VTEP2) network into area 0
(config-router)#bfd all-interfaces
Enabling bfd on all ospf interface for fast convergence
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)commit
Committing the ospf configuration
VxLAN Trunk Access port as default
In VxLAN, most of the use cases demand to carry the complete traffic received on the access interface to another VTEP access-port. Hence this support of accepting all tagged and untagged traffic received on the mapped physical port.
VTEP1
 
(config)#nvo vxlan access-if port xe7 default
Configuring the vxlan access port as default to receive untagged, single and double tagged traffic
(config-nvo-acc-if)#map vnid 100
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#arp-cache disable
Disable arp-cache - mandatory
(config-nvo-acc-if)#nd-cache disable
Disable nd-cache - mandatory
(config-nvo-acc-if)# mac 0000.1111.0001
Configure static mac-only
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#commit
Committing the vxlan configuration
VTEP2
 
(config)#nvo vxlan access-if port xe23 default
Configuring the vxlan access port as default to receive untagged, single and double tagged traffic
(config-nvo-acc-if)#map vnid 100
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#arp-cache disable
Disable arp-cache - mandatory
(config-nvo-acc-if)#nd-cache disable
Disable nd-cache - mandatory
(config-nvo-acc-if)# mac 0000.2222.0001
Configure static mac-only
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#commit
Committing the vxlan configuration
Validation
VTEP1
 
VTEP1#sh run nvo vxlan
!
nvo vxlan enable
!
nvo vxlan vtep-ip-global 1.1.1.1
!
nvo vxlan id 100 ingress-replication
vxlan host-reachability-protocol evpn-bgp L2VRF1
!
nvo vxlan access-if port xe7 default
map vnid 100
arp-cache disable
nd-cache disable
mac 0000.1111.0001
!
!
VTEP1#sh nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
============================================================================
1.1.1.1 2.2.2.2 Installed 00:02:49 00:02:49
 
Total number of entries are 1
VTEP1#sh nvo vxlan mac-table
==========================================================================================================================================
VxLAN MAC Entries
==========================================================================================================================================
VNID Interface VlanId Vlan-RangeId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
__________________________________________________________________________________________________________________________________________
 
100 xe7 ---- ---- ---- 0000.1111.0001 1.1.1.1 Static Local ------- -------
100 ---- ---- ---- 0000.2222.0001 2.2.2.2 Static Remote ------- -------
100 xe7 ---- ---- ---- b0da.1d10.6496 1.1.1.1 Dynamic Local ------- -------
 
Total number of entries are : 3
 
VTEP1#sh nvo vxlan mac-table hardware
==========================================================================================================================================
VxLAN MAC Entries
==========================================================================================================================================
VNID Interface VlanId Vlan-RangeId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status Time-out AccessPortDesc
_________________________________________________________________________________________________________________________________________
 
100 xe7 ---- ---- 0000.1111.0001 1.1.1.1 Static Local ------- --- -------
100 --- ---- ---- 0000.2222.0001 2.2.2.2 Remote ------- --- -------
100 xe7 ---- ---- b0da.1d10.6496 1.1.1.1 Dynamic Local ------- 300 -------
 
Total number of entries are 3
VTEP1#show nvo vxlan
VxLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 1.1.1.1 2.2.2.2
100 ---- -- AC xe7 --- Single Homed Port --- ---- ---- ---- ----
 
Total number of entries are 2
VTEP1#sh nvo vxlan route-count
VxLAN Active route count information
====================================
Max route count : 32768
Active route count: 3
 
---------------------------------------------
VNID Total MACONLY MACIPv4 MACIPv6
---------------------------------------------
100 3 3 0 0
 
Total number of entries are 1
VTEP1#sh nvo vxlan access-if-config
nvo vxlan access-if port xe7 default
map vnid 100
arp-cache disable
nd-cache disable
mac 0000.1111.0001
!
VTEP1#sh nvo vxlan access-if brief
 
Inner Admin Link
Interface Vlan vlan Ifindex Vnid status status
-----------------------------------------------------------
xe7 --- --- 500000 100 up up
 
Total number of entries are 1
VTEP1#sh bgp l2vpn evpn summary
BGP router identifier 1.1.1.1, local AS number 1
BGP table version is 2
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
2.2.2.2 4 1 15 17 2 0 0 00:04:52 2 0 1 1 0 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
VTEP1#sh bgp l2vpn evpn
BGP table version is 2, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[1.1.1.1:1] VRF[L2VRF1]:
*> [2]:[0]:[100]:[48,0000:1111:0001]:[0]:[100]
1.1.1.1 0 100 32768 i ---------- VxLAN
* i [2]:[0]:[100]:[48,0000:2222:0001]:[0]:[100]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*> [2]:[0]:[100]:[48,b0da:1d10:6496]:[0]:[100]
1.1.1.1 0 100 32768 i ---------- VxLAN
*> [3]:[100]:[32,1.1.1.1]
1.1.1.1 0 100 32768 i ---------- VxLAN
* i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
RD[2.2.2.2:1]
*>i [2]:[0]:[100]:[48,0000:2222:0001]:[0]:[100]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*>i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
Total number of prefixes 7
VTEP1#sh nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
Total number of entries are 0
VTEP1#sh nvo vxlan nd-cache
VxLAN ND-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________________________________
Total number of entries are 0
VTEP1#
VTEP2
 
VTEP2#sh run nvo vxlan
!
nvo vxlan enable
!
nvo vxlan vtep-ip-global 2.2.2.2
!
nvo vxlan id 100 ingress-replication
vxlan host-reachability-protocol evpn-bgp L2VRF1
!
nvo vxlan access-if port xe23 default
map vnid 100
arp-cache disable
nd-cache disable
mac 0000.2222.0001
!
!
VTEP2#sh nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
============================================================================
2.2.2.2 1.1.1.1 Installed 00:05:47 00:05:47
 
Total number of entries are 1
VTEP2#sh nvo vxlan
VxLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 1.1.1.1
100 ---- -- AC xe23 --- Single Homed Port --- ---- ---- ---- ----
 
Total number of entries are 2
VTEP2#sh nvo vxlan mac-table
==========================================================================================================================================
VxLAN MAC Entries
==========================================================================================================================================
VNID Interface VlanId Vlan-RangeId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
__________________________________________________________________________________________________________________________________________
 
100 ---- ---- ---- 0000.1111.0001 1.1.1.1 Static Remote ------- -------
100 xe23 ---- ---- ---- 0000.2222.0001 2.2.2.2 Static Local ------- -------
100 ---- ---- ---- b0da.1d10.6496 1.1.1.1 Dynamic Remote ------- -------
 
Total number of entries are : 3
 
VTEP2#sh nvo vxlan mac-table hardware
==========================================================================================================================================
VxLAN MAC Entries
==========================================================================================================================================
VNID Interface VlanId Vlan-RangeId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status Time-out AccessPortDesc
_________________________________________________________________________________________________________________________________________
 
100 --- ---- ---- 0000.1111.0001 1.1.1.1 Remote ------- --- -------
100 xe23 ---- ---- 0000.2222.0001 2.2.2.2 Static Local ------- --- -------
100 --- ---- ---- b0da.1d10.6496 1.1.1.1 Remote ------- --- -------
 
Total number of entries are 3
VTEP2#sh nvo vxlan route-count
VxLAN Active route count information
====================================
Max route count : 32768
Active route count: 3
 
---------------------------------------------
VNID Total MACONLY MACIPv4 MACIPv6
---------------------------------------------
100 3 3 0 0
 
Total number of entries are 1
VTEP2#sh nvo vxlan access-if br
 
Inner Admin Link
Interface Vlan vlan Ifindex Vnid status status
-----------------------------------------------------------
xe23 --- --- 500000 100 up up
 
Total number of entries are 1
VTEP2#sh nvo vxlan access-if-config
nvo vxlan access-if port xe23 default
map vnid 100
arp-cache disable
nd-cache disable
mac 0000.2222.0001
!
VTEP2#sh nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
Total number of entries are 0
VTEP2#sh nvo vxlan nd-cache
VxLAN ND-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________________________________
Total number of entries are 0
 
VTEP2#
VTEP2#sh bgp l2vpn evpn summary
BGP router identifier 2.2.2.2, local AS number 1
BGP table version is 2
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
1.1.1.1 4 1 27 27 1 0 0 00:09:54 3 0 2 1 0 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
VTEP2#sh bgp l2vpn evpn
BGP table version is 2, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[1.1.1.1:1]
*>i [2]:[0]:[100]:[48,0000:1111:0001]:[0]:[100]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*>i [2]:[0]:[100]:[48,b0da:1d10:6496]:[0]:[100]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*>i [3]:[100]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
 
RD[2.2.2.2:1] VRF[L2VRF1]:
* i [2]:[0]:[100]:[48,0000:1111:0001]:[0]:[100]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*> [2]:[0]:[100]:[48,0000:2222:0001]:[0]:[100]
2.2.2.2 0 100 32768 i ---------- VxLAN
* i [2]:[0]:[100]:[48,b0da:1d10:6496]:[0]:[100]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [3]:[100]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*> [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- VxLAN
 
Total number of prefixes 8
VTEP2#
VxLAN Trunk access port with vlan range
When an access port with a specific vlan range configured, all the traffic in that specific range are accepted and forwarded.
VTEP1
 
(config)#nvo vxlan access-if port-vlan xe7 2-100
Configuring the vxlan access port with vlan range 2-100 where traffic in the vlan range 2-100 are accepted
(config-nvo-acc-if)#map vnid 100
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#arp-cache disable
Disable arp-cache - mandatory
(config-nvo-acc-if)#nd-cache disable
Disable nd-cache - mandatory
(config-nvo-acc-if)# mac 0000.1111.0001
Configure static mac-only
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#commit
Committing the vxlan configuration
VTEP2
 
(config)#nvo vxlan access-if port-vlan xe23 2-100
Configuring the vxlan access port with vlan range 2-100 where traffic in the vlan range 2-100 are accepted
(config-nvo-acc-if)#map vnid 100
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#arp-cache disable
Disable arp-cache - mandatory
(config-nvo-acc-if)#nd-cache disable
Disable nd-cache - mandatory
(config-nvo-acc-if)# mac 0000.2222.0001
Configure static mac-only
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#commit
Committing the vxlan configuration
Validations
VTEP1
VTEP1#sh run nvo vx
!
nvo vxlan enable
!
nvo vxlan vtep-ip-global 1.1.1.1
!
nvo vxlan id 100 ingress-replication
vxlan host-reachability-protocol evpn-bgp L2VRF1
!
nvo vxlan access-if port-vlan xe7 2-100
map vnid 100
arp-cache disable
nd-cache disable
mac 0000.1111.0001
!
!
VTEP1#
VTEP1#sh nvo vxlan tunnel summary
 
Total number of entries: 1 [Installed: 1, Resolved: 0, Unresolved: 0]
 
Total number of entries are 1
VTEP1#sh nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
============================================================================
1.1.1.1 2.2.2.2 Installed 00:20:10 00:20:10
 
Total number of entries are 1
VTEP1#sh nvo vx
VxLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 1.1.1.1 2.2.2.2
100 ---- -- AC xe7 --- Single Homed Port --- 2 ---- ---- ----
 
Total number of entries are 2
VTEP1#sh nvo vxlan mac-table
==========================================================================================================================================
VxLAN MAC Entries
==========================================================================================================================================
VNID Interface VlanId Vlan-RangeId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
__________________________________________________________________________________________________________________________________________
 
100 xe7 ----- 2-100 ---- 0000.1111.0001 1.1.1.1 Static Local ------- -------
100 ---- ---- ---- 0000.2222.0001 2.2.2.2 Static Remote ------- -------
100 xe7 ----- 2-100 ---- b0da.1d10.6496 1.1.1.1 Dynamic Local ------- -------
 
Total number of entries are : 3
 
VTEP1#sh nvo vxlan mac-table hardware
==========================================================================================================================================
VxLAN MAC Entries
==========================================================================================================================================
VNID Interface VlanId Vlan-RangeId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status Time-out AccessPortDesc
_________________________________________________________________________________________________________________________________________
 
100 xe7 ----- 2-100 ---- 0000.1111.0001 1.1.1.1 Static Local ------- --- -------
100 --- ---- ---- 0000.2222.0001 2.2.2.2 Remote ------- --- -------
100 xe7 ----- 2-100 ---- b0da.1d10.6496 1.1.1.1 Dynamic Local ------- 300 -------
 
Total number of entries are 3
VTEP1#sh nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
Total number of entries are 0
VTEP1#sh nvo vxlan nd-cache
VxLAN ND-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________________________________
Total number of entries are 0
VTEP1#sh nvo vxlan access-if-config
nvo vxlan access-if port-vlan xe7 2-100
map vnid 100
arp-cache disable
nd-cache disable
mac 0000.1111.0001
!
VTEP1#sh nvo vxlan access-if brief
 
Inner Admin Link
Interface Vlan vlan Ifindex Vnid status status
-----------------------------------------------------------
xe7 2 --- 500000 100 up up
 
Total number of entries are 1
VTEP1#
VTEP1#sh nvo vxlan route-count
VxLAN Active route count information
====================================
Max route count : 32768
Active route count: 3
 
---------------------------------------------
VNID Total MACONLY MACIPv4 MACIPv6
---------------------------------------------
100 3 3 0 0
 
Total number of entries are 1
VTEP1#sh bgp l2vpn evpn summary
BGP router identifier 1.1.1.1, local AS number 1
BGP table version is 5
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
2.2.2.2 4 1 58 61 5 0 0 00:22:05 2 0 1 1 0 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
VTEP1#sh bgp l2vpn evpn
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[1.1.1.1:1] VRF[L2VRF1]:
*> [2]:[0]:[100]:[48,0000:1111:0001]:[0]:[100]
1.1.1.1 0 100 32768 i ---------- VxLAN
* i [2]:[0]:[100]:[48,0000:2222:0001]:[0]:[100]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*> [2]:[0]:[100]:[48,b0da:1d10:6496]:[0]:[100]
1.1.1.1 0 100 32768 i ---------- VxLAN
*> [3]:[100]:[32,1.1.1.1]
1.1.1.1 0 100 32768 i ---------- VxLAN
* i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
RD[2.2.2.2:1]
*>i [2]:[0]:[100]:[48,0000:2222:0001]:[0]:[100]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*>i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
Total number of prefixes 7
 
VTEP2
 
VTEP2#sh run nvo vxlan
!
nvo vxlan enable
!
nvo vxlan vtep-ip-global 2.2.2.2
!
nvo vxlan id 100 ingress-replication
vxlan host-reachability-protocol evpn-bgp L2VRF1
!
nvo vxlan access-if port-vlan xe23 2-100
map vnid 100
arp-cache disable
nd-cache disable
mac 0000.2222.0001
!
!
VTEP2#sh nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
============================================================================
2.2.2.2 1.1.1.1 Installed 00:19:28 00:19:28
 
Total number of entries are 1
VTEP2#sh nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
============================================================================
2.2.2.2 1.1.1.1 Installed 00:21:06 00:21:06
 
Total number of entries are 1
VTEP2#sh nvo vxlan
VxLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 1.1.1.1
100 ---- -- AC xe23 --- Single Homed Port --- 2 ---- ---- ----
 
Total number of entries are 2
VTEP2#sh nvo vxlan mac-table
==========================================================================================================================================
VxLAN MAC Entries
==========================================================================================================================================
VNID Interface VlanId Vlan-RangeId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
__________________________________________________________________________________________________________________________________________
 
100 ---- ---- ---- 0000.1111.0001 1.1.1.1 Static Remote ------- -------
100 xe23 ----- 2-100 ---- 0000.2222.0001 2.2.2.2 Static Local ------- -------
100 ---- ---- ---- b0da.1d10.6496 1.1.1.1 Dynamic Remote ------- -------
 
Total number of entries are : 3
 
VTEP2#sh nvo vxlan mac-table hardware
==========================================================================================================================================
VxLAN MAC Entries
==========================================================================================================================================
VNID Interface VlanId Vlan-RangeId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status Time-out AccessPortDesc
_________________________________________________________________________________________________________________________________________
 
100 --- ---- ---- 0000.1111.0001 1.1.1.1 Remote ------- --- -------
100 xe23 ----- 2-100 ---- 0000.2222.0001 2.2.2.2 Static Local ------- --- -------
100 --- ---- ---- b0da.1d10.6496 1.1.1.1 Remote ------- --- -------
 
Total number of entries are 3
VTEP2#sh nvo vxlan route-count
VxLAN Active route count information
====================================
Max route count : 32768
Active route count: 3
 
---------------------------------------------
VNID Total MACONLY MACIPv4 MACIPv6
---------------------------------------------
100 3 3 0 0
 
Total number of entries are 1
VTEP2#sh nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
Total number of entries are 0
VTEP2#sh nvo vxlan nd-cache
VxLAN ND-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________________________________
Total number of entries are 0
VTEP2#
VTEP2#
VTEP2#sh nvo vxlan access-if brief
 
Inner Admin Link
Interface Vlan vlan Ifindex Vnid status status
-----------------------------------------------------------
xe23 2 --- 500000 100 up up
 
Total number of entries are 1
VTEP2#sh nvo vxlan access-if-config
nvo vxlan access-if port-vlan xe23 2-100
map vnid 100
arp-cache disable
nd-cache disable
mac 0000.2222.0001
!
VTEP2#sh bgp l2vpn evpn summary
BGP router identifier 2.2.2.2, local AS number 1
BGP table version is 4
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
1.1.1.1 4 1 59 57 3 0 0 00:21:48 3 0 2 1 0 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
VTEP2#sh bgp l2vpn evpn
BGP table version is 4, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[1.1.1.1:1]
*>i [2]:[0]:[100]:[48,0000:1111:0001]:[0]:[100]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*>i [2]:[0]:[100]:[48,b0da:1d10:6496]:[0]:[100]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*>i [3]:[100]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
 
RD[2.2.2.2:1] VRF[L2VRF1]:
* i [2]:[0]:[100]:[48,0000:1111:0001]:[0]:[100]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*> [2]:[0]:[100]:[48,0000:2222:0001]:[0]:[100]
2.2.2.2 0 100 32768 i ---------- VxLAN
* i [2]:[0]:[100]:[48,b0da:1d10:6496]:[0]:[100]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [3]:[100]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*> [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- VxLAN
 
Total number of prefixes 8
VTEP2#