OcNOS-SP : Virtual Extensible LAN Guide : Virtual Extensible LAN Configuration Guide : VxLAN Multi-Homing Configuration
VxLAN Multi-Homing Configuration
This chapter contains the configurations for VxLAN Multi-homing feature.
Overview
VxLAN EVPN Multi-homing features enables to connect a CE/Host node to two VTEPs with all-active redundancy mode. A redundant VTEP device can provide network service to the customer site as soon as a failure is detected. The failure can be link or node failure. If one VTEP goes down, other will forward the entire traffic.
Below are Multi-homing concepts:
Ethernet Segment: Set of links which connect host/CE to two active-active multi-homed VTEP (only two VTEPs are supported) which appears as LACP link for host.
Ethernet Segment Identifier: Ethernet Segment Identifier (ESI) which is a 10 octet-value, which can be configured in two ways, system MAC is configured as esi in case of Dynamic LAG and 10-octet ESI format configuration is used on physical interface ES.
Ethernet Segment Route (ES route): When a multi-homed CE is configured as an VxLAN access-port, Ethernet segment route is sent. The main purpose of this route is to discover other VTEPs which share the ES and to perform DF election.
Ethernet A-D route per ESI: This route is used for Fast Convergence and Split Horizon.
Ethernet A-D route per EVI: This route is used for load sharing between DF and NON-DF by the remote VTEPs
Topology
VxLAN-Multihoming
Note: Enable VxLAN MUTIHOMING before executing any configurations.
VxLAN-EVPN MH Configuration
ESI can be configured in below two ways
Ethernet Segment through Dynamic LAG interface
 
#configure terminal
Enter Configure mode.
(config)#interface po1
Enter Interface mode for po1
(config-if)#switchport
Make it L2 interface
(config-if)#evpn multi-homed system-mac 8899.4400.6745
Configure system mac as ESI value for LAG (po1) interface
(config-if)#exit
Exit Interface mode.
(config)#commit
Commit the candidate configuration to the running configuration
OR
Ethernet Segment through Physical or Static LAG interface
 
#configure terminal
Enter Configure mode.
(config)#interface xe41
Enter Interface mode for xe41
(config-if)#switchport
Make it L2 interface
(config-if)# evpn multi-homed esi 00:01:02:03:04:05:06:07:08
Configure 9-octet ESI value for xe41 interface (in static config, out of 10-octet ESI value, first octet is reserved)
(config-if)#exit
Exit Interface mode.
(config)#commit
Commit the candidate configuration to the running configuration
VTEP1
(Multi-homed group1) – Part of both Multi-homed with po1 (MH1)
Hardware Profile and Generic Configuration
 
#configure terminal
Enter Configure mode.
(config)#hardware-profile filter vxlan enable
Enable hardware-profile filter for VxLAN.
(config)#hardware-profile filter vxlan-mh enable
Enable hardware-profile filter for VxLAN multi-homing.
(config)#hardware-profile filter egress-ipv4 enable
Enable hardware-profile filter for egress IPv4.
(config)#evpn vxlan multihoming enable
Enable Multihoming, save configs and reboot the board for multihoming to be effective
(config)#hardware-profile statistics ac-lif enable
Enable ac-lif for VxLAN access-if port counters
(config)#qos enable
Enabling QoS
(config)#commit
Commit the candidate configuration to the running configuration
Interface and Loopback Configuration
 
(config)#interface po1
Enter Interface mode for po1 (MH1)
(config-if)#switchport
Make it L2 interface
(config-if)# evpn multi-homed system-mac 0000.0000.1111
Configure system MAC as ESI value for LAG (po1) interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe9
Enter Interface mode for xe9
(config-if)#channel-group 1 mode active
Make it member port of po1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe10
Enter Interface mode for xe10
(config-if)#channel-group 1 mode active
Make it member port of po1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 1.1.1.1/32 secondary
Configure loopback ip address as 1.1.1.1 for VTEP1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe8
Enter Interface mode for xe8
(config-if)#ip address 10.10.10.1/24
Configure IP address as 10.10.10.1 on network side of Spine1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe31
Enter Interface mode for xe31
(config-if)#ip address 20.20.20.1/24
Configure IP address as 20.20.20.1 on network side of Spine2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
OSPF Configuration
 
(config)#router ospf 100
Enter into router OSPF mode
(config-router)#ospf router-id 1.1.1.1
Configure router-id as 1.1.1.1 (lo ip address)
(config-router)#network 1.1.1.1/32 area 0.0.0.0
Add 1.1.1.1 (lo IP address) network into area 0
(config-router)#network 10.10.10.0/24 area 0.0.0.0
Add 10.10.10.0 (Spine1) network into area 0
(config-router)#network 20.20.20.0/24 area 0.0.0.0
Add 20.20.20.0 (Spine2) network into area 0
(config-router)#bfd all-interfaces
Enabling BFD on all OSPF interface for fast convergence
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
BGP Configuration
 
(config)#router bgp 500
Enter into Router BGP mode
(config-router)#bgp router-id 1.1.1.1
Configure router-id as 1.1.1.1 (lo IP address)
(config-router)#neighbor 2.2.2.2 remote-as 500
Specify a VTEP2 loopback IP address and remote-as defined
(config-router)#neighbor 2.2.2.2 update-source lo
Configure update as loopback for VTEP2
(config-router)#neighbor 2.2.2.2 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP2
(config-router)#neighbor 3.3.3.3 remote-as 500
Specify a VTEP3 loopback IP address and remote-as defined
(config-router)#neighbor 3.3.3.3 update-source lo
Configure update as loopback for VTEP3
(config-router)#neighbor 3.3.3.3 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP3
(config-router)#address-family ipv4 unicast
Enter into ipv4 unicast address family mode
(config-router-af)#network 1.1.1.1/32
Advertise loopback network into BGP for VTEP ID reachability
(config-router-af)#neighbor 2.2.2.2 activate
Activate 2.2.2.2 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#neighbor 3.3.3.3 activate
Activate 3.3.3.3 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#exit-address-family
Exit from ipv4 unicast address family mode
(config-router)#address-family l2vpn evpn
Enter into L2VPN EVPN address family mode
(config-router-af)#neighbor 2.2.2.2 activate
Activate 2.2.2.2 (VTEP2) into L2VPN evpn address family mode
(config-router-af)#neighbor 3.3.3.3 activate
Activate 3.3.3.3 (VTEP3) into L2VPN evpn address family mode
(config-router-af)#exit-address-family
Exit from L2VPN address family mode
(config-router)#exit
Exit from Router BGP mode and enter into config mode
(config)#commit
Commit the candidate configuration to the running configuration
VRF Configuration
 
(config)#mac vrf VRF1
Create mac routing/forwarding instance with VRF1 name and enter into VRF mode
(config-vrf)#rd 1.1.1.1:11
Assign RD value
(config-vrf)#route-target both 9.9.9.9:100
Assign route-target value for same for import and export. Should be same on all node for VRF1
(config-vrf)#exit
Exit from VRF mode
(config)#mac vrf VRF2
Create MAC routing/forwarding instance with VRF1 name and enter into VRF mode
(config-vrf)#rd 1.1.1.1:21
Assign RD value
(config-vrf)#route-target both 90.90.90.90:100
Assign route-target value for same for import and export
(config-vrf)#exit
Exit from VRF mode
(config)#commit
Commit the candidate configuration to the running configuration
VxLAN Configuration
 
(config)#nvo vxlan enable
Enable VxLAN
(config)#evpn esi hold-time 60
Configure ESI hold time to allow tunnel to come up at the time of VxLAN initialization before making the ESI up
(config)#nvo vxlan vtep-ip-global 1.1.1.1
Configure Source VTEP-IP-global configuration
(config)#nvo vxlan id 10 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF1
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-RED
Configure VNI-name as VNI-RED
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan id 20 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF2
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-BLUE
Configure VNI-name as VNI-BLUE
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan access-if port-vlan po1 1001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) - Multihomed access port
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan po1 1002
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) - Multihomed access port
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan po1 3001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) - Multihomed access port
(config-nvo-acc-if)#map vni-name VNI-BLUE
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#exit
Exit from configuration mode
VTEP2
(Multi-homed group1) – Part of both Multi-homed with po1 (MH1). And it has xe32 as single home access-if port (SH2)
Hardware Profile and Generic Configuration
 
#configure terminal
Enter Configure mode.
(config)#hardware-profile filter vxlan enable
Enable hardware-profile filter for VxLAN.
(config)#hardware-profile filter vxlan-mh enable
Enable hardware-profile filter for VxLAN multi-homing.
(config)#hardware-profile filter egress-ipv4 enable
Enable hardware-profile filter for egress IPv4.
(config)#evpn vxlan multihoming enable
Enable Multihoming, save configs and reboot the board for multihoming to be effective
(config)#hardware-profile statistics ac-lif enable
Enable ac-lif for VxLAN access-if port counters
(config)#qos enable
Enabling QoS
(config)#commit
Commit the candidate configuration to the running configuration
Interface and Loopback Configuration
 
(config)#interface po1
Enter Interface mode for po1 (MH1)
(config-if)#switchport
Make it L2 interface
(config-if)# evpn multi-homed system-mac 0000.0000.1111
Configure system MAC as ESI value for LAG (po1) interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe3
Enter Interface mode for xe3
(config-if)#channel-group 1 mode active
Make it member port of po1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe4
Enter Interface mode for xe4
(config-if)#channel-group 1 mode active
Make it member port of po1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe32
Enter Interface mode for xe32 (SH2)
(config-if)#switchport
Make it L2 interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 2.2.2.2/32 secondary
Configure loopback IP address as 2.2.2.2 for VTEP2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe21
Enter Interface mode for xe21
(config-if)#ip address 30.30.30.1/24
Configure IP address as 30.30.30.1 on network side of Spine1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce53
Enter Interface mode for ce53
(config-if)#ip address 40.40.40.1/24
Configure IP address as 40.40.40.1 on network side of Spine2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
OSPF Configuration
 
(config)#router ospf 100
Enter into router OSPF mode
(config-router)#ospf router-id 2.2.2.2
Configure router-id as 2.2.2.2 (lo IP address)
(config-router)#network 2.2.2.2/32 area 0.0.0.0
Add 2.2.2.2 (lo IP address) network into area 0
(config-router)#network 30.30.30.0/24 area 0.0.0.0
Add 30.30.30.0 (Spine1) network into area 0
(config-router)#network 40.40.40.0/24 area 0.0.0.0
Add 40.40.40.0 (Spine2) network into area 0
(config-router)#bfd all-interfaces
Enabling BFD on all OSPF interface for fast convergence
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
BGP Configuration
 
(config)#router bgp 500
Enter into Router BGP mode
(config-router)#bgp router-id 2.2.2.2
Configure router-id as 2.2.2.2 (lo IP address)
(config-router)#neighbor 1.1.1.1 remote-as 500
Specify a VTEP1 loopback IP address and remote-as defined
(config-router)#neighbor 1.1.1.1 update-source lo
Configure update as loopback for VTEP1
(config-router)#neighbor 1.1.1.1 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP1
(config-router)#neighbor 3.3.3.3 remote-as 500
Specify a VTEP3 loopback IP address and remote-as defined
(config-router)#neighbor 3.3.3.3 update-source lo
Configure update as loopback for VTEP3
(config-router)#neighbor 3.3.3.3 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP3
(config-router)#address-family ipv4 unicast
Enter into ipv4 unicast address family mode
(config-router-af)#network 2.2.2.2/32
Advertise loopback network into BGP for VTEP ID reachability
(config-router-af)#neighbor 1.1.1.1 activate
Activate 1.1.1.1 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#neighbor 3.3.3.3 activate
Activate 3.3.3.3 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#exit-address-family
Exit from ipv4 unicast address family mode
(config-router)#address-family l2vpn evpn
Enter into L2VPN EVPN address family mode
(config-router-af)#neighbor 1.1.1.1 activate
Activate 1.1.1.1(VTEP1) into L2VPN evpn address family mode
(config-router-af)#neighbor 3.3.3.3 activate
Activate 3.3.3.3(VTEP3) into L2VPN evpn address family mode
(config-router-af)#exit-address-family
Exit from L2VPN address family mode
(config-router)#exit
Exit from Router BGP mode and enter into config mode
(config)#commit
Commit the candidate configuration to the running configuration
VRF Configuration
 
(config)# mac vrf VRF1
Create mac routing/forwarding instance with VRF1 name and enter into VRF mode
(config-vrf)#rd 2.2.2.2:11
Assign RD value
(config-vrf)#route-target both 9.9.9.9:100
Assign route-target value for same for import and export. Should be same on all node for VRF1
(config-vrf)#exit
Exit from VRF mode
(config)#mac vrf VRF2
Create MAC routing/forwarding instance with VRF1 name and enter into VRF mode
(config-vrf)#rd 2.2.2.2:21
Assign RD value
(config-vrf)#route-target both 90.90.90.90:100
Assign route-target value for same for import and export
(config-vrf)#exit
Exit from VRF mode
(config)#commit
Commit the candidate configuration to the running configuration
VxLAN Configuration
 
(config)#nvo vxlan enable
Enable VxLAN
(config)#evpn esi hold-time 60
Configure ESI hold time to allow tunnel to come up at the time of VxLAN initialization before making the ESI up
(config)#nvo vxlan vtep-ip-global 2.2.2.2
Configure Source VTEP-IP-global configuration
(config)#nvo vxlan id 10 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF1
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-RED
Configure VNI-name as VNI-RED
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan id 20 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF2
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-BLUE
Configure VNI-name as VNI-BLUE
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan access-if port-vlan po1 1001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) - Multihomed access port
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan po1 1002
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) - Multihomed access port
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan po1 3001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) - Multihomed access port
(config-nvo-acc-if)#map vni-name VNI-BLUE
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port xe32
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) - Multihomed access port
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#exit
Exit from configuration mode
(config)#commit
Commit the candidate configuration to the running configuration
VTEP3
It has xe48 as Single home access-if port (SH2)
Hardware Profile and Generic Configuration
 
#configure terminal
Enter Configure mode.
(config)#hardware-profile filter vxlan enable
Enable hardware-profile filter for VxLAN.
(config)#hardware-profile filter vxlan-mh enable
Enable hardware-profile filter for VxLAN multi-homing.
(config)#hardware-profile filter egress-ipv4 enable
Enable hardware-profile filter for egress IPv4.
(config)#evpn vxlan multihoming enable
Enable Multihoming, save configs and reboot the board for multihoming to be effective
(config)#hardware-profile statistics ac-lif enable
Enable ac-lif for VxLAN access-if port counters
(config)#qos enable
Enabling QoS
(config)#commit
Commit the candidate configuration to the running configuration
Interface and loopback configuration
 
(config)#interface xe48
Enter Interface mode for xe48 (SH3)
(config-if)#switchport
Make it L2 interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 3.3.3.3/32 secondary
Configure loopback IP address as 3.3.3.3 for VTEP3
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe18
Enter Interface mode for xe18
(config-if)#ip address 50.50.50.1/24
Configure IP address as 50.50.50.1 on network side of Spine1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe19
Enter Interface mode for xe19
(config-if)#ip address 60.60.60.1/24
Configure IP address as 60.60.60.1 on network side of Spine2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
OSPF Configuration
 
(config)#router ospf 100
Enter into router OSPF mode
(config-router)#ospf router-id 3.3.3.3
Configure router-ID as 3.3.3.3 (lo IP address)
(config-router)#network 3.3.3.3/32 area 0.0.0.0
Add 3.3.3.3 (lo IP address) network into area 0
(config-router)#network 50.50.50.0/24 area 0.0.0.0
Add 50.50.50.0 (Spine1) network into area 0
(config-router)#network 60.60.60.0/24 area 0.0.0.0
Add 60.60.60.0 (Spine2) network into area 0
(config-router)#bfd all-interfaces
Enabling BFD on all OSPF interface for fast convergence
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
BGP Configuration
 
(config)#router bgp 500
Enter into Router BGP mode
(config-router)#bgp router-id 3.3.3.3
Configure router-ID as 3.3.3.3 (lo ip address)
(config-router)#neighbor 1.1.1.1 remote-as 500
Specify a VTEP1 loopback IP address and remote-as defined
(config-router)#neighbor 1.1.1.1 update-source lo
Configure update as loopback for VTEP1
(config-router)#neighbor 1.1.1.1 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP1
(config-router)#neighbor 2.2.2.2 remote-as 500
Specify a VTEP2 loopback IP address and remote-as defined
(config-router)#neighbor 2.2.2.2 update-source lo
Configure update as loopback for VTEP2
(config-router)#neighbor 2.2.2.2 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP3
(config-router)#address-family ipv4 unicast
Enter into ipv4 unicast address family mode
(config-router-af)#network 3.3.3.3/32
Advertise loopback network into BGP for VTEP ID reachability
(config-router-af)#neighbor 1.1.1.1 activate
Activate 1.1.1.1 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#neighbor 2.2.2.2 activate
Activate 2.2.2.2 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#exit-address-family
Exit from ipv4 unicast address family mode
(config-router)#address-family l2vpn evpn
Enter into L2VPN EVPN address family mode
(config-router-af)#neighbor 1.1.1.1 activate
Activate 1.1.1.1 (VTEP1) into L2VPN evpn address family mode
(config-router-af)#neighbor 2.2.2.2 activate
Activate 2.2.2.2 (VTEP2) into L2VPN evpn address family mode
(config-router-af)#exit-address-family
Exit from L2VPN address family mode
(config-router)#exit
Exit from Router BGP mode and enter into config mode
(config)#commit
Commit the candidate configuration to the running configuration
VRF Configuration
 
(config)# mac vrf VRF1
Create MAC routing/forwarding instance with VRF1 name and enter into VRF mode
(config-vrf)#rd 3.3.3.3:11
Assign RD value
(config-vrf)#route-target both 9.9.9.9:100
Assign route-target value for same for import and export. Should be same on all node for VRF1
(config-vrf)#exit
Exit from VRF mode
(config)#mac vrf VRF2
Create MAC routing/forwarding instance with VRF2 name and enter into VRF mode
(config-vrf)#rd 3.3.3.3:21
Assign RD value
(config-vrf)#route-target both 90.90.90.90:100
Assign route-target value for same for import and export
(config-vrf)#exit
Exit from VRF
(config)#commit
Commit the candidate configuration to the running configuration
VxLAN Configuration
 
(config)#nvo vxlan enable
Enable VxLAN
(config)#nvo vxlan vtep-ip-global 3.3.3.3
Configure Source VTEP-IP-global configuration
(config)#nvo vxlan id 10 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF1
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-RED
Configure VNI-name as VNI-RED
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan id 20 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF2
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-BLUE
Configure VNI-name as VNI-BLUE
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan access-if port-vlan xe48 1001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) - Multihomed access port
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan xe48 1002
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) - Multihomed access port
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan xe48 3001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) - Multihomed access port
(config-nvo-acc-if)#map vni-name VNI-BLUE
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#exit
Exit from configuration mode
Switch (CE2)
Multihomed to 2-VTEPs (VTEP1 and VTEP2)
 
#configure terminal
Enter Configure mode.
(config)#bridge 1 protocol ieee vlan-bridge
Configure IEEE VLAN bridge
(config)#vlan 1001-1002 bridge 1 state enable
Configure VLANs from 1001-1002 and associate with bridge 1
(config)#vlan 3001 bridge 1 state enable
Configure VLANs from 3001 and associate with bridge 1
(config)#interface xe22
Enter Interface mode for xe22
(config-if)#switchport
Make xe22 as L2 port by configuring switchport
(config-if)#bridge-group 1
Associate xe22 to bridge 1
(config-if)#switchport mode hybrid
Configure xe22 as hybrid port
(config-if)#switchport hybrid allowed vlan add 1001-1002,3001 egress-tagged enable
Allow 1001-1002 and 3001 configured VLANs on xe22
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface po1
Enter Interface mode for po1
(config-if)#switchport
Make po1 as L2 port by configuring switchport
(config-if)#bridge-group 1
Associate po1 to bridge 1
(config-if)#switchport mode hybrid
Configure po1 as hybrid port
(config-if)#switchport hybrid allowed vlan add 1001-1002,3001 egress-tagged enable
Allow 1001-1002 and 3001 configured VLANs on po1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe3
Enter Interface mode for xe3
(config-if)#channel-group 1 mode active
Make it member port of po1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe4
Enter Interface mode for xe4
(config-if)#channel-group 1 mode active
Make it member port of po1
(config-if)#exit
Exit from configuration mode
(config)#interface xe9
Enter Interface mode for xe9
(config-if)#channel-group 1 mode active
Make it member port of po1
(config)#interface xe10
Enter Interface mode for xe10
(config-if)#channel-group 1 mode active
Make it member port of po1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
(config)#exit
Exit from configuration mode
Spine 1
Spine node where all VTEPs are connected
Generic Configuration
 
#configure terminal
Enter Configure mode.
(config)#qos enable
Enabling QoS
(config)#commit
Commit the candidate configuration to the running configuration
Interface and Loopback Configuration
 
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 11.11.11.11/32 secondary
Configure loopback IP address as 11.11.11.11 for Spine1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe8
Enter Interface mode for xe8
(config-if)#ip address 10.10.10.2/24
Configure IP address as 10.10.10.2 on network side of VTEP1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe1
Enter Interface mode for xe1
(config-if)#ip address 30.30.30.2/24
Configure IP address as 30.30.30.2 on network side of VTEP2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe18
Enter Interface mode for xe18
(config-if)#ip address 50.50.50.2/24
Configure IP address as 50.50.50.2 on network side of VTEP3
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
OSPF configuration
 
(config)#router ospf 100
Enter into router OSPF mode
(config-router)#ospf router-id 11.11.11.11
Configure router-ID as 11.11.11.11 (lo IP address)
(config-router)#network 11.11.11.11/32 area 0.0.0.0
Add 11.11.11.11 (lo IP address) network into area 0
(config-router)#network 10.10.10.0/24 area 0.0.0.0
Add 10.10.10.0 (VTEP1) network into area 0
(config-router)#network 30.30.30.0/24 area 0.0.0.0
Add 30.30.30.0 (VTEP2) network into area 0
(config-router)#network 50.50.50.0/24 area 0.0.0.0
Add 50.50.50.0 (VTEP3) network into area 0
(config-router)#bfd all-interfaces
Enabling BFD on all OSPF interface for fast convergence
(config-router)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
Spine 2
Spine node where all VTEPs are connected
Generic configuration
 
#configure terminal
Enter Configure mode.
(config)#qos enable
Enabling QoS
(config)#commit
Commit the candidate configuration to the running configuration
Interface and loopback configuration
 
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 22.22.22.22/32 secondary
Configure loopback IP address as 22.22.22.22 for Spine2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe5
Enter Interface mode for xe5
(config-if)#ip address 20.20.20.2/24
Configure IP address as 20.20.20.2 on network side of VTEP1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce0
Enter Interface mode for ce0
(config-if)#ip address 40.40.40.2/24
Configure IP address as 40.40.40.2 on network side of VTEP2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe19
Enter Interface mode for xe19
(config-if)#ip address 60.60.60.2/24
Configure IP address as 60.60.60.2 on network side of VTEP3
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
OSPF configuration
 
(config)#router ospf 100
Enter into router OSPF mode
(config-router)#ospf router-id 22.22.22.22
Configure router-id as 11.11.11.11 (lo IP address)
(config-router)#network 22.22.22.22/32 area 0.0.0.0
Add 22.22.22.22 (lo IP address) network into area 0
(config-router)#network 20.20.20.0/24 area 0.0.0.0
Add 20.20.20.0 (VTEP1) network into area 0
(config-router)#network 40.40.40.0/24 area 0.0.0.0
Add 40.40.40.0 (VTEP2) network into area 0
(config-router)#network 60.60.60.0/24 area 0.0.0.0
Add 60.60.60.0 (VTEP3) network into area 0
(config-router)#bfd all-interfaces
Enabling BFD on all OSPF interface for fast convergence
(config-router)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
Validation
VTEP1
VTEP1#show nvo vxlan
VxLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_________________________________________________________________________________________________________________
10 VNI-RED L2 NW ---- ---- ---- ---- 1.1.1.1 3.3.3.3
10 VNI-RED L2 NW ---- ---- ---- ---- 1.1.1.1 2.2.2.2
10 VNI-RED -- AC po1 00:00:00:00:00:11:11:00:00:00 1001 NON-DF ---- ----
10 VNI-RED -- AC po1 00:00:00:00:00:11:11:00:00:00 1002 DF ---- ----
20 VNI-BLUE L2 NW ---- ---- ---- ---- 1.1.1.1 3.3.3.3
20 VNI-BLUE L2 NW ---- ---- ---- ---- 1.1.1.1 2.2.2.2
20 VNI-BLUE -- AC po1 00:00:00:00:00:11:11:00:00:00 3001 NON-DF ---- ----
 
Total number of entries are 7
 
VTEP1#show nvo vxlan access-if brief
 
Inner Admin Link
Interface Vlan vlan Ifindex Vnid status status
-----------------------------------------------------------
po1 1002 --- 500001 10 up up
po1 1001 --- 500000 10 up up
po1 3001 --- 500002 20 up up
 
Total number of entries are 3
 
VTEP1#show bgp l2vpn evpn summary
BGP router identifier 1.1.1.1, local AS number 500
BGP table version is 6
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
2.2.2.2 4 500 161 163 5 0 0 01:05:15 6 3 0 2 1 0
3.3.3.3 4 500 157 161 5 0 0 01:05:07 2 0 0 2 0 0
 
Total number of neighbors 2
 
Total number of Established sessions 2
 
VTEP1#show nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
============================================================================
1.1.1.1 3.3.3.3 Installed 00:31:11 00:31:11
1.1.1.1 2.2.2.2 Installed 01:05:25 00:31:11
 
Total number of entries are 2
 
VTEP1#show bgp l2vpn evpn multihoming es-route
 
RD[1.1.1.1:1] VRF[evpn-gvrf-1]:
ESI PE IP-Address Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 1.1.1.1 1.1.1.1 VxLAN
00:00:00:00:00:11:11:00:00:00 2.2.2.2 2.2.2.2 VxLAN
 
RD[2.2.2.2:1]
ESI PE IP-Address Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 2.2.2.2 2.2.2.2 VxLAN
 
VTEP1#show bgp l2vpn evpn multihoming ethernet-ad-per-es
 
RD[1.1.1.1:1] VRF[evpn-gvrf-1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 1.1.1.1 VxLAN
 
RD[1.1.1.1:11] VRF[VRF1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 2.2.2.2 VxLAN
 
RD[1.1.1.1:21] VRF[VRF2]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 2.2.2.2 VxLAN
 
RD[2.2.2.2:1]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 2.2.2.2 VxLAN
VTEP1#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
 
RD[1.1.1.1:11] VRF[VRF1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 10 10 2.2.2.2 VxLAN
00:00:00:00:00:11:11:00:00:00 10 10 1.1.1.1 VxLAN
 
RD[1.1.1.1:21] VRF[VRF2]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 20 20 2.2.2.2 VxLAN
00:00:00:00:00:11:11:00:00:00 20 20 1.1.1.1 VxLAN
 
RD[2.2.2.2:11]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 10 10 2.2.2.2 VxLAN
 
RD[2.2.2.2:21]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 20 20 2.2.2.2 VxLAN
 
VTEP1#show bgp l2vpn evpn
BGP table version is 6, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[1.1.1.1:1] VRF[evpn-gvrf-1]:
*> [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
1.1.1.1 0 100 32768 i ---------- VxLAN
*> [4]:[00:00:00:00:00:11:11:00:00:00]:[32,1.1.1.1]
1.1.1.1 0 100 32768 i ---------- VxLAN
* i [4]:[00:00:00:00:00:11:11:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
RD[1.1.1.1:11] VRF[VRF1]:
* i [1]:[00:00:00:00:00:11:11:00:00:00]:[10]:[10]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*> 1.1.1.1 0 100 32768 i ---------- VxLAN
* i [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*> [3]:[10]:[32,1.1.1.1]
1.1.1.1 0 100 32768 i ---------- VxLAN
* i [3]:[10]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
* i [3]:[10]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VxLAN
 
RD[1.1.1.1:21] VRF[VRF2]:
* i [1]:[00:00:00:00:00:11:11:00:00:00]:[20]:[20]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*> 1.1.1.1 0 100 32768 i ---------- VxLAN
* i [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*> [3]:[20]:[32,1.1.1.1]
1.1.1.1 0 100 32768 i ---------- VxLAN
* i [3]:[20]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
* i [3]:[20]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VxLAN
 
RD[2.2.2.2:1]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*>i [4]:[00:00:00:00:00:11:11:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
RD[2.2.2.2:11]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[10]:[10]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*>i [3]:[10]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
RD[2.2.2.2:21]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[20]:[20]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*>i [3]:[20]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
RD[3.3.3.3:11]
*>i [3]:[10]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VxLAN
 
RD[3.3.3.3:21]
*>i [3]:[20]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VxLAN
 
Total number of prefixes 21
VTEP2
VTEP2#show nvo vxlan
VxLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_________________________________________________________________________________________________________________
10 VNI-RED L2 NW ---- ---- ---- ---- 2.2.2.2 1.1.1.1
10 VNI-RED L2 NW ---- ---- ---- ---- 2.2.2.2 3.3.3.3
10 VNI-RED -- AC xe32 --- Single Homed Port --- ---- ---- ---- ----
10 VNI-RED -- AC po1 00:00:00:00:00:11:11:00:00:00 1001 DF ---- ----
10 VNI-RED -- AC po1 00:00:00:00:00:11:11:00:00:00 1002 NON-DF ---- ----
20 VNI-BLUE L2 NW ---- ---- ---- ---- 2.2.2.2 1.1.1.1
20 VNI-BLUE L2 NW ---- ---- ---- ---- 2.2.2.2 3.3.3.3
20 VNI-BLUE -- AC po1 00:00:00:00:00:11:11:00:00:00 3001 DF ---- ----
 
Total number of entries are 8
 
VTEP2#show nvo vxlan access-if
% Incomplete command.
 
VTEP2#show nvo vxlan access-if brief
 
Inner Admin Link
Interface Vlan vlan Ifindex Vnid status status
-----------------------------------------------------------
xe32 --- --- 500004 10 up up
po1 1002 --- 500001 10 up up
po1 1001 --- 500000 10 up up
po1 3001 --- 500002 20 up up
 
Total number of entries are 4
 
VTEP2#show bgp l2vpn evpn summary
BGP router identifier 2.2.2.2, local AS number 500
BGP table version is 4
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
1.1.1.1 4 500 172 171 4 0 0 01:09:28 6 3 0 2 1 0
3.3.3.3 4 500 165 173 4 0 0 01:09:29 2 0 0 2 0 0
 
Total number of neighbors 2
 
Total number of Established sessions 2
 
VTEP2#show nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
============================================================================
2.2.2.2 1.1.1.1 Installed 01:09:38 00:35:24
2.2.2.2 3.3.3.3 Installed 01:09:39 01:09:39
 
Total number of entries are 2
 
VTEP2#show bgp l2vpn evpn multihoming es-route
 
RD[1.1.1.1:1]
ESI PE IP-Address Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 1.1.1.1 1.1.1.1 VxLAN
 
RD[2.2.2.2:1] VRF[evpn-gvrf-1]:
ESI PE IP-Address Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 1.1.1.1 1.1.1.1 VxLAN
00:00:00:00:00:11:11:00:00:00 2.2.2.2 2.2.2.2 VxLAN
VTEP2#show bgp l2vpn evpn multihoming ethernet-ad-per-es
 
RD[1.1.1.1:1]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 1.1.1.1 VxLAN
 
RD[2.2.2.2:1] VRF[evpn-gvrf-1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 2.2.2.2 VxLAN
 
RD[2.2.2.2:11] VRF[VRF1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 1.1.1.1 VxLAN
 
RD[2.2.2.2:21] VRF[VRF2]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 1.1.1.1 VxLAN
 
VTEP2#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
 
RD[1.1.1.1:11]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 10 10 1.1.1.1 VxLAN
 
RD[1.1.1.1:21]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 20 20 1.1.1.1 VxLAN
 
RD[2.2.2.2:11] VRF[VRF1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 10 10 2.2.2.2 VxLAN
00:00:00:00:00:11:11:00:00:00 10 10 1.1.1.1 VxLAN
 
RD[2.2.2.2:21] VRF[VRF2]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 20 20 2.2.2.2 VxLAN
00:00:00:00:00:11:11:00:00:00 20 20 1.1.1.1 VxLAN
 
VTEP2# show bgp l2vpn evpn
BGP table version is 4, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[1.1.1.1:1]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*>i [4]:[00:00:00:00:00:11:11:00:00:00]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
 
RD[1.1.1.1:11]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[10]:[10]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*>i [3]:[10]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
 
RD[1.1.1.1:21]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[20]:[20]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*>i [3]:[20]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
 
RD[2.2.2.2:1] VRF[evpn-gvrf-1]:
*> [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 32768 i ---------- VxLAN
* i [4]:[00:00:00:00:00:11:11:00:00:00]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*> [4]:[00:00:00:00:00:11:11:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- VxLAN
 
RD[2.2.2.2:11] VRF[VRF1]:
*> [1]:[00:00:00:00:00:11:11:00:00:00]:[10]:[10]
2.2.2.2 0 100 32768 i ---------- VxLAN
* i 1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [3]:[10]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*> [3]:[10]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- VxLAN
* i [3]:[10]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VxLAN
 
RD[2.2.2.2:21] VRF[VRF2]:
*> [1]:[00:00:00:00:00:11:11:00:00:00]:[20]:[20]
2.2.2.2 0 100 32768 i ---------- VxLAN
* i 1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [3]:[20]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*> [3]:[20]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- VxLAN
* i [3]:[20]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VxLAN
 
RD[3.3.3.3:11]
*>i [3]:[10]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VxLAN
 
RD[3.3.3.3:21]
*>i [3]:[20]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VxLAN
 
Total number of prefixes 21
VTEP3
VTEP3# show nvo vxlan
VxLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
10 VNI-RED L2 NW ---- ---- ---- ---- 3.3.3.3 2.2.2.2
10 VNI-RED L2 NW ---- ---- ---- ---- 3.3.3.3 1.1.1.1
10 VNI-RED -- AC xe48 --- Single Homed Port --- 1001 ---- ---- ----
10 VNI-RED -- AC xe48 --- Single Homed Port --- 1002 ---- ---- ----
20 VNI-BLUE L2 NW ---- ---- ---- ---- 3.3.3.3 2.2.2.2
20 VNI-BLUE L2 NW ---- ---- ---- ---- 3.3.3.3 1.1.1.1
20 VNI-BLUE -- AC xe48 --- Single Homed Port --- 3001 ---- ---- ----
 
Total number of entries are 7
 
VTEP3#show nvo vxlan access-if brief
 
Inner Admin Link
Interface Vlan vlan Ifindex Vnid status status
-----------------------------------------------------------
xe48 1002 --- 500001 10 up up
xe48 1001 --- 500000 10 up up
xe48 3001 --- 500002 20 up up
 
Total number of entries are 3
 
VTEP3#show bgp l2vpn evpn summary
BGP router identifier 3.3.3.3, local AS number 500
BGP table version is 4
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
1.1.1.1 4 500 177 173 3 0 0 01:11:49 6 3 0 2 1 0
2.2.2.2 4 500 177 171 2 0 0 01:11:59 6 3 0 2 1 0
 
Total number of neighbors 2
 
Total number of Established sessions 2
 
VTEP3#show nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
============================================================================
3.3.3.3 2.2.2.2 Installed 01:12:10 01:12:10
3.3.3.3 1.1.1.1 Installed 01:12:00 01:12:00
 
Total number of entries are 2
 
VTEP3#show bgp l2vpn evpn multihoming es-route
 
RD[1.1.1.1:1]
ESI PE IP-Address Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 1.1.1.1 1.1.1.1 VxLAN
 
RD[2.2.2.2:1]
ESI PE IP-Address Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 2.2.2.2 2.2.2.2 VxLAN
 
VTEP3#show bgp l2vpn evpn multihoming ethernet-ad-per-es
 
RD[1.1.1.1:1]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 1.1.1.1 VxLAN
 
RD[2.2.2.2:1]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 2.2.2.2 VxLAN
 
RD[3.3.3.3:11] VRF[VRF1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 2.2.2.2 VxLAN
00:00:00:00:00:11:11:00:00:00 4294967295 0 1.1.1.1 VxLAN
 
RD[3.3.3.3:21] VRF[VRF2]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 4294967295 0 2.2.2.2 VxLAN
00:00:00:00:00:11:11:00:00:00 4294967295 0 1.1.1.1 VxLAN
 
VTEP3#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
 
RD[1.1.1.1:11]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 10 10 1.1.1.1 VxLAN
 
RD[1.1.1.1:21]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 20 20 1.1.1.1 VxLAN
 
RD[2.2.2.2:11]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 10 10 2.2.2.2 VxLAN
 
RD[2.2.2.2:21]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 20 20 2.2.2.2 VxLAN
 
RD[3.3.3.3:11] VRF[VRF1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 10 10 2.2.2.2 VxLAN
00:00:00:00:00:11:11:00:00:00 10 10 1.1.1.1 VxLAN
 
RD[3.3.3.3:21] VRF[VRF2]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:00:00:11:11:00:00:00 20 20 2.2.2.2 VxLAN
00:00:00:00:00:11:11:00:00:00 20 20 1.1.1.1 VxLAN
 
VTEP3#show bgp l2vpn evpn
BGP table version is 4, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[1.1.1.1:1]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*>i [4]:[00:00:00:00:00:11:11:00:00:00]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
 
RD[1.1.1.1:11]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[10]:[10]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*>i [3]:[10]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
 
RD[1.1.1.1:21]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[20]:[20]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
*>i [3]:[20]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
 
RD[2.2.2.2:1]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*>i [4]:[00:00:00:00:00:11:11:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
RD[2.2.2.2:11]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[10]:[10]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*>i [3]:[10]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
RD[2.2.2.2:21]
*>i [1]:[00:00:00:00:00:11:11:00:00:00]:[20]:[20]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*>i [3]:[20]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
 
RD[3.3.3.3:11] VRF[VRF1]:
* i [1]:[00:00:00:00:00:11:11:00:00:00]:[10]:[10]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
* i 1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
* i 1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [3]:[10]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [3]:[10]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*> [3]:[10]:[32,3.3.3.3]
3.3.3.3 0 100 32768 i ---------- VxLAN
 
RD[3.3.3.3:21] VRF[VRF2]:
* i [1]:[00:00:00:00:00:11:11:00:00:00]:[20]:[20]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
* i 1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [1]:[00:00:00:00:00:11:11:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
* i 1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [3]:[20]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VxLAN
* i [3]:[20]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VxLAN
*> [3]:[20]:[32,3.3.3.3]
3.3.3.3 0 100 32768 i ---------- VxLAN
 
Total number of prefixes 22
Static MAC-IP Advertise through Single Home and Multihomed VTEPs
Advertise static MAC IPv4 from MH1 and SH3.
MH1-VTEPs: VTEP1 & VTEP2- same MAC should be configured on both VTEPs under po access-port, configs should be symmetric between MH VTEPs
SH3-VTEP: VTEP3
VTEP1 (MH1)
 
#configure terminal
Enter Configure mode.
(config)# nvo vxlan access-if port-vlan po1 1001
Enter into VxLAN MH po1 access-port with VLAN 1001
(config-nvo-acc-if)#mac 0000.1111.1001 ip 11.11.10.1
Configure static MAC IP
(config-nvo-acc-if)#exit
Exit from VxLAN access-port config mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#exit
Exit from configuration mode
VTEP2 (MH1)
 
#configure terminal
Enter Configure mode.
(config)#nvo vxlan access-if port-vlan po1 1001
Enter into VxLAN MH po1 access-port with vlan 1001
(config-nvo-acc-if)# mac 0000.1111.1001 ip 11.11.10.1
Configure static MAC IP
(config-nvo-acc-if)#exit
Exit from VxLAN access-port config mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#exit
Exit from configuration mode
VTEP3 (SH)
 
#configure terminal
Enter Configure mode.
(config)# nvo vxlan access-if port-vlan xe48 1001
Enter into single-homed access-port - xe48 with VLAN 1001
(config-nvo-acc-if)#mac 0000.3333.1001 ip 11.11.10.2
Configure static MAC IP
(config-nvo-acc-if)#exit
Exit from VxLAN access-port config mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#exit
Exit from configuration mode
Validation
Verify MAC-table in MH VTEPs and Single Home VTEP, MAC will be advertised through ESI value which is advertised from VTEP1 and VTEP2 and VTEP IP from SH VTEP VTEP3.
Verify ARP-cache table in all VTEPs, VTEP1 and VTEP2 will learn VTEP3 IP.
Any ARP request comes for 11.11.10.2, VTEP1/VTEP2 will do proxy-ARP.
VTEP1
VTEP1#show nvo vxlan mac-table
============================================================================================================================
VxLAN MAC Entries
============================================================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
__________________________________________________________________________________________________________________________________________
 
10 po1 1001 ---- 0000.1111.1001 00:00:00:00:00:11:11:00:00:00 Static Local ------- -------
10 ---- ---- ---- 0000.3333.1001 3.3.3.3 Static Remote ------- -------
 
Total number of entries are : 2
 
VTEP1#show nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
10 11.11.10.1 0000.1111.1001 Static Local ----
10 11.11.10.2 0000.3333.1001 Static Remote ----
Total number of entries are 2
VTEP2
VTEP2#show nvo vxlan mac-table
============================================================================================================================
VxLAN MAC Entries
============================================================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
____________________________________________________________________________________________________________________________
 
10 po1 1001 ---- 0000.1111.1001 00:00:00:00:00:11:11:00:00:00 Static Local ------- -------
10 ---- ---- ---- 0000.3333.1001 3.3.3.3 Static Remote ------- -------
 
Total number of entries are : 2
 
VTEP2#show nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
10 11.11.10.1 0000.1111.1001 Static Local ----
10 11.11.10.2 0000.3333.1001 Static Remote ----
Total number of entries are 2
VTEP3
VTEP3#show nvo vxlan mac-table
============================================================================================================================
VxLAN MAC Entries
============================================================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
____________________________________________________________________________________________________________________________
 
10 ---- 1001 ---- 0000.1111.1001 00:00:00:00:00:11:11:00:00:00 Static Remote ------- -------
10 xe48 1001 ---- 0000.3333.1001 3.3.3.3 Static Local ------- -------
 
Total number of entries are : 2
 
VTEP3#show nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
10 11.11.10.1 0000.1111.1001 Static Remote ----
10 11.11.10.2 0000.3333.1001 Static Local ----
Total number of entries are 2
Dynamic MAC Advertise through Single Home and Multihomed VTEPs
Advertise 2 MAC's through CE1 connected IXIA, dynamic MAC entries and verify MAC-table in all VTEPs.
One MAC will be dynamic local in VTEP1 and same will be remote in VTEP2 and other be dynamic local in VTEP2 and same will be remote in VTEP1.
Both MAC's will be in remote in VTEP3.
VTEP1
VTEP1#show nvo vxlan mac-table
============================================================================================================================
VxLAN MAC Entries
============================================================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
____________________________________________________________________________________________________________________________
 
10 po1 1001 ---- 0000.1111.1002 00:00:00:00:00:11:11:00:00:00 Dynamic Local ------- -------
10 ---- 1002 ---- 0000.1111.1003 00:00:00:00:00:11:11:00:00:00 Dynamic Remote ------- -------
 
Total number of entries are : 2
 
VTEP1#show nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
10 21.21.21.1 0000.1111.1002 Dynamic Local ----
10 31.1.31.1 0000.1111.1003 Dynamic Remote ----
Total number of entries are 2
VTEP2
VTEP2#show nvo vxlan mac-table
============================================================================================================================
VxLAN MAC Entries
============================================================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
____________________________________________________________________________________________________________________________
 
10 ---- 1001 ---- 0000.1111.1002 00:00:00:00:00:11:11:00:00:00 Dynamic Remote ------- -------
10 po1 1002 ---- 0000.1111.1003 00:00:00:00:00:11:11:00:00:00 Dynamic Local ------- -------
 
Total number of entries are : 2
 
VTEP2#show nvo vxla arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
10 21.21.21.1 0000.1111.1002 Dynamic Remote ----
10 31.1.31.1 0000.1111.1003 Dynamic Local ----
Total number of entries are 2
VTEP3
VTEP3#show nvo vxlan mac-table
==========================================================================================================================================
VxLAN MAC Entries
==========================================================================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
__________________________________________________________________________________________________________________________________________
 
10 ---- 1001 ---- 0000.1111.1002 00:00:00:00:00:11:11:00:00:00 Dynamic Remote ------- -------
10 ---- 1002 ---- 0000.1111.1003 00:00:00:00:00:11:11:00:00:00 Dynamic Remote ------- -------
 
Total number of entries are : 2
 
VTEP3#show nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
10 21.21.21.1 0000.1111.1002 Dynamic Remote ----
10 31.1.31.1 0000.1111.1003 Dynamic Remote ----
Total number of entries are 2
Note:  
When VTEP1 tunnel goes down, then traffic from VTEP3 will use VTEP2 for forwarding. But Traffic from Switch to VTEP1 will be lost in VTEP1 itself.
When DUT is rebooted, access-if will be in hold down state until ESI hold timer value expiry. After ESI hold timer expiry, access-if port will be up and started learning.
MAC Hold timer will not be applicable on ESI interface, because of mass-withdraw requirement.
A CE can connect to maximum two nodes for multihoming, more than two nodes in a multihoming group is not supported.
All configuration (shutdown, disable learning, disable arp/nd cache, disable arp/nd flood, map vnid, qos profiles, encapsulation) on a multihomed access port should be same on both VTEPs sharing the ESI for multihoming functionalities to work properly.
Multiple ESI values are supported on same VTEP.