Bridge1#configure terminal | Enter configure mode |
Bridge1(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
Bridge1(config)#hardware-profile filter cfm-domain-name-str enable | Enable CFM domain name as string |
Bridge1(config)#vlan database | Configure VLAN database |
Bridge1(config-vlan)# vlan 450 bridge 1 state enable | Create VLAN 450 on bridge 1 |
Bridge1(config-vlan)# vlan 900-1010 bridge 1 state enable | Create VLAN 900-1010 on bridge 1 |
Bridge1(config-vlan)#interface xe12 | Configure interface xe12 |
Bridge1(config-if)#switchport | Configure xe12 as a layer 2 port |
Bridge1(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge1(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge1(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge1(config-if)#switchport trunk allowed vlan add 450,900-1010 | Allow vlan 450,900-1010 on xe12 interface |
Bridge1(config-if)#interface xe20 | Configure interface xe20 |
Bridge1(config-if)#switchport | Configure xe20 as a layer 2 port |
Bridge1(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge1(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge1(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge1(config-if)#switchport trunk allowed vlan add 450,900-1010 | Allow vlan 450,900-1010 on xe20 interface |
Bridge1(config-if)#interface xe24 | Configure interface xe24 |
Bridge1(config-if)#switchport | Configure xe24 as a layer 2 port |
Bridge1(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge1(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge1(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge1(config-if)#switchport trunk allowed vlan add 450,900-1010 | Allow vlan 450,900-1010 on xe24 interface |
Bridge1(config-if)# ethernet cfm domain-type character-string domain-name mdna1 level 7 mip-creation default | Create cfm domain with type as character string with name mdna1 and set MIP creation criteria to default with level 7 |
Bridge1(config-ether-cfm)#service ma-type string ma-name n27 | Create MA type as string with name n27 |
Bridge1(config-ether-cfm-ma)# vlan 900 bridge 1 | Add VLAN 900 |
Bridge1(config-ether-cfm-ma)# mip-creation default | Set MIP-creation criteria to default |
Bridge1(config-ether-cfm-ma)# ethernet cfm mep down mpid 2027 active true xe12 | Create down MEP 2027 for xe12 interface |
Bridge1(config-ether-cfm-ma-mep)#cc multicast state enable | Enable CC multicast |
Bridge1(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet CFM MA-MEP mode |
Bridge1(config-ether-cfm-ma)#mep crosscheck mpid 27 | Configure crosscheck to remote MEP with value 27 |
Bridge1(config-ether-cfm-ma)#cc interval 10s | Enable cc interval with 10s |
Bridge1(config-ether-cfm-ma)# exit-ether-ma-mode | Exit Ethernet ma mode |
Bridge1(config-if)# ethernet cfm domain-type character-string domain-name mdna2 level 7 mip-creation default | Create cfm domain with type as character string with name mdna2 and set MIP creation criteria to default with level 7 |
Bridge1(config-ether-cfm)#service ma-type string ma-name n27 | Create MA type as string with name n27 |
Bridge1(config-ether-cfm-ma)# vlan 900 bridge 1 | Add VLAN 900 |
Bridge1(config-ether-cfm-ma)# mip-creation default | Set MIP-creation criteria to default |
Bridge1(config-ether-cfm-ma)# ethernet cfm mep down mpid 3037 active true xe20 | Create down MEP 3037 for xe20 interface |
Bridge1(config-ether-cfm-ma-mep)#cc multicast state enable | Enable CC multicast |
Bridge1(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet CFM MA-MEP mode |
Bridge1(config-ether-cfm-ma)#mep crosscheck mpid 37 | Configure crosscheck to remote MEP with value 37 |
Bridge1(config-ether-cfm-ma)#cc interval 10s | Enable cc interval with 10s |
Bridge1(config-ether-cfm-ma)# exit-ether-ma-mode | Exit Ethernet ma mode |
Bridge1(config-ether-cfm)#g8032 ring RING1 | Create g8032 ring with name RING1 |
Bridge1(g8032-ring-config)#east-interface xe20 | Associate xe20 interface as east-interface |
Bridge1(g8032-ring-config)#west-interface xe12 | Associate xe12 interface as west-interface |
Bridge1(g8032-ring-config)#g8032 profile profile1 | Create g8032 profile with profile name profile1 |
Bridge1(g8032-profile-config)#timer wait-to-restore 1 | Configure wait to restore time as 1 min |
Bridge1(g8032-profile-config)#timer hold-off 0 | Configure hold-off timer value as 0 |
Bridge1(g8032-profile-config)#timer guard-timer 10 | Configure guard-timer value as 10ms |
Bridge1(g8032-profile-config)#switching mode revertive | Configure Switching mode as revertive Switching mode |
Bridge1(g8032-profile-config)#g8032 erp-instance erp1 | Create g8032 erp instance erp1 |
Bridge1(g8032-config-switch)#ring RING1 | Associate ring RING1 to erp1 instance |
Bridge1(g8032-config-switch)#rpl role non-owner | Configure the node as non-owner node |
Bridge1(g8032-config-switch)#g8032-profile profile1 | Associate Profile profile1 to erp1 instance |
Bridge1(g8032-config-switch)#aps-channel level 7 | Configure level as 7 |
Bridge1(g8032-config-switch)#aps-channel vlan 900 | Configure RAPS channel vlan as 900 |
Bridge1(g8032-config-switch)#data vlan 950 | Configure traffic vlan 950 |
Bridge1(g8032-config-switch)#ring-id 1 | Configure ring-id as 1 |
Bridge1(g8032-config-switch)#commit | Commit the candidate configuration to the running configuration |
Bridge1(g8032-config-switch)#end | Exit g8032 erp instance mode |
Bridge2#configure terminal | Enter configure mode |
Bridge2(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
Bridge2(config)#hardware-profile filter cfm-domain-name-str enable | Enable CFM domain name as string |
Bridge2(config)#vlan database | Configure VLAN database |
Bridge2(config-vlan)# vlan 450 bridge 1 state enable | Create VLAN 450 on bridge 1 |
Bridge2(config-vlan)# vlan 900-1010 bridge 1 state enable | Create VLAN 900-1010 on bridge 1 |
Bridge2(config-vlan)#interface ce9/1 | Configure interface ce9/1 |
Bridge2(config-if)#switchport | Configure ce9/1 as a layer 2 port |
Bridge2(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge2(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge2(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge2(config-if)#switchport trunk allowed vlan add 450,900-1010 | Allow vlan 450,900-1010 on ce9/1 interface |
Bridge2(config-if)#interface ce6/1 | Configure interface ce6/1 |
Bridge2(config-if)#switchport | Configure ce6/1 as a layer 2 port |
Bridge2(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge2(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge2(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge2(config-if)#switchport trunk allowed vlan add 450,900-1010 | Allow vlan 450,900-1010 on ce6/1 interface |
Bridge2(config-if)# ethernet cfm domain-type character-string domain-name mdna1 level 7 mip-creation default | Create cfm domain with type as character string with name mdna1 and set MIP creation criteria to default with level 7 |
Bridge2(config-ether-cfm)#service ma-type string ma-name n27 | Create MA type as string with name n27 |
Bridge2(config-ether-cfm-ma)# vlan 900 bridge 1 | Add VLAN 900 |
Bridge2(config-ether-cfm-ma)# mip-creation default | Set MIP-creation criteria to default |
Bridge2(config-ether-cfm-ma)# ethernet cfm mep down mpid 27 active true ce9/1 | Create down MEP 27 for ce9/1 interface |
Bridge2(config-ether-cfm-ma-mep)#cc multicast state enable | Enable CC multicast |
Bridge2(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet CFM MA-MEP mode |
Bridge2(config-ether-cfm-ma)#mep crosscheck mpid 2027 | Configure crosscheck to remote MEP with value 2027 |
Bridge2(config-ether-cfm-ma)#cc interval 10s | Enable cc interval with 10s |
Bridge2(config-ether-cfm-ma)# exit-ether-ma-mode | Exit Ethernet ma mode |
Bridge2(config-if)# ethernet cfm domain-type character-string domain-name mdna5 level 7 mip-creation default | Create cfm domain with type as character string with name mdna5 and set MIP creation criteria to default with level 7 |
Bridge2(config-ether-cfm)#service ma-type string ma-name n27 | Create MA type as string with name n27 |
Bridge2(config-ether-cfm-ma)# vlan 900 bridge 1 | Add VLAN 900 |
Bridge2(config-ether-cfm-ma)# mip-creation default | Set MIP-creation criteria to default |
Bridge2(config-ether-cfm-ma)# ethernet cfm mep down mpid 6067 active true ce6/1 | Create down MEP 3037 for xe20 interface |
Bridge2(config-ether-cfm-ma-mep)#cc multicast state enable | Enable CC multicast |
Bridge2(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet CFM MA-MEP mode |
Bridge2(config-ether-cfm-ma)#mep crosscheck mpid 67 | Configure crosscheck to remote MEP with value 67 |
Bridge2(config-ether-cfm-ma)#cc interval 10s | Enable cc interval with 10s |
Bridge2(config-ether-cfm-ma)# exit-ether-ma-mode | Exit Ethernet ma mode |
Bridge2(config-ether-cfm)#g8032 ring RING1 | Create g8032 ring with name RING1 on bridge 1 |
Bridge2(g8032-ring-config)#east-interface ce9/1 | Associate ce9/1 interface as east-interface |
Bridge2(g8032-ring-config)#west-interface ce6/1 | Associate ce6/1 interface as west-interface |
Bridge2(g8032-ring-config)#g8032 profile profile1 | Create g8032 profile with profile name profile1 |
Bridge2(g8032-profile-config)#timer wait-to-restore 1 | Configure wait to restore time as 1 min |
Bridge2(g8032-profile-config)#timer hold-off 0 | Configure hold-off timer value as 0 |
Bridge2(g8032-profile-config)#timer guard-timer 10 | Configure guard-timer value as 10ms |
Bridge2(g8032-profile-config)#switching mode revertive | Configure Switching mode as revertive Switching mode |
Bridge2(g8032-profile-config)#g8032 erp-instance erp1 | Create g8032 erp instance erp1 |
Bridge2(g8032-config-switch)#ring RING1 | Associate ring RING1 to erp1 instance |
Bridge2(g8032-config-switch)#rpl role non-owner | Configure the node as non-owner node |
Bridge2(g8032-config-switch)#g8032-profile profile1 | Associate Profile profile1 to erp1 instance |
Bridge2(g8032-config-switch)#aps-channel level 7 | Configure level as 7 |
Bridge2(g8032-config-switch)#aps-channel vlan 900 | Configure RAPS channel vlan as 900 |
Bridge2(g8032-config-switch)#data vlan 950 | Configure traffic vlan 950 |
Bridge2(g8032-config-switch)#ring-id 1 | Configure ring-id as 1 |
Bridge2(g8032-config-switch)#commit | Commit the candidate configuration to the running configuration |
Bridge2(g8032-config-switch)#end | Exit g8032 erp instance mode |
Bridge3#configure terminal | Enter configure mode |
Bridge3(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
Bridge3(config)#hardware-profile filter cfm-domain-name-str enable | Enable CFM domain name as string |
Bridge3(config)#vlan database | Configure VLAN database |
Bridge3(config-vlan)# vlan 450 bridge 1 state enable | Create VLAN 450 on bridge 1 |
Bridge3(config-vlan)# vlan 900-1010 bridge 1 state enable | Create VLAN 900-1010 on bridge 1 |
Bridge3(config-vlan)#interface ce4/1 | Configure interface ce4/1 |
Bridge3(config-if)#switchport | Configure ce4/1 as a layer 2 port |
Bridge3(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge3(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge3(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge3(config-if)#switchport trunk allowed vlan add 450,900-1010 | Allow vlan 450,900-1010 on ce4/1 interface |
Bridge3(config-if)#interface ce7/1 | Configure interface ce7/1 |
Bridge3(config-if)#switchport | Configure ce7/1 as a layer 2 port |
Bridge3(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge3(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge3(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge3(config-if)#switchport trunk allowed vlan add 450,900-1010 | Allow vlan 450,900-1010 on ce7/1 interface |
Bridge3(config-if)# ethernet cfm domain-type character-string domain-name mdna4 level 7 mip-creation default | Create cfm domain with type as character string with name mdna4 and set MIP creation criteria to default with level 7 |
Bridge3(config-ether-cfm)#service ma-type string ma-name n27 | Create MA type as string with name n27 |
Bridge3(config-ether-cfm-ma)# vlan 900 bridge 1 | Add VLAN 900 |
Bridge3(config-ether-cfm-ma)# mip-creation default | Set MIP-creation criteria to default |
Bridge3(config-ether-cfm-ma)# ethernet cfm mep down mpid 5057 active true ce7/1 | Create down MEP 5057 for ce7/1 interface |
Bridge3(config-ether-cfm-ma-mep)#cc multicast state enable | Enable CC multicast |
Bridge3(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet CFM MA-MEP mode |
Bridge3(config-ether-cfm-ma)#mep crosscheck mpid 57 | Configure crosscheck to remote MEP with value 57 |
Bridge3(config-ether-cfm-ma)#cc interval 10s | Enable cc interval with 10s |
Bridge3(config-ether-cfm-ma)# exit-ether-ma-mode | Exit Ethernet ma mode |
Bridge3(config-if)# ethernet cfm domain-type character-string domain-name mdna5 level 7 mip-creation default | Create cfm domain with type as character string with name mdna5 and set MIP creation criteria to default with level 7 |
Bridge3(config-ether-cfm)#service ma-type string ma-name n27 | Create MA type as string with name n27 |
Bridge3(config-ether-cfm-ma)# vlan 900 bridge 1 | Add VLAN 900 |
Bridge3(config-ether-cfm-ma)# mip-creation default | Set MIP-creation criteria to default |
Bridge3(config-ether-cfm-ma)# ethernet cfm mep down mpid 67 active true ce4/1 | Create down MEP 67 for ce4/1 interface |
Bridge3(config-ether-cfm-ma-mep)#cc multicast state enable | Enable CC multicast |
Bridge3(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet CFM MA-MEP mode |
Bridge3(config-ether-cfm-ma)#mep crosscheck mpid 6067 | Configure crosscheck to remote MEP with value 6067 |
Bridge3(config-ether-cfm-ma)#cc interval 10s | Enable cc interval with 10s |
Bridge3(config-ether-cfm-ma)# exit-ether-ma-mode | Exit Ethernet ma mode |
Bridge3(config-ether-cfm)#g8032 ring RING1 | Create g8032 physical ring with name RING1 |
Bridge3(g8032-ring-config)#east-interface ce4/1 | Associate ce4/1 interface as east-interface |
Bridge3(g8032-ring-config)#west-interface ce7/1 | Associate ce7/1 interface as west-interface |
Bridge3(g8032-ring-config)#g8032 profile profile1 | Create g8032 profile with profile name profile1 |
Bridge3(g8032-profile-config)#timer wait-to-restore 1 | Configure wait to restore time as 1 min |
Bridge3(g8032-profile-config)#timer hold-off 0 | Configure hold-off timer value as 0 |
Bridge3(g8032-profile-config)#timer guard-timer 10 | Configure guard-timer value as 10ms |
Bridge3(g8032-profile-config)#switching mode revertive | Configure Switching mode as revertive Switching mode |
Bridge3(g8032-profile-config)#g8032 erp-instance erp1 | Create g8032 erp instance erp1 |
Bridge3(g8032-config-switch)#ring RING1 | Associate ring RING1 to erp1 instance |
Bridge3(g8032-config-switch)#rpl role non-owner | Configure the node as non-owner node |
Bridge3(g8032-config-switch)#g8032-profile profile1 | Associate Profile profile1 to erp1 instance |
Bridge3(g8032-config-switch)#aps-channel level 7 | Configure level as 7 |
Bridge3(g8032-config-switch)#aps-channel vlan 900 | Configure RAPS channel vlan as 900 |
Bridge1(g8032-config-switch)#data vlan 950 | Configure traffic vlan 950 |
Bridge3(g8032-config-switch)#ring-id 1 | Configure ring-id as 1 |
Bridge3(g8032-config-switch)#commit | Commit the candidate configuration to the running configuration |
Bridge3(g8032-config-switch)#end | Exit g8032 erp instance mode |
Bridge4#configure terminal | Enter configure mode |
Bridge4(config)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge4(config-router)#net 49.3600.3600.0001.00 | Configure net |
Bridge4(config-router)#exit | End current mode and down to previous mode |
Bridge4(config)#interface lo | Configure interface loopback |
Bridge4(config-if)#ip address 1.1.1.1/32 secondary | Configure secondary ip address |
Bridge4(config-if)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge4(config-if)#commit | Commit the candidate configuration to the running configuration |
Bridge4(config-if)#exit | End current mode and down to previous mode |
Bridge4(config)#router ldp | Enable LDP protocol |
Bridge4(config-router)#router-id 1.1.1.1 | Set router id |
Bridge4(config-router)#targeted-peer ipv4 2.2.2.2 | Configure targeted peer |
Bridge4(config-router)#exit-targeted-peer-mode | Exit Targeted Peer configuration mode |
Bridge4(config-router)#targeted-peer ipv4 3.3.3.3 | Configure targeted peer |
Bridge4(config-router)#exit-targeted-peer-mode | Exit Targeted Peer configuration mode |
Bridge4(config-router)#transport-address ipv4 1.1.1.1 | Configure a transport address for a label space |
Bridge4(config-router)#commit | Commit the candidate configuration to the running configuration |
Bridge4(config-router)#exit | End current mode and down to previous mode |
Bridge4(config)#mpls vpls vpls450 450 | Create an instance of MPLS based Virtual Private Lan Service (VPLS) |
Bridge4(config-vpls)#signaling ldp | Establishing pseudowires with other PE routers using ldp protocol |
Bridge4(config-vpls-sig)#vpls-peer 2.2.2.2 | Add a peer to VPLS domain |
Bridge4(config-vpls-sig)#vpls-peer 3.3.3.3 | Add a peer to VPLS domain |
Bridge4(config-vpls-sig)#exit-signaling | Exit from Signaling configuration mode and start signaling |
Bridge4(config-vpls)# exit-vpls | Exit from vpls mode |
Bridge4(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
Bridge4(config)#hardware-profile filter cfm-domain-name-str enable | Enable CFM domain name as string |
Bridge4(config)#vlan database | Configure VLAN database |
Bridge4(config-vlan)# vlan 900-1010 bridge 1 state enable | Create VLAN 900-1010 on bridge 1 |
Bridge4(config-vlan)#interface ce20 | Configure interface ce20 |
Bridge4(config-if)#switchport | Configure ce20 as a layer 2 port |
Bridge4(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge4(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge4(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge4(config-if)#switchport trunk allowed vlan add 900-1010 | Allow vlan 900-1010 on ce20 interface |
Bridge4(config-if)#interface interface ce20.450 switchport | Configure interface ce20.450 as L2 subinterface |
Bridge4(config-if)#encapsulation dot1q 450 | Configure dotq encapsulation for vlan 450 packets |
Bridge4(config-if)#access-if-vpls | Enter to VPLS MPLS Access interface mode |
Bridge4(config-acc-if-vpls)#mpls-vpls vpls450 | Attach VPLS instance |
Bridge4(config-acc-if-vpls)#exit | End current mode and down to previous mode |
Bridge4(config-if)#interface xe14 | Configure interface xe14 |
Bridge4(config-if)#switchport | Configure xe14 as a layer 2 port |
Bridge4(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge4(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge4(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge4(config-if)#switchport trunk allowed vlan add 900-1010 | Allow vlan 900-1010 on xe14 interface |
Bridge4(config-if)#interface xe14.450 | Configure sub-interface of xe14 |
Bridge4(config-if)#encapsulation dot1q 450 | Configure dotq encapsulation for vlan 450 packets |
Bridge4(config-if)#ip address 10.1.1.2/30 | Configure ip address |
Bridge4(config-if)#label-switching | Enable label-switching on interface |
Bridge4(config-if)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge4(config-if)#enable-ldp ipv4 | Enable LDP protocol |
Bridge4(config-if)#erps-instance none | Configure erps-instance in this subinterface |
Bridge4(config-if)#interface xe4 | Configure interface xe24 |
Bridge4(config-if)#ip address 30.1.1.2/30 | Configure ip address |
Bridge4(config-if)#label-switching | Enable label-switching on interface |
Bridge4(config-if)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge4(config-if)#enable-ldp ipv4 | Enable LDP protocol |
Bridge1(config-if)# ethernet cfm domain-type character-string domain-name mdna3 level 7 mip-creation default | Create cfm domain with type as character string with name mdna3 and set MIP creation criteria to default with level 7 |
Bridge4(config-ether-cfm)#service ma-type string ma-name n27 | Create MA type as string with name n27 |
Bridge4(config-ether-cfm-ma)#vlan 900 bridge 1 | Add VLAN 900 |
Bridge4(config-ether-cfm-ma)# mip-creation default | Set MIP-creation criteria to default |
Bridge4(config-ether-cfm-ma)# ethernet cfm mep down mpid 4047 active true xe14 | Create down MEP 4047 for xe14 interface |
Bridge4(config-ether-cfm-ma-mep)#cc multicast state enable | Enable CC multicast |
Bridge4(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet CFM MA-MEP mode |
Bridge4(config-ether-cfm-ma)#mep crosscheck mpid 47 | Configure crosscheck to remote MEP with value 47 |
Bridge4(config-ether-cfm-ma)#cc interval 10s | Enable cc interval with 10s |
Bridge4(config-ether-cfm-ma)# exit-ether-ma-mode | Exit Ethernet ma mode |
Bridge4(config-if)# ethernet cfm domain-type character-string domain-name mdna4 level 7 mip-creation default | Create cfm domain with type as character string with name mdna4 and set MIP creation criteria to default with level 7 |
Bridge4(config-ether-cfm)#service ma-type string ma-name n27 | Create MA type as string with name n27 |
Bridge4(config-ether-cfm-ma)# vlan 900 bridge 1 | Add VLAN 900 |
Bridge4(config-ether-cfm-ma)# mip-creation default | Set MIP-creation criteria to default |
Bridge4(config-ether-cfm-ma)# ethernet cfm mep down mpid 57 active true ce20 | Create down MEP 57 for ce20 interface |
Bridge4(config-ether-cfm-ma-mep)#cc multicast state enable | Enable CC multicast |
Bridge4(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet CFM MA-MEP mode |
Bridge4(config-ether-cfm-ma)#mep crosscheck mpid 5057 | Configure crosscheck to remote MEP with value 5057 |
Bridge4(config-ether-cfm-ma)#cc interval 10s | Enable cc interval with 10s |
Bridge4(config-ether-cfm-ma)# exit-ether-ma-mode | Exit Ethernet ma mode |
Bridge4(config-ether-cfm)#g8032 ring RING1 | Create g8032 ring with name RING1 |
Bridge4(g8032-ring-config)#east-interface ce20 | Associate ce20 interface as east-interface |
Bridge4(g8032-ring-config)#west-interface xe14 | Associate xe14 interface as west-interface |
Bridge4(g8032-ring-config)#g8032 profile profile1 | Create g8032 profile with profile name profile1 |
Bridge4(g8032-profile-config)#timer wait-to-restore 1 | Configure wait to restore time as 1 min |
Bridge4(g8032-profile-config)#timer hold-off 0 | Configure hold-off timer value as 0 |
Bridge4(g8032-profile-config)#timer guard-timer 10 | Configure guard-timer value as 10ms |
Bridge4(g8032-profile-config)#switching mode revertive | Configure Switching mode as revertive Switching mode |
Bridge4(g8032-profile-config)#g8032 erp-instance erp1 | Create g8032 erp instance erp1 |
Bridge4(g8032-config-switch)#ring RING1 | Associate ring RING1 to erp1 instance |
Bridge4(g8032-config-switch)#rpl role neighbor west-interface | Configure the node as neighbor towards west-interface |
Bridge4(g8032-config-switch)#g8032-profile profile1 | Associate Profile profile1 to erp1 instance |
Bridge4(g8032-config-switch)#aps-channel level 7 | Configure level as 7 |
Bridge4(g8032-config-switch)#aps-channel vlan 900 | Configure RAPS channel vlan as 900 |
Bridge4(g8032-config-switch)#data vlan 950 | Configure traffic vlan 950 |
Bridge4(g8032-config-switch)#ring-id 1 | Configure ring-id as 1 |
Bridge4(g8032-config-switch)#commit | Commit the candidate configuration to the running configuration |
Bridge4(g8032-config-switch)#end | Exit g8032 erp instance mode |
Bridge5#configure terminal | Enter configure mode |
Bridge5(config)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge5(config-router)# net 49.3600.3600.0002.00 | Configure net |
Bridge5(config-router)#exit | End current mode and down to previous mode |
Bridge5(config)#interface lo | Configure interface loopback |
Bridge5(config-if)# ip address 2.2.2.2/32 secondary | Configure secondary ip address |
Bridge5(config-if)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge5(config-if)#commit | Commit the candidate configuration to the running configuration |
Bridge5(config-if)#exit | End current mode and down to previous mode |
Bridge5(config)#router ldp | Enable LDP protocol |
Bridge5(config-router)#router-id 2.2.2.2 | Set router id |
Bridge5(config-router)#targeted-peer ipv4 1.1.1.1 | Configure targeted peer |
Bridge5(config-router)#exit-targeted-peer-mode | Exit Targeted Peer configuration mode |
Bridge5(config-router)#targeted-peer ipv4 3.3.3.3 | Configure targeted peer |
Bridge5(config-router)#exit-targeted-peer-mode | Exit Targeted Peer configuration mode |
Bridge5(config-router)#transport-address ipv4 2.2.2.2 | Configure a transport address for a label space |
Bridge5(config-router)#commit | Commit the candidate configuration to the running configuration |
Bridge5(config-router)#exit | End current mode and down to previous mode |
Bridge5(config)#mpls vpls vpls450 450 | Create an instance of MPLS based Virtual Private Lan Service (VPLS) |
Bridge5(config-vpls)#signaling ldp | Establishing pseudowires with other PE routers using ldp protocol |
Bridge5(config-vpls-sig)#vpls-peer 1.1.1.1 | Add a peer to VPLS domain |
Bridge5(config-vpls-sig)#vpls-peer 3.3.3.3 | Add a peer to VPLS domain |
Bridge5(config-vpls-sig)#exit-signaling | Exit from Signaling configuration mode and start signaling |
Bridge5(config-vpls)# exit-vpls | Exit from vpls mode |
Bridge5(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
Bridge5(config)#hardware-profile filter cfm-domain-name-str enable | Enable CFM domain name as string |
Bridge5(config)#vlan database | Configure VLAN database |
Bridge5(config-vlan)# vlan 900-1010 bridge 1 state enable | Create VLAN 900-1010 on bridge 1 |
Bridge5(config-vlan)#interface xe15 | Configure interface xe15 |
Bridge5(config-if)#switchport | Configure xe15 as a layer 2 port |
Bridge5(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge5(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge5(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge5(config-if)#switchport trunk allowed vlan add 900-1010 | Allow vlan 900-1010 on xe15 interface |
Bridge5(config-if)#interface interface xe15.450 switchport | Configure interface xe15.450 as L2 subinterface |
Bridge5(config-if)#encapsulation dot1q 450 | Configure dotq encapsulation for vlan 450 packets |
Bridge5(config-if)#access-if-vpls | Enter to VPLS MPLS Access interface mode |
Bridge5(config-acc-if-vpls)#mpls-vpls vpls450 | Attach VPLS instance |
Bridge5(config-acc-if-vpls)#exit | End current mode and down to previous mode |
Bridge5(config-if)#interface xe0 | Configure interface xe0 |
Bridge5(config-if)#switchport | Configure xe0 as a layer 2 port |
Bridge5(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge5(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge5(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge5(config-if)#switchport trunk allowed vlan add 900-1010 | Allow vlan 900-1010 on xe0 interface |
Bridge5(config-if)#interface xe0.450 | Configure sub-interface of xe0 |
Bridge5(config-if)#encapsulation dot1q 450 | Configure dotq encapsulation for vlan 450 packets |
Bridge5(config-if)#ip address 10.1.1.1/30 | Configure ip address |
Bridge5(config-if)#label-switching | Enable label-switching on interface |
Bridge5(config-if)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge5(config-if)#enable-ldp ipv4 | Enable LDP protocol |
Bridge5(config-if)#erps-instance none | Configure erps-instance in this subinterface |
Bridge5(config-if)#interface xe22 | Configure interface xe24 |
Bridge5(config-if)#ip address 20.1.1.1/30 | Configure ip address |
Bridge5(config-if)#label-switching | Enable label-switching on interface |
Bridge5(config-if)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge5(config-if)#enable-ldp ipv4 | Enable LDP protocol |
Bridge5(config-if)# ethernet cfm domain-type character-string domain-name mdna2 level 7 mip-creation default | Create cfm domain with type as character string with name mdna2 and set MIP creation criteria to default with level 7 |
Bridge5(config-ether-cfm)#service ma-type string ma-name n27 | Create MA type as string with name n27 |
Bridge5(config-ether-cfm-ma)#vlan 900 bridge 1 | Add VLAN 900 |
Bridge5(config-ether-cfm-ma)# mip-creation default | Set MIP-creation criteria to default |
Bridge5(config-ether-cfm-ma)# ethernet cfm mep down mpid 37 active true xe15 | Create down MEP 37 for xe15 interface |
Bridge5(config-ether-cfm-ma-mep)#cc multicast state enable | Enable CC multicast |
Bridge5(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet CFM MA-MEP mode |
Bridge5(config-ether-cfm-ma)#mep crosscheck mpid 3037 | Configure crosscheck to remote MEP with value 3037 |
Bridge5(config-ether-cfm-ma)#cc interval 10s | Enable cc interval with 10s |
Bridge5(config-ether-cfm-ma)# exit-ether-ma-mode | Exit Ethernet ma mode |
Bridge5(config-if)# ethernet cfm domain-type character-string domain-name mdna3 level 7 mip-creation default | Create cfm domain with type as character string with name mdna3 and set MIP creation criteria to default with level 7 |
Bridge5(config-ether-cfm)#service ma-type string ma-name n27 | Create MA type as string with name n27 |
Bridge5(config-ether-cfm-ma)# vlan 900 bridge 1 | Add VLAN 900 |
Bridge5(config-ether-cfm-ma)# mip-creation default | Set MIP-creation criteria to default |
Bridge5(config-ether-cfm-ma)# ethernet cfm mep down mpid 47 active true xe0 | Create down MEP 47 for xe0 interface |
Bridge5(config-ether-cfm-ma-mep)#cc multicast state enable | Enable CC multicast |
Bridge5(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet CFM MA-MEP mode |
Bridge5(config-ether-cfm-ma)#mep crosscheck mpid 4047 | Configure crosscheck to remote MEP with value 4047 |
Bridge5(config-ether-cfm-ma)#cc interval 10s | Enable cc interval with 10s |
Bridge5(config-ether-cfm-ma)# exit-ether-ma-mode | Exit Ethernet ma mode |
Bridge5(config-ether-cfm)#g8032 ring RING1 | Create g8032 ring with name RING1 |
Bridge5(g8032-ring-config)#east-interface xe0 | Associate ce20 interface as east-interface |
Bridge5(g8032-ring-config)#west-interface xe15 | Associate xe14 interface as west-interface |
Bridge5(g8032-ring-config)#g8032 profile profile1 | Create g8032 profile with profile name profile1 |
Bridge5(g8032-profile-config)#timer wait-to-restore 1 | Configure wait to restore time as 1 min |
Bridge5(g8032-profile-config)#timer hold-off 0 | Configure hold-off timer value as 0 |
Bridge5(g8032-profile-config)#timer guard-timer 10 | Configure guard-timer value as 10ms |
Bridge5(g8032-profile-config)#switching mode revertive | Configure Switching mode as revertive Switching mode |
Bridge5(g8032-profile-config)#g8032 erp-instance erp1 | Create g8032 erp instance erp1 |
Bridge5(g8032-config-switch)#ring RING1 | Associate ring RING1 to erp1 instance |
Bridge5(g8032-config-switch)#rpl role owner east-interface | Configure the node as owner towards east-interface |
Bridge5(g8032-config-switch)#g8032-profile profile1 | Associate Profile profile1 to erp1 instance |
Bridge5(g8032-config-switch)#aps-channel level 7 | Configure level as 7 |
Bridge5(g8032-config-switch)#aps-channel vlan 900 | Configure RAPS channel vlan as 900 |
Bridge5(g8032-config-switch)#data vlan 950 | Configure traffic vlan 950 |
Bridge5(g8032-config-switch)#ring-id 1 | Configure ring-id as 1 |
Bridge5(g8032-config-switch)#commit | Commit the candidate configuration to the running configuration |
Bridge5(g8032-config-switch)#end | Exit g8032 erp instance mode |
Bridge6#configure terminal | Enter configure mode |
Bridge6(config)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge6(config-router)# net 49.3600.3600.0003.00 | Configure net |
Bridge6(config-router)#exit | End current mode and down to previous mode |
Bridge6(config)#interface lo | Configure interface loopback |
Bridge6(config-if)# ip address 3.3.3.3/32 secondary | Configure secondary ip address |
Bridge6(config-if)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge6(config-if)#commit | Commit the candidate configuration to the running configuration |
Bridge6(config-if)#exit | End current mode and down to previous mode |
Bridge6(config)#router ldp | Enable LDP protocol |
Bridge6(config-router)#router-id 3.3.3.3 | Set router id |
Bridge6(config-router)#targeted-peer ipv4 1.1.1.1 | Configure targeted peer |
Bridge6(config-router)#exit-targeted-peer-mode | Exit Targeted Peer configuration mode |
Bridge6(config-router)#targeted-peer ipv4 2.2.2.2 | Configure targeted peer |
Bridge6(config-router)#exit-targeted-peer-mode | Exit Targeted Peer configuration mode |
Bridge6(config-router)#transport-address ipv4 3.3.3.3 | Configure a transport address for a label space |
Bridge6(config-router)#commit | Commit the candidate configuration to the running configuration |
Bridge6(config-router)#exit | End current mode and down to previous mode |
Bridge6(config)#mpls vpls vpls450 450 | Create an instance of MPLS based Virtual Private Lan Service (VPLS) |
Bridge6(config-vpls)#signaling ldp | Establishing pseudowires with other PE routers using ldp protocol |
Bridge6(config-vpls-sig)#vpls-peer 1.1.1.1 | Add a peer to VPLS domain |
Bridge6(config-vpls-sig)#vpls-peer 2.2.2.2 | Add a peer to VPLS domain |
Bridge6(config-vpls-sig)#exit-signaling | Exit from Signaling configuration mode and start signaling |
Bridge6(config-vpls)# exit-vpls | Exit from vpls mode |
Bridge6(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
Bridge6(config)#hardware-profile filter cfm-domain-name-str enable | Enable CFM domain name as string |
Bridge6(config)#vlan database | Configure VLAN database |
Bridge6(config-vlan)# vlan 450 bridge 1 state enable | Create VLAN 450 on bridge 1 |
Bridge6(config-vlan)# vlan 900-1010 bridge 1 state enable | Create VLAN 900-1010 on bridge 1 |
Bridge6(config-vlan)#interface xe4 | Configure interface xe4 |
Bridge6(config-if)#switchport | Configure xe4 as a layer 2 port |
Bridge6(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
Bridge6(config-if)#bridge-group 1 spanning-tree disable | Disable spanning tree for bridge group 1 on that interface |
Bridge6(config-if)#switchport mode trunk | Configure port as trunk port |
Bridge6(config-if)#switchport trunk allowed vlan add 900-1010 | Allow vlan 900-1010 on xe4 interface |
Bridge6(config-if)#interface interface xe4.450 switchport | Configure interface xe4.450 as L2 subinterface |
Bridge6(config-if)#encapsulation dot1q 450 | Configure dotq encapsulation for vlan 450 packets |
Bridge6(config-if)#access-if-vpls | Enter to VPLS MPLS Access interface mode |
Bridge6(config-acc-if-vpls)#mpls-vpls vpls450 | Attach VPLS instance |
Bridge6(config-acc-if-vpls)#exit | End current mode and down to previous mode |
Bridge6(config-if)#interface xe2 | Configure sub-interface of xe2 |
Bridge6(config-if)#ip address 20.1.1.2/30 | Configure ip address |
Bridge6(config-if)#label-switching | Enable label-switching on interface |
Bridge6(config-if)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge6(config-if)#enable-ldp ipv4 | Enable LDP protocol |
Bridge6(config-if)#interface xe5 | Configure interface xe24 |
Bridge6(config-if)#ip address 30.1.1.1/30 | Configure ip address |
Bridge6(config-if)#label-switching | Enable label-switching on interface |
Bridge6(config-if)#ip router isis 1 | Enable routing process - Intermediate System (IS-IS) |
Bridge6(config-if)#enable-ldp ipv4 | Enable LDP protocol |
Bridge6(config-if)#commit | Commit the candidate configuration to the running configuration |
Bridge6(config-if)#end | Exit g8032 erp instance mode |