OcNOS-SP : Layer 3 Guide : Virtual Router Redundancy Protocol Configuration Guide : VRRP Configuration : VRRP Over MLAG
VRRP Over MLAG
This section contains VRRP over MLAG configuration examples.
In this configuration TOR1 and TOR2 forms the VRRP master/backup relationship over MLAG interface.
Topology
 
Figure 1-180: VRRP over MLAG
SW1
 
#config terminal
Enter the Configure mode.
(config)#hostname SW1
Assign the hostname for the router.
SW1(config)# bridge 1 protocol rstp vlan-bridge
Create bridge
SW1(config)#vlan database
Enter to VLAN database
SW1(config-vlan)#vlan 2-1002 bridge 1 state enable
Create VLANs
SW1(config-vlan)#exit
Exit the VLAN database mode
SW1(config)# int po1
Enter the interface mode
SW1(config-if)#switchport
Configure the interface as Layer 2
SW1(config-if)# bridge-group 1
Assign the bridge to the interface.
SW1(config-if)#switchport mode trunk
Configure the interface as trunk mode
SW1(config-if)#switchport trunk allowed vlan all
Configure the interface to allow all VLAN IDs
(config-if)#commit
Commit the candidate configuration to the running configuration.
SW1(config-if)#exit
Exit the interface mode
SW1(config)# int xe15
Enter the interface mode
SW1(config-if)# channel-group 1 mode active
Add the interface as member of LAG interface
SW1(config-if)# int xe31
Enter the interface mode
SW1(config-if)# channel-group 1 mode active
Add the interface as member of LAG interface
SW1(config-if)# int xe36
Enter the interface mode
SW1(config-if)#switchport
Configure the interface as Layer 2
SW1(config-if)# bridge-group 1
Assign the bridge to the interface.
SW1(config-if)#switchport mode trunk
Configure the interface as trunk mode
SW1(config-if)#switchport trunk allowed vlan all
Configure the interface to allow all VLAN IDs
SW1(config-if)#exit
Exit the interface mode
SW1(config-if)#commit
Commit the candidate configuration to the running configuration.
SW1(config-if)#exit
Exit the interface mode.
TOR1
 
#config terminal
Enter the Config terminal
(config)#hostname TOR1
Assign the hostname to the router
TOR1(config)# bridge 1 protocol rstp vlan-bridge
Configure the bridge
TOR1(config)#vlan database
Enter the VLAN database
TOR1(config-vlan)#vlan 2-1002 bridge 1 state enable
Configure VLANs
TOR1(config-vlan)#commit
Commit the candidate configuration to the running configuration.
TOR1(config-vlan)#exit
Exit the VLAN database
TOR1(config)# int po1
Enter the interface mode
TOR1(config-if)#switchport
Configure the interface as L2
TOR1(config-if)# bridge-group 1
Assign the bridge to the interface
TOR1(config-if)#switchport mode trunk
Configure the interface as trunk mode
TOR1(config-if)#switchport trunk allowed vlan all
Configure to allow all the VLANs
TOR1(config-if)#commit
Commit the candidate configuration to the running configuration.
TOR1(config-if)#exit
Exit the interface mode
TOR1(config)# int xe15
Enter the interface mode
TOR1(config-if)# channel-group 1 mode active
Assign the interface as member of LAG interface
TOR1(config-if)#exit
Exit the interface mode
TOR1(config)#interface xe7
Enter interface mode.
TOR1(config)#switchport
Configure as switchport L2 interface.
TOR1(config)#mcec domain configuration
Enter the MCEC mode
TOR1(config-mcec-domain)#domain-system-number 1
Assign the domain system number for MLAG interface.
TOR1(config-mcec-domain)#domain-address 1111.2222.3333
Assign the domain address
TOR1(config-mcec-domain)#domain-hello-timeout short
Assign the domain hello timeout
TOR1(config-mcec-domain)#intra-domain-link xe7
Assign the interface as IDL
TOR1(config-mcec-domain)#commit
Commit the candidate configuration to the running configuration.
TOR1(config-mcec-domain)#exit
Exit the MCEC domain
TOR1(config)#interface lo
Enter the interface mode
TOR1(config-if)#ip add 1.1.1.1/32 secondary
Assign IP address to the interface
TOR1(config-if)#int xe11
Enter the interface mode
TOR1(config-if)#ip add 20.20.20.1/24
Assign IP address to the interface
TOR1(config-if)#commit
Commit the candidate configuration to the running configuration.
TOR1(config-if)#exit
Exit the interface mode
TOR1(config)#router ospf 100
Configure the routing process and specify the process ID (100). The process ID should be a unique integer.
TOR1(config-router)#network 20.20.20.1/24 area 0
Add the network to the OSPF process
TOR1(config-router)#network 1.1.1.1/32 area 0
Define one interface (1.1.1.1/32) on which OSPF runs and associate the area ID (0).
TOR1(config-router)#redistribute connected
Redistribute the connected routes
TOR1(config-router)#commit
Commit the candidate configuration to the running configuration
TOR1(config-router)#exit
Exit the OSPF process
TOR1(config)#interface mlag1
Enter mlag1 interface
TOR1(config)#switchport
Configure as switchport L2 interface
TOR1(config)#bridge-group 1
Assign the bridge to the interface
TOR1(config)#switchport mode trunk
Make the interface trunk mode
TOR1(config)#switchport trunk allowed vlan all
Configure to allow all vlans
TOR1(config)#int po1
Enter the interface mode
TOR1(config-if)#mlag 1
Redistribute the connected routes
TOR1(config-if)#exit
Exit the interface mode
TOR1(config)#int vlan1.2
Enter interface mode
TOR1(config-if)#ip address 10.10.10.1/24
Assign IP address
TOR1(config-if)#exit
Exit the interface mode
TOR1(config)#router vrrp 1 vlan1.2
Create the VRRP process
TOR1(config-router)# virtual-ip 10.10.10.1 owner
Assign the virtual IP address to VRRP
TOR1(config-router)#enable
Enable the VRRP process
TOR1(config-router)#commit
Commit the candidate configuration to the running configuration.
TOR1(config-router)#exit
Exit the VRRP mode
TOR2
 
#config terminal
Enter the Config terminal
(config)#hostname TOR2
Assign the hostname to the router
TOR2(config)# bridge 1 protocol rstp vlan-bridge
Configure the bridge
TOR2(config)#vlan database
Enter the VLAN database
TOR2(config-vlan)#vlan 2-1002 bridge 1 state enable
Configure VLANs
TOR2(config-vlan)#commit
Commit the candidate configuration to the running configuration.
TOR2(config-vlan)#exit
Exit the VLAN database
TOR2(config)# int po1
Enter the interface mode
TOR2(config-if)#switchport
Configure the interface as L2
TOR2(config-if)# bridge-group 1
Assign the bridge to the interface
TOR2(config-if)#switchport mode trunk
Configure the interface as trunk mode
TOR2(config-if)#switchport trunk allowed vlan add 2
Configure to add the VLAN 2 to the receiving packet.
TOR2(config-if)#commit
Commit the candidate configuration to the running configuration.
TOR2(config-if)#exit
Exit the interface mode
TOR2(config)# int xe32
Enter the interface mode
TOR2(config-if)# channel-group 1 mode active
Assign the interface as member of LAG interface
TOR2(config-if)#exit
Exit the interface mode
TOR2(config)#interface xe7
Enter interface mode
TOR2(config)#switchport
Configure as switchport L2 interface
TOR2(config)#mcec domain configuration
Enter the MCEC mode
TOR2(config-mcec-domain)#domain-system-number 2
Assign the domain system number for MLAG interface.
TOR2(config-mcec-domain)#domain-address 1111.2222.3333
Assign the domain address
TOR2(config-mcec-domain)#domain-hello-timeout short
Assign the domain hello timeout
TOR2(config-mcec-domain)#intra-domain-link xe7
Assign the interface as IDL
TOR2(config-mcec-domain)#commit
Commit the candidate configuration to the running configuration.
TOR2(config-mcec-domain)#exit
Exit the MCEC domain
TOR2(config)#interface mlag1
Enter mlag1 interface
TOR2(config)#switchport
Configure as switchport L2 interface
TOR2(config)#bridge-group 1
Assign the bridge to the interface
TOR2(config)#switchport mode trunk
Make the interface trunk mode
TOR2(config)#switchport trunk allowed vlan all
Configure to allow all vlans
TOR2(config)# int po1
Enter the interface mode
TOR2(config-if)# mlag 1
Create the MLAG interface.
TOR2(config-if)#commit
Commit the candidate configuration to the running configuration.
TOR2(config-if)#exit
Exit the interface mode
TOR2(config)#interface lo
Enter the interface mode
TOR2(config-if)#ip add 2.2.2.2/32 secondary
Assign IP address to the interface
TOR2(config-if)#int xe5
Enter the interface mode
TOR2(config-if)#ip add 30.30.30.1/24
Assign IP address to the interface
TOR2(config-if)#commit
Commit the candidate configuration to the running configuration.
TOR2(config-if)#exit
Exit the interface mode
TOR2(config)#router ospf 100
Enter the OSPF router mode
TOR2(config-router)#network 30.30.30.1/24 area 0
Add the network to the OSPF process
TOR2(config-router)#network 2.2.2.2/32 area 0
Add the network to the OSPF process
TOR2(config-router)#redistribute connected
Redistribute the connected routes
TOR2(config-router)#commit
Commit the candidate configuration to the running configuration.
TOR2(config-router)#exit
Exit the OSPF process
TOR2(config)#int vlan1.2
Enter interface mode
TOR2(config-if)#ip address 10.10.10.2/24
Assign IP address
TOR2(config-if)#exit
Exit the interface mode
TOR2(config)#router vrrp 1 vlan1.2
Create the VRRP process
TOR2(config-router)# virtual-ip 10.10.10.1
Assign the virtual IP address to VRRP
TOR2(config-router)#enable
Enable the VRRP process
TOR2(config-router)#commit
Commit the candidate configuration to the running configuration.
TOR2(config-router)#exit
Exit the VRRP mode
SW2
 
#config terminal
Enter the Config terminal
(config)#hostname SW2
Assign the hostname to the router
SW2(config)# bridge 1 protocol rstp vlan-bridge
Configure the bridge
SW2(config)#vlan database
Enter the VLAN database
SW2(config-vlan)#vlan 2-1002 bridge 1 state enable
Configure VLANs
SW2(config-vlan)#commit
Commit the candidate configuration to the running configuration.
SW2(config-vlan)#exit
Exit the VLAN database
SW2(config)# int xe11
Enter the interface mode
SW2(config-if)#ip address 20.20.20.2/24
Assign IP address to the interface
SW2(config-if)# int xe5
Enter the interface mode
SW2(config-if)#ip address 30.30.30.2/24
Assign IP address to the interface
SW2(config-if)#commit
Commit the candidate configuration to the running configuration.
SW2(config-if)# int xe46
Enter the interface mode
SW2(config-if)#ip address 40.40.40.1/24
Assign IP address to the interface
SW2(config-if)#int lo
Enter the interface mode
SW2(config-if)#ip add 3.3.3.3/32 secondary
Assign IP address to the interface
SW2(config-if)#int xe32
Enter the interface mode
SW2(config-if)#ip add 50.50.50.2/24
Assign IP address to the interface
SW2(config-if)#exit
Exit interface mode
SW2(config)# router ospf 100
Enter OSPF router
SW2(config-router)# network 3.3.3.3/32 area 0
Add the IP address to the OSPF process
SW2(config-router)# network 20.20.20.0/24 area 0
Add the IP address to the OSPF process
SW2(config-router)# network 30.30.30.0/24 area 0
Add the IP address to the OSPF process
SW2(config-router)#network 50.50.50.2/24 area 0
Add the IP address to the OSPF process
SW2(config-router)#commit
Commit the candidate configuration to the running configuration.
SW2(config-router)#exit
Exit the OSPF mode
Validation
TOR1
TOR1#show mlag domain summary
 
------------------------------------
Domain Configuration
------------------------------------
 
Domain System Number : 1
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : xe7
Domain Adjacency : UP
Domain Sync via : Intra-domain-interface
------------------------------------
MLAG Configuration
------------------------------------
 
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 54 a9 3a 2a 2b 50 65 bb 3c bc 3d bd c2 43 d6 22
Total Bandwidth : 10g
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Active
Switchover-mode : Revertive
 
TOR1#show vrrp 1 vlan1.2
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled
 
Address family IPv4
VRRP Id: 1 on interface: vlan1.2
State: AdminUp - Master
Virtual IP address: 10.10.10.1 (Owner)
Virtual MAC address is 0000.5e00.0101
Operational primary IP address: 10.10.10.1
Operational master IP address: 10.10.10.1
Priority is 255
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 5 minutes 11 seconds (31100 centi sec)
Master uptime: 0 hours 5 minutes 11 seconds (31100 centi sec)
Accept mode: TRUE
Preempt mode: TRUE
Auth-type: simple text, String: abcd
Multicast membership on IPv4 interface vlan1.2: JOINED
V2-Compatible: TRUE
 
TOR2
TOR2#show mlag domain summary
 
------------------------------------
Domain Configuration
------------------------------------
 
Domain System Number : 2
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : xe7
Domain Adjacency : UP
Domain Sync via : Intra-domain-interface
------------------------------------
MLAG Configuration
------------------------------------
 
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 54 a9 3a 2a 2b 50 65 bb 3c bc 3d bd c2 43 d6 22
Total Bandwidth : 10g
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Standby
Switchover-mode : Revertive
 
TOR2#show vrrp 1 vlan1.2
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled
 
Address family IPv4
VRRP Id: 1 on interface: vlan1.2
State: AdminUp - Backup
Virtual IP address: 10.10.10.1 (Not-owner)
Virtual MAC address is 0000.5e00.0101
Operational primary IP address: 10.10.10.2
Operational master IP address: 10.10.10.1
Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 6 minutes 27 seconds (38700 centi sec)
Skew time: 80 centi sec
Master Down Interval: 380 centi sec
Preempt mode: TRUE
Auth-type: simple text, String: abcd
Multicast membership on IPv4 interface vlan1.2: JOINED
V2-Compatible: TRUE
Session is on MLAG interface. Dataplane acting as Master
 
Last modified date: 08/28/2023