OcNOS-SP : Layer 3 Guide : Layer 3 Unicast Configuration Guide : BGP : Nexthop Tracking Delay Timer
Nexthop Tracking Delay Timer
The delay interval between routing table walks can be configured for nexthop delay tracking. This time determines how long BGP waits before it starts walking the full BGP routing table after receiving notification from NSM about a next-hop change.
Topology
Figure 1-27: Topology for Nexthop Tracking Delay Timer
R1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the loopback interface, and enter Interface mode.
(config-if)#ip address 150.150.150.150/32 secondary
Configure the IP address on this interface.
(config-if)#ip address 100.100.100.100/32 secondary
Configure the IP address on this interface.
(config-if)#exit
Exit interface mode.
(config)#router bgp 200
Assign the ASN value (200) to the router. The ASN range is <1-65535>.
(config-router)#neighbor 200.200.200.200 remote-as 200
Specify the neighbor's IP address (200.200.200.200) and the ASN value of the neighbor (200).
(config-router)#neighbor 200.200.200.200 update-source lo
Specify the routing update source.
(config-router)# address-family ipv4 unicast
Enter address-family ipv4 unicast mode
(config-router-af)# neighbor 200.200.200.200 activate
Activate neighbor under address family mode
(config-router-af)# exit-address-family
Exit address family mode
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the loopback interface, and enter Interface mode.
(config-if)#ip address 150.150.150.150/32 secondary
Configure the IP address on this interface.
(config-if)#ip address 100.100.100.100/32 secondary
Configure the IP address on this interface.
(config-if)#exit
Exit interface mode.
(config)#commit
Commit the candidate configuration to the running configuration.
(config)#router ospf 1
Configure the OSPF process (1).
(config-router)#network 172.4.5.0/24 area 0
Advertise the network in Area 0.
(config-router)#redistribute connected
Redistribute the connected routes.
(config-router)#commit
Commit the candidate configuration to the running configuration.
R2
 
#configure terminal
Enter configure mode.
(config)#router ospf 1
Configure the OSPF process (1).
(config-router)#network 172.4.5.0/24 area 0
Advertise the network in Area 0.
(config-router)#network 172.6.7.0/24 area 0
Advertise the network in Area 0.
(config-router)#commit
Commit the candidate configuration to the running configuration.
R3
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the loopback interface, and enter Interface mode.
(config-if)#ip address 200.200.200.200/32
Configure the IP address on this interface.
(config-if)#exit
Exit interface mode.
(config)#router bgp 200
Assign the ASN value (200) to the router.
(config-router)#neighbor 100.100.100.100 remote-as 200
Specify the neighbor's IP address (100.100.100.100) and the ASN value of the neighbor (200).
(config-router)#neighbor 100.100.100.100 update-source 200.200.200.200
Specify the routing update source.
(config-router)#neighbor 220.220.220.220 remote-as 200
Specify the neighbor's IP address (220.220.220.220) and the ASN value of the neighbor (200).
(config-router)#neighbor 220.220.220.220 update-source 150.150.150.150
Specify the routing update source.
(config-router)# address-family ipv4 unicast
Enter address-family ipv4 unicast mode
(config-router-af)# neighbor 100.100.100.100 activate
Activate neighbor under address family mode
(config-router-af)# neighbor 220.220.220.220 activate
Activate neighbor under address family mode
(config-router-af)# exit-address-family
Exit address family mode
(config-router)#exit
Exit Router mode, and return to Configure mode.
(config)#router ospf 1
Configure the OSPF process (1).
(config-router)#network 172.6.7.0/24 area 0
Advertise the network in Area 0.
(config-router)#network 172.1.2.0/24 area 0
Advertise the network in Area 0.
(config-router)#redistribute connected
Redistribute the connected routes.
(config-router)#exit
Exit Router mode, and return to Configure mode.
(config-router)#commit
Commit the candidate configuration to the running configuration.
(config)#bgp nexthop-trigger enable
Enable nexthop tracking.
(config)#bgp nexthop-trigger delay 20
Configure the nexthop trigger-delay time interval.
R4
 
#configure terminal
Enter configure mode.
(config)#router ospf 1
Configure the OSPF process (1).
(config-router)#network 172.1.2.0/24 area 0
Advertise the network in Area 0.
(config-router)#network 172.3.4.0/24 area 0
Advertise the network in Area 0.
(config-router)#commit
Commit the candidate configuration to the running configuration.
R5
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the loopback interface, and enter Interface mode.
(config-if)#ip address 220.220.220.220/32
Configure the IP address on this interface.
(config-if)#exit
Exit interface mode.
(config)#router bgp 200
Assign the ASN value (200) to the router.
(config-router)#neighbor 150.150.150.150 remote-as 200
Specify the neighbor's IP address (150.150.150.150) and the ASN value of the neighbor (200).
(config-router)#neighbor 150.150.150.150 update-source lo
Specify the routing update source.
(config-router)# address-family ipv4 unicast
Enter address-family ipv4 unicast mode
(config-router-af)# neighbor 150.150.150.150 activate
Activate neighbor under address family mode
(config-router-af)# exit-address-family
Exit address family mode
(config-router)#exit
Exit Router mode, and return to Configure mode.
(config)#router ospf 1
Configure the OSPF process (1).
(config-router)#network 172.3.4.0/24 area 0
Advertise the network in Area 0.
(config-router)#redistribute connected
Redistribute the connected routes.
(config-router)#commit
Commit the candidate configuration to the running configuration.
Validation
R1
#show ip bgp summary
BGP router identifier 10.12.20.71, local AS number 200
BGP table version is 1
0 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
200.200.200.200 4 200 15 16 1 0 0 00:06:37 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
#show ip bgp neighbors
BGP neighbor is 200.200.200.200, remote AS 200, local AS 200, internal link
BGP version 4, local router ID 10.12.20.71, remote router ID 200.200.200.200
BGP state = Established, up for 00:06:40
Last read 00:06:40, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Received 15 messages, 0 notifications, 0 in queue
Sent 16 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
Connections established 1; dropped 0
Local host: 100.100.100.100, Local port: 37676
Foreign host: 200.200.200.200, Foreign port: 179
Nexthop: 100.100.100.100
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
#show bgp nexthop-tracking
Configured NHT: DISABLED
NHT Delay time-interval : 5
BGP VRF: (Default) VRF_ID 0
BGP Instance: (Default), AS: 200, router-id 10.12.20.71
 
#show ip bgp scan
BGP VRF: (Default) VRF_ID 0
BGP scan interval is 60
scan remain-time: 38
Current BGP nexthop cache:
R3
#show ip bgp summary
BGP router identifier 200.200.200.200, local AS number 200
BGP table version is 1
0 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
100.100.100.100 4 200 17 19 1 0 0 00:07:41 0
220.220.220.220 4 200 95 101 1 0 0 00:07:12 0
 
Total number of neighbors 2
 
Total number of Established sessions 2
 
#show ip bgp neighbors
BGP neighbor is 100.100.100.100, remote AS 200, local AS 200, internal link
BGP version 4, local router ID 200.200.200.200, remote router ID 10.12.20.71
BGP state = Established, up for 00:07:46
Last read 00:07:46, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Received 17 messages, 0 notifications, 0 in queue
Sent 19 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is 200.200.200.200
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
Connections established 1; dropped 0
Local host: 200.200.200.200, Local port: 179
Foreign host: 100.100.100.100, Foreign port: 37676
Nexthop: 200.200.200.200
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
BGP neighbor is 220.220.220.220, remote AS 200, local AS 200, internal link
BGP version 4, remote router ID 220.220.220.220
local router ID 200.200.200.200
BGP state = Established, up for 00:07:17
Last read 00:07:17, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Received 94 messages, 1 notifications, 0 in queue
Sent 97 messages, 4 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is 150.150.150.150
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 2, Offset 0, Mask 0x4
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
Connections established 6; dropped 5
Local host: 150.150.150.150, Local port: 39831
Foreign host: 220.220.220.220, Foreign port: 179
Nexthop: 150.150.150.150
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Last Reset: 00:07:22, due to BGP Notification received
Notification Error Message: (Cease/Other Configuration Change.)
 
#show bgp nexthop-tracking
Configured NHT: ENABLED
NHT Delay time-interval : 20
BGP VRF: (Default) VRF_ID 0
BGP Instance: (Default), AS: 200, router-id 200.200.200.200
NHT is Enabled
Recvd Msg count from RIB: 0
NHT delay-timer remaining seconds: 0
BGP nexthop(s):
Total number of IPV4 nexthops : 0
Total number of IPV6 nexthops : 0
 
#show ip bgp scan
BGP VRF: (Default) VRF_ID 0
BGP scan interval is 60
scan remain-time: 11
Current BGP nexthop cache:
R5
#show ip bgp summary
BGP router identifier 220.220.220.220, local AS number 200
BGP table version is 1
0 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
150.150.150.150 4 200 99 101 1 0 0 00:08:26 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
#show ip bgp neighbors
BGP neighbor is 150.150.150.150, remote AS 200, local AS 200, internal link
BGP version 4, local router ID 220.220.220.220, remote router ID 200.200.200.200
BGP state = Established, up for 00:08:29
Last read 00:08:29, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Received 96 messages, 3 notifications, 0 in queue
Sent 99 messages, 2 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
Connections established 6; dropped 5
Local host: 220.220.220.220, Local port: 179
Foreign host: 150.150.150.150, Foreign port: 39831
Nexthop: 220.220.220.220
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Last Reset: 00:08:34, due to BGP Notification sent
Notification Error Message: (Cease/Other Configuration Change.)
 
#show bgp nexthop-tracking
Configured NHT: DISABLED
NHT Delay time-interval : 5
BGP VRF: (Default) VRF_ID 0
BGP Instance: (Default), AS: 200, router-id 220.220.220.220
 
#show ip bgp scan
BGP VRF: (Default) VRF_ID 0
BGP scan interval is 60
scan remain-time: 22
Current BGP nexthop cache:
Last modified date: 10/16/2023