OcNOS-SP : Layer 3 Guide : Layer 3 Unicast Configuration Guide : BGP : BGP Dampening
BGP Dampening
BGP supports route dampening for IPv4 and IPv6 prefixes. Route dampening minimizes the instability caused by route flapping. A penalty is added for every flap in a flapping route. As soon as the total penalty reaches the suppress limit, the advertisement of the route is suppressed. This penalty is decayed according to the configured half time value. Once the penalty is lower than the reuse limit, the route advertisement is unsuppressed. The dampening information is purged from the router once the penalty becomes less than half of the reuse limit.
Topology
In this example, a successful TCP connection is being established between the routers.
Figure 1-37: BGP dampening
IPv4 Configuration
R1
 
#configure terminal
Enter configure mode
(config)#interface lo
Enter loopback interface mode
(config-if)#ip address 1.1.1.1/32 secondary
Configure the secondary loopback address
(config-if)#exit
Exit interface mode
(config)#interface eth2
Enter interface mode
(config-if)#ip address 10.1.1.1/24
Configure the IP address of the interface
(config-if)#exit
Exit interface mode
(config)#interface eth1
Enter interface mode
(config-if)#ip address 101.1.0.1/24
Configure the IP address of the interface
(config-if)#exit
Exit interface mode
(config)#commit
Commit the candidate configuration to the running configuration.
(config)#router bgp 100
Configure BGP with the AS number 100
(config-router)#neighbor 10.1.1.2 remote-as 200
Define the BGP neighbor, and establish a TCP session.
10.1.1.2 is the IP address of one of the neighbors (R2), and 200 is the neighbor's AS number.
 
(config-router)#neighbor 100.1.0.2 remote-as 300
Define the BGP neighbor, and establish a TCP session.
100.1.0.2 is the IP address of one of the neighbors on interface eth1, and 300 is the neighbor's AS number.
 
(config-router)# address-family ipv4 unicast
Enter address-family ipv4 unicast mode
(config-router-af)#redistribute connected
Enable redistribute connected
(config-router-af)#neighbor 10.1.1.2 activate
Activate the neighbor
(config-router-af)#neighbor 100.1.0.2 activate
Activate the neighbor
(config-router-af)#exit-address-family
Exit address-family mode
(config-router)#commit
Commit the candidate configuration to the running configuration.
R2
 
#configure terminal
Enter configure mode
(config)#interface lo
Enter loopback interface mode
(config-if)# ip address 2.2.2.2/32 secondary
Configure the secondary loopback address
(config-if)#exit
Exit interface mode
(config)#interface eth1
Enter interface mode
(config-if)#ip address 10.1.1.2/24
Configure the IP address of the interface
(config-if)#exit
Exit interface mode
(config)#interface eth2
Enter interface mode
(config-if)#ip address 101.1.0.1/24
Configure the IP address of the interface
(config-if)#exit
Exit interface mode
(config)#commit
Commit the candidate configuration to the running configuration.
(config)#router bgp 200
Configure BGP with the AS number 100
(config-router)#neighbor 10.1.1.1 remote-as 100
Define the BGP neighbor, and establish a TCP session. 10.1.1.1 is the IP address of one of the neighbors (R1), and 100 is the neighbor's AS number.
(config-router)#neighbor 101.1.0.2 remote-as 400
Define the BGP neighbor, and establish a TCP session.101.1.0.2 is the IP address of one of the neighbors on eth2 interface, and 400 is the neighbor's AS number.
(config-router)#neighbor 100.1.0.2 remote-as 300
Define the BGP neighbor, and establish a TCP session.
100.1.0.2 is the IP address of one of the neighbors of router R1 on eth1 interface, and 300 is the neighbor's AS number.
(config-router)#neighbor 100.1.0.2 ebgp-multihop 2
Increase BGP neighbors with ebgp-multihop value
(config-router)# address-family ipv4 unicast
Enter address-family ipv4 unicast mode
(config-router-af)#neighbor 10.1.1.1 activate
Activate BGP neighbor
(config-router-af)#neighbor 101.1.0.2 activate
Activate BGP neighbor
(config-router-af)#redistribute connected
Enable redistribute connected
(config-router-af)#bgp dampening
Enable BGP dampening with default values:
Reachability half-life is 15 minutes
Reuse limit is 750:
Suppress limit is 2000
Max-suppress value is 60 minutes
Un-reachability half-life is 15 minutes
(config-router-af)#exit-address-family
Exit address-family mode
(config-router)#commit
Commit the candidate configuration to the running configuration.
Validation
R2
Verify the BGP dampening parameters.
#show ip bgp dampening parameters
 
dampening 15 750 2000 60 15 Dampening Control Block(s):
Reachability Half-Life time : 15 min Reuse penalty : 750
Suppress penalty : 2000
Max suppress time : 60 min Un-reachability Half-Life time : 15 min Max penalty (ceil) : 11999
Min penalty (floor) : 375
Verify BGP dampened paths for flapping networks.
#show ip bgp dampening dampened-paths
BGP table version is 21, local router ID is 4.4.4.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network From Reuse Path
d 200.1.0.0 10.1.1.1 00:29:00 100 300 i
d 200.2.0.0 10.1.1.1 00:28:20 100 300 i
d 200.3.0.0 10.1.1.1 00:28:20 100 300 i
d 200.4.0.0 10.1.1.1 00:28:20 100 300 i
d 200.5.0.0 10.1.1.1 00:28:20 100 300 i
d 200.6.0.0 10.1.1.1 00:28:20 100 300 i
d 200.7.0.0 10.1.1.1 00:28:20 100 300 i
d 200.8.0.0 10.1.1.1 00:28:20 100 300 i
d 200.9.0.0 10.1.1.1 00:28:20 100 300 i
d 200.10.0.0 10.1.1.1 00:28:20 100 300 i
Verify BGP dampening flap statistics for flapping networks.
 
#show ip bgp dampening flap-statistics
BGP table version is 21, local router ID is 4.4.4.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network From Flaps Duration Reuse Path
d 200.1.0.0 10.1.1.1 8 00:18:37 00:29:10 100 300 i
d 200.2.0.0 10.1.1.1 7 00:14:22 00:29:00 100 300 i
d 200.3.0.0 10.1.1.1 7 00:14:22 00:29:00 100 300 i
d 200.4.0.0 10.1.1.1 7 00:14:22 00:29:00 100 300 i
d 200.5.0.0 10.1.1.1 7 00:14:22 00:29:00 100 300 i
d 200.6.0.0 10.1.1.1 7 00:14:22 00:29:00 100 300 i
d 200.7.0.0 10.1.1.1 7 00:14:22 00:29:00 100 300 i
d 200.8.0.0 10.1.1.1 7 00:14:22 00:29:00 100 300 i
d 200.9.0.0 10.1.1.1 7 00:14:22 00:29:00 100 300 i
d 200.10.0.0 10.1.1.1 7 00:14:22 00:29:00 100 300 i
IPv6 Configuration
R1
 
#configure terminal
Enter configure mode
(config)#interface eth1
Enter interface mode
(config-if)#ipv6 address 2000:0:0:1::1/64
Configure the IPv6 address of the interface
(config-if)#exit
Exit interface mode
(config)#interface eth2
Enter interface mode
(config-if)#ip address 2000:0:2:1::1/64
Configure the IPv6 address of the interface
(config-if)#exit
Exit interface mode
(config)#router bgp 100
Configure BGP with the AS number 100
(config-router)#neighbor 2000:0:0:1::2 remote-as 300
Define the BGP neighbor, and establish a TCP session. 2000:0:0:1::2 is the IP address of one of the neighbors on interface eth1, and 300 is the neighbor's AS number.
(config-router)#neighbor 2000:0:2:1::2 remote-as 200
Define the BGP neighbor, and establish a TCP session. 2000:0:2:1::2 is the IP address of one of the neighbors (R2), and 200 is the neighbor's AS number.
(config-router)#address-family ipv6 unicast
Enter IPv6 address family
(config-router)#redistribute connected
Enable redistribute connected
(config-router-af)neighbor 2000:0:0:1::2 activate
Activate BGP neighbor
(config-router-af)neighbor 2000:0:2:1::2 activate
Activate BGP neighbor
(config-router-af)#exit-address-family
Exit address-family mode
(config-router)#commit
Commit the candidate configuration to the running configuration.
R2
 
#configure terminal
Enter configure mode
(config)#interface eth1
Enter interface mode
(config-if)#ip address 2000:0:2:1::2/64
Configure the IPv6 address of the interface
(config-if)#exit
Exit interface mode
(config)#interface eth2
Enter interface mode
(config-if)#ip address 2000:0:1:1::1/64
Configure the IPv6 address of the interface
(config-if)#exit
Exit interface mode
(config)#router bgp 200
Configure BGP with the AS number 200
(config-router)#address-family ipv6 unicast
Enter IPv6 address family
(config-router-af)#redistribute connected
Enable redistribute connected
(config-router-af)#exit-address-family
Exit address-family mode.
(config-router)#neighbor 2000:0:1:1::2 remote-as 400
Define the BGP neighbor, and establish a TCP session. 2000:0:1:1::2 is the IP address of one of the neighbors on interface eth2, and 400 is the neighbor's AS number.
(config-router)#neighbor 2000:0:2:1::1 remote-as 100
Define the BGP neighbor, and establish a TCP session. 2000:0:2:1::1 is the IP address of one of the neighbors (R1), and 100 is the neighbor's AS number.
(config-router)#address-family ipv6 unicast
Enter IPv6 address-family
(config-router-af)#bgp dampening
Enable BGP dampening with default values:
Reachability half-life is 15 minutes
Reuse limit is 750
Suppress limit is 2000
Max-suppress value is 60 minutes
Un-reachability half-life is 15 minutes
(config-router-af)#neighbor 2000:0:1:1::2 activate
Activate BGP neighbor
(config-router-af)#neighbor 2000:0:2:1::1 activate
Activate BGP neighbor
(config-router-af)#exit-address-family
Exit address-family mode
(config-router)#commit
Commit the candidate configuration to the running configuration.
Validation
R2
Verify the IPv6 BGP dampening parameters.
#sh bgp dampening parameters
 
dampening 15 750 2000 60 15
Dampening Control Block(s):
Reachability Half-Life time : 15 min
Reuse penalty : 750
Suppress penalty : 2000
Max suppress time : 60 min
Un-reachability Half-Life time : 15 min
Max penalty (ceil) : 11999
Min penalty (floor) : 375
Verify IPv6 BGP dampened paths for flapping networks.
#sh bgp dampening dampened-paths
BGP table version is 7, local router ID is 4.4.4.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network From Reuse Path
*d 3000:0:1:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
00:18:30 100 300 i
*d 3000:0:2:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
00:18:30 100 300 i
*d 3000:0:3:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
00:18:30 100 300 i
*d 3000:0:4:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
00:18:30 100 300 i
*d 3000:0:5:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
00:18:30 100 300 i
*d 3000:0:6:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
00:18:30 100 300 i
*d 3000:0:7:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
00:18:30 100 300 i
*d 3000:0:8:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
00:18:30 100 300 i
*d 3000:0:9:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
00:18:30 100 300 i
*d 3000:0:a:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
00:18:30 100 300 i
Verify IPv6 BGP dampening flap statistics for flapping networks.
#sh bgp dampening flap-statistics
BGP table version is 7, local router ID is 4.4.4.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network From Flaps Duration Reuse Path
*d 3000:0:1:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
4 00:05:19 00:18:30 100 300 i
*d 3000:0:2:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
4 00:05:19 00:18:30 100 300 i
*d 3000:0:3:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
4 00:05:19 00:18:30 100 300 i
*d 3000:0:4:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
4 00:05:19 00:18:30 100 300 i
*d 3000:0:5:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
4 00:05:19 00:18:30 100 300 i
*d 3000:0:6:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
4 00:05:19 00:18:30 100 300 i
*d 3000:0:7:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
4 00:05:19 00:18:30 100 300 i
*d 3000:0:8:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
4 00:05:19 00:18:30 100 300 i
*d 3000:0:9:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
4 00:05:19 00:18:30 100 300 i
*d 3000:0:a:1::/64 2000:0:2:1::1(fe80::ba6a:97ff:fed6:23d4)
4 00:05:19 00:18:30 100 300 i
Last modified date: 10/16/2023