Area Border Router
This example shows configuration for an Area Border Router. R2 is an Area Border Router (ABR). On R2, Interface eth2 is in Area 0, and Interface eth1 is in Area 1.
Topology
Figure 8-66: OSPF ABR Topology
Configuration
R2
#configure terminal | Enter configure mode |
(config)#router ospf 100 | Configure the routing process, and specify the Process ID (100). The Process ID should be a unique positive integer. |
(config-router)#network 10.10.10.0/24 area 0 | Define one interface (10.10.10.0/24) on which OSPF runs, and associate the area ID (0) with the interface. |
(config-router)#network 10.10.11.0/24 area 1 | Define the other interface (10.10.11.0/24) on which OSPF runs, and associate the area ID (1) with the interface. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
Validation
R2
#show running-config
!
no service password-encryption
!
hostname R2
!
logging monitor 7
!
ip vrf management
!
ip domain-lookup
!
ip pim register-rp-reachability
!
interface lo
mtu 65536
ip address 127.0.0.1/8
ipv6 address ::1/128
!
interface eth0
ip address 10.12.26.89/24
!
interface eth1
ip address 10.10.11.11/24
!
interface eth2
ip address 10.10.10.11/24
!
interface eth3
!
interface eth4
!
interface eth5
!
interface eth6
!
router ospf 100
network 10.10.10.0/24 area 0.0.0.0
network 10.10.11.0/24 area 0.0.0.1
!
line con 0
login
line vty 0 39
login
!
end
#sh ip ospf
Routing Process "ospf 100" with ID 10.12.26.89
Process uptime is 4 minutes
Process bound to VRF default
Conforms to RFC2328, and RFC1583 Compatibility flag is disabled
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Graceful Restart
This router is an ABR, ABR Type is Alternative Cisco (RFC3509)
SPF schedule delay initial 0 secs 500 msecs
SPF schedule delay min 0 secs 500 msecs
SPF schedule delay max 50 secs 0 msecs
Refresh timer 10 secs
Number of incomming current DD exchange neighbors 0/64
Number of outgoing current DD exchange neighbors 0/64
Initial LSA throttle delay 0 secs 0 msecs
Minimum hold time for LSA throttle 5 secs 0 msecs
Maximum wait time for LSA throttle 5 secs 0 msecs
Minimum LSA arrival 1 secs 0 msecs
Number of external LSA 0. Checksum 0x000000
Number of opaque AS LSA 0. Checksum 0x000000
Number of non-default external LSA 0
External LSA database is unlimited.
Number of LSA originated 9
Number of LSA received 18
Number of areas attached to this router: 2
Area 0.0.0.0 (BACKBONE)
Number of interfaces in this area is 1(1)
Number of fully adjacent neighbors in this area is 2
Area has no authentication
SPF algorithm last executed 00:01:54.085 ago
SPF algorithm executed 7 times
Number of LSA 11. Checksum 0x0428ac
Area 0.0.0.1
Number of interfaces in this area is 1(1)
Number of fully adjacent neighbors in this area is 1
Number of fully adjacent virtual neighbors through this area is 0
Area has no authentication
SPF algorithm last executed 00:00:41.737 ago
SPF algorithm executed 3 times
Number of LSA 8. Checksum 0x043ce4
Dste Staus: Disabled
#show ip ospf interface
eth2 is up, line protocol is up
Internet Address 10.10.10.11/24, Area 0.0.0.0, MTU 1500
Process ID 100, VRF (default), Router ID 10.12.26.89, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1, TE Metric 1
Designated Router (ID) 10.12.26.89, Interface Address 10.10.10.11
Backup Designated Router (ID) 10.12.26.88, Interface Address 10.10.10.10
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:11
Neighbor Count is 2, Adjacent neighbor count is 2
Suppress hello for 0 neighbor(s)
Hello received 66 sent 38, DD received 11 sent 7
LS-Req received 2 sent 2, LS-Upd received 15 sent 14
LS-Ack received 14 sent 10, Discarded 0
No authentication
eth1 is up, line protocol is up
Internet Address 10.10.11.11/24, Area 0.0.0.1, MTU 1500
Process ID 100, VRF (default), Router ID 10.12.26.89, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State Backup, Priority 1, TE Metric 1
Designated Router (ID) 10.12.26.92, Interface Address 10.10.11.13
Backup Designated Router (ID) 10.12.26.89, Interface Address 10.10.11.11
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:03
Neighbor Count is 1, Adjacent neighbor count is 1
Suppress hello for 0 neighbor(s)
Hello received 22 sent 24, DD received 3 sent 9
LS-Req received 1 sent 1, LS-Upd received 4 sent 5
LS-Ack received 4 sent 3, Discarded 0
No authentication
#show ip ospf neighbor
Total number of full neighbors: 3
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.12.26.88 1 Full/Backup 00:00:34 10.10.10.10 eth2 0
10.12.26.90 1 Full/DROther 00:00:32 10.10.10.12 eth2 0
10.12.26.92 1 Full/DR 00:00:33 10.10.11.13 eth1 0
#show ip ospf database
OSPF Router with ID (10.12.26.89) (Process ID 100 VRF default)
Router Link States (Area 0.0.0.0)
Link ID ADV Router Age Seq# CkSum Link count
10.12.26.88 10.12.26.88 365 0x80000005 0x10bc 1
10.12.26.89 10.12.26.89 312 0x80000006 0x0fb8 1
10.12.26.90 10.12.26.90 363 0x80000003 0x10b8 1
Net Link States (Area 0.0.0.0)
Link ID ADV Router Age Seq# CkSum
10.10.10.11 10.12.26.89 364 0x80000002 0xe7fd
Summary Link States (Area 0.0.0.0)
Link ID ADV Router Age Seq# CkSum Route
10.10.11.0 10.12.26.89 312 0x80000001 0x95fd 10.10.11.0/24
Area-Local Opaque-LSA (Area 0.0.0.0)
Link ID ADV Router Age Seq# CkSum Opaque ID
1.0.0.1 10.12.26.88 363 0x80000003 0xa972 1
1.0.0.1 10.12.26.89 362 0x80000003 0xad6c 1
1.0.0.1 10.12.26.90 363 0x80000001 0xb564 1
1.0.0.10 10.12.26.88 363 0x80000003 0x0a32 10
1.0.0.10 10.12.26.89 362 0x80000002 0x2417 10
1.0.0.10 10.12.26.90 363 0x80000001 0x3efb 10
Router Link States (Area 0.0.0.1)
Link ID ADV Router Age Seq# CkSum Link count
10.12.26.89 10.12.26.89 245 0x80000004 0x3d88 1
10.12.26.92 10.12.26.92 241 0x80000004 0x2698 1
Net Link States (Area 0.0.0.1)
Link ID ADV Router Age Seq# CkSum
10.10.11.13 10.12.26.92 246 0x80000001 0x6ffb
Summary Link States (Area 0.0.0.1)
Link ID ADV Router Age Seq# CkSum Route
10.10.10.0 10.12.26.89 312 0x80000001 0xa0f3 10.10.10.0/24
Area-Local Opaque-LSA (Area 0.0.0.1)
Link ID ADV Router Age Seq# CkSum Opaque ID
1.0.0.1 10.12.26.89 243 0x80000001 0xb16a 1
1.0.0.1 10.12.26.92 244 0x80000001 0xbd58 1
1.0.0.8 10.12.26.89 234 0x80000002 0x96a2 8
1.0.0.8 10.12.26.92 244 0x80000001 0xc272 8