OcNOS-SP : Layer 3 Guide : Layer 3 Unicast Configuration Guide : OSPFv3 : Redistribute Routes into OSPFv3
Redistribute Routes into OSPFv3
In this example, the BGP routes are imported into the OSPF routing table, and advertised as Type 5 External LSAs into Area 0.
Topology
Figure 12-89: OSPFv3 Redistribute Routes
Configuration
R5
(config)#router bgp 2
Configure router bgp instance
(config-router)# neighbor 5ffe:10::10 remote-as 1
Configure R1 as ipv6 BGP neighbor
(config-router)# neighbor 5ffe:10::10 ebgp-multihop 4
Configure the ebgp -multihop for the ebgp neighbor R1
(config-router)# address-family ipv6 unicast
 
(config-router-af)# neighbor 5ffe:10::10 activate
Activate the BGP neighbor on R1 for address-family ipv6 unicast to advertise and receive ipv6 routes
(config-router-af)#exit
Exit mode
(config-router)#commit
Commit the candidate configuration to the running configuration.
R1
 
#configure terminal
Enter configure mode.
(config)#router bgp 2
Configure router bgp instance
(config-router)# neighbor 5ffe:10::55 remote-as 2
Configure R5 as ipv6 BGP neighbor
(config-router)# neighbor 5ffe:10::55 ebgp-multihop 4
Configure the ebgp -multihop for the ebgp neighbor R5
(config-router)# address-family ipv6 unicast
 
(config-router-af)# neighbor 5ffe:10::55 activate
Activate the BGP neighbor on R5 for address-family ipv6 unicast to advertise and receive ipv6 routes
(config-router-af)#exit
Exit address-family ipv6 unicast mode
(config-router)#exit
Exit router bgp mode
(config)#router ipv6 ospf
Create an OSPFv3 routing instance.
(config-router)#router-id 10.10.10.10
Specify a Router ID (10.10.10.10) for the OSPFv3 routing process.
(config-router)#redistribute bgp
Specify redistributing routes from the other routing protocol (BGP) into OSPFv3.
(config-router)#exit
Exit OSPF router mode.
(config)#interface eth12
Enter interface mode.
(config-if)#ipv6 router ospf area 0
Enable OSPFv3 routing on an interface, and assign the Area ID (0).
(config-router)#commit
Commit the candidate configuration to the running configuration.
Validation
R2
R2#show ipv6 ospf neighbor
 
Total number of full neighbors: 3
OSPFv3 Process (*null*)
Neighbor ID Pri State Dead Time Interface Instance ID
10.10.10.12 1 Full/Backup 00:00:31 eth1 0
10.10.10.10 1 Full/Backup 00:00:32 eth2 0
10.10.10.13 10 Full/DR 00:00:31 eth2 0
R2#
 
R2#show ipv6 ospf database
 
OSPFv3 Router with ID (10.10.10.11) (Process *null*)
 
Link-LSA (Interface eth1)
 
Link State ID ADV Router Age Seq# CkSum Prefix
0.0.0.3 10.10.10.11 1327 0x80000006 0x9384 1
0.0.0.3 10.10.10.12 1180 0x80000006 0x1d21 1
 
Link-LSA (Interface eth2)
 
Link State ID ADV Router Age Seq# CkSum Prefix
0.0.0.4 10.10.10.10 348 0x80000008 0x8e91 1
0.0.0.4 10.10.10.11 300 0x80000008 0x33b6 1
0.0.0.4 10.10.10.13 387 0x80000009 0xcdee 1
 
Router-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum Link
0.0.0.0 10.10.10.10 24 0x8000000d 0xe6ad 1
0.0.0.0 10.10.10.11 1321 0x8000000b 0xe1b4 1
0.0.0.0 10.10.10.13 287 0x8000000b 0xd2c2 1
 
Network-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum
0.0.0.4 10.10.10.13 287 0x80000009 0x98b7
 
Inter-Area-Prefix-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum
0.0.0.1 10.10.10.11 1321 0x80000006 0xd2a4
 
Intra-Area-Prefix-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum Prefix Reference
0.0.0.2 10.10.10.13 287 0x80000009 0xcb47 1 Network-LSA
 
Intra-Area-Te-LSA (Area 0.0.0.0)
 
Link State ID ADV Router Age Seq# CkSum
0.0.0.4 10.10.10.10 284 0x8000000a 0x42ff
0.0.0.4 10.10.10.11 281 0x8000000a 0x6ed1
0.0.0.4 10.10.10.13 287 0x8000000a 0xc675
 
Router-LSA (Area 0.0.0.1)
 
Link State ID ADV Router Age Seq# CkSum Link
0.0.0.0 10.10.10.11 1165 0x80000008 0x9b02 1
0.0.0.0 10.10.10.12 1162 0x80000008 0x920b 1
 
Network-LSA (Area 0.0.0.1)
 
Link State ID ADV Router Age Seq# CkSum
0.0.0.3 10.10.10.11 1165 0x80000006 0x0c77
 
Inter-Area-Prefix-LSA (Area 0.0.0.1)
 
Link State ID ADV Router Age Seq# CkSum
0.0.0.1 10.10.10.11 1320 0x80000007 0xc2b4
 
Inter-Area-Router-LSA (Area 0.0.0.1)
 
Link State ID ADV Router Age Seq# CkSum
0.0.0.1 10.10.10.11 25 0x80000005 0x941a
 
Intra-Area-Prefix-LSA (Area 0.0.0.1)
 
Link State ID ADV Router Age Seq# CkSum Prefix Reference
0.0.0.2 10.10.10.11 1165 0x80000006 0xcd4c 1 Network-LSA
 
Intra-Area-Te-LSA (Area 0.0.0.1)
 
Link State ID ADV Router Age Seq# CkSum
0.0.0.3 10.10.10.11 1165 0x80000007 0x66df
0.0.0.3 10.10.10.12 1162 0x80000007 0xf64b
 
AS-external-LSA
 
Link State ID ADV Router Age Seq# CkSum Route Tag
0.0.0.1 10.10.10.10 65 0x80000002 0x284a E2 0
 
R2#
 
R2#show ipv6 ospfv3 topology
 
OSPFv3 Process (*null*)
OSPFv3 paths to Area (0.0.0.0) routers
Router ID Bits Metric Next-Hop Interface
10.10.10.10 E 1 10.10.10.10 eth2
10.10.10.11 B --
10.10.10.13 1 10.10.10.13 eth2
 
OSPFv3 paths to Area (0.0.0.1) routers
Router ID Bits Metric Next-Hop Interface
10.10.10.11 B --
10.10.10.12 1 10.10.10.12 eth1
 
R2#
 
R2#show ipv6 ospf route
OSPFv3 Process (*null*)
Codes: C - connected, D - Discard, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
 
Destination Metric
Next-hop
E2 2000::/64 1/20
via fe80::5054:ff:fe2b:20b7, eth2
C 3ffe:10::/64 1
directly connected, eth2, Area 0.0.0.0
C 3ffe:11::/64 1
directly connected, eth1, Area 0.0.0.1
R2#
 
R2#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 03:49:59
O E2 2000::/64 [110/20] via fe80::5054:ff:fe2b:20b7, eth2, 00:36:38
C 3ffe:10::/64 via ::, eth2, 03:46:32
C 3ffe:11::/64 via ::, eth1, 03:01:21
C fe80::/64 via ::, eth9, 03:49:59
R2#
 
 
R3
R3#show ipv6 ospf route
OSPFv3 Process (*null*)
Codes: C - connected, D - Discard, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
 
Destination Metric
Next-hop
E2 2000::/64 1/20
via fe80::5054:ff:fe2b:20b7, eth2
C 3ffe:10::/64 1
directly connected, eth2, Area 0.0.0.0
IA 3ffe:11::/64 2
via fe80::5054:ff:fe3d:e317, eth2, Area 0.0.0.0
R3#
 
R3#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 03:51:07
O E2 2000::/64 [110/20] via fe80::5054:ff:fe2b:20b7, eth2, 00:37:50
C 3ffe:10::/64 via ::, eth2, 03:47:35
O IA 3ffe:11::/64 [110/2] via fe80::5054:ff:fe3d:e317, eth2, 02:58:53
C fe80::/64 via ::, eth9, 03:51:07
R3#
R4
R4#show ipv6 ospf route
OSPFv3 Process (*null*)
Codes: C - connected, D - Discard, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
 
Destination Metric
Next-hop
E2 2000::/64 2/20
via fe80::5054:ff:fe0e:46b7, eth1
IA 3ffe:10::/64 2
via fe80::5054:ff:fe0e:46b7, eth1, Area 0.0.0.1
C 3ffe:11::/64 1
directly connected, eth1, Area 0.0.0.1
R4#
R4#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 03:15:06
O E2 2000::/64 [110/20] via fe80::5054:ff:fe0e:46b7, eth1, 00:39:34
O IA 3ffe:10::/64 [110/2] via fe80::5054:ff:fe0e:46b7, eth1, 02:57:53
C 3ffe:11::/64 via ::, eth1, 03:04:04
C fe80::/64 via ::, eth9, 03:15:06
R4#
Last modified date: 10/16/2023