#configure terminal | Enter configuration mode. |
(config)#ip vrf ripv2 | Configure ip vrf |
(config-vrf)#rd 1:1 | Configure rd |
(config-vrf)#route-target both 1:100 | Configure rt value |
(config-vrf)#int xe48 | Enter in to interface |
(config-if)#ip vrf forwarding ripv2 | Enable ip vrf forwarding |
(config-if)#ip address 10.10.10.1/24 | Configure ip address |
(config-if)#router rip | Enter in to router rip |
(config-router)#address-family ipv4 vrf ripv2 | Address family ipv4 with vrf name |
(config-router-af)#network 10.10.10.0/24 | Configure network command |
(config-router-af)#redistribute static | Configure Redistribute static |
(config-router-af)#redistribute connected | Configure Redistribute connected |
(config-router-af)#commit | Commit the transactions |
(config)#ip route vrf ripv2 191.1.1.10/32 xe48 | Configure static route with vrf |
(config)#commit | Commit the transaction |
#configure terminal | Enter configuration mode. |
(config)#ip vrf ripv2 | Configure ip vrf |
(config-vrf)#rd 1:1 | Configure rd |
(config-vrf)#route-target both 1:100 | Configure rt value |
(config-vrf)#int xe10 | Enter in to interface |
(config-if)#ip vrf forwarding ripv2 | Enable ip vrf forwarding |
(config-if)#ip address 10.10.10.2/24 | Configure ip address |
(config-if)#router rip | Enter in to router rip |
(config-router)#address-family ipv4 vrf ripv2 | Address family ipv4 with vrf name |
(config-router-af)#network 10.10.10.0/24 | Configure network command |
(config-router-af)#redistribute static | Configure Redistribute static |
(config-router-af)#redistribute connected | Configure Redistribute connected |
(config-router-af)#commit | Commit the transactions |