#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 44.44.44.44/32 secondary | Assign the IPv4 address |
(config-if)#exit | Exit interface mode |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ipv6 address 2001::2/64 | Assign the IPv6 address. |
(config-if)#exit | Exit interface mode. |
(config)#ipv6 route 2ffe::/64 xe1 | Advertise IPv6 static route. |
(config)#router bgp 200 | Enter BGP router mode. |
(config-router)#bgp router-id 44.44.44.44 | Configure bgp router-id |
(config-router)#neighbor 2001::1 remote-as 100 | Configure 6VPE1 as an eBGP4+ neighbor. |
(config-router)#address-family ipv6 unicast | Enter address-family IPv6 unicast mode. |
(config-router-af)#neighbor 2001::1 activate | Activate the neighbor in the IPv6 address family. |
(config-router-af)#redistribute connected | Redistribute the connected route under address family IPv6 unicast. |
(config-router-af)#redistribute static | Redistribute static routes. |
(config-router-af)#commit | Commit the transaction. |
#configure terminal | Enter configure mode |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 66.66.66.66/32 secondary | Assign the IPv4 address |
(config-if)#exit | Exit interface mode |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ipv6 address 3001::2/64 | Assign the IPv6 address. |
(config-if)#exit | Exit interface mode. |
(config)#ipv6 route 3ffe::/64 xe1 | Configure IPV6 static route |
(config)#router bgp 300 | Enter BGP router mode. |
(config-router)#bgp router-id 66.66.66.66 | Configure BGP router-id |
(config-router)#neighbor 3001::1 remote-as 100 | Configure 6VPE1 as an eBGP4+ neighbor. |
(config-router)#address-family ipv6 unicast | Enter address-family IPv6 unicast mode. |
(config-router-af)#neighbor 3001::1 activate | Activate the neighbor in the IPv6 address family. |
(config-router-af)#redistribute connected | Redistribute the connected route under address family IPv6 unicast. |
(config-router-af)#redistribute static | Redistribute static routes. |
(config-router-af)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#ip vrf IPI | Create a new VRF named IPI. |
(config-vrf)#rd 1:100 | Assign the route distinguisher (RD) value as 1:100. |
(config-vrf)#route-target both 100:200 | Import routes between route target (RT) ext-communities 100 and 200. |
(config-vrf)#router-id 77.77.77.77 | Configure router-id for VRF |
(config-vrf)#exit | Exit VRF mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip vrf forwarding IPI | Bind the interface connected to the CE router with VRF IPI. |
(config-if)#ipv6 address 2001::1/64 | Assign the IPv6 address. |
(config-if)#exit | Exit interface mode. |
(config)#router bgp 100 | Enter BGP router mode. |
(config-router)#bgp router-id 1.1.1.1 | Configure BGP router-id |
(config-router)#neighbor 3.3.3.3 remote-as 100 | Configure 6VPE2 as an iBGP peer. |
(config-router)#neighbor 3.3.3.3 update-source lo | Update the source as loopback for iBGP peering with the remote 6VPE router. |
(config-router)#address-family ipv4 unicast | Enter address family mode |
(config-router-af)#neighbor 3.3.3.3 activate | Activate the neighbor |
(config-router-af)#exit-address-family | Exit address family mode |
(config-router)#address-family vpnv6 unicast | Enter VPNv6 address family mode. |
(config-router-af)#neighbor 3.3.3.3 activate | Activate the 6VPE neighbor so that it can accept VPN IPv6 routes. |
(config-router-af)#exit-address-family | Exit VPNv6 address family mode. |
(config-router)#address-family ipv6 vrf IPI | Enter the IPv6 address family for VRF IPI. |
(config-router-af)#neighbor 2001::2 remote-as 200 | Activate CE inside IPv6 address family for vrf IPI. |
(config-router-af)#neighbor 2001::2 activate | Activate the 6VPE neighbor so that it can accept VPN IPv6 routes. |
(config-router-af)#redistribute connected | Redistribute the connected route under address family IPv6 for VRF IPI. |
(config-router-af)#exit-address-family | Exit IPv6 Address Family mode. |
(config-router)#exit | Exit router mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 1.1.1.1/32 secondary | Assign the IP address to loopback interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ldp | Enter router LDP mode. |
(config-router)#router-id 1.1.1.1 | Set the router ID to IP address 1.1.1.1 |
(config-router)#transport-address ipv4 1.1.1.1 | Configure transport address as loopback address. |
(config-router)#targeted-peer ipv4 3.3.3.3 | Configure targeted peer. |
(config-router-targeted-peer)#exit | Exit-targeted-peer-mode |
(config-router)#exit | Exit router LDP mode. |
(config)#router rsvp | Enter RSVP router mode. |
(config-router)#exit | Exit router mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#label-switching | Enable label switching in interface. |
(config-if)#enable-rsvp | Enable RSVP in interface. |
(config-if)#enable-ldp ipv4 | Enable LDP in interface. |
(config-if)#ip address 20.10.10.1/24 | Assign IP address to interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 100 | Enter OSPF router mode. |
(config-router)#ospf router-id 1.1.1.1 | Configure OSPF router id same as loopback ip address. |
(config-router)#network 1.1.1.1/32 area 0 (config-router)#network 20.10.10.1/24 area 0 | Define the network on which OSPF runs and associate area id. |
(config-router)#exit | Exit OSPF router mode. |
(config)#rsvp-trunk toPE2 | Enter the trunk mode for RSVP. |
(config-trunk)#to 3.3.3.3 | Specify IPv4 Egress for the LSP. |
(config-trunk)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 2.2.2.2/32 secondary | Assign the IP address to loopback interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ldp | Enter router LDP mode. |
(config-router)#router-id 2.2.2.2 | Set the router ID to IP address 2.2.2.2 |
(config-router)#transport-address ipv4 2.2.2.2 | Configure transport address as loopback address. |
(config-router)#exit | Exit router mode. |
(config)#router rsvp | Enter RSVP router mode. |
(config-router)#exit | Exit router mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#label-switching | Enable label switching in interface. |
(config-if)#enable-rsvp | Enable RSVP in interface. |
(config-if)#enable-ldp ipv4 | Enable LDP in interface. |
(config-if)#ip address 20.10.10.2/24 | Assign IP address to interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#label-switching | Enable label switching in interface. |
(config-if)#enable-rsvp | Enable RSVP in interface. |
(config-if)#enable-ldp ipv4 | Enable ldp in interface. |
(config-if)#ip address 20.10.20.1/24 | Assign IP address to interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 100 | Enter OSPF router mode. |
(config-router)#ospf router-id 2.2.2.2 | Configure OSPF router id same as loopback ip address. |
(config-router)#network 2.2.2.2/32 area 0 (config-router)#network 20.10.20.1/24 area 0 (config-router)#network 20.10.10.2/24 area 0 | Define the network on which OSPF runs and associate area id. |
(config-router)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#ip vrf IPI | Create a new VRF named IPI. |
(config-vrf)#rd 1:101 | Assign the route distinguisher (RD) value as 1:101. |
(config-vrf)#route-target both 100:200 | Import routes between route target (RT) ext-communities 100 and 200. |
(config-vrf)#router-id 55.55.55.55 | Configure Router-id for VRF |
(config-vrf)#exit | Exit VRF mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#ip vrf forwarding IPI | Bind the interface connected to the CE router with VRF IPI. |
(config-if)#ipv6 address 3001::1/64 | Assign the IPv6 address. |
(config-if)#exit | Exit interface mode. |
(config)#router bgp 100 | Enter BGP router mode. |
(config-router)#bgp router-id 3.3.3.3 | Configure BGP router-id |
(config-router)#neighbor 1.1.1.1 remote-as 100 | Configure 6VPE2 as an iBGP peer. |
(config-router)#neighbor 1.1.1.1 update-source lo | Update the source as loopback for iBGP peering with the remote 6VPE router. |
(config-router)#address-family ipv4 unicast | Enter address family mode |
(config-router-af)#neighbor 1.1.1.1 activate | Activate the neighbor |
(config-router-af)#exit-address-family | Exit address family mode |
(config-router)#address-family vpnv6 unicast | Enter VPNv6 address family mode. |
(config-router-af)#neighbor 1.1.1.1 activate | Activate the 6VPE neighbor so that it can accept VPN IPv6 routes. |
(config-router-af)#exit-address-family | Exit VPNv6 address family mode. |
(config-router)#address-family ipv6 vrf IPI | Enter the IPv6 address family for VRF IPI. |
(config-router-af)#neighbor 3001::2 remote-as 300 | Activate CE inside IPv6 address family for vrf IPI. |
(config-router-af)#neighbor 3001::2 activate | Activate the neighbor |
(config-router-af)#redistribute connected | Redistribute the connected route under address family IPv6 for VRF IPI. |
(config-router-af)#exit-address-family | Exit IPv6 Address Family mode. |
(config-router)#exit | Exit router mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 3.3.3.3/32 secondary | Assign the IP address to loopback interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ldp | Enter router LDP mode. |
(config-router)#router-id 3.3.3.3 | Set the router ID to IP address 3.3.3.3 |
(config-router)#transport-address ipv4 3.3.3.3 | Configure transport address as loopback address. |
(config-router)#targeted-peer ipv4 1.1.1.1 | Configure targeted peer. |
(config-router-targeted-peer)#exit | Exit-targeted-peer-mode |
(config-router)#exit | Exit router mode |
(config)#router rsvp | Enter RSVP router mode. |
(config-router)#exit | Exit router mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#label-switching | Enable label switching in interface |
(config-if)#enable-rsvp | Enable RSVP in interface. |
(config-if)#enable-ldp ipv4 | Enable LDP in interface. |
(config-if)#ip address 20.10.20.2/24 | Assign IP address to interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 100 | Enter OSPF router mode. |
(config-router)#ospf router-id 3.3.3.3 | Configure OSPF router id same as loopback ip address. |
(config-router)#network 3.3.3.3/32 area 0 (config-router)#network 20.10.20.2/24 area 0 | Define the network on which OSPF runs and associate area id. |
(config-router)#exit | Exit OSPF router mode. |
(config)#rsvp-trunk toPE1 | Enter the trunk mode for RSVP. |
(config-trunk)#to 1.1.1.1 | Specify IPv4 Egress for the LSP. |
(config-trunk)#commit | Commit the transaction. |