OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : Inter-AS VPN Option-C Configuration : Inter-AS VPN Option-C Configuration (Without RR)
Inter-AS VPN Option-C Configuration (Without RR)
This sub-option enables VPNv4 routes exchange between the Provider Edge Routers of different AS'es and thus requires
1. Remote PE loopback addresses to be known in the AS - This is accomplished using BGP-LU and is advertised inside the AS using the Route-reflector and outside the AS using the eBGP Peering between the ASBRs.
2. Next-hop attribute should be changed when ASBR advertises the remote PE's Loopback address as LU route to the RR. This is accomplished using the configuration "next-hop self" for the iBGP RR neighbor.
3. MP-eBGP session between the two PE's in different AS's to exchange the VPNv4 routes.
(1) and (2) enables an end to end LSP between the two PE's which needs to run the L3VPN service and (3) enables the PE's in different AS'es to form BGP neighborship with each other and successfully exchange the VPNv4 Routes.
Topology
Figure 32-11: InterAS-VPN Option-C without RR
PE1
 
#configure terminal
Enter configure mode.
PE1(config)#interface lo
Enter interface mode.
PE1(config-if)#ip address 41.41.41.41/32 secondary
Assign the IPv4 address.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#ip vrf vrf1
Create a new VRF named vrf1.
PE1(config-vrf)#rd 1:1
Assign the route distinguisher (RD) value as 1:1.
PE1(config-vrf)#route-target both 1:1
Configure import and export RT for this VRF.
PE1(config-vrf)#exit
Exit interface mode.
PE1(config)#interface xe23
Enter interface mode.
PE1(config-if)#ip vrf forwarding vrf1
Bind the interface connected to the CE router with VRF vrf1.
PE1(config-if)#ip address 10.1.1.1/24
Assign the IPv4 address.
PE1(config)#interface xe15
Enter interface mode.
PE1(config-if)#ip address 11.1.1.41/24
Assign the IPv4 address.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#router ospf 1
Enter router OSPF mode.
PE1(config-router)#ospf router-id 41.41.41.41
Configure OSPF router id same as loopback ip address.
PE1(config-router)#network 11.1.1.0/24 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
PE1(config-router)#network 41.41.41.41/32 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
PE1(config-router)#exit
Exit OSPF router mode.
PE1(config-router)#router ldp
Enter router LDP mode.
PE1(config-router)#router-id 41.41.41.41
Set the router ID to IP address 41.41.41.41
PE1(config-router)#transport-address ipv4 41.41.41.41
Configure LDP transport address same as loopback address
PE1(config-router)#exit
Exit LDP mode.
(config)#interface xe15
Enter interface mode.
(config-if)#label-switching
Enable label switching in interface.
(config-if)#enable-ldp ipv4
Enable LDP in interface.
(config-if)#exit
Exit interface mode.
PE1(config-if)#router bgp 65000
Enter BGP router mode.
PE1(config-router)# bgp router-id 41.41.41.41
Configure BGP router-id.
PE1(config-router)# no bgp default ipv4-unicast
Configure BGP peer to have no ipv4 unicast capability exchange by default.
PE1(config-router)# address-family ipv4 unicast
Enter address-family ipv4 unicast.
PE1(config-router-af)# network 41.41.41.41/32
Advertise loopback address.
PE1(config-router-af)# exit-address-family
Exit address-family ipv4 labeled-unicast.
PE1(config-router)# neighbor 2.2.2.2 re-mote-as 65000
Configure PE2-ASBR1 as an iBGP peer.
PE1(config-router)# neighbor 2.2.2.2 up-date-source lo
Update the source as loopback for iBGP peering with the remote PE2 router.
PE1(config-router)# neighbor 28.28.28.28 remote-as 65001
Configure PE4 as an eBGP peer.
PE1(config-router)# neighbor 28.28.28.28 ebgp-multihop
Configure eBGP multichip for eBGP peer PE4.
PE1(config-router)# neighbor 28.28.28.28 update-source lo
Update the source as loopback for eBGP peering with the remote PE4 router.
PE1(config-router)# allocate-label all
Configure allocate-label.
PE1(config-router)# address-family ipv4 la-beled-unicast
Enter address-family ipv4 labeled-unicast.
PE1(config-router-af)# neighbor 2.2.2.2 ac-tivate
Activate iBGP neighbor.
PE1(config-router-af)# exit-address-family
Exit address-family ipv4 labeled-unicast.
PE1(config-router)# address-family vpnv4 unicast
Enter address-family vpnv4.
PE1(config-router-af)# neighbor 28.28.28.28 allow-ebgp-vpn
Configure allow-ebgp-vpn for ebgp neighbor PE4.
PE1(config-router-af)# neighbor 28.28.28.28 activate
Activate eBGP neighbor PE4.
PE1(config-router-af)# exit-address-family
Exit address-family vpnv4.
PE1(config-router)# address-family ipv4 vrf vrf1
Enter the IPv4 address family for VRF vrf1.
PE1(config-router-af)# redistribute con-nected
Redistribute connected route.
PE1(config-router-af)# exit-address-family
Exit IPv4 VRF Address Family mode.
PE1(config-router)#exit
Exit the router mode.
PE1(config)#commit
Commit candidate configuration to be running configuration.
PE1(config)#exit
Exit the config mode.
P1
 
P1#configure terminal
Enter configure mode.
P1(config)#interface lo
Enter interface mode.
P1(config-if)# ip address 51.51.51.51/32 secondary
Assign the IPv4 address.
P1(config-if)#exit
Exit interface mode.
P1(config)#interface xe15
Enter interface mode.
P1(config-if)#ip address 11.1.1.31/24
Assign the IPv4 address.
P1(config-if)#exit
Exit interface mode.
P1(config)#interface xe21
Enter interface mode.
P1(config-if)#ip address 12.1.1.31/24
Assign the IPv4 address.
P1(config-if)#exit
Exit interface mode.
P1(config)#router ospf 1
Enter router OSPF mode.
P1(config-router)#ospf router-id 51.51.51.51
Configure OSPF router id same as loopback ip address.
P1(config-router)#network 11.1.1.0/24 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
P1(config-router)#network 12.1.1.0/24 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
P1(config-router)#network 51.51.51.51/32 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
P1(config-router)#exit
Exit router OSPF mode.
P1(config-router)#router ldp
Enter router LDP mode.
P1(config-router)#router-id 51.51.51.51
Set the router ID to IP address 51.51.51.51
P1(config-router)#transport-address ipv4 51.51.51.51
Configure LDP transport address same as loopback address
P1(config-router)#exit
Exit LDP mode.
P1(config)#interface xe15
Enter interface mode.
P1(config-if)#label-switching
Enable label switching in interface.
P1(config-if)# enable-ldp ipv4
Enable LDP on the interface.
P1(config-if)#exit
Exit interface mode.
P1(config)#interface xe21
Enter interface mode.
P1(config-if)#label-switching
Enable label switching in interface.
P1(config-if)# enable-ldp ipv4
Enable LDP on the interface.
P1(config-if)#exit
Exit interface mode.
P1(config)#commit
Commit candidate configuration to be running configuration.
P1(config)#exit
Exit the config mode.
PE2-ASBR1
 
#configure terminal
Enter configure mode.
PE2-ASBR(config)#interface lo
Enter interface mode.
PE2-ASBR(config-if)#ip address 2.2.2.2/32 secondary
Assign the IPv4 address.
PE2-ASBR(config-if)#exit
Exit interface mode.
PE2-ASBR(config)#router ospf 1
Enter router OSPF mode.
PE2-ASBR(config-router)#ospf router-id 2.2.2.2
Configure OSPF router id same as loopback ip address.
PE2-ASBR(config-router)#network 2.2.2.2/32 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
PE2-ASBR(config-router)#network 12.1.1.0/24 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
PE2-ASBR(config-router)#exit
Exit router OSPF mode.
PE2-ASBR(config-router)#router ldp
Enter router LDP mode.
PE2-ASBR(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2
PE2-ASBR(config-router)#transport-address ipv4 2.2.2.2
Configure LDP transport address same as loopback address.
PE2-ASBR(config-router)#exit
Exit LPD mode.
PE2-ASBR(config)#interface xe5
Enter interface mode.
PE2-ASBR(config-if)#ip address 20.1.1.2/24
Assign the IPv4 address.
PE2-ASBR(config-if)#label-switching
Enable label switching in interface.
PE2-ASBR(config-if)#exit
Exit interface mode.
PE2-ASBR(config)#interface xe20
Enter interface mode.
PE2-ASBR(config-if)#ip address 12.1.1.2/24
Assign the IPv4 address.
PE2-ASBR(config-if)#label-switching
Enable label switching in interface.
PE2-ASBR(config-if)# enable-ldp ipv4
Enable LDP on the interface.
PE2-ASBR(config-if)#exit
Exit interface mode
PE2-ASBR(config-if)#router bgp 65000
Enter BGP router mode.
PE2-ASBR(config-router)# bgp router-id 2.2.2.2
Configure BGP router-id.
PE2-ASBR(config-router)# no bgp default ipv4-unicast
Configure BGP to have no default ipv4 unicast capability exchange between neighbors.
PE2-ASBR(config-router)# neighbor 20.1.1.40 remote-as 65001
Configure PE3-ASBR2 as an eBGP peer.
PE2-ASBR(config-router)# neighbor 41.41.41.41 remote-as 65000
Configure PE1 as an iBGP peer.
PE2-ASBR(config-router)# neighbor 41.41.41.41 update-source lo
Update the source as loopback for iBGP peering with the remote PE1 router.
PE2-ASBR(config-router)# allocate-label all
Configure allocate-label.
PE2-ASBR(config-router)# address-family ipv4 labeled-unicast
Enter address-family ipv4 labeled-unicast.
PE2-ASBR(config-router-af)# neighbor 20.1.1.40 activate
Activate eBGP neighbor PE3-ASBR2.
PE2-ASBR(config-router-af)# neighbor 41.41.41.41 activate
Activate iBGP neighbor PE1.
PE2-ASBR(config-router-af)# neighbor 41.41.41.41 next-hop-self
Configure next-hop-self for iBGP neighbor PE1.
PE2-ASBR(config-router-af)# exit-address-family
Exit address-family ipv4 labeled-unicast.
PE2(config-router)#exit
Exit the router mode.
PE2(config)#commit
Commit candidate configuration to be running configuration.
PE2(config)#exit
Exit the config mode.
PE3-ASBR
 
PE3-ASBR#configure terminal
Enter configure mode.
PE3-ASBR(config)#interface lo
Enter interface mode.
PE3-ASBR(config-if)#ip address 40.40.40.40/32 secondary
Assign the IPv4 address.
PE3-ASBR(config-if)#exit
Exit interface mode.
PE3-ASBR(config)#interface xe5
Enter interface mode.
PE3-ASBR(config-if)#ip address 20.1.1.40/24
Assign the IPv4 address.
PE3-ASBR(config-if)#exit
Exit interface mode.
PE3-ASBR(config)#interface xe1
Enter interface mode.
PE3-ASBR(config-if)#ip address 21.1.1.40/24
Assign the IPv4 address.
PE3-ASBR(config-if)#exit
Exit interface mode.
PE3-ASBR(config)#router ospf 1
Enter router OSPF mode.
PE3-ASBR(config-router)#ospf router-id 40.40.40.40
Configure OSPF router id same as loopback ip address.
PE3-ASBR(config-router)#network 21.1.1.0/24 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
PE3-ASBR(config-router)#network 40.40.40.40/32 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
PE3-ASBR(config-router)#exit
Exit router OSPF mode.
PE3-ASBR(config-router)#router ldp
Enter router LDP mode.
PE3-ASBR(config-router)#router-id 40.40.40.40
Set the router ID to IP address 40.40.40.40
PE3-ASBR(config-router)#transport-address ipv4 40.40.40.40
Configure LDP transport address same as loopback address
PE3-ASBR(config)#interface xe1
Enter interface mode.
PE3-ASBR(config-if)#label-switching
Enable label switching in interface.
PE3-ASBR(config-if)#enable-ldp ipv4
Enable LDP on the interface.
PE3-ASBR(config)#interface xe5
Enter interface mode.
PE3-ASBR(config-if)#label-switching
Enable label switching in interface.
PE3-ASBR(config-if)#router bgp 65001
Enter BGP router mode.
PE3-ASBR(config-router)# bgp router-id 40.40.40.40
Configure BGP router-id.
PE3-ASBR(config-router)# no bgp default ipv4-unicast
Configure BGP to have no default ipv4 unicast capability exchange with the neighbors.
PE3-ASBR(config-router)# neighbor 20.1.1.2 remote-as 65000
Configure PE2-ASBR as an eBGP peer.
PE3-ASBR(config-router)# neighbor 28.28.28.28 remote-as 65001
Configure PE4 as an iBGP peer.
PE3-ASBR(config-router)# neighbor 28.28.28.28 update-source lo
Update the source as loopback for iBGP peering with the remote PE4 router.
PE3-ASBR(config-router)# allocate-label all
Configure allocate-label.
PE3-ASBR(config-router)# address-family ipv4 labeled-unicast
Enter address-family ipv4 labeled-unicast.
PE3-ASBR(config-router-af)# neighbor 20.1.1.2 activate
Activate eBGP neighbor PE2-ASBR1.
PE3-ASBR(config-router-af)# neighbor 28.28.28.28 activate
Activate iBGP neighbor PE4.
PE3-ASBR(config-router-af)# neighbor 28.28.28.28 next-hop-self
Configure next-hop-self for iBGP neighbor PE4.
PE3-ASBR(config-router-af)# exit-address-family
Exit address-family ipv4 labeled-unicast.
PE3-ASBR(config-router)#exit
Exit the router mode.
PE3-ASBR(config)#commit
Commit candidate configuration to be running configuration.
PE3-ASBR(config)#exit
Exit the config mode.
P2
 
#configure terminal
Enter configure mode.
P2(config)#interface lo
Enter interface mode.
P2(config-if)# ip address 6.6.6.6/32 secondary
Assign the IPv4 address.
P2(config-if)#exit
Exit interface mode.
P2(config)#interface xe0
Enter interface mode.
P2(config-if)#ip address 21.1.1.5/24
Assign the IPv4 address.
P2(config-if)#exit
Exit interface mode.
P2(config)#interface xe11
Enter interface mode.
P2(config-if)#ip address 22.1.1.5/24
Assign the IPv4 address.
P2(config-if)#exit
Exit interface mode.
P2(config)#router ospf 1
Enter router OSPF mode.
P2(config-router)#ospf router-id 6.6.6.6
Configure OSPF router id same as loopback ip address.
P2(config-router)# network 6.6.6.6/32 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
P2(config-router)#network 21.1.1.0/24 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
P2(config-router)#network 22.1.1.0/24 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
P2(config-router)#exit
Exit router OSPF mode.
P2(config)#router ldp
Enter router LDP mode.
P2(config-router)#router-id 6.6.6.6
Set the router ID to IP address 6.6.6.6
P2(config-router)#transport-address ipv4 6.6.6.6
Configure LDP transport address same as loopback address
P2(config-router)#exit
Exit LDP mode.
P2(config)#interface xe0
Enter interface mode.
P2(config-if)#label-switching
Enable label switching in interface.
P2(config-if)# enable-ldp ipv4
Enable LDP on the interface.
P2(config-if)#exit
Exit interface mode.
P2(config)#interface xe11
Enter interface mode.
P2(config-if)#label-switching
Enable label switching in interface.
P2(config-if)# enable-ldp ipv4
Enable LDP on the interface.
P2(config-if)#exit
Exit interface mode.
P2(config)#commit
Commit candidate configuration to be running configuration.
P2(config)#exit
Exit the config mode.
PE4
 
#configure terminal
Enter configure mode.
PE4(config)#interface lo
Enter interface mode.
PE4(config-if)#ip address 28.28.28.28/32 secondary
Assign the IPv4 address.
PE4(config-if)#exit
Exit interface mode.
PE4(config)#ip vrf vrf1
Create a new VRF named vrf1.
PE4(config-vrf)#rd 1:1
Assign the route distinguisher (RD) value as 1:1.
PE4(config-vrf)#route-target both 1:1
Configure import and export RTs for the VRF.
PE4(config-vrf)#exit
Exit VRF mode.
PE4(config)#interface xe23
Enter interface mode.
PE4(config-if)#ip vrf forwarding vrf1
Bind the interface connected to the CE router with VRF vrf1.
PE4(config-if)#ip address 30.1.1.1/24
Assign the IPv4 address.
PE4(config-if)#exit
Exit interface mode.
PE4(config)#interface xe11
Enter interface mode.
PE4(config-if)#ip address 22.1.1.28/24
Assign the IPv4 address.
PE4(config-if)#exit
Exit interface mode.
PE4(config)#router ospf 1
Enter router OSPF mode.
PE4(config-router)#ospf router-id 28.28.28.28
Configure OSPF router id same as loopback ip address.
PE4(config-router)#network 22.1.1.0/24 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
PE4(config-router)#network 28.28.28.28/32 area 0.0.0.0
Define the network on which OSPF runs and associate area id.
PE4(config-router)#exit
Exit OSPF router mode.
PE4(config)# router ldp
Enter router LDP mode.
PE4(config-router)#router-id 28.28.28.28
Set the router ID to IP address 28.28.28.28
PE4(config-router)#transport-address ipv4 28.28.28.28
Configure LDP transport address same as loopback address
PE4(config-router)#exit
Exit LDP mode.
PE4(config)#interface xe11
Enter interface mode.
PE4(config-if)#label-switching
Enable label switching in interface.
PE4(config-if)# enable-ldp ipv4
Enable LDP on the interface.
PE4(config-if)#exit
Exit interface mode.
PE4(config-if)#router bgp 65001
Enter BGP router mode.
PE4(config-router)# bgp router-id 28.28.28.28
Configure BGP router-id.
PE4(config-router)# no bgp default ipv4-unicast
Configure BGP speaker to have no default ipv4 unicast capability exchange between neighbors.
PE4(config-router)#address-family ipv4 unicast
Enter the IPv4 unicast address family.
PE4(config-router-af)#network 28.28.28.28/32
Advertise loopback address.
PE4(config-router-af)#exit-address-family
Exit address family mode
PE4(config-router)# neighbor 40.40.40.40 remote-as 65001
Configure PE3-ASBR2 as an iBGP peer.
PE4(config-router)# neighbor 40.40.40.40 update-source lo
Update the source as loopback for iBGP peering with the remote PE3-ASBR router.
PE4(config-router)# neighbor 41.41.41.41 remote-as 65000
Configure PE1 as an eBGP peer.
PE4(config-router)# neighbor 41.41.41.41 ebgp-multihop
Configure eBGP multichip for eBGP peer PE1.
PE4(config-router)# neighbor 41.41.41.41 update-source lo
Update the source as loopback for eBGP peering with the remote PE1 router.
PE4(config-router)# allocate-label all
Configure allocate-label.
PE4(config-router)# address-family ipv4 la-beled-unicast
Enter address-family ipv4 labeled-unicast.
PE4(config-router-af)# neighbor 40.40.40.40 activate
Activate iBGP neighbor.
PE4(config-router-af)# exit-address-family
Exit address-family ipv4 labeled-unicast.
PE4(config-router)# address-family vpnv4 unicast
Enter address-family vpnv4.
PE4(config-router-af)# neighbor 41.41.41.41 allow-ebgp-vpn
Activate eBGP neighbor PE1.
PE4(config-router-af)# neighbor 41.41.41.41 activate
Configure allow-ebgp-vpn for ebgp neighbor PE1.
PE4(config-router-af)# exit-address-family
Exit address-family vpnv4.
PE4(config-router)# address-family ipv4 vrf vrf1
Enter the IPv4 address family for VRF vrf1.
PE4(config-router-af)# redistribute con-nected
Redistribute connected route.
PE4(config-router-af)# exit-address-family
Exit IPv4 VRF Address Family mode.
PE4(config-router)#exit
Exit the router mode.
PE4(config)#commit
Commit candidate configuration to be running configuration.
PE4(config)#exit
Exit the config mode.
Validation
PE1
PE1#show ip bgp labeled-unicast summary
BGP router identifier 41.41.41.41, local AS number 65000
BGP table version is 10
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 65000 374 368 10 0 0 02:37:43 3
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE1#show ip bgp labeled-unicast
 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, S - stale
Network Next Hop In Label Out Label
*>i 5.5.5.5/32 2.2.2.2 24960 24965
*>i 28.28.28.28/32 2.2.2.2 24962 24962
*>i 31.31.31.31/32 2.2.2.2 24963 24961
*> 41.41.41.41/32 0.0.0.0 24961 -
 
PE1#show ip route bgp
IP Route Table for VRF "default"
B 28.28.28.28/32 [200/0] via 2.2.2.2 (recursive via 11.1.1.31), 02:41:00
 
Gateway of last resort is not set
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 4 0 Yes LSP_DEFAULT 24321 xe15 No 11.1.1.31
L> 5.5.5.5/32 6 0 Yes LSP_DEFAULT 24324 xe15 No 11.1.1.31
B 5.5.5.5/32 7 0 Yes LSP_DEFAULT 24965 - No 2.2.2.2
L> 12.1.1.0/24 2 0 Yes LSP_DEFAULT 3 xe15 No 11.1.1.31
L> 13.1.1.0/24 3 0 Yes LSP_DEFAULT 3 xe15 No 11.1.1.31
B> 28.28.28.28/32 8 0 Yes LSP_DEFAULT 24962 - No 2.2.2.2
L> 31.31.31.31/32 5 0 Yes LSP_DEFAULT 24322 xe15 No 11.1.1.31
B 31.31.31.31/32 9 0 Yes LSP_DEFAULT 24961 - No 2.2.2.2
L> 51.51.51.51/32 1 0 Yes LSP_DEFAULT 3 xe15 No 11.1.1.31
 
PE1#show ip bgp vpnv4 all summary
BGP router identifier 41.41.41.41, local AS number 65000
BGP table version is 4
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
28.28.28.28 4 65001 340 338 4 0 0 02:22:11 1
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE1#show ip bgp vpnv4 all
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:1 (Default for VRF vrf1)
*> l 10.1.1.0/24 0.0.0.0 0 100 32768 ?
*> 30.1.1.0/24 28.28.28.28 0 100 0 65001 ?
Announced routes count = 1
Accepted routes count = 1
Route Distinguisher: 1:1
*> 30.1.1.0/24 28.28.28.28 0 100 0 65001 ?
Announced routes count = 0
Accepted routes count = 1
 
PE1#show ip route vrf vrf1 database
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
> - selected route, * - FIB route, p - stale info
 
IP Route Table for VRF "vrf1"
C *> 10.1.1.0/24 is directly connected, xe23, 1d19h57m
B *> 30.1.1.0/24 [20/0] via 28.28.28.28, 02:22:28
 
Gateway of last resort is not set
P1
P1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, S - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 2.2.2.2/32 2 24321 3 N/A xe21 12.1.1.2 LSP_DEFAULT
L> 41.41.41.41/32 1 24320 3 N/A xe15 11.1.1.2 LSP_DEFAULT
L> 31.31.31.31/32 4 24323 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 31.31.31.31/32 3 24322 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 5.5.5.5/32 5 24324 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
PE2-ASBR
PE2-ASBR#show ip bgp labeled-unicast summary
BGP router identifier 2.2.2.2, local AS number 65000
BGP table version is 10
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
20.1.1.40 4 65001 6427 6521 10 0 0 1d20h28m 2
41.41.41.41 4 65000 379 385 10 0 0 02:42:38 1
 
Total number of neighbors 2
 
Total number of Established sessions 2
 
PE2-ASBR#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, S - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
B> 31.31.31.31/32 2 24961 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
B> 41.41.41.41/32 1 24960 24961 N/A N/A 41.41.41.41 LSP_DEFAULT
B> 5.5.5.5/32 6 24965 24965 N/A N/A 20.1.1.40 LSP_DEFAULT
B> 28.28.28.28/32 3 24962 24961 N/A N/A 20.1.1.40 LSP_DEFAULT
 
PE2-ASBR#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
B> 5.5.5.5/32 8 0 Yes LSP_DEFAULT 24965 xe5 No 20.1.1.40
L> 11.1.1.0/24 1 0 Yes LSP_DEFAULT 3 xe20 No 12.1.1.31
L> 13.1.1.0/24 2 0 Yes LSP_DEFAULT 3 xe20 No 12.1.1.31
B> 28.28.28.28/32 7 0 Yes LSP_DEFAULT 24961 xe5 No 20.1.1.40
L> 31.31.31.31/32 5 0 Yes LSP_DEFAULT 24323 xe20 No 12.1.1.31
L> 41.41.41.41/32 3 0 Yes LSP_DEFAULT 24320 xe20 No 12.1.1.31
B 41.41.41.41/32 6 0 Yes LSP_DEFAULT 24961 - No 41.41.41.41
L> 51.51.51.51/32 4 0 Yes LSP_DEFAULT 3 xe20 No 12.1.1.31
 
PE2-ASBR#show ip route bgp
IP Route Table for VRF "default"
B 28.28.28.28/32 [20/0] via 20.1.1.40, xe5, 02:41:38
 
Gateway of last resort is not set
PE3-ASBR
PE3-ASBR#show ip bgp labeled-unicast summary
BGP router identifier 40.40.40.40, local AS number 65001
BGP table version is 11
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
20.1.1.2 4 65000 6263 6267 11 0 0 1d20h31m 2
28.28.28.28 4 65001 383 389 11 0 0 02:42:56 1
 
Total number of neighbors 2
 
Total number of Established sessions 2
 
PE3-ASBR#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, S - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
B> 31.31.31.31/32 6 24964 24961 N/A N/A 20.1.1.2 LSP_DEFAULT
B> 41.41.41.41/32 2 24960 24960 N/A N/A 20.1.1.2 LSP_DEFAULT
B> 28.28.28.28/32 3 24961 24321 N/A N/A 28.28.28.28 LSP_DEFAULT
B> 5.5.5.5/32 7 24965 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
 
PE3-ASBR#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 5.5.5.5/32 5 0 Yes LSP_DEFAULT 24320 xe1 No 21.1.1.5
L> 6.6.6.6/32 6 0 Yes LSP_DEFAULT 3 xe1 No 21.1.1.5
L> 22.1.1.0/24 7 0 Yes LSP_DEFAULT 3 xe1 No 21.1.1.5
L> 23.1.1.0/24 8 0 Yes LSP_DEFAULT 3 xe1 No 21.1.1.5
L> 28.28.28.28/32 9 0 Yes LSP_DEFAULT 24321 xe1 No 21.1.1.5
B 28.28.28.28/32 2 0 Yes LSP_DEFAULT 24321 - No 28.28.28.28
B> 31.31.31.31/32 4 0 Yes LSP_DEFAULT 24961 xe5 No 20.1.1.2
B> 41.41.41.41/32 1 0 Yes LSP_DEFAULT 24960 xe5 No 20.1.1.2
 
PE3-ASBR#show ip route bgp
IP Route Table for VRF "default"
B 41.41.41.41/32 [20/0] via 20.1.1.2, xe5, 02:45:37
 
Gateway of last resort is not set
P2
P2#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, S - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 5.5.5.5/32 3 24322 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 5.5.5.5/32 1 24320 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 28.28.28.28/32 2 24321 3 N/A xe11 22.1.1.28 LSP_DEFAULT
L> 31.31.31.31/32 4 24323 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 40.40.40.40/32 5 24324 3 N/A xe0 21.1.1.40 LSP_DEFAULT
PE4
PE4#show ip bgp labeled-unicast summary
BGP router identifier 28.28.28.28, local AS number 65001
BGP table version is 12
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
40.40.40.40 4 65001 404 399 12 0 0 02:49:41 3
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE4#show ip bgp labeled-unicast
 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, S - stale
Network Next Hop In Label Out Label
*>i 5.5.5.5/32 40.40.40.40 24324 24965
*> 28.28.28.28/32 0.0.0.0 24321 -
*>i 31.31.31.31/32 40.40.40.40 24322 24964
*>i 41.41.41.41/32 40.40.40.40 24323 24960
PE4#
 
PE4#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 5.5.5.5/32 4 0 Yes LSP_DEFAULT 24322 xe11 No 22.1.1.5
B 5.5.5.5/32 3 0 Yes LSP_DEFAULT 24965 - No 40.40.40.40
L> 6.6.6.6/32 5 0 Yes LSP_DEFAULT 3 xe11 No 22.1.1.5
L> 21.1.1.0/24 6 0 Yes LSP_DEFAULT 3 xe11 No 22.1.1.5
L> 23.1.1.0/24 7 0 Yes LSP_DEFAULT 3 xe11 No 22.1.1.5
L> 31.31.31.31/32 8 0 Yes LSP_DEFAULT 24323 xe11 No 22.1.1.5
B 31.31.31.31/32 1 0 Yes LSP_DEFAULT 24964 - No 40.40.40.40
L> 40.40.40.40/32 9 0 Yes LSP_DEFAULT 24324 xe11 No 22.1.1.5
B> 41.41.41.41/32 2 0 Yes LSP_DEFAULT 24960 - No 40.40.40.40
 
PE4#show ip bgp vpnv4 all summary
BGP router identifier 28.28.28.28, local AS number 65001
BGP table version is 4
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
41.41.41.41 4 65000 373 376 4 0 0 02:37:04 1
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE4#show ip bgp vpnv4 all
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:1 (Default for VRF vrf1)
*> 10.1.1.0/24 41.41.41.41 0 100 0 65000 ?
*> l 30.1.1.0/24 0.0.0.0 0 100 32768 ?
Announced routes count = 1
Accepted routes count = 1
Route Distinguisher: 1:1
*> 10.1.1.0/24 41.41.41.41 0 100 0 65000 ?
Announced routes count = 0
Accepted routes count = 1
 
PE4#show ip route vrf vrf1 database
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
> - selected route, * - FIB route, p - stale info
 
IP Route Table for VRF "vrf1"
B *> 10.1.1.0/24 [20/0] via 41.41.41.41, 02:37:23
C *> 30.1.1.0/24 is directly connected, xe21, 1d20h11m
 
Gateway of last resort is not set
 
PE4#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, S - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
B> 41.41.41.41/32 4 24323 24960 N/A N/A 40.40.40.40 LSP_DEFAULT
B> 28.28.28.28/32 2 24321 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
B> vrf1 1 24320 Nolabel N/A vrf1 N/A LSP_DEFAULT
B> 31.31.31.31/32 3 24322 24964 N/A N/A 40.40.40.40 LSP_DEFAULT
B> 5.5.5.5/32 5 24324 24965 N/A N/A 40.40.40.40 LSP_DEFAULT
 
Last modified date: 10/17/2023