LDP-FRR with OSPF as IGP Configuration
Below are the configurations and validations involving NSM, OSPF, LDP before configuring fast-reroute for IGP and LDP
PE1
#configure terminal | Enter configuration mode. |
(config)#interface lo | Specify the loopback (lo) interface to be configured. |
(config-if)#ip address 1.1.1.1/32 secondary | Set the IP address of the loopback interface |
(config-if)#exit | Exit interface mode. |
(config)#router ldp | Enter router mode for LDP. |
(config-router)#router-id 1.1.1.1 | Set the router ID to IP address 1.1.1.1 |
(config-router)#transport-address ipv4 1.1.1.1 0 | Configure the transport address for IPv4 (for IPv6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address. |
(config-router)#targeted-peer ipv4 5.5.5.5 | Configure targeted peer. |
(config-router-targeted-peer)#exit | Exit-targeted-peer-mode |
(config-router)#exit | Exit router mode |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 10.10.10.1/24 | Configure IPv4 address for xe1. |
(config-if)#label-switching | Enable label switching on interface xe1. |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe1. |
(config-if)#ip ospf cost 10 | Assign ospf cost to the interface |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#interface xe2 | Enter interface mode. |
(config-if)#ip address 20.20.20.1/24 | Configure IPv4 address for xe2 |
(config-if)#label-switching | Enable label switching on interface xe2. |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe2. |
(config-if)#ip ospf cost 15 | Assign ospf cost to the interface |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#interface xe3 | Enter interface mode. |
(config-if)#ip address 30.30.30.1/24 | Configure IPv4 address for xe3 |
(config-if)#label-switching | Enable label switching on interface xe3 |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe3 |
(config-if)#ip ospf cost 20 | Assign OSPF cost to the interface |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync OSPF to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#router ospf 1 | Configure the routing process and specify the Process ID 100. The Process ID should be a unique positive integer identifying the routing process. |
(config)#ospf router-id 1.1.1.1 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 1.1.1.1/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#network 10.10.10.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#network 20.20.20.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#network 30.30.30.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#bfd all-interfaces | Enable the OSPF enabled interfaces with bfd |
(config-if)#exit | Exit interface mode. |
(config)#bfd interval 3 minrx 3 multiplier 3 | Configure BFD interval |
(config)#commit | Commit all the configurations |
P1
#configure terminal | Enter configuration mode. |
(config)#interface lo | Specify the loopback (lo) interface to be configured. |
(config-if)#ip address 2.2.2.2/32 secondary | Set the IP address of the loopback interface to 2.2.2.2/32 |
(config-if)#exit | Exit interface mode. |
(config)#router ldp | Enter router mode for LDP. |
(config-router)#router-id 2.2.2.2 | Set the router ID to IP address 2.2.2.2 |
(config-router)#transport-address ipv4 2.2.2.2 0 | Configure the transport address for IPv4 (for IPv6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address. |
(config-router)#exit | Exit router mode |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 10.10.10.2/24 | Configure IPv4 address for xe1. |
(config-if)#label-switching | Enable label switching on interface xe1. |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe1. |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#interface xe2 | Enter interface mode. |
(config-if)#ip address 40.40.40.1/24 | Configure IPv4 address for xe2 |
(config-if)#label-switching | Enable label switching on interface xe2. |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe2. |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#router ospf 1 | Configure the routing process and specify the Process ID • The Process ID should be a unique positive integer identifying the routing process. |
(config)#ospf router-id 2.2.2.2 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 2.2.2.2/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
(config-router)#network 10.10.10.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
(config-router)#network 40.40.40.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
(config-router)#bfd all-interfaces | Enable the OSPF enabled interfaces with bfd |
(config-if)#exit | Exit interface mode. |
(config)#bfd interval 3 minrx 3 multiplier 3 | Configure BFD interval |
(config)#commit | Commit all the configurations |
P2
#configure terminal | Enter configuration mode. |
(config)#interface lo | Specify the loopback (lo) interface to be configured. |
(config-if)#ip address 3.3.3.3/32 secondary | Set the IP address of the loopback interface |
(config-if)#exit | Exit interface mode. |
(config)#router ldp | Enter router mode for LDP. |
(config-router)#router-id 3.3.3.3 | Set the router ID to IP address 3.3.3.3 |
(config-router)#transport-address ipv4 3.3.3.3 0 | Configure the transport address for IPv4 (for IPv6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address. |
(config-router)#exit | Exit router mode |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 20.20.20.2/24 | Configure IPv4 address for xe1. |
(config-if)#label-switching | Enable label switching on interface xe1. |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe1. |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#interface xe2 | Enter interface mode. |
(config-if)#ip address 50.50.50.1/24 | Configure IPv4 address for xe2 |
(config-if)#label-switching | Enable label switching on interface xe2. |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe2. |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#router ospf 1 | Configure the routing process and specify the Process ID • The Process ID should be a unique positive integer identifying the routing process. |
(config)#ospf router-id 3.3.3.3 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 3.3.3.3/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
(config-router)#network 20.20.20.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
(config-router)#network 50.50.50.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
(config-router)#bfd all-interfaces | Enable the OSPF enabled interfaces with bfd |
(config-if)#exit | Exit interface mode. |
(config)#bfd interval 3 minrx 3 multiplier 3 | Configure BFD interval |
(config)#commit | Commit all the configurations |
P3
#configure terminal | Enter configuration mode. |
(config)#interface lo | Specify the loopback (lo) interface to be configured. |
(config-if)#ip address 4.4.4.4/32 secondary | Set the IP address of the loopback interface |
(config-if)#exit | Exit interface mode. |
(config)#router ldp | Enter router mode for LDP. |
(config-router)#router-id 4.4.4.4 | Set the router ID to IP address 4.4.4.4 |
(config-router)#transport-address ipv4 4.4.4.4 0 | Configure the transport address for IPv4 (for IPv6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address. |
(config-router)#exit | Exit router mode |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 30.30.30.2/24 | Configure IPv4 address for xe1. |
(config-if)#label-switching | Enable label switching on interface xe1. |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe1. |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#interface xe2 | Enter interface mode. |
(config-if)#ip address 60.60.60.1/24 | Configure IPv4 address for xe2 |
(config-if)#label-switching | Enable label switching on interface xe2. |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe2. |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#router ospf 1 | Configure the routing process and specify the Process ID • The Process ID should be a unique positive integer identifying the routing process. |
(config)#ospf router-id 4.4.4.4 | Configure OSPF router-ID same as loopback interface IP address. |
(config-router)#network 4.4.4.4/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#network 30.30.30.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#network 60.60.60.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#bfd all-interfaces | Enable the OSPF enabled interfaces with bfd |
(config-if)#exit | Exit interface mode. |
(config)#bfd interval 3 minrx 3 multiplier 3 | Configure BFD interval |
(config)#commit | Commit all the configurations |
PE2
#configure terminal | Enter configuration mode. |
(config)#interface lo | Specify the loopback (lo) interface to be configured. |
(config-if)#ip address 5.5.5.5/32 secondary | Set the IP address of the loopback interface to 5.5.5.5/32 |
(config-if)#exit | Exit interface mode. |
(config)#router ldp | Enter router mode for LDP. |
(config-router)#router-id 5.5.5.5 | Set the router ID to IP address 5.5.5.5 |
(config-router)#transport-address ipv4 5.5.5.5 0 | Configure the transport address for IPv4 (for IPv6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address. |
(config-router)#targeted-peer ipv4 1.1.1.1 | Configure targeted peer. |
(config-router-targeted-peer)#exit | Exit-targeted-peer-mode |
(config-router)#exit | Exit router mode |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 40.40.40.2/24 | Configure IPv4 address for xe1. |
(config-if)#label-switching | Enable label switching on interface xe1. |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe1. |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#interface xe2 | Enter interface mode. |
(config-if)#ip address 50.50.50.2/24 | Configure IPv4 address for xe2 |
(config-if)#label-switching | Enable label switching on interface xe2. |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe2. |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#interface xe3 | Enter interface mode. |
(config-if)#ip address 60.60.60.2/24 | Configure IPv4 address for xe3 |
(config-if)#label-switching | Enable label switching on interface xe3 |
(config-if)#enable-ldp ipv4 | Enable LDP for IPv4 on xe3 |
(config-if)#mpls ldp-igp sync ospf holddown-timer 500 | Enable LDP-IGP Synchronization for xe1 belonging to an OSPF process.500 seconds is holddown-timer value for IGP to wait until LDP converges. OSPF: This command is part of OSPF Process. Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer. |
(config-if)#exit | Exit interface mode |
(config)#router ospf 1 | Configure the routing process and specify the Process ID • The Process ID should be a unique positive integer identifying the routing process. |
(config)#ospf router-id 5.5.5.5 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 5.5.5.5/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#network 40.40.40.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#network 50.50.50.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#network 60.60.60.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#bfd all-interfaces | Enable the OSPF enabled interfaces with bfd |
(config-if)#exit | Exit interface mode. |
(config)#bfd interval 3 minrx 3 multiplier 3 | Configure BFD interval |
(config)#commit | Commit all the configurations |
Validation
PE1
PE1#show ip ospf neighbor
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:31 10.10.10.2 xe1 0
3.3.3.3 1 Full/Backup 00:00:32 20.20.20.2 xe2 0
4.4.4.4 1 Full/Backup 00:00:33 30.30.30.2 xe3 0
PE1#show ip ospf interface brief
Interface PID Area Intf ID Cost State Neighbors Status
lo 1 0.0.0.0 1 1 Loopback 0 Up
Interface PID Area Intf ID Cost State Neighbors Status
xe1 1 0.0.0.0 4 10 DR 1 Up
Interface PID Area Intf ID Cost State Neighbors Status
xe2 1 0.0.0.0 14 15 DR 1 Up
Interface PID Area Intf ID Cost State Neighbors Status
xe3 1 0.0.0.0 15 20 DR 1 Up
PE1#show ip ospf database
OSPF Router with ID (1.1.1.1) (Process ID 1 VRF default)
Router Link States (Area 0.0.0.0)
Link ID ADV Router Age Seq# CkSum Link count
1.1.1.1 1.1.1.1 66 0x8000000e 0x5cf2 4
2.2.2.2 2.2.2.2 48 0x80000008 0x615f 3
3.3.3.3 3.3.3.3 48 0x80000008 0x64d7 3
4.4.4.4 4.4.4.4 44 0x80000008 0x6750 3
5.5.5.5 5.5.5.5 47 0x80000004 0xd65b 4
Net Link States (Area 0.0.0.0)
Link ID ADV Router Age Seq# CkSum
10.10.10.1 1.1.1.1 249 0x80000001 0x9476
20.20.20.1 1.1.1.1 152 0x80000001 0x5d8b
30.30.30.1 1.1.1.1 106 0x80000001 0x26a0
40.40.40.1 2.2.2.2 55 0x80000001 0xf2a9
50.50.50.1 3.3.3.3 53 0x80000001 0x8de8
60.60.60.1 4.4.4.4 50 0x80000001 0x2828
Area-Local Opaque-LSA (Area 0.0.0.0)
Link ID ADV Router Age Seq# CkSum Opaque ID
1.0.0.1 1.1.1.1 150 0x80000003 0x2cf8 1
1.0.0.1 2.2.2.2 54 0x80000002 0x32eb 1
1.0.0.1 3.3.3.3 51 0x80000003 0x34e0 1
1.0.0.1 4.4.4.4 48 0x80000003 0x38d4 1
1.0.0.1 5.5.5.5 54 0x80000001 0x40c6 1
1.0.0.8 4.4.4.4 48 0x80000001 0x7b37 8
1.0.0.8 5.5.5.5 49 0x80000001 0x7b32 8
1.0.0.10 1.1.1.1 236 0x80000002 0xda05 10
1.0.0.10 2.2.2.2 237 0x80000002 0x8360 10
1.0.0.12 3.3.3.3 46 0x80000002 0xc924 12
1.0.0.12 5.5.5.5 49 0x80000002 0xab39 12
1.0.0.22 2.2.2.2 46 0x80000002 0xdd46 22
1.0.0.22 5.5.5.5 47 0x80000002 0xa175 22
1.0.0.30 1.1.1.1 109 0x80000002 0x7614 30
1.0.0.30 3.3.3.3 110 0x80000002 0x424d 30
1.0.0.32 1.1.1.1 64 0x80000002 0xc680 32
1.0.0.32 4.4.4.4 65 0x80000002 0xb597 32
PE1#show ip route summary
-----------------------------------------------
IP routing table name is Default-IP-Routing-Table(0)
-----------------------------------------------
IP routing table maximum-paths : 8
Total number of IPv4 routes : 14
Total number of IPv4 paths : 14
Pending routes (due to route max reached): 0
Route Source Networks
kernel 1
connected 6
ospf 7
Total 14
FIB 14
ECMP statistics (active in ASIC):
Total number of IPv4 ECMP routes : 0
Total number of IPv4 ECMP paths : 0
PE1#show ip interface brief
'*' - address is assigned by dhcp client
Interface IP-Address Admin-Status Link-Status
xe0 *10.12.49.172 up up
xe1 unassigned up up
xe1 10.10.10.1 up up
xe3 unassigned up up
xe4 unassigned up up
xe5 unassigned up up
xe6 unassigned up up
xe7 unassigned up up
xe8 unassigned up up
xe9 unassigned up up
xe10 unassigned up up
xe11 unassigned up up
xe2 20.20.20.1 up up
xe3 30.30.30.1 up up
lo 127.0.0.1 up up
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
5.5.5.5 xe2 Passive OPERATIONAL 30 00:01:06
2.2.2.2 xe1 Passive OPERATIONAL 30 00:04:34
3.3.3.3 xe2 Passive OPERATIONAL 30 00:02:28
4.4.4.4 xe3 Passive OPERATIONAL 30 00:01:43
PE1#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
IP Route Table for VRF "default"
Gateway of last resort is 10.12.49.1 to network 0.0.0.0
K* 0.0.0.0/0 [0/0] via 10.12.49.1, xe0
C 1.1.1.1/32 is directly connected, lo, 00:10:42
O 2.2.2.2/32 [110/11] via 10.10.10.2, xe1, 00:04:54
O 3.3.3.3/32 [110/13] via 10.10.10.2, xe1, 00:01:41
O 4.4.4.4/32 [110/13] via 10.10.10.2, xe1, 00:01:41
O 5.5.5.5/32 [110/12] via 10.10.10.2, xe1, 00:01:43
C 10.10.10.0/24 is directly connected, xe1, 00:08:51
C 10.12.49.0/24 is directly connected, xe0, 16:20:51
C 20.20.20.0/24 is directly connected, xe2, 00:08:51
C 30.30.30.0/24 is directly connected, xe3, 00:08:51
O 40.40.40.0/24 [110/11] via 10.10.10.2, xe1, 00:01:43
O 50.50.50.0/24 [110/12] via 10.10.10.2, xe1, 00:01:41
O 60.60.60.0/24 [110/12] via 10.10.10.2, xe1, 00:01:41
C 127.0.0.0/8 is directly connected, lo, 16:34:27
PE1#show ldp routes
Prefix Addr Nexthop Addr Intf Owner
0.0.0.0/0 10.12.49.1 xe0 kernel
1.1.1.1/32 0.0.0.0 lo connected
2.2.2.2/32 10.10.10.2 xe1 ospf
3.3.3.3/32 10.10.10.2 xe1 ospf
4.4.4.4/32 10.10.10.2 xe1 ospf
5.5.5.5/32 10.10.10.2 xe1 ospf
10.10.10.0/24 0.0.0.0 xe1 connected
10.12.49.0/24 0.0.0.0 xe0 connected
20.20.20.0/24 0.0.0.0 xe2 connected
30.30.30.0/24 0.0.0.0 xe3 connected
40.40.40.0/24 10.10.10.2 xe1 ospf
50.50.50.0/24 10.10.10.2 xe1 ospf
60.60.60.0/24 10.10.10.2 xe1 ospf
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 1 1 - Yes LSP_DEFAULT 3 xe1 No 10.10.10.2
L> 3.3.3.3/32 3 9 - Yes LSP_DEFAULT 25601 xe1 No 10.10.10.2
L> 4.4.4.4/32 5 10 - Yes LSP_DEFAULT 25602 xe1 No 10.10.10.2
L> 5.5.5.5/32 7 7 - Yes LSP_DEFAULT 25600 xe1 No 10.10.10.2
L> 40.40.40.0/24 2 1 - Yes LSP_DEFAULT 3 xe1 No 10.10.10.2
L> 50.50.50.0/24 4 11 - Yes LSP_DEFAULT 25612 xe1 No 10.10.10.2
L> 60.60.60.0/24 6 8 - Yes LSP_DEFAULT 25609 xe1 No 10.10.10.2
PE1#show mpls forwarding-table 5.5.5.5/32
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 5.5.5.5/32 7 7 - Yes LSP_DEFAULT 25600 xe1 No 10.10.10.2
PE1#show ldp fec
LSR codes : E/N - LSR is egress/non-egress for this FEC,
L - LSR received a label for this FEC,
> - LSR will use this route for the FEC
FEC Code Session Out Label ELC Nexthop Addr
1.1.1.1/32 E > non-existent none No connected
2.2.2.2/32 NL 4.4.4.4 25608 No no nexthop
NL 3.3.3.3 25607 No no nexthop
NL> 2.2.2.2 impl-null No 10.10.10.2
3.3.3.3/32 NL 4.4.4.4 25609 No no nexthop
NL> 2.2.2.2 25601 No 10.10.10.2
NL 3.3.3.3 impl-null No no nexthop
4.4.4.4/32 NL 3.3.3.3 25608 No no nexthop
NL> 2.2.2.2 25602 No 10.10.10.2
NL 4.4.4.4 impl-null No no nexthop
5.5.5.5/32 NL 4.4.4.4 25610 No no nexthop
NL> 2.2.2.2 25600 No 10.10.10.2
NL 3.3.3.3 25600 No no nexthop
10.10.10.0/24 NL 4.4.4.4 25611 No connected
NL 3.3.3.3 25610 No connected
NL 2.2.2.2 impl-null No connected
E > non-existent none No connected
10.12.49.0/24 NL 4.4.4.4 impl-null No connected
NL 3.3.3.3 impl-null No connected
NL 2.2.2.2 impl-null No connected
E > non-existent none No connected
20.20.20.0/24 NL 4.4.4.4 25612 No connected
NL 2.2.2.2 25610 No connected
NL 3.3.3.3 impl-null No connected
E > non-existent none No connected
30.30.30.0/24 NL 3.3.3.3 25611 No connected
NL 2.2.2.2 25611 No connected
NL 4.4.4.4 impl-null No connected
E > non-existent none No connected
40.40.40.0/24 NL 4.4.4.4 25613 No no nexthop
NL 3.3.3.3 25612 No no nexthop
NL> 2.2.2.2 impl-null No 10.10.10.2
50.50.50.0/24 NL 4.4.4.4 25614 No no nexthop
NL> 2.2.2.2 25612 No 10.10.10.2
NL 3.3.3.3 impl-null No no nexthop
60.60.60.0/24 NL> 2.2.2.2 25609 No 10.10.10.2
NL 3.3.3.3 25609 No no nexthop
NL 4.4.4.4 impl-null No no nexthop
PE1#show ldp downstream
gSession peer 5.5.5.5:
FEC Nexthop Addr State Label Req.ID Attr
Session peer 2.2.2.2:
FEC Nexthop Addr State Label Req.ID Attr
50.50.50.0/24 10.10.10.2 Established 25612 0
30.30.30.0/24 connected Established 25611 0
20.20.20.0/24 connected Established 25610 0
4.4.4.4/32 10.10.10.2 Established 25602 0
3.3.3.3/32 10.10.10.2 Established 25601 0
60.60.60.0/24 10.10.10.2 Established 25609 0
5.5.5.5/32 10.10.10.2 Established 25600 0
40.40.40.0/24 10.10.10.2 Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
10.10.10.0/24 connected Established impl-null 0
2.2.2.2/32 10.10.10.2 Established impl-null 0
Session peer 3.3.3.3:
FEC Nexthop Addr State Label Req.ID Attr
40.40.40.0/24 connected Established 25612 0
30.30.30.0/24 connected Established 25611 0
10.10.10.0/24 connected Established 25610 0
4.4.4.4/32 connected Established 25608 0
2.2.2.2/32 connected Established 25607 0
60.60.60.0/24 connected Established 25609 0
5.5.5.5/32 connected Established 25600 0
50.50.50.0/24 connected Established impl-null 0
20.20.20.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
3.3.3.3/32 connected Established impl-null 0
Session peer 4.4.4.4:
FEC Nexthop Addr State Label Req.ID Attr
50.50.50.0/24 connected Established 25614 0
40.40.40.0/24 connected Established 25613 0
20.20.20.0/24 connected Established 25612 0
10.10.10.0/24 connected Established 25611 0
5.5.5.5/32 connected Established 25610 0
3.3.3.3/32 connected Established 25609 0
2.2.2.2/32 connected Established 25608 0
60.60.60.0/24 connected Established impl-null 0
30.30.30.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
4.4.4.4/32 connected Established impl-null 0
PE1#show ldp lsp
DOWNSTREAM LSP :
FEC Nexthop Addr State Label Req.ID Attr
1.1.1.1/32 connected Established none 0 None
2.2.2.2/32 connected Established 25608 0
2.2.2.2/32 connected Established 25607 0
2.2.2.2/32 10.10.10.2 Established impl-null 0
3.3.3.3/32 connected Established 25609 0
3.3.3.3/32 10.10.10.2 Established 25601 0
3.3.3.3/32 connected Established impl-null 0
4.4.4.4/32 connected Established 25608 0
4.4.4.4/32 10.10.10.2 Established 25602 0
4.4.4.4/32 connected Established impl-null 0
5.5.5.5/32 connected Established 25610 0
5.5.5.5/32 10.10.10.2 Established 25600 0
5.5.5.5/32 connected Established 25600 0
10.10.10.0/24 connected Established 25611 0
10.10.10.0/24 connected Established 25610 0
10.10.10.0/24 connected Established impl-null 0
10.10.10.0/24 connected Established none 0 None
10.12.49.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established none 0 None
20.20.20.0/24 connected Established 25612 0
20.20.20.0/24 connected Established 25610 0
20.20.20.0/24 connected Established impl-null 0
20.20.20.0/24 connected Established none 0 None
30.30.30.0/24 connected Established 25611 0
30.30.30.0/24 connected Established 25611 0
30.30.30.0/24 connected Established impl-null 0
30.30.30.0/24 connected Established none 0 None
40.40.40.0/24 connected Established 25613 0
40.40.40.0/24 connected Established 25612 0
40.40.40.0/24 10.10.10.2 Established impl-null 0
50.50.50.0/24 connected Established 25614 0
50.50.50.0/24 10.10.10.2 Established 25612 0
50.50.50.0/24 connected Established impl-null 0
60.60.60.0/24 10.10.10.2 Established 25609 0
60.60.60.0/24 connected Established 25609 0
60.60.60.0/24 connected Established impl-null 0
UPSTREAM LSP :
FEC State Label Req.ID Attr
1.1.1.1/32 Established impl-null 0 None
1.1.1.1/32 Established impl-null 0 None
1.1.1.1/32 Established impl-null 0 None
2.2.2.2/32 Established 25602 0 None
2.2.2.2/32 Established 25608 0 None
3.3.3.3/32 Established 25614 0 None
3.3.3.3/32 Established 25609 0 None
3.3.3.3/32 Established 25609 0 None
4.4.4.4/32 Established 25605 0 None
4.4.4.4/32 Established 25615 0 None
4.4.4.4/32 Established 25605 0 None
5.5.5.5/32 Established 25606 0 None
5.5.5.5/32 Established 25613 0 None
5.5.5.5/32 Established 25613 0 None
10.10.10.0/24 Established impl-null 0 None
10.10.10.0/24 Established impl-null 0 None
10.10.10.0/24 Established impl-null 0 None
10.12.49.0/24 Established impl-null 0 None
10.12.49.0/24 Established impl-null 0 None
10.12.49.0/24 Established impl-null 0 None
20.20.20.0/24 Established impl-null 0 None
20.20.20.0/24 Established impl-null 0 None
20.20.20.0/24 Established impl-null 0 None
30.30.30.0/24 Established impl-null 0 None
30.30.30.0/24 Established impl-null 0 None
30.30.30.0/24 Established impl-null 0 None
40.40.40.0/24 Established 25603 0 None
40.40.40.0/24 Established 25610 0 None
50.50.50.0/24 Established 25616 0 None
50.50.50.0/24 Established 25611 0 None
50.50.50.0/24 Established 25611 0 None
60.60.60.0/24 Established 25607 0 None
60.60.60.0/24 Established 25612 0 None
60.60.60.0/24 Established 25612 0 None
60.60.60.0/24 Established 25607 0 None
PE1#show ldp lsp
DOWNSTREAM LSP :
FEC Nexthop Addr State Label Req.ID Attr
1.1.1.1/32 connected Established none 0 None
2.2.2.2/32 connected Established 25608 0
2.2.2.2/32 connected Established 25607 0
2.2.2.2/32 10.10.10.2 Established impl-null 0
3.3.3.3/32 connected Established 25609 0
3.3.3.3/32 10.10.10.2 Established 25601 0
3.3.3.3/32 connected Established impl-null 0
4.4.4.4/32 connected Established 25608 0
4.4.4.4/32 10.10.10.2 Established 25602 0
4.4.4.4/32 connected Established impl-null 0
5.5.5.5/32 connected Established 25610 0
5.5.5.5/32 10.10.10.2 Established 25600 0
5.5.5.5/32 connected Established 25600 0
10.10.10.0/24 connected Established 25611 0
10.10.10.0/24 connected Established 25610 0
10.10.10.0/24 connected Established impl-null 0
10.10.10.0/24 connected Established none 0 None
10.12.49.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established none 0 None
20.20.20.0/24 connected Established 25612 0
20.20.20.0/24 connected Established 25610 0
20.20.20.0/24 connected Established impl-null 0
20.20.20.0/24 connected Established none 0 None
30.30.30.0/24 connected Established 25611 0
30.30.30.0/24 connected Established 25611 0
30.30.30.0/24 connected Established impl-null 0
30.30.30.0/24 connected Established none 0 None
40.40.40.0/24 connected Established 25613 0
40.40.40.0/24 connected Established 25612 0
40.40.40.0/24 10.10.10.2 Established impl-null 0
50.50.50.0/24 connected Established 25614 0
50.50.50.0/24 10.10.10.2 Established 25612 0
50.50.50.0/24 connected Established impl-null 0
60.60.60.0/24 10.10.10.2 Established 25609 0
60.60.60.0/24 connected Established 25609 0
60.60.60.0/24 connected Established impl-null 0
UPSTREAM LSP :
FEC State Label Req.ID Attr
1.1.1.1/32 Established impl-null 0 None
1.1.1.1/32 Established impl-null 0 None
1.1.1.1/32 Established impl-null 0 None
2.2.2.2/32 Established 25602 0 None
2.2.2.2/32 Established 25608 0 None
3.3.3.3/32 Established 25614 0 None
3.3.3.3/32 Established 25609 0 None
3.3.3.3/32 Established 25609 0 None
4.4.4.4/32 Established 25605 0 None
4.4.4.4/32 Established 25615 0 None
4.4.4.4/32 Established 25605 0 None
5.5.5.5/32 Established 25606 0 None
5.5.5.5/32 Established 25613 0 None
5.5.5.5/32 Established 25613 0 None
10.10.10.0/24 Established impl-null 0 None
10.10.10.0/24 Established impl-null 0 None
10.10.10.0/24 Established impl-null 0 None
10.12.49.0/24 Established impl-null 0 None
10.12.49.0/24 Established impl-null 0 None
10.12.49.0/24 Established impl-null 0 None
20.20.20.0/24 Established impl-null 0 None
20.20.20.0/24 Established impl-null 0 None
20.20.20.0/24 Established impl-null 0 None
30.30.30.0/24 Established impl-null 0 None
30.30.30.0/24 Established impl-null 0 None
30.30.30.0/24 Established impl-null 0 None
40.40.40.0/24 Established 25603 0 None
40.40.40.0/24 Established 25610 0 None
50.50.50.0/24 Established 25616 0 None
50.50.50.0/24 Established 25611 0 None
50.50.50.0/24 Established 25611 0 None
60.60.60.0/24 Established 25607 0 None
60.60.60.0/24 Established 25612 0 None
60.60.60.0/24 Established 25612 0 None
60.60.60.0/24 Established 25607 0 None
PE1#show ldp fec prefix 5.5.5.5/32
LSR codes : E/N - LSR is egress/non-egress for this FEC,
L - LSR received a label for this FEC,
> - LSR will use this route for the FEC
FEC Code Session Out Label ELC Nexthop Addr
5.5.5.5/32 NL 4.4.4.4 25610 No no nexthop
NL> 2.2.2.2 25600 No 10.10.10.2
NL 3.3.3.3 25600 No no nexthop
PE1#show mpls ftn-table
Primary FTN entry with FEC: 2.2.2.2/32, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe1, out label: 3
Nexthop addr: 10.10.10.2 cross connect ix: 1, op code: Push
Primary FTN entry with FEC: 3.3.3.3/32, id: 3, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 9
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 9, owner: LDP, Stale: NO, out intf: xe1, out label: 25601
Nexthop addr: 10.10.10.2 cross connect ix: 5, op code: Push
Primary FTN entry with FEC: 4.4.4.4/32, id: 5, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 10
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: LDP, Stale: NO, out intf: xe1, out label: 25602
Nexthop addr: 10.10.10.2 cross connect ix: 6, op code: Push
Primary FTN entry with FEC: 5.5.5.5/32, id: 7, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:391, pkts:5, TX bytes:411, Pushed pkts:5
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 7
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: LDP, Stale: NO, out intf: xe1, out label: 25600
Nexthop addr: 10.10.10.2 cross connect ix: 2, op code: Push
Primary FTN entry with FEC: 40.40.40.0/24, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe1, out label: 3
Nexthop addr: 10.10.10.2 cross connect ix: 1, op code: Push
Primary FTN entry with FEC: 50.50.50.0/24, id: 4, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 11
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 11, owner: LDP, Stale: NO, out intf: xe1, out label: 25612
Nexthop addr: 10.10.10.2 cross connect ix: 7, op code: Push
Primary FTN entry with FEC: 60.60.60.0/24, id: 6, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 8
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 8, owner: LDP, Stale: NO, out intf: xe1, out label: 25609
Nexthop addr: 10.10.10.2 cross connect ix: 8, op code: Push
PE1#show mpls ftn-table 5.5.5.5/32
Primary FTN entry with FEC: 5.5.5.5/32, id: 7, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:391, pkts:5, TX bytes:411, Pushed pkts:5
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 7
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: LDP, Stale: NO, out intf: xe1, out label: 25600
Nexthop addr: 10.10.10.2 cross connect ix: 2, op code: Push
PE1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM, ! - using backup
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
L> 2.2.2.2/32 9 25608 3 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 4.4.4.4/32 6 25605 25602 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 2.2.2.2/32 3 25602 3 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 40.40.40.0/24 4 25603 3 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 5.5.5.5/32 7 25606 25600 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 60.60.60.0/24 8 25607 25609 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 60.60.60.0/24 13 25612 25609 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 40.40.40.0/24 11 25610 3 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 3.3.3.3/32 10 25609 25601 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 50.50.50.0/24 12 25611 25612 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 3.3.3.3/32 15 25614 25601 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 5.5.5.5/32 14 25613 25600 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 4.4.4.4/32 16 25615 25602 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
L> 50.50.50.0/24 17 25616 25612 N/A xe1 10.10.10.2 Yes LSP_DEFAULT
PE2
PE2#show ip ospf neighbor
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/DR 00:00:36 40.40.40.1 xe1 0
3.3.3.3 1 Full/DR 00:00:37 50.50.50.1 xe2 0
4.4.4.4 1 Full/DR 00:00:31 60.60.60.1 xe3 0
PE2#show ip ospf interface brief
Interface PID Area Intf ID Cost State Neighbors Status
lo 1 0.0.0.0 1 1 Loopback 0 Up
Interface PID Area Intf ID Cost State Neighbors Status
xe3 1 0.0.0.0 3 1 Backup 1 Up
Interface PID Area Intf ID Cost State Neighbors Status
xe2 1 0.0.0.0 5 1 Backup 1 Up
Interface PID Area Intf ID Cost State Neighbors Status
xe1 1 0.0.0.0 10 1 Backup 1 Up
PE2#show ip ospf database
OSPF Router with ID (5.5.5.5) (Process ID 1 VRF default)
Router Link States (Area 0.0.0.0)
Link ID ADV Router Age Seq# CkSum Link count
1.1.1.1 1.1.1.1 650 0x8000000e 0x5cf2 4
2.2.2.2 2.2.2.2 630 0x80000008 0x615f 3
3.3.3.3 3.3.3.3 631 0x80000008 0x64d7 3
4.4.4.4 4.4.4.4 627 0x80000008 0x6750 3
5.5.5.5 5.5.5.5 628 0x80000004 0xd65b 4
Net Link States (Area 0.0.0.0)
Link ID ADV Router Age Seq# CkSum
10.10.10.1 1.1.1.1 833 0x80000001 0x9476
20.20.20.1 1.1.1.1 736 0x80000001 0x5d8b
30.30.30.1 1.1.1.1 690 0x80000001 0x26a0
40.40.40.1 2.2.2.2 637 0x80000001 0xf2a9
50.50.50.1 3.3.3.3 636 0x80000001 0x8de8
60.60.60.1 4.4.4.4 632 0x80000001 0x2828
Area-Local Opaque-LSA (Area 0.0.0.0)
Link ID ADV Router Age Seq# CkSum Opaque ID
1.0.0.1 1.1.1.1 734 0x80000003 0x2cf8 1
1.0.0.1 2.2.2.2 638 0x80000002 0x32eb 1
1.0.0.1 3.3.3.3 634 0x80000003 0x34e0 1
1.0.0.1 4.4.4.4 630 0x80000003 0x38d4 1
1.0.0.1 5.5.5.5 634 0x80000001 0x40c6 1
1.0.0.8 4.4.4.4 630 0x80000001 0x7b37 8
1.0.0.8 5.5.5.5 629 0x80000001 0x7b32 8
1.0.0.10 1.1.1.1 819 0x80000002 0xda05 10
1.0.0.10 2.2.2.2 818 0x80000002 0x8360 10
1.0.0.12 3.3.3.3 629 0x80000002 0xc924 12
1.0.0.12 5.5.5.5 629 0x80000002 0xab39 12
1.0.0.22 2.2.2.2 628 0x80000002 0xdd46 22
1.0.0.22 5.5.5.5 627 0x80000002 0xa175 22
1.0.0.30 1.1.1.1 693 0x80000002 0x7614 30
1.0.0.30 3.3.3.3 694 0x80000002 0x424d 30
1.0.0.32 1.1.1.1 648 0x80000002 0xc680 32
1.0.0.32 4.4.4.4 649 0x80000002 0xb597 32
PE2#show ip route summary
-----------------------------------------------
IP routing table name is Default-IP-Routing-Table(0)
-----------------------------------------------
IP routing table maximum-paths : 8
Total number of IPv4 routes : 14
Total number of IPv4 paths : 16
Pending routes (due to route max reached): 0
Route Source Networks
kernel 1
connected 6
ospf 7
Total 14
FIB 14
ECMP statistics (active in ASIC):
Total number of IPv4 ECMP routes : 1
Total number of IPv4 ECMP paths : 3
Number of routes with 3 ECMP paths: 1
PE2#show ip interface brief
'*' - address is assigned by dhcp client
Interface IP-Address Admin-Status Link-Status
xe0 *10.12.49.174 up up
xe3 60.60.60.2 up up
xe2 unassigned up up
xe2 50.50.50.2 up up
xe4 unassigned up up
xe5 unassigned up up
xe6 unassigned up up
xe7 unassigned up up
xe1 40.40.40.2 up up
xe9 unassigned up up
xe30 unassigned up up
xe31 unassigned up up
xe32 unassigned up up
xe33 unassigned up up
lo 127.0.0.1 up up
PE2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
1.1.1.1 xe1 Active OPERATIONAL 30 00:10:40
2.2.2.2 xe1 Active OPERATIONAL 30 00:10:58
3.3.3.3 xe2 Active OPERATIONAL 30 00:10:58
4.4.4.4 xe3 Active OPERATIONAL 30 00:10:59
PE2#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
IP Route Table for VRF "default"
Gateway of last resort is 10.12.49.1 to network 0.0.0.0
K* 0.0.0.0/0 [0/0] via 10.12.49.1, xe0
O 1.1.1.1/32 [110/3] via 60.60.60.1, xe3, 00:11:10
[110/3] via 40.40.40.1, xe1
[110/3] via 50.50.50.1, xe2
O 2.2.2.2/32 [110/2] via 40.40.40.1, xe1, 00:11:04
O 3.3.3.3/32 [110/2] via 50.50.50.1, xe2, 00:11:04
O 4.4.4.4/32 [110/2] via 60.60.60.1, xe3, 00:11:10
C 5.5.5.5/32 is directly connected, lo, 00:11:16
O 10.10.10.0/24 [110/2] via 40.40.40.1, xe1, 00:11:04
C 10.12.49.0/24 is directly connected, xe0, 16:28:18
O 20.20.20.0/24 [110/2] via 50.50.50.1, xe2, 00:11:04
O 30.30.30.0/24 [110/2] via 60.60.60.1, xe3, 00:11:10
C 40.40.40.0/24 is directly connected, xe1, 00:11:16
C 50.50.50.0/24 is directly connected, xe2, 00:11:16
C 60.60.60.0/24 is directly connected, xe3, 00:11:16
C 127.0.0.0/8 is directly connected, lo, 16:43:24
PE2#show ldp routes
Prefix Addr Nexthop Addr Intf Owner
0.0.0.0/0 10.12.49.1 xe0 kernel
1.1.1.1/32 50.50.50.1 xe2 ospf
40.40.40.1 xe1 ospf
60.60.60.1 xe3 ospf
2.2.2.2/32 40.40.40.1 xe1 ospf
3.3.3.3/32 50.50.50.1 xe2 ospf
4.4.4.4/32 60.60.60.1 xe3 ospf
5.5.5.5/32 0.0.0.0 lo connected
10.10.10.0/24 40.40.40.1 xe1 ospf
10.12.49.0/24 0.0.0.0 xe0 connected
20.20.20.0/24 50.50.50.1 xe2 ospf
30.30.30.0/24 60.60.60.1 xe3 ospf
40.40.40.0/24 0.0.0.0 xe1 connected
50.50.50.0/24 0.0.0.0 xe2 connected
60.60.60.0/24 0.0.0.0 xe3 connected
PE2#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 1 1 - Yes LSP_DEFAULT 25601 xe2 No 50.50.50.1
5 - Yes LSP_DEFAULT 25603 xe1 No 40.40.40.1
9 - Yes LSP_DEFAULT 25600 xe3 No 60.60.60.1
L> 2.2.2.2/32 6 6 - Yes LSP_DEFAULT 3 xe1 No 40.40.40.1
L> 3.3.3.3/32 2 2 - Yes LSP_DEFAULT 3 xe2 No 50.50.50.1
L> 4.4.4.4/32 3 10 - Yes LSP_DEFAULT 3 xe3 No 60.60.60.1
L> 10.10.10.0/24 7 6 - Yes LSP_DEFAULT 3 xe1 No 40.40.40.1
L> 20.20.20.0/24 4 2 - Yes LSP_DEFAULT 3 xe2 No 50.50.50.1
L> 30.30.30.0/24 5 10 - Yes LSP_DEFAULT 3 xe3 No 60.60.60.1
PE2#show mpls forwarding-table 5.5.5.5/32
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
PE2#show mpls forwarding-table 1.1.1.1/32
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 1 1 - Yes LSP_DEFAULT 25601 xe2 No 50.50.50.1
5 - Yes LSP_DEFAULT 25603 xe1 No 40.40.40.1
9 - Yes LSP_DEFAULT 25600 xe3 No 60.60.60.1
PE2#show ldp routes
Prefix Addr Nexthop Addr Intf Owner
0.0.0.0/0 10.12.49.1 xe0 kernel
1.1.1.1/32 50.50.50.1 xe2 ospf
40.40.40.1 xe1 ospf
60.60.60.1 xe3 ospf
2.2.2.2/32 40.40.40.1 xe1 ospf
3.3.3.3/32 50.50.50.1 xe2 ospf
4.4.4.4/32 60.60.60.1 xe3 ospf
5.5.5.5/32 0.0.0.0 lo connected
10.10.10.0/24 40.40.40.1 xe1 ospf
10.12.49.0/24 0.0.0.0 xe0 connected
20.20.20.0/24 50.50.50.1 xe2 ospf
30.30.30.0/24 60.60.60.1 xe3 ospf
40.40.40.0/24 0.0.0.0 xe1 connected
50.50.50.0/24 0.0.0.0 xe2 connected
60.60.60.0/24 0.0.0.0 xe3 connected
PE2#show ldp fec
LSR codes : E/N - LSR is egress/non-egress for this FEC,
L - LSR received a label for this FEC,
> - LSR will use this route for the FEC
FEC Code Session Out Label ELC Nexthop Addr
1.1.1.1/32 NL> 2.2.2.2 25603 No 40.40.40.1
NL> 3.3.3.3 25601 No 50.50.50.1
NL> 4.4.4.4 25600 No 60.60.60.1
2.2.2.2/32 NL> 2.2.2.2 impl-null No 40.40.40.1
3.3.3.3/32 NL> 3.3.3.3 impl-null No 50.50.50.1
4.4.4.4/32 NL> 4.4.4.4 impl-null No 60.60.60.1
5.5.5.5/32 E > non-existent none No connected
10.10.10.0/24 NL> 2.2.2.2 impl-null No 40.40.40.1
10.12.49.0/24 NL 2.2.2.2 impl-null No connected
NL 3.3.3.3 impl-null No connected
NL 4.4.4.4 impl-null No connected
E > non-existent none No connected
20.20.20.0/24 NL> 3.3.3.3 impl-null No 50.50.50.1
30.30.30.0/24 NL> 4.4.4.4 impl-null No 60.60.60.1
40.40.40.0/24 NL 2.2.2.2 impl-null No connected
E > non-existent none No connected
50.50.50.0/24 NL 3.3.3.3 impl-null No connected
E > non-existent none No connected
60.60.60.0/24 NL 4.4.4.4 impl-null No connected
E > non-existent none No connected
PE2#show ldp downstream
Session peer 1.1.1.1:
FEC Nexthop Addr State Label Req.ID Attr
Session peer 2.2.2.2:
FEC Nexthop Addr State Label Req.ID Attr
40.40.40.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
10.10.10.0/24 40.40.40.1 Established impl-null 0
2.2.2.2/32 40.40.40.1 Established impl-null 0
1.1.1.1/32 40.40.40.1 Established 25603 0
Session peer 3.3.3.3:
FEC Nexthop Addr State Label Req.ID Attr
50.50.50.0/24 connected Established impl-null 0
20.20.20.0/24 50.50.50.1 Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
3.3.3.3/32 50.50.50.1 Established impl-null 0
1.1.1.1/32 50.50.50.1 Established 25601 0
Session peer 4.4.4.4:
FEC Nexthop Addr State Label Req.ID Attr
60.60.60.0/24 connected Established impl-null 0
30.30.30.0/24 60.60.60.1 Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
4.4.4.4/32 60.60.60.1 Established impl-null 0
1.1.1.1/32 60.60.60.1 Established 25600 0
PE2#show ldp lsp
DOWNSTREAM LSP :
FEC Nexthop Addr State Label Req.ID Attr
1.1.1.1/32 40.40.40.1 Established 25603 0
1.1.1.1/32 50.50.50.1 Established 25601 0
1.1.1.1/32 60.60.60.1 Established 25600 0
2.2.2.2/32 40.40.40.1 Established impl-null 0
3.3.3.3/32 50.50.50.1 Established impl-null 0
4.4.4.4/32 60.60.60.1 Established impl-null 0
5.5.5.5/32 connected Established none 0 None
10.10.10.0/24 40.40.40.1 Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established impl-null 0
10.12.49.0/24 connected Established none 0 None
20.20.20.0/24 50.50.50.1 Established impl-null 0
30.30.30.0/24 60.60.60.1 Established impl-null 0
40.40.40.0/24 connected Established impl-null 0
40.40.40.0/24 connected Established none 0 None
50.50.50.0/24 connected Established impl-null 0
50.50.50.0/24 connected Established none 0 None
60.60.60.0/24 connected Established impl-null 0
60.60.60.0/24 connected Established none 0 None
UPSTREAM LSP :
FEC State Label Req.ID Attr
2.2.2.2/32 Established 25607 0 None
2.2.2.2/32 Established 25601 0 None
3.3.3.3/32 Established 25602 0 None
3.3.3.3/32 Established 25609 0 None
4.4.4.4/32 Established 25611 0 None
4.4.4.4/32 Established 25612 0 None
5.5.5.5/32 Established impl-null 0 None
5.5.5.5/32 Established impl-null 0 None
5.5.5.5/32 Established impl-null 0 None
10.10.10.0/24 Established 25608 0 None
10.10.10.0/24 Established 25604 0 None
10.12.49.0/24 Established impl-null 0 None
10.12.49.0/24 Established impl-null 0 None
10.12.49.0/24 Established impl-null 0 None
20.20.20.0/24 Established 25605 0 None
20.20.20.0/24 Established 25610 0 None
30.30.30.0/24 Established 25613 0 None
30.30.30.0/24 Established 25614 0 None
40.40.40.0/24 Established impl-null 0 None
40.40.40.0/24 Established impl-null 0 None
40.40.40.0/24 Established impl-null 0 None
50.50.50.0/24 Established impl-null 0 None
50.50.50.0/24 Established impl-null 0 None
50.50.50.0/24 Established impl-null 0 None
60.60.60.0/24 Established impl-null 0 None
60.60.60.0/24 Established impl-null 0 None
60.60.60.0/24 Established impl-null 0 None
60.60.60.0/24 Established impl-null 0 None
60.60.60.0/24 Established impl-null 0 None
PE2#show ldp fec prefix 1.1.1.1/32
LSR codes : E/N - LSR is egress/non-egress for this FEC,
L - LSR received a label for this FEC,
> - LSR will use this route for the FEC
FEC Code Session Out Label ELC Nexthop Addr
1.1.1.1/32 NL> 2.2.2.2 25603 No 40.40.40.1
NL> 3.3.3.3 25601 No 50.50.50.1
NL> 4.4.4.4 25600 No 60.60.60.1
PE2#show router-id
Name: management
Router ID is not set
Name: default
Router ID: 10.12.49.174 (automatic)
PE2#show mpls ftn-table
Primary FTN entry with FEC: 1.1.1.1/32, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 1
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: LDP, Stale: NO, out intf: xe2, out label: 25601
Nexthop addr: 50.50.50.1 cross connect ix: 2, op code: Push
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 5
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Not present
Out-segment with ix: 5, owner: LDP, Stale: NO, out intf: xe1, out label: 25603
Nexthop addr: 40.40.40.1 cross connect ix: 2, op code: Push
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 9
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Not present
Out-segment with ix: 9, owner: LDP, Stale: NO, out intf: xe3, out label: 25600
Nexthop addr: 60.60.60.1 cross connect ix: 2, op code: Push
Primary FTN entry with FEC: 2.2.2.2/32, id: 6, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 6
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: N/A, Stale: NO, out intf: xe1, out label: 3
Nexthop addr: 40.40.40.1 cross connect ix: 6, op code: Push
Primary FTN entry with FEC: 3.3.3.3/32, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 2
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: N/A, Stale: NO, out intf: xe2, out label: 3
Nexthop addr: 50.50.50.1 cross connect ix: 3, op code: Push
Primary FTN entry with FEC: 4.4.4.4/32, id: 3, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 10
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: N/A, Stale: NO, out intf: xe3, out label: 3
Nexthop addr: 60.60.60.1 cross connect ix: 1, op code: Push
Primary FTN entry with FEC: 10.10.10.0/24, id: 7, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 6
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: N/A, Stale: NO, out intf: xe1, out label: 3
Nexthop addr: 40.40.40.1 cross connect ix: 6, op code: Push
Primary FTN entry with FEC: 20.20.20.0/24, id: 4, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 2
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: N/A, Stale: NO, out intf: xe2, out label: 3
Nexthop addr: 50.50.50.1 cross connect ix: 3, op code: Push
Primary FTN entry with FEC: 30.30.30.0/24, id: 5, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 10
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: N/A, Stale: NO, out intf: xe3, out label: 3
Nexthop addr: 60.60.60.1 cross connect ix: 1, op code: Push
PE2#show mpls ftn-table 1.1.1.1/32
Primary FTN entry with FEC: 1.1.1.1/32, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 1
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: LDP, Stale: NO, out intf: xe2, out label: 25601
Nexthop addr: 50.50.50.1 cross connect ix: 2, op code: Push
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 5
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Not present
Out-segment with ix: 5, owner: LDP, Stale: NO, out intf: xe1, out label: 25603
Nexthop addr: 40.40.40.1 cross connect ix: 2, op code: Push
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 9
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Not present
Out-segment with ix: 9, owner: LDP, Stale: NO, out intf: xe3, out label: 25600
Nexthop addr: 60.60.60.1 cross connect ix: 2, op code: Push
PE2#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM, ! - using backup
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
L> 3.3.3.3/32 10 25609 3 N/A xe2 50.50.50.1 Yes LSP_DEFAULT
L> 20.20.20.0/24 6 25605 3 N/A xe2 50.50.50.1 Yes LSP_DEFAULT
L> 3.3.3.3/32 3 25602 3 N/A xe2 50.50.50.1 Yes LSP_DEFAULT
L> 2.2.2.2/32 2 25601 3 N/A xe1 40.40.40.1 Yes LSP_DEFAULT
L> 10.10.10.0/24 5 25604 3 N/A xe1 40.40.40.1 Yes LSP_DEFAULT
L> 2.2.2.2/32 8 25607 3 N/A xe1 40.40.40.1 Yes LSP_DEFAULT
L> 10.10.10.0/24 9 25608 3 N/A xe1 40.40.40.1 Yes LSP_DEFAULT
L> 4.4.4.4/32 12 25611 3 N/A xe3 60.60.60.1 Yes LSP_DEFAULT
L> 20.20.20.0/24 11 25610 3 N/A xe2 50.50.50.1 Yes LSP_DEFAULT
L> 30.30.30.0/24 14 25613 3 N/A xe3 60.60.60.1 Yes LSP_DEFAULT
L> 4.4.4.4/32 13 25612 3 N/A xe3 60.60.60.1 Yes LSP_DEFAULT
L> 30.30.30.0/24 15 25614 3 N/A xe3 60.60.60.1 Yes LSP_DEFAULT