OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : LDP Configuration : LDP Session Protection
LDP Session Protection
LDP Session Protection is an optimization feature. It is used when directly connected LDP peer sessions (via multicast) become unavailable but still have IP reachability over a different path. LDP bindings are kept in the LIB to save time from full synchronization when the direct connections comes back up.
There are two types of LDP connections:
Direct LDP Session - directly connected LSR, one hop away.
Targeted LDP Session - not directly connected LSR, multiple hops away.
By default if the directly connected LDP session loses connectivity to its peer, all bindings are flushed from the LIB. When interfaces come up and LDP sessions are re-established, LDP has to synchronize its label bindings.
LDP Session Protection is an optimization, when enabled, will not flush the LIB when direct LDP sessions go down. As long as there exists another path to the LDP Peer, it will maintain the LIB synchronized using Targeted LDP Session. IGP will cause a reroute, but the label bindings will still be present from the old peer. When interfaces come back up, LDP will not need to synchronize since it maintains the state using the targeted sessions.
1. Running LDP Session Protection on a system requires the following tasks:
2. Enabling label-switching on the interface on NSM.
3. Enabling LDP on an interface in the LDP daemon.
4. Running an IGP (Internal Gateway Protocol), for example, OSPF, to distribute reachability information within the MPLS cloud.
5. Configuring the transport address.
6. Configuring LDP Session Protection.
Figure 11-25: Basic LDP Topology
PE1 - NSM
 
#configure terminal
Enter configure mode.
(config)#interface xe6
Specify the interface (xe6) to be configured.
(config-if)#ip address 10.10.10.1/24
Configure IPv4 address for xe6
(config-if)#label-switching
Enable label switching on interface xe6.
(config)#interface xe12
Specify the interface (xe12) to be configured.
(config-if)#ip address 30.30.30.1/24
Configure IPv4 address for xe12
(config-if)#label-switching
Enable label switching on interface xe12.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 1.1.1.1/32
Set the IP address of the loopback interface to 1.1.1.1/32.
(config-if)#commit
Commit the transaction.
PE1 - LDP
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
(config-router)#exit
Exit the Router mode and return to the Configure mode.
(config)#interface xe6
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe6.
(config)#interface xe12
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe12.
(config-if)#commit
Commit the transaction.
PE1 - OSPF
 
(config)#router ospf 1
Configure the routing process and specify the Process ID (1). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 1.1.1.1
Configure Router ID
(config-router)#network 1.1.1.1/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.10.10.1/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 30.30.30.1/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
P1 - NSM
 
#configure terminal
Enter configure mode.
(config)#interface xe47
Specify the interface (xe47) to be configured.
(config-if)#ip address 10.10.10.2/24
Configure IPv4 address for xe47
(config-if)#label-switching
Enable label switching on interface xe47.
(config)#interface xe48
Specify the interface (xe48) to be configured.
(config-if)#ip address 20.20.20.1/24
Configure IPv4 address for xe48
(config-if)#label-switching
Enable label switching on interface xe48.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 2.2.2.2/32 secondary
Set the IP address of the loopback interface to 2.2.2.2/32.
(config-if)#commit
Commit the transaction.
P1 - LDP
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2
(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
(config-router)#exit
Exit the Router mode and return to the Configure mode.
(config)#interface xe47
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe47.
(config)#interface xe48
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe48.
(config-if)#commit
Commit the transaction.
P1 - OSPF
 
(config)#router ospf 1
Configure the routing process and specify the Process ID (1). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 2.2.2.2
Configure Router ID
 
(config-router)#network 2.2.2.2/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 10.10.10.2/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 20.20.20.1/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
P2 - NSM
 
#configure terminal
Enter configure mode.
(config)#interface xe48
Specify the interface (xe48) to be configured.
(config-if)#ip address 30.30.30.2/24
Configure IPv4 address for xe48
(config-if)#label-switching
Enable label switching on interface xe48.
(config)#interface xe5
Specify the interface (xe5) to be configured.
(config-if)#ip address 40.40.40.1/24
Configure IPv4 address for xe5
(config-if)#label-switching
Enable label switching on interface xe5.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 4.4.4.4/32 secondary
Set the IP address of the loopback interface to 4.4.4.4/32.
(config-if)#commit
Commit the transaction.
P2 - LDP
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 4.4.4.4
Set the router ID to IP address 4.4.4.4
(config-router)#transport-address ipv4 4.4.4.4
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
(config-router)#exit
Exit the Router mode and return to the Configure mode.
(config)#interface xe48
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe48.
(config)#interface xe5
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe5.
(config-if)#commit
Commit the transaction.
P2 - OSPF
 
(config)#router ospf 1
Configure the routing process and specify the Process ID (1). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 4.4.4.4
Configure Router ID
 
(config-router)#network 4.4.4.4/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 20.20.20.2/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 30.30.30.1/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
PE2 - NSM
 
#configure terminal
Enter configure mode.
(config)#interface xe10
Specify the interface (xe10) to be configured.
(config-if)#ip address 20.20.20.2/24
Configure IPv4 address for xe10
(config-if)#label-switching
Enable label switching on interface xe10.
(config)#interface xe5
Specify the interface (xe5) to be configured.
(config-if)#ip address 40.40.40.2/24
Configure IPv4 address for xe5
(config-if)#label-switching
Enable label switching on interface xe5.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 3.3.3.3/32 secondary
Set the IP address of the loopback interface to 3.3.3.3/32.
(config-if)#commit
Commit the transaction.
PE2 - LDP
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 3.3.3.3
Set the router ID to IP address 3.3.3.3
(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
(config-router)#exit
Exit the Router mode and return to the Configure mode.
(config)#interface xe10
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe10.
(config)#interface xe5
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe5.
(config-if)#commit
Commit the transaction.
PE2 - OSPF
 
(config)#router ospf 1
Configure the routing process and specify the Process ID (1). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 3.3.3.3
Configure Router ID
(config-router)#network 3.3.3.3/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 20.20.20.2/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#network 40.40.40.2/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
Validation
Without session protection enabled
Verify that session protection status is not shown when session protection not enabled.
 
PE1#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
C 1.1.1.1/32 is directly connected, lo, 00:04:22
O 2.2.2.2/32 [110/2] via 10.10.10.2, xe12, 00:03:03
O 3.3.3.3/32 [110/3] via 10.10.10.2, xe12, 00:02:49
O 4.4.4.4/32 [110/31] via 30.30.30.2, xe6, 00:02:17
C 10.10.10.0/24 is directly connected, xe12, 00:03:48
O 20.20.20.0/24 [110/2] via 10.10.10.2, xe12, 00:03:03
C 30.30.30.0/24 is directly connected, xe6, 00:03:02
O 40.40.40.0/24 [110/31] via 30.30.30.2, xe6, 00:02:17
C 127.0.0.0/8 is directly connected, lo, 00:04:22
 
Gateway of last resort is not set
 
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
4.4.4.4 xe6 Passive OPERATIONAL 30 00:02:25
2.2.2.2 xe12 Passive OPERATIONAL 30 00:03:11
PE1#show ldp targeted-peers
PE1#show ldp session 2.2.2.2
Session state : OPERATIONAL
Session role : Passive
TCP Connection : Established
IP Address for TCP : 2.2.2.2
Interface being used : xe12
Peer LDP ID : 2.2.2.2:0
Peer LDP Password : Not Set
Adjacencies : 10.10.10.2
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Address List received : 2.2.2.2
10.10.10.2
20.20.20.1
254.128.0.0
Received Labels : Fec Label Maps To
IPV4:3.3.3.3/32 52480 24963
IPV4:20.20.20.0/24 impl-null 24964
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null 24962
Sent Labels : Fec Label Maps To
IPV4:40.40.40.0/24 24961 impl-null
IPV4:4.4.4.4/32 24960 impl-null
IPV4:30.30.30.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:1.1.1.1/32 impl-null none
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 1 2 - Yes LSP_DEFAULT 3 xe12 No 10.10.10.2
L> 3.3.3.3/32 3 5 - Yes LSP_DEFAULT 52480 xe12 No 10.10.10.2
L> 4.4.4.4/32 4 7 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
L> 20.20.20.0/24 2 3 - Yes LSP_DEFAULT 3 xe12 No 10.10.10.2
L> 40.40.40.0/24 5 8 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
 
PE1#show mpls ftn-table
Primary FTN entry with FEC: 2.2.2.2/32, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe12, out label: 3
Nexthop addr: 10.10.10.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 3.3.3.3/32, id: 3, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 4
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: LDP, Stale: NO, out intf: xe12, out label: 52480
Nexthop addr: 10.10.10.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 4.4.4.4/32, id: 4, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: N/A, Stale: NO, out intf: xe6, out label: 3
Nexthop addr: 30.30.30.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 20.20.20.0/24, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe12, out label: 3
Nexthop addr: 10.10.10.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 40.40.40.0/24, id: 5, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: N/A, Stale: NO, out intf: xe6, out label: 3
Nexthop addr: 30.30.30.2 cross connect ix: 4, op code: Push
 
 
PE1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 3.3.3.3/32 4 24963 52480 N/A xe12 10.10.10.2 LSP_DEFAULT
L> 40.40.40.0/24 2 24961 3 N/A xe6 30.30.30.2 LSP_DEFAULT
L> 4.4.4.4/32 1 24960 3 N/A xe6 30.30.30.2 LSP_DEFAULT
L> 2.2.2.2/32 3 24962 3 N/A xe12 10.10.10.2 LSP_DEFAULT
L> 20.20.20.0/24 5 24964 3 N/A xe12 10.10.10.2 LSP_DEFAULT
 
PE1#show ldp fec
LSR codes : E/N - LSR is egress/non-egress for this FEC,
L - LSR received a label for this FEC,
> - LSR will use this route for the FEC
FEC Code Session Out Label ELC Nexthop Addr
1.1.1.1/32 E > non-existent none No connected
2.2.2.2/32 NL> 2.2.2.2 impl-null No 10.10.10.2
3.3.3.3/32 NL 4.4.4.4 24325 No no nexthop
NL> 2.2.2.2 52480 No 10.10.10.2
4.4.4.4/32 NL> 4.4.4.4 impl-null No 30.30.30.2
10.10.10.0/24 NL 2.2.2.2 impl-null No connected
E > non-existent none No connected
20.20.20.0/24 NL 4.4.4.4 24326 No no nexthop
NL> 2.2.2.2 impl-null No 10.10.10.2
30.30.30.0/24 NL 4.4.4.4 impl-null No connected
E > non-existent none No connected
40.40.40.0/24 NL> 4.4.4.4 impl-null No 30.30.30.2
Configure Session Protection:
 
Note: Recommended to configure both ends.
Configure session protection under LDP in both nodes.
PE1
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#session-protection
Session-protection protect label indefinitely if no timer mentioned.
(config-router)#commit
Commit and exit
P1
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#session-protection
Session-protection protect label indefinitely if no timer mentioned.
(config-router)#commit
Commit and exit
Validation
With session protection command enabled
 
Verify that session protection status shown once session protection enabled in both peer nodes.
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
4.4.4.4 xe6 Passive OPERATIONAL 30 00:05:46
2.2.2.2 xe12 Passive OPERATIONAL 30 00:06:32
PE1#show ldp targeted-peers
IP Address Interface
2.2.2.2 xe12
4.4.4.4 xe6
PE1#show ldp session 2.2.2.2
Session state : OPERATIONAL
Session role : Passive
TCP Connection : Established
IP Address for TCP : 2.2.2.2
Interface being used : xe12
Peer LDP ID : 2.2.2.2:0
Peer LDP Password : Not Set
Adjacencies : 10.10.10.2
2.2.2.2
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Session protection : Ready
Address List received : 2.2.2.2
10.10.10.2
20.20.20.1
254.128.0.0
Received Labels : Fec Label Maps To
IPV4:3.3.3.3/32 52480 24963
IPV4:20.20.20.0/24 impl-null 24964
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null 24962
Sent Labels : Fec Label Maps To
IPV4:40.40.40.0/24 24961 impl-null
IPV4:4.4.4.4/32 24960 impl-null
IPV4:30.30.30.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:1.1.1.1/32 impl-null none
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 1 2 - Yes LSP_DEFAULT 3 xe12 No 10.10.10.2
L> 3.3.3.3/32 3 5 - Yes LSP_DEFAULT 52480 xe12 No 10.10.10.2
L> 4.4.4.4/32 4 7 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
L> 20.20.20.0/24 2 3 - Yes LSP_DEFAULT 3 xe12 No 10.10.10.2
L> 40.40.40.0/24 5 8 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
PE1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 3.3.3.3/32 4 24963 52480 N/A xe12 10.10.10.2 LSP_DEFAULT
L> 40.40.40.0/24 2 24961 3 N/A xe6 30.30.30.2 LSP_DEFAULT
L> 4.4.4.4/32 1 24960 3 N/A xe6 30.30.30.2 LSP_DEFAULT
L> 2.2.2.2/32 3 24962 3 N/A xe12 10.10.10.2 LSP_DEFAULT
L> 20.20.20.0/24 5 24964 3 N/A xe12 10.10.10.2 LSP_DEFAULT
PE1#show mpls ftn-table
Primary FTN entry with FEC: 2.2.2.2/32, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe12, out label: 3
Nexthop addr: 10.10.10.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 3.3.3.3/32, id: 3, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 4
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: LDP, Stale: NO, out intf: xe12, out label: 52480
Nexthop addr: 10.10.10.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 4.4.4.4/32, id: 4, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: N/A, Stale: NO, out intf: xe6, out label: 3
Nexthop addr: 30.30.30.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 20.20.20.0/24, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe12, out label: 3
Nexthop addr: 10.10.10.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 40.40.40.0/24, id: 5, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: N/A, Stale: NO, out intf: xe6, out label: 3
Nexthop addr: 30.30.30.2 cross connect ix: 4, op code: Push
 
 
PE1#show ldp fec
LSR codes : E/N - LSR is egress/non-egress for this FEC,
L - LSR received a label for this FEC,
> - LSR will use this route for the FEC
FEC Code Session Out Label ELC Nexthop Addr
1.1.1.1/32 E > non-existent none No connected
2.2.2.2/32 NL> 2.2.2.2 impl-null No 10.10.10.2
3.3.3.3/32 NL 4.4.4.4 24325 No no nexthop
NL> 2.2.2.2 52480 No 10.10.10.2
4.4.4.4/32 NL> 4.4.4.4 impl-null No 30.30.30.2
10.10.10.0/24 NL 2.2.2.2 impl-null No connected
E > non-existent none No connected
20.20.20.0/24 NL 4.4.4.4 24326 No no nexthop
NL> 2.2.2.2 impl-null No 10.10.10.2
30.30.30.0/24 NL 4.4.4.4 impl-null No connected
E > non-existent none No connected
40.40.40.0/24 NL> 4.4.4.4 impl-null No 30.30.30.2
 
 
P1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe5 Passive OPERATIONAL 30 00:05:40
1.1.1.1 xe48 Active OPERATIONAL 30 00:06:43
P1#show ldp targeted-peers
IP Address Interface
1.1.1.1 xe48
3.3.3.3 xe5
 
P1#show ldp session 1.1.1.1
Session state : OPERATIONAL
Session role : Active
TCP Connection : Established
IP Address for TCP : 1.1.1.1
Interface being used : xe48
Peer LDP ID : 1.1.1.1:0
Peer LDP Password : Not Set
Adjacencies : 10.10.10.1
1.1.1.1
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Session protection : Ready
Address List received : 1.1.1.1
10.10.10.1
30.30.30.1
254.128.0.0
Received Labels : Fec Label Maps To
IPV4:4.4.4.4/32 24960 52482
IPV4:40.40.40.0/24 24961 52484
IPV4:30.30.30.0/24 impl-null 52483
IPV4:10.10.10.0/24 impl-null none
IPV4:1.1.1.1/32 impl-null 52481
Sent Labels : Fec Label Maps To
IPV4:3.3.3.3/32 52480 impl-null
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null none
 
P1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 1 2 - Yes LSP_DEFAULT 3 xe48 No 10.10.10.1
L> 3.3.3.3/32 5 9 - Yes LSP_DEFAULT 3 xe5 No 20.20.20.2
L> 4.4.4.4/32 3 5 - Yes LSP_DEFAULT 24960 xe48 No 10.10.10.1
L> 30.30.30.0/24 2 3 - Yes LSP_DEFAULT 3 xe48 No 10.10.10.1
L> 40.40.40.0/24 4 7 - Yes LSP_DEFAULT 24961 xe48 No 10.10.10.1
 
 
P1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 30.30.30.0/24 4 52483 3 N/A xe48 10.10.10.1 LSP_DEFAULT
L> 1.1.1.1/32 2 52481 3 N/A xe48 10.10.10.1 LSP_DEFAULT
L> 3.3.3.3/32 1 52480 3 N/A xe5 20.20.20.2 LSP_DEFAULT
L> 4.4.4.4/32 3 52482 24960 N/A xe48 10.10.10.1 LSP_DEFAULT
L> 40.40.40.0/24 5 52484 24961 N/A xe48 10.10.10.1 LSP_DEFAULT
P1#show mpls ftn-table
Primary FTN entry with FEC: 1.1.1.1/32, id: 1, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe48, out label: 3
Nexthop addr: 10.10.10.1 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 3.3.3.3/32, id: 5, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 8
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 8, owner: N/A, Stale: NO, out intf: xe5, out label: 3
Nexthop addr: 20.20.20.2 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 4.4.4.4/32, id: 3, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 4
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: LDP, Stale: NO, out intf: xe48, out label: 24960
Nexthop addr: 10.10.10.1 cross connect ix: 3, op code: Push
 
 
Primary FTN entry with FEC: 30.30.30.0/24, id: 2, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe48, out label: 3
Nexthop addr: 10.10.10.1 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 40.40.40.0/24, id: 4, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: LDP, Stale: NO, out intf: xe48, out label: 24961
Nexthop addr: 10.10.10.1 cross connect ix: 4, op code: Push
 
 
P1#show ldp fec
LSR codes : E/N - LSR is egress/non-egress for this FEC,
L - LSR received a label for this FEC,
> - LSR will use this route for the FEC
FEC Code Session Out Label ELC Nexthop Addr
1.1.1.1/32 NL> 1.1.1.1 impl-null No 10.10.10.1
2.2.2.2/32 E > non-existent none No connected
3.3.3.3/32 NL> 3.3.3.3 impl-null No 20.20.20.2
4.4.4.4/32 NL> 1.1.1.1 24960 No 10.10.10.1
10.10.10.0/24 NL 1.1.1.1 impl-null No connected
E > non-existent none No connected
20.20.20.0/24 NL 3.3.3.3 impl-null No connected
E > non-existent none No connected
30.30.30.0/24 NL> 1.1.1.1 impl-null No 10.10.10.1
40.40.40.0/24 NL 3.3.3.3 impl-null No no nexthop
NL> 1.1.1.1 24961 No 10.10.10.1
Perform Link failure and check labels are retained until peer is reachable through alternate path.
 
(config)#interface xe12
Enter interface mode.
(config-if)#shutdown
Shutdown the link.
(config)#commit
commit.
Validation
After link down
 
PE1#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
C 1.1.1.1/32 is directly connected, lo, 00:14:17
O 2.2.2.2/32 [110/33] via 30.30.30.2, xe6, 00:03:38
O 3.3.3.3/32 [110/32] via 30.30.30.2, xe6, 00:03:38
O 4.4.4.4/32 [110/31] via 30.30.30.2, xe6, 00:12:12
O 20.20.20.0/24 [110/32] via 30.30.30.2, xe6, 00:03:38
C 30.30.30.0/24 is directly connected, xe6, 00:12:57
O 40.40.40.0/24 [110/31] via 30.30.30.2, xe6, 00:12:12
C 127.0.0.0/8 is directly connected, lo, 00:14:17
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
4.4.4.4 xe6 Passive OPERATIONAL 30 00:10:10
2.2.2.2 xe6 Passive OPERATIONAL 30 00:10:56
PE1#show ldp targeted-peers
IP Address Interface
2.2.2.2 xe6
4.4.4.4 xe6/
PE1#show ldp session 2.2.2.2
Session state : OPERATIONAL
Session role : Passive
TCP Connection : Established
IP Address for TCP : 2.2.2.2
Interface being used : xe6
Peer LDP ID : 2.2.2.2:0
Peer LDP Password : Not Set
Adjacencies : 2.2.2.2
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Session protection : Protecting
Address List received : 2.2.2.2
20.20.20.1
254.128.0.0
Received Labels : Fec Label Maps To
IPV4:3.3.3.3/32 52480 none
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null none
Sent Labels : Fec Label Maps To
IPV4:40.40.40.0/24 24961 impl-null
IPV4:4.4.4.4/32 24960 impl-null
IPV4:30.30.30.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:1.1.1.1/32 impl-null none
 
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 3 9 - Yes LSP_DEFAULT 24321 xe6 No 30.30.30.2
L> 3.3.3.3/32 1 2 - Yes LSP_DEFAULT 24325 xe6 No 30.30.30.2
L> 4.4.4.4/32 4 7 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
L> 20.20.20.0/24 2 4 - Yes LSP_DEFAULT 24326 xe6 No 30.30.30.2
L> 40.40.40.0/24 5 8 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
 
PE1#show mpls ftn-table
Primary FTN entry with FEC: 2.2.2.2/32, id: 3, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 5
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: LDP, Stale: NO, out intf: xe6, out label: 24321
Nexthop addr: 30.30.30.2 cross connect ix: 3, op code: Push
 
 
Primary FTN entry with FEC: 3.3.3.3/32, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: LDP, Stale: NO, out intf: xe6, out label: 24325
Nexthop addr: 30.30.30.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 4.4.4.4/32, id: 4, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: N/A, Stale: NO, out intf: xe6, out label: 3
Nexthop addr: 30.30.30.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 20.20.20.0/24, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 3
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 3, owner: LDP, Stale: NO, out intf: xe6, out label: 24326
Nexthop addr: 30.30.30.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 40.40.40.0/24, id: 5, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: N/A, Stale: NO, out intf: xe6, out label: 3
Nexthop addr: 30.30.30.2 cross connect ix: 4, op code: Push
 
 
PE1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 40.40.40.0/24 2 24961 3 N/A xe6 30.30.30.2 LSP_DEFAULT
L> 4.4.4.4/32 1 24960 3 N/A xe6 30.30.30.2 LSP_DEFAULT
 
P1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe5 Passive OPERATIONAL 30 00:11:12
1.1.1.1 xe5 Active OPERATIONAL 30 00:12:15
P1#show ldp targeted-peers
IP Address Interface
1.1.1.1 xe5
3.3.3.3 xe5
 
P1#show ldp session 1.1.1.1
Session state : OPERATIONAL
Session role : Active
TCP Connection : Established
IP Address for TCP : 1.1.1.1
Interface being used : xe5
Peer LDP ID : 1.1.1.1:0
Peer LDP Password : Not Set
Adjacencies : 1.1.1.1
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Session protection : Protecting
Address List received : 1.1.1.1
30.30.30.1
254.128.0.0
Received Labels : Fec Label Maps To
IPV4:4.4.4.4/32 24960 52482
IPV4:40.40.40.0/24 24961 52484
IPV4:30.30.30.0/24 impl-null 52483
IPV4:10.10.10.0/24 impl-null none
IPV4:1.1.1.1/32 impl-null 52481
Sent Labels : Fec Label Maps To
IPV4:3.3.3.3/32 52480 impl-null
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null none
 
P1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 2 3 - Yes LSP_DEFAULT 24965 xe5 No 20.20.20.2
L> 3.3.3.3/32 5 9 - Yes LSP_DEFAULT 3 xe5 No 20.20.20.2
L> 4.4.4.4/32 3 5 - Yes LSP_DEFAULT 24966 xe5 No 20.20.20.2
L> 30.30.30.0/24 4 7 - Yes LSP_DEFAULT 24967 xe5 No 20.20.20.2
L> 40.40.40.0/24 1 1 - Yes LSP_DEFAULT 3 xe5 No 20.20.20.2
P1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 4.4.4.4/32 3 52482 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 3.3.3.3/32 1 52480 3 N/A xe5 20.20.20.2 LSP_DEFAULT
L> 1.1.1.1/32 2 52481 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 30.30.30.0/24 4 52483 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 40.40.40.0/24 5 52484 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
P1#
P1#show mpls ftn-table
Primary FTN entry with FEC: 1.1.1.1/32, id: 2, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 2
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: LDP, Stale: NO, out intf: xe5, out label: 24965
Nexthop addr: 20.20.20.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 3.3.3.3/32, id: 5, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 8
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 8, owner: N/A, Stale: NO, out intf: xe5, out label: 3
Nexthop addr: 20.20.20.2 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 4.4.4.4/32, id: 3, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 4
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: LDP, Stale: NO, out intf: xe5, out label: 24966
Nexthop addr: 20.20.20.2 cross connect ix: 3, op code: Push
 
 
Primary FTN entry with FEC: 30.30.30.0/24, id: 4, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: LDP, Stale: NO, out intf: xe5, out label: 24967
Nexthop addr: 20.20.20.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 40.40.40.0/24, id: 1, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 8
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 8, owner: N/A, Stale: NO, out intf: xe5, out label: 3
Nexthop addr: 20.20.20.2 cross connect ix: 5, op code: Push
 
 
P1#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
O 1.1.1.1/32 [110/53] via 20.20.20.2, xe5, 00:03:44
C 2.2.2.2/32 is directly connected, lo, 00:14:13
O 3.3.3.3/32 [110/2] via 20.20.20.2, xe5, 00:12:51
O 4.4.4.4/32 [110/52] via 20.20.20.2, xe5, 00:03:44
C 20.20.20.0/24 is directly connected, xe5, 00:13:46
O 30.30.30.0/24 [110/52] via 20.20.20.2, xe5, 00:03:44
O 40.40.40.0/24 [110/51] via 20.20.20.2, xe5, 00:03:44
C 127.0.0.0/8 is directly connected, lo, 00:14:13
 
Bring up the link and check same labels reused.
 
(config)#interface xe12
Enter interface mode.
(config-if)#no shutdown
Shutdown the link.
(config)#commit
Commit.
Validation
 
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
4.4.4.4 xe6 Passive OPERATIONAL 30 00:14:55
2.2.2.2 xe12 Passive OPERATIONAL 30 00:15:41
PE1#show ldp targeted-peers
IP Address Interface
2.2.2.2 xe12
4.4.4.4 xe6
 
PE1#show ldp session 2.2.2.2
Session state : OPERATIONAL
Session role : Passive
TCP Connection : Established
IP Address for TCP : 2.2.2.2
Interface being used : xe12
Peer LDP ID : 2.2.2.2:0
Peer LDP Password : Not Set
Adjacencies : 10.10.10.2
2.2.2.2
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Session protection : Ready
Address List received : 2.2.2.2
10.10.10.2
20.20.20.1
254.128.0.0
Received Labels : Fec Label Maps To
IPV4:3.3.3.3/32 52480 24966
IPV4:20.20.20.0/24 impl-null 24967
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null 24965
Sent Labels : Fec Label Maps To
IPV4:40.40.40.0/24 24961 impl-null
IPV4:4.4.4.4/32 24960 impl-null
IPV4:30.30.30.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:1.1.1.1/32 impl-null none
 
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 3 9 - Yes LSP_DEFAULT 3 xe12 No 10.10.10.2
L> 3.3.3.3/32 1 2 - Yes LSP_DEFAULT 52480 xe12 No 10.10.10.2
L> 4.4.4.4/32 4 7 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
L> 20.20.20.0/24 2 4 - Yes LSP_DEFAULT 3 xe12 No 10.10.10.2
L> 40.40.40.0/24 5 8 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
PE1#
PE1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 2.2.2.2/32 9 24965 3 N/A xe12 10.10.10.2 LSP_DEFAULT
L> 40.40.40.0/24 2 24961 3 N/A xe6 30.30.30.2 LSP_DEFAULT
L> 4.4.4.4/32 1 24960 3 N/A xe6 30.30.30.2 LSP_DEFAULT
L> 3.3.3.3/32 10 24966 52480 N/A xe12 10.10.10.2 LSP_DEFAULT
L> 20.20.20.0/24 11 24967 3 N/A xe12 10.10.10.2 LSP_DEFAULT
PE1#show mpls ftn-table
Primary FTN entry with FEC: 2.2.2.2/32, id: 3, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 10
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: N/A, Stale: NO, out intf: xe12, out label: 3
Nexthop addr: 10.10.10.2 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 3.3.3.3/32, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 11
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 11, owner: LDP, Stale: NO, out intf: xe12, out label: 52480
Nexthop addr: 10.10.10.2 cross connect ix: 6, op code: Push
 
 
Primary FTN entry with FEC: 4.4.4.4/32, id: 4, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: N/A, Stale: NO, out intf: xe6, out label: 3
Nexthop addr: 30.30.30.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 20.20.20.0/24, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 10
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: N/A, Stale: NO, out intf: xe12, out label: 3
Nexthop addr: 10.10.10.2 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 40.40.40.0/24, id: 5, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: N/A, Stale: NO, out intf: xe6, out label: 3
Nexthop addr: 30.30.30.2 cross connect ix: 4, op code: Push
 
 
P1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe5 Passive OPERATIONAL 30 00:15:30
1.1.1.1 xe48 Active OPERATIONAL 30 00:16:33
 
P1#show ldp targeted-peers
IP Address Interface
1.1.1.1 xe48
3.3.3.3 xe5
 
P1#show ldp session 1.1.1.1
Session state : OPERATIONAL
Session role : Active
TCP Connection : Established
IP Address for TCP : 1.1.1.1
Interface being used : xe48
Peer LDP ID : 1.1.1.1:0
Peer LDP Password : Not Set
Adjacencies : 10.10.10.1
1.1.1.1
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Session protection : Ready
Address List received : 1.1.1.1
10.10.10.1
30.30.30.1
254.128.0.0
Received Labels : Fec Label Maps To
IPV4:4.4.4.4/32 24960 52482
IPV4:40.40.40.0/24 24961 52484
IPV4:30.30.30.0/24 impl-null 52483
IPV4:10.10.10.0/24 impl-null none
IPV4:1.1.1.1/32 impl-null 52481
Sent Labels : Fec Label Maps To
IPV4:3.3.3.3/32 52480 impl-null
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null none
 
P1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 2 3 - Yes LSP_DEFAULT 3 xe48 No 10.10.10.1
L> 3.3.3.3/32 5 9 - Yes LSP_DEFAULT 3 xe5 No 20.20.20.2
L> 4.4.4.4/32 3 5 - Yes LSP_DEFAULT 24960 xe48 No 10.10.10.1
L> 30.30.30.0/24 4 7 - Yes LSP_DEFAULT 3 xe48 No 10.10.10.1
L> 40.40.40.0/24 1 1 - Yes LSP_DEFAULT 24961 xe48 No 10.10.10.1
 
P1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 4.4.4.4/32 3 52482 24960 N/A xe48 10.10.10.1 LSP_DEFAULT
L> 1.1.1.1/32 2 52481 3 N/A xe48 10.10.10.1 LSP_DEFAULT
L> 3.3.3.3/32 1 52480 3 N/A xe5 20.20.20.2 LSP_DEFAULT
L> 40.40.40.0/24 5 52484 24961 N/A xe48 10.10.10.1 LSP_DEFAULT
L> 30.30.30.0/24 4 52483 3 N/A xe48 10.10.10.1 LSP_DEFAULT
 
P1#show mpls ftn-table
Primary FTN entry with FEC: 1.1.1.1/32, id: 2, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 10
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: N/A, Stale: NO, out intf: xe48, out label: 3
Nexthop addr: 10.10.10.1 cross connect ix: 6, op code: Push
 
 
Primary FTN entry with FEC: 3.3.3.3/32, id: 5, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 8
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 8, owner: N/A, Stale: NO, out intf: xe5, out label: 3
Nexthop addr: 20.20.20.2 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 4.4.4.4/32, id: 3, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 11
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 11, owner: LDP, Stale: NO, out intf: xe48, out label: 24960
Nexthop addr: 10.10.10.1 cross connect ix: 7, op code: Push
 
 
Primary FTN entry with FEC: 30.30.30.0/24, id: 4, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 10
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: N/A, Stale: NO, out intf: xe48, out label: 3
Nexthop addr: 10.10.10.1 cross connect ix: 6, op code: Push
 
 
Primary FTN entry with FEC: 40.40.40.0/24, id: 1, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 12
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 12, owner: LDP, Stale: NO, out intf: xe48, out label: 24961
Nexthop addr: 10.10.10.1 cross connect ix: 8, op code: Push
 
Last modified date: 10/17/2023