OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : Understanding Label Space : Overview
Overview
The Label space refers to the scope of labels in a given LSR. It determines assignment and distribution of labels to a given peer. During data flow, it decides the key for looking up MPLS table and takes appropriate action based on the entry.
OcNOS supports per-platform label space, where a label must be unique for the entire platform. A label is interpreted the same way at all the interfaces. The FIB entry in the router does not contain incoming interface-related information. Thus the incoming traffic will be matched only with the label.
Topology
Figure 1-1: LDP Topology
PE1
 
PE1#configure terminal
Enter configure mode
PE1(config)#interface lo
Enter interface mode.
PE1(config-if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback address
PE1(config-if)#exit
Exit interface mode
PE1(config)#interface xe6
Specify the interface (xe6)to be configured
PE1(config-if)#ip address 10.10.10.1/24
Configure IP address for the interface
PE1(config-if)#no shutdown
Administratively bringing up the interface
PE1(config-if)#exit
Exit interface mode
PE1(config)#router ospf 100
Configure the routing process and specify the Process ID (100)
PE1(config-router)#ospf router-id 1.1.1.1
Configure OSPF router ID same as loopback IP address
PE1(config-router)#network 10.10.10.0/24 area 0
PE1(config-router)#network 1.1.1.1/32 area 0
Define the interface on which OSPF runs and associate the area ID(0)with the interface
PE1(config-router)#exit
Exit configure mode
PE1(config)#router ldp
Enter router mode for LDP
PE1(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1
PE1(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
PE1(config-router)# targeted-peer ipv4 3.3.3.3
Configure targeted peer.
PE1(config-router-targeted-peer)#exit
Exit from router target peer and LDP mode
PE1(config-if)#exit
Exit interface mode
PE1(config)#interface xe6
Specify the interface (xe6)to be configured
PE1(config-if)#label-switching
Enabling label switching capability on router
PE1(config-if)#enable-ldp ipv4
Enabling ldp on interface
PE1(config-if)#commit
Commit the transaction.
P
 
P#configure terminal
Enter configure mode.
P(config)#interface lo
Enter interface mode.
P(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback address
P(config-if)#exit
Exit interface mode
P(config)#interface xe6
Specify the interface (xe6)to be configured
P(config-if)#ip address 10.10.10.2/24
Configure IP address for the interface
P(config-if)#no shutdown
Administratively bringing up the interface
P(config)#interface xe1
Specify the interface (xe1)to be configured
P(config-if)#ip address 20.20.20.1/24
Configure IP address for the interface
P(config)#router ospf 100
Configure the routing process and specify the Process ID (100)
P(config-router)#ospf router-id 2.2.2.2
Configure OSPF router ID same as loopback IP address
P(config-router)#network 10.10.10.0/24 area 0
P(config-router)#network 20.20.20.0/24 area 0
P(config-router)#network 2.2.2.2/32 area 0
Define the interface on which OSPF runs and associate the area ID (0)with the interface
P(config-router)#exit
Exit router mode
P(config)#router ldp
Enter router mode for LDP
P(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2
P(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
P(config-router)#exit
Exit router mode for LDP
P(config)#mpls min-label-value 1000 max-label-value 50000 label-space 0
Configure the minimum label value and maximum label value to be used by Platform label space (Label space 0)
P(config)#interface xe6
Specify the interface (xe6)to be configured
P(config-if)#label-switching
Enabling label switching capability on router
P(config-if)#enable-ldp ipv4
Enabling ldp on interface
P(config-if)#exit
Exit interface mode
P(config)#interface xe1
Specify the interface (xe1) to be configured
P(config-if)#label-switching
Enabling label switching capability on router
P(config-if)#enable-ldp ipv4
Enabling ldp on interface
P(config-if)#commit
Commit the transaction.
PE2
 
PE2#configure terminal
Enter configure mode.
PE2(config)#interface lo
Enter interface mode.
PE2(config-if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback address
PE2(config-if)#exit
Exit interface mode
PE2(config)#interface xe1
Specify the interface (xe1)to be configured
PE2(config-if)#ip address 20.20.20.2/24
Configure IP address for the interface
PE2(config-if)#no shutdown
Administratively bringing up the interface
PE2(config-if)#exit
Exit interface mode
PE2(config)#router ospf 100
Configure the routing process and specify the Process ID (100)
PE2(config-router)#ospf router-id 3.3.3.3
Configure OSPF router ID same as loopback IP address
PE2(config-router)#network 20.20.20.0/24 area 0
PE2(config-router)#network 3.3.3.3/32 area 0
Define the interface on which OSPF runs and associate the area ID (0)with the interface
PE2(config-router)#exit
Exit router mode
PE2(config)#router ldp
Enter router mode for LDP
PE2(config-router)#router-id 3.3.3.3
Set the router ID to IP address 3.3.3.3
(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
PE2(config-router)# targeted-peer ipv4 1.1.1.1
Configure targeted peer.
PE1(config-router-targeted-peer)#exit
Exit from router target peer and LDP mode
PE2(config-router)#exit
Exit router mode for LDP
PE2(config)#interface xe1
Specify the interface (xe1) to be configured
PE2(config-if)#label-switching
Enabling label switching capability on router
PE2(config-if)#enable-ldp ipv4
Enabling ldp on interface
PE2(config-if)#commit
Commit the transaction.
Last modified date: 10/17/2023