OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : EVPN MPLS Configuration : EVPN MPLS Multihoming
EVPN MPLS Multihoming
Topology
The diagram depicts the Multi Homed topology for the EVPN MPLS configuration examples that follow.
Figure 24-3: MPLS EVPN multi-homing configuration
PE1: Loopback Interface
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 10.143.73.1/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
(config-if)#commit
Commit the transaction.
PE1: Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 10.143.73.1
Set the router ID to IP address 10.143.73.1
(config-router)#transport-address ipv4
10.143.73.1
Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as the transport address.
(config-router)#targeted-peer ipv4 10.143.73.3
Configure targeted peer.
(config-router)#targeted-peer ipv4 10.143.73.4
Configure targeted peer.
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#exit
Exit from router target peer and LDP mode
(config-router)#commit
Commit the transaction.
PE1: Global EVPN MPLS Command
 
(config)#evpn mpls enable
Enable EVPN MPLS
(config)#commit
Commit candidate configuration to be running configuration
 
(config)#evpn mpls vtep-ip-global 10.143.73.1
Configuring VTEP global IP to loopback IP
(config)#hardware-profile filter evpn-mpls-mh enable
Enable hardware-profile filter EVPN-MPLS-MH
(config)#evpn mpls multihoming enable
Enable Multihoming
(config)#commit
Commit the transaction.
PE1: Interface Configuration Network Side
 
(config)#interface xe3
Enter the Interface mode for xe3.
(config-if)#ip address 10.255.128.8/31
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config-if)#commit
Commit the transaction.
Note: For RSVP Configuration refer RSVP-TE Configuration
PE1: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#ospf router-id 10.143.73.1
Router-ID configurations
(config-router)#network 10.143.73.1/32 area 0.0.0.0
Advertise loopback address in OSPF.
(config-router)#network 10.255.128.8/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#commit
Commit the transaction.
PE1: BGP Configuration
 
(config)#router bgp 65010
Enter the Router BGP mode, ASN: 65010
(config-router)#neighbor 10.143.73.3 remote-as 65010
Configuring Neighbor as iBGP neighbor
(config-router)#neighbor 10.143.73.3 update-source lo
Source of routing updates as loopback
(config-router)#neighbor 10.143.73.4 remote-as 65010
Configuring Neighbor as iBGP neighbor
(config-router)#neighbor 10.143.73.4 update-source lo
Source of routing updates as loopback
(config-router)#address-family l2vpn evpn
Entering into address family mode as EVPN
(config-router-af)#neighbor 10.143.73.3 activate
Enabling EVPN Address family for neighbor
(config-router-af)#neighbor 10.143.73.4 activate
Enabling EVPN Address family for neighbor
(config-router-af)#exit
Exiting of Address family mode
(config-router)#commit
Commit the transaction.
PE1: MAC VRF Configuration
 
(config)#mac vrf vrf2
Enter VRF mode
(config-vrf)#rd 10.143.73.1:1700
Configuring Route-Distinguisher value 10.143.73.1:1700
(config-vrf)#route-target both 1700:1700
Configuring import and export value as 1700:1700
(config-vrf)#exit
Exiting VRF Mode
(config)#mac vrf vpls1001
Enter VRF mode
(config-vrf)#rd 10.143.73.1:1001
Configuring Route-Distinguisher value 10.143.73.1:1001
(config-vrf)#route-target both 1001:1001
Configuring import and export value as 1001:1001
(config-vrf)#exit
Exiting VRF Mode
(config)#commit
Commit the transaction.
PE1: EVPN and VRF Mapping
 
(config)#evpn mpls id 1700 xconnect target-mpls-id 1800
Configure the EVPN-VPWS identifier with source identifier 1700 and target identifier 1800
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf2
Mapping vrf "vrf2" to EVPN-VPWS identifier
(config-evpn-mpls)#evpn mpls id 3000
Configure the EVPN-VPLS identifier with identifier 3000
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vpls1001
Mapping vrf "vpls1001" to EVPN-VPLS identifier
(config-evpn-mpls)#commit
Commit the transaction.
PE1: Access Port Configuration
 
(config)#interface xe6
Enter the Interface mode for xe6.
(config-if)#interface xe6.1700 switchport
Creating L2 sub interface of physical interface xe6
(config-if)#description access-side-int
Giving Interface Description
(config-if)#encapsulation dot1q 1700
Setting Encapsulation to dot1q with VLAN ID 1700
(config-if)#access-if-evpn
Entering Access mode for EVPN MPLS ID configuration
(config-access-if)#map vpn-id 1700
Map vpn-id 1700 to interface xe6.1700 (VPWS)
(config-access-if)#exit
Exiting out of access interface mode
(config-if)#interface xe6.300 switchport
Creating L2 sub interface of physical interface xe6
(config-if)#encapsulation dot1q 3000
Setting Encapsulation to dot1q with VLAN ID 3000
(config-if)#access-if-evpn
Entering Access mode for EVPN MPLS ID configuration
(config-access-if)#map vpn-id 3000
Map vpn-id 3000 to interface xe6.3000 (VPLS)
(config-access-if)#commit
Commit candidate configuration to be running configuration
P: Loopback Interface
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 10.143.73.6/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
(config-if)#commit
Commit the transaction.
P: Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 10.143.73.6
Set the router ID to IP address 10.143.73.6
(config-router)#transport-address ipv4
10.143.73.6
Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as the transport address.
(config-router)#exit
Exit from router target peer and LDP mode
(config-router)#commit
Commit the transaction.
P: Interface Configuration
 
(config)#interface xe3
Enter the Interface mode for xe3.
(config-if)#ip address 10.255.128.9/31
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe5
Enter the Interface mode for xe5
(config-if)#ip address 10.255.128.25/31
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config)#interface po92
Enter the Interface mode for po92
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#interface xe7
Enter the Interface mode for xe7
(config-if)#channel-group 92 mode active
Moving interface to Dynamic LAG 92
(config-if)#interface xe8
Enter the Interface mode for xe8
(config-if)#channel-group 92 mode active
Moving interface to Dynamic LAG 92
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
P: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#ospf router-id 10.143.73.6
Setting the Router ID as Loopback IP
(config-router)#network 10.143.73.6/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 10.255.128.8/31 area 0.0.0.0
Advertise xe3 network address in OSPF that comes under same subnet
(config-router)#network 10.255.128.24/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)#network 10.255.128.36/31 area 0.0.0.0
Advertise po92 network address in OSPF that comes under same subnet
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
OcNOS(config)#commit
Commit candidate configuration to be running configuration
PE2: Loopback Interface
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 10.143.73.3/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
PE2: Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 10.143.73.3
Set the router ID to IP address 10.143.73.3
(config-router)#transport-address ipv4
10.143.73.3
Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as the transport address.
(config-router)#targeted-peer ipv4 10.143.73.1
Configure targeted peer.
(config-router-targeted-peer)# targeted-peer ipv4 10.143.73.4
Configure targeted peer
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#exit
Exit from router target peer and LDP mode
(config)#commit
Commit the transaction.
PE2: Global EVPN MPLS Command
 
(config)#evpn mpls enable
Enable EVPN MPLS
Note: Reload is required after Enabling/Disabling EVPN MPLS Feature
(config)#commit
Commit candidate configuration to be running configuration
(config)#evpn mpls vtep-ip-global 10.143.73.3
Configuring VTEP global IP to loopback IP
(config)#hardware-profile filter evpn-mpls-mh enable
Enable hardware-profile filter EVPN-MPLS-MH
(config)#evpn mpls multihoming enable
Enable Multihoming
(config)#evpn esi hold-time 60
Delay timer for ESI to come up before enabling evpn
(config)#commit
Commit the transaction.
PE2: Interface Configuration Network Side
 
(config)#interface xe3
Enter the Interface mode for xe3.
(config-if)#ip address 10.255.128.24/31
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config-if)#commit
Commit the transaction.
Note: For RSVP Configuration refer RSVP-TE Configuration
PE2: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#ospf router-id 10.143.73.3
Router-ID configurations
(config-router)#network 10.143.73.3/32 area 0.0.0.0
Advertise loopback address in OSPF.
(config-router)#network 10.255.128.24/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
OcNOS(config)#commit
Commit candidate configuration to be running configuration
PE2: BGP Configuration
 
(config)#router bgp 65010
Enter the Router BGP mode, ASN: 65010
(config-router)#neighbor 10.143.73.1 remote-as 65010
Configuring Neighbor as iBGP neighbor
(config-router)#neighbor 10.143.73.1 update-source lo
Source of routing updates as loopback
(config-router)#neighbor 10.143.73.4 remote-as 65010
Configuring Neighbor as iBGP neighbor
(config-router)#neighbor 10.143.73.4 update-source lo
Source of routing updates as loopback
(config-router)#address-family l2vpn evpn
Entering into address family mode as EVPN
(config-router-af)#neighbor 10.143.73.1 activate
Enabling EVPN Address family for neighbor
(config-router-af)#neighbor 10.143.73.4 activate
Enabling EVPN Address family for neighbor
(config-router-af)#exit
Exiting of Address family mode
(config-router)#commit
Commit the transaction.
PE2: MAC VRF Configuration
 
(config)#mac vrf vrf2
Enter VRF mode
(config-vrf)#rd 10.143.73.3:1700
Configuring Route-Distinguisher value 10.143.73.3:1700
(config-vrf)#route-target both 1700:1700
Configuring import and export value as 1700:1700
 
Support: route-target export
route-target import
(config-vrf)#exit
Exiting VRF Mode
(config)#mac vrf vpls1001
Enter VRF mode
(config-vrf)#rd 10.143.73.3:1001
Configuring Route-Distinguisher value 10.143.73.3:1001
(config-vrf)#route-target both 1001:1001
Configuring import and export value as 1001:1001
(config-vrf)#exit
Exiting VRF Mode
(config)#commit
Commit the transaction.
PE2: EVPN and MAC VRF Mapping
 
(config)#evpn mpls id 1800 xconnect target-mpls-id 1700
Configure the EVPN-VPWS identifier with source identifier 1800 and target identifier 1700
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf2
Mapping vrf "test" to EVPN-VPWS identifier
(config-evpn-mpls)#evpn mpls id 3000
Configure the EVPN-VPLS identifier with identifier 3000
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vpls1001
Mapping vrf "vpls1001" to EVPN-VPLS identifier
(config-evpn-mpls)#commit
Commit the transaction.
PE2: Access Port Configuration
 
(config)#interface po90
Enter the Interface mode for po90.
(config-if)#load-interval 30
Load interval setting
(config-if)#evpn multi-homed system-mac 0000.aaaa.bbbc
Configure ESI on a link on which Multi homed CE is connected
(config-if)#interface po90.1700 switchport
Creating L2 sub interface of Dynamic LAG po90
(config-if)#encapsulation dot1q 1700
Setting Encapsulation to dot1q with VLAN ID 1700
Supported Encapsulation: dot1ad, dot1q, untagged, default
(config-if)#access-if-evpn
Entering Access mode for EVPN MPLS ID configuration
(config-access-if)#map vpn-id 1800
Map vpn-id 2 to interface xe2.2 (VPWS)
(config-access-if)#exit
Exiting out of access interface mode
(config-if)#interface po90.300 switchport
Creating L2 sub interface of Dynamic LAG po90
(config-if)#encapsulation dot1q 3000
Setting Encapsulation to dot1q with VLAN ID 3000
Supported Encapsulation: dot1ad, dot1q, untagged, default
(config-if)#access-if-evpn
Entering Access mode for EVPN MPLS ID configuration
(config-access-if)#map vpn-id 3000
Map vpn-id 3000 to interface po90.300 (VPLS)
(config-access-if)#exit
Exiting out of Access if mode
(config-if)#interface xe2
Enter the Interface mode for xe2
(config-if)#channel-group 90 mode active
Putting interface xe2 in Dynamic LAG po90
(config)#commit
Commit candidate configuration to be running configuration
PE3: Loopback Interface
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 10.143.73.4/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
PE3: Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 10.143.73.4
Set the router ID to IP address 10.143.73.4
(config-router)#transport-address ipv4
10.143.73.4
Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as the transport address.
(config-router)#targeted-peer ipv4 10.143.73.1
Configure targeted peer.
(config-router-targeted-peer)# targeted-peer ipv4 10.143.73.3
Configure targeted peer.
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#exit
Exit from router LDP mode
(config-router)#commit
Commit the transaction.
PE3: Global EVPN MPLS Command
 
(config)#evpn mpls enable
Enable EVPN MPLS
(config)#commit
Commit candidate configuration to be running configuration
(config)#evpn mpls vtep-ip-global 10.143.73.4
Configuring VTEP global IP to loopback IP
(config)#hardware-profile filter evpn-mpls-mh enable
Enable hardware-profile filter EVPN-MPLS-MH
(config)#evpn mpls multihoming enable
Enable Multihoming
(config)#evpn esi hold-time 60
Delay timer for ESI to come up before enabling evpn
(config)#commit
Commit the transaction.
PE3: Interface Configuration Network Side
 
(config)#interface xe3
Enter the Interface mode for xe3.
(config-if)#ip address 10.255.128.36/31
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config-if)#interface xe7
Enter the Interface mode for xe7
(config-if)#channel-group 92 mode active
Moving interface to Dynamic LAG 92
(config-if)#interface xe8
Enter the Interface mode for xe8
(config-if)#channel-group 92 mode active
Moving interface to Dynamic LAG 92
(config-if)#exit
Exit interface mode
(config)#commit
Commit the transaction.
Note: For RSVP Configuration refer RSVP-TE Configuration
PE3: OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#ospf router-id 10.143.73.4
Router-ID configurations
(config-router)#network 10.143.73.4/32 area 0.0.0.0
Advertise loopback address in OSPF.
(config-router)#network 10.255.128.36/31 area 0.0.0.0
Advertise network address in OSPF.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#commit
Commit the transaction.
PE3: BGP Configuration
 
(config)#router bgp 65010
Enter the Router BGP mode, ASN: 65010
(config-router)#neighbor 10.143.73.1 remote-as 65010
Configuring Neighbor as iBGP neighbor
(config-router)#neighbor 10.143.73.1 update-source lo
Source of routing updates as loopback
(config-router)#neighbor 10.143.73.3 remote-as 65010
Configuring Neighbor as iBGP neighbor
(config-router)#neighbor 10.143.73.3 update-source lo
Source of routing updates as loopback
(config-router)#address-family l2vpn evpn
Entering into address family mode as EVPN
(config-router-af)#neighbor 10.143.73.1 activate
Enabling EVPN Address family for neighbor
(config-router-af)#neighbor 10.143.73.3 activate
Enabling EVPN Address family for neighbor
(config-router-af)#exit
Exiting of Address family mode
(config-router)#commit
Commit the transaction.
PE3: MAC VRF Configuration
 
(config)#mac vrf vrf2
Enter VRF mode
(config-vrf)#rd 10.143.73.4:1700
Configuring Route-Distinguisher value 10.143.73.4:1700
(config-vrf)#route-target both 1700:1700
Configuring import and export value as 1700:1700
(config-vrf)#exit
Exiting VRF Mode
(config)#mac vrf vpls1001
Enter VRF mode
(config-vrf)#rd 10.143.73.4:1001
Configuring Route-Distinguisher value 10.143.73.4:1001
(config-vrf)#route-target both 1001:1001
Configuring import and export value as 1001:1001
(config-vrf)#exit
Exiting VRF Mode
(config)#commit
Commit the transaction.
PE3: EVPN and MAC VRF Mapping
 
(config)#evpn mpls id 1800 xconnect target-mpls-id 1700
Configure the EVPN-VPWS identifier with source identifier 1800 and target identifier 1800
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf2
Mapping vrf "test" to EVPN-VPWS identifier
(config-evpn-mpls)#evpn mpls id 3000
Configure the EVPN-VPLS identifier with identifier 3000
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vpls1001
Mapping vrf "vpls1001" to EVPN-VPLS identifier
(config-evpn-mpls)#commit
Commit the transaction.
PE3: Access Port Configuration
 
(config)#interface po90
Enter the Interface mode for po90.
(config-if)#load-interval 30
Load interval setting
(config-if)#evpn multi-homed system-mac 0000.aaaa.bbbc
Configure ESI on a link on which Multi homed CE is connected
(config-if)#interface po90.1700 switchport
Creating L2 sub interface of Dynamic LAG po90
(config-if)#encapsulation dot1q 1700
Setting Encapsulation to dot1q with VLAN ID 1700
Supported Encapsulation: dot1ad, dot1q, untagged, default
 
(config-if)#access-if-evpn
Entering Access mode for EVPN MPLS ID configuration
(config-access-if)#map vpn-id 1800
Map vpn-id 1800 to Dynamic LAG sub interface po90.1700 (VPWS)
(config-access-if)#exit
Exiting out of access interface mode
(config-if)#interface po90.300 switchport
Creating L2 sub interface of Dynamic LAG po90
(config-if)#encapsulation dot1q 3000
Setting Encapsulation to dot1q with VLAN ID 3000
Supported Encapsulation: dot1ad, dot1q, untagged, default
(config-if)#access-if-evpn
Entering Access mode for EVPN MPLS ID configuration
(config-access-if)#map vpn-id 3000
Map vpn-id 3000 to interface po90.3000 (VPLS)
(config-access-if)#exit
Exiting out of Access if mode
(config-if)#interface xe2
Enter the Interface mode for xe2
(config-if)#channel-group 90 mode active
Putting interface xe2 in Dynamic LAG po90
(config-if)#commit
Commit candidate configuration to be running configuration
Validation
PE1: ELAN
PE1#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
10.143.73.1 10.143.73.4 Installed 00:13:32 00:13:32 3000
10.143.73.1 10.143.73.3 Installed 00:13:33 00:13:33 3000
 
Total number of entries are 2
 
PE1#show evpn mpls tunnel label
EVPN-MPLS Network tunnel labels
Local Remote
Destination Status evpn-id Network-Intf Tunnel-Label MC-Label UC-Label MC-Label UC-Label
===================================================================================================================
10.143.73.4 Installed 3000 xe3 25601 753 403 654 53
10.143.73.3 Installed 3000 xe3 25600 753 403 753 402
 
Total number of entries are 2
 
PE1#show evpn mpls id 3000
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
3000 ---- L2 NW ---- ---- ---- ---- 10.143.73.1 10.143.73.4
3000 ---- L2 NW ---- ---- ---- ---- 10.143.73.1 10.143.73.3
3000 ---- -- AC xe6.300 --- Single Homed Port --- ---- ---- ---- ----
 
PE1#show evpn mpls mac-table
============================================================================================================================
EVPN MPLS MAC Entries
============================================================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
__________________________________________________________________________________________________________________________________________
3000 xe6.300 ---- ---- 0211.2000.03e8 10.143.73.1 Dynamic Local ------- -------
3000 xe6.300 ---- ---- b86a.97cd.6a3d 10.143.73.1 Dynamic Local ------- -------
3000 ---- ---- ---- 0224.2000.03e8 00:00:00:aa:aa:bb:bc:00:00:00 Dynamic Remote ------- -------
3000 ---- ---- ---- b86a.97d2.53bb 00:00:00:aa:aa:bb:bc:00:00:00 Dynamic Remote ------- -------
PE1: ELINE or VPWS
PE1#show evpn mpls xconnect
EVPN-MPLS Xconnect Info
========================
AC-AC: Local-Cross-connect
AC-NW: Cross-connect to Network
AC-UP: Access-port is up
AC-DN: Access-port is down
NW-UP: Network is up
NW-DN: Network is down
NW-SET: Network and AC both are up
 
Local Remote Connection-Details
================================ ============ ===================================================================================
VPN-ID EVI-Name MTU VPN-ID Source Destination PE-IP MTU Type NW-Status
================================ ============ ===================================================================================
1700 ---- 1500 1800 xe6.1700 00:00:00:aa:aa:bb:bc:00:00:00 10.143.73.4 1500 AC-NW NW-SET
 
Total number of entries are 1
 
PE1#show evpn mpls xconnect tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update local-evpn-id remote-evpn-id
================================================================================================
10.143.73.1 10.143.73.4 Installed 00:16:50 00:16:50 1700 1800
10.143.73.1 10.143.73.3 Installed 00:16:50 00:16:50 1700 1800
 
Total number of entries are 2
 
PE1#show evpn mpls xconnect tunnel label
EVPN-MPLS Network tunnel labels
Local Remote Local Remote
Destination Status VPWS-ID VPWS-ID Network-Intf Tunnel-Label MC-Label UC-Label MC-Label UC-Label
==============================================================================================================================
10.143.73.4 Installed 1700 1800 xe3 25601 -- 402 -- 52
10.143.73.3 Installed 1700 1800 xe3 25600 -- 402 -- 401
Total number of entries are 2
 
PE1#show evpn mpls xconnect id 1700
EVPN-MPLS Xconnect Info
========================
AC-AC: Local-Cross-connect
AC-NW: Cross-connect to Network
AC-UP: Access-port is up
AC-DN: Access-port is down
NW-UP: Network is up
NW-DN: Network is down
NW-SET: Network and AC both are up
 
Local Remote Connection-Details
================================ ============ ===================================================================================
VPN-ID EVI-Name MTU VPN-ID Source Destination PE-IP MTU Type NW-Status
================================ ============ ===================================================================================
1700 ---- 1500 1800 xe6.1700 00:00:00:aa:aa:bb:bc:00:00:00 10.143.73.3 1500 AC-NW NW-SET
10.143.73.4 1500 ---- ----
Total number of entries are 1
PE2: VPLS
PE2#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
10.143.73.3 10.143.73.4 Installed 00:24:41 00:24:41 3000
10.143.73.3 10.143.73.1 Installed 00:24:38 00:24:38 3000
 
Total number of entries are 2
 
PE2#show evpn mpls tunnel label
EVPN-MPLS Network tunnel labels
Local Remote
Destination Status evpn-id Network-Intf Tunnel-Label MC-Label UC-Label MC-Label UC-Label
============================================================================================================
10.143.73.4 Installed 3000 xe5 24965 753 402 654 53
10.143.73.1 Installed 3000 xe5 25604 753 402 753 403
 
Total number of entries are 2
 
PE2#show evpn mpls id 3000
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
____________________________________________________________________________________________________________________________
3000 ---- L2 NW ---- ---- ---- ---- 10.143.73.3 10.143.73.4
3000 ---- L2 NW ---- ---- ---- ---- 10.143.73.3 10.143.73.1
3000 ---- -- AC po90.300 00:00:00:aa:aa:bb:bc:00:00:00 ---- DF ---- ----
 
Total number of entries are 3
 
PE2#show evpn mpls mac-table
============================================================================================================================
EVPN MPLS MAC Entries
============================================================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
____________________________________________________________________________________________________________________________
3000 ---- ---- ---- 0211.2000.03e8 10.143.73.1 Dynamic Remote ------- -------
3000 ---- ---- ---- b86a.97cd.6a3d 10.143.73.1 Dynamic Remote ------- -------
3000 ---- ---- ---- 0224.2000.03e8 00:00:00:aa:aa:bb:bc:00:00:00 Dynamic Remote ------- -------
3000 po90.300 ---- ---- b86a.97d2.53bb 00:00:00:aa:aa:bb:bc:00:00:00 Dynamic Local ------- -------
PE2: VPWS
PE2#show evpn mpls xconnect id 1800
EVPN-MPLS Xconnect Info
========================
AC-AC: Local-Cross-connect
AC-NW: Cross-connect to Network
AC-UP: Access-port is up
AC-DN: Access-port is down
NW-UP: Network is up
NW-DN: Network is down
NW-SET: Network and AC both are up
 
Local Remote Connection-Details
================================ ============ ===================================================================================
VPN-ID EVI-Name MTU VPN-ID Source Destination PE-IP MTU Type NW-Status
================================ ============ ===================================================================================
1800 ---- 1500 1700 po90.1700 --- Single Homed Port --- 10.143.73.1 1500 AC-NW NW-SET
 
Total number of entries are 1
 
PE2#show evpn mpls xconnect tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update local-evpn-id remote-evpn-id
=======================================================================================
10.143.73.3 10.143.73.1 Installed 00:50:18 00:50:18 1800 1700
 
Total number of entries are 1
 
 
PE2#show evpn mpls xconnect
EVPN-MPLS Xconnect Info
========================
AC-AC: Local-Cross-connect
AC-NW: Cross-connect to Network
AC-UP: Access-port is up
AC-DN: Access-port is down
NW-UP: Network is up
NW-DN: Network is down
NW-SET: Network and AC both are up
 
Local Remote Connection-Details
================================ ============ ===================================================================================
VPN-ID EVI-Name MTU VPN-ID Source Destination PE-IP MTU Type NW-Status
================================ ============ ===================================================================================
1800 ---- 1500 1700 po90.1700 --- Single Homed Port --- 10.143.73.1 1500 AC-NW NW-SET
 
Total number of entries are 1
 
PE2#show evpn mpls xconnect tunnel label
EVPN-MPLS Network tunnel labels
Local Remote Local Remote
Destination Status VPWS-ID VPWS-ID Network-Intf Tunnel-Label MC-Label UC-Label MC-Label UC-Label
============================================================================================================================
10.143.73.1 Installed 1800 1700 xe5 25604 -- 401 -- 402
 
Total number of entries are 1
PE3: VPLS
PE3#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
================================================================================
10.143.73.4 10.143.73.3 Installed 00:22:11 00:22:11 3000
10.143.73.4 10.143.73.1 Installed 00:22:11 00:22:11 3000
 
Total number of entries are 2
 
PE3#show evpn mpls tunnel label
EVPN-MPLS Network tunnel labels
Local Remote
Destination Status evpn-id Network-Intf Tunnel-Label MC-Label UC-Label MC-Label UC-Label
============================================================================================================
10.143.73.3 Installed 3000 po92 24962 654 53 753 402
10.143.73.1 Installed 3000 po92 24964 654 53 753 403
 
Total number of entries are 2
 
PE3#show evpn mpls id 3000
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
3000 ---- L2 NW ---- ---- ---- ---- 10.143.73.4 10.143.73.3
3000 ---- L2 NW ---- ---- ---- ---- 10.143.73.4 10.143.73.1
3000 ---- -- AC po90.300 00:00:00:aa:aa:bb:bc:00:00:00 ---- NON-DF ---- ----
 
Total number of entries are 3
 
PE3#show evpn mpls mac-table
============================================================================================================================
EVPN MPLS MAC Entries
============================================================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
__________________________________________________________________________________________________________________________________________
 
3000 ---- ---- ---- 0211.2000.03e8 10.143.73.1 Dynamic Remote ------- -------
3000 ---- ---- ---- b86a.97cd.6a3d 10.143.73.1 Dynamic Remote ------- -------
3000 ---- ---- ---- 0224.2000.03e8 00:00:00:aa:aa:bb:bc:00:00:00 Dynamic Remote ------- -------
3000 po90.300 ---- ---- b86a.97d2.53bb 00:00:00:aa:aa:bb:bc:00:00:00 Dynamic Local ------- -------
PE3: VPWS
PE3#show evpn mpls xconnect id 1800
EVPN-MPLS Xconnect Info
========================
AC-AC: Local-Cross-connect
AC-NW: Cross-connect to Network
AC-UP: Access-port is up
AC-DN: Access-port is down
NW-UP: Network is up
NW-DN: Network is down
NW-SET: Network and AC both are up
 
Local Remote Connection-Details
================================ ============ ===================================================================================
VPN-ID EVI-Name MTU VPN-ID Source Destination PE-IP MTU Type NW-Status
================================ ============ ===================================================================================
1800 ---- 1500 1700 po90.1700 --- Single Homed Port --- 10.143.73.1 1500 AC-NW NW-SET
 
Total number of entries are 1
 
PE3#show evpn mpls xconnect tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update local-evpn-id remote-evpn-id
========================================================================================================
10.143.73.4 10.143.73.1 Installed 00:23:18 00:23:18 1800 1700
 
Total number of entries are 1
 
PE3#show evpn mpls xconnect tunnel label
EVPN-MPLS Network tunnel labels
Local Remote Local Remote
Destination Status VPWS-ID VPWS-ID Network-Intf Tunnel-Label MC-Label UC-Label MC-Label UC-Label
==============================================================================================================================
10.143.73.1 Installed 1800 1700 po92 24964 -- 52 -- 402
 
Total number of entries are 1
 
PE3#show evpn mpls xconnect
EVPN-MPLS Xconnect Info
========================
AC-AC: Local-Cross-connect
AC-NW: Cross-connect to Network
AC-UP: Access-port is up
AC-DN: Access-port is down
NW-UP: Network is up
NW-DN: Network is down
NW-SET: Network and AC both are up
 
Local Remote Connection-Details
================================ ============ ===================================================================================
VPN-ID EVI-Name MTU VPN-ID Source Destination PE-IP MTU Type NW-Status
================================ ============ ===================================================================================
1800 ---- 1500 1700 po90.1700 --- Single Homed Port --- 10.143.73.1 1500 AC-NW NW-SET
 
Total number of entries are 1
Last modified date: 10/17/2023