#configure terminal | Enter configuration mode. |
(config)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)#ip address 10.143.73.1/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit candidate configuration to be running configuration |
#configure terminal | Enter configuration mode. |
(config)#evpn mpls enable | Enable EVPN MPLS |
(config)#commit | Commit candidate configuration to be running configuration Note: Reload is required after Enabling/Disabling EVPN MPLS Feature |
(config-evpn-mpls)#evpn mpls vtep-ip-global 10.143.73.1 | Configuring VTEP global IP to loopback IP |
(config)#router ldp | Enter the Router LDP mode. |
PE1(config-router)#router-id 10.143.73.1 | Set the router ID to IP address 10.143.73.1 |
PE1(config-router)#transport-address ipv4 10.143.73.1 0 | Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address |
PE1(config-router)#targeted-peer ipv4 10.143.73.3 | Configure targeted peer. |
(config-router)#exit | Exit from router target peer and LDP mode |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#interface xe3 | Enter the Interface mode for xe3 |
(config-if)#ip address 10.255.128.2/31 | Configure IP address on the interface. |
(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface |
(config-if)#label-switching | Enable label switching on the interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#router ospf 100 | Enter the Router OSPF mode. |
(config-router)#ospf router-id 10.143.73.1 | Router-ID configurations |
(config-router)#network 10.143.73.1/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)#network 10.255.128.2/31 area 0.0.0.0 | Advertise xe3 network address in OSPF. |
(config-router)#exit | Exit Router OSPF mode and return to Configure mode. |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#router bgp 65010 | Enter the Router BGP mode, ASN: 65010 |
(config-router)#neighbor 10.143.73.3 remote-as 65010 | Configuring PE2 as iBGP neighbor using it's loopback IP |
(config-router)#neighbor 10.143.73.3 update-source lo | Source of routing updates as loopback |
(config-router)#address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)#neighbor 10.143.73.3 activate | Enabling EVPN Address family for neighbor |
(config-router-af)#exit | Exiting of Address family mode |
(config-router)#commit | Commit candidate configuration to be running configuration |
(config)#mac vrf vrf2 | Enter VRF mode |
(config-vrf)#rd 10.143.73.1:2 | Configuring Route-Distinguisher value 10.143.73.1:2 |
(config-vrf)#route-target both 2:2 | Configuring import and export value as 2:2 |
(config-vrf)#exit | Exiting VRF Mode |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#evpn mpls id 2 xconnect target-mpls-id 252 | Configure the EVPN-VPWS identifier with source identifier 2 and target identifier 252 |
(config)#host-reachability-protocol evpn-bgp vrf2 | Mapping vrf "vrf2" to EVPN-VPWS identifier |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#interface xe6 | Enter the Interface mode for xe6. |
(config-if)#description access-side-int | Giving Interface Description |
(config-if)#interface xe6.2 switchport | Creating L2 sub interface of physical interface xe6 |
(config-if)#encapsulation dot1q 2 | Setting Encapsulation to dot1q with VLAN ID 2 Supported Encapsulation: dot1ad, dot1q, untagged, default |
(config-if)#access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-access-if)#map vpn-id 2 | Map vpn-id 252 to interface xe2.2 (VPWS) |
(config-access-if)#exit | Exiting out of access interface mode |
(config-if)#commit | Commit candidate configuration to be running configuration |
(config)#hardware-profile filter cfm-domain-name-str enable | Configure cfm-domain-name-str profile to enable cfm |
(config)#ethernet cfm domain-type character-string domain-name MD-01 level 2 mip-creation none | Create CFM domain for Evpn ELine with type as character string and set mip creation to none |
(config-ether-cfm-mpls-md)#service ma-type string ma-name S1 | Create ma type with string and set mip creation to none |
(config-ether-cfm-mpls-ma)# evpn 2 | Configure evpn <Evpn-id> |
(config-ether-cfm-mpls-ma)#ethernet cfm mep up mpid 8191 active true evpn 2 | Create up-mep for local evpn id 2 |
(config-ether-cfm-mpls-ma-mep)#cc multicast state enable | Enable cc multicast |
(config-ether-cfm-mpls-ma-mep)#exit-ether-ma-mep-mode | Exit Ethernet ma-mep-mode |
(config-ether-cfm-mpls-ma)#mep crosscheck mpid 8000 | Configure cross check to remote mep for vlan 2 |
(config-ether-cfm-mpls-ma)#cc interval 2 | Enable cc interval with value 2 i.e 10 milliseconds |
(config-ether-cfm-mpls-ma)#exit-ether-ma-mode | Exit ethernnet ma mode |
(config-ether-cfm-mpls-md)#exit | Exit Ethernet cfm mode |
(config)#exit | Exit from config mode |
(config)#commit | Commit candidate configuration to be running configuration |
#configure terminal | Enter configuration mode. |
(config)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)#ip address 10.143.73.2/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#router ldp | Enter the Router LDP mode. |
PE1(config-router)#router-id 10.143.73.2 | Set the router ID to IP address 10.143.73.2 |
PE1(config-router)#transport-address ipv4 10.143.73.2 0 | Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address. |
(config-router)#exit | Exit from router target peer and LDP mode |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#interface xe3 | Enter the Interface mode for xe3 |
(config-if)#ip address 10.255.128.3/31 | Configure IP address on the interface. |
(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface |
(config-if)#label-switching | Enable label switching on the interface. |
(config-if)#exit | Exit interface mode |
(config)#interface xe5 | Enter the Interface mode for xe5 |
(config-if)#ip address 10.255.128.22/31 | Configure IP address on the interface. |
(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface |
(config-if)#label-switching | Enable label switching on the interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#router ospf 100 | Enter the Router OSPF mode. |
(config-router)#ospf router-id 10.143.73.2 | Setting the Router ID as Loopback IP |
(config-router)#network 10.143.73.2/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)#network 10.255.128.22/31 area 0.0.0.0 | Advertise xe5 network address in OSPF |
(config-router)#network 10.255.128.3/31 area 0.0.0.0 | Advertise xe3 network address in OSPF. |
(config-router)#exit | Exit Router OSPF mode and return to Configure mode. |
(config)#commit | Commit candidate configuration to be running configuration |
#configure terminal | Enter configuration mode. |
(config)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)#ip address 10.143.73.3/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#router ldp | Enter the Router LDP mode. |
PE1(config-router)#router-id 10.143.73.3 | Set the router ID to IP address 10.143.73.3 |
PE1(config-router)#transport-address ipv4 10.143.73.3 0 | Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address. |
PE1(config-router)#targeted-peer ipv4 10.143.73.1 | Configure targeted peer. |
(config-router)#exit | Exit from router target peer and LDP mode |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#evpn mpls enable | Enable EVPN MPLS |
OcNOS(config)#commit | Commit candidate configuration to be running configuration Note: Reload is required after Enabling/Disabling EVPN MPLS Feature. |
(config-evpn-mpls)#evpn mpls vtep-ip-global 10.143.73.3 | Configuring VTEP global IP to loopback IP |
(config-evpn-mpls)#commit | Commit candidate configuration to be running configuration |
(config)#interface xe5 | Enter the Interface mode for xe5 |
(config-if)#ip address 10.255.128.23/31 | Configure IP address on the interface. |
(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface |
(config-if)#label-switching | Enable label switching on the interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#router ospf 100 | Enter the Router OSPF mode. |
(config-router)#ospf router-id 10.143.73.3 | Router-ID configurations |
(config-router)#network 10.143.73.3/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)#network 10.255.128.23/31 area 0.0.0.0 | Advertise xe5 network address in OSPF. |
(config-router)#exit | Exit Router OSPF mode and return to Configure mode. |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#router bgp 65010 | Enter the Router BGP mode, ASN: 65010 |
(config-router)#neighbor 10.143.73.1 remote-as 65010 | Configuring PE1 as iBGP neighbor using it's loopback IP |
(config-router)#neighbor 10.143.73.1 update-source lo | Source of routing updates as loopback |
(config-router)#address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)#neighbor 10.143.73.1 activate | Enabling EVPN Address family for neighbor |
(config-router-af)#exit | Exiting of Address family mode |
(config-router)#commit | Commit candidate configuration to be running configuration |
(config)#mac vrf vrf2 | Enter VRF mode |
(config-vrf)#rd 10.143.73.3:2 | Configuring Route-Distinguisher value 10.143.73.3:2 |
(config-vrf)#route-target both 2:2 | Configuring import and export value as 2:2 |
(config-vrf)#exit | Exiting VRF Mode |
(config)#commit | Commit candidate configuration to be running configuration |
(config)#evpn mpls id 252 xconnect target-mpls-id 2 | Configure the EVPN-ELINE identifier with source identifier 252 and target identifier 2 |
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf2 | Mapping vrf "vrf2" to EVPN-ELINE identifier |
(config-evpn-mpls)#commit | Commit candidate configuration to be running configuration |
(config)#interface xe2 | Enter the Interface mode for xe2. |
(config-if)#description access-side-int | Giving Interface Description |
(config-if)#interface xe2.2 switchport | Creating L2 sub interface of physical interface xe2 |
(config-if)#encapsulation dot1q 2 | Setting Encapsulation to dot1q with VLAN ID 2 Supported Encapsulation: dot1ad, dot1q, untagged, default |
(config-if)#access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-access-if)#map vpn-id 252 | Map vpn-id 252 to interface xe2.2 (VPWS) |
(config-access-if)#exit | Exiting out of access interface mode |
(config-if)#commit | Commit candidate configuration to be running configuration |
(config)#hardware-profile filter cfm-domain-name-str enable | Configure cfm-domain-name-str profile to enable cfm |
(config)#ethernet cfm domain-type character-string domain-name MD-01 level 2 mip-creation none | Create CFM domain for Evpn ELine with type as character string and set mip creation to none |
(config-ether-cfm-mpls-md)#service ma-type string ma-name S1 | Create ma type with string and set mip creation to none |
(config-ether-cfm-mpls-ma)# evpn 252 | Configure evpn <Evpn-id> |
(config-ether-cfm-mpls-ma)#ethernet cfm mep up mpid 8000 active true evpn 252 | Create up-mep for local evpn id 252 |
(config-ether-cfm-mpls-ma-mep)#cc multicast state enable | Enable cc multicast |
(config-ether-cfm-mpls-ma-mep)#exit-ether-ma-mep-mode | Exit Ethernet ma-mep-mode |
(config-ether-cfm-mpls-ma)#mep crosscheck mpid 8191 | Configure cross check to remote mep for vlan 2 |
(config-ether-cfm-mpls-ma)#cc interval 2 | Enable cc interval with value 2 i.e 10 milliseconds |
(config-ether-cfm-mpls-ma)#exit-ether-ma-mode | Exit ethernnet ma mode |
(config-ether-cfm-mpls)#exit | Exit Ethernet cfm mode |
(config)#exit | Exit from config mode |
(config)#commit | Commit candidate configuration to be running configuration |