OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : MPLS LDP-IGP Synchronization : LDP-IGP Synchronization with OSPF
LDP-IGP Synchronization with OSPF
When IGP synchronization is enabled on OSPF-enabled interfaces, OSPF sends Maximum/Normal cost based on LDP session Down or Up state messages to interfaces until the hold-down-timer expires or synchronization is achieved.
Before configuring LDP-IGP synchronization, the NSM, OSPF and LDP configurations must be completed. The tables below contain examples of how this is done.
RTR1 - NSM
 
#configure terminal
Enter configuration mode.
(config)#interface xe11
Enter interface mode.
(config-if)#ip address 10.10.10.1/24
Configure IPv4 address for xe11.
(config-if)#label-switching
Enable label switching on interface xe11.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 1.1.1.1/32 secondary
Set the IP address of the loopback interface to 1.1.1.1/32.
(config-if)#commit
Commit the transaction.
RTR1 - OSPF
 
(config)#router ospf 100
Configure the routing process and specify the Process ID 100. The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 1.1.1.1
Configure OSPF router ID same as loopback IP address.
(config-router)#network 10.10.10.0/24
area 0
(config-router)#network 1.1.1.1/32
area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
RTR1 - LDP
 
(config)#router ldp
Enter router mode for LDP.
(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1.
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as the transport address.
(config-router)#exit
Exit router mode.
(config)#interface xe11
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP for IPv4 on xe11.
(config-if)#commit
Commit the transaction.
 
RTR2 - NSM
 
#configure terminal
Enter configuration mode.
(config)#interface xe11
Enter interface mode.
(config-if)#ip address 10.10.10.2/24
Configure IPv4 address for xe11.
(config-if)#label-switching
Enable label switching on interface xe11.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 2.2.2.2/32 secondary
Set the IP address of the loopback interface to 2.2.2.2/32.
(config-if)#commit
Commit the transaction.
RTR2 - OSPF
 
(config)#router ospf 100
Configure the routing process and specify the Process ID 100. The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 2.2.2.2
Configure OSPF router ID same as loopback IP address.
(config-router)#network 10.10.10.0/24
area 0
(config-router)#network 2.2.2.2/32
area 0
 
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#commit
Commit the transaction.
RTR2 - LDP
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2.
(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as transport address.
(config-router)#exit
Exit the Router mode and return to the Configure mode.
(config)#interface xe11
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP for IPv4 on xe11.
(config-if)#commit
Commit the transaction.
Validation
R1#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/DR 00:00:33 10.10.10.2 xe11 0
 
R2#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
1.1.1.1 1 Full/Backup 00:00:31 10.10.10.1 xe11 0
 
R1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe11 Passive OPERATIONAL 30 00:06:03
 
R2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
1.1.1.1 xe11 Active OPERATIONAL 30 00:06:31
 
R1#show ldp adjacency
IP Address Mode Intf Name Holdtime LDP-Identifier
10.10.10.2 Interface xe11 15 2.2.2.2:0
 
 
R2#show ldp adjacency
IP Address Mode Intf Name Holdtime LDP-Identifier
10.10.10.1 Interface xe11 15 1.1.1.1:0
 
R1#show ip ospf interface
lo is up, line protocol is up
Internet Address 1.1.1.1/32, Area 0.0.0.0, MTU 16436
Process ID 100, VRF (default), Router ID 1.1.1.1, Network Type LOOPBACK, Cost: 1
Transmit Delay is 1 sec, State Loopback, TE Metric 1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
xe11 is up, line protocol is up
Internet Address 10.10.10.1/24, Area 0.0.0.0, MTU 1500
Process ID 100, VRF (default), Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State Backup, Priority 1, TE Metric 1
Designated Router (ID) 2.2.2.2, Interface Address 10.10.10.2
Backup Designated Router (ID) 1.1.1.1, Interface Address 10.10.10.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:01
Neighbor Count is 1, Adjacent neighbor count is 1
Hello received 61 sent 62, DD received 3 sent 6
LS-Req received 1 sent 1, LS-Upd received 4 sent 5
LS-Ack received 4 sent 3, Discarded 0
No authentication
 
R2#show ip ospf interface
lo is up, line protocol is up
Internet Address 2.2.2.2/32, Area 0.0.0.0, MTU 16436
Process ID 100, VRF (default), Router ID 2.2.2.2, Network Type LOOPBACK, Cost: 1
Transmit Delay is 1 sec, State Loopback, TE Metric 1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
xe11 is up, line protocol is up
Internet Address 10.10.10.2/24, Area 0.0.0.0, MTU 1500
Process ID 100, VRF (default), Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1, TE Metric 1
Designated Router (ID) 2.2.2.2, Interface Address 10.10.10.2
Backup Designated Router (ID) 1.1.1.1, Interface Address 10.10.10.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:01
Neighbor Count is 1, Adjacent neighbor count is 1
Hello received 62 sent 63, DD received 6 sent 3
LS-Req received 1 sent 1, LS-Upd received 5 sent 4
LS-Ack received 3 sent 4, Discarded 0
No authentication
LDP-IGP Synchronization
Now that NSM, OSPF and LDP are all enabled, the LDP-IGP synchronization can be configured.
RTR1
 
(config)#interface xe11
Enter interface mode.
(config-if)#mpls ldp-igp sync ospf holddown-timer 500
Enable LDP-IGP Synchronization for xe11 belonging to an OSPF process and 500 seconds is holddown-timer value for IGP to wait until LDP converges.
OSPF: This command is part of OSPF Process.
Note: Holddown-timer range is 1 to 2147483 seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use the command mpls ldp-igp sync ospf to configure without a holddown-timer.
(config-if)#mpls ldp-igp sync-delay 60
Configure time delay in seconds for notification of LDP convergence to IGP. This is not applicable for notification of non-convergence. Range is 5 to 60 seconds. This command is optional.
LDP: This command is part of LDP Process.
Default: If not configured the delay is 0 seconds.
(config-if)#commit
Commit the transaction.
RTR2
 
(config)#interface xe11
Enter interface mode.
(config-if)#mpls ldp-igp sync ospf holddown-timer 500
Enable LDP-IGP Synchronization for interfaces (xe11) belonging to an OSPF process.and 500 secs is Holddown-timer value for IGP to wait until LDP Converge.
OSPF: This command is part of the OSPF Process.vNote: Holddown-timer range is <1-2147483> seconds. If holddown timer is not configured, IGP waits indefinitely for LDP to converge. Use command mpls ldp-igp sync ospf to configure without a holddown-timer.
(config-if)#mpls ldp-igp sync-delay 60
Configure the time delay in seconds for the notification of LDP convergence to IGP. (This is not applicable for notification of non-convergence.) Range is 5 to 60 seconds. This command is optional.
LDP: This command is part of LDP Process.
Default: If not configured the delay is 0 seconds.
(config-if)#commit
Commit the transaction.
RTR1 Validation
When LDP IGP SYNC is Configured with hold-down and sync-delay timer
R1#show ip ospf interface
lo is up, line protocol is up
Internet Address 1.1.1.1/32, Area 0.0.0.0, MTU 16436
Process ID 100, VRF (default), Router ID 1.1.1.1, Network Type LOOPBACK, Cost:
1
Transmit Delay is 1 sec, State Loopback, TE Metric 1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
xe11 is up, line protocol is up
Internet Address 10.10.10.1/24, Area 0.0.0.0, MTU 1500
Process ID 100, VRF (default), Router ID 1.1.1.1, Network Type BROADCAST, Cost
: 1
Transmit Delay is 1 sec, State Backup, Priority 1, TE Metric 1
LDP-OSPF Sync configured
Holddown timer : 500 seconds, Remaining time = 0 seconds
Designated Router (ID) 2.2.2.2, Interface Address 10.10.10.2
Backup Designated Router (ID) 1.1.1.1, Interface Address 10.10.10.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:06
Neighbor Count is 1, Adjacent neighbor count is 1
Hello received 178 sent 179, DD received 3 sent 6
LS-Req received 1 sent 1, LS-Upd received 5 sent 6
LS-Ack received 5 sent 4, Discarded 0
No authentication
 
R1#show mpls ldp igp sync
xe11 is up, line protocol is up
LDP configured; LDP-IGP Synchronization enabled.
Session IP Address : 2.2.2.2
Sync status: Achieved
Delay timer: Configured, 60 seconds, Not Running
RTR2 Validation
R2#show ip ospf interface
lo is up, line protocol is up
Internet Address 2.2.2.2/32, Area 0.0.0.0, MTU 16436
Process ID 100, VRF (default), Router ID 2.2.2.2, Network Type LOOPBACK, Cost:
1
Transmit Delay is 1 sec, State Loopback, TE Metric 1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
xe11 is up, line protocol is up
Internet Address 10.10.10.2/24, Area 0.0.0.0, MTU 1500
Process ID 100, VRF (default), Router ID 2.2.2.2, Network Type BROADCAST, Cost
: 1
Transmit Delay is 1 sec, State DR, Priority 1, TE Metric 1
LDP-OSPF Sync configured
Holddown timer : 500 seconds, Remaining time = 0 seconds
Designated Router (ID) 2.2.2.2, Interface Address 10.10.10.2
Backup Designated Router (ID) 1.1.1.1, Interface Address 10.10.10.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:01
Neighbor Count is 1, Adjacent neighbor count is 1
Hello received 211 sent 211, DD received 6 sent 3
LS-Req received 1 sent 1, LS-Upd received 8 sent 7
LS-Ack received 6 sent 7, Discarded 0
No authentication
 
R2#show mpls ldp igp sync
xe11 is up, line protocol is up
LDP configured; LDP-IGP Synchronization enabled.
Session IP Address : 1.1.1.1
Sync status: Achieved
Delay timer: Configured, 60 seconds, Not Running
Last modified date: 10/17/2023