OcNOS-DC 6.4.2 : Layer 2 Guide : Layer 2 Configuration Guide : Link Aggregation Configuration
Link Aggregation Configuration
This chapter contains a complete sample Link Aggregation Group configuration.
LACP is based on the 802.3ad IEEE specification. It allows bundling of several physical interfaces to form a single logical channel providing enhanced performance and redundancy. The aggregated interface is viewed as a single link to each switch. The spanning tree views it as one interface and not as two or three interfaces. When there is a failure in one physical interface, the other interfaces stay up and there is no disruption. Traffic can be load balanced within an LACP trunk group in a controlled manner using the hashing algorithm.The maximum number of physical Ethernet links in a single logical channel depends upon the hardware support.
Note:  
Physical interfaces will inherit the properties of LAG port once it is attached to be part of LAG, irrespective of the configuration present on the physical interface.
In case of Dynamic and Static LAG, it is possible to move member ports from one LAG to another LAG.
Configure LAG port as a switch or router port, before adding member ports into it.
Topology
In Figure 6-7, 3 links are configured between the two switches S1 and S2. These three links are assigned the same administrative key (1) so that they aggregate to form a single channel 1. They are viewed by the STP as one interface.
LACP Topology
Dynamic LAG Configuration
SW1
 
SW1#configure terminal
Enter configure mode.
SW1(config)# bridge 1 protocol mstp
Configure bridge 1 as MSTP bridge
SW1(config)#vlan database
Enter vlan database mode.
SW1(config-vlan)#vlan 2-10 bridge 1 state enable
Configure a VLAN and add it to the bridge.
SW1(config-vlan)#exit
Exit vlan configuration mode.
SW1(config)#lacp system-priority 20000
Set the system priority of this switch. This priority is used for determining the system that is responsible for resolving conflicts in the choice of aggregation groups. A lower numerical value has a higher priority.
SW1(config)#interface po10
Enter into port channel interface po10.
SW1(config-if)#switchport
Configure po10 as a layer 2 port.
SW1(config-if)#bridge-group 1
Associate bridge to an interface.
SW1(config-if)#switchport mode trunk
Configure port as a trunk.
SW1(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the po10 interface.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#interface eth1
Enter interface mode.
SW1(config-if)#channel-group 10 mode active
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#interface eth2
Enter interface mode.
SW1(config-if)#channel-group 10 mode active
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#interface eth3
Enter interface mode.
SW1(config-if)#channel-group 10 mode active
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW1(config-if)#commit
Commit the transaction.
SW1(config-if)#exit
Exit interface mode.
S2
 
SW2#configure terminal
Enter configure mode.
SW2(config)# bridge 1 protocol mstp
Configure bridge 1 as MSTP bridge
SW2(config)#vlan database
Enter vlan database mode.
SW2(config-vlan)#vlan 2-10 bridge 1 state enable
Configure a VLAN and add it to the bridge.
SW2(config-vlan)#exit
Exit vlan configuration mode.
SW1(config)#interface po10
Enter into port channel interface sa10.
SW2(config-if)#switchport
Configure po10 as a layer 2 port.
SW2(config-if)#bridge-group 1
Associate bridge to an interface.
SW2(config-if)#switchport mode trunk
Configure port as a trunk.
SW2(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the po10 interface.
SW2(config-if)#exit
Exit interface mode.
SW2(config)#interface eth2
Enter interface mode.
SW2(config-if)#channel-group 10 mode active
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW2(config-if)#exit
Exit interface mode.
SW2(config)#interface eth3
Enter interface mode.
SW2(config-if)#channel-group 10 mode active
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW2(config-if)#exit
Exit interface mode.
SW2(config)#interface eth4
Enter interface mode.
SW2(config-if)#channel-group 10 mode active
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW2(config-if)#commit
Commit the transaction.
SW2(config-if)#exit
Exit interface mode.
Validation
show etherchannel detail, show etherchannel summary, show running-config interface po10, show running-config interface eth1
#show etherchannel detail
% Aggregator po10 7
% Aggregator Type: Layer2
% Mac address: 08:00:27:50:6a:9b
% Admin Key: 0010 - Oper Key 0010
% Actor LAG ID- 0x4e20,08-00-27-ab-ea-38,0x000a
% Receive link count: 3 - Transmit link count: 3
% Individual: 0 - Ready: 1
% Partner LAG ID- 0x4e20,08-00-27-f8-3c-30,0x000a
% Link: eth1 (3) sync: 1
% Link: eth2 (4) sync: 1
% Link: eth3 (5) sync: 1
% Collector max delay: 5
 
#show etherchannel summary
% Aggregator po10 7
% Aggregator Type: Layer2
% Admin Key: 0010 - Oper Key 0010
% Aggregator Type: Layer2
% Link: eth1 (3) sync: 1
% Link: eth2 (4) sync: 1
% Link: eth3 (5) sync: 1
 
#show running-config interface po10
!
interface po10
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan all
#show running-config interface eth1
!
interface eth1
channel-group 10 mode active
Static LAG Configuration
SW1
 
SW1#configure terminal
Enter configure mode.
SW1(config)# bridge 1 protocol mstp
Configure bridge 1 as MSTP bridge
SW1(config)#vlan database
Enter vlan database mode.
SW1(config-vlan)#vlan 2-10 bridge 1 state enable
Configure a VLAN and add it to the bridge.
SW1(config-vlan)#exit
Exit vlan configuration mode.
SW1(config)#interface sa10
Enter into port channel interface sa10.
SW1(config-if)#switchport
Configure po10 as a layer 2 port.
SW1(config-if)#bridge-group 1
Associate bridge to an interface.
SW1(config-if)#switchport mode trunk
Configure port as a trunk.
SW1(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the po10 interface.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#interface eth1
Enter interface mode.
SW1(config-if)#static-channel-group 10
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#interface eth2
Enter interface mode.
SW1(config-if)#static-channel-group 10
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#interface eth3
Enter interface mode.
SW1(config-if)#static-channel-group 10
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW1(config-if)#commit
Commit the transaction.
SW1(config-if)#exit
Exit interface mode.
SW2
 
SW2#configure terminal
Enter configure mode.
SW2(config)# bridge 1 protocol mstp
Configure bridge 1 as MSTP bridge
SW2(config)#vlan database
Enter vlan database mode.
SW2(config-vlan)#vlan 2-10 bridge 1 state enable
Configure a VLAN and add it to the bridge.
SW2(config-vlan)#exit
Exit vlan configuration mode.
SW2(config)#interface sa10
Enter into port channel interface po10.
SW2(config-if)#switchport
Configure po10 as a layer 2 port.
SW2(config-if)#bridge-group 1
Associate bridge to an interface.
SW2(config-if)#switchport mode trunk
Configure port as a trunk.
SW2(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the po10 interface.
SW2(config-if)#exit
Exit interface mode.
SW2(config)#interface eth2
Enter interface mode.
SW2(config-if)#static-channel-group 10
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW2(config-if)#exit
Exit interface mode.
SW2(config)#interface eth3
Enter interface mode.
SW2(config-if)#static-channel-group 10
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW2(config-if)#exit
Exit interface mode.
SW2(config)#interface eth4
Enter interface mode.
SW2(config-if)#static-channel-group 10
Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system.
SW2(config-if)#exit
Exit interface mode.
SW1(config)#commit
Commit the transaction.
Validation
#show static-channel-group
% Static Aggregator: sa10
% Member status:
eth1 up
eth2 up
eth3 up
 
#show running-config interface sa10
!
interface sa10
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan all
 
#show running-config interface eth1
!
interface eth1
static-channel-group 10
Static LAG Minimum Link Configuration
Configure the minimum number of ports that must be linked up and bundled in the LACP port channel. We can configure the minimum links range from 2 to 32. If the number of ports aggregated to the port channel is less than the minimum number of links configured, then the port channel enters the Protocol Down because of the minimum link state.
Note: Minimum links should be configured the same on both sides for optimal performance.
Topology
LAG Minimum Link
SW11
 
#configure terminal
Enter configure mode.
(config)#interface sa10
Creating interface static-lag sa10
(config-if)#port-channel min-links 4
Configuring port channel minimum links as 4(range is 2-32)
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit the configure mode
Validation
SW1
#show static-channel-group 10
% Static Aggregator: sa10
% Minimum-Links 4
% Member status:
xe4/1 up
xe4/2 up
xe4/3 up
xe4/4 up
 
 
 
#show running-config interface sa10
!
interface sa10
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan all
port-channel min-links 4
SW2
 
#configure terminal
Enter configure mode.
(config)#interface sa10
Creating interface port-channel sa10
(config-if)#port-channel min-links 4
Configuring port channel minimum links as 4 (range is 2-32)
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit the configure mode
Validation
SW2
#show running-config interface sa10
!
interface sa10
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan all
port-channel min-links 4
!
 
#show static-channel-group 10
% Static Aggregator: sa10
% Minimum-Links 4
% Member status:
Xe50/1 up
Xe50/2 up
Xe50/3 up
Xe50/4 up
 
Note:When a sa goes down due to the minimum links configured (number of minimum links is greater than the links aggregated to the sa).
SW1:
=====
#OcNOS#sh int brief sa10
 
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
 
--------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
sa10 AGG 1 trunk down PD(Min L/B) 0
OcNOS#
 
SW2:
=====
 
OcNOS#sh int brief sa10
 
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
 
--------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
sa10 AGG 1 trunk down PD(Min L/B) 0
OcNOS#
Static-LAG Minimum Bandwidth Configuration
Configure the minimum bandwidth allowed for ports that must be linked up and bundled in the LACP port channel. We can configure the minimum bandwidth range from BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits. If the Total bandwidth of ports aggregated to the port channel is less than the minimum Bandwidth value configured, then the port channel enters the Protocol Down because of the minimum Bandwidth state.
Note: Minimum Bandwidth should be configured the same on both sides for optimal performance.
Topology
LAG Minimum Bandwidth
SW1
 
#configure terminal
Enter configure mode.
(config)#interface sa10
Creating interface static-lag sa10
(config-if)#port-channel min-bandwidth 40g
Configuring port channel minimum bandwidth as 40g (range from BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits.)
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit the configure mode
Validation
SW1
#show static-channel-group 10
% Static Aggregator: sa10
% Minimum- 4
% Member status:
xe4/1 up
xe4/2 up
xe4/3 up
xe4/4 up
 
 
 
#show running-config interface sa10
!
interface sa10
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan all
port-channel load-balance src-dst-mac
port-channel min-links 40g
 
SW2
 
#configure terminal
Enter configure mode.
(config)#interface sa10
Creating interface port-channel sa10
(config-if)#port-channel min-bandwidth 40g
Configuring port channel minimum bandwidth as 40g (range from BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits.)
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit the configure mode
Validation
SW2
#show running-config interface sa10
!
interface sa10
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan all
port-channel min-bandwidth 40g
!
 
#show static-channel-group 10
% Static Aggregator: sa10
% Minimum-bandwidth 40g
% Member status:
Xe50/1 up
Xe50/2 up
Xe50/3 up
Xe50/4 up
 
Note: When sa goes down due to [Total Bandwidth of sa] <[ Minimum Bandwidth value Configured]
SW1:
=====
#OcNOS #sh int brief sa10
 
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
 
--------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
sa10 AGG 1 trunk down PD(Min L/B) 0
OcNOS#
 
 
SW2:
=====
 
OcNOS#sh int brief sa10
 
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
 
--------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
sa10 AGG 1 trunk down PD(Min L/B) 0
OcNOS#
 
!
Dynamic-LAG Minimum Link Configuration
Configure the minimum number of ports that must be linked up and bundled in the LACP port channel. We can configure the minimum links range from 2 to 32. If the number of ports aggregated to the port channel is less than the minimum number of links configured, then the port channel enters the Protocol Down because of the minimum link state.
Note: Minimum links should be configured the same on both sides for optimal performance.
Topology
LAG Minimum Link
SW1
 
#configure terminal
Enter configure mode.
(config)#interface po10
Creating interface port-channel po10
(config-if)#port-channel min-links 4
Configuring port channel minimum links as 4 (range is 2-32)
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit the configure mode
Validation
SW1
#sh running-config interface po10
 
interface po10
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan all
port-channel min-links 4
!
 
!
 
#show etherchannel
------------------------------------
% Lacp Aggregator: po10
% Min-links : 4
% Member:
xe4/1
xe4/2
xe4/3
xe4/4
------------------------------------
 
#show etherchannel summary
 
% Aggregator po10 100010
% Aggregator Type: Layer2
% Admin Key: 0010 - Oper Key 0010
% Link: xe4/4 (10072) sync: 1
% Link: xe4/1 (10069) sync: 1
% Link: xe4/2 (10070) sync: 1
% Link: xe4/3 (10071) sync: 1
--------------------------------------
 
SW2
 
#configure terminal
Enter configure mode.
(config)#interface po10
Creating interface port-channel po10
(config-if)#port-channel min-links 4
Configuring port channel minimum links as 4 (range is 2-32)
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit the configure mode
Validation
SW2
#show running-config interface po10
!
interface po10
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan all
port-channel min-links 4
!
 
#show etherchannel
 
% Lacp Aggregator: po10
% Min-links: 4
% Member:
xe50/1
xe50/2
xe50/3
xe50/4
 
#show etherchannel summary
 
% Aggregator po10 100010
% Aggregator Type: Layer2
% Admin Key: 0010 - Oper Key 0010
% Link: xe50/4 (10072) sync: 1
% Link: xe50/1 (10069) sync: 1
% Link: xe50/2 (10070) sync: 1
% Link: xe50/3 (10071) sync: 1
 
 
Note: When a PO goes down due to the minimum links configured (number of minimum links is greater than the links aggregated to the PO).
SW1:
====
#OcNOS#sh int brief po10
 
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
 
--------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
po10 AGG 1 trunk down PD(Min L/B) 0
OcNOS#
 
 
OcNOS#sh etherchannel
% Lacp Aggregator: po10
% Min-links: 4
% Protocol Down (Min L/B): True
% Member:
xe4/1
xe4/2
xe4/3
xe4/4
 
SW2:
====
OcNOS#sh etherchannel
% Lacp Aggregator: po10
% Min-links: 4
% Protocol Down (Min L/B): True
% Member:
Xe50/1
Xe50/2
Xe50/3
xe50/4
 
OcNOS#sh int brief po10
 
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
 
--------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
po10 AGG 1 trunk down PD(Min L/B) 0
OcNOS#
 
Dynamic LAG Minimum Bandwidth Configuration
Configure the minimum bandwidth allowed for ports that must be linked up and bundled in the LACP port channel. We can configure the minimum bandwidth range from BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits. If the Total bandwidth of ports aggregated to the port channel is less than the minimum Bandwidth value configured, then the port channel enters the Protocol Down because of the minimum Bandwidth state.
Note: Minimum Bandwidth should be configured the same on both sides for optimal performance.
Topology
LAG Minimum Bandwidth
SW1
 
#configure terminal
Enter configure mode.
(config)#interface po10
Creating interface port-channel po10
(config-if)#port-channel min-bandwidth 40g
Configuring port channel minimum bandwidth as 40g (range from BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits.)
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit the configure mode
Validation
SW1
#sh running-config interface po10
 
interface po10
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan all
port-channel min-bandwidth 40g
!
 
!
 
#show etherchannel
------------------------------------
% Lacp Aggregator: po10
% Min-Bandwidth : 40g
% Member:
xe4/1
xe4/2
xe4/3
xe4/4
------------------------------------
 
#show etherchannel summary
 
% Aggregator po10 100010
% Aggregator Type: Layer2
% Admin Key: 0010 - Oper Key 0010
% Link: xe4/4 (10072) sync: 1
% Link: xe4/1 (10069) sync: 1
% Link: xe4/2 (10070) sync: 1
% Link: xe4/3 (10071) sync: 1
--------------------------------------
 
SW2
 
#configure terminal
Enter configure mode.
(config)#interface po10
Creating interface port-channel po10
(config-if)#port-channel min-bandwidth 40g
Configuring port channel minimum bandwidth as 40g (range from BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits.)
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit the configure mode
Validation
SW2
#show running-config interface po10
!
interface po10
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan all
port-channel min-bandwidth 40g
!
 
#show etherchannel
 
% Lacp Aggregator: po10
% Min-Bandwidth : 40g
% Member:
xe50/1
xe50/2
xe50/3
xe50/4
 
#show etherchannel summary
 
% Aggregator po10 100010
% Aggregator Type: Layer2
% Admin Key: 0010 - Oper Key 0010
% Link: xe50/4 (10072) sync: 1
% Link: xe50/1 (10069) sync: 1
% Link: xe50/2 (10070) sync: 1
% Link: xe50/3 (10071) sync: 1
 
Note: When a PO goes down due to the [Total bandwidth] < [minimum bandwidth configured ]
SW1:
=====
#OcNOS#sh int brief po10
 
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
 
--------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
po10 AGG 1 trunk down PD(Min L/B) 0
OcNOS#
 
 
OcNOS#sh etherchannel
% Lacp Aggregator: po10
% Min-Bandwidth : 40g
% Protocol Down (Min L/B): True
% Member:
xe4/1
xe4/2
xe4/3
xe4/4
 
 
SW2:
=====
OcNOS#sh etherchannel
% Lacp Aggregator: po10
% Min-Bandwidth : 40g
% Protocol Down (Min L/B): True
% Member:
Xe50/1
Xe50/2
Xe50/3
xe50/4
 
OcNOS#sh int brief po10
 
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
 
--------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
po10 AGG 1 trunk down PD(Min L/B) 0
OcNOS#
 
LACP Minimum-Link, Minimum-Bandwidth
Configurations on dynamic, static Channel-Groups
with MLAG.
Overview
OcNOS allows the configuration of minimum number of the LAG members per LAG group. Both these configurations are meaningful in case the LAG is used for incremental-BW mode. The minimum configuration controls the minimum number of members /bandwidth that must be operationally up / bandwidth available to declare their LAG as operationally UP.
When static/dynamic LAG interface configured with minimum links / minimum bandwidth, the following conditions are to be met:
Ports which are admin and operational up are considered for min-link.
The specified minimum number of links should be up.
Min-link and min-bandwidth cannot co-exist.
When ports are down due to min-link/min-bandwidth, in show interface brief command output, port down with the corresponding reason code for the failure due to min-link/min-bandwidth.
Minimum Active Members/Bandwidth
The user can specify the minimum number of members that must be operationally up to declare their LAG as operationally UP. Note that this parameter applies to static/dynamic LAG.
port-channel min-links <2 - 32>
The minimum active member configuration will be allowed to be modified to be greater than the current number of active members. In such configuration, the LAG operational status will become operationally down.
The user can specify the minimum bandwidth, based on the configured value and the ports that satisfy the conditions LAG will be operationally UP. This parameter is applied for static/dynamic LAG.
port-channel min-bandwidth BANDWIDTH
BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits.
When condition fails, the operational state changes to DOWN.
Note: Do not configure minimum-link, Minimum Bandwidth both on TORS and switches at the same time to avoid flaps of MLAG.
Topology
MC - LAG Topology
 
 
 
 
 
Configuration
TOR1:
#configure terminal
Enter configure mode.
(config)# bridge 1 protocol rstp vlan-bridge
Configure bridge type
(config)# vlan database
Enter vlan database mode
(config-vlan)# vlan 600,601,502 bridge 1 state enable
Configure a vlans and add it to the bridge.
(config-if)#exit
Exit vlan configuration mode.
(config)#interface mlag1
Enter Interface mode
(config-if)# switchport
Make mlag as layer2 port
(config-if)# bridge-group 1
Attach interface to bridge
(config-if)# switchport mode trunk
Configure trunk port
(config-if)# switchport trunk allowed vlan add 600,601,502
Add interface to vlans
(config-if)# spanning-tree edgeport
Configure port as edge port to avoid loops
(config-if)# spanning-tree bpdu-filter enable
Enable bpdu filter to avoid loops
(config-if)#mtu 9216
Configure mtu.
(config-if)#exit
Return to privilege mode
(config)#interface mlag3
Enter Interface mode
(config-if)# switchport
Make mlag as layer2 port
(config-if)# bridge-group 1
Attach interface to bridge
(config-if)# switchport mode trunk
Configure trunk port
(config-if)# switchport trunk allowed vlan add 600,502
Add interface to vlans
(config-if)# spanning-tree edgeport
Configure port as edge port to avoid loops
(config-if)# spanning-tree bpdu-filter enable
Enable bpdu filter to avoid loops
(config-if)#mtu 9216
Configure mtu.
(config-if)#exit
Return to privilege mode
(config)#commit
Commit the candidate configuration to the running
Configuration.
(config)#interface po100
Enter Interface mode
(config-if)# switchport
Make po as layer2 port
(config-if)#exit
Exit interface mode.
(config)#interface sa1
Enter Interface mode
(config-if)# switchport
Make sa1 as layer2 port
(config-if)# port-channel load-balance src-dst-mac
Enable load balance
(config-if)#exit
Return to privilege mode
(config)#interface sa3
Enter Interface mode
(config-if)# switchport
Make sa3 as layer2 port
(config-if)# port-channel load-balance src-dst-mac
Enable load balance
(config-if)#exit
Return to privilege mode
(config)#interface ce2/4
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#exit
Return to privilege mode
(config)#interface ce3/1
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#exit
Return to privilege mode
(config)#interface ce3/2
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#exit
Return to privilege mode
(config)#interface ce3/3
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#exit
Return to privilege mode
(config)#interface ce3/4
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#exit
Return to privilege mode
(config)#interface ce4/1
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface ce4/2
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface ce4/3
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#commit
Commit the candidate configuration to the running
Configuration.
(config)#mcec domain configuration
Enter Multichasis Etherchannel domain configuration mode.
(config-mcec-domain)# domain-address 1111.2222.3333
Configure the domain address.
(config-mcec-domain)# domain-system-number 1
Configure the domain system number
(config-mcec-domain)# intra-domain-link po100
Specify the intra domain link for MLAG communication
(config-mcec-domain)#exit
Return to privilege mode
(config)#int mlag1
Enter Interface mode
(config-if)#mode active-standby
Configure mlag mode for mlag1
(config-if)#switchover type revertive 10
Configure revertive timer
(config-if)#exit
Return to privilege mode
(config)#interface sa1
Enter Interface mode
(config-if)#mlag 1
Map sa1 to mlag1
(config-if)#exit
Return to privilege mode
(config)#int mlag3
Enter Interface mode
(config-if)#mode active-standby
Configure mlag mode for mlag3
(config-if)#switchover type revertive 10
Configure revertive timer
(config-if)#exit
Return to privilege mode
(config)#interface sa3
Enter Interface mode
(config-if)#mlag 3
Map sa3 to mlag3
(config-if)#exit
Return to privilege mode
(config-if)# interface sa1
Enter sa interface mode
(config-if)#port-channel min-links 3
Configure min-link value on sa interface
(config)#interface sa3
Enter sa Interface mode
(config-if)#port-channel min-bandwidth 30g
Configure min-bandwidth value on sa/po interface
(config-if)#commit
Commit the candidate configuration to the running
Configuration.
(config-if)#exit
Exit interface mode.
TOR2
 
#configure terminal
Enter configure mode.
(config)#bridge 1 protocol rstp vlan-bridge
Configure bridge type
(config)# vlan database
Enter vlan database
(config-vlan)# vlan 600,601,502 bridge 1 state enable
Configure vlans
(config-vlan)#exit
Exit vlan configure mode.
(config)#interface mlag1
Enter Interface mode
(config-if)# switchport
Make mlag as layer2 port
(config-if)# bridge-group 1
Attach interface to bridge
(config-if)# switchport mode trunk
Configure trunk port
(config-if)# switchport trunk allowed vlan add 600,601,502
Add interface to vlans
(config-if)# spanning-tree edgeport
Configure port as edge port to avoid loops
(config-if)# spanning-tree bpdu-filter enable
Enable bpdu filter to avoid loops
(config-if)#mtu 9216
Configure mtu.
(config-if)#exit
Return to privilege mode
(config)#interface mlag3
Enter Interface mode
(config-if)# switchport
Make mlag as layer2 port
(config-if)# bridge-group 1
Attach interface to bridge
(config-if)# switchport mode trunk
Configure trunk port
(config-if)# switchport trunk allowed vlan add 600,502
Add interface to vlans
(config-if)# spanning-tree edgeport
Configure port as edge port to avoid loops
(config-if)# spanning-tree bpdu-filter enable
Enable bpdu filter to avoid loops
(config-if)#mtu 9216
Configure mtu.
(config-if)#exit
Return to privilege mode
(config)#commit
Commit the candidate configuration to the running
Configuration.
(config)#interface po100
Enter Interface mode
(config-if)# switchport
Make po(IDL) as layer2 port
(config-if)#exit
Return to privilege mode
(config)#interface sa1
Enter Interface mode
(config-if)# switchport
Make sa1 as layer2 port
(config-if)# port-channel load-balance src-dst-mac
Enable load balance
(config-if)#exit
Return to privilege mode
(config)#interface sa3
Enter Interface mode
(config-if)# switchport
Make sa3 as layer2 port
(config-if)# port-channel load-balance src-dst-mac
Enable load balance
(config-if)#exit
Return to privilege mode
(config)#interface ce1/1
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface ce1/2
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface ce1/3
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface ce3/1
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#exit
Return to privilege mode
(config)#interface ce3/2
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#exit
Return to privilege mode
(config)#interface ce3/3
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#exit
Return to privilege mode
(config)#interface ce3/4
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#exit
Return to privilege mode
(config)#interface ce5/1
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#exit
Return to privilege mode
(config)#interface ce5/2
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#exit
Return to privilege mode
(config)#interface ce5/3
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#exit
Return to privilege mode
(config)#commit
Commit the candidate configuration to the running
Configuration.
(config)#mcec domain configuration
Enter Multichasis Etherchannel domain configuration mode.
(config-mcec-domain)# domain-address 1111.2222.3333
Configure the domain address.
(config-mcec-domain)# domain-system-number 2
Configure the domain system number
(config-mcec-domain)# intra-domain-link po100
Specify the intra domain link for MLAG communication
(config-mcec-domain)#exit
Return to privilege mode
(config)#int mlag1
Enter Interface mode
(config-if)#mode active-standby
Configure mlag mode for mlag1
(config-if)#switchover type revertive 10
Configure revertive timer
(config-if)#exit
Return to privilege mode
(config)#interface sa1
Enter Interface mode
(config-if)#mlag 1
Map sa1 to mlag1
(config-if)#exit
Return to privilege mode
(config)#int mlag3
Enter Interface mode
(config-if)#mode active-standby
Configure mlag mode for mlag3
(config-if)#switchover type revertive 10
Configure revertive timer
(config-if)#exit
Return to privilege mode
(config)#interface sa3
Enter Interface mode
(config-if)#mlag 3
Map sa3 to mlag3
(config-if)#exit
Return to privilege mode
(config-if)#interface sa1
Enter sa interface mode
(config-if)#port-channel min-links 3
Configure min-link value on sa interface
(config)#interface sa3
Enter sa Interface mode
(config-if)#port-channel min-bandwidth 30g
Configure min-bandwidth value on sa interface.
(config-if)#commit
Commit the candidate configuration to the running
Configuration.
(config-if)#exit
Exit interface mode.
 
SW1
 
 
#configure terminal
Enter Configure mode.
(config)#bridge 1 protocol rstp vlan-bridge
Configure bridge type
(config)#vlan database
Create vlan database
(config-vlan)#vlan 600,601,502,101,100,300,401,402 bridge 1 state enable
Create Vlans
(config-vlan)#exit
Exit vlan configuration mode.
(config)#interface xe1
Enter Interface mode
(config-if)# switchport
Make xe1 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed vlan all
Enable all VLAN identifiers on this interface.
(config-if)#spanning-tree edgeport
Configure port as edgeport
(config-if)#spanning-tree bpdu-filter enable
Enable spanning tree bpdu filter
(config-if)# mtu 9216
Configure mtu
(config-if)#exit
Return to privilege mode
(config)#interface sa1
Enter Interface mode
(config-if)# switchport
Make xe1 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed vlan add 100,101,300,401,402,502
Enable all VLAN identifiers on this interface.
(config-if)# port-channel load-balance src-dst-mac
Enable load balance
(config-if)#spanning-tree edgeport
Configure port as edgeport
(config-if)#spanning-tree bpdu-filter enable
Enable spanning tree bpdu filter
(config-if)# mtu 9216
Configure mtu
(config-if)#exit
Return to privilege mode
(config)#interface xe2
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#exit
Return to privilege mode
(config)#interface xe3
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#exit
Return to privilege mode
(config)#interface xe4
Enter Interface mode
(config-if)#static-channel-group 1
Add interface to sa1
(config-if)#exit
Return to privilege mode
(config)#interface xe6
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface xe7
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface xe8
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#commit
Commit the candidate configuration to the running
Configuration.
 
SW2
 
(config)#bridge 1 protocol rstp vlan-bridge
Configure bridge type
(config)#vlan database
Create vlan database
(config-vlan)#vlan 600,601,502,101,100, 300,401,402 bridge 1 state enable
Create vlans
(config-vlan)#exit
Exit vlan configuration mode
(config)#interface xe5/1
Enter Interface mode
(config-if)# switchport
Make xe1 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed vlan all
Enable all VLAN identifiers on this interface.
(config-if)#spanning-tree edgeport
Configure port as edge port
(config-if)#spanning-tree bpdu-filter enable
Enable spanning tree bpdu filter
(config-if)# mtu 9216
Configure mtu
(config-if)#exit
Return to privilege mode
(config)#interface sa3
Enter Interface mode
(config-if)# switchport
Make xe1 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed vlan add 100,101,401,402,600,502
Enable all VLAN identifiers on this interface.
(config-if)# port-channel load-balance src-dst-mac
Enable load balance
(config-if)#spanning-tree edgeport
Configure port as edge port
(config-if)#spanning-tree bpdu-filter enable
Enable spanning tree bpdu filter
(config-if)# mtu 9216
Configure mtu
(config-if)#exit
Return to privilege mode
(config)#interface xe3/1
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface xe3/2
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface xe3/3
Enter Interface mode
(config-if)#static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface xe1/1
Enter Interface mode
(config-if)#static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface xe1/2
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#exit
Return to privilege mode
(config)#interface xe1/3
Enter Interface mode
(config-if)#static-channel-group 3
Add interface to sa3
(config-if)#exit
Exit interface mode.
(config)#commit
Commit the candidate configuration to the running
Configuration.
 
This configuration is applicable for the dynamic LAG with MLAG topology except dynamic LAG interface creations, which needs to be referred from the dynamic LAG configurations given above.
Validation Commands
sh int brief sa [id], sh int brief po [id], sh mlag-domain summary, sh static-channel-group <sa id>, <sh etherchannel>, sh running-config interface sa [id], <sh etherchannel summary>.
When sa or po goes down due to min-link or min-bandwidth not satisfied, below validations to be done:
TOR
====
#sh int brief sa1
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
sa1 AGG 1 trunk down PD(Min L/B) 0
 
#
#sh int brief po100
 
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
 
--------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
po100 AGG 1 trunk down PD(Min L/B) 0
 
#
#sh etherchannel
% Lacp Aggregator: po100
% Min-Bandwidth : 40g
% Protocol Down (Min L/B) : True
% Member:
ce3/1
ce3/2
ce3/3
ce3/4
------------------------------------
% Lacp Aggregator: sa1
% Min-links : 3
% Protocol Down (Min L/B): True
% Member:
ce2/2
ce2/3
ce2/4
------------------------------------
% Lacp Aggregator: sa3
% Member:
ce4/1
ce4/2
ce4/3
#
#sh running-config interface sa1
!
interface sa1
switchport
port-channel min-links 3
mlag 1
!
 
#sh static-channel-group 1
Static Aggregator: sa1
Minimum-Links 3
Member Status
ce2/2 down
ce2/3 down
ce2/4 down
#
#sh etherchannel summary
Aggregator po100 100100
Aggregator Type: Layer2
Admin Key: 0100 - Oper Key 0100
Link: ce3/1 (5057) sync: 0
Link: ce3/2 (5058) sync: 0
Link: ce3/3 (5059) sync: 0
Link: ce3/4 (5060) sync: 0
--------------------------------------
LACP Force-Up
In an aggregated environment, there are some parameters that are set for member ports in lag. Whenever the parameters are set and conditions are satisfied, the port channel will be in SYNC. If force-up mode is enabled for the member port, the port channel will always be in SYNC even if the parameters are not set i.e. the traffic will not be affected and the port channel will never go down.
LACP force-up with Dynamic LAG
Topology
LACP force-up with Dynamic LAG
PE1
 
#configure terminal
Enter configure mode.
(config)#hostname PE1
Configure host name
(config)#bridge 1 protocol rstp vlan-bridge
Create a RSTP VLAN bridge on customer side
(config)#vlan database
Enter vlan database.
(config-vlan)#vlan 2-100 bridge 1 state enable
Configure VLAN for the bridge
(config-vlan)#exit
Exit vlan configuration mode.
(config)#interface ge46
Enter interface mode
(config-if)#switchport
Make interface as Switchport
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode hybrid
Configure the mode as hybrid
(config-if)#switchport hybrid allowed vlan all
Configure allowed VLAN all on the interface
(config-if)#load-interval 30
Configure load period in multiple of 30 seconds
(config-if)#exit
Exit interface mode.
(config)#interface po1
Enter the interface mode
(config-if)#switchport
Make the interface as switch port
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode hybrid
Configure the mode as hybrid
(config-if)#switchport hybrid allowed vlan all
Configure allowed vlan all for the hybrid mode
(config-if)#load-interval 30
Configure load period in multiple of 30 seconds
(config-if)#exit
Exit interface mode.
(config)#interface ge44
Enter interface mode
(config-if)#channel-group 1 mode active
Adding interface to channel-group 1
(config-if)#exit
Exit interface mode.
(config)#interface ge45
Enter interface mode
(config-if)#channel-group 1 mode active
Adding interface to channel-group 1
(config-if)#commit
Commit the candidate configuration to the running
Configuration.
(config-if)#exit
Exit interface mode.
PE2
 
#configure terminal
Enter configure mode.
(config)#hostname PE2
Configure host name
(config)#bridge 1 protocol provider-rstp edge
Create provider rstp edge bridge
(config)#vlan database
Enter vlan database mode
(config-vlan)#vlan 2-100 type customer bridge 1 state enable
Configure customer VLAN for the bridge
(config-vlan)#vlan 100 type service point-point bridge 1 state enable
Configure service VLAN for the bridge
(config)#exit
Exit vlan database mode
(config)#cvlan registration table map1 bridge 1
Creating registration table
(config-cvlan-registration)#cvlan 2-100 svlan 100
Mapping cvlan to svlan
(config-cvlan-registration)#exit
Exit cvlan registration mode.
(config)#commit
Commit the candidate configuration to the running
Configuration.
(config)#interface ge43
Enter interface mode
(config-if)#switchport
Make interface as Switchport
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode provider-network
Configure the mode as provider-network
(config-if)# switchport provider-network allowed vlan all
Configure allowed VLAN all on the interface
(config-if)#load-interval 30
Configure load period in multiple of 30 seconds
(config-if)#exit
Exit interface mode.
(config)#interface po1
Enter the interface mode
(config-if)#switchport
Make the interface as switch port
(config-if)#bridge-group 1
Associate the interface with bridge group 1
(config-if)#switchport mode customer-edge hybrid
Set the switching characteristics of this interface to customer-edge hybrid
(config-if)#switchport customer-edge hybrid allowed vlan all
Set the switching characteristics of this interface to customer-edge hybrid and allow vlan all
(config-if)#switchport customer-edge vlan registration map1
Configuring the registration table mapping on lag interface
(config-if)#load-interval 30
Configure load period in multiple of 30 seconds
(config-if)#exit
Exit interface mode.
(config)#interface ge44
Enter interface mode
(config-if)#channel-group 1 mode active
Adding interface to channel-group 1
(config-if)#lacp force-up
Enable lacp force-up for the member port interface
(config-if)#exit
Exit interface mode.
(config)#interface ge45
Enter interface mode
(config-if)#channel-group 1 mode active
Adding interface to channel-group 1
(config-if)#commit
Commit the candidate configuration to the running
Configuration.
(config-if)#exit
Exit interface mode.
Send L2 traffic with incremental source mac of 1000 and with VLAN 100 from CE1 and with incremental source mac of 1000 and with SVLAN 100(TPID 0x88a8), CVLAN 100 from CE2.
Validation
PE1
CE1#show mac address-table count bridge 1
MAC Entries for all vlans:
Dynamic Address Count: 2001
Static (User-defined) Unicast MAC Address Count: 0
Static (User-defined) Multicast MAC Address Count: 0
Total MAC Addresses in Use: 2001
 
CE1#show etherchannel summary
Aggregator po1 100001
Aggregator Type: Layer2
Admin Key: 0001 - Oper Key 0001
Link: ge44 (5043) sync: 1
Link: ge45 (5046) sync: 1
 
CE1#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
ge44 363.65 710252 772.76 1420506
ge45 363.63 710222 0.00 0
ge46 772.77 1420525 727.31 1420526
po1 728.56 1422971 774.09 1422966
 
CE2#show mac address-table count bridge 1
MAC Entries for all vlans:
Dynamic Address Count: 2001
Static (User-defined) Unicast MAC Address Count: 0
Static (User-defined) Multicast MAC Address Count: 0
Total MAC Addresses in Use: 2001
 
CE2#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
ge43 774.26 1423267 784.17 1361411
ge44 774.26 1423268 364.36 711634
ge45 0.00 0 364.36 711634
po1 774.26 1423267 728.71 1423267
 
CE2#show etherchannel summary
Aggregator po1 100001
Aggregator Type: Layer2
Admin Key: 0001 - Oper Key 0001
Link: ge44 (5020) sync: 1
Link: ge45 (5022) sync: 1
 
On server side (PE1) to make LAG down you can unconfigure the channel-group 1 configurations and verify force-up is getting enabled in PE2.
To simulate the force-up
 
PE1(config)#interface ge44
Enter interface mode.
PE1(config-if)#no channel-group
Removing channel-group configurations from interface.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#interface ge45
Enter interface mode.
PE1(config-if)#no channel-group
Removing channel-group configurations from interface.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#commit
Commit the candidate configuration to the running
Configuration.
PE2
PE2#show interface brief | include po1
po1 AGG 1 customer-edge up none 1g
 
PE2#show etherchannel summary
Aggregator po1 100001
Aggregator Type: Layer2
Admin Key: 0001 - Oper Key 0001
Link: ge44 (5020) sync: 0 (force-up)
Link: ge45 (5022) sync: 0
 
PE2#show etherchannel detail
Aggregator po1 100001
Aggregator Type: Layer2
Mac address: b8:6a:97:4d:65:d5
Admin Key: 0001 - Oper Key 0001
Actor LAG ID- 0x8000,b8-6a-97-28-a5-c0,0x0001
Receive link count: 0 - Transmit link count: 0
Individual: 0 - Ready: 1
Partner LAG ID- 0x0000,00-00-00-00-00-00,0x0000
Link: ge44 (5020) sync: 0 (force-up)
Link: ge45 (5022) sync: 0
Collector max delay: 5
 
To forward traffic from ge44 of PE1
 
PE1(config)#interface ge44
Enter interface mode.
PE1(config-if)#switchport
Make the interface as switch port.
PE1(config-if)#bridge-group 1
Associate the interface to bridge.
PE1(config-if)#switchport mode hybrid
Configure the mode as hybrid.
PE1(config-if)#switchport hybrid allowed vlan all
Configure allowed vlan all for the hybrid mode.
PE1(config-if)#load-interval 30
Configure load period in multiple of 30 seconds.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#commit
Commit the candidate configuration to the running
Configuration.
 
PE2#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
ge43 774.25 1423257 784.17 1361400
ge44 774.25 1423258 728.71 1423257
ge45 0.00 0 0.00 0
po1 774.25 1423247 728.70 1423245
CE2#
PE1#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
ge44 657.67 1284505 640.77 1177884
ge45 0.00 0 0.00 0
ge46 772.71 1420426 603.08 1177886
 
 
LACP force-up with McLAG
Topology
LACP force-up with McLAG
TOR1
 
(config)#bridge 1 protocol provider-rstp edge
Create provider rstp bridge.
(config)#vlan database
Enter vlan database mode
(config-vlan)#vlan 2-10 type customer bridge 1 state enable
Enabling customer vlan for bridge
(config-vlan)#vlan 2-10 type service point-point bridge 1 state enable
Enabling service vlan for bridge
(config-vlan)#exit
Exit vlan configuration mode.
(config)#cvlan registration table map1 bridge 1
Creating registration table
(config-cvlan-registration)#cvlan 2 svlan 2
Mapping cvlan to svlan
(config-cvlan-registration)#cvlan 10 svlan 2
Mapping cvlan to svlan
(config-cvlan-registration)#exit
Exit cvlan registration mode.
(config)#commit
Commit the candidate configuration to the running configuration.
(config)#interface xe49/1
Entering interface mode
(config-if)#switchport
Configuring interface as switchport
(config-if)#exit
Exit interface mode.
(config)#interface mlag1
Entering mlag interface
(config-if)#switchport
Configuring interface as switchport
(config-if)#bridge-group 1 spanning-tree disable
Associate the interface with bridge group 1and disabling spanning-tree
(config-if)#switchport mode customer-edge hybrid
Set the switching characteristics of this interface to customer-edge hybrid
(config-if)#switchport customer-edge hybrid vlan 2
Set the switching characteristics of this interface to customer-edge hybrid and allow vlan 2
(config-if)#switchport customer-edge hybrid allowed vlan all
Set the switching characteristics of this interface to customer-edge hybrid and allow vlan all
(config-if)#switchport customer-edge vlan registration map1
Configuring the registration table mapping on mlag interface
(config-if)#exit
Exit interface mode.
(config)#interface po1
Entering dynamic lag interface
(config-if)#switchport
Configuring interface as switchport
(config-if)#mlag 1
Enabling mlag group number
(config-if)#exit
Exit interface mode.
(config)#interface ge1
Entering interface mode
(config-if)#lacp force-up
Enable lacp force-up for the member port interface
(config-if)#channel-group 1 mode active
Add this interface to channel group 1
(config-if)#exit
Exit the interface mode
(config)#mcec domain configuration
Entering MCEC mode
(config-mcec-domain)#domain-address 2222.2222.2222
Domain address for the mlag domain
(config-mcec-domain)#domain-system-number 1
Number to identify the node in a domain
(config-mcec-domain)#intra-domain-link xe49/1
Intra domain line between mlag domain
(config-mcec-domain)#exit
Exit mcec domain mode.
(config)#commit
Commit the candidate configuration to the running configuration.
TOR2
 
(config)#bridge 1 protocol provider-rstp edge
Create provider rstp bridge.
(config)#vlan database
Enter vlan database mode
(config-vlan)#vlan 2-10 type customer bridge 1 state enable
Enabling customer vlan for bridge
(config-vlan)#vlan 2-10 type service point-point bridge 1 state enable
Enabling service vlan for bridge
(config-vlan)#exit
Exit vlan database mode.
(config)#cvlan registration table map1 bridge 1
Creating registration table
(config-cvlan-registration)#cvlan 2 svlan 2
Mapping cvlan to svlan
(config-cvlan-registration)#cvlan 10 svlan 2
Mapping cvlan to svlan
(config-cvlan-registration)#exit
Exit cvlan registration mode.
(config)#commit
Commit the candidate configuration to the running configuration.
(config)#interface xe49/1
Entering interface mode
(config-if)#switchport
Configuring interface as switchport
(config-if)#exit
Exit interface mode.
(config)#interface mlag1
Entering mlag interface
(config-if)#switchport
Configuring interface as switchport
(config-if)#bridge-group 1 spanning-tree disable
Associate the interface with bridge group 1and disabling spanning-tree
(config-if)#switchport mode customer-edge hybrid
Set the switching characteristics of this interface to customer-edge hybrid
(config-if)#switchport customer-edge hybrid vlan 2
Set the switching characteristics of this interface to customer-edge hybrid and allow vlan 2
(config-if)#switchport customer-edge hybrid allowed vlan all
Set the switching characteristics of this interface to customer-edge hybrid and allow vlan all
(config-if)#switchport customer-edge vlan registration map1
Configuring the registration table mapping on mlag interface
(config-if)#exit
Exit interface mode.
(config)#interface po1
Entering dynamic lag interface
(config-if)#switchport
Configuring interface as switchport
(config-if)#mlag 1
Enabling mlag group number
(config-if)#exit
Exit interface mode.
(config)#interface ge21
Entering interface mode
(config-if)#lacp force-up
Enable lacp force-up for the member port interface
(config-if)#channel-group 1 mode active
Add this interface to channel group 1
(config-if)#exit
Exit the interface mode
(config)#mcec domain configuration
Entering MCEC mode
(config-mcec-domain)#domain-address 2222.2222.2222
Domain address for the mlag domain
(config-mcec-domain)#domain-system-number 2
Number to identify the node in a domain
(config-mcec-domain)#intra-domain-link xe49/1
Intra domain line between mlag domain
(config-mcec-domain)#exit
Exit mcec domain mode.
(config)#commit
Commit the candidate configuration to the running configuration.
SW1
 
(config)#config t
Enter configure terminal.
(config)#bridge 1 protocol rstp vlan-bridge
Configuring the rstp vlan bridge
(config)#vlan database
Enter vlan database mode.
(config-vlan)#vlan 2-10 bridge 1 state enable
Configure customer vlan.
(config-vlan)#exit
Exit vlan configuration mode.
(config)#interface po1
Entering interface mode
(config-if)#switchport
Configuring interface as switchport
(config-if)#bridge-group 1 spanning-tree disable
Associate the interface with bridge group 1 and disabling spanning-tree
(config-if)#switchport mode access
Configure switchport mode as access
(config-if)#switchport access vlan 2,10
Configure access vlan 2,10
(config-if)#exit
Exit interface mode.
(config)#interface ge1
Entering interface mode
(config-if)#channel-group 1 mode active
Add this interface to channel group 1 .
(config-if)#exit
Exit interface mode.
(config)#interface ge21
Entering interface mode
(config-if)#channel-group 1 mode active
Add this interface to channel group 1.
(config-if)#exit
Exit interface mode.
(config-if)#interface ge46
Entering interface mode
(config-if)#switchport
Configuring interface as switchport
(config-if)#bridge-group 1 spanning-tree disable
Associate the interface with bridge group 1and disabling spanning-tree
(config-if)#switchport mode hybrid
Set the switching characteristics of this interface to hybrid
(config-if)#switchport hybrid allowed vlan all
Set the switching characteristics of this interface to hybrid and allow vlan all
(config-if)#exit
Exit interface mode.
(config)#commit
Commit the candidate configuration to the running configuration.
Validation
TOR1#show etherchannel summary
Aggregator po1 100001
Aggregator Type: Layer2
Admin Key: 32769 - Oper Key 16385
Link: ge1 (5026) sync: 1
 
TOR2#show etherchannel summary
Aggregator po1 100001
Aggregator Type: Layer2
Admin Key: 16385 - Oper Key 16385
Link: ge21 (5046) sync: 1
 
SW1#show etherchannel summary
Aggregator po2 100002
Aggregator Type: Layer2
Admin Key: 0002 - Oper Key 0002
Link: ge2 (5001) sync: 1
Link: ge22 (5021) sync: 1
 
 
 
TOR1#show mlag domain summary
------------------------------------
Domain Configuration
------------------------------------
Domain System Number : 2
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : po99
Domain Adjacency : UP
------------------------------------
MLAG Configuration
------------------------------------
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 1 ef 71 4b 7f 37 5b 6a a5 8c e1 2f 95 9a fe cf
Total Bandwidth : 2g
Mlag Sync : IN_SYNC
Mode : Active-Active
Current Mlag state : Active
 
 
TOR2#show mlag domain summary
------------------------------------
Domain Configuration
------------------------------------
Domain System Number : 1
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : po99
Domain Adjacency : UP
------------------------------------
MLAG Configuration
------------------------------------
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 1 ef 71 4b 7f 37 5b 6a a5 8c e1 2f 95 9a fe cf
Total Bandwidth : 2g
Mode : Active-Active
Current Mlag state : Activ
 
 
 
TOR1#show mac address-table count bridge 1 interface mlag1
MAC Entries for all vlans:
Dynamic Address Count: 1001
Static (User-defined) Unicast MAC Address Count: 0
Static (User-defined) Multicast MAC Address Count: 0
Total MAC Addresses in Use: 1001
TOR1#show mac address-table l count bridge 1 interface mlag1
MAC Entries for all vlans:
Total MAC Addresses in Use: 500
 
 
TOR1#show mac address-table r count bridge 1 interface mlag1
MAC Entries for all vlans:
Total MAC Addresses in Use: 501
 
 
TOR2#show mac address-table count bridge 1 interface mlag1
MAC Entries for all vlans:
Dynamic Address Count: 1001
Static (User-defined) Unicast MAC Address Count: 0
Static (User-defined) Multicast MAC Address Count: 0
Total MAC Addresses in Use: 1001
 
 
TOR2#show mac address-table l count bridge 1 interface mlag1
MAC Entries for all vlans:
Total MAC Addresses in Use: 501
TOR2#show mac address-table r count bridge 1 interface mlag1
MAC Entries for all vlans:
Total MAC Addresses in Use: 500
 
Note: For MLAG case, admin should configure 'force-up' port either on master node or slave node only.
Example: In a static trunk environment, Preboot eXecution Environment (PXE) images are too small for most operating systems to leverage LACP during the boot process. As a result, during a PXE build process, traffic sent by the server is dropped, and the build process can fail.
To correct this situation, a port on an ICX 7750 device connected to a server that is configured as an MCT client can be set to a “force-up” state so that even if the LACPDU is not received from the server, the connected port is up and forwards packets.
To simulate this scenario we can remove channel-group configurations from the server side switch SW1 and check LACP force-up is getting enabled on TOR1:
SW1(config)#interface ge1
Enter interface mode.
SW1(config-if)#no channel-group
Removing channel-group configurations from interface.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#interface ge21
Enter interface mode.
SW1(config-if)#no channel-group
Removing channel-group configurations from interface.
SW1(config-if)#exit
Exit interface mode.
SW1(config)#commit
Commit the candidate configuration to the running
Configuration.
 
TOR1#show etherchannel summary
Aggregator po1 100001
Aggregator Type: Layer2
Admin Key: 32769 - Oper Key 16385
Link: ge1 (5026) sync: 0 (force-up)
 
TOR2#show etherchannel summary
Aggregator po1 100001
Aggregator Type: Layer2
Admin Key: 16385 - Oper Key 16385
Link: ge21 (5046) sync: 0
 
 
TOR1#show mlag domain summary
------------------------------------
Domain Configuration
------------------------------------
Domain System Number : 2
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : po99
Domain Adjacency : UP
------------------------------------
MLAG Configuration
------------------------------------
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 1 ef 71 4b 7f 37 5b 6a a5 8c e1 2f 95 9a fe cf
Total Bandwidth : 1g
Mlag Sync : IN_SYNC
Mode : Active-Active
Current Mlag state : Active
 
 
TOR2#show mlag domain summary
------------------------------------
Domain Configuration
------------------------------------
Domain System Number : 1
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : po99
Domain Adjacency : UP
------------------------------------
MLAG Configuration
------------------------------------
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 1 ef 71 4b 7f 37 5b 6a a5 8c e1 2f 95 9a fe cf
Total Bandwidth : 1g
Mlag Sync : IN_SYNC
Mode : Active-Active
Current Mlag state : Active
 
 
To forward traffic from ge1 of SW2:
 
SW1(config)#interface ge1
Enter interface mode.
SW1(config-if)#switchport
Make the interface as switch port.
SW1(config-if)#bridge-group 1 spanning-tree disable
Associate the interface to bridge.
SW1(config-if)#switchport mode access
Configure the mode as access.
SW1(config-if)#switchport access vlan 4001
Configure allowed vlan 4001 for the access mode.
SW1(config-if)#load-interval 30
Configure load period in multiple of 30 seconds.
SW1(config-if)#commit
Commit the candidate configuration to the running
configuration.
SW1(config-if)#exit
Exit interface mode.
 
TOR1#show mac address-table count bridge 1 interface mlag1
MAC Entries for all vlans:
Dynamic Address Count: 999
Static (User-defined) Unicast MAC Address Count: 0
Static (User-defined) Multicast MAC Address Count: 0
Total MAC Addresses in Use: 999
TOR1#show mac address-table l count bridge 1 interface mlag1
MAC Entries for all vlans:
Total MAC Addresses in Use: 999
TOR1#show mac address-table r count bridge 1 interface mlag1
MAC Entries for all vlans:
Total MAC Addresses in Use: 0
 
 
TOR2#show mac address-table count bridge 1 interface mlag1
MAC Entries for all vlans:
Dynamic Address Count: 0
Static (User-defined) Unicast MAC Address Count: 0
Static (User-defined) Multicast MAC Address Count: 0
Total MAC Addresses in Use: 0
 
 
TOR2#show mac address-table l count bridge 1 interface mlag1
MAC Entries for all vlans:
Total MAC Addresses in Use: 0
TOR2#show mac address-table r count bridge 1 interface mlag1
MAC Entries for all vlans:
Total MAC Addresses in Use: 0
 
 
TOR1#show etherchannel summary
Aggregator po1 100001
Aggregator Type: Layer2
Admin Key: 32769 - Oper Key 16385
Link: ge1 (5026) sync: 0 (force-up)
 
 
TOR1#show etherchannel detail
Aggregator po1 100001
Aggregator Type: Layer2
Mac address: 14:02:ec:1c:31:5b
Admin Key: 32769 - Oper Key 16385
Actor LAG ID- 0x8000,11-11-22-22-33-33,0x4001
Receive link count: 0 - Transmit link count: 0
Individual: 0 - Ready: 1
Partner LAG ID- 0x0000,00-00-00-00-00-00,0x0000
Link: ge1 (5026) sync: 0 (force-up)
Collector max delay: 5
 
 
SW1#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
ge1 0.00 0 726.53 1418994
ge46 772.68 1420362 0.00 0
 
 
TOR1#show interface counters rate mbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx mbps | Rx pps | Tx mbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
ge1 729.42 1424656 0.00 0
mlag1 729.42 1424655 0.00 0
po1 729.43 1424658 0.00 0