OcNOS-DC 6.4.2 : Virtual Extensible Local Area Network Guide : Virtual eXtensible Local Area Network Configuration Guide : EVPN-VXLAN Hybrid Port Support
EVPN-VXLAN Hybrid Port Support
This chapter contains the configurations for EVPN-VXLAN Hybrid Port Support.
Overview
This feature is to map VxLAN untagged and tagged (port+vlan) access interfaces on the same parent interface (Physical, Dynamic and Static LAG). It also supports the Bridge vlan and vxlan untagged access on the same parent interface. 
Topology
The procedures in this section use the topology in Figure 15-16
 
EVPN-VxLAN hybrid port
 
 
 
VXLAN-EVPN Hybrid Port Configuration
VTEP1
Interface and Loopback Configuration
 
(config)#interface xe9
Enter Interface mode for xe9
(config-if)#switchport
Make it L2 interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 1.1.1.1/32 secondary
Configure loopback ip address as 1.1.1.1 for VTEP1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe8
Enter Interface mode for xe8
(config-if)#ip address 10.10.10.1/24
Configure IP address as 10.10.10.1 on network side of Spine1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe31
Enter Interface mode for xe31
(config-if)#ip address 20.20.20.1/24
Configure IP address as 20.20.20.1 on network side of Spine2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
 
OSPF Configuration
 
(config)#router ospf 100
Enter into router OSPF mode
(config-router)#ospf router-id 1.1.1.1
Configure router-id as 1.1.1.1 (lo ip address)
(config-router)#network 1.1.1.1/32 area 0.0.0.0
Add 1.1.1.1 (lo IP address) network into area 0
(config-router)#network 10.10.10.0/24 area 0.0.0.0
Add 10.10.10.0 (Spine1) network into area 0
(config-router)#network 20.20.20.0/24 area 0.0.0.0
Add 20.20.20.0 (Spine2) network into area 0
(config-router)#bfd all-interfaces
Enabling BFD on all OSPF interface for fast convergence
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
 
 
 
BGP Configuration
 
(config)#router bgp 500
Enter into Router BGP mode
(config-router)#bgp router-id 1.1.1.1
Configure router-id as 1.1.1.1 (lo IP address)
(config-router)#neighbor 2.2.2.2 remote-as 500
Specify a VTEP2 loopback IP address and remote-as defined
(config-router)#neighbor 2.2.2.2 update-source lo
Configure update as loopback for VTEP2
(config-router)#neighbor 2.2.2.2 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP2
(config-router)#neighbor 3.3.3.3 remote-as 500
Specify a VTEP3 loopback IP address and remote-as defined
(config-router)#neighbor 3.3.3.3 update-source lo
Configure update as loopback for VTEP3
(config-router)#neighbor 3.3.3.3 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP3
(config-router)#address-family ipv4 unicast
Enter into ipv4 unicast address family mode
(config-router-af)#network 1.1.1.1/32
Advertise loopback network into BGP for VTEP ID reachability
(config-router-af)#neighbor 2.2.2.2 activate
Activate 2.2.2.2 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#neighbor 3.3.3.3 activate
Activate 3.3.3.3 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#exit-address-family
Exit from ipv4 unicast address family mode
(config-router)#address-family l2vpn evpn
Enter into L2VPN EVPN address family mode
(config-router-af)#neighbor 2.2.2.2 activate
Activate 2.2.2.2 (VTEP2) into L2VPN evpn address family mode
(config-router-af)#neighbor 3.3.3.3 activate
Activate 3.3.3.3 (VTEP3) into L2VPN evpn address family mode
(config-router-af)#exit-address-family
Exit from L2VPN address family mode
(config-router)#exit
Exit from Router BGP mode and enter into config mode
(config)#commit
Commit the candidate configuration to the running configuration
 
 
 
VRF Configuration
(config)#mac vrf VRF1
Create mac routing/forwarding instance with VRF1 name and enter into VRF mode
(config-vrf)#rd 1.1.1.1:11
Assign RD value
(config-vrf)#route-target both 9.9.9.9:100
Assign route-target value for same for import and export. Should be same on all node for VRF1
(config-vrf)#exit
Exit from VRF mode
(config)#commit
Commit the candidate configuration to the running configuration
VxLAN Configuration
 
(config)#nvo vxlan enable
Enable VxLAN
(config)#nvo vxlan vtep-ip-global 1.1.1.1
Configure Source VTEP-IP-global configuration
(config)#nvo vxlan id 10 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF1
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-RED
Configure VNI-name as VNI-RED
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan id 20 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF1
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-BLUE
Configure VNI-name as VNI-BLUE
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan access-if port xe9
Enable port mapping i.e. access port to the physical interface
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan xe9 1001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) – physical interface
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan xe9 2001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) – physical interface
(config-nvo-acc-if)#map vni-name VNI-BLUE
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#exit
Exit from configuration mode
 
VTEP2
Interface and Loopback Configuration
 
(config)#interface xe3
Enter Interface mode for xe3
(config-if)#switchport
Make it L2 interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 2.2.2.2/32 secondary
Configure loopback IP address as 2.2.2.2 for VTEP2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe21
Enter Interface mode for xe21
(config-if)#ip address 30.30.30.1/24
Configure IP address as 30.30.30.1 on network side of Spine1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce53
Enter Interface mode for ce53
(config-if)#ip address 40.40.40.1/24
Configure IP address as 40.40.40.1 on network side of Spine2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
 
OSPF Configuration
 
(config)#router ospf 100
Enter into router OSPF mode
(config-router)#ospf router-id 2.2.2.2
Configure router-id as 2.2.2.2 (lo IP address)
(config-router)#network 2.2.2.2/32 area 0.0.0.0
Add 2.2.2.2 (lo IP address) network into area 0
(config-router)#network 30.30.30.0/24 area 0.0.0.0
Add 30.30.30.0 (Spine1) network into area 0
(config-router)#network 40.40.40.0/24 area 0.0.0.0
Add 40.40.40.0 (Spine2) network into area 0
(config-router)#bfd all-interfaces
Enabling BFD on all OSPF interface for fast convergence
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
 
BGP Configuration
 
(config)#router bgp 500
Enter into Router BGP mode
(config-router)#bgp router-id 2.2.2.2
Configure router-id as 2.2.2.2 (lo IP address)
(config-router)#neighbor 1.1.1.1 remote-as 500
Specify a VTEP1 loopback IP address and remote-as defined
(config-router)#neighbor 1.1.1.1 update-source lo
Configure update as loopback for VTEP1
(config-router)#neighbor 1.1.1.1 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP1
(config-router)#neighbor 3.3.3.3 remote-as 500
Specify a VTEP3 loopback IP address and remote-as defined
(config-router)#neighbor 3.3.3.3 update-source lo
Configure update as loopback for VTEP3
(config-router)#neighbor 3.3.3.3 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP3
(config-router)#address-family ipv4 unicast
Enter into ipv4 unicast address family mode
(config-router-af)#network 2.2.2.2/32
Advertise loopback network into BGP for VTEP ID reachability
(config-router-af)#neighbor 1.1.1.1 activate
Activate 1.1.1.1 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#neighbor 3.3.3.3 activate
Activate 3.3.3.3 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#exit-address-family
Exit from ipv4 unicast address family mode
(config-router)#address-family l2vpn evpn
Enter into L2VPN EVPN address family mode
(config-router-af)#neighbor 1.1.1.1 activate
Activate 1.1.1.1(VTEP1) into L2VPN evpn address family mode
(config-router-af)#neighbor 3.3.3.3 activate
Activate 3.3.3.3(VTEP3) into L2VPN evpn address family mode
(config-router-af)#exit-address-family
Exit from L2VPN address family mode
(config-router)#exit
Exit from Router BGP mode and enter into config mode
(config)#commit
Commit the candidate configuration to the running configuration
VRF Configuration
 
(config)# mac vrf VRF1
Create mac routing/forwarding instance with VRF1 name and enter into VRF mode
(config-vrf)#rd 2.2.2.2:11
Assign RD value
(config-vrf)#route-target both 9.9.9.9:100
Assign route-target value for same for import and export. Should be same on all node for VRF1
(config-vrf)#exit
Exit from VRF mode
(config)#commit
Commit the candidate configuration to the running configuration
VxLAN Configuration
 
(config)#nvo vxlan enable
Enable VxLAN
(config)#nvo vxlan vtep-ip-global 2.2.2.2
Configure Source VTEP-IP-global configuration
(config)#nvo vxlan id 10 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF1
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-RED
Configure VNI-name as VNI-RED
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan id 20 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF1
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-BLUE
Configure VNI-name as VNI-BLUE
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan access-if port xe3
Enable port mapping i.e. access port to physical interface
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan xe3 1002
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) – physical interface
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VXLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan xe3 2001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) – physical interface
(config-nvo-acc-if)#map vni-name VNI-BLUE
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#exit
Exit from configuration mode
 
 
 
 
 
VTEP3
Interface and loopback configuration
 
#configure terminal
Enter Configure mode.
(config)#interface xe48
Enter Interface mode for xe48 (SH3)
(config-if)#switchport
Make it L2 interface
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 3.3.3.3/32 secondary
Configure loopback IP address as 3.3.3.3 for VTEP3
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe18
Enter Interface mode for xe18
(config-if)#ip address 50.50.50.1/24
Configure IP address as 50.50.50.1 on network side of Spine1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe19
Enter Interface mode for xe19
(config-if)#ip address 60.60.60.1/24
Configure IP address as 60.60.60.1 on network side of Spine2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
 
OSPF Configuration
 
(config)#router ospf 100
Enter into router OSPF mode
(config-router)#ospf router-id 3.3.3.3
Configure router-ID as 3.3.3.3 (lo IP address)
(config-router)#network 3.3.3.3/32 area 0.0.0.0
Add 3.3.3.3 (lo IP address) network into area 0
(config-router)#network 50.50.50.0/24 area 0.0.0.0
Add 50.50.50.0 (Spine1) network into area 0
(config-router)#network 60.60.60.0/24 area 0.0.0.0
Add 60.60.60.0 (Spine2) network into area 0
(config-router)#bfd all-interfaces
Enabling BFD on all OSPF interface for fast convergence
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
 
 
 
BGP Configuration
 
(config)#router bgp 500
Enter into Router BGP mode
(config-router)#bgp router-id 3.3.3.3
Configure router-ID as 3.3.3.3 (lo ip address)
(config-router)#neighbor 1.1.1.1 remote-as 500
Specify a VTEP1 loopback IP address and remote-as defined
(config-router)#neighbor 1.1.1.1 update-source lo
Configure update as loopback for VTEP1
(config-router)#neighbor 1.1.1.1 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP1
(config-router)#neighbor 2.2.2.2 remote-as 500
Specify a VTEP2 loopback IP address and remote-as defined
(config-router)#neighbor 2.2.2.2 update-source lo
Configure update as loopback for VTEP2
(config-router)#neighbor 2.2.2.2 advertisement-interval 0
Configure advertisement-interval as 0 for fast convergence for VTEP3
(config-router)#address-family ipv4 unicast
Enter into ipv4 unicast address family mode
(config-router-af)#network 3.3.3.3/32
Advertise loopback network into BGP for VTEP ID reachability
(config-router-af)#neighbor 1.1.1.1 activate
Activate 1.1.1.1 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#neighbor 2.2.2.2 activate
Activate 2.2.2.2 (VTEP2) into ipv4 unicast address family mode
(config-router-af)#exit-address-family
Exit from ipv4 unicast address family mode
(config-router)#address-family l2vpn evpn
Enter into L2VPN EVPN address family mode
(config-router-af)#neighbor 1.1.1.1 activate
Activate 1.1.1.1 (VTEP1) into L2VPN evpn address family mode
(config-router-af)#neighbor 2.2.2.2 activate
Activate 2.2.2.2 (VTEP2) into L2VPN evpn address family mode
(config-router-af)#exit-address-family
Exit from L2VPN address family mode
(config-router)#exit
Exit from Router BGP mode and enter into config mode
(config)#commit
Commit the candidate configuration to the running configuration
 
 
 
VRF Configuration
 
(config)# mac vrf VRF1
Create MAC routing/forwarding instance with VRF1 name and enter into VRF mode
(config-vrf)#rd 3.3.3.3:11
Assign RD value
(config-vrf)#route-target both 9.9.9.9:100
Assign route-target value for same for import and export. Should be same on all node for VRF1
(config-vrf)#exit
Exit from VRF mode
(config)#commit
Commit the candidate configuration to the running configuration
VxLAN Configuration
 
(config)#nvo vxlan enable
Enable VxLAN
(config)#nvo vxlan vtep-ip-global 3.3.3.3
Configure Source VTEP-IP-global configuration
(config)#nvo vxlan id 10 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF1
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-RED
Configure VNI-name as VNI-RED
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan id 20 ingress-replication inner-vid-disabled
Configure VxLAN Network identifier with/without inner-VID- disabled configure and enter into VxLAN tenant mode
(config-nvo)#vxlan host-reachability-protocol evpn-bgp VRF1
Assign VRF for EVPN-BGP to carry EVPN route
(config-nvo)#vni-name VNI-BLUE
Configure VNI-name as VNI-BLUE
(config-nvo)#exit
Exit from VxLAN tenant mode and enter into configuration mode.
(config)#nvo vxlan access-if port xe48
Enable port mapping i.e. access port to physical interface
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan xe48 1001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) – physical interface
(config-nvo-acc-if)#map vni-name VNI-RED
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#nvo vxlan access-if port-vlan xe48 2001
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) – physical interface
(config-nvo-acc-if)#map vni-name VNI-BLUE
Map VxLAN Identified to access-port for VxLAN
(config-nvo-acc-if)#exit
Exit from VxLAN access-interface mode and enter into configuration mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#exit
Exit from configuration mode
 
Spine 1
Spine node where all VTEPs are connected
Interface and Loopback Configuration
 
#configure terminal
Enter Configure mode.
(config)#qos enable
Enabling QoS
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 11.11.11.11/32 secondary
Configure loopback IP address as 11.11.11.11 for Spine1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe8
Enter Interface mode for xe8
(config-if)#ip address 10.10.10.2/24
Configure IP address as 10.10.10.2 on network side of VTEP1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe1
Enter Interface mode for xe1
(config-if)#ip address 30.30.30.2/24
Configure IP address as 30.30.30.2 on network side of VTEP2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe18
Enter Interface mode for xe18
(config-if)#ip address 50.50.50.2/24
Configure IP address as 50.50.50.2 on network side of VTEP3
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
OSPF configuration
 
(config)#router ospf 100
Enter into router OSPF mode
(config-router)#ospf router-id 11.11.11.11
Configure router-ID as 11.11.11.11 (lo IP address)
(config-router)#network 11.11.11.11/32 area 0.0.0.0
Add 11.11.11.11 (lo IP address) network into area 0
(config-router)#network 10.10.10.0/24 area 0.0.0.0
Add 10.10.10.0 (VTEP1) network into area 0
(config-router)#network 30.30.30.0/24 area 0.0.0.0
Add 30.30.30.0 (VTEP2) network into area 0
(config-router)#network 50.50.50.0/24 area 0.0.0.0
Add 50.50.50.0 (VTEP3) network into area 0
(config-router)#bfd all-interfaces
Enabling BFD on all OSPF interface for fast convergence
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
 
Spine 2
Spine node where all VTEPs are connected
Interface and loopback configuration
 
(config)#interface lo
Enter Interface mode for lo
(config-if)#ip address 22.22.22.22/32 secondary
Configure loopback IP address as 22.22.22.22 for Spine2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe5
Enter Interface mode for xe5
(config-if)#ip address 20.20.20.2/24
Configure IP address as 20.20.20.2 on network side of VTEP1
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface ce0
Enter Interface mode for ce0
(config-if)#ip address 40.40.40.2/24
Configure IP address as 40.40.40.2 on network side of VTEP2
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#interface xe19
Enter Interface mode for xe19
(config-if)#ip address 60.60.60.2/24
Configure IP address as 60.60.60.2 on network side of VTEP3
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
 
OSPF configuration
 
(config)#router ospf 100
Enter into router OSPF mode
(config-router)#ospf router-id 22.22.22.22
Configure router-id as 11.11.11.11 (lo IP address)
(config-router)#network 22.22.22.22/32 area 0.0.0.0
Add 22.22.22.22 (lo IP address) network into area 0
(config-router)#network 20.20.20.0/24 area 0.0.0.0
Add 20.20.20.0 (VTEP1) network into area 0
(config-router)#network 40.40.40.0/24 area 0.0.0.0
Add 40.40.40.0 (VTEP2) network into area 0
(config-router)#network 60.60.60.0/24 area 0.0.0.0
Add 60.60.60.0 (VTEP3) network into area 0
(config-router)#bfd all-interfaces
Enabling BFD on all OSPF interface for fast convergence
(config-if)#exit
Exit Interface mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
Validation
VTEP1
VTEP1#sh nvo vxlan
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
10 VNI-RED L2 NW ---- ---- ---- ---- 1.1.1.1 3.3.3.3
10 VNI-RED L2 NW ---- ---- ---- ---- 1.1.1.1 2.2.2.2
10 VNI-RED -- AC xe9 --- Single Homed Port --- 0 ---- ---- ----
10 VNI-RED -- AC xe9 --- Single Homed Port --- 1001 ---- ---- ----
20 VNI-BLUE L2 NW ---- ---- ---- ---- 1.1.1.1 3.3.3.3
20 VNI-BLUE L2 NW ---- ---- ---- ---- 1.1.1.1 2.2.2.2
20 VNI-BLUE -- AC xe9 --- Single Homed Port --- 2001 ---- ---- ----
 
Total number of entries are 7
 
VTEP1#sh nvo vxlan access-if brief
 
Inner Admin Link
Interface Vlan vlan Ifindex Vnid status status
-----------------------------------------------------------
xe57 --- --- 500000 10 up up
xe57 1001 --- 500001 10 up up
xe57 2001 --- 500002 20 up up
 
Total number of entries are 3
 
 
VTEP1#show bgp l2vpn evpn summary
BGP router identifier 1.1.1.1, local AS number 500
BGP table version is 4
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
2.2.2.2 4 500 53 54 3 0 0 00:20:58 2 0 0 2 0 0
3.3.3.3 4 500 53 53 3 0 0 00:20:58 2 0 0 2 0 0
 
Total number of neighbors 2
 
Total number of Established sessions 2
 
 
VTEP1#show nvo vxlan tunnel
VXLAN Network tunnel Entries
Source Destination Status Up/Down Update
======================================================================
1.1.1.1 3.3.3.3 Installed 00:10:44 00:10:44
1.1.1.1 2.2.2.2 Installed 00:10:58 00:10:58
 
Total number of entries are 2
 
 
VTEP1#show bgp l2vpn evpn
BGP table version is 4, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[1.1.1.1:1] VRF[VRF1]:
*> [3]:[10]:[32,1.1.1.1]
1.1.1.1 0 100 32768 i ---------- VXLAN
* i[3]:[10]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VXLAN
* i[3]:[10]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VXLAN
*> [3]:[20]:[32,1.1.1.1]
1.1.1.1 0 100 32768 i ---------- VXLAN
* i[3]:[20]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VXLAN
* i[3]:[20]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VXLAN
 
RD[2.2.2.2:1]
*>i[3]:[10]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VXLAN
*>i[3]:[20]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VXLAN
 
RD[3.3.3.3:1]
*>i[3]:[10]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VXLAN
*>i[3]:[20]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VXLAN
 
Total number of prefixes 10
 
VTEP2
VTEP2#sh nvo vxlan
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
10 VNI-RED L2 NW ---- ---- ---- ---- 2.2.2.2 1.1.1.1
10 VNI-RED L2 NW ---- ---- ---- ---- 2.2.2.2 3.3.3.3
10 VNI-RED -- AC xe8 --- Single Homed Port --- 0 ---- ---- ----
10 VNI-RED -- AC xe8 --- Single Homed Port --- 1001 ---- ---- ----
20 VNI-BLUE L2 NW ---- ---- ---- ---- 2.2.2.2 1.1.1.1
20 VNI-BLUE L2 NW ---- ---- ---- ---- 2.2.2.2 3.3.3.3
20 VNI-BLUE -- AC xe8 --- Single Homed Port --- 2001 ---- ---- ----
 
Total number of entries are 7
 
 
VTEP2#sh nvo vxlan access-if brief
 
Inner Admin Link
Interface Vlan vlan Ifindex Vnid status status
-----------------------------------------------------------
xe8 --- --- 500000 10 up up
xe8 1001 --- 500001 10 up up
xe8 2001 --- 500002 20 up up
 
Total number of entries are 3
 
 
VTEP2#show bgp l2vpn evpn summary
BGP router identifier 2.2.2.2, local AS number 500
BGP table version is 4
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
1.1.1.1 4 500 53 53 3 0 0 00:20:56 2 0 0 2 0 0
3.3.3.3 4 500 51 54 3 0 0 00:20:56 2 0 0 2 0 0
 
Total number of neighbors 2
 
Total number of Established sessions 2
 
 
VTEP2#show nvo vxlan tunnel
VXLAN Network tunnel Entries
Source Destination Status Up/Down Update
======================================================================
2.2.2.2 1.1.1.1 Installed 00:11:01 00:11:01
2.2.2.2 3.3.3.3 Installed 00:10:47 00:10:47
 
Total number of entries are 2
 
 
VTEP2#show bgp l2vpn evpn
BGP table version is 4, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[1.1.1.1:1]
*>i [3]:[10]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VXLAN
*>i [3]:[20]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VXLAN
 
RD[2.2.2.2:1] VRF[VRF1]:
* i [3]:[10]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VXLAN
*> [3]:[10]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- VXLAN
* i [3]:[10]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VXLAN
* i [3]:[20]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VXLAN
*> [3]:[20]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- VXLAN
* i [3]:[20]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VXLAN
 
RD[3.3.3.3:1]
*>i [3]:[10]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VXLAN
*>i [3]:[20]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 VXLAN
 
Total number of prefixes 10
VTEP3
VTEP3#sh nvo vxlan
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
10 VNI-RED L2 NW ---- ---- ---- ---- 3.3.3.3 2.2.2.2
10 VNI-RED L2 NW ---- ---- ---- ---- 3.3.3.3 1.1.1.1
10 VNI-RED -- AC ce13/1 --- Single Homed Port --- 0 ---- ---- ----
10 VNI-RED -- AC ce13/1 --- Single Homed Port --- 1001 ---- ---- ----
20 VNI-BLUE L2 NW ---- ---- ---- ---- 3.3.3.3 2.2.2.2
20 VNI-BLUE L2 NW ---- ---- ---- ---- 3.3.3.3 1.1.1.1
20 VNI-BLUE -- AC ce13/1 --- Single Homed Port --- 2001 ---- ---- ----
 
Total number of entries are 7
 
VTEP3#sh nvo vxlan access-if brief
Inner Admin Link
Interface Vlan vlan Ifindex Vnid status status
-----------------------------------------------------------
ce13/1 --- --- 500000 10 up up
ce13/1 1001 --- 500001 10 up up
ce13/1 2001 --- 500002 20 up up
 
Total number of entries are 3
 
VTEP3#show bgp l2vpn evpn summary
BGP router identifier 3.3.3.3, local AS number 500
BGP table version is 3
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
1.1.1.1 4 500 52 52 3 0 0 00:20:37 2 0 0 2 0 0
2.2.2.2 4 500 52 51 3 0 0 00:20:37 2 0 0 2 0 0
 
Total number of neighbors 2
 
Total number of Established sessions 2
 
VTEP3#show nvo vxlan tunnel
VXLAN Network tunnel Entries
Source Destination Status Up/Down Update
======================================================================
3.3.3.3 2.2.2.2 Installed 00:10:50 00:10:50
3.3.3.3 1.1.1.1 Installed 00:10:50 00:10:50
 
Total number of entries are 2
 
VTEP3#show bgp l2vpn evpn
BGP table version is 3, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[1.1.1.1:1]
*>i [3]:[10]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VXLAN
*>i [3]:[20]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VXLAN
 
RD[2.2.2.2:1]
*>i [3]:[10]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VXLAN
*>i [3]:[20]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VXLAN
 
RD[3.3.3.3:1] VRF[VRF1]:
* i [3]:[10]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VXLAN
* i [3]:[10]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VXLAN
*> [3]:[10]:[32,3.3.3.3]
3.3.3.3 0 100 32768 i ---------- VXLAN
* i [3]:[20]:[32,1.1.1.1]
1.1.1.1 0 100 0 i 1.1.1.1 VXLAN
* i [3]:[20]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 VXLAN
*> [3]:[20]:[32,3.3.3.3]
3.3.3.3 0 100 32768 i ---------- VXLAN
 
Total number of prefixes 10