OcNOS-DC 6.4.2 : Virtual Extensible Local Area Network Guide : Virtual eXtensible Local Area Network Configuration Guide : VXLAN Unicast Configuration
VXLAN Unicast Configuration
This chapter contains basic Static-VXLAN unicast configuration examples.
Port Mapping
In this example each VTEP (VTEP1 and VTEP2) is a multilayer switch where xe2 is an access port while xe1 is network port.
After we start sending a packet (say untagged ipv4 packet) from VM1, it hits the VTEP1,VTEP1 does encapsulation based on the VNID configured and send it on xe1. Now the packet reaches VTEP2 and it does decapsulation of the packet. Now based on VNID packet is sent out on access port and it reaches destination VM, VM2.
Topology
The procedures in this section use the topology in Figure 2-2
VXLAN unicast
VTEP1
 
#configure terminal
Enter the configure mode
(config)#interface xe2
Enter interface mode
(config-if)#switchport
Configure the interface as switchport
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode
(config)#interface lo
Enter the configure mode
(config-if)#ip address 1.1.1.1/32 secondary
Configure IP address on the interface xe1
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter the configure mode
(config-if)#ip address 5.5.5.2/24
Configure IP address on the interface xe1
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode
(config)#ip route 2.2.2.2/32 5.5.5.4
Configure static route
(config)#nvo vxlan enable
Enable VXLAN globally on this vtep
(config)#interface tunnel 4
Specify the interface (Tunnel4)to be configured and Enter interface mode
(config-if)#tunnel mode vxlan
Assign this tunnel mode as VXLAN
(config-if)#tunnel source 1.1.1.1
Configure the source IP of this tunnel as an IP address which is configured on the interface xe1 of VTEP1
(config-if)#tunnel destination 2.2.2.2
Configure the destination IP of this tunnel as an IP address which is configured on the interface xe1 of VTEP2.
(config-if)#exit
Exit interface mode
(config)#nvo vxlan id 2
Configure a VNID on this VTEP and enter the nvo mode.
(config-nvo)#vxlan map-network tunnel Tunnel4
Map the tunnel 4 with VNID 2
(config-nvo)#vxlan static-entry host-mac 0000.0000.aaaa remote-vtep-ip 2.2.2.2
Configure a static entry for remote VM with MAC address and IP address.
(config-nvo)#exit
Exit the nvo mode
(config)#nvo vxlan access-if port xe2
Map the access port xe2 of this VTEP
(config-nvo-acc-if)#map vnid 2
Map the VNID 2 to access-port xe2
(config-nvo-acc-if)#exit
Exit the nvo access-if mode
(config)#commit
Perform commit operation for the changes to take effect.
VTEP2
 
#configure terminal
Enter the configure mode
(config)#interface xe2
Enter interface mode
(config-if)#switchport
Configure the interface as switchport
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode
(config)#interface lo
Enter the configure mode
(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address on the interface xe1
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter the configure mode
(config-if)#ip address 5.5.5.4/24
Configure IP address on the interface xe1
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode
(config)#ip route 1.1.1.1/32 5.5.5.2
Configure static route
(config)#nvo vxlan enable
Enable VXLAN globally on this vtep
(config)#interface tunnel 4
Specify the interface (Tunnel4)to be configured and Enter interface mode.
(config-if)#tunnel mode vxlan
Assign this tunnel mode as VXLAN
(config-if)#tunnel source 2.2.2.2
Configure the source IP of this tunnel as an IP address which is configured on the interface xe1 of VTEP1.
(config-if)#tunnel destination 1.1.1.1
Configure the destination IP of this tunnel as an IP address which is configured on the interface xe1 of VTEP2.
(config-if)#exit
Exit interface mode.
(config)#nvo vxlan id 2
Configure a VNID on this VTEP and enter the nvo mode.
(config-nvo)#vxlan map-network tunnel Tunnel4
Map the tunnel 4 with VNID 2
(config-nvo)#vxlan static-entry host-mac 0000.0000.bbbb remote-vtep-ip 1.1.1.1
Configure a static entry for remote VM with MAC address and IP address.
(config-nvo)#exit
Exit the nvo mode.
(config)#nvo vxlan access-if port xe2
Map the access port xe2 of this VTEP
(config-nvo-acc-if)#map vnid 2
Map the VNID 2 to access-port xe2
(config-nvo-acc-if)#exit
Exit the nvo access-if mode
(config)#commit
Perform commit operation for the changes to take effect.
Validation
VTEP1
VTEP1#show nvo vxlan tunnel
VVXLAN Network tunnel Entries
Source Destination Status Up/Down Update
====================================================================================
2.2.2.4 3.3.3.4 Installed 00:37:56 00:37:56
 
Total number of entries are 1
VTEP1#
 
VTEP1#show nvo vxlan
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
3 ---- L2 NW ---- ------ ---- ---- 2.2.2.4 3.3.3.4
3 ---- -- AC xe2 --- Single Homed Port --- ---- ---- ---- ----
 
Total number of entries are 2
 
VTEP1#show nvo vxlan mac-table
===============================================================================================================================================
======
VXLAN MAC Entries
===============================================================================================================================================
======
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
_______________________________________________________________________________________________________________________________________________
______
 
3 ---- ---- ---- 0000.0000.aaaa 3.3.3.4 Static Remote ------- -------
3 xe2 ---- ---- 0000.0000.bbbb Local Dynamic Local ------- -------
 
Total number of entries are : 2
 
VTEP1#show nvo vxlan mac-table vnid 3
 
===============================================================================================================================================
======
VXLAN MAC Entries
===============================================================================================================================================
======
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
_______________________________________________________________________________________________________________________________________________
______
 
3 ---- ---- ---- 0000.0000.aaaa 3.3.3.4 Static Remote ------- -------
3 xe2 ---- ---- 0000.0000.bbbb Local Dynamic Local ------- -------
 
Total number of entries are : 2
RTR1
RTR1#show ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires State Last Reporter
2.2.2.1 xe1 00:11:25 00:03:44 Active 2.2.2.4
3.3.3.1 xe2 00:01:36 00:04:17 Active 3.3.3.4
VTEP2
VTEP2#show nvo vxlan tunnel
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
3 ---- L2 NW ---- ------ ---- ---- 3.3.3.4 2.2.2.4
3 ---- L2 NW ---- ------ ---- ---- 3.3.3.4 239.10.10.9
3 ---- -- AC xe1 --- Single Homed Port --- ---- ---- ---- ----
Total number of entries are 3
VTEP2#
 
VTEP#2show nvo vxlan vnid 3
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
3 ---- L2 NW ---- ------ ---- ---- 3.3.3.4 2.2.2.4
3 ---- -- AC xe2 --- Single Homed Port --- ---- ---- ---- ----
 
Total number of entries are 2
VTEP#show vno vxlan mac-table
===============================================================================================================================================
======
VXLAN MAC Entries
===============================================================================================================================================
======
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
_______________________________________________________________________________________________________________________________________________
______
 
3 xe2 ---- ---- 0000.0000.aaaa Local Dynamic Local ------- -------
3 ---- ---- ---- 0000.0000.bbbb 2.2.2.4 Static Remote ------- -------
 
Total number of entries are : 2
 
VTEP2#show nvo vxlan mac-table vnid 3
===============================================================================================================================================
======
VXLAN MAC Entries
===============================================================================================================================================
======
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
_______________________________________________________________________________________________________________________________________________
______
 
3 xe2 ---- ---- 0000.0000.aaaa Local Dynamic Local ------- -------
3 ---- ---- ---- 0000.0000.bbbb 2.2.2.4 Static Remote ------- -------
 
Total number of entries are : 2
 
 
Intermediate Non-VXLAN Router
This example is same as port mapping but we have an intermediate non VXLAN router. It does forwarding based on IP header.
Topology
The procedures in this section use the topology in Figure 2-3
VXLAN unicast
VTEP1
 
#configure terminal
Enter the configure mode.
(config)#interface xe2
Enter interface mode.
(config-if)#switchport
Configure the interface as switchport.
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter the configure mode.
(config-if)#ip address 2.2.2.4/24
Configure IP address on the interface xe1.
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode.
(config)#ip route 3.3.3.0/24 2.2.2.1
Configuring static route
(config)#nvo vxlan enable
Enable VXLAN globally on this vtep.
(config)#interface tunnel 4
Specify the interface (Tunnel4)to be configured and Enter interface mode.
(config-if)#tunnel mode vxlan
Assign this tunnel mode as VXLAN.
(config-if)#tunnel source 2.2.2.4
Configure the source IP of this tunnel as an IP address which is configured on the interface xe1 of VTEP1.
(config-if)#tunnel destination 3.3.3.4
Configure the destination IP of this tunnel as an IP address which is configured on the interface xe1 of VTEP2.
(config-if)#exit
Exit interface mode.
(config)#nvo vxlan id 3
Configure a VNID on this VTEP and enter the nvo mode.
(config-nvo)#vxlan map-network tunnel Tunnel4
Map the tunnel 4 with this VNID
(config-nvo)#vxlan static-entry host-mac 0000.0000.aaaa remote-vtep-ip 3.3.3.4
Configure a static entry for remote VM with MAC address and IP address.
(config)#nvo vxlan access-if port xe2
Map the access port xe2 of this VTEP
(config-nvo-acc-if)#map vnid 3
Map the VNID 2 to access-port xe2
(config-nvo-acc-if)#exit
Exit NVO access-interface mode
(config)#commit
Perform commit operation for the changes to take effect.
 
RTR1
 
(config)#interface xe1
Enter the configure mode.
(config-if)#ip address 2.2.2.1/24
Configure IP address on the interface xe1.
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter the configure mode.
(config-if)#ip address 3.3.3.1/24
Configure IP address on the interface xe2.
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode.
(config)#commit
Perform commit operation for the changes to take effect.
VTEP2
 
#configure terminal
Enter the configure mode.
(config)#interface xe2
Enter interface mode.
(config-if)#switchport
Configure the interface as switchport.
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter the configure mode.
(config-if)#ip address 3.3.3.4/24
Configure IP address on the interface xe1.
(config-if)#no shutdown
Bring the interface into operation with the no shutdown
(config-if)#exit
Exit interface mode.
(config)#ip route 2.2.2.0/24 3.3.3.1
Configuring static route
(config)#nvo vxlan enable
Enable VXLAN globally on this vtep.
(config)#interface tunnel 4
Specify the interface (Tunnel4)to be configured and Enter interface mode.
(config-if)#tunnel mode vxlan
Assign this tunnel mode as VXLAN.
(config-if)#tunnel source 3.3.3.4
Configure the source IP of this tunnel as an IP address which is configured on the interface xe1 of VTEP1.
(config-if)#tunnel destination 2.2.2.4
Configure the destination IP of this tunnel as an IP address which is configured on the interface xe1 of VTEP2.
(config-if)#exit
Exit interface mode.
(config)#nvo vxlan id 3
Configure a VNID on this VTEP and enter the nvo mode.
(config-nvo)#vxlan map-network tunnel Tunnel4
Map the tunnel 4 with this VNID
(config-nvo)#vxlan static-entry host-mac 0000.0000.bbbb remote-vtep-ip 2.2.2.4
Configure a static entry for remote VM with MAC address and IP address.
(config)#nvo vxlan access-if port xe2
Map the access port xe2 of this VTEP
(config-nvo-acc-if)#map vnid 3
Map the VNID 3 to access-port xe2
(config-nvo-acc-if)#exit
Exit the NVO access interface mode
(config)#commit
Perform commit operation for the changes to take effect.
Validation
VTEP1
VTEP1#show nvo vxlan tunnel
VXLAN Network tunnel Entries
Source Destination Status Up/Down Update
====================================================================================
2.2.2.4 3.3.3.4 Installed 00:37:56 00:37:56
Total number of entries are 1
VTEP1#
VTEP1#
VTEP1#show nvo vxlan
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
3 ---- L2 NW ---- ------ ---- ---- 2.2.2.4 3.3.3.4
3 ---- -- AC xe2 --- Single Homed Port --- ---- ---- ---- ----
Total number of entries are 2
VTEP1#
VTEP1#show nvo vxlan mac-table
===============================================================================================================================================
======
VXLAN MAC Entries
===============================================================================================================================================
======
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
_______________________________________________________________________________________________________________________________________________
______
 
3 ---- ---- ---- 0000.0000.aaaa 3.3.3.4 Static Remote ------- -------
3 xe2 ---- ---- 0000.0000.bbbb Local Dynamic Local ------- -------
 
Total number of entries are : 2
 
VTEP1#
VTEP1#
VTEP1#sh nvo vxlan mac-table vnid 3
===============================================================================================================================================
======
VXLAN MAC Entries
===============================================================================================================================================
======
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
_______________________________________________________________________________________________________________________________________________
______
 
3 ---- ---- ---- 0000.0000.aaaa 3.3.3.4 Static Remote ------- -------
3 xe2 ---- ---- 0000.0000.bbbb Local Dynamic Local ------- -------
 
Total number of entries are : 2
 
VTEP1#
 
 
VTEP2
VTEP2#show nvo vxlan tunnel
VXLAN Network tunnel Entries
Source Destination Status Up/Down Update
====================================================================================
3.3.3.4 2.2.2.4 Installed 00:34:02 00:34:02
Total number of entries are 1
VTEP2#show nvo vxlan
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
3 ---- L2 NW ---- ------ ---- ---- 3.3.3.4 2.2.2.4
3 ---- -- AC xe1 --- Single Homed Port --- ---- ---- ---- ----
Total number of entries are 2
VTEP2#sh nvo vxlan mac-table
===============================================================================================================================================
======
VXLAN MAC Entries
===============================================================================================================================================
======
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
_______________________________________________________________________________________________________________________________________________
______
 
3 xe1 ---- ---- 0000.0000.aaaa Local Dynamic Local ------- -------
3 ---- ---- ---- 0000.0000.bbbb 2.2.2.4 Static Remote ------- -------
 
Total number of entries are : 2
 
VTEP2#sh nvo vxlan mac-table vnid 3
===============================================================================================================================================
======
VXLAN MAC Entries
===============================================================================================================================================
======
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
_______________________________________________________________________________________________________________________________________________
______
 
3 xe1 ---- ---- 0000.0000.aaaa Local Dynamic Local ------- -------
3 ---- ---- ---- 0000.0000.bbbb 2.2.2.4 Static Remote ------- -------
 
Total number of entries are : 2
 
VTEP2#