(config)#nvo vxlan enable | Enable VXLAN |
(config)#nvo vxlan irb | Enable VXLAN IRB |
(config)#evpn esi hold-time 90 | Configure ESI hold time to allow tunnel to come up at the time of vxlan initialization before making the ESI up. It should be same on both VTEP1 and VTEP2 |
(config)#evpn vxlan multihoming enable | Enable Multihoming, save configs and reboot the board for multihoming to be effective |
(config)#mac vrf L2VRF2 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#description MAC VRF BLUE | Give description to L2VRF2 as Blue |
(config-vrf)#rd 1.1.1.1:21 | Assign RD value |
(config-vrf)#route-target both 90.90.90.90:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF2 |
(config-vrf)#exit | Exit from vrf mode |
(config)#ip vrf L3VRF1 | Create MAC routing/forwarding instance with L3VRF1 name and enter into VRF mode |
(config-vrf)#rd 11000:11 | Assign RD value |
(config-vrf)#route-target both 100:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-vrf)# l3vni 1000 | Configure L3VNI as 1000 for L3VRF1 |
(config-vrf)#exit | Exit from vrf mode |
(config)#mac vrf L2VRF1 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#description MAC VRF RED | Give description to L2VRF1 as Red |
(config-vrf)#rd 1.1.1.1:11 | Assign RD value |
(config-vrf)#route-target both 9.9.9.9:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration |
(config)# evpn irb-forwarding anycast-gateway-mac | Add evpn irb-forwarding anycast-gateway-mac address |
(config)#nvo vxlan vtep-ip-global 1.1.1.1 | Assign a global IP to the VTEP |
(config)#nvo vxlan id 101 ingress-replication inner-vid-disabled | Configure VXLAN Network identifier with/without inner-viddisabled configure and enter into VXLAN tenant mode |
(config)#vxlan host-reachability-protocol evpn-bgp L2VRF1 | Assign vrf for evpn-bgp to carry EVPN rout |
(config-nvo)# evpn irb1001 | Configure irb1001 under vxlan id 101 |
(config-nvo)# vni-name VNI-101 | Configure VNI name as VNI-101 |
(config-nvo)#exit | Exit from VXLAN tenant mode and enter into configuration mode |
(config)#nvo vxlan id 201 ingress-replication inner-vid-disabled | Configure VXLAN Network identifier with/without inner-viddisabled configure and enter into VXLAN tenant mode |
(config-nvo)#vxlan host-reachability-protocol evpn-bgp L2VRF2 | Assign VRF for EVPN-BGP to carry EVPN route |
(config-nvo)# evpn irb2001 | Configure irb2001 under vxlan id 201 |
(config-nvo)# vni-name VNI-201 | Configure VNI name as VNI-201 |
(config)#qos enable | Enabling QoS |
(config)#hostname VTEP1 | Configure hostname |
(config)#interface po1 | Enter Interface mode for po1 (MH2) |
(config-if)#switchport | Make it L2 interface |
(config-if)# evpn multi-homed system-mac 0000.0000.2222 | Configure system mac as ESI value for Lag (po1) interface. VTEP1 and VTEP2 should have same ESI value |
(config)#interface po100 | Enter Interface mode for po100 |
(config-if)#load-interval 30 | Make it member port of po1 |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P3 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce49 | Enter Interface mode for ce49 |
(config-if)#channel-group 100 mode active | Map the interface ce49 to po1 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce52 | Enter Interface mode for network side port |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P3 |
(config-if)#channel-group 1 mode active | Map the ce52 interface to po100 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)# interface irb1001 | Configure IRB interface 1001 |
(config-if)#ip vrf forwarding L3VRF1 | Configure L3VRF1 |
(config-if)#evpn irb-if-forwarding anycast-gateway-mac | Enable an IRB interface to use the global anycast IRB mac-address. |
(config-irb-if)# ip address 11.11.11.1/24 anycast | Configure the IPv4 primary address as anycast |
(config-irb-if)# ip address 12.11.11.1/24 secondary anycast | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 13.11.11.1/16 secondary | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 14.11.11.1/24 secondary | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 15.11.11.1/16 secondary anycast | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 16.11.11.1/8 secondary anycast | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 17.11.11.1/24 secondary anycast | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 18.11.11.1/16 secondary anycast | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 19.11.11.1/8 secondary | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 20.11.11.1/24 secondary anycast | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 21.11.11.1/8 secondary anycast | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 22.11.11.1/24 secondary anycast | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ip address 25.11.11.1/16 secondary anycast | Configure secondary IPv4 secondary address as anycast |
(config-irb-if)# ipv6 address 11:11::11:1/48 anycast | Configure secondary IPv6 primary address as anycast |
(config-irb-if)# ipv6 address 12:11::11:1/64 | Configure secondary IPv6 address |
(config-irb-if)# ipv6 address 13:11::11:1/48 anycast | Configure secondary IPv6 secondary address as anycast |
(config-irb-if)# ipv6 address 14:11::11:1/50 anycast | Configure secondary IPv6 secondary address as anycast |
(config)#router ospf 100 | Enter into router OSPF mode |
(config-router)#ospf router-id 1.1.1.1 | Configure router-id as 1.1.1.1 (lo ip address) |
(config-router)#network 1.1.1.1/32 area 0.0.0.0 | Add 1.1.1.1 (lo ip address) network into area 0 |
(config-router)#network 100.11.11.0/24 area 0.0.0.0 | Add 100.11.11.0(Spine-P3) network into area 0 |
(config-router)#bfd all-interfaces | Enabling bfd on all ospf interface for fast convergence |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#router bgp 5000 | Enter into Router BGP mode |
(config-router)#bgp router-id 1.1.1.1 | Configure router-id as 1.1.1.1 (lo ip address) |
(config-router)#neighbor 2.2.2.2 remote-as 5000 | Specify a VTEP2 loopback ip address and remote-as defined |
(config-router)#neighbor 2.2.2.2 update-source lo | Configure update as loopback for VTEP2 |
(config-router)#neighbor 2.2.2.2 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP2 |
(config-router)#neighbor 4.4.4.4 remote-as 5000 | Specify a VTEP4 loopback ip address and remote-as defined |
(config-router)#neighbor 4.4.4.4 update-source lo | Configure update as loopback for VTEP4 |
(config-router)#neighbor 4.4.4.4 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP4 |
(config-router)#neighbor 5.5.5.5 remote-as 5000 | Specify a VTEP5 loopback ip address and remote-as defined |
(config-router)#neighbor 5.5.5.5 update-source lo | Configure update as loopback for VTEP5 |
(config-router)#neighbor 5.5.5.5 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP5 |
(config-router)#address-family l2vpn evpn | Enter into l2vpn EVPN address family mode |
(config-router-af)#neighbor 2.2.2.2 activate | Activate 2.2.2.2(VTEP2) into l2vpn evpn address family mode |
(config-router-af)#neighbor 4.4.4.4 activate | Activate 3.3.3.3(VTEP4) into l2vpn evpn address family mode |
(config-router-af)#neighbor 5.5.5.5 activate | Activate 5.5.5.5(VTEP5) into l2vpn evpn address family mode |
(config-router-af)#exit-address-family | Exit from l2vpn address family mode |
(config-router)#exit | Exit from Router BGP mode and enter into config mode |
(config)#mac vrf L2VRF1 | Create mac routing/forwarding instance with L2VRF1 name and enter into vrf mode |
(config-vrf)#rd 1.1.1.1:11 | Assign RD value |
(config-vrf)#description MAC VRF RED | Give description to L2VRF1 as RED |
(config-vrf)#route-target both 9.9.9.9:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-vrf)#exit | Exit from vrf mode |
(config)#mac vrf L2VRF2 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#rd 1.1.1.1:21 | Assign RD value |
(config-vrf)#route-target both 90.90.90.90:100 | Assign route-target value for same for import and export |
(config-vrf)#description MAC VRF BLUE | Give description to L2VRF2 as BLUE |
(config-vrf)#exit | Exit from vrf mode |
(config)#nvo vxlan access-if port-vlan po1 10 | Enable port-vlan mapping i.e. access port to outer-vlan (SVLAN) - Multihomed access port |
(config-nvo-acc-if)#map vnid 101 | Map VXLAN Identified to access-port for VXLAN |
(config-nvo-acc-if)# mac 0000.2222.1010 ip 11.11.11.51 | Configure static mac-ip |
(config-nvo-acc-if)#exit | Exit from VXLAN access-interface mode and enter into configuration mode |
(config)#nvo vxlan access-if port-vlan po1 20 | Enable port-vlan mapping i.e. access port to outer-vlan (SVLAN) - Multihomed access port |
(config-nvo-acc-if)#map vnid 201 | Map VXLAN Identified to access-port for VXLAN |
(config-nvo-acc-if)# mac 0000.2222.1020 ip 21.21.21.51 | Configure static mac-ip |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration |
(config-nvo-acc-if)#exit | Exit from VXLAN access-interface mode and enter into configuration mode |
(config)#exit | Exit from configuration mode |
(config)#nvo vxlan enable | Enable VXLAN |
(config)#nvo vxlan irb | Enable VXLAN IRB |
(config)#evpn esi hold-time 90 | Configure ESI hold time to allow tunnel to come up at the time of vxlan initialization before making the ESI up. It should be same on both VTEP1 and VTEP2 |
(config)#evpn vxlan multihoming enable | Enable Multihoming |
(config)#mac vrf L2VRF2 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#description MAC VRF BLUE | Give description to L2VRF2 as Blue |
(config-vrf)#rd 1.1.1.1:21 | Assign RD value |
(config-vrf)#route-target both 90.90.90.90:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF2 |
(config-vrf)#exit | Exit from vrf mode |
(config)#ip vrf L3VRF1 | Create MAC routing/forwarding instance with L3VRF1 name and enter into VRF mode |
(config-vrf)#rd 11000:11 | Assign RD value |
(config-vrf)#route-target both 100:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-vrf)# l3vni 1000 | Configure L3VNI as 1000 for L3VRF1 |
(config-vrf)#exit | Exit from vrf mode |
(config)#mac vrf L2VRF1 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#description MAC VRF RED | Give description to L2VRF1 as Red |
(config-vrf)#rd 1.1.1.1:11 | Assign RD value |
(config-vrf)#route-target both 9.9.9.9:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration |
(config)# evpn irb-forwarding anycast-gateway-mac | Add evpn irb-forwarding anycast-gateway-mac address |
(config)#nvo vxlan vtep-ip-global 1.1.1.1 | Assign a global IP to the VTEP |
(config)#nvo vxlan id 101 ingress-replication inner-vid-disabled | Configure VXLAN Network identifier with/without inner-viddisabled configure and enter into VXLAN tenant mode |
(config)#vxlan host-reachability-protocol evpn-bgp L2VRF1 | Assign vrf for evpn-bgp to carry EVPN rout |
(config-nvo)# evpn irb1001 | Configure irb1001 under vxlan id 101 |
(config-nvo)# vni-name VNI-101 | Configure VNI name as VNI-101 |
(config-nvo)#exit | Exit from VXLAN tenant mode and enter into configuration mode |
(config)#nvo vxlan id 201 ingress-replication inner-vid-disabled | Configure VXLAN Network identifier with/without inner-viddisabled configure and enter into VXLAN tenant mode |
(config-nvo)#vxlan host-reachability-protocol evpn-bgp L2VRF2 | Assign VRF for EVPN-BGP to carry EVPN route |
(config-nvo)# evpn irb2001 | Configure irb2001 under vxlan id 201 |
(config-nvo)# vni-name VNI-201 | Configure VNI name as VNI-201 |
(config)#qos enable | Enabling QoS |
VTEP1(config)#hostname VTEP2 | Configure hostname |
VTEP2(config)#exit | Exit from VTEP1 |
(config)#interface po1 | Enter Interface mode for po1 (MH2) |
(config-if)#switchport | Make it L2 interface |
(config-if)# evpn multi-homed system-mac 0000.0000.2222 | Configure system mac as ESI value for Lag (po1) interface. VTEP1 and VTEP2 should have same ESI value |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface po100 | Enter Interface mode for xe3 |
(config-if)#load-interval 30 | Make it member port of po1 |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P3 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce49 | Enter Interface mode for ce49 |
(config-if)#channel-group 100 mode active | Map the ce49 interface to po100 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce52 | Enter Interface mode for network side port |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P3 |
(config-if)#channel-group 1 mode active | Map the ce52 interface to po1 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)# interface irb1001 | Configure IRB interface 1001 |
(config-if)#ip vrf forwarding L3VRF1 | Configure L3VRF1 |
(config-if)#evpn irb-if-forwarding anycast-gateway-mac | Enable an IRB interface to use the global anycast IRB mac-address. |
(config-irb-if)# ip address 11.11.11.1/24 anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 12.11.11.1/24 secondary anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 13.11.11.1/16 secondary | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 14.11.11.1/24 secondary | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 15.11.11.1/16 secondary anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 16.11.11.1/8 secondary anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 17.11.11.1/24 secondary anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 18.11.11.1/16 secondary anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 19.11.11.1/8 secondary | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 20.11.11.1/24 secondary anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 21.11.11.1/8 secondary anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 22.11.11.1/24 secondary anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ip address 25.11.11.1/16 secondary anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ipv6 address 11:11::11:1/48 anycast | Configure primary IPv4 address as anycast |
(config-irb-if)# ipv6 address 12:11::11:1/64 | Configure the IPv6 address |
(config-irb-if)# ipv6 address 13:11::11:1/48 anycast | Configure the IPv6 address as primary anycast |
(config-irb-if)# ipv6 address 14:11::11:1/50 anycast | Configure the IPv6 address as anycast |
(config)#router ospf 100 | Enter into router OSPF mode |
(config-router)#ospf router-id 1.1.1.1 | Configure router-id as 1.1.1.1 (lo ip address) |
(config-router)#network 1.1.1.1/32 area 0.0.0.0 | Add 1.1.1.1 (lo ip address) network into area 0 |
(config-router)#network 100.11.11.0/24 area 0.0.0.0 | Add 100.11.11.0(Spine-P3) network into area 0 |
(config-router)#bfd all-interfaces | Enabling bfd on all ospf interface for fast convergence |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#router bgp 5000 | Enter into Router BGP mode |
(config-router)#bgp router-id 1.1.1.1 | Configure router-id as 1.1.1.1 (lo ip address) |
(config-router)#neighbor 2.2.2.2 remote-as 5000 | Specify a VTEP2 loopback ip address and remote-as defined |
(config-router)#neighbor 2.2.2.2 update-source lo | Configure update as loopback for VTEP2 |
(config-router)#neighbor 2.2.2.2 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP2 |
(config-router)#neighbor 4.4.4.4 remote-as 5000 | Specify a VTEP4 loopback ip address and remote-as defined |
(config-router)#neighbor 4.4.4.4 update-source lo | Configure update as loopback for VTEP4 |
(config-router)#neighbor 4.4.4.4 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP4 |
(config-router)#neighbor 5.5.5.5 remote-as 5000 | Specify a VTEP5 loopback ip address and remote-as defined |
(config-router)#neighbor 5.5.5.5 update-source lo | Configure update as loopback for VTEP5 |
(config-router)#neighbor 5.5.5.5 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP5 |
(config-router)#address-family l2vpn evpn | Enter into l2vpn EVPN address family mode |
(config-router-af)#neighbor 2.2.2.2 activate | Activate 2.2.2.2(VTEP2) into l2vpn evpn address family mode |
(config-router-af)#neighbor 4.4.4.4 activate | Activate 3.3.3.3(VTEP4) into l2vpn evpn address family mode |
(config-router-af)#neighbor 5.5.5.5 activate | Activate 5.5.5.5(VTEP5) into l2vpn evpn address family mode |
(config-router-af)#exit-address-family | Exit from l2vpn address family mode |
(config-router)#exit | Exit from Router BGP mode and enter into config mode |
(config)#mac vrf L2VRF1 | Create mac routing/forwarding instance with L2VRF1 name and enter into vrf mode |
(config-vrf)#rd 1.1.1.1:11 | Assign RD value |
(config-vrf)#description MAC VRF RED | Give description to L2VRF1 as RED |
(config-vrf)#route-target both 9.9.9.9:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-vrf)#exit | Exit from vrf mode |
(config)#mac vrf L2VRF2 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#rd 1.1.1.1:21 | Assign RD value |
(config-vrf)#route-target both 90.90.90.90:100 | Assign route-target value for same for import and export |
(config-vrf)#description MAC VRF BLUE | Give description to L2VRF2 as BLUE |
(config-vrf)#exit | Exit from vrf mode |
(config)#nvo vxlan access-if port-vlan po1 10 | Enable port-vlan mapping i.e. access port to outer-vlan (SVLAN) - Multihomed access port |
(config-nvo-acc-if)#map vnid 101 | Map VXLAN Identified to access-port for VXLAN |
(config-nvo-acc-if)# mac 0000.2222.1010 ip 11.11.11.51 | Configure static mac-ip |
(config-nvo-acc-if)#exit | Exit from VXLAN access-interface mode and enter into configuration mode |
(config)#nvo vxlan access-if port-vlan po1 20 | Enable port-vlan mapping i.e. access port to outer-vlan (SVLAN) - Multihomed access port |
(config-nvo-acc-if)#map vnid 201 | Map VXLAN Identified to access-port for VXLAN |
(config-nvo-acc-if)# mac 0000.2222.1020 ip 21.21.21.51 | Configure static mac-ip |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration |
(config-nvo-acc-if)#exit | Exit from VXLAN access-interface mode and enter into configuration mode |
(config)#exit | Exit from configuration mode |
(config)#nvo vxlan enable | Enable VXLAN |
(config)#nvo vxlan irb | Enable VXLAN IRB |
(config)#evpn esi hold-time 90 | Configure ESI hold time to allow tunnel to come up at the time of vxlan initialization before making the ESI up. It should be same on both VTEP1 and VTEP2 |
(config)#evpn vxlan multihoming enable | Enable Multihoming |
(config)#mac vrf L2VRF2 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#description MAC VRF BLUE | Give description to L2VRF2 as Blue |
(config-vrf)#rd 1.1.1.1:21 | Assign RD value |
(config-vrf)#route-target both 90.90.90.90:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF2 |
(config-vrf)#exit | Exit from vrf mode |
(config)#ip vrf L3VRF1 | Create MAC routing/forwarding instance with L3VRF1 name and enter into VRF mode |
(config-vrf)#rd 11000:11 | Assign RD value |
(config-vrf)#route-target both 100:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-vrf)# l3vni 1000 | Configure L3VNI as 1000 for L3VRF1 |
(config-vrf)#exit | Exit from vrf mode |
(config)#mac vrf L2VRF1 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#description MAC VRF RED | Give description to L2VRF1 as Red |
(config-vrf)#rd 1.1.1.1:11 | Assign RD value |
(config-vrf)#route-target both 9.9.9.9:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration |
(config)# evpn irb-forwarding anycast-gateway-mac | Add evpn irb-forwarding anycast-gateway-mac address |
(config)#nvo vxlan vtep-ip-global 1.1.1.1 | Assign a global IP to the VTEP |
(config)#nvo vxlan id 101 ingress-replication inner-vid-disabled | Configure VXLAN Network identifier with/without inner-viddisabled configure and enter into VXLAN tenant mode |
(config)#vxlan host-reachability-protocol evpn-bgp L2VRF1 | Assign vrf for evpn-bgp to carry EVPN rout |
(config-nvo)# evpn irb1001 | Configure irb1001 under vxlan id 101 |
(config-nvo)# vni-name VNI-101 | Configure VNI name as VNI-101 |
(config-nvo)#exit | Exit from VXLAN tenant mode and enter into configuration mode |
(config)#nvo vxlan id 201 ingress-replication inner-vid-disabled | Configure VXLAN Network identifier with/without inner-viddisabled configure and enter into VXLAN tenant mode |
(config-nvo)#vxlan host-reachability-protocol evpn-bgp L2VRF2 | Assign VRF for EVPN-BGP to carry EVPN route |
(config-nvo)# evpn irb2001 | Configure irb2001 under vxlan id 201 |
(config-nvo)# vni-name VNI-201 | Configure VNI name as VNI-201 |
(config)#qos enable | Enabling QoS |
VTEP3(config)#hostname VTEP3 | Configure hostname |
(config)#interface po1 | Enter Interface mode for po1 (MH2) |
(config-if)#switchport | Make it L2 interface |
(config-if)# evpn multi-homed system-mac 0000.0000.2222 | Configure system mac as ESI value for Lag (po1) interface. VTEP1 and VTEP2 should have same ESI value |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface po100 | Enter Interface mode for xe3 |
(config-if)#load-interval 30 | Make it member port of po1 |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P3 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce49 | Enter Interface mode for ce49 |
(config-if)#channel-group 100 mode active | Map the interface ce49 to po100 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce52 | Enter Interface mode for network side port |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P3 |
(config-if)#channel-group 1 mode active | Map the interface ce52 to po1 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)# interface irb1001 | Configure IRB interface 1001 |
(config-if)#ip vrf forwarding L3VRF1 | Configure L3VRF1 |
(config-if)#evpn irb-if-forwarding anycast-gateway-mac | Enable an IRB interface to use the global anycast IRB mac-address. |
(config-irb-if)# ip address 11.11.11.1/24 anycast | Configure the IPv4 address |
(config-irb-if)# ip address 12.11.11.1/24 secondary anycast | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 13.11.11.1/16 secondary | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 14.11.11.1/24 secondary | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 15.11.11.1/16 secondary anycast | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 16.11.11.1/8 secondary anycast | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 17.11.11.1/24 secondary anycast | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 18.11.11.1/16 secondary anycast | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 19.11.11.1/8 secondary | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 20.11.11.1/24 secondary anycast | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 21.11.11.1/8 secondary anycast | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 22.11.11.1/24 secondary anycast | Configure secondary IPv4 address as anycast |
(config-irb-if)# ip address 25.11.11.1/16 secondary anycast | Configure secondary IPv4 address as anycast |
(config-irb-if)# ipv6 address 11:11::11:1/48 anycast | Configure the IPv6 as primary anycast |
(config-irb-if)# ipv6 address 12:11::11:1/64 | Configure the IPv6 address |
(config-irb-if)# ipv6 address 13:11::11:1/48 anycast | Configure the IPv6 address as anycast |
(config-irb-if)# ipv6 address 14:11::11:1/50 anycast | Configure the IPv6 address as anycast |
(config)#router ospf 100 | Enter into router OSPF mode |
(config-router)#ospf router-id 1.1.1.1 | Configure router-id as 1.1.1.1 (lo ip address) |
(config-router)#network 1.1.1.1/32 area 0.0.0.0 | Add 1.1.1.1 (lo ip address) network into area 0 |
(config-router)#network 100.11.11.0/24 area 0.0.0.0 | Add 100.11.11.0(Spine-P3) network into area 0 |
(config-router)#bfd all-interfaces | Enabling bfd on all ospf interface for fast convergence |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#router bgp 5000 | Enter into Router BGP mode |
(config-router)#bgp router-id 1.1.1.1 | Configure router-id as 1.1.1.1 (lo ip address) |
(config-router)#neighbor 2.2.2.2 remote-as 5000 | Specify a VTEP2 loopback ip address and remote-as defined |
(config-router)#neighbor 2.2.2.2 update-source lo | Configure update as loopback for VTEP2 |
(config-router)#neighbor 2.2.2.2 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP2 |
(config-router)#neighbor 4.4.4.4 remote-as 5000 | Specify a VTEP4 loopback ip address and remote-as defined |
(config-router)#neighbor 4.4.4.4 update-source lo | Configure update as loopback for VTEP4 |
(config-router)#neighbor 4.4.4.4 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP4 |
(config-router)#neighbor 5.5.5.5 remote-as 5000 | Specify a VTEP5 loopback ip address and remote-as defined |
(config-router)#neighbor 5.5.5.5 update-source lo | Configure update as loopback for VTEP5 |
(config-router)#neighbor 5.5.5.5 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP5 |
(config-router)#address-family l2vpn evpn | Enter into l2vpn EVPN address family mode |
(config-router-af)#neighbor 2.2.2.2 activate | Activate 2.2.2.2(VTEP2) into l2vpn evpn address family mode |
(config-router-af)#neighbor 4.4.4.4 activate | Activate 3.3.3.3(VTEP4) into l2vpn evpn address family mode |
(config-router-af)#neighbor 5.5.5.5 activate | Activate 5.5.5.5(VTEP5) into l2vpn evpn address family mode |
(config-router-af)#exit-address-family | Exit from l2vpn address family mode |
(config-router)#exit | Exit from Router BGP mode and enter into config mode |
(config)#mac vrf L2VRF1 | Create mac routing/forwarding instance with L2VRF1 name and enter into vrf mode |
(config-vrf)#rd 1.1.1.1:11 | Assign RD value |
(config-vrf)#description MAC VRF RED | Give description to L2VRF1 as RED |
(config-vrf)#route-target both 9.9.9.9:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-vrf)#exit | Exit from vrf mode |
(config)#mac vrf L2VRF2 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#rd 1.1.1.1:21 | Assign RD value |
(config-vrf)#route-target both 90.90.90.90:100 | Assign route-target value for same for import and export |
(config-vrf)#description MAC VRF BLUE | Give description to L2VRF2 as BLUE |
(config-vrf)#exit | Exit from vrf mode |
(config)#nvo vxlan access-if port-vlan po1 10 | Enable port-vlan mapping i.e. access port to outer-vlan (SVLAN) - Multihomed access port |
(config-nvo-acc-if)#map vnid 101 | Map VXLAN Identified to access-port for VXLAN |
(config-nvo-acc-if)# mac 0000.2222.1010 ip 11.11.11.51 | Configure static mac-ip |
(config-nvo-acc-if)#exit | Exit from VXLAN access-interface mode and enter into configuration mode |
(config)#nvo vxlan access-if port-vlan po1 20 | Enable port-vlan mapping i.e. access port to outer-vlan (SVLAN) - Multihomed access port |
(config-nvo-acc-if)#map vnid 201 | Map VXLAN Identified to access-port for VXLAN |
(config-nvo-acc-if)# mac 0000.2222.1020 ip 21.21.21.51 | Configure static mac-ip |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration |
(config-nvo-acc-if)#exit | Exit from VXLAN access-interface mode and enter into configuration mode |
(config)#exit | Exit from configuration mode |
(config)#nvo vxlan enable | Enable VXLAN |
(config)#nvo vxlan irb | Enable VXLAN IRB |
(config)#evpn esi hold-time 90 | Configure ESI hold time to allow tunnel to come up at the time of vxlan initialization before making the ESI up. It should be same on both VTEP1 and VTEP2 |
(config)#evpn vxlan multihoming enable | Enable Multihoming |
(config)#mac vrf L2VRF2 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#description MAC VRF BLUE | Give description to L2VRF2 as Blue |
(config-vrf)#rd 1.1.1.1:21 | Assign RD value |
(config-vrf)#route-target both 90.90.90.90:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF2 |
(config-vrf)#exit | Exit from vrf mode |
(config)#ip vrf L3VRF1 | Create MAC routing/forwarding instance with L3VRF1 name and enter into VRF mode |
(config-vrf)#rd 11000:11 | Assign RD value |
(config-vrf)#route-target both 100:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-vrf)# l3vni 1000 | Configure L3VNI as 1000 for L3VRF1 |
(config-vrf)#exit | Exit from vrf mode |
(config)#mac vrf L2VRF1 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#description MAC VRF RED | Give description to L2VRF1 as Red |
(config-vrf)#rd 1.1.1.1:11 | Assign RD value |
(config-vrf)#route-target both 9.9.9.9:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration |
(config)# evpn irb-forwarding anycast-gateway-mac | Add evpn irb-forwarding anycast-gateway-mac address |
(config)#nvo vxlan vtep-ip-global 1.1.1.1 | Assign a global IP to the VTEP |
(config)#nvo vxlan id 101 ingress-replication inner-vid-disabled | Configure VXLAN Network identifier with/without inner-viddisabled configure and enter into VXLAN tenant mode |
(config)#vxlan host-reachability-protocol evpn-bgp L2VRF1 | Assign vrf for evpn-bgp to carry EVPN rout |
(config-nvo)# evpn irb1001 | Configure irb1001 under vxlan id 101 |
(config-nvo)# vni-name VNI-101 | Configure VNI name as VNI-101 |
(config-nvo)#exit | Exit from VXLAN tenant mode and enter into configuration mode |
(config)#nvo vxlan id 201 ingress-replication inner-vid-disabled | Configure VXLAN Network identifier with/without inner-viddisabled configure and enter into VXLAN tenant mode |
(config-nvo)#vxlan host-reachability-protocol evpn-bgp L2VRF2 | Assign VRF for EVPN-BGP to carry EVPN route |
(config-nvo)# evpn irb2001 | Configure irb2001 under vxlan id 201 |
(config-nvo)# vni-name VNI-201 | Configure VNI name as VNI-201 |
(config)#qos enable | Enabling QoS |
VTEP4(config)#hostname VTEP4 | Configure hostname |
(config)#interface po1 | Enter Interface mode for po1 (MH2) |
(config-if)#switchport | Make it L2 interface |
(config-if)# evpn multi-homed system-mac 0000.0000.2222 | Configure system mac as ESI value for Lag (po1) interface. VTEP1 and VTEP2 should have same ESI value |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface po100 | Enter Interface mode for xe3 |
(config-if)#load-interval 30 | Make it member port of po1 |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P3 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce49 | Enter Interface mode for ce49 |
(config-if)#channel-group 100 mode active | Map the ce49 interface to po100 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce52 | Enter Interface mode for network side port |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P3 |
(config-if)#channel-group 1 mode active | Map the ce52 interface to po01 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)# interface irb1001 | Configure IRB interface 1001 |
(config-if)#ip vrf forwarding L3VRF1 | Configure L3VRF1 |
(config-if)#evpn irb-if-forwarding anycast-gateway-mac | Enable an IRB interface to use the global anycast IRB mac-address. |
(config-irb-if)# ip address 11.11.11.1/24 anycast | Configure the IPv4 address anycast gateway |
(config-irb-if)# ip address 12.11.11.1/24 secondary anycast | Configure the IPv4 address anycast gateway |
(config-irb-if)# ip address 13.11.11.1/16 secondary | Configure the IPv4 address as anycast |
(config-irb-if)# ip address 14.11.11.1/24 secondary | Configure the IPv4 address as anycast |
(config-irb-if)# ip address 15.11.11.1/16 secondary anycast | Configure the IPv4 address as anycast |
(config-irb-if)# ip address 16.11.11.1/8 secondary anycast | Configure the IPv4 address as anycast |
(config-irb-if)# ip address 17.11.11.1/24 secondary anycast | Configure the IPv4 address as anycast |
(config-irb-if)# ip address 18.11.11.1/16 secondary anycast | Configure the IPv4 address as anycast |
(config-irb-if)# ip address 19.11.11.1/8 secondary | Configure the IPv4 address as anycast |
(config-irb-if)# ip address 20.11.11.1/24 secondary anycast | Configure the IPv4 address as anycast |
(config-irb-if)# ip address 21.11.11.1/8 secondary anycast | Configure the IPv4 address as anycast |
(config-irb-if)# ip address 22.11.11.1/24 secondary anycast | Configure the IPv4 address as anycast |
(config-irb-if)# ip address 25.11.11.1/16 secondary anycast | Configure the IPv4 address as anycast |
(config-irb-if)# ipv6 address 11:11::11:1/48 anycast | Configure the IPv4 address as anycast |
(config-irb-if)# ipv6 address 12:11::11:1/64 | Configure the IPv6 address as anycast |
(config-irb-if)# ipv6 address 13:11::11:1/48 anycast | Configure the IPv6 address as anycast |
(config-irb-if)# ipv6 address 14:11::11:1/50 anycast | Configure the IPv6 address as anycast |
(config)#router ospf 100 | Enter into router OSPF mode |
(config-router)#ospf router-id 1.1.1.1 | Configure router-id as 1.1.1.1 (lo ip address) |
(config-router)#network 1.1.1.1/32 area 0.0.0.0 | Add 1.1.1.1 (lo ip address) network into area 0 |
(config-router)#network 100.11.11.0/24 area 0.0.0.0 | Add 100.11.11.0(Spine-P3) network into area 0 |
(config-router)#bfd all-interfaces | Enabling bfd on all ospf interface for fast convergence |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#router bgp 5000 | Enter into Router BGP mode |
(config-router)#bgp router-id 1.1.1.1 | Configure router-id as 1.1.1.1 (lo ip address) |
(config-router)#neighbor 2.2.2.2 remote-as 5000 | Specify a VTEP2 loopback ip address and remote-as defined |
(config-router)#neighbor 2.2.2.2 update-source lo | Configure update as loopback for VTEP2 |
(config-router)#neighbor 2.2.2.2 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP2 |
(config-router)#neighbor 4.4.4.4 remote-as 5000 | Specify a VTEP4 loopback ip address and remote-as defined |
(config-router)#neighbor 4.4.4.4 update-source lo | Configure update as loopback for VTEP4 |
(config-router)#neighbor 4.4.4.4 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP4 |
(config-router)#neighbor 5.5.5.5 remote-as 5000 | Specify a VTEP5 loopback ip address and remote-as defined |
(config-router)#neighbor 5.5.5.5 update-source lo | Configure update as loopback for VTEP5 |
(config-router)#neighbor 5.5.5.5 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP5 |
(config-router)#address-family l2vpn evpn | Enter into l2vpn EVPN address family mode |
(config-router-af)#neighbor 2.2.2.2 activate | Activate 2.2.2.2(VTEP2) into l2vpn evpn address family mode |
(config-router-af)#neighbor 4.4.4.4 activate | Activate 3.3.3.3(VTEP4) into l2vpn evpn address family mode |
(config-router-af)#neighbor 5.5.5.5 activate | Activate 5.5.5.5(VTEP5) into l2vpn evpn address family mode |
(config-router-af)#exit-address-family | Exit from l2vpn address family mode |
(config-router)#exit | Exit from Router BGP mode and enter into config mode |
(config)#mac vrf L2VRF1 | Create mac routing/forwarding instance with L2VRF1 name and enter into vrf mode |
(config-vrf)#rd 1.1.1.1:11 | Assign RD value |
(config-vrf)#description MAC VRF RED | Give description to L2VRF1 as RED |
(config-vrf)#route-target both 9.9.9.9:100 | Assign route-target value for same for import and export. Should be same on all node for L2VRF1 |
(config-vrf)#exit | Exit from vrf mode |
(config)#mac vrf L2VRF2 | Create mac routing/forwarding instance with L2VRF2 name and enter into vrf mode |
(config-vrf)#rd 1.1.1.1:21 | Assign RD value |
(config-vrf)#route-target both 90.90.90.90:100 | Assign route-target value for same for import and export |
(config-vrf)#description MAC VRF BLUE | Give description to L2VRF2 as BLUE |
(config-vrf)#exit | Exit from vrf mode |
(config)#nvo vxlan access-if port-vlan po1 10 | Enable port-vlan mapping i.e. access port to outer-vlan (SVLAN) - Multihomed access port |
(config-nvo-acc-if)#map vnid 101 | Map VXLAN Identified to access-port for VXLAN |
(config-nvo-acc-if)# mac 0000.2222.1010 ip 11.11.11.51 | Configure static mac-ip |
(config-nvo-acc-if)#exit | Exit from VXLAN access-interface mode and enter into configuration mode |
(config)#nvo vxlan access-if port-vlan po1 20 | Enable port-vlan mapping i.e. access port to outer-vlan (SVLAN) - Multihomed access port |
(config-nvo-acc-if)#map vnid 201 | Map VXLAN Identified to access-port for VXLAN |
(config-nvo-acc-if)# mac 0000.2222.1020 ip 21.21.21.51 | Configure static mac-ip |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration |
(config-nvo-acc-if)#exit | Exit from VXLAN access-interface mode and enter into configuration mode |
(config)#exit | Exit from configuration mode |
#configure terminal | Enter Configure mode. |
(config)#evpn vxlan multihoming enable | Enable Multihoming, save configs and reboot the board for multihoming to be effective |
(config)#qos enable | Enabling qos |
(config)#interface po1 | Enter Interface mode for po1 (MH2) |
(config-if)#switchport | Make it L2 interface |
(config-if)# bridge-group 1 | Configure system mac as ESI value for Lag (po1) interface. VTEP1 and VTEP2 should have same ESI value |
(config-if)#switchport mode trunk | Exit Interface mode and return to Configure mode. |
(config-if)#switchport trunk allowed vlan add 2 | Configure the VLANs that should be allowed through this interface |
(config)#interface po4 | Enter Interface mode for xe3 |
(config-if)#load-interval 30 | Make it member port of po1 |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P3 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface po25 | Enter Interface mode for lo |
(config-if)#load-interval 30 | Make it member port of po1 |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P1 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface po100 | Enter Interface mode for network side port |
(config-if)#ip address 100.11.11.1/24 | Configure ip address as 100.11.11.1 on network side of Spine-P3 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce1 | Enter Interface mode for network side port |
(config-if)#channel-group 1 mode activev | Map the ce1 interface to po1 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce2 | Enter Interface mode for network side port |
(config-if)#channel-group 2 mode active | Map the ce2 interface to po2 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce3 | Enter Interface mode for network side port |
(config-if)#channel-group 1 mode active | Map the ce3 interface to po1 |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface ce4 | Enter Interface mode for network side port |
(config-if)#channel-group 1 mode active | Map the ce4 interface to po1 |
(config)# interface lo | Configure IRB interface 1001 |
(config)#ip address 127.0.0.1/8 | Configure the IPv4 address |
(config)#ip address 100.100.100.100/32 secondary | Configure the IPv4 address |
(config)#ipv6 address ::1/128 | Configure the IPv6 address |
(config)# vlan1.2 | Configure IRB interface 1001 |
(config)#ip address 100.12.12.2/24 | Configure the Ip address |
(config)#exit | Exit Interface mode and return to Configure mode. |
(config)#router ospf 100 | Enter into router OSPF mode |
(config-router)#ospf router-id 1.1.1.1 | Configure router-id as 1.1.1.1 (lo ip address) |
(config-router)#network 1.1.1.1/32 area 0.0.0.0 | Add 1.1.1.1 (lo ip address) network into area 0 |
(config-router)#network 100.11.11.0/24 area 0.0.0.0 | Add 100.11.11.0(Spine-P3) network into area 0 |
(config-router)#bfd all-interfaces | Enabling bfd on all ospf interface for fast convergence |
(config-if)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface po1 | Enter Interface mode for po1 (MH2) |
(config-if)#switchport | Enable switch port under po1 |
(config-if)# bridge-group 1 | Map the bridge group |
(config-if)#switchport mode trunk | Configure switch port as trunk |
(config-if)#switchport trunk allowed vlan add 2,10,20 | Add the vlan for the trunk |
(config-if)#switchport trunk allowed vlan add 2 | Add the vlan for the trunk |
(config)#interface ce56 | Enter Interface mode for network side port |
(config-if)#channel-group 1 mode active | Map interface ce56 for channel group |
(config)#interface vlan1.20 | Configure the vlan |
(config)#ip address 21.21.21.2/24 | Configure the IPv4 address for vlan1.20 |
(config)#ipv6 address 21:21::21:2/48 | Configure the IPv6 address for vlan1.20 |
(config)# interface vlan1.2 | Configure the interface Vlan1.2 |
(config)# ip adress100.12.12.2/24 | Configure the IP address for vlan1.2 interface. |
(config)#exit | Exit Interface mode and return to Configure mode. |
(config)#interface xe1 | Enter Interface mode for xe1 |
(config-if)#switchport | Enable switch port under xe1 |
(config-if)# bridge-group 1 | Map the bridge group |
(config-if)#switchport mode trunk | Configure switch port as trunk |
(config-if)#switchport trunk allowed vlan add 2,10,20 | Add the vlan for the trunk |
(config)#exit | Exit Interface mode and return to Configure mode. |
(config)#router ospf 100 | Enter into router OSPF mode |
(config-router)#ospf router-id 5.5.5.5 | Configure router-id as 5.5.5.5 (lo ip address) |
(config-router)#network 5.5.5.5/32 area 0.0.0.0 | Add 5.5.5.5/32 (lo ip address) network into area 0 |
(config-router)#network 100.14.14.0/24 .0/24 area 0.0.0.0 | Add 100.14.14.0/24 (Spine-P3) network into area 0 |
(config-router)#bfd all-interfaces | Enabling bfd on all ospf interface for fast convergence |
(config-if)#exit | Exit Interface mode and return to Configure mode. |