#configure terminal | Enter configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config-vlan)#exit | Exit vlan database mode. |
(config)#interface po2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe33 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe34 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config-vlan)#exit | Exit vlan database mode. |
(config)#interface po1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe5 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe6 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe7 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe8 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config-vlan)#exit | Exit vlan database mode. |
(config)#interface mlag1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface mlag2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface po1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 1 | Enabling Mlag group number |
(config-if)#exit | Exit interface mode. |
(config)#interface po2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 2 | enabling Mlag group number |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe57 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe58 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe10 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe49 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#exit | Exit interface mode. |
(cosnfig)#commit | Commit the transaction. |
(config)#mcec domain configuration | Entering MCEC mode |
(config-mcec-domain)#domain-address 1111.2222.3333 | Domain address for the mlag domain |
(config-mcec-domain)#intra-domain link xe49 | Intra domain line between mlag domain |
(config-mcec-domain)#domain-system-number 1 | Number to identify the node in a domain |
(config-mcec-domain)#exit | Exit MCEC mode |
(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config-vlan)#exit | Exit vlan database mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface mlag2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface po1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 1 | Enabling Mlag group number |
(config-if)#exit | Exit interface mode. |
(config)#interface po2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 2 | enabling Mlag group number |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe10 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe57 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe58 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe49 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the transaction. |
(config)#mcec domain configuration | Entering MCEC mode |
(config-mcec-domain)#domain-address 1111.2222.3333 | Domain address for the Mlag domain |
(config-mcec-domain)#intra-domain link xe49 | Intra domain Link between Mlag domains |
(config-mcec-domain)#domain-system-number 2 | Number to identify the node in domain |
(config-mcec-domain)#exit | Exit MCEC mode |
(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#hostname L2SW | Configuring host name |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN bridge on customer side |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Configure VLAN for the bridge |
(config-vlan)#exit | Exit vlan database mode. |
(config)#interface sa1 | Enter the interface mode |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)# bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Enter the interface mode |
(config-if)# static-channel-group 1 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe9 | Enter the interface mode |
(config-if)# static-channel-group 1 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe11 | Enter the interface mode |
(config-if)# static-channel-group 1 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe22 | Enter the interface mode |
(config-if)# static-channel-group 1 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe47 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)# bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#exit | Exit the interface mode |
(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#hostname TOR1 | Configuring host name |
(config)#bridge 1 protocol provider-rstp edge | Create a PROVIDER-RSTP EDGE bridge |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 type customer bridge 1 state enable | Configure VLAN for the bridge |
(config-vlan)# vlan 200 type service point-point bridge 1 state enable | Configure SVLAN for the bridge |
(config-vlan)#exit | Exit vlan database mode. |
(config)# #cvlan registration table map1 bridge 1 | Configure cvlan-svlan mapping registration table for the bridge. |
(config-cvlan-registration)#cvlan 2 svlan 200 | Map CVLAN to SVLAN |
(config-cvlan-registration)#exit | Exit the config-cvlan-registration mode |
(config)#interface mlag1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 spanning-tree disable | Associate the interface to bridge and disable the spanning tree. |
(config-if)# switchport mode customer-edge hybrid | Configure the mode as customer-edge hybrid |
(config-if)# switchport customer-edge hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#switchport customer-edge vlan registration map1 | Map the cvlan registration table into the MLAG interface |
(config-if)#mode active-standby | Configuring MLAG mode |
(config-if)#exit | Exit the interface mode |
(config)#interface mlag2 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 spanning-tree disable | Associate the interface to bridge and disable the spanning-tree. |
(config-if)# switchport mode provider-network | Configure the mode as provider-network |
(config-if)# switchport provider-network allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#mode active-standby | Configuring MLAG mode |
(config-if)#exit | Exit the interface mode |
(config)#interface sa1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#mlag 1 | Map MLAG on SA interface |
(config-if)#exit | Exit the interface mode |
(config)#interface sa2 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#mlag 2 | Map MLAG on SA interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe1 | Enter the interface mode |
(config-if)# static-channel-group 2 | Map static channel-group to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe13 | Enter the interface mode |
(config-if)# static-channel-group 2 | Map static channel-group to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe9 | Enter the interface mode |
(config-if)# static-channel-group 1 | Map static channel-group to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe11 | Enter the interface mode |
(config-if)# static-channel-group 1 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface sa5 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#exit | Exit the interface mode |
(config)#interface xe3 | Enter the interface mode |
(config-if)#static-channel-group 5 | Map static channel-group to the interface |
(config)#interface xe5 | Enter the interface mode |
(config-if)#static-channel-group 5 | Map static channel-group to the interface |
(config-if)#exit | Exit the interface mode |
(config)#commit | Commit the transaction. |
(config)#mcec domain configuration | Enter the MLAG domain configuration mode |
(config-mcec-domain)#domain-address 1111.2222.3333 | Configure the MLAG domain address |
(config-mcec-domain)#domain-system-number 1 | Configure MLAG domain system number |
(config-mcec-domain)#intra-domain-link sa5 | Configure the intra domain link |
(config-mcec-domain)#exit | Exit from mcec domain mode. |
(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#hostname TOR2 | Configuring host name |
(config)#bridge 1 protocol provider-rstp edge | Create a PROVIDER-RSTP EDGE bridge |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Configure VLAN for the bridge |
(config-vlan)# vlan 200 type service point-point bridge 1 state enable | Configure SVLAN for the bridge |
(config-vlan)#exit | Exit vlan database mode. |
(config)#cvlan registration table map1 bridge 1 | Configure cvlan-svlan mapping registration table for the bridge |
(config-cvlan-registration)#cvlan 2 svlan 200 | Map CVLAN to SVLAN |
(config-cvlan-registration)#exit | Exit the config-cvlan-registration mode |
(config)#interface mlag1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 spanning-tree disable | Associate the interface to bridge and disable the spanning-tree. |
(config-if)# switchport mode customer-edge hybrid | Configure the mode as customer-edge hybrid |
(config-if)# switchport customer-edge hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#switchport customer-edge vlan registration map1 | Map the cvlan registration table into the MLAG interface |
(config-if)#mode active-standby | Configuring MLAG mode |
(config-if)#exit | Exit the interface mode |
(config)#interface mlag2 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 spanning-tree disable | Associate the interface to bridge and disable the spanning-tree. |
(config-if)# switchport mode provider-network | Configure the mode as provider-network |
(config-if)# switchport provider-network allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#mode active-standby | Configuring MLAG mode |
(config-if)#exit | Exit the interface mode |
(config)#interface sa1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#mlag 1 | Map MLAG on SA interface |
(config-if)#exit | Exit the interface mode |
(config)#interface sa2 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#mlag 2 | Map MLAG on SA interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe11 | Enter the interface mode |
(config-if)# static-channel-group 2 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe38 | Enter the interface mode |
(config-if)# static-channel-group 2 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Enter the interface mode |
(config-if)# static-channel-group 1 | Create static channel group |
(config-if)#exit | Exit the interface mode |
(config)#interface xe22 | Enter the interface mode |
(config-if)# static-channel-group 1 | Create static channel group |
(config-if)#exit | Exit the interface mode |
(config)#interface sa5 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#exit | Exit the interface mode |
(config)#interface xe3 | Enter the interface mode |
(config-if)#static-channel-group 5 | Map static channel-group to the interface |
(config)#interface xe5 | Enter the interface mode |
(config-if)#static-channel-group 5 | Map static channel-group to the interface |
(config-if)#exit | Exit the interface mode |
(config)#commit | Commit the transaction. |
(config)#mcec domain configuration | Enter the MLAG domain configuration mode |
(config-mcec-domain)#domain-address 1111.2222.3333 | Configure the MLAG domain address |
(config-mcec-domain)#domain-system-number 2 | Configure MLAG domain system number |
(config-mcec-domain)#intra-domain-link sa5 | Configure the intera domain link |
(config-if)#exit | Exit the interface mode |
(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#hostname LEAF | Configuring host name |
(config)#bridge 1 protocol provider-rstp edge | Create a PROVIDER-RSTP EDGE bridge |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Configure VLAN for the bridge |
(config-vlan)# vlan 200 type service point-point bridge 1 state enable | Configure SVLAN for the bridge |
(config-vlan)#exit | Exit vlan database mode. |
(config)#cvlan registration table map1 bridge 1 | Configure cvlan-svlan mapping registration table for the bridge |
(config-cvlan-registration)#cvlan 2 svlan 200 | Map CVLAN to SVLAN |
(config-cvlan-registration)#exit | Exit the config-cvlan-registration mode |
(config)#interface sa2 | Enter the interface mode |
(config-if)#swtichport | Make the interface a switch port |
(config-if)# bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode provider-network | Configure the mode as provider-network |
(config-if)#)# switchport provider-network allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe1 | Enter the interface mode |
(config-if)# static-channel-group 2 | Map the interface to the static channel-group |
(config-if)#exit | Exit the interface mode |
(config)#interface xe13 | Enter the interface mode |
(config-if)# static-channel-group 2 | Create static channel group |
(config-if)#exit | Exit the interface mode |
(config)#interface xe11 | Enter the interface mode |
(config-if)# static-channel-group 2 | Map the interface to the static channel-group |
(config-if)#exit | Exit the interface mode |
(config)#interface xe38 | Enter the interface mode |
(config-if)# static-channel-group 2 | Create static channel group |
(config-if)#exit | Exit the interface mode |
(config)#interface xe47 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)# bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)# switchport mode customer-edge hybrid | Configure the mode as customer-edge hybrid |
(config-if)# switchport customer-edge hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#switchport customer-edge vlan registration map1 | Map the cvlan registration table into the MLAG interface |
(config-if)#exit | Exit the interface mode |
(config)#commit | Commit the transaction. |
TOR1(config)#bridge 1 protocol provider-rstp edge | Create provider rstp bridge |
TOR1(config)#vlan database | Enter vlan database mode. |
TOR1(config-vlan)#vlan 2-3990 type customer bridge 1 state enable | Enable customer vlan for bridge |
TOR1(config-vlan)#vlan 2-3990 type service point-point bridge 1 state enable | Enable service vlan for bridge |
TOR1(config-vlan)#exit | Exit vlan database mode. |
TOR1(config)#cvlan registration table map1 bridge 1 | Create registration table |
TOR1(config-cvlan-registration)#cvlan 2-3990 svlan 3990 | Map cvlan to svlan |
TOR1(config-cvlan-registration)#exit | Exit the cvlan registration table mode |
TOR1(config)#interface mlag1 | Enter mlag interface |
TOR1(config-if)#switchport | Configure interface as switchport |
TOR1(config-if)#bridge-group 1 spanning-tree disable | Associate the interface to bridge and disable the spanning-tree. |
TOR1(config-if)# switchport mode customer-edge hybrid | Configure the mode as customer-edge hybrid |
TOR1(config-if)# switchport customer-edge hybrid allowed vlan all | Configure allowed VLAN all on the interface |
TOR1(config-if)#switchport customer-edge vlan registration map1 | Map the cvlan registration table into the MLAG interface |
TOR1(config-if)#exit | Exit interface mode. |
TOR1(config)#interface mlag2 | Enter mlag interface mode. |
TOR1(config-if)#switchport | Configure interface as switchport |
TOR1(config-if)#bridge-group 1 spanning-tree disable | Associate the interface to bridge and disable the spanning-tree. |
TOR1(config-if)#switchport mode provider- network | Set the switching characteristics of this interface to provider network |
TOR1(config-if)#switchport provider-network allowed vlan all | Set the switching characteristics of this interface to provider network and allow all vlan |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#interface po1 | Enter dynamic lag interface |
TOR1(config-if)#switchport | Configure interface as switchport |
TOR1(config-if)#mlag 1 | Enable mlag group number |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config-if)#interface po2 | Enter dynamic lag interface |
TOR1(config-if)#switchport | Configure interface as switchport |
TOR1(config-if)#mlag 2 | Enable mlag group number |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#interface po3 | Enter dynamic lag interface |
TOR1(config-if)#switchport | Configure interface as switchport |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#interface xe2 | Enter interface mode |
TOR1(config-if)#channel-group 3 mode active | Make part of channel group 3 |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#interface xe3 | Enter interface mode |
TOR1(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config-if)#interface xe49/1 | Enter interface mode |
TOR1(config-if)#channel-group 2 mode active | Enable channel-group 2 |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#commit | Commit the transaction. |
TOR1(config)#mcec domain configuration | Enter MCEC mode |
TOR1(config-mcec-domain)#domain-address 2222.3333.4444 | Domain address for the mlag domain |
TOR1(config-mcec-domain)#domain-system-number 1 | Number to identify the node in a domain |
TOR1(config-mcec-domain)#intra-domain-link po3 | Intra domain line between mlag domain |
TOR1(config-mcec-domain)#exit | Exit mcec domain mode. |
TOR1(config)#commit | Commit the transaction. |
TOR1(config)#hardware-profile filter ingress-arp enable | Enable globally hardware profile for arp |
TOR1(config)#arp access-list cep | Create access list with name as cep |
TOR1(config-arp-acl)# 30 permit request ip any mac host 0000.2A6C.668D vlan 3990 inner-vlan 2 | Create permit rule for particular arp request |
TOR1(config-arp-acl)# 40 permit response ip any any mac host 0000.2A6C.668D host 0000.2A6C.7202 vlan 3990 inner-vlan 2 | Create permit rule for particular arp response |
TOR1(config-arp-acl)#exit | Exit ARP ACL mode. |
TOR1(config)#arp access-list pnp | Create access list with name as pnp |
TOR1(config-arp-acl)#20 permit request ip any mac host 0000.2A6C.7202 vlan 3990 inner-vlan 2 | Create permit rule for particular arp request |
TOR1(config-arp-acl)#30 permit response ip any any mac host 0000.2A6C.7202 host 0000.2A6C.668D vlan 3990 inner-vlan 2 | Create permit rule for particular arp response |
TOR1(config-arp-acl)#exit | Exit ARP ACL mode. |
TOR1(config)#interface mlag1 | Enter mlag1 interface |
TOR1(config-if)#arp access-group cep in | Attach rule with access-group cep |
TOR1(config-if)#interface mlag2 | Enter mlag2 interface |
TOR1(config-if)#arp access-group pnp in | Attach rule with access-group pnp |
TOR1(config-if)#exit | Exit interface mode. |
TOR1(config)#commit | Commit the transaction. |
TOR2(config)#bridge 1 protocol provider-rstp edge | Create provider rstp bridge |
TOR2(config)#vlan database | Enter vlan database mode. |
TOR2(config-vlan)#vlan 2-3990 type customer bridge 1 state enable | Enable customer vlan for bridge |
TOR2(config-vlan)#vlan 2-3990 type service point-point bridge 1 state enable | Enable service vlan for bridge |
TOR2(config-vlan)#exit | Exit vlan database mode. |
TOR2(config)#cvlan registration table map1 bridge 1 | Create registration table |
TOR2(config-cvlan-registration)#cvlan 2-3990 svlan 3990 | Map cvlan to svlan |
TOR2(config-cvlan-registration)#exit | Exit the cvlan registration table mode |
TOR2(config)#interface mlag1 | Enter mlag interface mode. |
TOR2(config-if)#switchport | Configure interface as a switch. |
TOR2(config-if)#bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1and disabling spanning-tree |
TOR2(config-if)#switchport mode customer-edge hybrid | Set the switching characteristics of this interface to customer-edge hybrid |
TOR2(config-if)#switchport customer-edge hybrid allowed vlan all | Set the switching characteristics of this interface to customer-edge hybrid and allow vlan all |
TOR2(config-if)#switchport customer-edge vlan registration map1 | Configure the registration table mapping on mlag interface |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface mlag2 | Enter mlag interface |
TOR2(config-if)#switchport | Configure interface as switchport |
TOR2(config-if)#bridge-group 1 | Associate the interface with bridge group 1 |
TOR2(config-if)#switchport mode provider- network | Set the switching characteristics of this interface to provider network |
TOR2(config-if)#switchport provider-network allowed vlan all | Set the switching characteristics of this interface to provider network and allow all vlan |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface po1 | Enter dynamic lag interface |
TOR2(config-if)#switchport | Configure interface as switchport |
TOR2(config-if)#mlag 1 | Enable mlag group number |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface po2 | Enter dynamic lag interface |
TOR2(config-if)#switchport | Configure interface as switchport |
TOR2(config-if)#mlag 2 | Enable mlag group number |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface po3 | Enter dynamic lag interface |
TOR2(config-if)#switchport | Configure interface as switchport |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface xe2 | Enter interface mode |
TOR2(config-if)#channel-group 3 mode active | Make part of channel group 3 |
TOR2(config-if)#interface xe3 | Enter interface mode |
TOR2(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#Interface xe49/1 | Enter interface mode |
TOR2(config-if)#channel-group 2 mode active | Enable channel-group 2 |
TOR2(config-if)#exit | Exit interface mode. |
TOR2(config)#commit | Commit the transaction. |
TOR2(config)#mcec domain configuration | Configure mcec domain information |
TOR2(config-mcec-domain)#domain-address 2222.3333.4444 | Domain address for the mlag domain |
TOR2(config-mcec-domain)#domain-system-number 2 | Number to identify the node in a domain |
TOR2(config-mcec-domain)#intra-domain-link po3 | Intra domain line between mlag domain |
TOR2(config-mcec-domain)#exit | Exit mcec domain mode. |
TOR2(config)#commit | Commit the transaction. |
TOR2(config)#hardware-profile filter ingress-arp enable | Enable globally hardware profile for arp |
TOR2(config)#arp access-list cep | Create access list with name as cep |
TOR2(config-arp-acl)# 30 permit request ip any mac host 0000.2A6C.668D vlan 3990 inner-vlan 2 | Create permit rule for particular arp request |
TOR2(config-arp-acl)# 40 permit response ip any any mac host 0000.2A6C.668D host 0000.2A6C.7202 vlan 3990 inner-vlan 2 | Create permit rule for particular arp response |
TOR2(config-arp-acl)#exit | Exit ARP ACL mode. |
TOR2(config)#arp access-list pnp | Create access list with name as pnp |
TOR2(config-arp-acl)#20 permit request ip any mac host 0000.2A6C.7202 vlan 3990 inner-vlan 2 | Create permit rule for particular arp request |
TOR2(config-arp-acl)#30 permit response ip any any mac host 0000.2A6C.7202 host 0000.2A6C.668D vlan 3990 inner-vlan 2 | Create permit rule for particular arp response |
TOR2(config-arp-acl)#exit | Exit ARP ACL mode. |
TOR2(config-if)#interface mlag1 | Enter mlag1 interface |
TOR2(config-if)#arp access-group cep in | Attach rule with access-group cep |
TOR2(config-if)#interface mlag2 | Enter mlag2 interface |
TOR2(config-if)#arp access-group pnp in | Attach rule with access-group pnp |
TOR2(config-if)#exit | Exit interface mode. |
TOR2(config)#commit | Commit the transaction. |
SW1(config)#bridge 1 protocol rstp vlan-bridge | Configure the rstp vlan bridge |
SW1(config)#vlan database | Enter vlan database mode. |
SW1(config-vlan)#vlan 2-3990 type customer bridge 1 state enable | Enable customer vlan for bridge |
SW1(config-vlan)#exit | Exit vlan database mode. |
SW1(config)#interface po1 | Enter dynamic lag interface |
SW1(config-if)#switchport | Configure interface as switchport |
SW1(config-if)#bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1and disabling spanning-tree |
SW1(config-if)#switchport mode hybrid | Set the switching characteristics of this interface hybrid |
SW1(config-if)#switchport hybrid allowed vlan all | Set the switching characteristics of this interface hybrid and allowing all vlan |
SW1(config-if)#exit | Exit the interface mode |
SW1(config)#interface xe1 | Enter interface mode |
SW1(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW1(config-if)#exit | Exit the interface mode |
SW1(config)#interface xe2 | Enter interface mode |
SW1(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW1(config-if)#exit | Exit the interface mode |
SW1(config)#interface xe3 | Enter interface mode |
SW1(config-if)#switchport | Configure interface as switchport |
SW1(config-if)#bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1and disabling spanning-tree |
SW1(config-if)#switchport mode hybrid | Set the switching characteristics of this interface hybrid |
SW1(config-if)#switchport hybrid allowed vlan all | Set the switching characteristics of this interface hybrid and allowing all vlan |
SW1(config-if)#exit | Exit the interface mode |
SW1(config)#commit | Commit the transaction. |
Leaf(config)#bridge 1 protocol provider-rstp edge | Configure the rstp vlan bridge |
Leaf(config)#vlan database | Enter vlan database |
Leaf(config-vlan)#vlan 2-3990 type customer bridge 1 state enable | Enable customer vlan for bridge |
Leaf(config)#vlan 2-3990 type service point-point bridge 1 state enable | Enable service vlan for bridge |
Leaf(config-vlan)#exit | Exit vlan database mode. |
Leaf(config)#cvlan registration table map1 bridge 1 | Create registration table |
Leaf(config-cvlan-registration)#cvlan 2-3990 svlan 3990 | Map cvlan to svlan |
Leaf(config-cvlan-registration)#exit | Exit the cvlan registration table mode |
Leaf(config)#interface po2 | Enter interface mode |
Leaf(config-if)#switchport | Configure interface as switchport |
Leaf(config-if)#bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1and disabling spanning-tree |
Leaf(config-if)#switchport mode provider-network | Set the switching characteristics of this interface provider network |
Leaf(config-if)#switchport provider-network allowed vlan all | Set the switching characteristics of this interface provider and allowing all vlan |
Leaf(config-if)#exit | Exit the interface mode |
Leaf(config)#interface xe1 | Enter interface mode |
Leaf(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
Leaf(config-if)#exit | Exit the interface mode |
Leaf(config)#interface xe2 | Enter interface mode |
Leaf(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
Leaf(config-if)#exit | Exit the interface mode |
Leaf(config)#Interface xe3 | Enter interface mode |
Leaf(config-if)#switchport | Configure interface as switchport |
Leaf(config-if)#bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1and disabling spanning-tree |
Leaf(config-if)#switchport mode customer-edge hybrid | Set the switching characteristics of this interface to customer-edge hybrid |
Leaf(config-if)#switchport customer-edge hybrid allowed vlan all | Set the switching characteristics of this interface to customer-edge hybrid and allow vlan all |
Leaf(config-if)#switchport customer-edge vlan registration map1 | Configure the registration table mapping on mlag interface |
Leaf(config-if)#exit | Exit the interface mode |
Leaf(config)#commit | Commit the transaction. |
OcNOS#configure terminal | Enter Configure mode. |
OcNOS(config)# bridge 1 protocol provider-rstp edge | Configure Provider-rstp edge bridge. |
OcNOS(config)# interface xe13/2 | Configure interface xe13/2\ |
OcNOS(config-if)# switchport | Configure the interface as switchport |
OcNOS(config-if)# bridge-group 1 | Assign the above created bridge to this port. |
OcNOS(config-vrf)#exit | Exit from interface mode to config mode |
OcNOS(config)# interface po1 | Configure interface po1 |
OcNOS(config-if)# switchport | Configure the interface as switchport |
OcNOS(config-if)# bridge-group 1 | Assign the above created bridge to this port. |
OcNOS(config-vrf)#exit | Exit from interface mode to config mode |
OcNOS(config)# interface mlag2 | Configure interface mlag1 |
OcNOS(config-if)# switchport | Configure the interface as switchport |
OcNOS(config-if)# bridge-group 1 spanning-tree disable | Assign the above created bridge to this port and disable the spanning tree. |
OcNOS(config-vrf)#exit | Exit from interface mode to config mode |
OcNOS(config)#commit | Commit the transaction. |
OcNOS#configure terminal | Enter Configure mode. |
OcNOS(config)# no bridge 1 rapid-spanning-tree enable bridge-forward | Disable spanning tree globally for Provider-RSTP and keeping the ports in Forwarding state. |
OcNOS(config)# interface mlag1 | Configure interface mlag1 |
OcNOS(config-if)# switchport | Configure the interface as switchport |
OcNOS(config-if)# bridge-group 1 | Assign the above created bridge to this port. |
OcNOS(config-vrf)#exit | Exit from interface mode to config mode |
OcNOS(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode.(config)#bridge 1 protocol rstp vlan-bridge |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan database | Enter VLAN database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config-vlan)#exit | Exit vlan database mode. |
(config)#interface po1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe11 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe22 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config-vlan)#exit | Exit vlan database mode. |
(config)#hardware-profile filter port-isolation enable | Enable the hardware profile filter globally |
(config)#interface mlag1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#switchport protected promiscuous | Configure interface as promiscuous port |
(config-if)#exit | Exit interface mode. |
(config)#interface mlag2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#switchport protected isolated | Configure interface as isolated port |
(config-if)#exit | Exit interface mode. |
(config)#interface po1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 1 | Enabling Mlag group number |
(config-if)#exit | Exit interface mode. |
(config)#interface po2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 2 | enabling Mlag group number |
(config-if)#exit | Exit interface mode. |
(config)#interface po3 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe11 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe13 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe49 | Enter interface mode. |
(config-if)#channel-group 3 mode active | Add this interface to channel group 3 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(cosnfig)#commit | Commit the transaction. |
(config)#mcec domain configuration | Entering MCEC mode |
(config-mcec-domain)#domain-address 1111.2222.3333 | Domain address for the mlag domain |
(config-mcec-domain)# domain-system-number 1 | Number to identify the node in a domain |
(config-mcec-domain)# intra-domain link po3 | Intra domain line between mlag domain |
(config-mcec-domain)#idl-higig | Enable the idl-higig on mlag idl |
(config-mcec-domain)#exit | Exit MCEC mode |
(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config-vlan)#exit | Exit vlan database mode. |
(config)#hardware-profile filter port-isolation enable | Enable the hardware profile filter globally |
(config)#interface mlag1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#switchport protected promiscuous | Configure interface as promiscuous port |
(config-if)#exit | Exit interface mode. |
(config)#interface mlag2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#switchport protected isolated | Configure interface as isolated port |
(config-if)#exit | Exit interface mode. |
(config)#interface po1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 1 | Enabling Mlag group number |
(config-if)#exit | Exit interface mode. |
(config)#interface po2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 2 | Enabling Mlag group number |
(config-if)#exit | Exit interface mode. |
(config)#interface po3 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe22 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe11 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe38 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe49 | Enter interface mode. |
(config-if)#channel-group 3 mode active | Add this interface to channel group 3 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the transaction. |
(config)#mcec domain configuration | Entering MCEC mode |
(config-mcec-domain)#domain-address 1111.2222.3333 | Domain address for the mlag domain |
(config-mcec-domain)# domain-system-number 2 | Number to identify the node in a domain |
(config-mcec-domain)# intra-domain link po3 | Intra domain line between mlag domain |
(config-mcec-domain)#idl-higig | Enable the idl-higig on mlag idl. |
(config-mcec-domain)#exit | Exit MCEC mode |
(config)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan database | Enter vlan database mode. |
(config-vlan)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config-vlan)#exit | Exit vlan database mode. |
(config)#interface po2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe11 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe13 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe38 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#commit | (config)#commit |