OcNOS DC : Virtual Extensible Local Area Network Guide : VxLAN - Data Forwarding Configuration : Static VxLAN Configuration
Static VxLAN Configuration
This chapter explains the static configurations of VxLAN using dynamic OSPF routing protocol configuration.
Configuration
This configuration establishes Layer 2 connectivity over an IP network by setting up two spine switches and VXLAN Tunnel Endpoints (VTEPs) with static VXLAN routing.
In this configuration, each VTEP (VTEP1 and VTEP2) operates as a multilayer switch. Here, xe34/xe34 serves as the access port for VTEP1/VTEP2 while ce50/ce49 and ce12/ce11 acts as the transport network port towards SPINE1 and 2 respectively.
When VM1 sends an untagged IPv4 packet, it arrives at VTEP1 via the access port xe34. VTEP1 encapsulates the packet using the configured VXLAN Network Identifier (VNID 3) and forwards it through the tunnel interface over (ce50/ce49). The encapsulated packet is then received by VTEP2 on its transport port (ce12/ce11). VTEP2 performs decapsulation, extracting the original packet, and forwards it through its access port xe34 by looking up its local forwarding table using VNID. Finally, the packet reaches the destination VM (VM2), completing the communication.
This process ensures seamless Layer 2 connectivity between the two VMs over the IP network using static VXLAN routing.
Topology
The procedures in this section use the topology shown in Figure 1-2
Static VxLAN Routing
Procedure to configure Static VxLAN Routing
Configure the VTEP1:
1. Login to VTEP1 and configure VxLAN mode, assign VNID, map network tunnel with VNID, and enter static route for remote VM (VTEP 2) with MAC address and IP address.
(config)#hostname VTEP1
(config)#nvo vxlan enable
(config)#nvo vxlan id 3
(config-nvo)#vxlan map-network tunnel Tunnel4
(config-nvo)#vxlan static-entry host-mac 0000.0000.aaaa remote-vtep-ip 11.11.11.1
 
2. Configure VxLAN tunnel with source IP address as VTEP1 IP address and destination IP address as VTEP 2 IP address.
(config)#interface Tunnel4
(config-if)#tunnel mode vxlan
(config-if)#tunnel source 10.10.10.1
(config-if)#tunnel destination 11.11.11.1
 
3. Configure VTEP 1 network interface ce49.
(config)#interface ce49
(config-if)#ip address 4.4.4.4/24
 
4. Configure VTEP 1 network interface ce50 with IP address.
(config)#interface ce50
(config-if)#ip address 2.2.2.4/24
 
5. Configure VTEP1 loop back address.
(config)#interface lo
(config-if)#ip address 127.0.0.1/8
(config-if)#ip address 10.10.10.1/32 secondary
 
6. Configure VTEP 1 switchport interface xe34.
(config)#interface xe34
(config-if)#switchport
 
7. Configure a dynamic routing using OSPF router for the network tunnel interfaces ce50 and ce49 source IP address.
(config)router ospf 1
(config-router)ospf router-id 10.10.10.1
(config-router)network 2.2.2.0/24 area 0.0.0.0
(config-router)network 4.4.4.0/24 area 0.0.0.0
(config-router)network 10.10.10.1/32 area 0.0.0.0
 
8. Map the access port interface xe34 with network tunnel VNID 3.
(config)#nvo vxlan access-if port xe34
(config-nvo-acc-if)#map vnid 3
Configure the VTEP2
1. Login to VTEP2 and configure VxLAN mode, assign VNID, map network tunnel with VNID, and enter static route for remote VM (VTEP 2) with MAC address and IP address.
(config)#hostname VTEP2
(config)#nvo vxlan enable
(config)#nvo vxlan id 3
(config-nvo)#vxlan map-network tunnel Tunnel4
(config-nvo)#vxlan static-entry host-mac 0000.0000.bbbb remote-vtep-ip 10.10.10.1
 
2. Configure VxLAN tunnel with source IP address as VTEP2 IP address and destination IP as VTEP2 IP address.
(config)#interface Tunnel4
(config-if)#tunnel mode vxlan
(config-if)#tunnel source 11.11.11.1
(config-if)#tunnel destination 10.10.10.1
 
3. Configure VTEP2 network interface ce11.
(config)#interface ce11
(config-if)#ip address 5.5.5.4/24
 
4. Configure VTEP2 network interface ce12 with IP address.
(config)#interface ce12
(config-if)#ip address 3.3.3.4/24
 
5. Configure VTEP2 loop back address.
(config)#interface lo
(config-if)#ip address 127.0.0.1/8
(config-if)#ip address 11.11.11.1/32 secondary
 
6. Configure VTEP 2 switchport interface xe34.
(config)#interface xe34
(config-if)#switchport
 
7. Configure a dynamic routing using OSPF router for the network tunnel interfaces ce50 and ce49 source IP address.
(config)router ospf 1
(config-router)ospf router-id 11.11.11.1
(config-router)network 3.3.3.0/24 area 0.0.0.0
(config-router)network 5.5.5.0/24 area 0.0.0.0
(config-router)network 11.11.11.1/32 area 0.0.0.0
 
8. Map the access port interface xe34 with network tunnel VNID 3.
(config)#nvo vxlan access-if port xe34
(config-nvo-acc-if)#map vnid 3
Configure the SPINE1
1. Login to SPINE1 and configure the network interfaces.
(config)#hostname SPINE1
(config)#interface ce1/1
(config-if)# ip address 3.3.3.1/24
(config-if)#exit
(config)#interface ce2/1
(config-if)#ip address 2.2.2.1/24
 
2. Configure SPINE1 loop back address.
(config)#interface lo
(config-if)#ip address 127.0.0.1/8
(config-if)#ip address 12.12.12.1/32 secondary
 
3. Configure a dynamic routing using OSPF router.
(config)router ospf 1
(config-router)ospf router-id 12.12.12.1
(config-router)network 2.2.2.0/24 area 0.0.0.0
(config-router)network 3.3.3.0/24 area 0.0.0.0
(config-router)network 12.12.12.1/32 area 0.0.0.0
Configure the SPINE2
1. Login to SPINE2 and configure the network interfaces.
(config)#hostname SPINE1
(config)#interface ce11/1
(config-if)# ip address 5.5.5.1/24
(config-if)#exit
(config)#interface ce14/1
(config-if)#ip address 4.4.4.1/24
 
2. Configure SPINE2 loop back address.
(config)#interface lo
(config-if)#ip address 127.0.0.1/8
(config-if)#ip address 13.13.13.1/32 secondary
 
3. Configure a dynamic routing using OSPF router.
(config)router ospf 1
(config-router)ospf router-id 13.13.13.1
(config-router)network 4.4.4.0/24 area 0.0.0.0
(config-router)network 5.5.5.0/24 area 0.0.0.0
(config-router)network 13.13.13.1/32 area 0.0.0.0
Validation
Execute following show commands to verify the static VxLAN to reach remote virtual machines through the network tunnel interface.
VTEP1
Verify the OSPF neighbors towards SPINEs:
VTEP1#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
 
Neighbor ID Pri State Dead Time Address Interface Instance ID
12.12.12.1 1 Full/DR 00:00:37 2.2.2.1 ce50 0
13.13.13.1 1 Full/Backup 00:00:36 4.4.4.1 ce49 0
VTEP1#
Verify the static VxLAN tunnel on VTEP1:
VTEP1#show nvo vxlan tunnel
VXLAN Network tunnel Entries
Source Destination Status Up/Down Update
========================================================================
10.10.10.1 11.11.11.1 Installed 00:11:58 00:10:13
 
Total number of entries are 1
VTEP1#
 
Verify the VNID Mapping:
VTEP1#show nvo vxlan
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
____________________________________________________________________________________________________________________________
3 ---- L2 NW ---- ---- ---- ---- 10.10.10.1 11.11.11.1
3 ---- -- AC xe34 --- Single Homed Port --- 0 ---- ---- ----
 
Total number of entries are 2
VTEP1#
 
Verify the local and remote MAC address configured:
VTEP1#show nvo vxlan mac-table
============================================================================================================================
VXLAN MAC Entries
============================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc LeafFlag
____________________________________________________________________________________________________________________________
 
3 ---- ---- ---- 0000.0000.aaaa 11.11.11.1 Static Remote ------- 0 ------- ----
 
Total number of entries are : 1
 
VTEP1#
VTEP1#show nvo vxlan mac-table vnid 3
============================================================================================================================
VXLAN MAC Entries
============================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc LeafFlag
____________________________________________________________________________________________________________________________
 
3 ---- ---- ---- 0000.0000.aaaa 11.11.11.1 Static Remote ------- 0 ------- ----
 
Total number of entries are : 1
 
VTEP1#
VTEP2
Verify the OSPF neighbors towards SPINEs.
VTEP2#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
12.12.12.1 1 Full/DR 00:00:35 3.3.3.1 ce12 0
13.13.13.1 1 Full/Backup 00:00:31 5.5.5.1 ce11 0
VTEP2#
 
Verify the static tunnel configured on VTEP2:
VTEP2#show nvo vxlan tunnel
VXLAN Network tunnel Entries
Source Destination Status Up/Down Update
========================================================================
11.11.11.1 10.10.10.1 Installed 00:11:32 00:10:28
 
Total number of entries are 1
VTEP2#
Verify the VNID Mapping:
VTEP2#show nvo vxlan
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
3 ---- L2 NW ---- ---- ---- ---- 11.11.11.1 10.10.10.1
3 ---- -- AC xe34 --- Single Homed Port --- 0 ---- ---- ----
 
Total number of entries are 2
VTEP2#
 
Verify the local and remote MAC address configured:
VTEP2#
VTEP2#show nvo vxlan mac-table
============================================================================================================================
VXLAN MAC Entries
============================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc LeafFlag
____________________________________________________________________________________________________________________________
 
3 ---- ---- ---- 0000.0000.bbbb 10.10.10.1 Static Remote ------- 0 ------- ----
 
Total number of entries are : 1
 
VTEP2#
VTEP2#show nvo vxlan mac-table vnid 3
============================================================================================================================
VXLAN MAC Entries
============================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc LeafFlag
____________________________________________________________________________________________________________________________
 
3 ---- ---- ---- 0000.0000.bbbb 10.10.10.1 Static Remote ------- 0 ------- ----
 
Total number of entries are : 1
 
VTEP2#
VTEP2#show nvo vxlan tunnel
VXLAN Network tunnel Entries
Source Destination Status Up/Down Update
========================================================================
11.11.11.1 10.10.10.1 Installed 00:11:32 00:10:28
 
Total number of entries are 1
VTEP2#
VTEP2#show nvo vxlan
VXLAN Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VNID VNI-Name VNI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
____________________________________________________________________________________________________________________________
3 ---- L2 NW ---- ---- ---- ---- 11.11.11.1 10.10.10.1
3 ---- -- AC xe34 --- Single Homed Port --- 0 ---- ---- ----
 
Total number of entries are 2
VTEP2#
VTEP2#
VTEP2#show nvo vxlan mac-table
============================================================================================================================
VXLAN MAC Entries
============================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc LeafFlag
____________________________________________________________________________________________________________________________
 
3 ---- ---- ---- 0000.0000.bbbb 10.10.10.1 Static Remote ------- 0 ------- ----
 
Total number of entries are : 1
 
VTEP2#
VTEP2#show nvo vxlan mac-table vnid 3
============================================================================================================================
VXLAN MAC Entries
============================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc LeafFlag
____________________________________________________________________________________________________________________________
 
3 ---- ---- ---- 0000.0000.bbbb 10.10.10.1 Static Remote ------- 0 ------- ----
 
Total number of entries are : 1