Traffic class | Queue |
---|---|
0 | 0 |
1, 2, 3 | 1 |
4, 5 | 2 |
6, 7 | 3 |
RTR1#configure terminal | Enter into configuration mode |
RTR1(config)#service-template VPLS-30 | Create L2VPN VPLS service template of VPLS-30 |
RTR1(config-svc)# match double-tag outer-vlan 30 inner-vlan 2030 | Match for double tagged VLAN with inner VLAN 30 and outer VLAN 2030 |
RTR1(config-svc)#rewrite ingress pop outgoing-tpid dot1.q | Rewrite ingress pop outgoing as dot1q |
RTR1(config-svc)#exit | Exit |
RTR1(config)#service-template VPLS-40 | Create L2VPN VPLS service template of VPLS-40 |
RTR1(config-svc)#match double-tag outer-vlan 40 inner-vlan 2040 | Match for double tagged VLAN with inner VLAN 40 and outer VLAN 2040 |
RTR1(config-svc)#rewrite ingress pop outgoing-tpid dot1.q | Rewrite ingress pop outgoing as dot1q |
RTR1(config-svc)#exit | Exit |
RTR1(config)#mpls vpls V30 30 | Create MPLS VPLS with V30 and 30 |
RTR1(config-vpls)#service-tpid dot1.ad | Make service tpid as dot1.ad |
RTR1(config-vpls)#signaling ldp | Configure signaling as ldp |
RTR1(config-vpls-sig)#vpls-type vlan | Configure vpls type as vlan |
RTR1(config-vpls-sig)#vpls-peer 6.6.6.6 | Configure peer as 6.6.6.6 |
RTR1(config-vpls-sig)#exit-signaling | Exit |
RTR1(config-vpls)#exit | Exit |
RTR1(config)#mpls vpls V40 40 | Create MPLS VPLS with V40 and 40 |
RTR1(config-vpls)#service-tpid dot1.ad | Make service tpid as dot1.ad |
RTR1(config-vpls)#signaling ldp | Configure signaling as LDP |
RTR1(config-vpls-sig)#vpls-type vlan | Configure VPLS type as VLAN |
RTR1(config-vpls-sig)#vpls-peer 6.6.6.6 | Configure peer as 6.6.6.6 |
RTR1(config-vpls-sig)#exit-signaling | Exit |
RTR1(config-vpls)#exit | Exit |
RTR1(config)#interface xe14 | Enter interface configuration |
RTR1(config-if)#switchport | Change port as switchport |
RTR1(config-if)#load-interval 30 | Configure load interval as 30 |
RTR1(config-if)#mpls-vpls V30 service-template VPLS-30 | Bind MPLS VPLS V30 with service template VPLS-30 |
RTR1(config_if_vpls)#exit-if-vpls | Exit |
RTR1(config-if)#mpls-vpls V40 service-template VPLS-40 | Bind MPLS VPLS V40 with service template VPLS-40 |
RTR1(config_if_vpls)#exit-if-vpls | Exit |
RTR1(config)#router bgp 64512 | Configure BGP of as number 64512 |
RTR1(config-router)#address-family l2vpn vpls | Enter into l2vpn VPLS address family |
RTR1(config-router-af)#neighbor 6.6.6.6 activate | Activate neighbor 6.6.6.6 |
RTR1(config-router-af)#exit-address-family | Exit |
RTR1(config-router)#exit | Exit |
RTR6#configure terminal | Enter into configuration mode |
RTR6(config)#service-template VPLS-30 | Create L2VPN VPLS service template of VPLS-30 |
RTR6(config-svc)#match double-tag outer-vlan 30 inner-vlan 2030 | Match for double tagged VLAN with inner VLAN 30 and outer VLAN 2030 |
RTR6(config-svc)#rewrite ingress pop outgoing-tpid dot1.q | Rewrite ingress pop outgoing as dot1q |
RTR6(config-svc)#exit | Exit |
RTR6(config)#service-template VPLS-40 | Create L2VPN VPLS service template of VPLS-40 |
RTR6(config-svc)#match double-tag outer-vlan 40 inner-vlan 2040 | Match for double tagged VLAN with inner VLAN 40 and outer VLAN 2040 |
RTR6(config-svc)#rewrite ingress pop outgoing-tpid dot1.q | Rewrite ingress pop outgoing as dot1q |
RTR6(config-svc)#exit | Exit |
RTR6(config)#mpls vpls V30 30 | Create MPLS VPLS with V30 and 30 |
RTR6(config-vpls)#service-tpid dot1.ad | Make service tpid as dot1.ad |
RTR6(config-vpls)#signaling ldp | Configure signaling as LDP |
RTR6(config-vpls-sig)#vpls-type vlan | Configure VPLS type as VLAN |
RTR6(config-vpls-sig)#vpls-peer 1.1.1.1 | Configure peer as 1.1.1.1 |
RTR6(config-vpls-sig)#exit-signaling | Exit |
RTR6(config-vpls)#exit | Exit |
RTR6(config)#mpls vpls V40 40 | Create MPLS VPLS with V40 and 40 |
RTR6(config-vpls)#service-tpid dot1.ad | Make service tpid as dot1.ad |
RTR6(config-vpls)#signaling ldp | Configure signaling as LDP |
RTR6(config-vpls-sig)#vpls-type vlan | Configure VPLS type as VLAN |
RTR6(config-vpls-sig)#vpls-peer 1.1.1.1 | Configure peer as 1.1.1.1 |
RTR6(config-vpls-sig)#exit-signaling | Exit |
RTR6(config-vpls)#exit | Exit |
RTR6(config)#interface xe13 | Enter interface configuration |
RTR6(config-if)#switchport | Change port as switchport |
RTR6(config-if)#load-interval 30 | Configure load interval as 30 |
RTR6(config-if)#mpls-vpls V30 service-template VPLS-30 | Bind MPLS VPLS V30 with service template VPLS-30 |
RTR6(config_if_vpls)#exit-if-vpls | Exit |
RTR6(config-if)#mpls-vpls V40 service-template VPLS-40 | Bind MPLS VPLS V40 with service template VPLS-40 |
RTR6(config_if_vpls)#exit-if-vpls | Exit |
RTR6(config)#router bgp 64512 | Configure BGP of as number 64512 |
RTR6(config-router)#address-family l2vpn vpls | Enter into l2vpn VPLS address family |
RTR6(config-router-af)#neighbor 1.1.1.1 activate | Activate neighbor 1.1.1.1 |
RTR6(config-router-af)#exit-address-family | Exit |
RTR6(config-router)#exit | Exit |
RTR6(config)#qos enable | Enable QoS |
RTR6(config)#class-map type queuing que0 | Create class map of type queuing with name que0 |
RTR6(config-cmap-que)# match queue 0 | Match for queue 0 |
RTR6(config-cmap-que)#class-map type queuing que1 | Create class map of type queuing with name que1 |
RTR6(config-cmap-que)#match queue 1 | Match for queue 1 |
RTR6(config-cmap-que)#class-map type queuing que2 | Create class map of type queuing with name que2 |
RTR6(config-cmap-que)#match queue 2 | Match for queue 2 |
RTR6(config-cmap-que)#class-map type queuing que3 | Create class map of type queuing with name que3 |
RTR6(config-cmap-que)#match queue 3 | Match for queue 3 |
RTR6(config-cmap-que)#class-map type queuing service30 | Create class map of type queuing with name VPLS-30 |
RTR6(config-cmap-que)#match service-template VPLS-30 | Match for service template VPLS-30 |
RTR6(config-cmap-que)#class-map type queuing service40 | Create class map of type queuing with name VPLS-40 |
RTR6(config-cmap-que)#match service-template VPLS-40 | Match for service template VPLS-40 |
RTR6(config-cmap-que)#policy-map type queuing queue | Create policy map with name queue |
RTR6(config-pmap-que)#class type queuing que0 | Add class map que0 to above policy map |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing que1 | Add class map que1 to above policy map |
RTR6(config-pmap-que)#shape 100 mbps | Shape traffic to 100 mbps |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing que2 | Add class map que2 to above policy map |
RTR6(config-pmap-que)#shape 100 mbps | Shape traffic to 100 mbps |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing que3 | Add class map que3 to above policy map |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#policy-map type queuing service | Create policy map with name service |
RTR6(config-pmap-que)#class type queuing service30 | Add class map service30 to above policy map |
RTR6(config-pmap-que)#shape 1000 mbps | Shape rate to 1000 mbps |
RTR6(config-pmap-c-que)#service-policy queue | Add policy map queue as service-policy |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing service40 | Add class map service40 to above policymap |
RTR6(config-pmap-c-que)#service-policy queue | Add policy map queue as service-policy |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#interface xe13 | Configure interface xe13 |
RTR6(config-if)#service-policy type queuing output service | Attach the policy map service to the interface |
RTR6(config-if)#shape rate 3000 mbps | Shape rate traffic to 3000 mbps |
RTR6(config-if)#exit | Exit |
RTR1#configure terminal | Enter into configuration mode |
RTR1(config)#mpls l2-circuit VPWS10 10 6.6.6.6 | Create MPLS l2 circuit with VPWS10 with ID 10 and end point 6.6.6.6 |
(config-pseudowire)#exit | Exit pseudowire config mode. |
RTR1(config)#mpls l2-circuit VPWS20 20 6.6.6.6 | Create MPLS l2 circuit with VPWS20 with ID 20 and end point 6.6.6.6 |
(config-pseudowire)#exit | Exit pseudowire config mode. |
RTR1(config)#service-template VPWS-10 | Create service template VPWS-10 |
RTR1(config-svc)#match outer-vlan 10 | Match outer vlan 10 |
RTR1(config-svc)#rewrite ingress translate 1000 outgoing-tpid dot1.q | Rewrite ingress translate 1010 with outgoing tpid as dot1q |
RTR1(config-svc)#exit | Exit |
RTR1(config)# | |
RTR1(config-svc)#service-template VPWS-20 | Create service template VPWS-20 |
RTR1(config-svc)# match outer-vlan 20 | Match outer vlan 20 |
RTR1(config-svc)# rewrite ingress translate 1020 outgoing-tpid dot1.q | Rewrite ingress translate 1020 with outgoing tpid as dot1q |
RTR1(config-svc)#exit | Exit |
RTR1(config)#interface xe14 | Configure interface xe14 |
RTR1(config-if)#switchport | Configure as layer 2 port |
RTR1(config-if)#load-interval 30 | Configure load interval as 30 |
RTR1(config-if)#mpls-l2-circuit VPWS10 service-template VPWS-10 | Attach l2circuit VPWS10 with service template VPWS-10 |
RTR1(config-if)#mpls-l2-circuit VPWS20 service-template VPWS-20 | Attach l2circuit VPWS20 with service template VPWS-20 |
RTR1(config-if)#exit | exit |
RTR6#configure terminal | Enter into configuration mode |
RTR6(config)#mpls l2-circuit VPWS10 10 1.1.1.1 | Create MPLS l2 circuit with VPWS10 with ID 10 and end point 1.1.1.1 |
(config-pseudowire)#exit | Exit pseudowire config mode. |
RTR6(config)#mpls l2-circuit VPWS20 20 1.1.1.1 | Create MPLS l2 circuit with VPWS20 with ID 20 and end point 1.1.1.1 |
(config-pseudowire)#exit | Exit pseudowire config mode. |
RTR6(config)#service-template VPWS-10 | Create service template VPWS-10 |
RTR6(config-svc)# match outer-vlan 10 | Match outer vlan 10 |
RTR6(config-svc)# rewrite ingress translate 1000 outgoing-tpid dot1.q | Rewrite ingress translate 1010 with outgoing tpid as dot1q |
RTR6(config-svc)#exit | Exit |
RTR6(config-svc)#service-template VPWS-20 | Create service template VPWS-20 |
RTR6(config-svc)#match outer-vlan 20 | Match outer VLAN 20 |
RTR6(config-svc)#rewrite ingress translate 1020 outgoing-tpid dot1.q | Rewrite ingress translate 1020 with outgoing tpid as dot1q |
RTR6(config-svc)#exit | Exit |
RTR6(config)#interface xe14 | Configure interface xe14 |
RTR6(config-if)#switchport | Configure as layer 2 port |
RTR6(config-if)#load-interval 30 | Configure load interval as 30 |
RTR6(config-if)#mpls-l2-circuit VPWS10 service-template VPWS-10 | Attach l2circuit VPWS10 with service template VPWS-10 |
RTR6(config-if)#mpls-l2-circuit VPWS20 service-template VPWS-20 | Attach l2circuit VPWS20 with service template VPWS-20 |
RTR6(config-if)#exit | exit |
RTR6(config)#qos enable | Enable Qos |
RTR6(config)#class-map type queuing que0 | Create class map of type queuing with name que0 |
RTR6(config-cmap-que)# match queue 0 | Match for queue 0 |
RTR6(config-cmap-que)#class-map type queuing que1 | Create class map of type queuing with name que1 |
RTR6(config-cmap-que)#match queue 1 | Match for queue 1 |
RTR6(config-cmap-que)#class-map type queuing que2 | Create class map of type queuing with name que2 |
RTR6(config-cmap-que)#match queue 2 | Match for queue 2 |
RTR6(config-cmap-que)#class-map type queuing que3 | Create class map of type queuing with name que3 |
RTR6(config-cmap-que)#match queue 3 | Match for queue 3 |
RTR6(config-cmap-que)#class-map type queuing service10 | Create class map of type queuing with name VPWS-10 |
RTR6(config-cmap-que)#match service-template VPWS-10 | Match for service template VPWS-10 |
RTR6(config-cmap-que)#class-map type queuing service20 | Create class map of type queuing with name VPWS-20 |
RTR6(config-cmap-que)#match service-template VPWS-20 | Match for service template VPWS-20 |
RTR6(config-cmap-que)#policy-map type queuing queue | Create policy map with name queue |
RTR6(config-pmap-que)#class type queuing que0 | Add class map que0 to above policy map |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing que1 | Add class map que1 to above policy map |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing que2 | Add class map que2 to above policy map |
RTR6(config-pmap-que)#priority level 0 | configure Priority level 0 |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing que3 | Add class map que3 to above policy map |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#policy-map type queuing service | Create policy map with name service |
RTR6(config-pmap-que)#class type queuing service10 | Add class map service10 to above policy map |
RTR6(config-pmap-que)#priority level 0 | Change priority level 0 |
RTR6(config-pmap-c-que)#service-policy queue | Add policy map queue as service-policy |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing service20 | Add class map service20 to above policy map |
RTR6(config-pmap-c-que)#service-policy queue | Add policy map queue as service-policy |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#interface xe13 | Configure interface xe13 |
RTR6(config-if)#service-policy type queuing output service | Attach the policy map service to the interface |
RTR6(config-if)#shape rate 1000 mbps | Shape rate traffic to 1000 mbps |
RTR6(config-if)#exit | Exit |
RTR1(config)#ip vrf 3 | Create new vrf with name 3 |
RTR1(config-vrf)#rd 2:3 | Create route distinguisher for vrf 3 |
RTR1(config-vrf)#route-target both 1:3 | Create route target for vrf 3 |
RTR1(config-vrf)#ip vrf 4 | Create new vrf with name 4 |
RTR1(config-vrf)#rd 2:4 | Create route distinguisher for vrf 4 |
RTR1(config-vrf)#route-target both 1:4 | Create route target for vrf 4 |
RTR1(config-vrf)#ip vrf 5 | Create new vrf with name 5 |
RTR1(config-vrf)#rd 2:5 | Create route distinguisher for vrf 5 |
RTR1(config-vrf)#route-target both 1:5 | Create route target for vrf 5 |
RTR1(config-vrf)#ip vrf 6 | Create new vrf with name 6 |
RTR1(config-vrf)#rd 2:6 | Create route distinguisher for vrf 6 |
RTR1(config-vrf)#route-target both 1:6 | Create route target for vrf 6 |
RTR1(config-vrf)#exit | Exit |
RTR1(config)#interface lo.3 | Configure loopback lo.3 |
RTR1(config-if)#ip vrf forwarding 3 | Attach VRF 3 to loopback lo.3 interface |
RTR1(config-if)#interface lo.4 | Configure loopback lo.4 |
RTR1(config-if)#ip vrf forwarding 4 | Attach VRF 4 to loopback lo.4 interface |
RTR1(config-if)#interface lo.5 | Configure loopback lo.5 |
RTR1(config-if)#ip vrf forwarding 5 | Attach VRF 5 to loopback lo.5 interface |
RTR1(config-if)#interface lo.6 | Configure loopback lo.6 |
RTR1(config-if)#ip vrf forwarding 6 | Attach vrf 6 to loopback lo.6 interface |
RTR1(config-if)#exit | Exit |
RTR1(config)#interface ce52.203 | Create sub interface for ce52 port |
RTR1(config-if)#ip vrf forwarding 3 | Attach vrf 3 to sub int ce52.203 |
RTR1(config-if)#ip address 201.203.1.1/24 | Assign ip address 201.203.1.1/24 |
RTR1(config-if)#encapsulation dot1q 203 | Encapsulate dot1q VLAN with id 203 |
RTR1(config-if)#interface ce52.204 | Create sub interface for ce52 port |
RTR1(config-if)#ip vrf forwarding 4 | Attach vrf 4 to sub int ce52.204 |
RTR1(config-if)#ip address 201.204.1.1/24 | Assign ip address 201.204.1.1/24 |
RTR1(config-if)#encapsulation dot1q 204 | Encapsulate dot1q VLAN with id 204 |
RTR1(config-if)#interface vlan1.205 | Create VLAN interface with id 205 |
RTR1(config-if)#ip vrf forwarding 5 | Attach VRF 5 to vlan1.205 |
RTR1(config-if)#ip address 201.205.1.1/24 | Assign IP address of 201.205.1.1/24 |
RTR1(config-if)#mtu 9216 | Configure MTU of size 9216 |
RTR1(config-if)#interface vlan1.206 | Create VLAN interface with id 206 |
RTR1(config-if)#ip vrf forwarding 6 | Attach VRF 6 to vlan1.206 |
RTR1(config-if)#ip address 201.206.1.1/24 | Assign ip address of 201.206.1.1/24 |
RTR1(config-if)#mtu 9216 | Configure MTU of size 9216 |
RTR1(config)#router bgp 64512 | Configure router BGP 66512 |
RTR1(config-router)#address-family vpnv4 unicast | Enter into vpnv4 unicast address family |
RTR1(config-router-af)#neighbor 6.6.6.6 activate | Activate neighbor on vpnv4 unicast |
RTR1(config-router-af)#exit-address-family | Exit |
RTR1(config-router)#address-family ipv4 vrf 3 | Enter into ipv4 vrf3 address family |
RTR1(config-router-af)#redistribute connected | Redistribute connected networks into vrf 3 |
RTR1(config-router-af)#exit-address-family | Exit |
RTR1(config-router)#address-family ipv4 vrf 4 | Enter into ipv4 vrf4 address family |
RTR1(config-router-af)#redistribute connected | Redistribute connected networks into vrf 4 |
RTR1(config-router-af)#exit-address-family | Exit |
RTR1(config-router)#address-family ipv4 vrf 5 | Enter into ipv4 vrf5 address family |
RTR1(config-router-af)#redistribute connected | Redistribute connected networks into vrf 5 |
RTR1(config-router-af)#exit-address-family | Exit |
RTR1(config-router)#address-family ipv4 vrf 6 | Enter into ipv4 vrf6 address family |
RTR1(config-router-af)#redistribute connected | Redistribute connected networks into vrf 6 |
RTR1(config-router-af)#exit-address-family | Exit |
RTR1(config-router)#exit | Exit |
RTR1(config)#interface ce52 | Configure interface ce52 |
RTR1(config-if)#load-interval 30 | Configure load interval 30 |
RTR1(config-if)#interface ce50 | Configure interface ce50 |
RTR1(config-if)#switchport | Configure port as layer 2 port |
RTR1(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR1(config-if)#switchport mode trunk | Configure interface as trunk port |
RTR1(config-if)#switchport trunk allowed vlan add 205, 206 | Allow only VLANs 205 and 206 |
RTR1(config-if)#load-interval 30 | Configure load interval 30 |
RTR6(config)#ip vrf 3 | Create new vrf with name 3 |
RTR6(config-vrf)#rd 1:3 | Create route distinguisher for VRF 3 |
RTR6(config-vrf)#route-target both 1:3 | Create route target for VRF 3 |
RTR6(config-vrf)#ip vrf 4 | Create new VRF with name 4 |
RTR6(config-vrf)#rd 1:4 | Create route distinguisher for VRF 4 |
RTR6(config-vrf)#route-target both 1:4 | Create route target for VRF 4 |
RTR6(config-vrf)#ip vrf 5 | Create new VRF with name 5 |
RTR6(config-vrf)#rd 1:5 | Create route distinguisher for VRF 5 |
RTR6(config-vrf)#route-target both 1:5 | Create route target for VRF 5 |
RTR6(config-vrf)#ip vrf 6 | Create new VRF with name 6 |
RTR6(config-vrf)#rd 1:6 | Create route distinguisher for VRF 6 |
RTR6(config-vrf)#route-target both 1:6 | Create route target for VRF 6 |
RTR6(config-vrf)#exit | Exit |
RTR6(config)#interface lo.3 | Configure loopback lo.3 |
RTR6(config-if)#ip vrf forwarding 3 | Attach vrf 3 to loopback lo.3 interface |
RTR6(config-if)#interface lo.4 | Configure loopback lo.4 |
RTR6(config-if)#ip vrf forwarding 4 | Attach vrf 4 to loopback lo.4 interface |
RTR6(config-if)#interface lo.5 | Configure loopback lo.5 |
RTR6(config-if)#ip vrf forwarding 5 | Attach vrf 5 to loopback lo.5 interface |
RTR6(config-if)#interface lo.6 | Configure loopback lo.6 |
RTR6(config-if)#ip vrf forwarding 6 | Attach VRF 6 to loopback lo.6 interface |
RTR6(config-if)#interface xe13.103 | Create sub interface for xe13 port |
RTR6(config-if)#ip vrf forwarding 3 | Attach VRF 3 to sub int xe13.103 |
RTR6(config-if)#ip address 101.103.1.1/24 | Assign ip address 101.103.1.1/24 |
RTR6(config-if)#encapsulation dot1q 103 | Encapsulate dot1q VLAN with id 103 |
RTR6(config-if)#interface xe13.104 | Create sub interface for xe13.104 port |
RTR6(config-if)#ip vrf forwarding 4 | Attach VRF 4 to sub int xe13.104 |
RTR6(config-if)#ip address 101.104.1.1/24 | Assign IP address 101.104.1.1/24 |
RTR6(config-if)#encapsulation dot1q 104 | Encapsulate dot1q VLAN with id 104 |
RTR6(config-if)#interface vlan1.105 | Create VLAN interface with id 105 |
RTR6(config-if)#ip vrf forwarding 5 | Attach VRF 5 to vlan1.105 |
RTR6(config-if)#ip address 101.105.1.1/24 | Assign ip address of 101.105.1.1/24 |
RTR6(config-if)#mtu 9216 | Configure MTU of size 9216 |
RTR6(config-if)#interface vlan1.106 | Create VLAN interface with id 106 |
RTR6(config-if)#ip vrf forwarding 6 | Attach VRF 6 to vlan1.106 |
RTR6(config-if)#ip address 101.106.1.1/24 | Assign IP address of 101.106.1.1/24 |
RTR6(config-if)#mtu 9216 | Configure mtu of size 9216 |
RTR6(config-if)#exit | Exit |
RTR6(config)#router bgp 64512 | Configure BGP 64512 |
RTR6(config-router)#address-family vpnv4 unicast | Enter into vpnv4 unicast address family |
RTR6(config-router-af)#neighbor 1.1.1.1 activate | Activate neighbor on vpnv4 unicast |
RTR6(config-router-af)#exit-address-family | Exit |
RTR6(config-router)#address-family ipv4 vrf 3 | Enter into ipv4 vrf3 address family |
RTR6(config-router-af)#redistribute connected | Redistribute connected networks into VRF 3 |
RTR6(config-router-af)#exit-address-family | Exit |
RTR6(config-router)#address-family ipv4 vrf 4 | Enter into ipv4 vrf4 address family |
RTR6(config-router-af)#redistribute connected | Redistribute connected networks into vrf 4 |
RTR6(config-router-af)#exit-address-family | Exit |
RTR6(config-router)#address-family ipv4 vrf 5 | Enter into ipv4 vrf5 address family |
RTR6(config-router-af)#redistribute connected | Redistribute connected networks into vrf 5 |
RTR6(config-router-af)#exit-address-family | Exit |
RTR6(config-router)#address-family ipv4 vrf 6 | Enter into ipv4 vrf6 address family |
RTR6(config-router-af)#redistribute connected | Redistribute connected networks into vrf 6 |
RTR6(config-router-af)#exit-address-family | Exit |
RTR6(config-router)#exit | Exit |
RTR6(config)#interface xe13 | Configure interface xe13 |
RTR6(config-if)#load-interval 30 | Configure load interval 30 |
RTR6(config-if)#interface xe14 | Configure interface xe14 |
RTR6(config-if)#switchport | Configure port as layer 2 port |
RTR6(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR6(config-if)#switchport mode trunk | Configure interface as trunk port |
RTR6(config-if)#switchport trunk allowed vlan add 105,106 | Allow only vlans105 and 106 |
RTR6(config-if)#load-interval 30 | Configure load interval 30 |
RTR6(config-if)#exit | Exit |
RTR1#configure terminal | Enter into configure terminal mode |
RTR1(config)#bridge 1 protocol provider-rstp edge | Configure bridge 1 protocol as provider RSTP edge |
RTR1(config)#vlan database | Configure VLAN database |
RTR1(config-vlan)#vlan 201-300 type customer bridge 1 state enable | Configure customer VLANs from 201-300 |
RTR1(config-vlan)#vlan 301-400 type service point-point bridge 1 state enable | Configure service VLANs from 301-400 |
RTR1(config-vlan)#cvlan registration table map1 bridge 1 | Create cvlan registration table |
RTR1(config-cvlan-registration)#cvlan 201 svlan 301 | Map 201 cvlan to 301 svlan |
RTR1(config-cvlan-registration)#cvlan 202 svlan 302 | Map 202 cvlan to 302 svlan |
RTR1(config-cvlan-registration)#cvlan 203 svlan 303 | Map 203 cvlan to 303 svlan |
RTR1(config-cvlan-registration)#cvlan 204 svlan 304 | Map 204 cvlan to 304 svlan |
RTR1(config-cvlan-registration)#cvlan 205 svlan 305 | Map 205 cvlan to 305 svlan |
RTR1(config-cvlan-registration)#interface po12 | Configure interface po12 |
RTR1(config-if)#switchport | Configure as layer 2 port |
RTR1(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR1(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR1(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed VLAN from 301-400 |
RTR1(config-if)#load-interval 30 | Configure load interval 30 |
RTR1(config-if)#interface po13 | Configure interface po13 |
RTR1(config-if)#switchport | Configure as layer 2 port |
RTR1(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR1(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR1(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR1(config-if)#load-interval 30 | Configure load interval 30 |
RTR1(config-if)#interface xe1 | Configure xe1 |
RTR1(config-if)#channel-group 12 mode active | Add xe1 to po12 |
RTR1(config-if)#interface xe2 | Configure xe2 |
RTR1(config-if)#channel-group 12 mode active | Add xe2 to po12 |
RTR1(config-if)#interface xe3 | Configure xe3 |
RTR1(config-if)#channel-group 13 mode active | Add xe3 to po13 |
RTR1(config-if)#interface xe4 | Configure xe4 |
RTR1(config-if)#channel-group 13 mode active | Add xe4 to po13 |
RTR1(config-if)#interface xe15 | Configure interface xe15 |
RTR1(config-if)#switchport | Configure as layer 2 port |
RTR1(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR1(config-if)#switchport mode customer-edge trunk | Configure switchport mode as customer edge trunk |
RTR1(config-if)#switchport customer-edge trunk allowed vlan add 201-300 | Configure allowed vlan from 201-300 |
RTR1(config-if)#switchport customer-edge vlan registration map1 | Attach VLAN registration table map 1 to xe15 |
RTR1(config-if)#load-interval 30 | Configure load interval 30 |
RTR1(config-if)#exit | Exit |
RTR2#configure terminal | Configure terminal |
RTR2(config)#bridge 1 protocol provider-rstp | Configure bridge 1 protocol as provider rstp edge |
RTR2(config)#vlan database | VLAN database |
RTR2(config-vlan)#vlan 301-400 type service point-point bridge 1 state enable | Configure service vlans from 301-400 |
RTR2(config-vlan)#interface po12 | Configure interface po12 |
RTR2(config-if)#switchport | Configure as layer 2 port |
RTR2(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR2(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR2(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR2(config-if)#load-interval 30 | Configure load interval 30 |
RTR2(config-if)#interface po24 | Configure interface po24 |
RTR2(config-if)#switchport | Configure as layer 2 port |
RTR2(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR2(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR2(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR2(config-if)#load-interval 30 | Configure load interval 30 |
RTR2(config-if)#interface po25 | Configure interface po25 |
RTR2(config-if)#switchport | Configure as layer 2 port |
RTR2(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR2(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR2(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR2(config-if)#load-interval 30 | Configure load interval 30 |
RTR2(config-if)#interface xe1 | Configure xe1 |
RTR2(config-if)#channel-group 12 mode active | Add xe1 to po12 |
RTR2(config-if)#interface xe2 | Configure xe2 |
RTR2(config-if)#channel-group 12 mode active | Add xe2 to po12 |
RTR2(config-if)#interface xe8 | Configure xe8 |
RTR2(config-if)#channel-group 25 mode active | Add xe8 to po25 |
RTR2(config-if)#interface xe9 | Configure xe9 |
RTR2(config-if)#channel-group 25 mode active | Add xe9 to po25 |
RTR2(config-if)#interface xe14 | Configure xe14 |
RTR2(config-if)#channel-group 24 mode active | Add xe14 to po24 |
RTR2(config-if)#interface xe15 | Configure xe15 |
RTR2(config-if)#channel-group 24 mode active | Add xe15 to po24 |
RTR2(config)#exit | Exit |
RTR3#config term | Configure terminal |
RTR3(config)#bridge 1 protocol provider-rstp | Configure bridge 1 protocol as provider rstp edge |
RTR3(config)#vlan database | Configure VLAN database |
RTR3(config-vlan)#vlan 301-400 type service point-point bridge 1 state enable | Configure service VLANS from 301-400 |
RTR3(config-vlan)#interface po13 | Configure interface po13 |
RTR3(config-if)# switchport | Configure as layer 2 port |
RTR3(config-if)# bridge-group 1 | Configure interface in bridge group 1 |
RTR3(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR3(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR3(config-if)#load-interval 30 | Configure load interval 30 |
RTR3(config-if)#interface po34 | Configure interface po34 |
RTR3(config-if)#switchport | Configure as layer 2 port |
RTR3(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR3(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR3(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR3(config-if)#load-interval 30 | Configure load interval 30 |
RTR3(config-if)#interface po35 | Configure interface po35 |
RTR3(config-if)#switchport | Configure as layer 2 port |
RTR3(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR3(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR3(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR3(config-if)#load-interval 30 | Configure load interval 30 |
RTR3(config-if)#interface xe3 | Configure xe3 |
RTR3(config-if)#channel-group 13 mode active | Add xe3 to po13 |
RTR3(config-if)#interface xe4 | Configure xe4 |
RTR3(config-if)# channel-group 13 mode active | Add xe4 to po13 |
RTR3(config-if)#interface xe7 | Configure xe7 |
RTR3(config-if)#channel-group 34 mode active | Add xe7 to po34 |
RTR3(config-if)#interface xe8 | Configure xe8 |
RTR3(config-if)#channel-group 34 mode active | Add xe8 to po34 |
RTR3(config-if)#interface xe14 | Configure xe14 |
RTR3(config-if)#channel-group 35 mode active | Add xe14 to po35 |
RTR3(config-if)#interface xe15 | Configure xe15 |
RTR3(config-if)#channel-group 35 mode active | Add xe15 to po35 |
RTR3(config-if)#exit | Exit |
RTR4#config term | Configure terminal |
RTR4(config)#bridge 1 protocol provider-rstp | Configure bridge 1 protocol as provider rstp edge |
RTR4(config)#vlan database | Configure vlan database |
RTR4(config-vlan)#vlan 301-400 type service point-point bridge 1 state enable | Configure service vlans from 301-400 |
RTR4(config-vlan)#interface po24 | Configure interface po24 |
RTR4(config-if)#switchport | Configure as layer 2 port |
RTR4(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR4(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR4(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed VLAN from 301-400 |
RTR4(config-if)#load-interval 30 | Configure load interval 30 |
RTR4(config-if)#interface po34 | Configure interface po34 |
RTR4(config-if)#switchport | Configure as layer 2 port |
RTR4(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR4(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR4(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR4(config-if)#load-interval 30 | Configure load interval 30 |
RTR4(config-if)#interface po46 | Configure interface po46 |
RTR4(config-if)#switchport | Configure as layer 2 port |
RTR4(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR4(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR4(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR4(config-if)#load-interval 30 | Configure load interval 30 |
RTR4(config-if)#interface xe0 | Configure xe0 |
RTR4(config-if)#channel-group 46 mode active | Add xe0 to po46 |
RTR4(config-if)#interface xe1 | Configure xe1 |
RTR4(config-if)#channel-group 46 mode active | Add xe1 to po46 |
RTR4(config-if)#interface xe2 | Configure xe2 |
RTR4(config-if)#channel-group 46 mode active | Add xe2 to po46 |
RTR4(config-if)#interface xe3 | Configure xe3 |
RTR4(config-if)#channel-group 46 mode active | Add xe3 to po46 |
RTR4(config-if)#interface xe7 | Configure xe7 |
RTR4(config-if)#channel-group 34 mode active | Add xe7 to po34 |
RTR4(config-if)#interface xe8 | Configure xe8 |
RTR4(config-if)#channel-group 34 mode active | Add xe8 to po34 |
RTR4(config-if)#interface xe14 | Configure xe14 |
RTR4(config-if)#channel-group 24 mode active | Add xe14 to po24 |
RTR4(config-if)#interface xe15 | Configure xe15 |
RTR4(config-if)#channel-group 24 mode active | Add xe15 to po24 |
RTR4(config-if)#end | End |
RTR5#config term | Configure terminal |
RTR5(config)#bridge 1 protocol provider-rstp | Configure bridge 1 protocol as provider rstp edge |
RTR5(config)#vlan database | Configure vlan database |
RTR5(config-vlan)#vlan 301-305 type service point-point bridge 1 state enable | Configure service vlans from 301-305 |
RTR5(config-vlan)#interface po25 | Configure interface po25 |
RTR5(config-if)#switchport | Configure as layer 2 port |
RTR5(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR5(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR5(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR5(config-if)#load-interval 30 | Configure load interval 30 |
RTR5(config-if)#interface po35 | Configure interface po35 |
RTR5(config-if)#switchport | Configure as layer 2 port |
RTR5(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR5(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR5(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR5(config-if)#load-interval 30 | Configure load interval 30 |
RTR5(config-if)#interface po56 | Configure interface po56 |
RTR5(config-if)#switchport | Configure as layer 2 port |
RTR5(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR5(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR5(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR5(config-if)#load-interval 30 | Configure load interval 30 |
RTR5(config-if)#interface xe2 | Configure xe2 |
RTR5(config-if)#channel-group 25 mode active | Add xe2 to po25 |
RTR5(config-if)#interface xe3 | Configure xe3 |
RTR5(config-if)#channel-group 25 mode active | Add xe3 to po25 |
RTR5(config-if)#interface xe6 | Configure xe6 |
RTR5(config-if)#channel-group 56 mode active | Add xe6 to po56 |
RTR5(config-if)#interface xe7 | Configure xe7 |
RTR5(config-if)#channel-group 56 mode active | Add xe7 to po56 |
RTR5(config-if)#interface xe8 | Configure xe8 |
RTR5(config-if)#channel-group 56 mode active | Add xe8 to po56 |
RTR5(config-if)#interface xe9 | Configure xe9 |
RTR5(config-if)#channel-group 56 mode active | Add xe9 to po56 |
RTR5(config-if)#interface xe14 | Configure xe14 |
RTR5(config-if)#channel-group 35 mode active | Add xe14 to po35 |
RTR5(config-if)#interface xe15 | Configure xe15 |
RTR5(config-if)#channel-group 35 mode active | Add xe15 to po35 |
RTR5(config-if)#end | End |
RTR6#config terminal | Configure terminal |
RTR6(config)#bridge 1 protocol provider-rstp edge | Configure bridge 1 protocol as provider rstp edge |
RTR6(config)#vlan database | Configure vlan database |
RTR6(config-vlan)#vlan 201-300 type customer bridge 1 state enable | Configure customer VLANS from 201-300 |
RTR6(config-vlan)#vlan 301-400 type service point-point bridge 1 state enable | Configure service VLANs from 301-400 |
RTR6(config-vlan)#cvlan registration table map1 bridge 1 | Create cvlan registration table |
RTR6(config-cvlan-registration)#cvlan 201 svlan 301 | Map 201 cvlan to 301 svlan |
RTR6(config-cvlan-registration)#cvlan 202 svlan 302 | Map 202 cvlan to 302 svlan |
RTR6(config-cvlan-registration)#cvlan 203 svlan 303 | Map 203 cvlan to 303 svlan |
RTR6(config-cvlan-registration)#cvlan 204 svlan 304 | Map 204 cvlan to 304 svlan |
RTR6(config-cvlan-registration)#cvlan 205 svlan 305 | Map 205 cvlan to 305 svlan |
RTR6(config-cvlan-registration)#interface po46 | Configure interface po46 |
RTR6(config-if)#switchport | Configure as layer 2 port |
RTR6(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR6(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR6(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR6(config-if)#load-interval 30 | Configure load interval 30 |
RTR6(config-if)#interface po56 | Configure interface po56 |
RTR6(config-if)#switchport | Configure as layer 2 port |
RTR6(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR6(config-if)#switchport mode provider-network | Configure switchport mode as provider network |
RTR6(config-if)#switchport provider-network allowed vlan add 301-400 | Configure allowed vlan from 301-400 |
RTR6(config-if)#load-interval 30 | Configure load interval 30 |
RTR6(config-if)#interface xe0 | Configure xe0 |
RTR6(config-if)#channel-group 46 mode active | Add xe0 to po46 |
RTR6(config-if)#interface xe1 | Configure xe1 |
RTR6(config-if)#channel-group 46 mode active | Add xe1 to po46 |
RTR6(config-if)#interface xe2 | Configure xe2 |
RTR6(config-if)#channel-group 46 mode active | Add xe2 to po46 |
RTR6(config-if)#interface xe3 | Configure xe3 |
RTR6(config-if)#channel-group 46 mode active | Add xe3 to po46 |
RTR6(config-if)#interface xe6 | Configure xe6 |
RTR6(config-if)#channel-group 56 mode active | Add xe6 to po56 |
RTR6(config-if)#interface xe7 | Configure xe7 |
RTR6(config-if)#channel-group 56 mode active | Add xe7 to po56 |
RTR6(config-if)#interface xe8 | Configure xe8 |
RTR6(config-if)#channel-group 56 mode active | Add xe8 to po56 |
RTR6(config-if)#interface xe9 | Configure xe9 |
RTR6(config-if)#channel-group 56 mode active | Add xe9 to po56 |
RTR6(config-if)#interface xe15 | Configure interface xe15 |
RTR6(config-if)#switchport | Configure as layer 2 port |
RTR6(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
RTR6(config-if)#switchport mode customer-edge trunk | Configure switchport mode as customer edge trunk |
RTR6(config-if)#switchport customer-edge trunk allowed vlan add 201-300 | Configure allowed vlan from 201-300 |
RTR6(config-if)#switchport customer-edge vlan registration map1 | Attach vlan registration table map 1 to xe15 |
RTR6(config-if)#load-interval 30 | Configure load interval 30 |
RTR6(config)#class-map type queuing que0 | Create Class map type queuing que0 |
RTR6(config-cmap-que)#match queue 0 | Match for queue 0 |
RTR6(config-cmap-que)#class-map type queuing que1 | Create Class map type queuing que0 |
RTR6(config-cmap-que)#match queue 1 | Match for queue 1 |
RTR6(config-cmap-que)#class-map type queuing que2 | Create Class map type queuing que1 |
RTR6(config-cmap-que)#match queue 2 | Match for queue 2 |
RTR6(config-cmap-que)#class-map type queuing que3 | Create Class map type queuing que2 |
RTR6(config-cmap-que)#match queue 3 | Match for queue 3 |
RTR6(config-cmap-que)#class-map type queuing vlan201 | Create class map type queuing vlan201 |
RTR6(config-cmap-que)#match vlan 201 | Match for VLAN 201 |
RTR6(config-cmap-que)#class-map type queuing vlan202 | Create class map type queuing vlan202 |
RTR6(config-cmap-que)#match vlan 202 | Match for VLAN 202 |
RTR6(config-cmap-que)#class-map type queuing vlan203 | Create class map type queuing vlan203 |
RTR6(config-cmap-que)#match vlan 203 | Match for VLAN 203 |
RTR6(config-cmap-que)#class-map type queuing vlan204 | Create class map type queuing vlan204 |
RTR6(config-cmap-que)#match vlan 204 | Match for VLAN 204 |
RTR6(config-cmap-que)#policy-map type queuing queue | Create policy map of type queuing with name queue |
RTR6(config-pmap-que)#class type queuing que0 | Attach class map que0 |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing que1 | Attach class map que1 |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing que2 | Attach class map que2 |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing que3 | Attach class map que3 |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#policy-map type queuing vlan | Create policy map of type queuing with name vlan |
RTR6(config-pmap-que)#class type queuing vlan201 | Attach class map vlan201 |
RTR6(config-pmap-c-que)#service-policy queue | Attach service policy queue |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing vlan202 | Attach class map vlan202 |
RTR6(config-pmap-c-que)#shape 100 mbps | Shape traffic to 100 mbps |
RTR6(config-pmap-c-que)#service-policy queue | Attach service policy queue |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing vlan203 | Attach class map vlan203 |
RTR6(config-pmap-c-que)#service-policy queue | Attach service policy queue |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#class type queuing vlan204 | Attach class map vlan204 |
RTR6(config-pmap-c-que)#service-policy queue | Attach service policy queue |
RTR6(config-pmap-c-que)#exit | Exit |
RTR6(config-pmap-que)#interface xe13 | Configure interface xe13 |
RTR6(config-if)#service-policy type queuing output vlan | Attach service policy vlan to interface xe13 |
RTR6(config-if)#shape rate 1000 mbps | Shape rate 1000 mbps |
RTR6(config-if)#exit | Exit |