Hardware | Number of LAG groups per device | Number of port settings per LAG group |
---|---|---|
QMX | 256 | 64 |
QUX | 32 | 64 |
QAX | 256 | 64 |
SW1#configure terminal | Enter configure mode. |
SW1(config)# bridge 1 protocol mstp | Configure bridge 1 as MSTP bridge |
SW1(config)# vlan database | Enter VLAN database mode. |
SW1(config-vlan)# vlan 2-10 bridge 1 state enable | Configure a VLAN and add it to the bridge. |
SW1(config-vlan)# commit | Commit the candidate configuration to the running Configuration. |
SW1(config-vlan)# exit | Exit the VLAN configuration mode. |
SW1(config)#lacp system-priority 20000 | Set the system priority of this switch. This priority is used for determining the system that is responsible for resolving conflicts in the choice of aggregation groups. A lower numerical value has a higher priority. |
SW1(config)#interface po10 | Enter into port channel interface po10. |
SW1(config-if)#switchport | Configure po10 as a layer 2 port. |
SW1(config-if)#bridge-group 1 | Associate bridge to an interface. |
SW1(config-if)#switchport mode trunk | Configure port as a trunk. |
SW1(config-if)#switchport trunk allowed vlan all | Allow all the VLANs on the po10 interface. |
SW1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW1(config-if)#exit | Exit interface mode. |
SW1(config)#interface eth1 | Enter interface mode. |
SW1(config-if)#channel-group 10 mode active | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW1(config-if)#exit | Exit interface mode. |
SW1(config)#interface eth2 | Enter interface mode. |
SW1(config-if)#channel-group 10 mode active | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW1(config-if)#exit | Exit interface mode. |
SW1(config)#interface eth3 | Enter interface mode. |
SW1(config-if)#channel-group 10 mode active | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW1(config-if)#exit | Exit interface mode. |
SW2#configure terminal | Enter configure mode. |
SW2(config)# bridge 1 protocol mstp | Configure bridge 1 as MSTP bridge |
SW2(config)# vlan database | Enter VLAN database mode. |
SW2(config-vlan)# vlan 2-10 bridge 1 state enable | Configure a VLAN and add it to the bridge. |
SW2(config-vlan)# commit | Commit the candidate configuration to the running Configuration. |
SW2(config-vlan)# exit | Exit the VLAN configuration mode. |
SW2(config)#lacp system-priority 20000 | Set the system priority of this switch. This priority is used for determining the system that is responsible for resolving conflicts in the choice of aggregation groups. A lower numerical value has a higher priority. |
SW2(config)#interface po10 | Enter into port channel interface po10. |
SW2(config-if)#switchport | Configure po10 as a layer 2 port. |
SW2(config-if)#bridge-group 1 | Associate bridge to an interface. |
SW2(config-if)#switchport mode trunk | Configure port as a trunk. |
SW2(config-if)#switchport trunk allowed vlan all | Allow all the VLANs on the po10 interface. |
SW2(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface eth2 | Enter interface mode. |
SW2(config-if)#channel-group 10 mode active | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW2(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface eth3 | Enter interface mode. |
SW2(config-if)#channel-group 10 mode active | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW2(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface eth4 | Enter interface mode. |
SW2(config-if)#channel-group 10 mode active | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW2(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW1#configure terminal | Enter configure mode. |
SW1(config)# bridge 1 protocol mstp | Configure bridge 1 as MSTP bridge |
SW1(config)# vlan database | Enter VLAN database mode. |
SW1(config-vlan)# vlan 2-10 bridge 1 state enable | Configure a VLAN and add it to the bridge. |
SW1(config-vlan)# commit | Commit the candidate configuration to the running Configuration. |
SW1(config-vlan)# exit | Exit the VLAN configuration mode. |
SW1(config)#lacp system-priority 20000 | Set the system priority of this switch. This priority is used for determining the system that is responsible for resolving conflicts in the choice of aggregation groups. A lower numerical value has a higher priority. |
SW1(config)#interface sa10 | Enter into port channel interface sa10. |
SW1(config-if)#switchport | Configure sa10 as a layer 2 port. |
SW1(config-if)#bridge-group 1 | Associate bridge to an interface. |
SW1(config-if)#switchport mode trunk | Configure port as a trunk. |
SW1(config-if)#switchport trunk allowed vlan all | Allow all the VLANs on the po10 interface. |
SW1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW1(config-if)#exit | Exit interface mode. |
SW1(config)#interface eth1 | Enter interface mode. |
SW1(config-if)#static-channel-group 10 | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW1(config-if)#exit | Exit interface mode. |
SW1(config)#interface eth2 | Enter interface mode. |
SW1(config-if)#static-channel-group 10 | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW1(config-if)#exit | Exit interface mode. |
SW1(config)#interface eth3 | Enter interface mode. |
SW1(config-if)#static-channel-group 10 | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW1(config-if)#exit | Exit interface mode. |
SW2#configure terminal | Enter configure mode. |
SW2(config)# bridge 1 protocol mstp | Configure bridge 1 as MSTP bridge |
SW2(config)# vlan database | Enter VLAN database mode. |
SW2(config-vlan)# vlan 2-10 bridge 1 state enable | Configure a VLAN and add it to the bridge. |
SW2(config-vlan)# commit | Commit the candidate configuration to the running Configuration. |
SW2(config-vlan)# exit | Exit the VLAN configuration mode. |
SW2(config)#interface sa10 | Enter into port channel interface sa10. |
SW2(config-if)#switchport | Configure sa10 as a layer 2 port. |
SW2(config-if)#bridge-group 1 | Associate bridge to an interface. |
SW2(config-if)#switchport mode trunk | Configure port as a trunk. |
SW2(config-if)#switchport trunk allowed vlan all | Allow all the VLANs on the po10 interface. |
SW2(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface eth2 | Enter interface mode. |
SW2(config-if)#static-channel-group 10 | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW2(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface eth3 | Enter interface mode. |
SW2(config-if)#static-channel-group 10 | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface eth4 | Enter interface mode. |
SW2(config-if)#static-channel-group 10 | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW2(config-if)#commit | Commit the candidate configuration to the running Configuration. |
SW2(config-if)#exit | Exit interface mode. |
#configure terminal | Enter configure mode. |
(config)#interface sa10 | Creating interface static-lag sa10 |
(config-if)#port-channel min-links 4 | Configuring port channel minimum links as 4(range is 2-32) |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode |
#configure terminal | Enter configure mode. |
(config)#interface sa10 | Creating interface port-channel sa10 |
(config-if)#port-channel min-links 4 | Configuring port channel minimum links as 4 (range is 2-32) |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode |
#configure terminal | Enter configure mode. |
(config)#interface sa10 | Creating interface static-lag sa10 |
(config-if)#port-channel min-bandwidth 40g | Configuring port channel minimum bandwidth as 40g (range from BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits.) |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode |
#configure terminal | Enter configure mode. |
(config)#interface sa10 | Creating interface port-channel sa10 |
(config-if)#port-channel min-bandwidth 40g | Configuring port channel minimum bandwidth as 40g (range from BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits.) |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode |
#configure terminal | Enter configure mode. |
(config)#interface po10 | Creating interface port-channel po10 |
(config-if)#port-channel min-links 4 | Configuring port channel minimum links as 4 (range is 2-32) |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode |
#configure terminal | Enter configure mode. |
(config)#interface po10 | Creating interface port-channel po10 |
(config-if)#port-channel min-links 4 | Configuring port channel minimum links as 4 (range is 2-32) |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode |
#configure terminal | Enter configure mode. |
(config)#interface po10 | Creating interface port-channel po10 |
(config-if)#port-channel min-bandwidth 40g | Configuring port channel minimum bandwidth as 40g (range from BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits.) |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode |
#configure terminal | Enter configure mode. |
(config)#interface po10 | Creating interface port-channel po10 |
(config-if)#port-channel min-bandwidth 40g | Configuring port channel minimum bandwidth as 40g (range from BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits.) |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode |
#configure terminal | Enter configure mode. |
(config)# bridge 1 protocol rstp vlan-bridge | Configure bridge type |
(config)# vlan database | Enter vlan database |
(config-vlan)# vlan 600,601,502 bridge 1 state enable | Configure vlans |
(config-vlan)#commit | Commit the candidate configuration to the running Configuration. |
(config-vlan)#exit | Exit the configure mode. |
(config)#interface mlag1 | Enter Interface mode |
(config-if)# switchport | Make mlag as layer2 port |
(config-if)# bridge-group 1 | Attach interface to bridge |
(config-if)# switchport mode trunk | Configure trunk port |
(config-if)# switchport trunk allowed vlan add 600,601,502 | Add interface to vlans |
(config-if)# spanning-tree edgeport | Configure port as edge port to avoid loops |
(config-if)# spanning-tree bpdu-filter enable | Enable bpdu filter to avoid loops |
(config-if)# mtu 9216 | Configure mtu. |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface mlag3 | Enter Interface mode |
(config-if)# switchport | Make mlag as layer2 port |
(config-if)# bridge-group 1 | Attach interface to bridge |
(config-if)# switchport mode trunk | Configure trunk port |
(config-if)# switchport trunk allowed vlan add 600,502 | Add interface to vlans |
(config-if)# spanning-tree edgeport | Configure port as edge port to avoid loops |
(config-if)# spanning-tree bpdu-filter enable | Enable bpdu filter to avoid loops |
(config-if)# mtu 9216 | Configure mtu. |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface po100 | Enter Interface mode |
(config-if)# switchport | Make po as layer2 port |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface sa1 | Enter Interface mode |
(config-if)# switchport | Make sa1 as layer2 port |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)# interface sa3 | Enter interface mode. |
(config-if)# switchport | Make sa3 as layer2 port. |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce2/1 | Enter Interface mode |
(config-if)#port breakout enable | Port breakout enabled |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce2/2 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce2/3 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce2/4 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce3/1 | Enter Interface mode |
(config-if)#port breakout enable | Port breakout enabled |
(config-if)# channel-group 100 mode active | Add interface to po100 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce3/2 | Enter Interface mode |
(config-if)# channel-group 100 mode active | Add interface to po100 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce3/3 | Enter Interface mode |
(config-if)# channel-group 100 mode active | Add interface to po100 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce3/4 | Enter Interface mode |
(config-if)# channel-group 100 mode active | Add interface to po100 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce4/1 | Enter Interface mode |
(config-if)#port breakout enable | Port breakout enabled |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce4/2 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce4/3 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#mcec domain configuration | Enter Multichasis Etherchannel domain configuration mode. |
(config-mcec-domain)# domain-address 1111.2222.3333 | Configure the domain address. |
(config-mcec-domain)# domain-system-number 1 | Configure the domain system number |
(config-mcec-domain)# intra-domain-link po100 | Specify the intra domain link for MLAG communication |
(config-mcec-domain)#commit | Commit the candidate configuration to the running Configuration. |
(config-mcec-domain)#exit | Exit the configure mode. |
(config)#interface sa1 | Enter Interface mode |
(config-if)#mlag 1 | Map sa1 to mlag1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#int mlag1 | Enter Interface mode |
(config-if)#mode active-standby | Configure mlag mode for mlag1 |
(config-if)#switchover type revertive 10 | Configure revertive timer |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface sa3 | Enter Interface mode |
(config-if)#mlag 3 | Map sa3 to mlag3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#int mlag3 | Enter Interface mode |
(config-if)#mode active-standby | Configure mlag mode for mlag3 |
(config-if)#switchover type revertive 10 | Configure revertive timer |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config-if)# interface sa1 | Enter sa interface mode |
(config-if)#port-channel min-links 3 | Configure min-link value on sa interface |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface sa3 | Enter sa Interface mode |
(config-if)#port-channel min-bandwidth 30g | Configure min-bandwidth value on sa/po interface |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
#configure terminal | Enter configure mode. |
(config)# bridge 1 protocol rstp vlan-bridge | Configure bridge type |
(config)# vlan database | Enter vlan database |
(config-vlan)# vlan 600,601,502 bridge 1 state enable | Configure vlans |
(config-vlan)#commit | Commit the candidate configuration to the running Configuration. |
(config-vlan)#exit | Exit the configure mode. |
(config)#interface mlag1 | Enter Interface mode |
(config-if)# switchport | Make mlag as layer2 port |
(config-if)# bridge-group 1 | Attach interface to bridge |
(config-if)# switchport mode trunk | Configure trunk port |
(config-if)# switchport trunk allowed vlan add 600,601,502 | Add interface to vlans |
(config-if)# spanning-tree edgeport | Configure port as edge port to avoid loops |
(config-if)# spanning-tree bpdu-filter enable | Enable bpdu filter to avoid loops |
(config-if)# mtu 9216 | Configure mtu. |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface mlag3 | Enter Interface mode |
(config-if)# switchport | Make mlag as layer2 port |
(config-if)# bridge-group 1 | Attach interface to bridge |
(config-if)# switchport mode trunk | Configure trunk port |
(config-if)# switchport trunk allowed vlan add 600,502 | Add interface to vlans |
(config-if)# spanning-tree edgeport | Configure port as edge port to avoid loops |
(config-if)# spanning-tree bpdu-filter enable | Enable bpdu filter to avoid loops |
(config-if)# mtu 9216 | Configure mtu. |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface po100 | Enter Interface mode |
(config-if)# switchport | Make po(IDL) as layer2 port |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface sa1 | Enter Interface mode |
(config-if)# switchport | Make sa1 as layer2 port |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface sa3 | Enter Interface mode |
(config-if)# switchport | Make sa3 as layer2 port |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce1/1 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce1/2 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce1/3 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce3/1 | Enter Interface mode |
(config-if)# channel-group 100 mode active | Add interface to po100 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce3/2 | Enter Interface mode |
(config-if)# channel-group 100 mode active | Add interface to po100 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce3/3 | Enter Interface mode |
(config-if)# channel-group 100 mode active | Add interface to po100 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce3/4 | Enter Interface mode |
(config-if)# channel-group 100 mode active | Add interface to po100 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce5/1 | Enter Interface mode |
(config-if)# port breakout enable | Port breakout enabled |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce5/2 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce5/3 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ce5/4 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config-mcec-domain)# intra-domain-link po100 | Specify the intra domain link for MLAG communication |
(config-mcec-domain)#commit | Commit the candidate configuration to the running Configuration. |
(config-mcec-domain)#exit | Exit the configure mode. |
(config)#interface sa1 | Enter Interface mode |
(config-if)#mlag 1 | Map sa1 to mlag1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#int mlag1 | Enter Interface mode |
(config-if)#mode active-standby | Configure mlag mode for mlag1 |
(config-if)#switchover type revertive 10 | Configure revertive timer |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface sa3 | Enter Interface mode |
(config-if)#mlag 3 | Map sa3 to mlag3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#int mlag3 | Enter Interface mode |
(config-if)#mode active-standby | Configure mlag mode for mlag3 |
(config-if)#switchover type revertive 10 | Configure revertive timer |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config-if)# interface sa1 | Enter sa interface mode |
(config-if)#port-channel min-links 3 | Configure min-link value on sa interface |
(config)#interface sa3 | Enter sa Interface mode |
(config-if)#port-channel min-bandwidth 30g | Configure min-bandwidth value on sa interface. |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
configure terminal | Enter Configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Configure bridge type |
(config)#vlan database | Create vlan database |
(config-vlan)#vlan 600,601,502,101,100,300,401,402 bridge 1 state enable | Create Vlans |
(config-vlan)#commit | Commit the candidate configuration to the running Configuration. |
(config-vlan)#exit | Exit the configure mode. |
(config)#interface xe1 | Enter Interface mode |
(config-if)# switchport | Make xe1 as layer2 port |
(config-if)# bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)# switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#spanning-tree edgeport | Configure port as edgeport |
(config-if)#spanning-tree bpdu-filter enable | Enable spanning tree bpdu filter |
(config-if)# mtu 9216 | Configure mtu |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface sa1 | Enter Interface mode |
(config-if)# switchport | Make xe1 as layer2 port |
(config-if)# bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)# switchport trunk allowed vlan add 100,101,300,401,402,502 | Enable all VLAN identifiers on this interface. |
(config-if)#spanning-tree edgeport | Configure port as edgeport |
(config-if)#spanning-tree bpdu-filter enable | Enable spanning tree bpdu filter |
(config-if)# mtu 9216 | Configure mtu |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe2 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe3 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe4 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe6 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe7 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe8 | Enter Interface mode |
(config-if)# static-channel-group 1 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
configure terminal | Enter Configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Configure bridge type |
(config)#vlan database | Create vlan database |
(config-vlan)#vlan 600,601,502,101,100,401,402 bridge 1 state enable | Create vlans |
(config-vlan)#commit | Commit the candidate configuration to the running Configuration. |
(config-vlan)#exit | Exit the configure mode. |
(config)#interface xe5/1 | Enter Interface mode |
(config-if)# switchport | Make xe1 as layer2 port |
(config-if)# bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)# switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#spanning-tree edgeport | Configure port as edge port |
(config-if)#spanning-tree bpdu-filter enable | Enable spanning tree bpdu filter |
(config-if)# mtu 9216 | Configure mtu |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface sa3 | Enter Interface mode |
(config-if)# switchport | Make sa3 as layer2 port |
(config-if)# bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)# switchport trunk allowed vlan add 100,101,401,402,600,502 | Enable all VLAN identifiers on this interface. |
(config-if)#spanning-tree edgeport | Configure port as edge port |
(config-if)#spanning-tree bpdu-filter enable | Enable spanning tree bpdu filter |
(config-if)# mtu 9216 | Configure mtu |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe3/1 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
#configure terminal | Enter Configure mode. |
(config)#interface xe3/2 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe3/3 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe1/1 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe1/2 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe1/3 | Enter Interface mode |
(config-if)# static-channel-group 3 | Add interface to sa3 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
#configure terminal | Enter configure mode. |
(config)#hostname CE1 | Configure host name |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN bridge on customer side |
(config)#vlan database | Enter VLAN database mode. |
(config-vlan)#vlan 2-100 bridge 1 state enable | Configure VLAN for the bridge |
(config-vlan)#commit | Commit the candidate configuration to the running Configuration. |
(config-vlan)#exit | Exit the VLAN configure mode. |
(config)#interface ge46 | Enter interface mode |
(config-if)#switchport | Make interface as Switchport |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface po1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed vlan all for the hybrid mode |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ge44 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#exit | Exit interface mode. |
(config)#interface ge45 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
#configure terminal | Enter configure mode. |
(config)#hostname CE2 | Configure host name |
(config)#bridge 1 protocol provider-rstp edge | Create provider rstp edge bridge |
(config)#vlan database | Enter vlan database mode |
(config-vlan)#vlan 2-100 type customer bridge 1 state enable | Configure customer VLAN for the bridge |
(config-vlan)#vlan 100 type service point-point bridge 1 state enable | Configure service VLAN for the bridge |
(config)#exit | Exit vlan database mode |
(config)#cvlan registration table map1 bridge 1 | Creating registration table |
(config-cvlan-registration)#cvlan 2-100 svlan 100 | Mapping cvlan to svlan |
(config-cvlan-registration)#commit | Commit the candidate configuration to the running Configuration. |
(config-cvlan-registration)#exit | Exit the cvlan registration mode. |
(config)#interface ge43 | Enter interface mode |
(config-if)#switchport | Make interface as Switchport |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode provider-network | Configure the mode as provider-network |
(config-if)# switchport provider-network allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface po1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1 |
(config-if)#switchport mode customer-edge hybrid | Set the switching characteristics of this interface to customer-edge hybrid |
(config-if)#switchport customer-edge hybrid allowed vlan all | Set the switching characteristics of this interface to customer-edge hybrid and allow vlan all |
(config-if)#switchport customer-edge vlan registration map1 | Configuring the registration table mapping on lag interface |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ge44 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#lacp force-up | Enable lacp force-up for the member port interface |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface ge45 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#commit | Commit the candidate configuration to the running Configuration. |
(config-if)#exit | Exit the configure mode. |
PE1(config)#interface ge44 | Enter interface mode. |
PE1(config-if)#no channel-group | Removing channel-group configurations from interface. |
PE1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
PE1(config)#interface ge45 | Enter interface mode. |
PE1(config-if)#no channel-group | Removing channel-group configurations from interface. |
PE1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
PE1(config-if)#exit | Exit interface mode. |
PE1(config)#interface ge44 | Enter interface mode. |
PE1(config-if)#switchport | Make the interface as switch port. |
PE1(config-if)#bridge-group 1 | Associate the interface to bridge. |
PE1(config-if)#switchport mode hybrid | Configure the mode as hybrid. |
PE1(config-if)#switchport hybrid allowed vlan all | Configure allowed vlan all for the hybrid mode. |
PE1(config-if)#commit | Commit the candidate configuration to the running Configuration. |
PE1(config-if)#exit | Exit the configure mode. |
#configure terminal | Enter configure mode. |
(config)#hostname SW1 | Configure host name |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN bridge on customer side |
(config-vlan)#vlan database | Enter VLAN database mode. |
(config-vlan)#vlan 2-100 bridge 1 state enable | Configure VLAN for the bridge |
(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
(config-vlan)#exit | Exit the VLAN configure mode. |
(config)#interface xe14 | Enter interface mode |
(config-if)#switchport | Make interface as Switchport |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface po1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed vlan all for the hybrid mode |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe7 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#port-channel weight 10 | Configuring port-channel weight |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#port-channel weight 2 | Configuring port-channel weight |
(config-if)#exit | Exit interface mode. |
(config)#interface xe13 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#port-channel weight 16 | Configuring port-channel weight |
(config-if)#exit | Exit interface mode. |
(config)#interface xe15 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#port-channel weight 5 | Configuring port-channel weight |
(config-if)#exit | Exit interface mode. |
(config)#interface xe19 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#port-channel weight 13 | Configuring port-channel weight |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
#configure terminal | Enter configure mode. |
(config)#hostname SW2 | Configure host name |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN bridge on customer side |
(config)#vlan database | Enter the VLAN database mode. |
(config-vlan)#vlan 2-100 bridge 1 state enable | Configure VLAN for the bridge |
(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
(config-vlan)#exit | Exit the VLAN configure mode. |
(config)#interface xe11 | Enter interface mode |
(config-if)#switchport | Make interface as Switchport |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface po1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed vlan all for the hybrid mode |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe7 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe13 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe15 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe19 | Enter interface mode |
(config-if)#channel-group 1 mode active | Adding interface to channel-group 1 |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
#configure terminal | Enter configure mode. |
(config)#hostname SW1 | Configure host name |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN bridge on customer side |
(config)#vlan database | Enter VLAN database mode. |
(config-vlan)#vlan 2-100 bridge 1 state enable | Configure VLAN for the bridge |
(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
(config-vlan)#exit | Exit the VLAN configure mode. |
(config)#interface xe14 | Enter interface mode |
(config-if)#switchport | Make interface as Switchport |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface sa1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed vlan all for the hybrid mode |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe7 | Enter interface mode |
(config-if)#static-channel-group 1 | Adding interface to static channel-group 1 |
(config-if)#port-channel weight 16 | Configuring port-channel weight |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9 | Enter interface mode |
(config-if)#static-channel-group 1 | Adding interface to static channel-group 1 |
(config-if)#port-channel weight 14 | Configuring port-channel weight |
(config-if)#exit | Exit interface mode. |
(config)#interface xe13 | Enter interface mode |
(config-if)#static-channel-group 1 | Adding interface to static channel-group 1 |
(config-if)#port-channel weight 10 | Configuring port-channel weight |
(config-if)#exit | Exit interface mode. |
(config)#interface xe15 | Enter interface mode |
(config-if)#static-channel-group 1 | Adding interface to static channel-group 1 |
(config-if)#port-channel weight 8 | Configuring port-channel weight |
(config-if)#exit | Exit interface mode. |
(config)#interface xe19 | Enter interface mode |
(config-if)#static-channel-group 1 | Adding interface to static channel-group 1 |
(config-if)#port-channel weight 16 | Configuring port-channel weight |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
#configure terminal | Enter configure mode. |
(config)#hostname SW2 | Configure host name |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN bridge on customer side |
(config)#vlan database | Enter VLAN database mode. |
(config-vlan)#vlan 2-100 bridge 1 state enable | Configure VLAN for the bridge |
(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
(config-vlan)#exit | Exit the VLAN configure mode. |
(config)#interface xe11 | Enter interface mode |
(config-if)#switchport | Make interface as Switchport |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface sa1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed vlan all for the hybrid mode |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |
(config)#interface xe7 | Enter interface mode |
(config-if)#static-channel-group 1 | Adding interface to static channel-group 1 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9 | Enter interface mode |
(config-if)#static-channel-group 1 | Adding interface to static channel-group 1 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe13 | Enter interface mode |
(config-if)#static-channel-group 1 | Adding interface to static channel-group 1 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe15 | Enter interface mode |
(config-if)#static-channel-group 1 | Adding interface to static channel-group 1 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe19 | Enter interface mode |
(config-if)#static-channel-group 1 | Adding interface to static channel-group 1 |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit the configure mode. |