OcNOS SP : Layer 2 Guide : Layer 2 Configuration Guide : Link Layer Discovery Protocol Configuration
Link Layer Discovery Protocol Configuration
This chapter contains a complete sample Link Layer Discovery Protocol (LLDP) configuration.
LLDP is a neighbor discovery protocol that defines a method for network access devices using Ethernet connectivity to advertise themselves to other devices on the same physical LAN, and then to store information about the network. It allows a device to learn higher-layer management reachability and connection endpoint information from adjacent devices. Using LLDP, a network device is able to advertise its identity, its capabilities and its media-specific configuration, as well as learn the same information from other connected devices.
Note: The lldp-agent command is not supported for SVLAN, VLAN, and loop-back interfaces.
Topology
Figure 1-1 displays a sample LLDP topology.
LLDP Topology
Interface Mode TLV
Default Agent
All configuration commands in the table below should be followed for each switch.
 
#configure terminal
Enter configure mode.
(config)#bridge 1 protocol ieee vlan-bridge
Configure an IEEE VLAN-aware bridge.
(config)#vlan database
Enter VLAN configure mode.
(config-vlan)#vlan 2 bridge 1 state enable
Configure a VLAN and add it to the bridge.
(config-vlan)#exit
Exit the VLAN configuration mode.
(config)#interface eth1
Enter interface mode.
(config-if)#switchport
Set switching characteristics on the port.
(config-if)#bridge-group 1
Associate the interface to the bridge.
(config-if)#lldp-agent
Enter into the default agent
(if-lldp-agent)#set lldp enable txrx
Enable an LLDP agent on the port.
(if-lldp-agent)#set lldp chassis-id-tlv ip-address
Configure the subtype for chassis-id TLV
(if-lldp-agent)#set lldp port-id-tlv mac-address
Configure the subtype for port-id TLV
(if-lldp-agent)#lldp tlv basic-mgmt port-description select
Enable the port-description TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv basic-mgmt system-name select
Enable the system-name TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv basic-mgmt system-capabilities select
Enable the system-capabilities TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv basic-mgmt system-description select
Enable the system-description TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv basic-mgmt management-address select
Enable the management-address TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific port-vlanid select
Enable the VLAN-id TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific vlan-name select
Enable the VLAN-NAME TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific port-ptcl-vlanid select
Enable the Port and Protocol VLAN id TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific ptcl-identity select
Enable the Protocol Identity TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific vid-digest select
Enable the VID Usage Digest TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific mgmt-vid select
Enable the Management VID TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific link-agg select
Enable the Link Aggregation TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8023-org-specific mac-phy select
Enable the MAC/PHY Configuration/Status TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8023-org-specific max-mtu-size select
Enable the Maximum Frame Size TLV to be transmitted on the port
(if-lldp-agent)#set lldp timer msg-fast-tx 5
Defines the time interval during fast transmission periods
(if-lldp-agent)#set lldp tx-fast-init 6
Defines the number of LLDPDUs that are transmitted during a fast transmission period
(if-lldp-agent)#exit
Exit the lldp agent mode
(config-if)#commit
Commit the candidate configuration to the running configuration.
(config-if)#exit
Exit interface mode.
Validation
1. Verify the LLDP configurations in the local switch
#show running-config lldp
!
interface eth1
lldp-agent
set lldp enable txrx
set lldp chassis-id-tlv ip-address
set lldp port-id-tlv mac-address
lldp tlv basic-mgmt port-description select
lldp tlv basic-mgmt system-name select
lldp tlv basic-mgmt system-description select
lldp tlv basic-mgmt system-capabilities select
lldp tlv basic-mgmt management-address select
lldp tlv ieee-8021-org-specific port-vlanid select
lldp tlv ieee-8021-org-specific port-ptcl-vlanid select
lldp tlv ieee-8021-org-specific vlan-name select
lldp tlv ieee-8021-org-specific ptcl-identity select
lldp tlv ieee-8021-org-specific vid-digest select
lldp tlv ieee-8021-org-specific mgmt-vid select
lldp tlv ieee-8021-org-specific link-agg select
lldp tlv ieee-8023-org-specific mac-phy select
lldp tlv ieee-8023-org-specific max-mtu-size select
set lldp timer msg-fast-tx 5
set lldp tx-fast-init 6
!
 
2. Verify the LLDP port statistics
#show lldp interface eth1 nearest-bridge
 
Agent Mode : Nearest bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 5
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : N
Device Type : Not Defined
Traffic statistics :
Total frames transmitted : 4
Total entries aged : 0
Total frames received : 3
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Customer Bridge
All configuration commands in the table below should be followed for each switch.
 
#configure terminal
Enter configure mode.
(config)#bridge 1 protocol ieee vlan-bridge
Configure an IEEE VLAN-aware bridge.
(config)#vlan database
Enter VLAN configure mode.
(config-vlan)#vlan 2 bridge 1 state enable
Configure a VLAN and add it to the bridge.
(config-vlan)#exit
Exit the VLAN configuration mode.
(config)#interface eth1
Enter interface mode.
(config-if)#switchport
Set switching characteristics on the port.
(config-if)#bridge-group 1
Associate the interface to the bridge.
(config-if)#lldp-agent customer-bridge
Enter into the Customer Bridge agent
(if-lldp-agent)#set lldp enable txrx
Enable an LLDP agent on the port.
(if-lldp-agent)#set lldp chassis-id-tlv ip-address
Configure the subtype for chassis-id TLV
(if-lldp-agent)#set lldp port-id-tlv mac-address
Configure the subtype for port-id TLV
(if-lldp-agent)#lldp tlv basic-mgmt port-description select
Enable the port-description TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv basic-mgmt system-name select
Enable the system-name TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv basic-mgmt system-capabilities select
Enable the system-capabilities TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv basic-mgmt system-description select
Enable the system-description TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv basic-mgmt management-address select
Enable the management-address TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv ieee-8021-org-specific port-vlanid select
Enable the VLAN-id TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv ieee-8021-org-specific vlan-name select
Enable the VLAN-NAME TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv ieee-8021-org-specific port-ptcl-vlanid select
Enable the Port and Protocol VLAN id TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv ieee-8021-org-specific ptcl-identity select
Enable the Protocol Identity TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv ieee-8021-org-specific vid-digest select
Enable the VID Usage Digest TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific mgmt-vid select
Enable the Management VID TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv ieee-8021-org-specific link-agg select
Enable the Link Aggregation TLV to be transmitted on the port.
(if-lldp-agent)#lldp tlv ieee-8023-org-specific mac-phy select
Enable the MAC/PHY Configuration/Status TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8023-org-specific max-mtu-size select
Enable the Maximum Frame Size TLV to be transmitted on the port.
(if-lldp-agent)#set lldp timer msg-fast-tx 5
Defines the time interval during fast transmission periods.
(if-lldp-agent)#set lldp tx-fast-init 6
Defines the number of LLD PDUs that are transmitted during a fast transmission period.
(if-lldp-agent)#exit
Exit the lldp agent mode
(config-if)#commit
Commit the candidate configuration to the running configuration.
(config-if)#exit
Exit interface mode.
Validation
1. Verify the LLDP configurations in the local switch:
#show #show running-config lldp
!
interface eth1
lldp-agent customer-bridge
set lldp enable txrx
set lldp chassis-id-tlv ip-address
set lldp port-id-tlv mac-address
lldp tlv basic-mgmt port-description select
lldp tlv basic-mgmt system-name select
lldp tlv basic-mgmt system-description select
lldp tlv basic-mgmt system-capabilities select
lldp tlv basic-mgmt management-address select
lldp tlv ieee-8021-org-specific port-vlanid select
lldp tlv ieee-8021-org-specific port-ptcl-vlanid select
lldp tlv ieee-8021-org-specific vlan-name select
lldp tlv ieee-8021-org-specific ptcl-identity select
lldp tlv ieee-8021-org-specific vid-digest select
lldp tlv ieee-8021-org-specific mgmt-vid select
lldp tlv ieee-8021-org-specific link-agg select
lldp tlv ieee-8023-org-specific mac-phy select
lldp tlv ieee-8023-org-specific max-mtu-size select
set lldp timer msg-fast-tx 5
set lldp tx-fast-init 6
!
 
2. Verify the LLDP port statistics
#show lldp interface eth1 customer-bridge
 
Agent Mode : Customer-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 5
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : N
Device Type : Not Defined
Traffic statistics :
Total frames transmitted : 8
Total entries aged : 0
Total frames received : 7
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Non-Tpmr-Bridge
The below configurations should be followed for each switch.
 
#configure terminal
Enter configure mode.
(config)#bridge 1 protocol ieee vlan-bridge
Configure an IEEE VLAN-aware bridge.
(config)#vlan database
Enter VLAN configure mode.
(config-vlan)#vlan 2 bridge 1 state enable
Configure a VLAN and add it to the bridge.
(config-vlan)#exit
Exit the VLAN configuration mode.
(config)#interface eth1
Enter interface mode.
(config-if)#switchport
Set switching characteristics on the port.
(config-if)#bridge-group 1
Associate the interface to the bridge.
(config-if)#lldp-agent non-tpmr-bridge
Enter into the Non tpmr Bridge agent
(if-lldp-agent)#set lldp enable txrx
Enable an LLDP agent on the port.
(if-lldp-agent)#set lldp chassis-id-tlv ip-address
Configure the subtype for chassis-id TLV
(if-lldp-agent)#set lldp port-id-tlv mac-address
Configure the subtype for port-id TLV
(if-lldp-agent)#lldp tlv basic-mgmt port-description select
Enable the port-description TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv basic-mgmt system-name select
Enable the system-name TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv basic-mgmt system-capabilities select
Enable the system-capabilities TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv basic-mgmt system-description select
Enable the system-description TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv basic-mgmt management-address select
Enable the management-address TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific port-vlanid select
Enable the VLAN-id TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific vlan-name select
Enable the VLAN-NAME TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific port-ptcl-vlanid select
Enable the Port and Protocol VLAN id TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific ptcl-identity select
Enable the Protocol Identity TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific vid-digest select
Enable the VID Usage Digest TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific mgmt-vid select
Enable the Management VID TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8021-org-specific link-agg select
Enable the Link Aggregation TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8023-org-specific mac-phy select
Enable the MAC/PHY Configuration/Status TLV to be transmitted on the port
(if-lldp-agent)#lldp tlv ieee-8023-org-specific max-mtu-size select
Enable the Maximum Frame Size TLV to be transmitted on the port
(if-lldp-agent)#set lldp timer msg-fast-tx 5
Defines the time interval during fast transmission periods
(if-lldp-agent)#set lldp tx-fast-init 6
Defines the number of LLD PDUs that are transmitted during a fast transmission period
(if-lldp-agent)#exit
Exit the lldp agent mode
(config-if)#commit
Commit the candidate configuration to the running configuration.
(config-if)#exit
Exit interface mode.
Validation
1. Verify the LLDP configurations in the local switch:
#show running-config lldp
lldp-agent non-tpmr-bridge
set lldp enable txrx
set lldp chassis-id-tlv ip-address
set lldp port-id-tlv mac-address
lldp tlv basic-mgmt port-description select
lldp tlv basic-mgmt system-name select
lldp tlv basic-mgmt system-description select
lldp tlv basic-mgmt system-capabilities select
lldp tlv basic-mgmt management-address select
lldp tlv ieee-8021-org-specific port-vlanid select
lldp tlv ieee-8021-org-specific port-ptcl-vlanid select
lldp tlv ieee-8021-org-specific vlan-name select
lldp tlv ieee-8021-org-specific ptcl-identity select
lldp tlv ieee-8021-org-specific vid-digest select
lldp tlv ieee-8021-org-specific mgmt-vid select
lldp tlv ieee-8021-org-specific link-agg select
lldp tlv ieee-8023-org-specific mac-phy select
lldp tlv ieee-8023-org-specific max-mtu-size select
set lldp timer msg-fast-tx 5
set lldp tx-fast-init 6
 
!
 
2. Verify the LLDP port statistics
#show lldp interface eth1 non-tmpr-bridge
 
Agent Mode : Non-TPMR-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 5
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : Y
Device Type : Not Defined
Traffic statistics :
Total frames transmitted : 17
Total entries aged : 0
Total frames received : 6
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Media Endpoint Devices TLV
Switch A
 
(config)#interface eth1
Enter interface mode.
(config-if)#lldp-agent
Enter the default agent.
(if-lldp-agent)#set lldp enable txrx
Set the admin status of the LLDP agent.
(if-lldp-agent)#exit
Exit agent mode.
(config-if)#lldp-agent customer-bridge
Enter the customer-bridge agent.
(if-lldp-agent)#set lldp enable txrx
Set the admin status of the LLDP agent.
(if-lldp-agent)#exit
Exit agent mode.
(config-if)#lldp-agent non-tpmr-bridge
Enter the non-tpmr-bridge agent.
(if-lldp-agent)#set lldp enable txrx
Set the admin status of the LLDP agent.
(if-lldp-agent)#exit
Exit agent mode.
(config-if)#set lldp med-devtype net-connect
Enter the med-devtype agent and set the device type to network connectivity.
(config-if)#exit
Exit agent mode.
(config-if)#commit
Commit the candidate configuration to the running configuration.
Validation
#show run lldp
!
!
interface eth1
lldp-agent
set lldp enable txrx
set lldp med-devtype net-connect
lldp-agent non-tpmr-bridge
set lldp enable txrx
lldp-agent customer-bridge
set lldp enable txrx
!
#
 
#show lldp interface eth1
Agent Mode : Customer-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : Y
Device Type : Network Connectivity
Traffic statistics :
Total frames transmitted : 97
Total entries aged : 1
Total frames received : 92
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Agent Mode : Non-TPMR-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : N
Device Type : Network Connectivity
Traffic statistics :
Total frames transmitted : 89
Total entries aged : 0
Total frames received : 0
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Agent Mode : Nearest bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : N
Device Type : Network Connectivity
Traffic statistics :
Total frames transmitted : 90
Total entries aged : 0
Total frames received : 0
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
#
Switch B
 
(config)#interface eth1
Enter interface mode.
(config-if)#lldp-agent
Enter the default agent.
(if-lldp-agent)#set lldp enable txrx
Set the admin status of the LLDP agent.
(if-lldp-agent)#exit
Exit agent mode.
(config-if)#lldp-agent customer-bridge
Enter the customer-bridge agent.
(if-lldp-agent)#set lldp enable txrx
Set the admin status of the LLDP agent.
(if-lldp-agent)#exit
Exit agent mode.
(config-if)#lldp-agent non-tpmr-bridge
Enter the non-tpmr-bridge agent.
(if-lldp-agent)#set lldp enable txrx
Set the admin status of the LLDP agent.
(if-lldp-agent)#exit
Exit agent mode.
(config-if)#set lldp med-devtype ep-class3
Enter the med-devtype agent and set the device type to endpoint class 3.
(config-if)#exit
Exit agent mode.
(config-if)#commit
Commit the candidate configuration to the running configuration.
Validation
#show running-config lldp
!
!
interface eth1
lldp-agent
set lldp enable txrx
set lldp chassis-id-tlv ip-address
set lldp med-devtype ep-class3
lldp-agent non-tpmr-bridge
set lldp enable txrx
set lldp chassis-id-tlv ip-address
lldp-agent customer-bridge
set lldp enable txrx
set lldp chassis-id-tlv ip-address
!
#
 
#show lldp interface eth1
Agent Mode : Customer-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : Y
Device Type : End Point Class-3
Traffic statistics :
Total frames transmitted : 11
Total entries aged : 0
Total frames received : 12
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Agent Mode : Non-TPMR-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : Y
Device Type : End Point Class-3
Traffic statistics :
Total frames transmitted : 7
Total entries aged : 0
Total frames received : 0
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Agent Mode : Nearest bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : Y
Device Type : End Point Class-3
Traffic statistics :
Total frames transmitted : 8
Total entries aged : 0
Total frames received : 0
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
#
Global Mode TLV
LLDPv2 TLVs can be configured globally, making it applicable for all interfaces where LLDP is enabled.
Topology
LLDP topology
SW1
 
SW1#configure terminal
Enter Configure mode
SW1(config)#lldp tlv-select basic-mgmt port-description
Enable LLDP port description TLV in global mode
SW1(config)#lldp tlv-select basic-mgmt system-name
Enable LLDP system name TLV in global mode
SW1(config)#lldp tlv-select basic-mgmt system-capabilities
Enable LLDP system capabilities TLV in global mode
SW1(config)#lldp tlv-select basic-mgmt system-description
Enable LLDP system description TLV in global mode
SW1(config)#lldp tlv-select basic-mgmt management-address
Enable LLDP management address TLV in global mode
SW1(config)#interface eth1
Enter interface mode
SW1(config-if)#lldp-agent
Enter LLDP interface mode
SW1(if-lldp-agent)#set lldp enable txrx
Enable LLDP TLV transmit and receive for the nearest bridge
SW1(if-lldp-agent)#exit
Exit LLDP mode
SW1(config-if)#commit
Commit the candidate configuration to the running configuration.
SW1(config-if)#exit
Exit interface mode
SW1(config)#end
Exit the configure mode
SW2
 
SW2#configure terminal
Enter Configure mode
SW2(config)#lldp tlv-select basic-mgmt port-description
Enable LLDP port description TLV in global mode
SW2(config)#lldp tlv-select basic-mgmt system-name
Enable LLDP system name TLV in global mode
SW2(config)#lldp tlv-select basic-mgmt system-capabilities
Enable LLDP system capabilities TLV in global mode
SW2(config)#lldp tlv-select basic-mgmt system-description
Enable LLDP system description TLV in global mode
SW2(config)#lldp tlv-select basic-mgmt management-address
Enable LLDP management address TLV in global mode
SW2(config)#interface eth1
Enter interface mode
SW2(config-if)#lldp-agent
Enter LLDP interface mode
SW2(if-lldp-agent)#set lldp enable txrx
Enable LLDP TLV transmit and receive for the nearest bridge
SW2(if-lldp-agent)#exit
Exit LLDP mode
SW2(config-if)#commit
Commit the candidate configuration to the running configuration.
SW2(config-if)#exit
Exit interface mode
SW2(config)#end
Exit the configure mode
Validation
SW1#show running-config lldp
!
lldp tlv-select basic-mgmt port-description
lldp tlv-select basic-mgmt system-name
lldp tlv-select basic-mgmt system-capabilities
lldp tlv-select basic-mgmt system-description
lldp tlv-select basic-mgmt management-address
!
interface eth1
lldp-agent
set lldp enable txrx
 
 
SW1#show lldp neighbors
 
Loc PortID Rem Host Name Rem Chassis Id Rem Port Id Agent Mode
 
--------------------------------------------------------------------------------
Eth1 OcNOS cc37.ab56.6d80 cc37.abbb.ed81 Nearest bridge
 
 
SW1#show lldp neighbors detail
 
--------------------------------------------------------------------------------
 
Nearest bridge Neighbors
Interface Name : eth1
Mandatory TLVs
Chassis id type : MAC address [cc37.ab56.6d80]
Port id type : MAC address [cc37.abbb.ed81]
Time to live : 121
Basic Management TLVs
System Name : SW2
System Description : Hardware Model:EC_AS4610-54, Software version: Oc
NOS,1.3.6.241a
Port Description : eth1
Remote System Capabilities : Bridge
Router
Capabilities Enabled : Router
Management Address : MAC Address [cc37.abbb.ed81]
Interface Number subtype : ifindex
Interface Number 10046
OID Number : 0
802.1 Org specific TLVs
Port vlan id : 0
Port & Protocol vlan id : 0
Remote Configured VLANs : None
Remote Protocols Advertised: None
Remote VID Usage Digest : 0
Remote Management Vlan : 0
Link Aggregation Capability: not capable of being aggregated
Link Aggregation Status : not currently in aggregation
Link Aggregation Port ID :
802.3 Org specific TLVs
AutoNego Support : Not-Supported
AutoNego Status : Disabled
AutoNego Capability : 0
Operational MAU Type : 0 [unknown]
Max Frame Size :
SW1#
LLDP-MED
LLDP extensions and behavior requirements are described specifically in the areas of network Configuration and policy, device location (including for Emergency Call Service / E911), Power over Ethernet management, and inventory management.
Based on the device type, different TLVs are advertised by the Station.
LLDP-MED Network Connectivity Device
LLDP-MED Network Connectivity Devices, as defined in this Standard, provide access to the IEEE 802 based LAN infrastructure for LLDP-MED Endpoint Devices. An LLDP-MED Network Connectivity Device is a LAN access device based on any of the following technologies:
LAN Switch/Router
IEEE 802.1 Bridge
IEEE 802.3 Repeater (included for historical reasons)
IEEE 802.11 Wireless Access Point
Any device that supports the IEEE 802.1AB and MED extensions defined by this Standard and can relay IEEE 802 frames via any method.
Configuration Command
set lldp med-devtype net-connect
LLDP-MED Generic Endpoint (Class I)
The LLDP-MED Generic Endpoint (Class I) definition is applicable to all endpoint products that require the base LLDP discovery services, however do not support IP media or act as an end-user communication appliance. Such devices may include (but are not limited to) IP Communication Controllers, other communication related servers, or any device requiring basic services.
Configuration command:
set lldp med-devtype ep-class1
LLDP-MED Generic Endpoint (Class 2)
The LLDP-MED Media Endpoint (Class II) definition is applicable to all endpoint products that have IP media capabilities however may or may not be associated with a particular end user. Capabilities include all of the capabilities defined for the previous Generic Endpoint Class (Class I), and are extended to include aspects related to media streaming. Example product categories expected to adhere to this class include (but are not limited to) Voice / Media Gateways, Conference Bridges, Media Servers, and similar
Configuration command:
set lldp med-devtype ep-class2
LLDP-MED Generic Endpoint (Class 3)
The LLDP-MED Communication Endpoint (Class III) definition is applicable to all endpoint products that act as end user communication appliances supporting IP media. Capabilities include all of the capabilities defined for the previous Generic Endpoint (Class I) and Media Endpoint (Class II) classes, and are extended to include aspects related to end user devices. Example product categories expected to adhere to this class include (but are not limited to) end user communication appliances, such as IP Phones, PC-based softphones, or other communication appliances that directly support the end user.
Configuration command:
set lldp med-devtype ep-class3
Switch A
 
#configure terminal
Enter configure mode.
(config)#bridge 1 protocol ieee vlan-bridge
Configure an IEEE VLAN-aware bridge.
(config)#vlan database
Enter VLAN configure mode.
(config-vlan)#vlan 2 bridge 1 state enable
Configure a VLAN and add it to the bridge.
(config-vlan)#exit
Exit the VLAN configuration mode.
(config)#interface eth1
Enter interface mode.
(config-if)#switchport
Set switching characteristics on the port.
(config-if)#bridge-group 1
Associate the interface to the bridge.
(config-if)#lldp-agent
Enter into the default agent
(if-lldp-agent)#set lldp enable txrx
Enable an LLDP agent on the port.
(if-lldp-agent)#exit
Exit the lldp agent mode
(if-config-if)#lldp-agent customer-bridge
Enter into the customer-bridge agent.
(if-lldp-agent)#set lldp enable txrx
Enable an LLDP agent on the port.
(if-lldp-agent)#exit
Exit the lldp agent mode
(config-if)#lldp-agent non-tpmr-bridge
Enter into the non-tpmr-bridge agent
(if-lldp-agent)#set lldp enable txrx
Enable an LLDP agent on the port.
(if-lldp-agent)#exit
Exit the lldp agent mode
(config-if)#set lldp med-devtype net-connect
Configure the med device type
(config-if)#exit
Exit interface mode.
(config-if)#commit
Commit the candidate configuration to the running configuration.
Switch B
 
#configure terminal
Enter configure mode.
(config)#bridge 1 protocol ieee vlan-bridge
Configure an IEEE VLAN-aware bridge.
(config)#vlan database
Enter VLAN configure mode.
(config-vlan)#vlan 2 bridge 1 state enable
Configure a VLAN and add it to the bridge.
(config-vlan)#exit
Exit the VLAN configuration mode.
(config)#interface eth1
Enter interface mode.
(config-if)#switchport
Set switching characteristics on the port.
(config-if)#bridge-group 1
Associate the interface to the bridge.
(config-if)#lldp-agent
Enter into the default agent
(if-lldp-agent)#set lldp enable txrx
Enable an LLDP agent on the port.
(if-lldp-agent)#exit
Exit the lldp agent mode
(config-if)#lldp-agent customer-bridge
Enter into the customer-bridge agent
(if-lldp-agent)#set lldp enable txrx
Enable an LLDP agent on the port.
(if-lldp-agent)#exit
Exit the lldp agent mode
(config-if)#lldp-agent non-tpmr-bridge
Enter into the non-tpmr-bridge agent
(if-lldp-agent)#set lldp enable txrx
Enable an LLDP agent on the port.
(if-lldp-agent)#exit
Exit the lldp agent mode
(config-if)#set lldp med-devtype ep-class3
Configure the med device type
(config-if)#exit
Exit interface mode.
(config-if)#commit
Commit the candidate configuration to the running configuration.
Validation
1. Verify the LLDP configurations on Switch A:
#show running-config lldp
!
!
interface eth1
lldp-agent
set lldp enable txrx
set lldp med-devtype net-connect
lldp-agent non-tpmr-bridge
set lldp enable txrx
lldp-agent customer-bridge
set lldp enable txrx
!
2. Verify the LLDP port statistics on Switch A:
#show lldp interface eth1
Agent Mode : Customer-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : Y
Device Type : Network Connectivity
Traffic statistics :
Total frames transmitted : 11
Total entries aged : 0
Total frames received : 10
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Agent Mode : Non-TPMR-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : N
Device Type : Network Connectivity
Traffic statistics :
Total frames transmitted : 7
Total entries aged : 0
Total frames received : 0
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Agent Mode : Nearest bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : N
Device Type : Network Connectivity
Traffic statistics :
Total frames transmitted : 7
Total entries aged : 0
Total frames received : 0
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
 
#show lldp interface eth1 non-tpmr-bridge
Agent Mode : Non-TPMR-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 5
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : N
Device Type : Not Defined
Traffic statistics :
Total frames transmitted : 4
Total entries aged : 0
Total frames received : 0
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
3. Verify the LLDP configurations for end device ep-class3 on Switch B:
#show running-config lldp
!
interface eth1
set lldp med-devtype ep-class3
lldp-agent
set lldp enable txrx
lldp tlv med network-policy select
lldp-agent non-TPMR-bridge
set lldp enable txrx
lldp tlv med network-policy select
lldp-agent customer-bridge
set lldp enable txrx
lldp tlv med network-policy select
!
4. Verify the LLDP port statistics on Switch B:
 
#show lldp interface eth1
Agent Mode : Customer-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : Y
Device Type : End Point Class-3
Traffic statistics :
Total frames transmitted : 124
Total entries aged : 0
Total frames received : 125
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Agent Mode : Non-TPMR-bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : Y
Device Type : End Point Class-3
Traffic statistics :
Total frames transmitted : 120
Total entries aged : 0
Total frames received : 0
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
Agent Mode : Nearest bridge
Enable (tx/rx) : Y/Y
Message fast transmit time : 1
Message transmit interval : 30
Reinitialisation delay : 2
MED Enabled : Y
Device Type : End Point Class-3
Traffic statistics :
Total frames transmitted : 120
Total entries aged : 0
Total frames received : 0
Total error frames received: 0
Total frames discarded : 0
Total discarded TLVs : 0
Total unrecognised TLVs : 0
#
LLDP Over SVI, LAG, and Sub-Interface
Overview
Link Layer Discovery Protocol (LLDP) is an open-source Layer 2 protocol that runs on the data link layer. It is a neighbor discovery protocol that defines a method for network access devices using Ethernet connectivity to advertise themselves to other devices on the same physical LAN and then store information about the network. It allows a device to learn higher-layer management reachability and connection endpoint information from adjacent devices. Using LLDP, a network device can advertise its identity, capabilities, and media-specific configuration and learn the same information.
LLDP supports a set of defined attributes used to find neighboring devices includeing:
T- type
L- length
V- value descriptions
The information is transmitted and/or received by neighbor devices through each of their LLDP-enabled interfaces, which send Ethernet frames at regular intervals. The Management Address TLV in LLDP identifies an address (MAC or Layer3 IP) associated with the local LLDP agent used to reach higher-layer entities to assist discovery by network management. This TLV also provides room for the inclusion of the system interface number and an object identifier (OID) associated with this management address.
Feature Characteristics
LLDP enabled devices are capable of:
Discovering neighboring devices.
Using as an open standard protocol.
Sharing details about their layer-2 configurations with neighboring devices.
Benefits
LLDP neighbor are used for SVI,LAG, and Sub Interface.
LLDP is easy for devices to broadcast and identify information across networks.
Prerequisites
Upon logging into the OcNOS environment enable LLDP run command on global mode.
The enabled device should support the LLDP sub-interface configuration.
Note: Before configuring the SVI interface, ensure the physical connection between the switches is active, and ports are in the trunk mode.
Topology
LLDP topology
Configuration
Provide the following:
1. Enter the configuration mode and configure VLAN interface.
SW1(#config)terminal
SW1(config)#bridge 1 protocol ieee vlan-bridge
SW1(config)#vlan database
SW1(config-vlan)#vlan 2-200 bridge 1 state enable
SW1(config-vlan)#commit
SW1(config-if)#int xe7
SW1(config-if)#switchport
SW1(config-if)#bridge-group 1
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk allowed vlan all
SW1(config-if)#commit
 
SW2(config)#bridge 1 protocol ieee vlan-bridge
SW2(config)#vlan database
SW2(config-vlan)#vlan 2-200 bridge 1 state enable
SW2(config-vlan)#commit
SW2(config)#int xe7
SW2(config-if)#switchport
SW2(config-if)#bridge-group 1
SW2(config-if)#switchport mode trunk
SW2(config-if)#switchport trunk allowed vlan all
SW2(config-if)#commit
 
2. Configure the SVLAN interface and assign the IP address to the interface.
SW1(config)#interface vlan1.20
SW1(config-if)#ip vrf forwarding management
SW1(config-if)#ip address 3.3.3.3/24
SW1(config-if)#commit
SW2(config)#interface vlan1.20
SW2(config-if)#ipvrf forwarding management
SW2(config-if)#ip address 3.3.3.2/24
SW2(config-if)#commit
3. Configure the port channel interface and assign the IP address. Connect the interfaces to the port channel.
SW1(config)#interface po10
SW1(config-if)#ip address 1.1.1.1/24
SW1(config-if)# ip vrf forwarding management
SW1(config-if)#commit Feature Name
SW1(config-if)#exit
 
SW1(config)#int xe2
SW1(config-if)#switchport
SW1(config-if)#no switchport
SW1(config-if)#channel-group 10 mode active
SW1(config-if)#commit
 
SW1(config)#int xe3
SW1(config-if)#switchport
SW1(config-if)#no switchport
SW1(config-if)#channel-group 10 mode active
SW1(config-if)#commit
 
SW1(config)#int xe4
SW1(config-if)#switchport
SW1(config-if)#no switchport
SW1(config-if)#channel-group 10 mode active
SW1(config-if)#commit
 
SW2(config)#interface po10
SW2(config-if)#ip address 1.1.1.2/24
SW2(config-if)# ip vrf forwarding management
SW2(config-if)#commit
SW2(config-if)#exit
 
SW2(config)#int xe2
SW2(config-if)#switchport
SW2(config-if)#no switchport
SW2(config-if)#channel-group 10 mode active
SW2(config-if)#commit
 
SW2(config)#int xe3
SW2(config-if)#switchport
SW2(config-if)#no switchport
SW2(config-if)#channel-group 10 mode active
SW2(config-if)#commit
 
SW2(config)#int xe4
SW2(config-if)#switchport
SW2(config-if)#no switchport
SW2(config-if)#channel-group 10 mode active
4. Configure sub interfaces on both SW1 and SW2, and assign the IP address to the interfaces.
SW1(config)#int xe6.10
SW1(config-if)#encapsulation dot1q 10
SW1(config-if)#ip address 2.2.2.3/24
SW1(config-if)#ip vrf forwarding management
SW1(config-if)#commit
SW2(config)#int xe6.10
SW2(config-if)#encapsulation dot1q 10
SW2(config-if)#ip address 2.2.2.2/24
SW2(config-if)#ip vrf forwarding management
SW2(config-if)#commit
5. Enable the LLDP agent mode and capabilities on both switch interfaces.
SW1(config)#int xe6
SW1(config-if)#lldp-agent customer-bridge
SW1(if-lldp-agent)#set lldp enable txrx
SW1(if-lldp-agent)#set lldp chassis-id-tlv ip-address
SW1(if-lldp-agent)#lldp tlv basic-mgmt management-address select
SW1(if-lldp-agent)#commit
SW2(config-if)#int xe6
SW2(config-if)# lldp-agent
SW2(if-lldp-agent)#set lldp enable txrx
SW2(if-lldp-agent)#set lldp management-address-tlv ip-address
SW2(if-lldp-agent)#lldp tlv basic-mgmt management-address select
SW2(if-lldp-agent)#commit
6. Verify the LLDP neighbors on the device.
SW1 show lldp int xe6 neighbor
 
Nearest bridge Neighbors
Interface Name : xe6
Mandatory TLVs
Chassis id type : MAC address [b86a.9782.1fba]
Port id type : MAC address [b86a.9782.1fc1]
Time to live : 121
Basic Management TLVs
System Name :
System Description :
Port Description :
Remote System Capabilities : None
Capabilities Enabled : None
Management Address : IP Address [10.12.181.117]
Interface Number subtype : ifindex
Interface Number : 3
OID Number : 0
Management Address : IP Address [2.2.2.2]
Interface Number subtype : ifindex
Interface Number : 327876618
OID Number : 0
Management Address : IP Address [3.3.3.2]
Interface Number subtype : ifindex
Interface Number : 25020
OID Number : 0
802.1 Org specific TLVs
Port vlan id : 0
Port & Protocol vlan id : 0
Remote Configured VLANs : None
Remote Protocols Advertised: None
Remote VID Usage Digest : 0
Remote Management Vlan : 0
Link Aggregation Capability: not capable of being aggregated
Link Aggregation Status : not currently in aggregation
Link Aggregation Port ID : 802.3 Org specific TLVs
AutoNego Support : Not-Supported
AutoNego Status : Disabled
AutoNego Capability : 0
Operational MAU Type : 0 [unknown]
SW2#sh lldp int xe7 neighbor
Nearest bridge Neighbors
Interface Name : xe7
 
Mandatory TLVs
Chassis id type : MAC address [5c07.5828.a775]
Port id type : MAC address [5c07.5828.a77d]
Time to live : 121
 
Basic Management TLVs
System Name : SW1
System Description : Hardware Model:UFI_S9510-30XC,
Software version: OcNOS,6.5.1.48
Port Description : xe7
Remote System Capabilities : Bridge Router
Capabilities Enabled : Bridge Router
 
Management Address : MAC Address [5c07.5828.a77d]
Interface Number subtype : ifindex
Interface Number : 5008
OID Number : 0
802.1 Org specific TLVs
Port vlan id : 1
Port & Protocol vlan id : 0
 
Remote Configured VLANs :
vlan-id: 1 vlan-name: default
vlan-id: 2 vlan-name: VLAN0002
vlan-id: 3 vlan-name: VLAN0003
vlan-id: 4 vlan-name: VLAN0004
vlan-id: 5 vlan-name: VLAN0005
vlan-id: 6 vlan-name: VLAN0006
vlan-id: 7 vlan-name: VLAN0007
vlan-id: 8 vlan-name: VLAN0008
vlan-id: 9 vlan-name: VLAN0009
vlan-id: 10 vlan-name: VLAN0010
vlan-id: 11 vlan-name: VLAN0011
vlan-id: 12 vlan-name: VLAN0012
vlan-id: 13 vlan-name: VLAN0013
vlan-id: 14 vlan-name: VLAN0014
vlan-id: 15 vlan-name: VLAN0015
vlan-id: 16 vlan-name: VLAN0016
vlan-id: 17 vlan-name: VLAN0017
vlan-id: 18 vlan-name: VLAN0018
vlan-id: 19 vlan-name: VLAN0019
vlan-id: 20 vlan-name: VLAN0020
vlan-id: 21 vlan-name: VLAN0021
vlan-id: 22 vlan-name: VLAN0022
vlan-id: 23 vlan-name: VLAN0023
vlan-id: 24 vlan-name: VLAN0024
vlan-id: 25 vlan-name: VLAN0025
vlan-id: 26 vlan-name: VLAN0026
vlan-id: 27 vlan-name: VLAN0027
vlan-id: 28 vlan-name: VLAN0028
vlan-id: 29 vlan-name: VLAN0029
vlan-id: 30 vlan-name: VLAN0030
vlan-id: 31 vlan-name: VLAN0031
vlan-id: 32 vlan-name: VLAN0032
vlan-id: 33 vlan-name: VLAN0033
vlan-id: 34 vlan-name: VLAN0034
vlan-id: 35 vlan-name: VLAN0035
vlan-id: 36 vlan-name: VLAN0036
vlan-id: 37 vlan-name: VLAN0037
vlan-id: 38 vlan-name: VLAN0038
vlan-id: 39 vlan-name: VLAN0039
vlan-id: 40 vlan-name: VLAN0040
vlan-id: 41 vlan-name: VLAN0041
vlan-id: 42 vlan-name: VLAN0042
vlan-id: 43 vlan-name: VLAN0043
vlan-id: 44 vlan-name: VLAN0044
vlan-id: 45 vlan-name: VLAN0045
vlan-id: 46 vlan-name: VLAN0046
vlan-id: 47 vlan-name: VLAN0047
vlan-id: 48 vlan-name: VLAN0048
vlan-id: 49 vlan-name: VLAN0049
vlan-id: 50 vlan-name: VLAN0050
vlan-id: 51 vlan-name: VLAN0051
vlan-id: 52 vlan-name: VLAN0052
vlan-id: 53 vlan-name: VLAN0053
vlan-id: 54 vlan-name: VLAN0054
vlan-id: 55 vlan-name: VLAN0055
vlan-id: 56 vlan-name: VLAN0056
vlan-id: 57 vlan-name: VLAN0057
vlan-id: 58 vlan-name: VLAN0058
vlan-id: 59 vlan-name: VLAN0059
vlan-id: 60 vlan-name: VLAN0060
vlan-id: 61 vlan-name: VLAN0061
vlan-id: 62 vlan-name: VLAN0062
vlan-id: 63 vlan-name: VLAN0063
vlan-id: 64 vlan-name: VLAN0064
vlan-id: 65 vlan-name: VLAN0065
vlan-id: 66 vlan-name: VLAN0066
vlan-id: 67 vlan-name: VLAN0067
vlan-id: 68 vlan-name: VLAN0068
vlan-id: 69 vlan-name: VLAN0069
vlan-id: 70 vlan-name: VLAN0070
vlan-id: 71 vlan-name: VLAN0071
vlan-id: 72 vlan-name: VLAN0072
vlan-id: 73 vlan-name: VLAN0073
vlan-id: 74 vlan-name: VLAN0074
vlan-id: 75 vlan-name: VLAN0075
Remote Protocols Advertised: Spanning Tree Protocol
Remote VID Usage Digest : 0
Remote Management Vlan : 0
Link Aggregation Capability: capable of being aggregated
Link Aggregation Status : not currently in aggregation
Link Aggregation Port ID : 802.3 Org specific TLVs
AutoNego Support : Supported
AutoNego Status : Disabled
AutoNego Capability : 16
Operational MAU Type : 54 [Four-pair Category 6A or better, full duplex mode only]
Max Frame Size : 1522
Implementation Examples
Enter configuration commands.
SW1(config)#lldp tlv-select basic-mgmt port-description
SW1(config)# lldp tlv-select basic-mgmt system-name
SW1(config)# lldp tlv-select basic-mgmt system-description
SW1(config)# lldp tlv-select basic-mgmt system-capabilities
SW1(config)# lldp tlv-select basic-mgmt management-address
SW1(config)#
SW1(config)#
SW1(config)# lldp tlv-select ieee-8021-org-specific port-vlanid
SW1(config)# lldp tlv-select ieee-8021-org-specific port-ptcl-vlanid
SW1(config)# lldp tlv-select ieee-8021-org-specific vlan-name
SW1(config)# lldp tlv-select ieee-8021-org-specific ptcl-identity
SW1(config)# lldp tlv-select ieee-8021-org-specific vid-digest
SW1(config)# lldp tlv-select ieee-8021-org-specific mgmt-vid
SW1(config)# lldp tlv-select ieee-8021-org-specific link-agg
SW1(config)#
SW1(config)# lldp tlv-select ieee-8023-org-specific mac-phy
SW1(config)# lldp tlv-select ieee-8023-org-specific max-mtu-size
SW1(config)#commit
SW1(config)#do sh lldp int xe6 neighbor
 
Nearest bridge Neighbors
Interface Name : xe6
Mandatory TLVs
Chassis id type : MAC address [b86a.9782.1fba]
Port id type : MAC address [b86a.9782.1fc1]
Time to live : 121
Basic Management TLVs
System Name : SW2
System Description : Hardware Model:EC_AS5912-54X, Software version: OcNOS,6.5.1.49
Port Description : xe6
Remote System Capabilities : Bridge
Router
Capabilities Enabled : Bridge
Router
Management Address : IP Address [10.12.181.117]
Interface Number subtype : ifindex
Interface Number : 3
OID Number : 0
Management Address : IP Address [2.2.2.2]
Interface Number subtype : ifindex
Interface Number : 327876618
OID Number : 0
Management Address : IP Address [3.3.3.2]
Interface Number subtype : ifindex
Interface Number : 25020
OID Number : 0
802.1 Org specific TLVs
Port vlan id : 0
Port & Protocol vlan id : 0
Remote Configured VLANs : None
Remote Protocols Advertised: None
Remote VID Usage Digest : 0
Remote Management Vlan : 0 Feature Name
Link Aggregation Capability: capable of being aggregated
Link Aggregation Status : not currently in aggregation
Link Aggregation Port ID :
802.3 Org specific TLVs
AutoNego Support : Supported
AutoNego Status : Disabled
AutoNego Capability : 16
Operational MAU Type : 54 [Four-pair Category 6A or better, full duplex mode only]
Max Frame Size : 1518
SW1(config)# end