SW1#configure terminal | Enter the config terminal. |
(config)#hostname SW1 | Assign the hostname for the router. |
SW1(config)#bridge 1 protocol rstp vlan-bridge | Create bridge. |
SW1(config)#vlan database | Enter the VLAN database. |
SW1(config-vlan)#vlan 2-1002 bridge 1 state enable | Create the VLANs. |
SW1(config-vlan)#exit | Exit the VLAN database. |
SW1(config)#int po1 | Enter the interface mode. |
SW1(config-if)#switchport | Configure the interface as Layer 2. |
SW1(config-if)#bridge-group 1 | Assign the bridge to the interface. |
SW1(config-if)#switchport mode trunk | Configure the interface as trunk mode. |
SW1(config-if)#switchport trunk allowed vlan all | Configure the interface to allow all VLAN ids. |
SW1(config-if)#exit | Exit the interface mode. |
SW1(config)#int xe15 | Enter the interface mode. |
SW1(config-if)#channel-group 1 mode active | Add the interface as member of LAG interface. |
SW1(config-if)#int xe31 | Enter the interface mode. |
SW1(config-if)#channel-group 1 mode active | Add the interface as member of LAG interface. |
SW1(config-if)#commit | Commit the configure on the node. |
SW1(config-if)#exit | Exit the interface mode. |
TOR1#configure terminal | Enter the config terminal. |
TOR1(config)#hostname TOR1 | Assign the hostname for the router. |
TOR1(config)#bridge 1 protocol rstp vlan-bridge | Create bridge. |
TOR1(config)#vlan database | Enter the VLAN database. |
TOR1(config-vlan)#vlan 2-1002 bridge 1 state enable | Create the VLANs. |
TOR1(config-vlan)#exit | Exit the VLAN database. |
TOR1(config)#int mlag1 | Create the MLAG interface. |
TOR1(config-if)#switchport | Configure the interface as Layer 2. |
TOR1(config-if)#bridge-group 1 | Assign the bridge to the interface. |
TOR1(config-if)#switchport mode trunk | Configure the interface as trunk mode. |
TOR1(config-if)#switchport trunk allowed vlan all | Configure the interface to allow all VLAN ids. |
TOR1(config-if)#exit | Exit the interface mode. |
TOR1(config)#int mlag2 | Create the MLAG interface. |
TOR1(config-if)#switchport | Configure the interface as Layer 2. |
TOR1(config-if)#bridge-group 1 | Assign the bridge to the interface. |
TOR1(config-if)#switchport mode trunk | Configure the interface as trunk mode. |
TOR1(config-if)#switchport trunk allowed vlan all | Configure the interface to allow all VLAN ids. |
TOR1(config-if)#exit | Exit the interface mode. |
TOR1(config)#int po1 | Create the port channel interface. |
TOR1(config-if)#switchport | Configure the interface as Layer 2. |
TOR1(config-if)#mlag 1 | Bind MLAG to the port channel. |
TOR1(config-if)#exit | Exit the interface mode. |
TOR1(config)#int po2 | Create the port channel interface |
TOR1(config-if)#switchport | Configure the interface as Layer 2. |
TOR1(config-if)#mlag 2 | Bind MLAG to the port channel. |
TOR1(config-if)#exit | Exit the interface mode. |
TOR1(config)#interface xe7 | Configure xe7 interface mode only if the IDL is required. |
TOR1(config-if)#switchport | Configure the interface as Layer 2 only if the IDL is required. |
TOR1(config-if)#exit | Exit the interface mode. |
TOR1(config-if)#interface xe10 | Configure xe10 interface mode only if the IDP is required.. |
TOR1(config-if)#ip address 2.2.2.2/24 | Configure source IP address for IDP only if the IDP is required. |
TOR1(config)#int xe15 | Enter the interface mode. |
TOR1(config-if)#channel-group 1 mode active | Add the interface as member of LAG interface. |
TOR1(config-if)#exit | Exit the interface mode. |
TOR1(config)#int xe11 | Enter the interface mode. |
TOR1(config-if)#channel-group 2 mode active | Add the interface as member of LAG interface. |
TOR1(config-if)#exit | Exit the interface mode. |
TOR1(config)#mcec domain configuration | Enter the MCEC mode. |
TOR1(config-mcec-domain)#domain-system-number 1 | Assign the domain system number for MLAG interface. |
TOR1(config-mcec-domain)#domain-address 1111.2222.3333 | Assign the domain address. |
TOR1(config-mcec-domain)#domain-hello-timeout short | Assign the domain hello timeout. |
TOR1(config-mcec-domain)#intra-domain-link xe7 | Assign the interface as IDL only if the IDP is required. |
TOR1(config-mcec-domain)#)#intra-domain-peer 2.2.2.3 source-address 2.2.2.2 | Configure source ip address for IDP only if the IDP is required. |
TOR1(config-mcec-domain)#exit | Exit the MCEC domain. |
TOR1(config-mcec-domain)#commit | Commit the configure on the node. |
TOR1(config)#exit | Exit the config terminal. |
TOR2#configure terminal | Enter the config terminal. |
TOR2(config)#hostname TOR2 | Assign the hostname for the router. |
TOR2(config)#bridge 1 protocol rstp vlan-bridge | Create bridge. |
TOR2(config)#vlan database | Enter the VLAN database. |
TOR2(config-vlan)#vlan 2-1002 bridge 1 state enable | Create the VLANs. |
TOR2(config-vlan)#exit | Exit the VLAN database. |
TOR2(config)#int mlag1 | Create the MLAG interface. |
TOR2(config-if)#switchport | Configure the interface as Layer 2 |
TOR2(config-if)#bridge-group 1 | Assign the bridge to the interface. |
TOR2(config-if)#switchport mode trunk | Configure the interface as trunk mode. |
TOR2(config-if)#switchport trunk allowed vlan all | Configure the interface to allow all VLAN ids. |
TOR2(config-if)#exit | Exit the interface mode. |
TOR2(config)#int mlag2 | Create the MLAG interface. |
TOR2(config-if)#switchport | Configure the interface as Layer 2. |
TOR2(config-if)#bridge-group 1 | Assign the bridge to the interface. |
TOR2(config-if)#switchport mode trunk | Configure the interface as trunk mode. |
TOR2(config-if)#switchport trunk allowed vlan all | Configure the interface to allow all VLAN ids. |
TOR2(config-if)#exit | Exit the interface mode. |
TOR2(config)#int po1 | Create the port channel interface |
TOR2(config-if)#switchport | Configure the interface as Layer 2 |
TOR2(config-if)#mlag 1 | Bind MLAG to the port channel. |
TOR2(config-if)#exit | Exit the interface mode. |
TOR2(config)#int po2 | Create the port channel interface. |
TOR2(config-if)#switchport | Configure the interface as Layer 2. |
TOR2(config-if)#mlag 2 | Bind MLAG to the port channel. |
TOR2(config-if)#exit | Exit the interface mode. |
TOR2(config)#interface xe7 | Enter the interface mode |
TOR2(config-if)#switchport | Configure the interface as Layer 2. |
TOR2(config-if)#interface xe10 | Enter the interface mode. |
TOR2(config-if)#ip address 2.2.2.3/24 | Configure source ip address for IDP only if the IDP is required. |
TOR2(config-if)#exit | Exit the interface mode. |
TOR2(config)#int xe32 | Enter the interface mode. |
TOR2(config-if)#channel-group 1 mode active | Add the interface as member of LAG interface. |
TOR2(config-if)#exit | Exit the interface mode. |
TOR2(config)#int xe5 | Enter the interface mode |
TOR2(config-if)#channel-group 2 mode active | Add the interface as member of LAG interface. |
TOR2(config-if)#exit | Exit the interface mode. |
TOR2(config)#mcec domain configuration | Enter the MCEC mode. |
TOR2(config-mcec-domain)#domain-system-number 2 | Assign the domain system number for MLAG interface. |
TOR2(config-mcec-domain)#domain-address 1111.2222.3333 | Assign the domain address. |
TOR2(config-mcec-domain)#domain-hello-timeout short | Assign the domain hello timeout. |
TOR2(config-mcec-domain)#intra-domain-link xe7 | Assign the interface as IDL only if the IDL is required. |
TOR2(config-mcec-domain)#)#intra-domain-peer 2.2.2.2 source-address 2.2.2.3 | Configure source ip address for IDP only if the IDP is required. |
TOR2(config-mcec-domain)#exit | Exit the MCEC domain. |
TOR2(config-mcec-domain)#commit | Commit the configure on the node. |
TOR2(config)#exit | Exit the config terminal. |
SW2#configure terminal | Enter the config terminal. |
SW2(config)#hostname SW2 | Assign the hostname for the router. |
SW2(config)#bridge 1 protocol rstp vlan-bridge | Create bridge. |
SW2(config)#vlan database | Enter the VLAN database |
SW2(config-vlan)#vlan 2-1002 bridge 1 state enable | Create the VLANs. |
SW2(config-vlan)#exit | Exit the VLAN database |
SW2(config)#int po2 | Enter the interface mode |
SW2(config-if)#switchport | Configure the interface as Layer 2 |
SW2(config-if)#bridge-group 1 | Assign the bridge to the interface. |
SW2(config-if)#switchport mode trunk | Configure the interface as trunk mode. |
SW2(config-if)#switchport trunk allowed vlan all | Configure the interface to allow all VLAN ids. |
SW2(config-if)#exit | Exit the interface mode. |
SW2(config)#int xe11 | Enter the interface mode. |
SW2(config-if)#channel-group 2 mode active | Add the interface as member of LAG interface. |
SW2(config-if)#int xe5 | Enter the interface mode. |
SW2(config-if)#channel-group 2 mode active | Add the interface as member of LAG interface. |
SW2(config-if)#commit | Commit the configure on the node. |
SW2(config-if)#exit | Exit the interface mode. |
#configure terminal | Enter configure mode. |
(config)#hardware-profile filter egress-l2 enable | Enable the hardware-profile filter |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config)#interface po2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe33 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe34 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
#configure terminal | Enter configure mode. |
(config)#hardware-profile filter egress-l2 enable | Enable the hardware-profile filter |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config)#interface po1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 | Associate the interface with bridge group 1. |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe5 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe6 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe7 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe8 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
#configure terminal | Enter configure mode. |
(config)#hardware-profile filter egress-l2 enable | Enable the hardware-profile filter |
(config)#interface mlag1 | Enter interface mode. |
(config-if)#mode active-active | Mode need to be configured as active-active |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface mlag2 | Enable the hardware-profile filter |
(config-if)#mode active-active | Mode need to be configured as active-active |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config)#interface mlag1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface mlag2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface po1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 1 | Enabling MLAG group number |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface po2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 2 | enabling Mlag group number |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe57 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe58 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe10 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe49 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#exit | Exit interface mode. |
(config)#mcec domain configuration | Entering MCEC mode |
(config-mcec-domain)#domain-address 1111.2222.3333 | Domain address for the mlag domain |
(config-mcec-domain)#intra-domain link xe49 | Intra domain line between mlag domain |
(config-mcec-domain)#domain-system-number 1 | Number to identify the node in a domain |
(config-mcec-domain)#commit | Commit the candidate configuration to the running configuration |
(config-mcec-domain)#exit | Exit MCEC mode |
#configure terminal | Enter configure mode. |
(config)#hardware-profile filter egress-l2 enable | Enable the hardware-profile filter |
(config)#interface mlag1 | Enter interface mode. |
(config-if)#mode active-active | Mode need to be configured as active-active |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode |
(config)#interface mlag2 | Enable the hardware-profile filter |
(config-if)#mode active-active | Mode need to be configured as active-active |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config)#interface mlag1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode |
(config)#bridge 1 protocol rstp vlan-bridge | Create RSTP bridge 1. |
(config)#vlan 2 bridge 1 state enable | Create VLAN 2. |
(config)#interface mlag1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface mlag2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
(config-if)#switchport trunk allowed vlan all | Enable all VLAN identifiers on this interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface po1 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 1 | Enabling Mlag group number |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface po2 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#mlag 2 | enabling MLAG group number |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe10 | Enter interface mode. |
(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe57 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe58 | Enter interface mode. |
(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#interface xe49 | Enter interface mode. |
(config-if)#switchport | Configure the interface as Layer 2 |
(config-if)#commit | Commit the candidate configuration to the running configuration |
(config-if)#exit | Exit interface mode. |
(config)#mcec domain configuration | Entering MCEC mode |
(config-mcec-domain)#domain-address 1111.2222.3333 | Domain address for the Mlag domain |
(config-mcec-domain)#intra-domain link xe49 | Intra domain Link between Mlag domains |
(config-mcec-domain)#domain-system-number 2 | Number to identify the node in domain |
(config-mcec-domain)#exit | Exit MCEC mode |
(config-mcec-domain)#commit | Commit the candidate configuration to the running configuration |
#configure terminal | Enter configure mode. |
(config)#hostname L2SW | Configuring host name |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN bridge on customer side |
(config)#vlan 2 bridge 1 state enable | Configure VLAN for the bridge |
(config)#interface sa1 | Enter the interface mode |
(config-if)#bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Enter the interface mode |
(config-if)#static-channel-group 1 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe9 | Enter the interface mode |
(config-if)#static-channel-group 1 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe11 | Enter the interface mode |
(config-if)#static-channel-group 1 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe22 | Enter the interface mode |
(config-if)#static-channel-group 1 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe47 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode hybrid | Configure the mode as hybrid |
(config-if)#switchport hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#exit | Exit the interface mode |
#configure terminal | Enter configure mode. |
(config)#hostname TOR1 | Configuring host name |
(config)#bridge 1 protocol provider-rstp edge | Create a PROVIDER-RSTP EDGE bridge |
(config)#vlan 2 bridge 1 state enable | Configure VLAN for the bridge |
(config)#vlan 200 type service point-point bridge 1 state enable | Configure SVLAN for the bridge |
(config)#cvlan registration table map1 bridge 1 | Configure CVLAN-SVLAN mapping registration table for the bridge |
(config-cvlan-registration)#cvlan 2 svlan 200 | Map CVLAN to SVLAN |
(config-cvlan-registration)#exit | Exit the config-cvlan-registration mode |
(config)#interface mlag1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode customer-edge hybrid | Configure the mode as customer-edge hybrid |
(config-if)#switchport customer-edge hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#switchport customer-edge vlan registration map1 | Map the CVLAN registration table into the MLAG interface |
(config-if)#mode active-standby | Configuring MLAG mode |
(config-if)#exit | Exit the interface mode |
(config)#interface mlag2 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-.if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode provider- network | Configure the mode as provider-network |
(config-if)#switchport provider-network allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#mode active-standby | Configuring MLAG mode |
(config-if)#exit | Exit the interface mode |
(config)#interface sa1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#mlag 1 | Map MLAG on SA interface |
(config-if)#exit | Exit the interface mode |
(config)#interface sa2 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#mlag 2 | Map MLAG on SA interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe1 | Enter the interface mode |
(config-if)#static-channel-group 2 | Map static channel-group to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe13 | Enter the interface mode |
(config-if)#static-channel-group 2 | Map static channel-group to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe9 | Enter the interface mode |
(config-if)#static-channel-group 1 | Map static channel-group to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe11 | Enter the interface mode |
(config-if)#static-channel-group 1 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface sa5 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#exit | Exit the interface mode |
(config)#interface xe3 | Enter the interface mode |
(config-if)#static-channel-group 5 | Map static channel-group to the interface |
(config)#interface xe5 | Enter the interface mode |
(config-if)#static-channel-group 5 | Map static channel-group to the interface |
(config-if)#exit | Exit the interface mode |
(config)#mcec domain configuration | Enter the MLAG domain configuration mode |
(config-mcec-domain)#domain-address 1111.2222.3333 | Configure the MLAG domain address |
(config-mcec-domain)#domain-system-number 1 | Configure MLAG domain system number |
(config-mcec-domain)#intra-domain-link sa5 | Configure the intra domain link |
#configure terminal | Enter configure mode. |
(config)#hostname TOR2 | Configuring host name |
(config)#bridge 1 protocol provider-rstp edge | Create a PROVIDER-RSTP EDGE bridge |
(config)#vlan 2 bridge 1 state enable | Configure VLAN for the bridge |
(config)#vlan 200 type service point-point bridge 1 state enable | Configure SVLAN for the bridge |
(config)#cvlan registration table map1 bridge 1 | Configure CVLAN-SVLAN mapping registration table for the bridge |
(config-cvlan-registration)#cvlan 2 svlan 200 | Map CVLAN to SVLAN |
(config-cvlan-registration)#exit | Exit the config-CVLAN-registration mode |
(config)#interface mlag1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode customer-edge hybrid | Configure the mode as customer-edge hybrid |
(config-if)#switchport customer-edge hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#switchport customer-edge vlan registration map1 | Map the CVLAN registration table into the MLAG interface |
(config-if)#mode active-standby | Configuring MLAG mode |
(config-if)#exit | Exit the interface mode |
(config)#interface mlag2 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 | Associate the interface to bridge |
(config-if)#switchport mode provider- network | Configure the mode as provider-network |
(config-if)#switchport provider-network allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#mode active-standby | Configuring MLAG mode |
(config-if)#exit | Exit the interface mode |
(config)#interface sa1 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#mlag 1 | Map MLAG on SA interface |
(config-if)#exit | Exit the interface mode |
(config)#interface sa2 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#mlag 2 | Map MLAG on SA interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe11 | Enter the interface mode |
(config-if)#static-channel-group 2 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe38 | Enter the interface mode |
(config-if)#static-channel-group 2 | Map static channel to the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Enter the interface mode |
(config-if)#static-channel-group 1 | Create static channel group |
(config-if)#exit | Exit the interface mode |
(config)#interface xe22 | Enter the interface mode |
(config-if)#static-channel-group 1 | Create static channel group |
(config-if)#exit | Exit the interface mode |
(config)#interface sa5 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#exit | Exit the interface mode |
(config)#interface xe3 | Enter the interface mode |
(config-if)#static-channel-group 5 | Map static channel-group to the interface |
(config)#interface xe5 | Enter the interface mode |
(config-if)#static-channel-group 5 | Enter the interface mode |
(config-if)#exit | Exit the interface mode |
(config)#mcec domain configuration | Enter the MLAG domain configuration mode |
(config-mcec-domain)#domain-address 1111.2222.3333 | Configure the MLAG domain address |
(config-mcec-domain)#domain-system-number 2 | Configure MLAG domain system number |
(config-mcec-domain)#intra-domain-link sa5 | Configure the intra domain link |
(config-if)#exit | Exit the interface mode |
#configure terminal | Enter configure mode. |
(config)#hostname LEAF | Configuring host name |
(config)#bridge 1 protocol provider-rstp edge | Create a PROVIDER-RSTP EDGE bridge |
(config)#vlan 2 bridge 1 state enable | Configure VLAN for the bridge |
(config)#vlan 200 type service point-point bridge 1 state enable | Configure SVLAN for the bridge |
(config)#cvlan registration table map1 bridge 1 | Configure CVLAN-SVLAN mapping registration table for the bridge |
(config-cvlan-registration)#cvlan 2 svlan 200 | Map CVLAN to SVLAN |
(config-cvlan-registration)#exit | Exit the config-CVLAN-registration mode |
(config)#interface sa2 | Enter the interface mode |
(config-if)#swtichport | Make the interface a switch port |
(config-if)#bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode provider-network | Configure the mode as provider-network |
(config-if)#)#switchport provider-network allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe1 | Enter the interface mode |
(config-if)#static-channel-group 2 | Map the interface to the static channel-group |
(config-if)#exit | Exit the interface mode |
(config)#interface xe13 | Enter the interface mode |
(config-if)#static-channel-group 2 | Create static channel group |
(config-if)#exit | Exit the interface mode |
(config)#interface xe11 | Enter the interface mode |
(config-if)#static-channel-group 2 | Map the interface to the static channel-group |
(config-if)#exit | Exit the interface mode |
(config)#interface xe38 | Enter the interface mode |
(config-if)#static-channel-group 2 | Create static channel group |
(config-if)#exit | Exit the interface mode |
(config)#interface xe47 | Enter the interface mode |
(config-if)#switchport | Make the interface as switch port |
(config-if)#bridge-group 1 spanning-tree disable | Disable the spanning-tree for the interface |
(config-if)#switchport mode customer-edge hybrid | Configure the mode as customer-edge hybrid |
(config-if)#switchport customer-edge hybrid allowed vlan all | Configure allowed VLAN all on the interface |
(config-if)#switchport customer-edge vlan registration map1 | Map the CVLAN registration table into the MLAG interface |
(config-if)#exit | Exit the interface mode |
#configure terminal | Enter configure mode. |
TOR1(config)#bridge 1 protocol provider-rstp edge | Create provider RSTP bridge |
TOR1(config)#vlan 2-3990 type customer bridge 1 state enable | Enable customer VLAN for bridge |
TOR1(config)#vlan 2-3990 type service point- point bridge 1 state enable | Enable service VLAN for bridge |
TOR1(config)#cvlan registration table map1 bridge 1 | Create registration table |
TOR1(config-cvlan-registration)#cvlan 2- 3990 svlan 3990 | Map CVLAN to svlan |
TOR1(config-cvlan-registration)#exit | Exit the CVLAN registration table mode |
TOR1(config-if)#interface mlag1 | Enter MLAG interface |
TOR1(config-if)#switchport | Configure interface as switchport |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#interface mlag2 | Enter MLAG interface |
TOR1(config-if)#switchport | Configure interface as switchport |
TOR1(config-if)#bridge-group 1 | Associate the interface with bridge group 1 |
TOR1(config-if)#switchport mode provider- network | Set the switching characteristics of this interface to provider network |
TOR1(config-if)#switchport provider-network allowed vlan all | Set the switching characteristics of this interface to provider network and allow all VLAN |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#interface po1 | Enter dynamic LAG interface |
TOR1(config-if)#switchport | Configure interface as switchport |
TOR1(config-if)#mlag 1 | Enable MLAG group number |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config-if)#interface po2 | Enter dynamic LAG interface |
TOR1(config-if)#switchport | Configure interface as switchport |
TOR1(config-if)#mlag 2 | Enable MLAG group number |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#interface po3 | Enter dynamic LAG interface |
TOR1(config-if)#switchport | Configure interface as switchport |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#interface xe2 | Enter interface mode |
TOR1(config-if)#channel-group 3 mode active | Make part of channel group 3 |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#interface xe3 | Enter interface mode |
TOR1(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config-if)#interface xe49/1 | Enter interface mode |
TOR1(config-if)#channel-group 2 mode active | Enable channel-group 2 |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#mcec domain configuration | Enter MCEC mode |
TOR1(config-mcec-domain)#domain-address 2222.3333.4444 | Domain address for the MLAG domain |
TOR1(config-mcec-domain)#domain-system- number 1 | Number to identify the node in a domain |
TOR1(config-mcec-domain)#intra-domain-link po3 | Intra domain line between MLAG domain |
TOR1(config)#hardware-profile filter ingress-arp enable | Enable globally hardware profile for ARP |
TOR1(config)#arp access-list cep | Create access list with name as CEP |
TOR1(config-arp-acl)#30 permit request ip any mac host 0000.2A6C.668D vlan 3990 inner- vlan 2 | Create permit rule for particular ARP request |
TOR1(config-arp-acl)#40 permit response ip any any mac host 0000.2A6C.668D host 0000.2A6C.7202 vlan 3990 inner-vlan 2 | Create permit rule for particular ARP response |
TOR1(config)#arp access-list pnp | Create access list with name as PNP |
TOR1(config-arp-acl)#20 permit request ip any mac host 0000.2A6C.7202 vlan 3990 inner- vlan 2 | Create permit rule for particular ARP request |
TOR1(config-arp-acl)#30 permit response ip any any mac host 0000.2A6C.7202 host 0000.2A6C.668D vlan 3990 inner-vlan 2 | Create permit rule for particular ARP response |
TOR1(config-if)#interface mlag1 | Enter mlag1 interface |
TOR1(config-if)#arp access-group cep in | Attach rule with access-group CEP |
TOR1(config-if)#interface mlag2 | Enter mlag2 interface |
TOR1(config-if)#arp access-group pnp in | Attach rule with access-group PNP |
#configure terminal | Enter configure mode. |
TOR2(config)#bridge 1 protocol provider-rstp edge | Create provider RSTP bridge |
TOR2(config)#vlan 2-3990 type customer bridge 1 state enable | Enable customer VLAN for bridge |
TOR2(config)#vlan 2-3990 type service point- point bridge 1 state enable | Enable service VLAN for bridge |
TOR2(config)#cvlan registration table map1 bridge 1 | Create registration table |
TOR2(config-cvlan-registration)#cvlan 2- 3990 svlan 3990 | Map CVLAN to svlan |
TOR2(config-cvlan-registration)#exit | Exit the CVLAN registration table mode |
TOR2(config)#interface mlag1 | Enter MLAG interface |
TOR2(config-if)#switchport | Configure interface as switchport |
TOR2(config-if)#bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1and disabling spanning-tree |
TOR2(config-if)#switchport mode customer- edge hybrid | Set the switching characteristics of this interface to customer- edge hybrid |
TOR2(config-if)#switchport customer-edge hybrid allowed vlan all | Set the switching characteristics of this interface to customer- edge hybrid and allow VLAN all |
TOR2(config-if)#switchport customer-edge vlan registration map1 | Configure the registration table mapping on MLAG interface |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface mlag2 | Enter MLAG interface |
TOR2(config-if)#switchport | Configure interface as switchport |
TOR2(config-if)#bridge-group 1 | Associate the interface with bridge group 1 |
TOR2(config-if)#switchport mode provider- network | Set the switching characteristics of this interface to provider network |
TOR2(config-if)#switchport provider-network allowed vlan all | Set the switching characteristics of this interface to provider network and allow all VLAN |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface po1 | Enter dynamic LAG interface |
TOR2(config-if)#switchport | Configure interface as switchport |
TOR2(config-if)#mlag 1 | Enable MLAG group number |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface po2 | Enter dynamic LAG interface |
TOR2(config-if)#switchport | Configure interface as switchport |
TOR2(config-if)#mlag 2 | Enable MLAG group number |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface po3 | Enter dynamic LAG interface |
TOR2(config-if)#switchport | Configure interface as switchport |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface xe2 | Enter interface mode |
TOR2(config-if)#channel-group 3 mode active | Make part of channel group 3 |
TOR2(config-if)#interface xe3 | Enter interface mode |
TOR2(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#Interface xe49/1 | Enter interface mode |
TOR2(config-if)#channel-group 2 mode active | Enable channel-group 2 |
TOR2(config)#mcec domain configuration | Configure MCEC domain information |
TOR2(config-mcec-domain)#domain-address 2222.3333.4444 | Domain address for the MLAG domain |
TOR2(config-mcec-domain)#domain-system- number 2 | Number to identify the node in a domain |
TOR2(config-mcec-domain)#intra-domain-link po3 | Intra domain line between MLAG domain |
TOR2(config)#hardware-profile filter ingress-arp enable | Enable globally hardware profile for ARP |
TOR2(config)#arp access-list cep | Create access list with name as CEP |
TOR2(config-arp-acl)#30 permit request ip any mac host 0000.2A6C.668D vlan 3990 inner- vlan 2 | Create permit rule for particular ARP request |
TOR2(config-arp-acl)#40 permit response ip any any mac host 0000.2A6C.668D host 0000.2A6C.7202 vlan 3990 inner-vlan 2 | Create permit rule for particular ARP response |
TOR2(config)#arp access-list pnp | Create access list with name as PNP |
TOR2(config-arp-acl)#20 permit request ip any mac host 0000.2A6C.7202 vlan 3990 inner- vlan 2 | Create permit rule for particular ARP request |
TOR2(config-arp-acl)#30 permit response ip any any mac host 0000.2A6C.7202 host 0000.2A6C.668D vlan 3990 inner-vlan 2 | Create permit rule for particular ARP response |
TOR2(config-if)#interface mlag1 | Enter mlag1 interface |
TOR2(config-if)#arp access-group cep in | Attach rule with access-group CEP |
TOR2(config-if)#interface mlag2 | Enter mlag2 interface |
TOR2(config-if)#arp access-group pnp in | Attach rule with access-group PNP |
#configure terminal | Enter configure mode. |
SW1(config)#bridge 1 protocol rstp vlan- bridge | Configure the RSTP VLAN bridge |
SW1(config)#vlan 2-3990 type customer bridge 1 state enable | Enable customer VLAN for bridge |
SW1(config-if)#interface po1 | Enter dynamic LAG interface |
SW1(config-if)#switchport | Configure interface as switchport |
SW1(config-if)#bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1and disabling spanning-tree |
SW1(config-if)#switchport mode hybrid | Set the switching characteristics of this interface hybrid |
SW1(config-if)#switchport hybrid allowed vlan all | Set the switching characteristics of this interface hybrid and allowing all VLAN |
SW1(config-if)#exit | Exit the interface mode |
SW1(config)#interface xe1 | Enter interface mode |
SW1(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW1(config-if)#exit | Exit the interface mode |
SW1(config)#interface xe2 | Enter interface mode |
SW1(config-if)#channel-group 1 mode active | Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system. |
SW1(config-if)#exit | Exit the interface mode |
SW1(config)#interface xe3 | Enter interface mode |
SW1(config-if)#switchport | Configure interface as switchport |
SW1(config-if)#bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1and disabling spanning-tree |
SW1(config-if)#switchport mode hybrid | Set the switching characteristics of this interface hybrid |
SW1(config-if)#switchport hybrid allowed vlan all | Set the switching characteristics of this interface hybrid and allowing all VLAN |
SW1(config-if)#exit | Exit the interface mode |
#configure terminal | Enter configure mode. |
Leaf(config)#bridge 1 protocol provider-rstp edge | Configure the RSTP VLAN bridge |
Leaf(config)#vlan 2-3990 type customer bridge 1 state enable | Enable customer VLAN for bridge |
Leaf(config)#vlan 2-3990 type service point- point bridge 1 state enable | Enable service VLAN for bridge |
Leaf(config)#cvlan registration table map1 bridge 1 | Create registration table |
Leaf(config-cvlan-registration)#cvlan 2- 3990 svlan 3990 | Map CVLAN to SVLAN |
Leaf(config-if)#exit | Exit the CVLAN registration table mode |
Leaf(config)#interface po2 | Enter interface mode |
Leaf(config-if)#switchport | Configure interface as switchport |
Leaf(config-if)#bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1and disabling spanning-tree |
Leaf(config-if)#switchport mode provider- network | Set the switching characteristics of this interface provider network |
Leaf(config-if)#switchport provider-network allowed vlan all | Set the switching characteristics of this interface provider and allowing all VLAN |
Leaf(config-if)#exit | Exit the interface mode |
Leaf(config)#interface xe1 | Enter interface mode |
Leaf(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
Leaf(config-if)#exit | Exit the interface mode |
Leaf(config)#interface xe2 | Enter interface mode |
Leaf(config-if)#channel-group 2 mode active | Add this interface to channel group 2 and enable link aggregation so that it can be selected for aggregation by the local system. |
Leaf(config-if)#exit | Exit the interface mode |
Leaf(config)#Interface xe3 | Enter interface mode |
Leaf(config-if)#switchport | Configure interface as switchport |
Leaf(config-if)#bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1and disabling spanning-tree |
Leaf(config-if)#switchport mode customer- edge hybrid | Set the switching characteristics of this interface to customer- edge hybrid |
Leaf(config-if)#switchport customer-edge hybrid allowed vlan all | Set the switching characteristics of this interface to customer- edge hybrid and allow vlan all |
Leaf(config-if)#switchport customer-edge vlan registration map1 | Configure the registration table mapping on mlag interface |
Leaf(config-if)#exit | Exit the interface mode |