PE1#configure terminal | Enter configure mode. |
PE1(config)#interface lo | Enter the interface mode for the loopback interface lo. |
PE1(config-if)#ip address 1.1.1.1/32 secondary | Configure a secondary IP address, 1.1.1.1/32, on the loopback interface. |
PE1(config-if)#exit | Exit interface mode lo. |
PE1(config)#commit | Commit the transaction. |
PE1(config)#router ldp | Enter the Router LDP mode. |
PE1(config-router)#router-id 1.1.1.1 | Set the router ID for LDP to 1.1.1.1. |
PE1(config-router)#targeted-peer ipv4 7.7.7.7 | Configure targeted peer for LDP using IPv4 addresses. |
PE1(config-router-targeted-peer)#exit-targeted-peer-mode | Exit router targeted-peer-mode. |
PE1(config-router)#targeted-peer ipv4 8.8.8.8 | Configure targeted peer for LDP using IPv4 addresses. |
PE1(config-router-targeted-peer)#exit-targeted-peer-mode | Exit router targeted-peer-mode. |
PE1(config-router)#exit | Exit router LDP mode and return to the configure mode. |
PE1(config)#commit | Commit the transaction. |
PE1(config)#evpn mpls enable | Activate the EVPN MPLS functionality on PE1, enabling it to participate in EVPN MPLS services. |
PE1(config)#commit | Commit candidate configuration to be running configuration. |
PE1(config)#evpn mpls vtep-ip-global 1.1.1.1 | Configure the global VTEP IP address 1.1.1.1, associating it with the loopback IP. |
PE1(config)#hardware-profile filter evpn-mpls-mh enable | Enable hardware-profile filter for EVPN MPLS multihoming. |
PE1(config)#evpn mpls multihoming enable | Activate the EVPN MPLS multihoming functionality, allowing PE1 to support multihomed EVPN MPLS services. |
PE1(config)#commit | Commit the transaction. |
PE1(config)#interface xe3 | Enter interface mode xe3. |
PE1(config-if)#ip address 10.1.0.1/16 | Configure an IP address, 10.1.0.1/16, on the interface xe3. |
PE1(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface, facilitating the exchange of label information between devices in the network. |
PE1(config-if)#label-switching | Enable label switching on the interface to enable MPLS-based packet forwarding. |
PE1(config-if)#exit | Exit interface mode xe3. |
PE1(config)#commit | Commit the transaction. |
PE1(config)#router ospf 1 | Enter the router OSPF mode. Configure PE1 to run OSPF with process ID 1. |
PE1(config-router)#ospf router-id 1.1.1.1 | Set the OSPF router ID to 1.1.1.1, identifying PE1 within the OSPF network. |
PE1(config-router)#network 1.1.1.1/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
PE1(config-router)#network 10.1.0.0/16 area 0.0.0.0 | Advertise network address in OSPF. |
PE1(config-router)#exit | Exit router OSPF mode and return to configure mode. |
PE1(config)#commit | Commit the transaction. |
PE1(config)#router bgp 1 | Enter the Router BGP mode, ASN: 1 |
PE1(config-router)#bgp router-id 1.1.1.1 | Configure BGP router ID 1.1.1.1, identifying PE1 within the BGP network. |
PE1(config-router)#neighbor 7.7.7.7 remote-as 1 | Configure neighbor 7.7.7.7 as an iBGP neighbor with their remote AS number 1. |
PE1(config-router)#neighbor 7.7.7.7 update-source lo | Configure neighbor 7.7.7.7 as an iBGP neighbor, specifying the source of routing updates as the loopback interface. |
PE1(config-router)#neighbor 8.8.8.8 remote-as 1 | Configure neighbor 8.8.8.8 as an iBGP neighbor with their remote AS number 1. |
PE1(config-router)#neighbor 8.8.8.8 update-source lo | Configure neighbor 8.8.8.8 as an iBGP neighbor, specifying the source of routing updates as the loopback interface. |
PE1(config-router)#address-family l2vpn evpn | Enter into address family mode for L2VPN EVPN. |
PE1(config-router-af)#neighbor 7.7.7.7 activate | Activate EVPN for iBGP neighbor 7.7.7.7 within the address family mode, ensuring that EVPN address family is enabled for the neighbor. |
PE1(config-router-af)#neighbor 8.8.8.8 activate | Activate EVPN for iBGP neighbor 8.8.8.8 within the address family mode, ensuring that EVPN address family is enabled for the neighbor. |
PE1(config-router-af)#exit | Exit address family mode and return to the router BGP mode. |
PE1(config-router)#commit | Commit the transaction. |
PE1(config-router)#exit | Exit router BGP mode and return to the configure mode. |
PE1(config)#mac vrf vrf2 | Enter VRF mode named vrf2. |
PE1(config-vrf)#rd 1.1.1.1:2 | Configure Route-Distinguisher value of 1.1.1.1:2. |
PE1(config-vrf)#route-target both 2:2 | Configure import and export values for the vrf2 as 2:2. |
PE1(config-vrf)#exit | Exit VRF mode and return to the configure mode. |
PE1(config)#commit | Commit the transaction. |
PE1(config)#evpn mpls id 52 xconnect target-mpls-id 2 | Configure the EVPN-VPWS identifier with a source identifier of 52 and a target identifier of 2. |
PE1(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf2 | Map VRF vrf2 to the EVPN-VPWS identifier |
PE1(config-evpn-mpls)#commit | Commit the transaction. |
PE1(config-evpn-mpls)#exit | Exit the EVPN MPLS mode and return to the configure mode. |
PE1(config)#interface xe33 | Enter interface mode xe33. |
PE1(config-if)#interface xe33.2 switchport | Create a Layer 2 sub-interface xe33.2 within the physical interface xe33. |
PE1(config-if)#description access-side-int | Provide a description for the interface. |
PE1(config-if)#encapsulation dot1q 2 | Set encapsulation to dot1q with VLAN ID 2. |
PE1(config-if)#access-if-evpn | Enter the access mode for EVPN MPLS ID configuration. |
PE1(config-acc-if-evpn)#map vpn-id 52 | Map VPN-ID 52. |
PE1(config-acc-if-evpn)#exit | Exit the access mode and return to the interface mode. |
PE1(config-if)#exit | Exit interface mode xe33 and return to the configure mode. |
PE1(config)#commit | Commit the transaction. |
P#configure terminal | Enter configure mode. |
P(config)#interface lo | Enter the interface mode for the loopback interface lo. |
P(config-if)#ip address 2.2.2.2/32 secondary | Configure a secondary IP address, 2.2.2.2/32, on the loopback interface. |
P(config-if)#exit | Exit interface mode lo. |
P(config)#commit | Commit the transaction. |
P(config)#router ldp | Enter the Router LDP mode. |
P(config-router)#router-id 2.2.2.2 | Set the router ID for LDP to 2.2.2.2. |
P(config-router)#exit | Exit router LDP mode and return to the configure mode. |
P(config)#commit | Commit the transaction. |
P(config)#interface xe6 | Enter interface mode xe6. |
P(config-if)#ip address 10.1.0.2/16 | Configure an IP address, 10.1.0.2/16, on the interface xe6. |
P(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface, facilitating the exchange of label information between devices in the network. |
P(config-if)#label-switching | Enable label switching on the interface to enable MPLS-based packet forwarding. |
P(config-if)#exit | Exit interface mode xe6. |
P(config)#commit | Commit the transaction. |
P(config)#interface xe21 | Enter interface mode xe21. |
P(config-if)#ip address 123.1.1.1/24 | Configure an IP address, 123.1.1.1/24, on the interface xe21. |
P(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface, facilitating the exchange of label information between devices in the network. |
P(config-if)#label-switching | Enable label switching on the interface to enable MPLS-based packet forwarding. |
P(config-if)#exit | Exit interface mode xe21. |
P(config)#commit | Commit the transaction. |
P(config)#interface xe20 | Enter interface mode xe20. |
P(config-if)#ip address 124.1.1.1/24 | Configure an IP address, 124.1.1.1/24, on the interface xe20. |
P(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface, facilitating the exchange of label information between devices in the network. |
P(config-if)#label-switching | Enable label switching on the interface to enable MPLS-based packet forwarding. |
P(config-if)#exit | Exit interface mode xe20. |
P(config)#commit | Commit the transaction. |
P(config)#router ospf 1 | Enter the router OSPF mode. Configure P to run OSPF with process ID 1. |
P(config-router)#ospf router-id 2.2.2.2 | Set the OSPF router ID to 2.2.2.2, identifying P within the OSPF network. |
P(config-router)#network 2.2.2.2/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
P(config-router)#network 10.1.0.2/16 area 0.0.0.0 | Advertise network address in OSPF. |
P(config-router)#network 123.1.1.1/24 area 0.0.0.0 | Advertise network address in OSPF. |
P(config-router)#network 124.1.1.1/24 area 0.0.0.0 | Advertise network address in OSPF. |
P(config-router)#exit | Exit router OSPF mode and return to the configure mode. |
P(config)#commit | Commit the transaction. |
PE2#configure terminal | Enter configure mode. |
PE2(config)#interface lo | Enter the interface mode for the loopback interface lo. |
PE2(config-if)#ip address 7.7.7.7/32 secondary | Configure a secondary IP address, 7.7.7.7/32, on the loopback interface. |
PE2(config-if)#exit | Exit interface mode lo. |
PE2(config)#commit | Commit the transaction. |
PE2(config)#router ldp | Enter the Router LDP mode. |
PE2(config-router)#router-id 7.7.7.7 | Set the router ID for LDP to 7.7.7.7. |
PE2(config-router)#targeted-peer ipv4 1.1.1.1 | Configure targeted peer for LDP using IPv4 addresses. |
PE2(config-router-targeted-peer)#exit-targeted-peer-mode | Exit router targeted-peer-mode. |
PE2(config-router)#targeted-peer ipv4 8.8.8.8 | Configure targeted peer for LDP using IPv4 addresses. |
PE2(config-router-targeted-peer)#exit-targeted-peer-mode | Exit router targeted-peer-mode. |
PE2(config-router)#exit | Exit router LDP mode and return to the configure mode. |
PE2(config)#commit | Commit the transaction. |
PE2(config)#evpn mpls enable | Activate the EVPN MPLS functionality on PE2, enabling it to participate in EVPN MPLS services. |
PE2(config)#commit | Commit candidate configuration to be running configuration. |
PE2(config)#evpn mpls vtep-ip-global 7.7.7.7 | Configure the global VTEP IP address 7.7.7.7, associating it with the loopback IP. |
PE2(config)#hardware-profile filter evpn-mpls-mh enable | Enable hardware-profile filter for EVPN MPLS multihoming. |
PE2(config)#evpn mpls multihoming enable | Activate the EVPN MPLS multihoming functionality, allowing PE2 to support multihomed EVPN MPLS services. |
PE2(config)#commit | Commit the transaction. |
PE2(config)#interface xe21 | Enter interface mode xe21. |
PE2(config-if)#ip address 123.1.1.2/24 | Configure an IP address, 123.1.1.2/24, on the interface xe21. |
PE2(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface, facilitating the exchange of label information between devices in the network. |
PE2(config-if)#label-switching | Enable label switching on the interface to enable MPLS-based packet forwarding. |
PE2(config-if)#exit | Exit interface mode xe21. |
PE2(config)#commit | Commit the transaction. |
PE2(config)#router ospf 1 | Enter the router OSPF mode. Configure PE2 to run OSPF with process ID 1. |
PE2(config-router)#ospf router-id 7.7.7.7 | Set the OSPF router ID to 7.7.7.7, identifying PE2 within the OSPF network. |
PE2(config-router)#network 7.7.7.7/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
PE2(config-router)#network 123.1.1.0/24 area 0.0.0.0 | Advertise network address in OSPF. |
PE2(config-router)#exit | Exit router OSPF mode and return to configure mode. |
PE2(config)#commit | Commit the transaction. |
PE2(config)#router bgp 1 | Enter the Router BGP mode, ASN: 1 |
PE2(config-router)#bgp router-id 7.7.7.7 | Configure BGP router ID 7.7.7.7, identifying PE2 within the BGP network. |
PE2(config-router)#neighbor 1.1.1.1 remote-as 1 | Configure neighbor 1.1.1.1 as an iBGP neighbor with their remote AS number 1. |
PE2(config-router)#neighbor 1.1.1.1 update-source lo | Configure neighbor 1.1.1.1 as an iBGP neighbor, specifying the source of routing updates as the loopback interface. |
PE2(config-router)#neighbor 8.8.8.8 remote-as 1 | Configure neighbor 8.8.8.8 as an iBGP neighbor with their remote AS number 1. |
PE2(config-router)#neighbor 8.8.8.8 update-source lo | Configure neighbor 8.8.8.8 as an iBGP neighbor, specifying the source of routing updates as the loopback interface. |
PE2(config-router)#address-family l2vpn evpn | Enter into address family mode for L2VPN EVPN. |
PE2(config-router-af)#neighbor 1.1.1.1 activate | Activate EVPN for iBGP neighbor 1.1.1.1 within the address family mode, ensuring that EVPN address family is enabled for the neighbor. |
PE2(config-router-af)#neighbor 8.8.8.8 activate | Activate EVPN for iBGP neighbor 8.8.8.8 within the address family mode, ensuring that EVPN address family is enabled for the neighbor. |
PE2(config-router-af)#exit | Exit address family mode and return to the router BGP mode. |
PE2(config-router)#commit | Commit the transaction. |
PE2(config-router)#exit | Exit router BGP mode and return to the configure mode. |
PE2(config)#mac vrf vrf2 | Enter VRF mode named vrf2. |
PE2(config-vrf)#rd 7.7.7.7:2 | Configure Route-Distinguisher value of 7.7.7.7:2. |
PE2(config-vrf)#route-target both 2:2 | Configure import and export values for the vrf2 as 2:2. |
PE2(config-vrf)#exit | Exit VRF mode and return to the configure mode. |
PE2(config)#commit | Commit the transaction. |
PE2(config)#evpn mpls id 2 xconnect target-mpls-id 52 | Configure the EVPN-VPWS identifier with a source identifier of 2 and a target identifier of 52. |
PE2(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf2 | Map VRF vrf2 to the EVPN-VPWS identifier |
PE2(config-evpn-mpls)#commit | Commit the transaction. |
PE2(config-evpn-mpls)#exit | Exit the EVPN MPLS mode and return to the configure mode. |
PE2(config)#interface po1 | Enter the port channel interface mode for po1 |
PE2(config-if)#load-interval 30 | Set the load interval to 30. |
PE2(config-if)#evpn multi-homed system-mac 0000.aaaa.bbbc | Configure the system-mac address 0000.aaaa.bbbc which plays a role in load balancing. |
PE2(config-if)#interface po1.2 switchport | Create a Layer 2 sub-interface po1.2 within the port channel. |
PE2(config-if)#encapsulation dot1q 2 | Set encapsulation to dot1q with VLAN ID 2. |
PE2(config-if)#access-if-evpn | Enter the access mode for EVPN MPLS ID configuration. |
PE2(config-acc-if-evpn)#map vpn-id 2 | Map VPN-ID 2. |
PE2(config-acc-if-evpn)#exit | Exit the access mode and return to the interface mode. |
PE2(config-if)#exit | Exit interface mode po1 and return to the configure mode. |
PE2(config)#commit | Commit the transaction. |
PE3#configure terminal | Enter configure mode. |
PE3(config)#interface lo | Enter the interface mode for the loopback interface lo. |
PE3(config-if)#ip address 8.8.8.8/32 secondary | Configure a secondary IP address, 8.8.8.8/32, on the loopback interface. |
PE3(config-if)#exit | Exit interface mode lo. |
PE3(config)#commit | Commit the transaction. |
PE3(config)#router ldp | Enter the Router LDP mode. |
PE3(config-router)#router-id 8.8.8.8 | Set the router ID for LDP to 7.7.7.7. |
PE3(config-router)#targeted-peer ipv4 1.1.1.1 | Configure targeted peer for LDP using IPv4 addresses. |
PE3(config-router-targeted-peer)#exit-targeted-peer-mode | Exit router targeted-peer-mode. |
PE3(config-router)#targeted-peer ipv4 7.7.7.7 | Configure targeted peer for LDP using IPv4 addresses. |
PE3(config-router-targeted-peer)#exit-targeted-peer-mode | Exit router targeted-peer-mode. |
PE3(config-router)#exit | Exit router LDP mode and return to the configure mode. |
PE3(config)#commit | Commit the transaction. |
PE3(config)#evpn mpls enable | Activate the EVPN MPLS functionality on PE3, enabling it to participate in EVPN MPLS services. |
PE3(config)#commit | Commit candidate configuration to be running configuration. |
PE3(config)#evpn mpls vtep-ip-global 8.8.8.8 | Configure the global VTEP IP address 8.8.8.8, associating it with the loopback IP. |
PE3(config)#hardware-profile filter evpn-mpls-mh enable | Enable hardware-profile filter for EVPN MPLS multihoming. |
PE3(config)#evpn mpls multihoming enable | Activate the EVPN MPLS multihoming functionality, allowing PE3 to support multihomed EVPN MPLS services. |
PE3(config)#commit | Commit the transaction. |
PE3(config)#interface xe5 | Enter interface mode xe5. |
PE3(config-if)#ip address 124.1.1.2/24 | Configure an IP address, 124.1.1.2/24, on the interface xe5. |
PE3(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface, facilitating the exchange of label information between devices in the network. |
PE3(config-if)#label-switching | Enable label switching on the interface to enable MPLS-based packet forwarding. |
PE3(config-if)#exit | Exit interface mode xe5. |
PE3(config)#interface xe4 | Enter the interface mode for xe4. |
PE3(config-if)#channel-group 1 mode active | Attach LAG interface xe4. |
PE3(config-if)#exit | Exit interface mode xe4 and return to the configure mode. |
PE3(config)#commit | Commit the transaction. |
PE3(config)#router ospf 1 | Enter the router OSPF mode. Configure PE3 to run OSPF with process ID 1. |
PE3(config-router)#ospf router-id 8.8.8.8 | Set the OSPF router ID to 8.8.8.8, identifying PE3 within the OSPF network. |
PE3(config-router)#network 8.8.8.8/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
PE3(config-router)#network 124.1.1.0/24 area 0.0.0.0 | Advertise network address in OSPF. |
PE3(config-router)#exit | Exit router OSPF mode and return to configure mode. |
PE3(config)#commit | Commit the transaction. |
PE3(config)#router bgp 1 | Enter the Router BGP mode, ASN: 1 |
PE3(config-router)#bgp router-id 8.8.8.8 | Configure BGP router ID 8.8.8.8, identifying PE3 within the BGP network. |
PE3(config-router)#neighbor 1.1.1.1 remote-as 1 | Configure neighbor 1.1.1.1 as an iBGP neighbor with their remote AS number 1. |
PE3(config-router)#neighbor 1.1.1.1 update-source lo | Configure neighbor 1.1.1.1 as an iBGP neighbor, specifying the source of routing updates as the loopback interface. |
PE3(config-router)#neighbor 7.7.7.7 remote-as 1 | Configure neighbor 7.7.7.7 as an iBGP neighbor with their remote AS number 1. |
PE3(config-router)#neighbor 7.7.7.7 update-source lo | Configure neighbor 7.7.7.7 as an iBGP neighbor, specifying the source of routing updates as the loopback interface. |
PE3(config-router)#address-family l2vpn evpn | Enter into address family mode for L2VPN EVPN. |
PE3(config-router-af)#neighbor 1.1.1.1 activate | Activate EVPN for iBGP neighbor 1.1.1.1 within the address family mode, ensuring that EVPN address family is enabled for the neighbor. |
PE3(config-router-af)#neighbor 7.7.7.7 activate | Activate EVPN for iBGP neighbor 7.7.7.7 within the address family mode, ensuring that EVPN address family is enabled for the neighbor. |
PE3(config-router-af)#exit | Exit address family mode and return to the router BGP mode. |
PE3(config-router)#commit | Commit the transaction. |
PE3(config-router)#exit | Exit router BGP mode and return to the configure mode. |
PE3(config)#mac vrf vrf2 | Enter VRF mode named vrf2. |
PE3(config-vrf)#rd 8.8.8.8:2 | Configure Route-Distinguisher value of 8.8.8.8:2. |
PE3(config-vrf)#route-target both 2:2 | Configure import and export values for the vrf2 as 2:2. |
PE3(config-vrf)#exit | Exit VRF mode and return to the configure mode. |
PE3(config)#commit | Commit the transaction. |
PE3(config)#evpn mpls id 2 xconnect target-mpls-id 52 | Configure the EVPN-VPWS identifier with a source identifier of 2 and a target identifier of 52. |
PE3(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf2 | Map VRF vrf2 to the EVPN-VPWS identifier |
PE3(config-evpn-mpls)#commit | Commit the transaction. |
PE3(config-evpn-mpls)#exit | Exit the EVPN MPLS mode and return to the configure mode. |
PE3(config)#interface po1 | Enter the port channel interface mode for po1 |
PE3(config-if)#load-interval 30 | Set the load interval to 30. |
PE3(config-if)#evpn multi-homed system-mac 0000.aaaa.bbbc | Configure the system-mac address 0000.aaaa.bbbc which plays a role in load balancing. |
PE3(config-if)#interface po1.2 switchport | Create a Layer 2 sub-interface po1.2 within the port channel. |
PE3(config-if)#encapsulation dot1q 2 | Set encapsulation to dot1q with VLAN ID 2. |
PE3(config-if)#access-if-evpn | Enter the access mode for EVPN MPLS ID configuration. |
PE3(config-acc-if-evpn)#map vpn-id 2 | Map VPN-ID 2. |
PE3(config-acc-if-evpn)#exit | Exit the access mode and return to the interface mode. |
PE3(config-if)#exit | Exit interface mode po1 and return to the configure mode. |
PE3(config)#commit | Commit the transaction. |
PE1(config)#hardware-profile filter cfm-domain-name-str enable | Enable the CFM domain name as a character string profile for CFM filtering. |
PE1(config)#ethernet cfm domain-type character-string domain-name evpn1 level 7 mip-creation none | Create a CFM domain for EVPN ELINE with a character string type and set MIP creation to none. |
PE1(config-ether-cfm)#service ma-type string ma-name evp1 | Define a maintenance association (MA) type with the string evp1. |
PE1(config-ether-cfm-ma)#evpn 52 | Configure the MA for EVPN ID 52. |
PE1(config-ether-cfm-ma)#ethernet cfm mep up mpid 20 active true evpn 52 | Create an up-maintenance endpoint (MEP) for local EVPN ID 52. |
PE1(config-ether-cfm-ma-mep)#cc multicast state enable | Enable multicast continuity check (CC) state for the MEP. |
PE1(config-ether-cfm-ma-mep)#cc interval 100 | Set the CC interval to 100 milliseconds. |
PE1(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit Ethernet MA MEP mode. |
PE1(config-ether-cfm-ma)#mep crosscheck mpid 10 | Configure cross-check to the remote MEP. |
PE1(config-ether-cfm-ma)#exit-ether-ma-mode | Exit Ethernet MA mode. |
PE1(config-ether-cfm)#exit | Exit Ethernet CFM mode and return to the configure mode. |
PE1(config)#commit | Commit candidate configuration to be running configuration. |
PE2(config)#hardware-profile filter cfm-domain-name-str enable | Enable the CFM domain name as a character string profile for CFM filtering. |
PE2(config)#ethernet cfm domain-type character-string domain-name evpn1 level 7 mip-creation none | Create a CFM domain for EVPN ELINE with a character string type and set MIP creation to none. |
PE2(config-ether-cfm)#service ma-type string ma-name evp1 | Define a maintenance association (MA) type with the string evp1. |
PE2(config-ether-cfm-ma)#evpn 2 | Configure the MA for EVPN ID 2. |
PE2(config-ether-cfm-ma)#ethernet cfm mep up mpid 10 active true evpn 2 | Create an up-maintenance endpoint (MEP) for local EVPN ID 2. |
PE2(config-ether-cfm-ma-mep)#cc multicast state enable | Enable multicast continuity check (CC) state for the MEP. |
PE2(config-ether-cfm-ma-mep)#cc interval 100 | Set the CC interval to 100 milliseconds. |
PE2(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit Ethernet MA MEP mode. |
PE2(config-ether-cfm-ma)#mep crosscheck mpid 20 | Configure cross-check to the remote MEP. |
PE2(config-ether-cfm-ma)#exit-ether-ma-mode | Exit Ethernet MA mode. |
PE2(config-ether-cfm)#exit | Exit Ethernet CFM mode and return to the configure mode. |
PE2(config)#commit | Commit candidate configuration to be running configuration. |
Acronym | Description |
CFM | Continuity Fault Management |
CCM | Continuity Check Messages |
EVPN | Ethernet Virtual Private Network |
ELINE | Ethernet-LINE |
MPLS | Multi-Protocol Label Switching |
UP | User-to-Provider |
MEP | Maintenance End Point |
MH | MultiHoming |
R-MEP | Remote Maintenance End Point |
MAC | Media Access Control |
AC | Access Circuit |
TLV | Type-Length-Value |
RDI | Remote Defect Indicator |
LB | Loopback |
LBM | Loopback Message |
LTR | Looptrace Reply |
Continuity Fault Management (CFM) | A protocol (802.1ag) that facilitates the monitoring of network connectivity by using Continuity Check Messages (CCM) to detect faults. |
Continuity Check Messages (CCM) | Periodic messages are used in CFM to check the continuity of a network connection. |
Ethernet Virtual Private Network (EVPN) | A technology that enables the extension of Layer 2 Ethernet networks over a Layer 3 infrastructure. |
Multi-Protocol Label Switching (MPLS) | In telecommunications networks, a routing technique is employed to guide data from one node to the next using concise path labels rather than relying on lengthy network addresses. |
User-to-Provider (UP) | Refers to the connection between the user's and service provider's networks. |
Maintenance End Point (MEP) | A point in a network where maintenance operations are initiated or terminated. |
MultiHoming (MH) | A networking architecture that allows a device to be connected to multiple network paths or points of attachment. |
Remote Maintenance End Point (R-MEP) | A maintenance end point located remotely from the originating point. |
Media Access Control (MAC) | A unique identifier assigned to a network interface card. |
Attachment Circuit (AC) | A circuit that connects a customer's equipment to a provider's network. |
Type-Length-Value (TLV) | A format used to encapsulate data in a variety of protocols. |
Remote Defect Indication (RDI) | A signal used to indicate a fault condition in a network link. |
Loopback Message (LBM) | A message used in loopback testing to check connectivity. |