BGP Link-State Advertisement of IGP TE
IGP Traffic Engineering Metric Extensions defined in the IS-IS and OSPF protocols can be collected from networks and shared with external components using BGP. This is achieved using a new BGP Network Layer Reachability Information (NLRI) encoding format.
This chap ter contains configurations for BGP Link state advertisements for IGP TE with OSPF as IGP.
Topology
Figure 7-9 displays a sample BGP LS Advertisement of IGP TE configuration topology.
BGP LS IGP-TE configuration topology
RTR1
RTR1#configure terminal | Enter configure mode. |
RTR1(config)#hardware-profile filter twamp-ipv4 enable | Enabling hardware filter for ipv4 to configure measurement configs |
RTR1(config)#delay-profile interfaces | Enter in to delay profile mode |
RTR1(config-dp-intf)#burst-interval 1000 | Configure burst interval value under delay profile mode |
RTR1(config-dp-intf)#exit | Exit delay profile mode |
RTR1(config)#interface lo | Enter interface mode. |
RTR1(config-if)# ip address 1.1.1.1/32 secondary | Configure IP address on the loopback interface as secondary |
RTR1(config-if)# prefix-sid index 1 | Configure prefix-sid value |
RTR1(config-if)#exit | Exit interface mode. |
RTR1(config)#interface eth1 | Enter interface mode. |
RTR1(config-if)# ip address 23.1.1.1/24 | Configure the IPv6 address of the interface. |
RTR1(config-if)# label-switching | Enable label-switching on interface |
RTR1(config-if)# delay-measurement dynamic twamp reflector-ip 23.1.1.2 | Configuring delay measurement with reflector IP |
RTR1(config)#router ospf 1 | Set the routing process ID as 1 |
RTR1(config-router)#ospf router-id 1.1.1.1 | Configure OSPF router ID |
RTR1(config-router)#network 1.1.1.1/32 area 0.0.0.0 | Configure OSPF network in area 0 |
RTR1(config-router)#network 23.1.1.0/24 area 0.0.0.0 | Configure OSPF network in area 0 |
RTR1(config-router)#segment-routing mpls | Enable segment routing MPLS under OSPF |
RTR1(config-router)#exit | Exit router mode. |
RTR1(config)#twamp-light control | Enter to Twamp-Light control mode |
RTR1(config-twamp-light-ctrl)#control-admin-state enable | Enabling the Twamp-light Control |
RTR2
RTR2#configure terminal | Enter configure mode. |
RTR2(config)#hardware-profile filter twamp-ipv4 enable | Enabling hardware filter for ipv4 to configure measurement configs |
RTR2(config)#delay-profile interfaces | Enter in to delay profile mode |
RTR2(config-dp-intf)#burst-interval 1000 | Configure burst interval value under delay profile mode |
RTR2(config-dp-intf)#exit | Exit delay profile mode |
RTR2(config)#interface lo | Enter interface mode. |
RTR2(config-if)# ip address 2.2.2.2/32 secondary | Configure IP address on the loopback interface as secondary |
RTR2(config-if)# prefix-sid index 2 | Configure prefix-sid value |
RTR2(config-if)#exit | Exit interface mode. |
RTR2(config)#interface eth1 | Enter interface mode. |
RTR2(config-if)# ip address 23.1.1.2/24 | Configure the IPv6 address of the interface. |
RTR2(config-if)# label-switching | Enable label-switching on interface |
RTR2(config)#interface eth2 | Enter interface mode. |
RTR2(config-if)# ip address 50.1.1.1/24 | Configure the IPv6 address of the interface. |
RTR2(config-if)# label-switching | Enable label-switching on interface |
RTR2(config-if)# exit | Exit interface mode |
RTR1(config)#router ospf 1 | Set the routing process ID as 1 |
RTR2(config-router)#network 2.2.2.2/32 area 0.0.0.0 | Configure OSPF network in area 0 |
RTR2(config-router)#network 23.1.1.0/24 area 0.0.0.0 | Configure OSPF network in area 0 |
RTR2(config-router)#distribute bgp-ls | Link State distribution to BGP |
RTR2(config-router)#segment-routing mpls | Enable segment routing MPLS under OSPF |
RTR2(config-router)#exit | Exit router mode |
RTR2(config)# twamp-light reflector | Enter to Twamp-Light reflector mode |
RTR2(config-twamp-light-ref)#reflector-admin-state enable | Enabling the Twamp-light reflector |
RTR2(config-twamp-light-ref)#reflector-name 123 reflector-ip ipv4 23.1.1.2 | Configure reflector IP |
RTR2(config-twamp-light-ref)# exit | Exit reflector mode |
RTR2(config)# router bgp 100 | Configure BGP in AS 100 |
RTR2(config-router)# neighbor 50.1.1.2 remote-as 100 | Configure neighbor in AS 100 |
RTR2(config-router)# address-family link-state link-state | Configure link-state address-family |
RTR2(config-router-af)# neighbor 50.1.1.2 activate | Activate neighbor under link-state add family |
RTR2(config-router-af)# exit-address-family | Exit address family |
RTR3
RTR3#configure terminal | Enter configure mode. |
RTR3(config)#interface lo | Enter interface mode. |
RTR3(config-if)# ip address 3.3.3.3/32 secondary | Configure IP address on the loopback interface as secondary |
RTR3(config-if)# prefix-sid index 3 | Configure prefix-sid value |
RTR3(config-if)#exit | Exit interface mode. |
RTR3(config)#interface eth2 | Enter interface mode. |
RTR3(config-if)# ip address 50.1.1.2/24 | Configure the IPv6 address of the interface. |
RTR3(config-if)# label-switching | Enable label-switching on interface |
RTR3(config-if)# exit | Exit interface mode |
RTR3(config)# router bgp 100 | Configure BGP in AS 100 |
RTR3(config-router)# neighbor 50.1.1.1 remote-as 100 | Configure neighbor in AS 100 |
RTR3(config-router)# address-family link-state link-state | Configure link-state address-family |
RTR3(config-router-af)# neighbor 50.1.1.1 activate | Activate neighbor under link-state add family |
RTR3(config-router-af)# exit-address-family | Exit address family |
Validation
RTR1
RTR1#show twamp-statistics interfaces
Interface Last Advertisement Delay(us) Min(us) Max(us) Var(us) Loss(%)
eth1 2022-01-24 16:33:44 2 1 2 0 Not Enabled
RTR1#show twamp-statistics interfaces eth1
Interface name : eth1
Sender IP : 23.1.1.1
Reflector IP : 23.1.1.2
Reflector port : 862
DSCP value : 0
Last Advertised stats:
Time: 2022-01-24 16:33:44
Average delay : 2
Minimum delay : 1
Maximum delay : 2
Average delay variation: 0
Minimum delay variation: 0
Maximum delay variation: 0
Packets sent : 300
Packets received : 300
Packets timeout : 0
Packet Loss: Not Enabled
Last Calculated stats:
Time: 2022-01-24 16:38:45
Average delay : 2
Minimum delay : 1
Maximum delay : 2
Average delay variation: 0
Minimum delay variation: 0
Maximum delay variation: 0
Packets sent : 300
Packets received : 300
Packets timeout : 0
Packet Loss : Not Enabled
RTR1#show ip ospf database opaque-area
OSPF Router with ID (1.1.1.1) (Process ID 1 VRF default)
Area-Local Opaque-LSA (Area 0.0.0.0)
LS age: 1649
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 1.1.1.1
LS Seq Number: 80000009
Checksum: 0x20fe
Length: 28
MPLS TE router ID : 1.1.1.1
Number of Links : 0
LS age: 1209
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 2.2.2.2
LS Seq Number: 80000004
Checksum: 0x2eed
Length: 28
MPLS TE router ID : 2.2.2.2
Number of Links : 0
LS age: 363
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.16 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 16
Advertising Router: 1.1.1.1
LS Seq Number: 800000d2
Checksum: 0x8931
Length: 136
Link connected to Broadcast network
Link ID : 23.1.1.2
Interface Address : 23.1.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
Link Delay : 2 us, Anomalous : 0
Link Min/Max Delay : 1/2 us, Anomalous : 0
Link Delay Variation: 0 us
Number of Links : 1
LS age: 1189
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.16 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 16
Advertising Router: 2.2.2.2
LS Seq Number: 80000004
Checksum: 0x4ed7
Length: 108
Link connected to Broadcast network
Link ID : 23.1.1.2
Interface Address : 23.1.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
Number of Links : 1
LS age: 839
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 1.1.1.1
LS Seq Number: 80000005
Checksum: 0xedeb
Length: 44
Range Size: 8000
Base-SID: 16000
Algorithm0: 0
LS age: 1159
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 2.2.2.2
LS Seq Number: 80000005
Checksum: 0xcf06
Length: 44
Range Size: 8000
Base-SID: 16000
Algorithm0: 0
LS age: 1319
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 1.1.1.1
LS Seq Number: 80000005
Checksum: 0xc9c7
Length: 44
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 1.1.1.1
Flags: 0x00 (-|-|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 1
LS age: 1109
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 2.2.2.2
LS Seq Number: 80000006
Checksum: 0xf591
Length: 44
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 2.2.2.2
Flags: 0x00 (-|-|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 2
LS age: 1579
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 1.1.1.1
LS Seq Number: 80000006
Checksum: 0x704a
Length: 48
Link Type: 2
Link ID: 23.1.1.2
Link Data: 23.1.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24320
LS age: 1699
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 2.2.2.2
LS Seq Number: 80000005
Checksum: 0xb36f
Length: 52
Link Type: 2
Link ID: 23.1.1.2
Link Data: 23.1.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 1.1.1.1
SID: 24960
RTR3
RTR3#show bgp link-state link-state
BGP router identifier 50.1.1.2, local AS number 100
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
i [V][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r1.1.1.1]]/216
i [V][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2]]/216
i [V][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2d23.1.1.2]]/248
i [E][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r1.1.1.1][R[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2d23.1.1.2]][L[i23.1.1.1][n23.1.1.2]]/376
i [E][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2][R[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2d23.1.1.2]][L[i23.1.1.2][n23.1.1.2]]/376
i [E][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2d23.1.1.2][R[c100][b23.1.1.2][a0.0.0.0][r1.1.1.1]][L[i23.1.1.2][n23.1.1.1]]/376
i [E][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2d23.1.1.2][R[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2]][L[i23.1.1.2][n23.1.1.2]]/376
i [T][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r1.1.1.1]][P[0x1][p1.1.1.1/32]]/264
i [T][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2]][P[0x1][p2.2.2.2/32]]/264
NLRIs, Total: 9, Node: 3, Link: 4, Prefix: 2
RTR3#show bgp link-state link-state [E][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r1.1.1.1][R[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2d23.1.1.2]][L[i23.1.1.1][n23.1.1.2]]/376
BGP routing table entry for [E][O][I0x1][N[c100][b23.1.1.2][a0.0.0.0][r1.1.1.1][R[c100][b23.1.1.2][a0.0.0.0][r2.2.2.2d23.1.1.2]][L[i23.1.1.1][n23.1.1.2]]/376
Local
Received from 23.1.1.2
Link State:
Local Router ID: 1.1.1.1, Remote Router ID: 2.2.2.2
Max link bw(kbits/sec): 10000000.00 ,Max reservable link bw(kbits/sec): 10000000.00
Max unreserved link bw(kbits/sec):10000000.00 10000000.00 10000000.00 10000000.00 10000000.00 10000000.00 10000000.00 10000000.00
TE metric 1 , IGP metric 1
SR Flags: B:0 V:1 L:1 G:0 P:0
Adjacency SID: 24320 Link Delay : 2 us Anomalous : 0
Link Min/Max Delay : 1/2 us, Anomalous : 0
Link Delay-variation : 0 us
Local TE Router-ID:1.1.1.1